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Introduction 

The phenomenon of induction heating is important in engineering applications such as 

induction cooking, induction heat treating (surface hardening, annealing, etc.), induction 

mass heating (bar and billet heating, etc.) and numerous other applications. The induction 

heating process often involves a complex interaction between the electromagnetic and 

thermal fields; thus, numerical modeling is an essential tool for optimizing designs. 

 

In this workshop, we will analyze the problem of inductively heating a cylindrical 

metallic rod using an encircling coil winding with a rectangular cross-section (the 

geometry is shown in Figure W1–1). We will use the co-simulation feature in Abaqus to 

couple time-harmonic electromagnetic analysis to a time transient heat transfer analysis. 

The co-simulation engine automatically maps the Joule heat generated by the induced 

eddy currents in the rod as a concentrated heat flux load for the heat transfer analysis. 

 

 

Figure W1–1 Problem geometry 
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Model 

Geometry: The Abaqus model represents one-eighth of the problem domain and is 

shown in Figure W1–2. Reduction of the problem domain in the presence of symmetries 

reduces both the memory requirements and computation times. The diameter of the 

conducting cylindrical rod is 0.1 m and its length is 0.5 m. The inner and outer diameters 

of the coil winding are 0.18 m and 0.22 m, respectively.  The coil winding has a cross-

sectional area of 0.02 m × 0.02 m. The outer boundaries of the domain are located far 

enough away from the coil winding that they do not significantly affect the physics of the 

problem. The outer cylindrical and planar surfaces are placed 0.5 m away (5 times the 

mean radius of the coil winding) from the center of the domain. For the subsequent heat 

transfer analysis only the geometry of the rod is modeled. 

Material Properties: The material properties of the rod are chosen such that they 

represent a typical good conductor like copper. The electrical conductivity of the rod is 

chosen to be 1×10
7
 S/m and its magnetic permeability is chosen to be equal to the 

vacuum permeability (0 = 4×10
7

 H/m). Aside from the rod, the rest of the domain is 

modeled as vacuum/air. For the subsequent heat transfer analysis, the rod is assumed to 

have a thermal conductivity of 400 W/m-K, a specific heat of 400 J/kg-K and a density of 

9000 kg/m
3
. 

 

 

 
Figure W1–2 Model 

 

Mesh: For the eddy current analysis, the model consists of approximately 24K 

hexahedral electromagnetic elements (EMC3D8). To resolve the skin depth, about 5 

elements are used within the first skin depth from the surface of the rod. Single bias edge 

seeding is used away from the coil to reduce the total number of elements. For the 

subsequent heat transfer analysis, the model consists of approximately 5K hexahedral 
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diffusive heat transfer elements (DC3D8). Both the meshes are assumed to be adequately 

refined to yield a good solution to the problem. 

Boundary Conditions: For the eddy current analysis, appropriate symmetry boundary 

conditions (either homogeneous Dirichlet or homogeneous Neumann) are applied on the 

symmetry planes. Homogeneous Dirichlet boundary conditions are applied on the outer 

surfaces. The total current flowing across the cross-sectional area of the coil winding is 

assumed to be 25
 
kA-turns. The large value of current is chosen for illustration purposes 

only and it may be 1-2 orders of magnitude larger than a typical value in an induction 

heating problem. The equivalent current density is 2.5×10
4
/0.02

2
 = 6.25×10

7
 A/m

2
. For 

the heat transfer analysis, homogeneous Neumann boundary conditions (zero heat flux 

normal to the surface) are applied on all surfaces (including symmetry surfaces). 

Analysis Procedure: A steady-state low frequency eddy current analysis procedure is 

used to compute the Joule heat generated in the conducting rod. The frequency of the 

current is assumed to be 50 Hz. Using the Abaqus co-simulation feature, the eddy current 

analysis is coupled to a transient heat transfer analysis to compute the temperature 

evolution over 120 s. 

Preliminaries: 

1. Enter the working directory for this workshop: 

../emag/rod  

2. Run the script ws_emag_rod.py using the following command:  

abaqus cae startup=ws_emag_rod.py 

The above command creates an Abaqus/CAE database named rod.cae in the 

current directory. The database contains a model named rod_emag for 

performing the electromagnetic analysis and one named rod_heat for performing 

the heat transfer analysis. The electromagnetic model contains only the geometry 

of the problem while the heat transfer model is nearly complete. 

3. In this workshop, you will complete the models, submit the jobs and review the 

results in Abaqus/CAE. 
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Part 1 

Prepare the electromagnetic model in Abaqus/CAE 

Begin by defining a portion of the electromagnetic model using Abaqus/CAE. 

1. Make current the model named rod_emag. 

2. Currently the vacuum/air, cylinder, and coil are modeled as individual parts. Since 

tie constraints cannot currently be used to attach the parts to each other, the parts 

will be merged instead. Thus, you will first merge all the parts into a single part. 

a. Switch to the Assembly module. 

b. Select a predefined view: in the Views toolbar, select . 

c. In the toolbox, select the Merge/Cut Instances tool . 

d. In the Merge/Cut Instances dialog box that appears: 

i. Specify domain as the part name. 

ii. Select Geometry as the entity to be merged. 

iii. Select the option to Suppress the original instances. 

iv. Select the option to Retain the intersecting boundaries. 

v. Click Continue. 

e. In the viewport, select all instances and click Done in the prompt area. 

f. A new part named domain and an instance named domain-1 are now 

created. Make sure all other instances in the assembly are suppressed. 

 

 

 
 

Figure W1–3 Set definitions 
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3. Define sets. 

a. In the Model Tree, expand the Parts container and double-click the part 

named domain. 

b. Select a predefined view: in the Views toolbar, select . 

c. Select the geometry. 

i. In the Display Group toolbar, click  to replace the viewport 

contents. 

ii. In the prompt area, select the Cells as the entity type to be 

replaced. 

iii. In the viewport, select the geometry corresponding to the 

cylindrical rod and click Done in the prompt area. 

d. Define the set. 

i. In the Model Tree, expand the Parts container. Expand the 

container for the part named domain. 

ii. Double-click Sets. 

iii. In the Create Set dialog box that appears, enter rod as the name 

for the set and click Continue. 

iv. In the viewport, select the geometry and click Done in the prompt 

area. 

e. Repeat the steps (c) and (d) to create sets for the coil and the surrounding 

area and name them coil and air, respectively (see Figure W1–3). 

Tip: Click  to restore the visibility of the entire part and then click  

to view only the desired cell. 

 

 

 
 

Figure W1–4 Surface definitions 
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4. Define surfaces. 

a. In the Display Group toolbar, click  to restore the visibility of the 

entire part. 

b. In the Model Tree, expand the Parts container. Expand the container for 

the part named domain. 

c. Double-click Surfaces. 

d. In the Create Surface dialog box, enter xzer as the name for the surface 

and click Continue. 

e. In the prompt area, select by angle as the selection option. 

f. In the viewport, select the faces on the symmetry plane X = 0 (surface 

xzer in Figure W1–4) and click Done. 

g. Similarly, create surfaces for the symmetry planes Y = 0 and Z = 0 

(surfaces yzer and zzer in Figure W1–4) and name them yzer and zzer, 

respectively.  

h. Create a surface for the remaining outer boundaries and name it outer. 

i. Select a predefined view: in the Views toolbar, select . 

5. Define material properties. 

a. In the Model Tree, double-click Materials. 

b. In the material editor: 

i. Enter conductor as the name for the material. 

ii. In the Material Behaviors region, select  

Electrical/Magnetic→Magnetic Permeability. 

iii. In the Data group box, enter a value of 4*pi/1e7 H/m for the 

permeability. 

iv. In the Material Behaviors region, select  

Electrical/Magnetic→Electrical Conductivity. 

v. In the Data group box, enter a value of 1e7 S/m for the 

conductivity and click OK. 

c. Create another material named air with a magnetic permeability of 

4*pi/1e7 H/m and an electrical conductivity of 1000 S/m. The 

specification of electric conductivity value will regularize the problem for 

the solver. The chosen value of conductivity is on the larger side of its 

recommended values but still produces correct results for this problem. 

6. Define and assign section properties. 

a. In the Model Tree, double-click Sections. 

b. In the Create Section dialog box, enter conductor as the name and 

select Solid as the category and Electromagnetic, Solid as the type. 

Click Continue. 

c. In the section editor, select conductor as the material and click OK. 

d. Create another section named air and assign air as its material. 
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e. Assign sections. 

i. In the Model Tree, expand the Parts container. Expand the 

container for the part named domain. 

ii. Double-click Section Assignments. 

iii. In the prompt area, click Sets.  

iv. In the Region Selection dialog box that appears, choose rod and 

toggle on Highlight selections in viewport to identify the region. 

Click Continue. 

v. In the Edit Section Assignment dialog box, select conductor as 

the section and click OK. 

vi. Similarly, assign the section named air to the sets named coil and 

air. 

 

Upon completion of this task, all regions of the part should be 

colored green, indicating that section properties have been 

assigned to them. 

 

 
Figure W1–5 Surface used for partitioning air region 

 

7. Partition the domain so that a sweep mesh can be generated. 

a. Switch to the Mesh module. 

b. Display only the set named air. 

i. In the Display Group toolbar, select the Create Display Group  

tool . 

ii. In the Create Display Group dialog box: 

1. Select Sets as the item and then choose the set named air. 
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2. Toggle-on Highlight items in the viewport to review the 

selection and click Replace. 

3. Click Dismiss. 

 

 

c. Partition the selected region. 

i. In the toolbox, select the Partition Cell: Extend Face  

tool . 

ii. In the viewport, select the displayed region and click Done in the 

prompt area. 

iii. In the viewport, select the surface that corresponds to the 

cylindrical surface of the rod as shown in Figure W1–5 and click 

Create Partition in the prompt area. 

iv. In the prompt area, click Done. 

 

 
Figure W1–6 Edges with different seed values. 

 
 

 Bias Min Size Max Size 

Seed–1 None 0.005 - 

Seed–2 None 0.05 - 

Seed–3 Single 0.005 0.05 

 
Table W1–1 Values of the edge seeds. 

 

8. Generate a sweep mesh. 

a. In the Display Group toolbar, click  to restore the visibility of the 

entire part. 

Seed–1 

Seed–2

 

 

Seed 1 

Seed–3 
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b. Assign sweep mesh controls. 

i. From the main menu bar, select Mesh→Controls. 

ii. In the viewport, select all displayed regions and click Done in the 

prompt area. 

iii. In the Mesh Controls dialog box, select Hex as the element shape, 

Sweep as the technique, and click OK. 

c. Seed the various edges as indicated in Figure W1–6 and Table W1–1. 

i. Define the mesh size for the edges of Seed–1. 

1. From the main menu bar, select Seed→Edges. 

2. In the prompt area, make the selection that the edges will 

be individually selected in the viewport. 

3. In the viewport, select the edges shown in Figure W1–6 for 

Seed–1 and click Done the prompt area. 

4. In the Local Seeds dialog box, set the bias to None. 

5. In the Local Seeds dialog box, set the Approximate 

element size to 0.005 and click OK. 

ii. Similarly, define the mesh size for the edges of Seed–2. 

iii. Define the mesh size for edges of Seed–3. 

1. From the main menu bar, select Seed→Edges. 

2. In the viewport, select the edges shown in Figure W1–6 for 

Seed–3 and click Done the prompt area. 

3. In the Local Seeds dialog box: 

a. Set the bias to Single. 

b. If required, click Flip to ensure that the direction of 

bias points radially inward. 

4. Set the Minimum size to 0.005 and the Maximum size to 

0.05 and click OK. 

d. Generate the mesh. 

i. From the main menu bar, select Mesh→Part. 

ii. In the prompt area, click Yes to mesh the part. 

9. Save your model. 

a. From the main menu bar, select File→Save. 

You have now successfully created a partial model of the electromagnetic analysis. In 

Part 2 of this workshop you will complete the model. 

 

 S T O P! 

 

Continue with the remainder of this workshop after the 
completion of Lecture 4.  
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Part 2 

In this part of the workshop, you will complete electromagnetic and heat transfer models, 

run the electromagnetic analysis, transfer the resulting output to a subsequent heat 

transfer analysis, and finally run the heat transfer analysis. 

Complete the electromagnetic model in Abaqus/CAE 

1. Define a step for the time-harmonic low frequency electromagnetic analysis 

procedure. 

a. In the Model Tree, double-click Steps. 

b. In the step editor: 

i. Select Electromagnetic, time harmonic as the procedure type 

and click Continue. 

ii. In the Data group box, enter a value of 50 Hz for the lower 

frequency and click OK. 

 

2. Define loads. 

a. Create a cylindrical coordinate system 

i. From the main menu bar, select Tools → Datum. 

ii. In the Create Datum dialog box, select CSYS as the type and 3 

points as the method. 

iii. In the Create Datum CSYS dialog box, name the coordinate 

system cyl, select Cylindrical as the type and click Continue. 

iv. In the prompt area, enter 0,0,0 as the coordinates of the origin, 

1,0,0 as the coordinates of a point on the R-axis, and 0,1,0 as 

the coordinates of a point on the R-Theta plane. 

v. Click Cancel to close the Create Datum CSYS dialog box. 

b. Define body current density load. 

i. In the Model Tree, double-click Loads. 

ii. In the Create Load dialog box: 

1. Name the load current.  

2. Select Electrical/Magnetic as the category. 

3. Select Body current density as the type and click 

Continue. 

iii. Select the set domain-1.coil. 

iv. In the Edit Load dialog box: 

1. Click the arrow next to CSYS: (Global). 

2. In the prompt area click Datum CSYS List. 

3. Select cyl and click OK in the dialog box. 

4. Define the real part of Component 2 to be 6.25e+07 

A/m
2
 and click OK. 

 

3. Define boundary conditions. 
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a. Define homogeneous Dirichlet boundary conditions on symmetry planes 

xzer and yzer, and on outer boundary surface outer. 

i. In the Model Tree, double-click BCs. 

ii. In the Create Boundary Condition dialog box: 

1. Name the boundary condition xsymm. 

2. Select Step-1 as the step. 

3. Select Electrical/Magnetic as the category. 

4. Select Magnetic vector potential as the type and click 

Continue. 

iii. In the prompt area, click Surfaces. 

iv. In the Region Selection dialog box, select the surface domain-

1.xzer and click Continue. 

v. In the Edit Boundary Condition dialog box accept the defaults 

and click OK. 

vi. Repeat the previous steps for surfaces domain-1.yzer and 

domain-1.outer. Name the boundary conditions ysymm and 

outer, respectively. 

b. Homogeneous Neumann boundary conditions are assumed by default. 

Hence, boundary condition need not be explicitly specified on the surface 

domain-1.zzer. 

 

4. Define output requests. 

a. Define field output requests for the whole model. 

i. In the Model Tree, double-click Field Output Requests. 

ii. In the Create Field dialog box, click Continue. 

iii. In the Field Output Request dialog box, request EMB, EMH, 

EME output under the Electrical/Magnetic section and click OK. 

b. Define field output requests for the conductor. 

i. In the Model Tree, double-click Field Output Requests. 

ii. In the Create Field dialog box, click Continue. 

iii. In the Field Output Request dialog box 

1. Select Set as the Domain and select the set domain-1.rod. 

2. Request EMJH output under the Energy section and 

EMCD, EMBF output under the Electrical/Magnetic 

section and click OK. 

c. History output requests are not necessary for this model. 

 

5. Specify co-simulation details. 

a. From the main menu bar, select Model→Edit Keywords→rod_emag. 

b. In the keyword editor, add the following data before *End Step: 
*Co-Simulation, program=multiphysics, name=cosim 

*Co-Simulation Region, type=volume, export 

domain-1.rod, EMJH 

*Co-Simulation Region, type=volume, import 

domain-1.rod, TEMP 
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6. Generate the input file. 

a. In the Model Tree, expand the Analysis container. 

b. Double-click Jobs.   

c. In the Create Job dialog box, select the model rod_emag, name the job 

rod_emag and click Continue. 

d. In the job editor, enter the following description: Induction heating 

of a cylindrical rod: eddy-current analysis and click OK. 

e. In the Model Tree, click mouse button 3 on the job named rod_emag and 

select Write Input from the menu that appears. 

f. Ignore the warning about the missing history output requests. 

 

Complete the heat transfer model in Abaqus/CAE 

1. Make current the model named rod_heat. 

2. Specify co-simulation details. 

a. From the main menu bar, select Model→Edit Keywords→rod_heat. 

b. In the keyword editor, add the following data before *End Step: 
*Co-Simulation, program=multiphysics, name=cosim 

*Co-Simulation Region, type=volume, import 

rod-1.rod, CFLUX 

*Co-Simulation Region, type=volume, export 

rod-1.rod, NT 
3. Generate the input file. 

a. From the Job module write the input file rod_heat.inp. 

i. In the Model Tree, expand the Analysis container and then the 

Jobs container. 

ii. Click mouse button 3 on the job named rod_heat. 

iii. From the menu that appears, select Write Input. 

 

Running the co-simulaton analysis 

1. Define the configuration file. 

a. Fetch the example template exa_em_std_export.xml for one way 

force coupling and rename it rod_config.xml. 

abaqus fetch -job rod_config –inp exa_em_std_export 

b. Open the configuration file in an editor and specify the values rod_emag, 

rod_heat and 120 for the EM_Job, Structural_Job and duration 

fields, respectively. 

2. Run the co-simulation analysis. 

abaqus cosimulation -j rod_emag,rod_heat -cosimjob 

cosim -config rod_config.xml 
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Monitoring the analysis 

While a job is running, you can monitor its progress by watching the output written to the 

data (.dat), message (.msg), status (.sta) and log (.log) files. A co-simulation job 

generates an additional log file that shows the status of the co-simulation and any errors 

that occur during the co-simulation setup and run. 

 

Note the possible presence of numerical singularity warnings in an electromagnetic 

analysis log file. These are due to the fact that the left-hand side of the matrix resulting 

from the finite element variational formulation is singular. Specifying a stabilization 

value or a small conductivity in the non-conducting regions (as was done here) 

regularizes the problem but there is no guarantee that all such warnings will be removed. 

In the presence of singularity warnings the electric field, Joule heat and Lorentz force 

outputs are not reliable in the non-conducting regions. These outputs in the conducting 

regions will be correct. 

Viewing the results 

Once the job completes, do the following. 

1. Open the electromagnetic analysis output database file in the Visualization 

module. 

a. From the main menu bar, select File→Open. 

b. In the Open Database dialog box that appears: 

i. Select Output Database (*.odb*) as the file filter. 

ii. Select the file rod_emag.odb and click OK. 

 

2. Create symbol plots of the magnetic field and induced current density in the rod. 

a. Display only the elements corresponding to cylindrical rod: 

i. In the Display Group toolbar, select the, select the Create 

Display Group tool . 

ii. In the Create Display Group dialog box: 

1. Select Elements as the item. 

2. Select Element Sets as the method. 

3. Select the element set DOMAIN-1.ROD. 

4. Toggle on Highlight items in viewport to review the 

selection and click Replace followed by Dismiss. 

b. In the View Manipulation toolbar, click the Auto-Fit View tool . 

c. In the Render Style toolbar, click the Render Model: Wireframe tool 

. 

d. In the toolbox, click the Plot Symbols on Deformed Shape  

tool . 

e. In the Field Output toolbar, select EMB as the symbol variable and 

RESULTANT in the combo box next to it. 

f. Similarly, select EMCD as the symbol variable and RESULTANT in the 

combo box next to it. 
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g. Show only the free edges. 

i. In the toolbox, select the Common Options tool . 

ii. In the Common Plot Options dialog box, under the Basic tab, 

select Free edges as the visible edges and click OK. 

h. Reduce the length of the arrows in the symbol plot. 

i. In the toolbox, select the Symbol Options tool . 

ii. In the Symbol Plot Options dialog box, switch to the Color & 

Style tabbed page and select the Vector tab. In the Size region, set 

the value to 3. 

The plot appears as shown in Figure W1–7. 

 

                   
 

Figure W1–7 Symbol plots of the real part of magnetic field (left) and the real part 
of induced current density (right). 

 

We see from the plots that both the magnetic field and the induced current density 

are large closer to the coil (top) and their magnitude falls off away from the coil. 

 

3. Create contour plots of Joule heat. 

a. In the toolbox, select the Plot Contours on Deformed Shape  

tool . 

b. In the Field Output toolbar, select EMJH as the primary variable. 
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c. Optionally, you can use the results representing the repetitive portion of a 

model to visualize those for the entire (360°) model using the 

Mirror/Pattern model display options. 

i. From the main menu bar, select View→ODB Display Options. 

ii. In the ODB Display Options dialog box: 

1. Select the Mirror/Pattern tab. 

2. In the Mirror field, toggle on the XY mirror plane. 

3. In the Circular field, choose Z as the axis of rotation, 

specify a value of 4 as the number of sectors displayed, and 

enter 360 for the total angle.  

4. Click OK to apply your changes. 

The plot appears as shown in Figure W1–8. 

 

                             
 

Figure W1–8 Contour plots of Joule heat 
 

We see from Figure W1–8 (left) that inside region of the rod receives less Joule 

heat compared to the outer surface. From Figure W1–8 (right), we see that larger 

Joule heat is generated at the center of the rod compared to its ends. Both of these 

observations can be explained by the proximity of these regions to the current 

coil. 

 

4. Open the heat transfer analysis output database file in the Visualization module. 

a. From the main menu bar, select File→Open. 

b. In the Open Database dialog box that appears: 

i. Select Output Database (*.odb*) as the file filter. 

ii. Select the file rod_heat.odb and click OK. 

5. Create contour plots of temperature. 

a. In the toolbox, select the Plot Contours on Deformed Shape  

tool . 

b. In the Field Output toolbar, select NT11 as the primary variable. 

The plot appears as shown in Figure W1–9. 
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Figure W1–9 Contour plots of temperature at t = 1s (left) and t = 120s (right) 
 

We see from Figure W1–9 that heat generated at the center of the rod is gradually 

distributed throughout the rod as time progresses. The maximum temperature 

increase over two minutes is about 20° C. 

 

 

 

Note:  A script that creates the complete models described in these 
instructions is available for your convenience.  Run this script if you 
encounter difficulties following the instructions outlined here or if you wish 
to check your work.  The script is named 

 

ws_emag_rod_answer.py 

 

and is available using the Abaqus fetch utility.  


