NX - Understanding and Utilizing the Examine Geometry Function

There are cases when running NX where you may encounter strange behavior in the software: a Mass
Property does not look right, a Boolean operation will not complete; or editing a feature causes error
messages to occur.

NX provides the Examine Geometry tool to assist in diagnosing and finding problem areas in your
parts. Understanding what this tool accomplishes, and also how to use the tool to find problems in part

files, will help you build better models by identifying and correcting problems earlier in the design cycle.
What the Tool does

The Examine Geometry tool analyzes sheet and solid bodies, faces, edges and curves where
conditions can range from the detection of corrupt data structures to warnings concerning the geometric
form of faces and edges. The system cannot automatically correct such conditions, but it highlights
them, giving you the opportunity to fix them.

Solid Body Types

The body being analyzed can either be an unparameterized — a ‘dumb’ solid -- or it can be a
parameterized solid. The methods used to repair each type of model differ depending on the type of
solid body. Unparameterized bodies will require reconstruction of the areas indicating errors.
Parametric bodies can normally be repaired by using Edit => Feature and adjusting the method and/or
tolerances used during creation of the noted features.

Accessing the Tool

To access the tool, choose Analysis => Examine Geometry. At this point, the Examine Geometry
dialog window appears (NX4 dialog shown):
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Using the Tool

Select the button Set all Checks. This will interrogate the model in the most complete manner
available. Note that the Threshold Tolerance Values default to the current Modeling Tolerances.

Select the OK button and the Class Selection Toolbar appears.

Specific objects can be selected, but for a complete analysis you should select all objects, either from
the Class Selection Toolbar or by Windowing the part file on the screen.



Select OK or MB2 to execute the analysis.

When the analysis operation completes, the Highlight Results dialog will appear, along with an
information window reporting the results.

The following Highlight Results dialog and the Information window are from running the Examine
Geometry analysis on a sample part file:
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The Highlight Results dialog will show items requiring attention with a white checkbox. Items that
passed the analysis will be grayed out.

Notice the i icon on the Highlight Results dialog. This allows access to the information window
without re-running the analysis. If you close the Information window, it can be redisplayed by select the
iicon. The data in the Information window can be saved to a text file if desired by using the File =>
Save As function from the Information window menu.

Utilizing the Results

Now that the analysis is complete and the information window has been reviewed, you can begin using
the Highlight Results dialog to identify problem areas of the part. To enhance visibility of the problem
areas of the model use this tool with the model in Wireframe display mode.

Here is what the Highlight Results dialog indicates for Spikes/Cuts in this sample part: NOTE the areas
highlighted in red. These are the areas where Spikes/Cuts were found in this sample model.
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At this point, it is necessary to understand what each check is verifying so that the user knows what
needs to be done to repair the model.

Here are excerpts from the NX4 Help Documentation regarding the Examine Geometry Checks.

The author's comments regarding each check follow each excerpt.

“On selecting a test option from the Highlight Results dialog, and choosing OK, the geometry in
the graphics window corresponding to the test is highlighted. The highlighted objects are easily
visible: curves, solid faces and bodies have a temporary box drawn around them with asterisks
at each corner; solid edges are highlighted with temporary asterisks at each vertex (continuous
or circular edges have one asterisk).”

“With the aid of these highlights, you can locate and zoom in on an area to examine it closely.
The highlighting persists, even if you go to another function to edit the geometry. You can erase
the highlighting with a Refresh or a Fit.”

It is important to note that many of the errors listed below are dependent upon the Tolerance Values
used to run the analysis. Using the loosest distance tolerance your manufacturing operation can
support, as well as a loose angular tolerance will result in fewer errors reported.

Also, many parts are created using features created with different tolerance values, for instance a block
created with a tolerance of 0.001 and a trimming sheet body created with a tolerance of 0.005. This
type of mixed tolerance modeling will frequently report errors in the Examine Geometry Tool.

Objects
Tiny
This function searches for all tiny bodies, faces, edges or curves in:

e curves, edges and bodies for which the diagonal length of a box enclosing the object is
less than the specified distance tolerance

e faces whose surface area is less than the specified distance tolerance, squared

o faces whose area to perimeter ratio is such that 2 times the area, divided by the
perimeter is less than the specified distance tolerance (this detects sliver faces)



The number of incidences of tiny geometry is reported in the Information window. To highlight
the tiny objects in the graphics window, click the Tiny option on the Highlight Results dialog.

Tiny objects are not necessarily a problem. These can cause problems in downstream applications
such as CAM, especially when the tiny object is a face. They do deserve a close look by the user to
verify the condition causing the tiny object.

Misaligned

This function checks all of the selected geometry that is close to being orthogonal with respect to
the WCS, but is not exactly aligned with it. To check an ortho alignment with respect to some
other coordinate system, change the WCS from the main menu bar. The test is made on lines,
circles, planes, cylinders, cones, tori, swept and swung surfaces. For each object, a vector is
obtained as follows:

e lines - a vector in the direction of the line

e arcs and circles - a vector normal to the plane of the curve

e planes - the normal vector

e cylinders, cones, tori, surfaces of revolution - the axis vector
e extruded surfaces - the extrusion vector

Objects for which the vector is almost, but not exactly, parallel to XC, YC or ZC are flagged as
misaligned.

The number of incidences of misaligned geometry is reported in the Information window. To
highlight the misaligned geometry in the graphics window, click the Mis-aligned option on the
Highlight Results dialog.

Again, misaligned objects are not necessarily a problem. This check is useful if the model is supposed
to be orthogonal. This check is an advisory tool.

Bodies
Data Structures

This function checks each selected body for data structure problems, such as corruption. The
results are reported in the Information window. To highlight the invalid bodies in the graphics
window, click the Data Structures option on the Highlight Results dialog.

Any Data Structure error is cause for concern. The offending entities should be deleted and
reconstructed.

Consistency
If you select this option, NX checks each selected body for inconsistencies.
This option will check:
o that the topological structure is consistent

o that the geometrical objects are valid and that faces and edges have G1 continuous
geometry

o that the geometrical objects are consistent; that is, the point geometry of vertices lies
on the edges and faces to which they are linked; that edge geometry lies in the faces to
which they are linked, and that edges intersect only at vertices

The results are reported in the Information window. Certain objects with inconsistencies are
highlighted in the graphics window if requested from the Highlight Results dialog.

This is another error that should cause concern. This condition is a frequent cause of Boolean errors,
mass/density errors and failure of some functions to operate correctly. A File => Utilities => Part
Cleanup operation is appropriate when receiving this type of error. Also appropriate is an Edit =>
Feature => Playback operation. This will usually show at what point a failure occurs, giving the user a



place to start investigating. These errors are probably the most difficult to isolate. When used in
conjunction with repair of other errors reported, the part file can often be successfully repaired.

Face-Face Intersections

This function checks each selected body for face-to-face intersections, and that all faces of the
selected body meet each other at their edges and nowhere else.

It is possible to inadvertently create face-face inconsistencies during modeling. For example,
suppose you hollowed a cube to a thickness of Tmm, and then blended one of the outer edges
to a radius of 5mm. The inner shell then intersects the outer shell, and the model is invalid.

Face-face inconsistencies can often be remedied by further modeling operations. In the above
example, the model can be made valid by blending the inner edge.

The results of this test are reported in the Information window. Faces that intersect incorrectly
are highlighted in the graphics window if requested from the Highlight Results dialog.

Anytime this error is reported, it should be investigated. This message will often be coincident with a
‘Spikes/Cuts’ error message. These errors should be repaired. Deleting the offending faces and
recreating them will often repair this error. Close examination of the model is necessary for a visual
verification of the error.

Sheet Boundaries

This function searches for all of the boundaries (or gaps) in the selected bodies. The number
of sheet boundaries is reported in the Information window. The edge of each boundary is
highlighted with an asterisk at each vertex, when requested from the Highlight Results dialog.

The number of sheet boundaries should be the same as the number of sheet bodies selected. For solid
bodies this is a relatively rare error which needs to be fixed. In conjunction with the ‘Spikes /Cuts’ error
message, these errors can be repaired by deleting and remodeling the offending feature.

Faces

Smoothness

For faces whose surfaces are b-surfaces, Smoothness checks the b-surfaces to make sure the
surfaces are smooth along their patch boundaries.

The results of the check are reported in the Information window. Any rough face is highlighted
when requested from the Highlight Results dialog.

This error only applies to b-surface faces. It generally appears when tolerance values used to create
features vary within the model. This error is not necessarily a flaw in the model, but an observation by
the Examine Geometry function.

Self-intersection

This function performs a check for faces that self-intersect. The results of the check are
reported in the Information window. Any self-intersecting face found is highlighted when
requested from the Highlight Results dialog.

Receiving this error indicates an issue that should be repaired. It frequently occurs in conjunction with
‘Consistency’ errors. Deleting and remodeling the offending feature is usually required.

Spikes/Cuts

This function searches the selected faces for possible spikes or cuts. It does this by checking
the angle between adjoining edges. When the angle is very small, the system checks several
points along the shorter edge; if the distance between all of those points and the longer edge is
less than the specified Distance Tolerance, that face is determined to have a possible spike or
cut.

The number of such faces is reported in the Information window. Each face found to contain a
possible spike or cut is highlighted when requested from the Highlight Results dialog.
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These errors should always be repaired. As seen in the examples shown above, faulty output will result
in erroneous Mass Property calculations. This is also a frequent cause of Boolean failures.

Edges
Smoothness

This function searches for all edges whose adjoining faces do not join smoothly. The numbers
of unsmooth edges are reported in the Information window. Each unsmooth edge is highlighted
when requested from the Highlight Results dialog.

Most bodies have at least a few ‘sharp’ edges, where faces intersect at near 90 degree angles. This
tool is generally intended to check edges that are supposed to be ‘tangent’.

Tolerances

This function checks the tolerance of all of the selected edges against the value specified in the
Distance tolerance field. The maximum edge tolerance found and the number of edges whose
tolerance exceeds the specified tolerance is reported in the Information window. All edges with
tolerance greater than the specified tolerances are highlighted when requested from the
Highlight Results dialog.

All Checks
Set all checks selects all tests for the analysis and Clear All Checks de-selects all the tests.
Threshold Tolerance Values

The Modeling Preferences dialog values are accessed by selecting Preferences => Modeling
(while in the Modeling Application mode). The values that appear in the Distance and Angle
fields are used as a benchmark for some of the Examine Geometry tests. You are free to enter
your own values, which will persist through the rest of the session.

Summary

By understanding the specific checks in the Examine Geometry Tool, and the information the checks
are looking for, you will be able to repair part files in an efficient manner. Knowledge and practice in
using the Examine Geometry Tool will enable you to avoid errors during the creation of their parts.

As a recommended Good Modeling Practice, run the Examine Geometry check at least once per day.
This will ensure that the part file construction is proceeding with good features. Ignoring this function
until the end of a project can create unnecessary amounts of effort. By using this function frequently,
errors can be prevented from ‘snowballing’ out of control.

Ron Young



