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Copyright © 2002 Nortel Networks

All rights reserved. November 2002.

The information in this document is subject to change without notice. The statements, configurations, technical data, and 
recommendations in this document are believed to be accurate and reliable, but are presented without express or implied 
warranty. Users must take full responsibility for their applications of any products specified in this document. The 
information in this document is proprietary to Nortel Networks Inc. 

The software described in this document is furnished under a license agreement and may be used only in accordance 
with the terms of that license. The software license agreement is included in this document.

Nortel Networks, the Nortel Networks logo, the Globemark, Unified Networks, SL-1, Meridian 1, Succession 
Communication Server for Enterprise 1000, and Optivity are trademarks of Nortel Networks.

Microsoft, MS, MS-DOS, Windows, and Windows NT are registered trademarks of Microsoft Corporation.

Adobe and Acrobat Reader are trademarks of Adobe Systems Incorporated.

The asterisk after a name denotes a trademarked item.

Restricted rights legend

Use, duplication, or disclosure by the United States Government is subject to restrictions as set forth in subparagraph 
(c)(1)(ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013.

Notwithstanding any other license agreement that may pertain to, or accompany the delivery of, this computer software, 
the rights of the United States Government regarding its use, reproduction, and disclosure are as set forth in the 
Commercial Computer Software-Restricted Rights clause at FAR 52.227-19.

Statement of conditions

In the interest of improving internal design, operational function, and/or reliability, Nortel Networks Inc. reserves the 
right to make changes to the products described in this document without notice.

Nortel Networks Inc. does not assume any liability that may occur due to the use or application of the product(s) or 
circuit layout(s) described herein.

Portions of the code in this software product may be Copyright © 1988, Regents of the University of California. All 
rights reserved. Redistribution and use in source and binary forms of such portions are permitted, provided that the above 
copyright notice and this paragraph are duplicated in all such forms and that any documentation, advertising materials, 
and other materials related to such distribution and use acknowledge that such portions of the software were developed 
by the University of California, Berkeley. The name of the University may not be used to endorse or promote products 
derived from such portions of the software without specific prior written permission.

SUCH PORTIONS OF THE SOFTWARE ARE PROVIDED “AS IS” AND WITHOUT ANY EXPRESS OR IMPLIED 
WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.

In addition, the program and information contained herein are licensed only pursuant to a license agreement that contains 
restrictions on use and disclosure (that may incorporate by reference certain limitations and notices imposed by third 
parties).
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Nortel Networks Inc. Optivity* Telephony Manager software license 
agreement

NOTICE: Please carefully read this license agreement before copying or using the accompanying Optivity Telephony 
Manager software or installing the hardware unit with pre-enabled Optivity Telephony Manager software (each of which 
is referred to as “Software” in this Agreement). BY COPYING OR USING THE SOFTWARE, YOU ACCEPT ALL OF 
THE TERMS AND CONDITIONS OF THIS LICENSE AGREEMENT. THE TERMS EXPRESSED IN THIS 
AGREEMENT ARE THE ONLY TERMS UNDER WHICH NORTEL NETWORKS WILL PERMIT YOU TO USE 
THE SOFTWARE. If you do not accept these terms and conditions, return the product, unused and in the original 
shipping container, within 30 days of purchase to obtain a credit for the full purchase price.

1. License grant. Nortel Networks Inc. (“Nortel Networks”) grants the end user of the Software (“Licensee”) a personal, 
nonexclusive license: a) to use the Software either on a single computer or, if applicable, on a single authorized device 
identified by host ID; b) to copy the Software solely for backup purposes in support of authorized use of the Software; 
and c) to use and copy the associated user manual solely in support of authorized use of the Software by Licensee. This 
license applies to the Software only and does not extend to Nortel Networks Agent software or other Nortel Networks 
software products. Nortel Networks Agent software or other Nortel Networks software products are licensed for use 
under the terms of the applicable Nortel Networks Inc. Software License Agreement that accompanies such software and 
upon payment by the end user of the applicable license fees for such software. 

2. Restrictions on use; reservation of rights. The Software and user manuals are protected under copyright laws. 
Nortel Networks and/or its licensors retain all title and ownership in both the Software and user manuals, including any 
revisions made by Nortel Networks or its licensors. The copyright notice must be reproduced and included with any copy 
of any portion of the Software or user manuals. Licensee may not modify, translate, decompile, disassemble, use for any 
competitive analysis, reverse engineer, distribute, or create derivative works from the Software or user manuals or any 
copy, in whole or in part. Except as expressly provided in this Agreement, Licensee may not copy or transfer the 
Software or user manuals, in whole or in part. The Software and user manuals embody Nortel Networks’ and its 
licensors’ confidential and proprietary intellectual property. Licensee shall not disclose to any third party the Software, 
or any information about the operation, design, performance, or implementation of the Software and user manuals that is 
confidential to Nortel Networks and its licensors; however, Licensee may grant permission to its consultants, 
subcontractors, and agents to use the Software at Licensee’s facility, provided they have agreed to use the Software only 
in accordance with the terms of this license.

3. Limited warranty. Nortel Networks warrants each item of Software, as delivered by Nortel Networks and properly 
installed and operated on Nortel Networks hardware or other equipment it is originally licensed for, to function 
substantially as described in its accompanying user manual during its warranty period, which begins on the date 
Software is first shipped to Licensee. If any item of Software fails to so function during its warranty period, as the sole 
remedy Nortel Networks will at its discretion provide a suitable fix, patch, or workaround for the problem that may be 
included in a future Software release. Nortel Networks further warrants to Licensee that the media on which the 
Software is provided will be free from defects in materials and workmanship under normal use for a period of 90 days 
from the date the Software is first shipped to Licensee. Nortel Networks will replace defective media at no charge if it is 
returned to Nortel Networks during the warranty period along with proof of the date of shipment. This warranty does not 
apply if the media has been damaged as a result of accident, misuse, or abuse. The Licensee assumes all responsibility 
for selection of the Software to achieve Licensee’s intended results and for the installation, use, and results obtained from 
the Software. Nortel Networks does not warrant a) that the functions contained in the software will meet the Licensee’s 
requirements, b) that the Software will operate in the hardware or software combinations that the Licensee may select, c) 
that the operation of the Software will be uninterrupted or error free, or d) that all defects in the operation of the Software 
will be corrected. Nortel Networks is not obligated to remedy any Software defect that cannot be reproduced with the 
latest Software release. These warranties do not apply to the Software if it has been (i) altered, except by Nortel 
Networks or in accordance with its instructions; (ii) used in conjunction with another vendor’s product, resulting in the 
defect; or (iii) damaged by improper environment, abuse, misuse, accident, or negligence. THE FOREGOING 
WARRANTIES AND LIMITATIONS ARE EXCLUSIVE REMEDIES AND ARE IN LIEU OF ALL OTHER 
WARRANTIES EXPRESS OR IMPLIED, INCLUDING WITHOUT LIMITATION ANY WARRANTY OF 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Licensee is responsible for the security of its 
Using Optivity Telephony Manager Release 2.0x
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own data and information and for maintaining adequate procedures apart from the Software to reconstruct lost or altered 
files, data, or programs.

4. Limitation of liability. IN NO EVENT WILL NORTEL NETWORKS OR ITS LICENSORS BE LIABLE FOR 
ANY COST OF SUBSTITUTE PROCUREMENT; SPECIAL, INDIRECT, INCIDENTAL, OR CONSEQUENTIAL 
DAMAGES; OR ANY DAMAGES RESULTING FROM INACCURATE OR LOST DATA OR LOSS OF USE OR 
PROFITS ARISING OUT OF OR IN CONNECTION WITH THE PERFORMANCE OF THE SOFTWARE, EVEN IF 
NORTEL NETWORKS HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. IN NO EVENT 
SHALL THE LIABILITY OF NORTEL NETWORKS RELATING TO THE SOFTWARE OR THIS AGREEMENT 
EXCEED THE PRICE PAID TO NORTEL NETWORKS FOR THE SOFTWARE LICENSE.

5. Government licensees. This provision applies to all Software and documentation acquired directly or indirectly by or 
on behalf of the United States Government. The Software and documentation are commercial products, licensed on the 
open market at market prices, and were developed entirely at private expense and without the use of any U.S. 
Government funds. The license to the U.S. Government is granted only with restricted rights, and use, duplication, or 
disclosure by the U.S. Government is subject to the restrictions set forth in subparagraph (c)(1) of the Commercial 
Computer Software––Restricted Rights clause of FAR 52.227-19 and the limitations set out in this license for civilian 
agencies, and subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause of DFARS 
252.227-7013, for agencies of the Department of Defense or their successors, whichever is applicable.

6. Use of software in the European Community. This provision applies to all Software acquired for use within the 
European Community. If Licensee uses the Software within a country in the European Community, the Software 
Directive enacted by the Council of European Communities Directive dated 14 May, 1991, will apply to the examination 
of the Software to facilitate interoperability. Licensee agrees to notify Nortel Networks of any such intended examination 
of the Software and may procure support and assistance from Nortel Networks.

7. Term and termination. This license is effective until terminated; however, all of the restrictions with respect to 
Nortel Networks’ copyright in the Software and user manuals will cease being effective at the date of expiration of the 
Nortel Networks copyright; those restrictions relating to use and disclosure of Nortel Networks’ confidential information 
shall continue in effect. Licensee may terminate this license at any time. The license will automatically terminate if 
Licensee fails to comply with any of the terms and conditions of the license. Upon termination for any reason, Licensee 
will immediately destroy or return to Nortel Networks the Software, user manuals, and all copies. Nortel Networks is not 
liable to Licensee for damages in any form solely by reason of the termination of this license.

8. Export and re-export. Licensee agrees not to export, directly or indirectly, the Software or related technical data or 
information without first obtaining any required export licenses or other governmental approvals. Without limiting the 
foregoing, Licensee, on behalf of itself and its subsidiaries and affiliates, agrees that it will not, without first obtaining all 
export licenses and approvals required by the U.S. Government: (i) export, re-export, transfer, or divert any such 
Software or technical data, or any direct product thereof, to any country to which such exports or re-exports are restricted 
or embargoed under United States export control laws and regulations, or to any national or resident of such restricted or 
embargoed countries; or (ii) provide the Software or related technical data or information to any military end user or for 
any military end use, including the design, development, or production of any chemical, nuclear, or biological weapons.

9. General. If any provision of this Agreement is held to be invalid or unenforceable by a court of competent 
jurisdiction, the remainder of the provisions of this Agreement shall remain in full force and effect. This Agreement will 
be governed by the laws of the state of California.

Should you have any questions concerning this Agreement, contact Nortel Networks Inc., 2375 N. Glenville Dr., 
Richardson, TX 75082.

LICENSEE ACKNOWLEDGES THAT LICENSEE HAS READ THIS AGREEMENT, UNDERSTANDS IT, AND 
AGREES TO BE BOUND BY ITS TERMS AND CONDITIONS. LICENSEE FURTHER AGREES THAT THIS 
AGREEMENT IS THE ENTIRE AND EXCLUSIVE AGREEMENT BETWEEN NORTEL NETWORKS AND 
LICENSEE, WHICH SUPERSEDES ALL PRIOR ORAL AND WRITTEN AGREEMENTS AND 
COMMUNICATIONS BETWEEN THE PARTIES PERTAINING TO THE SUBJECT MATTER OF THIS 
AGREEMENT. NO DIFFERENT OR ADDITIONAL TERMS WILL BE ENFORCEABLE AGAINST NORTEL 
NETWORKS UNLESS NORTEL NETWORKS GIVES ITS EXPRESS WRITTEN CONSENT, INCLUDING AN 
EXPRESS WAIVER OF THE TERMS OF THIS AGREEMENT.
553-3001-330 Standard 3.00 November 2002
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Revision History

Date Revised Version Reason for revision

June 2001 1.00 Initial Standard release coincided with the introduction of OTM 1.1.

January 2002 2.00 Upissued to coincide with the introduction of OTM Release 1.2.

November 2002 3.00 Upissued to coincide with the introduction of OTM Release 2.0.
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Preface

Optivity* Telephony Manager (OTM) is designed for managers of 
telecommunications equipment and authorized Nortel Networks* distributors. 
OTM provides a single point of access and control for Nortel Networks 
Meridian 1* and Succession Communication Server for Enterprise (CSE) 1000* 
system management. OTM uses IP technology to target the following key 
customer values: 

• Single point of connectivity to Meridian 1 systems, Succession CSE 1000 
systems, and related devices

• Data collection for traffic and billing records

• Collection, processing, distribution, and notification for alarms and events

• Data entry and propagation (employee names and telephone numbers shared 
in multiple databases)

• Web-based management applications

Before you begin

This guide is intended for Meridian 1 and Succession CSE 1000 system 
administrators using a Microsoft Windows*-based PC for management activities. 
This guide assumes that you have the following background:

• Working knowledge of the Windows NT*/Windows 2000 Server operating 
system

• Familiarity with Meridian 1 and Succession CSE 1000 system management 
activities

• Knowledge of general telecommunications concepts

• Experience with windowing systems or graphical user interfaces (GUIs)
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Text conventions

This guide uses the following text conventions:

Acronyms

This guide uses the following acronyms:

angle brackets (< >) Indicate that you choose the text to enter based on the 
description inside the brackets. Do not type the brackets 
when entering the command.
Example: If the command syntax is
chg suppress_alarm <n> where n is 0 = all, 
1 = minor, 2 = major, 3 = critical, you enter
chg suppress_alarm 3 to suppress all alarms 
except critical alarms.

bold
Courier text

Indicates command names and options and text that you 
need to enter.
Example: Enter prt open_alarm.

italic text Indicates new terms, book titles, and variables in 
command syntax descriptions. Where a variable is two or 
more words, the words are connected by an underscore.
Example: For installation information, refer to Installing 
and Configuring Optivity Telephony Manager for 
Meridian 1.

plain Courier 
text

Indicates command syntax and system output, such as 
prompts and system messages.
Example: Open Alarm destination #0 is 
47.82.40.237

separator ( > ) Shows menu paths. 
Example: Select Utilities > Backup in the Navigator 
window. 

ASP active server page

CLI command line interface
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Related publications

For more information about using Optivity Telephony Manager and associated 
applications, refer to the following publications:

• Installing and Configuring Optivity Telephony Manager (553-3001-230)

Provides information on how to install and configure the Optivity Telephony 
Manager software.

• Using Optivity Telephony Manager Telemanagement Applications 
(553-3001-331)

Provides information on the following optional telemanagement applications: 
Telecom Billing System (TBS), TBS Web Reporting, General Cost Allocation 
System (GCAS), Consolidated Reporting System (CRS), and Consolidated 
Call Cost Reports (CCCR).

DBA Data Buffering and Access

DN directory number

GUI graphical user interface

IP Internet Protocol

LAN local area network

LDAP lightweight directory access protocol

MAT Meridian Administration Tools

NMS network management system

OTM Optivity Telephony Manager

PTY pseudo-TTY (network port)

RAS remote access server

TBS Telecom Billing System

TN terminal number

TTY teletype (serial port)

uid unique identifier in LDAP synchronization
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• Meridian Internet Telephony Gateway (ITG) Trunk 1.0/Basic Per-Trunk 
Signaling (553-3001-116)

Describes configuration and maintenance of the 8-port ITG trunk card.

• Meridian Internet Telephony Gateway (ITG) Trunk 2.0/ISDN Signaling Link 
(ISL) (553-3001-202)

Describes configuration and maintenance of the 24-port ITG trunk card. This 
card appears to the Meridian 1 switch as a 24-port trunk card with ISDN 
Signaling Link (ISL) and D-channel signaling.

• Meridian Internet Telephony Gateway (ITG) Line 1.0/IP Telecommuter 
(553-3001-119)

Describes configuration and maintenance of the ITG line card for IP 
Telecommuter.

• Meridian 1 and Succession Communication Server for Enterprise 1000 IP 
Line: Description, Installation, and Operation (553-3001-204)

Describes configuration and maintenance of the ITG gateway card for the 
Meridian Internet Telephones, also referred to as IP telephones.

• Meridian/Succession Companion DECT: Overview (553-3601-103)

Provides an overview of OTM for MDECT systems.

• Meridian/Succession Companion DECT: Installation Guide (553-3601-203)

Provides instructions on how to install the OTM DECT application and how 
to configure the MDECT system on the OTM Server.

• Meridian/Succession Companion DECT: Operation Administration and 
Maintenance (553-3601-301)

Provides detailed instructions on using OTM to administer and maintain the 
MDECT system.

• M3900 Series Meridian Digital Telephones: Description, Installation, and 
Administration (553-3001-216)

Describes M3900 series telephones and related features. The M3904 and 
M3905 telephones provide access to an OTM-generated Corporate Directory.

• Internet Terminals Guide (553-3001-217)

Describes the i2002, i2004, and i2050 telephones and their features.

• Software Features Guide (553-3001-306)
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Describes features associated with the Meridian 1 and Succession CSE 1000 
systems. For each feature, information is provided on feature implementation, 
feature operation, and interaction between features.

• Software Input/Output Guide: Administration (553-3001-311)

Describes the prompts and responses for the Meridian 1 and Succession 
CSE 1000 systems’ command line interface (CLI). This guide includes 
information on overlay programs that are classified as administration 
overlays.

• Software Input/Output Guide: System Messages (553-3001-411)

Describes the meaning of the messages generated by the Meridian 1 and 
Succession CSE 1000 systems.

• Software Input/Output Guide: Maintenance (553-3001-511)

Describes the prompts and responses for the Meridian 1 and Succession 
CSE 1000 systems’ command line interface (CLI). This guide includes 
information on overlay programs that are classified as maintenance overlays.

• Option 11C Planning and Installation (553-3021-210)

Provides information on the Survivable IP Expansion (SIPE) feature.

• Succession Communication Server for Enterprise 1000 Planning and 
Installation Guide (553-3023-210)

Provides information on the Survivable IP Expansion (SIPE) feature for 
Succession CSE 1000 systems.

You can print selected technical manuals and release notes free, directly from the 
Internet. Go to the www.nortelnetworks.com/documentation URL. Find the 
product for which you need documentation. Then locate the specific category and 
model or version for your hardware or software product. Use Adobe Acrobat 
Reader to open the manuals and release notes, search for the sections you need, 
and print them on most standard printers. Go to Adobe* at the www.adobe.com 
URL to download a free copy of the Adobe Acrobat Reader*.

You can purchase selected documentation sets, CDs, and technical publications 
through the Internet at the www.nortelnetworks.com URL. From the main page, 
select Customer Support > Documentation.
Using Optivity Telephony Manager Release 2.0x
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How to get help

If you purchased a service contract for your Nortel Networks product from a 
distributor or authorized reseller, contact the technical support staff for that 
distributor or reseller for assistance.
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Chapter 1
Overview of Optivity Telephony Manager

OTM contains all of the Meridian Administration Tools (MAT) Microsoft 
Windows applications. In addition, OTM introduces new Web applications and 
integration with Optivity NMS.

OTM provides value by acting as a management server. It collects and processes 
alarms from multiple devices (Meridian 1, Succession CSE 1000, Call Pilot, ITG, 
and so on); collects call accounting and traffic data from multiple Meridian 1 and 
Succession CSE 1000 systems; and acts as a terminal server for multiple devices. 
One OTM Windows NT® Server replaces multiple buffer boxes, access modems, 
and terminal servers. 

You may also install OTM in a stand-alone configuration, without client support 
or Web applications, on a PC running Windows 98, Windows NT version 4.0, or 
Windows 2000. System access is provided through the OTM Windows System 
Terminal, and security management is provided through the OTM User 
Administration.

What’s new in OTM Release 2.0

The following content is being introduced with OTM Release 2.0:

• New Network View

• Concurrency with Succession CSE 1000 Release 2.0

• Security enhancements

• Web Station scheduler with telephone courtesy change

• Multi-system billing reports for both Meridian 1 and Succession CSE 1000
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Technical documentation

OTM technical documentation consists of an installation and configuration guide 
and two user guides. Table 1 outlines the contents of the various guides in the 
OTM documentation suite. The entries in the second and third columns indicate 
whether the information in that section applies to:

• OTM Windows Navigator, which is the Microsoft Windows-based interface

• OTM Web Navigator, which is the Web-based (http) interface

• Both interfaces
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Table 1   OTM 2.0 technical documentation content

Book title
Microsoft
Windows Web Contents

Installing and 
Configuring 
Optivity Telephony 
Manager

X
X
X

X
X
X

X
X
X

X

X
X

X
X

X
X
X

X
X
X

X
X
X

X
X

X

X

Initial installation tasks:
OTM requirements

Installing a server
Installing a client

OTM server software installation
Serial numbers and keycodes
Java runtime environment (JRE)

OTM client software installation
Upgrades, migration, licensing
Installing Web Help

Initial configuration tasks:
Modem configuration for OTM applications in 
Microsoft Windows

Logging in, changing the default password
Testing the connection

Setting up OTM applications
Adding sites, systems, Windows users
Adding Web users

Setting up the Meridian 1
Setting up the Virtual Terminal Service
Setting up data buffering and access (DBA)

Setting up the LDAP server
Setting up Alarm Management
Performing an OTM backup

Installing a Web browser client
Integrating OTM with Optivity NMS
Integrating OTM with HP OpenView

Windows NT reference
Installing Windows NT
Configuring a Windows NT server

Windows NT security guidelines
Uninstalling OTM
OTM engineering guidelines
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Using Optivity 
Telephony 
Manager

X

X
X
X

X
X
X

X
X
X

X
X
X

X

X
X
X

X
X

X

X

X

X

X
X

X
X
X

X
X
X

X
X

Overview of Optivity Telephony Manager
Common Services

Services
OTM Windows Navigator
Security management
Configuring sites, systems, and users

Maintenance tasks
Regional Settings
Access Server

Directory Services
Corporate Directory
Event log viewer

System Terminal
System Monitor
Data Buffering and Access

Utilities
Scheduler

Import and Export Utilities
Database Compact and Repair
Backup and Restore

LDAP Synchronization
Electronic Data Dump

Web services
OTM Web Navigator
Equipment
Web Station

Web Administration
Customizable Web Help

Web Virtual Terminal Service

Web System Terminal
Web Desktop Services

(continued)

Table 1   OTM 2.0 technical documentation content (continued)

Book title
Microsoft
Windows Web Contents
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Using Optivity 
Telephony 
Manager

(continued)
X

X

X
X

X
X
X

X
X
X

X
X

X

X

X
X
X

X
X

X
X
X

X

(continued)
Station Administration

Getting started
Retrieving and updating system data

General information
Station data and synchronization 
considerations
Station administration windows and menus
Accessing station data

Adding and deleting stations
Swapping TNs
Managing station data

Designation strips (DNs)
Station data validation
Directory Service

Architecture, links, integration
Excess DN report

Station and directory synchronization
Station Administration features

Call Party Name Display (CPND)

List manager
Voice mailbox
Global update

Communicating with the PBX
Conversion utility
Reporting:

Generating reports
OTM file viewer
Designing report forms

Power user tool
(continued)

Table 1   OTM 2.0 technical documentation content (continued)

Book title
Microsoft
Windows Web Contents
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Using Optivity 
Telephony 
Manager

(continued)
X

X

X

X

X

X
X
X

X

X

X
X
X

X
X
X

X
X
X

X
X

X

X
X
X

X

X

X
X
X

X
X
X

X
X

(continued)
Alarm Management

Alarm management configurations
Web-based alarm management
Windows-based alarm management

Alarm banner

Event monitor window
Alarm notification

Notification process

Setting up alarm notification
Events processing
Scripting

Script wizard and sample scripts
Maintenance Applications

Launching maintenance windows 
applications
Maintenance pages/windows

Core CPU
I/O Ports 
Network Groups 

Network Loops 
PE Shelves 
PE Cards 

PE Units 
B- and D-channels 

Inventory reporting
Traffic Analysis

Configuration
User Reference

ESN Analysis and Reporting Tool
Synchronizing the OTM ESN database and 
the Meridian 1 switch
Update the V&H table
Printing ESN reports
ESN Setup wizard

Table 1   OTM 2.0 technical documentation content (continued)

Book title
Microsoft
Windows Web Contents
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Overview of OTM applications

OTM includes the following Windows-based applications:

• Enhanced Station Administration/CPND

• Directory Service with LDAP support

• Telecom Billing System (TBS), which replaced MAT Call Accounting

• Data Buffering and Access (DBA)

• Call Tracking

• General Cost Allocation System (GCAS)

• Consolidated Reporting System (CRS)

Using Optivity 
Telephony 
Manager 
Telemanagement 
Applications

X

X

X
X

X
X

X
X

X
X
X

X

X

X

X

X

X
X

Overview of Telemanagement Applications
Telecom Billing System (TBS)

Configuration

Operating Procedures
User Reference

Consolidated Call Cost Reports (CCCR)
Operating Procedures
User Reference

Telecom Billing System (TBS) Web Reporting
Setting up TBS Web Reporting
User Reference

Call Tracking
Collecting data from a Meridian 1 switch
Call Tracking menus
Sample setup for real time monitoring

General Cost Allocation System (GCAS)
Operating Procedures

User Reference
Consolidated Reporting System (CRS)

Operating Procedures

User Reference

Table 1   OTM 2.0 technical documentation content (continued)

Book title
Microsoft
Windows Web Contents
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• Consolidated Call Cost Reports (CCCR)

OTM Windows-based applications can operate in either server or stand-alone 
mode on a PC running Windows NT version 4.0 Server or Windows 2000 Server. 
You can also install OTM as a stand-alone on the Windows 98 operating system.

OTM can also operate in client mode on a PC running Windows 98, Windows NT 
4.0 Workstation, or Windows 2000 Professional. For more information about 
configuring OTM in stand-alone mode, refer to “Stand-alone configuration” on 
page 56. For more information about configuring OTM in client mode, refer to 
Installing and Configuring Optivity Telephony Manager (553-3001-230).

The following MAT 6.6 applications are supported in OTM:

• Windows Navigator

• List Manager

• ESN

• Traffic Analysis module

• Call Tracking application

• Corporate Directory

• IP Telephony Gateway (ITG) applications

• Inventory

• Maintenance Windows

• Alarm Notification 

OTM provides the following Web-based (http) applications:

• OTM Web Navigator

• Virtual Terminal Service (command line interface from the Web)

• Web System Terminal

• Web Station Administration

• Web Alarm Browser

• Maintenance Pages

• Customizable Web Help

• Web User Access and Session Monitor pages
553-3001-330 Standard 3.00 November 2002



Overview of Optivity Telephony Manager 49
• Desktop Services that provide Web pages to display directory and telephone 
configuration. You may permit end users to modify the configuration of their 
telephones using Desktop Services.

Comparison of OTM Windows and OTM Web interfaces

You can access OTM using either OTM Windows Navigator or OTM Web 
Navigator. You can perform many basic configuration and management tasks 
through either interface. This section describes the similarities and differences 
between the OTM Windows Navigator and the OTM Web Navigator.

OTM Windows Navigator

OTM Windows Navigator gives you access to OTM-managed systems. Through 
menus and folders, you can do the following:

• View, configure and administer sites, systems and users.

• Configure and administer OTM services.

• Launch utility applications.

• Display licensing and release information for all installed OTM applications.

The OTM Windows Navigator displays sites and systems in a tree structure. When 
you choose a system on the tree, you can launch a System window to configure 
the system and launch management applications. The OTM System Navigator 
window displays all configured systems. When you select a system, the list of 
available applications appears in the window. The OTM Windows Navigator 
system access depends on the privileges assigned to your OTM User Group. For a 
list of available functions and applications, refer to Table 2.

OTM Web Navigator

The OTM Web Navigator provides a number of the same functions available in 
the OTM Windows Navigator. The OTM Web Navigator allows you to view sites, 
systems, and users. The Web Navigator also allows you to configure and 
administer OTM users. OTM Web security meets the same criteria as provided by 
Windows NT and Windows 2000.
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One of the advantages of the OTM Web interface is the ability for users to 
configure their telephones through their Web browser. As an administrator, using 
Web Desktop Services, you can also block end user access to configuration 
windows. A particularly useful Desktop Services feature is the ability to 
customize the Help files to suit specific customer needs.

Table 2 compares the functions and applications available in the OTM Windows 
Navigator with those available in the OTM Web Navigator. 

Table 2   Comparing Windows and Web Navigators

OTM Windows Navigator OTM Web Navigator

Common Services

Ability to launch other applications
Scheduler
Backup & Restore (OTM Data)

Import/Export
PC Event Log
Compact and Repair

License management
Data Buffering and Access

Trap Master
Trap Server
Related utilities

Ability to link to other Web sites
Event Service
System Sanity

Terminal Server
Trap Master
Trap Server

Fault Management

PC Event Log and Viewer

Event Monitor for Meridian 1 and Succession 
CSE 1000
Alarm Banner

Alarm notification by:
• pager
• e-mail

• file
• SNMP trap forwarder

Alarm Browser (consolidated systems)

• view alarms from core Meridian 1, Succession 
CSE 1000, Meridian Mail, ITG, Symposium Call 
Center Server, and Call Pilot.
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Configuration Management

Station Administration
Directory Editor
LDAP Query utility

LDAP Synchronization
Corporate Directory
Maintenance Windows

• real time status of PBX hardware
• sorting by type or status
• enable, disable, test, and so on

ESN
ITG Configuration
DBA Backup

DBA Restore
List Manager
Inventory

Web Station Administration
• Telephone management
• Directory Update

• Scheduling
• End User Access
Maintenance Pages

• real time status of PBX hardware
• sorting by type or status
• enable, disable, test, and so on

Customizable Web Help
LDAP Synchronization Report
Directory Update (Global Change)

Desktop User Access
• finding telephones
• viewing set configuration

• changing keys and features

Accounting Management

Telecom Billing System (TBS)
• analyzes CDR from multiple switches

• predefined reports
• customization of reports
General Cost Allocation System (GCAS)

Consolidated Reporting System (CRS)
Consolidated Call Cost Reports (CCCR)
Call Tracking

Telecom Billing Services (TBS) Web Reporting

Performance Management

Traffic Analysis

Call Tracking

Security Management

OTM User Template Administration
OTM User Management

Web Navigator Access Security (Local OTM Server)
Web Desktop Access Security using Local OTM 
Server, WinNT Domain, or LDAP account

OTM User Management
Web Session Monitor

Table 2   Comparing Windows and Web Navigators (continued)

OTM Windows Navigator OTM Web Navigator
Using Optivity Telephony Manager Release 2.0x



52 Overview of Optivity Telephony Manager
Common Services

OTM Common Services are similar to MAT Common Services. Most have been 
enhanced for OTM; several are new. OTM Common services are:

• OTM Windows Navigator and OTM System windows

• OTM Windows-based System Terminal

• New Import and Export Utilities

• New Compact and Repair Utility

• Enhanced 32-bit Scheduler

• Enhanced PC Event Log Viewer 

• Enhanced Database Buffering and Access (DBA)

• OTM user administration

• OTM Backup and Restore

• New System Monitor on the OTM server

• License management

• NT Client capability

System Access

Windows System Terminal Web System Terminal

User Applications

Windows Help Web Help
End User Desktop Services
• viewing set configuration

• changing keys and features
Telecom Billing System (TBS) Web Reports

Table 2   Comparing Windows and Web Navigators (continued)

OTM Windows Navigator OTM Web Navigator
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OTM Server

The OTM Server runs on a Windows NT 4.0 Server or Windows 2000 Server. It 
performs the following functions:

• Virtual Terminal Service providing single-point of connectivity to the 
Meridian 1 or Succession CSE 1000 system and related devices

• Common Services and file server for OTM client applications

• Data Buffering and Access (DBA) collects and stores CDR and Traffic data

• Web Server for OTM Web-based applications

• Alarm and event collection, processing, distribution, and notification

• Run other management applications, such as Call Pilot

Figure 1 is a block diagram illustrating the functions provided by the OTM Server.

Note: Do not install OTM on a Microsoft Windows NT or 
Windows 2000 server that is configured as a primary domain controller 
(PDC).
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Figure 1   OTM Server block diagram

Configurations

Network model

OTM can manage voice switches in both a centralized and local manner.

Centralized management is geared towards network management centers, whereas 
local management is geared toward site level telecom managers. 

Figure 2 shows an example of OTM in a centralized configuration.
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Figure 2   OTM Network model

Site model

Figure 3 shows an example of a single OTM as a Site Manager supporting 
multiple voice devices in a single site. You can run Client/Server acting 
applications (Web or Windows) on the OTM server, or remotely via IP or dial-in 
connections. 
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Figure 3   OTM Site model

Stand-alone configuration

OTM may be installed in a stand-alone configuration. The stand-alone 
configuration can run on a Windows 98, Windows NT 4.0 Workstation, or 
Windows 2000 Professional PC. An OTM system configured as a stand-alone 
does not allow for remote clients; however, it does allow for access to Web-based 
applications. Windows System Terminal provides system access, and OTM User 
Template Administration provides Security Management.

Common Services available in a stand-alone configuration include:
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• Windows Navigator

• Scheduler

• Backup and Restore (OTM data)

• Import/Export

• Compact/Repair

In the area of fault management, when installed in a stand-alone configuration, 
OTM provides a subset of the functionality available when installed in a network. 
You can set up the stand-alone configuration to forward alarms to Optivity NMS. 
An enhanced PC Event Log and viewer is available along with an Event Monitor, 
which allows you to view Meridian 1 and Succession CSE 1000 system alarms. 
Alarm Banner is included for core alarms, and Alarm Notification permits 
handling, filtering and forwarding (including forwarding to numeric and 
alphanumeric pagers).

Call accounting is accomplished using the Telecom Billing System (TBS). Data 
Buffering and Access (DBA) provides real time collection of Call Detail 
Recording (CDR) and Traffic data via IP. Traffic and TBS use data collected by 
DBA or via a buffer box to generate reports.

The stand-alone configuration supports the following configuration management 
and maintenance activities:

• System Window

• Data Buffering and Access (DBA)

• Station Administration with Directory and Lightweight Directory Access 
Protocol (LDAP) support

• Maintenance Windows

• Electronic Switched Network (ESN) Analysis and Reporting Tool

• Internet Telephony Gateway (ITG) configuration

• DBA Backup and Restore (X11 database)

• List Manager

• Inventory
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Connectivity through OTM

The Virtual Terminal Service provides the connection between your browser and a 
device or system. You can launch the OTM Web Navigator from a Web browser, 
such as Internet Explorer or Netscape Navigator, and select a Meridian 1 or 
Succession CSE 1000 system or other device to view. 

You can access systems and devices using OTM’s Web System Terminal window 
from within your Web browser, without referring to IP addresses, serial port 
settings, or URLs. That information is retained on the OTM Server. 

If you are not using Access Server, uncheck the “Launch Automatically” check 
box. This allows the server COM port to be used by another application, if needed. 
For information on Access Server, see “Access Server” on page 153. 

Figure 4 shows the various ways you can use OTM to connect to network devices 
and systems, such as the Meridian 1 and Succession CSE 1000. The figure legend, 
which follows the figure, describes these connections in more detail.

Caution: For security reasons, Nortel Networks strongly recommends 
that you configure RAS to allow the incoming call to Access the 
Computer Only. This setting allows access to the RAS server, but not to 
the rest of your network.
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Figure 4   OTM connectivity

Table 3   Legend

1. OTM users can access a system via the OTM Windows and Web Navigators. 
Applications include System Terminal as well as any Web-based applications 
supported by the system. OTM clients on the CLAN/ELAN can also use the OTM 
Windows-based applications (Station Administration, ESN, and so on).

2. OTM provides the connectivity to the Meridian 1 system for all windows and 
Web-based applications.

3. OTM provides the connectivity to the Succession CSE 1000 system for all windows 
and Web-based applications.

4. Generic IP System connection - The Web-based System Terminal provides a 
telnet-type connection to any IP-connected system or device. You can also navigate to 
the device’s management Web pages (if applicable).
Example: MIRAN II cards provide both a telnet access and Web-based management 
applications.
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Alarm Management

OTM Alarm Management provides an alarm collection and processing center for 
multiple systems and devices. OTM receives SNMP traps from systems, such as 
the Meridian 1, Succession CSE 1000, and Call Pilot, and stores them in a circular 
log file on the OTM Server. The OTM Alarm Notification application monitors 
the incoming traps and notifies the appropriate people of important events and 
alarms.

OTM Alarm Management has the following components:

• Web-based Alarm Browser - Used for viewing alarms from multiple systems 
and devices. HTML Help is provided for individual alarms.

5. Com Ports - You can equip the OTM Server with a Multiple Serial card to provide up to 
8 additional com ports. You can use these ports for dial in or dial out.

6. Generic System direct serial connection - Allows direct connection to any serial 
device. For example, for legacy Meridian 1 systems (R21 and earlier), you can 
connect to a maintenance TTY port and capture the error messages. A new OTM Text 
Handler capability can filter the TTY output and generate SNMP traps for selected 
error messages.

7. Generic System remote serial connection - When connecting to a remote serial 
system, you select the com port and manually dial the number of the desired system.

8. Access Server - Provides a serial command line interface (CLI) into the OTM Server, 
enabling remote access. Once connected, you can change Windows NT passwords or 
connect to any system or devices defined and enabled in the Virtual Terminal Service. 
The CLI is launched at Server Startup, and opens a status window displaying different 
status messages. The CLI Configuration window allows you to configure the server 
COM port settings. A real-time Log file details all CLI activities. For more information, 
see “Access Server option” on page 63.

9. Remote Access - You can dial in to the OTM Server, log in using the Windows NT 
Remote Access Service (RAS), and access all defined systems, such as Web System 
Terminal or system-specific Web applications. In addition, you can use the PC 
Anywhere application to dial in to an OTM client PC on the CLAN/ELAN.

10. Web Alarm Browser - Displays alarms collected from multiple supported Meridian 1 
and Succession CSE 1000 systems and devices.

11. PC LAN cards - Provide access to both the CLAN and ELAN. 

Table 3   Legend (continued)
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• Windows-based Alarm Browser - Used for viewing Meridian 1- and 
Succession CSE 1000-specific alarms. Windows Help is provided for 
individual alarms.

• Alarm Notification application - Provides a scripting language to generate 
notifications on selected incoming traps. Notification types include pagers, 
e-mail, and the forwarding of SNMP traps to an upstream processor (such as 
Optivity NMS). Notification is triggered by trap data, such as alarm severity, 
device type, and time of day. A Script Wizard application simplifies the 
creation of Alarm Notification scripts.

• Text Handler application - Parses maintenance TTY output and generates 
traps on selected error messages. This is intended primarily for legacy 
Meridian 1 systems (Release 21 and earlier) and Meridian Mail systems, 
which cannot generate traps. You can create Text Handler rules to support 
other serial devices.

• PC Event Log and Viewer - For viewing events and alarms generated on the 
OTM Server and all of its Windows clients. This Windows application can 
also generate SNMP traps based on the event severity level. 

Figure 5 shows the main components of OTM Alarm Management. The Trap 
Master is responsible for handling the SNMP traps from the systems and storing 
them on the server for retrieval by the Alarm Browser client. The Trap Server 
distributes traps to OTM applications registered to receive traps, such as Alarm 
Notification.
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Figure 5   OTM Alarm Management block diagram

The Trap Master and Trap Server are run as Windows NT Services on the OTM 
Server. 

OTM integrates with Optivity NMS 9.0.1 and above. The devices represented in 
Optivity NMS are OTM servers. These are manually added by the Optivity NMS 
administrator (Figure 6).

For a list of supported devices and additional information on alarm management, 
see Chapter 5, “Alarm management,” on page 653.
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Figure 6   Centralized alarms

Access Server option

The Access Server capability is available as an orderable option within an OTM 
server. This functionality allows CLI access to an OTM server using either a direct 
serial connection or a modem. From the OTM Server, connectivity is available to 
configured devices using the connection capability within Virtual Terminal Server. 
This connectivity must be preconfigured within Virtual Terminal Server to be 
available to a CLI connection. 
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Typically, Access Server is installed on an on-site PC that is used like a terminal 
server to allow a single connection to the site and then to fan out this connectivity 
to multiple devices that are connected to the OTM Server. You can access the 
remote location either by means of a terminal or human interactive session, or 
through a remote computer communicating via scripts.

You can use the OTM Access Server option with any level of OTM package 
(General, Enhanced, or Premium). You add this CLI input capability by ordering 
the “Access Server” to add to the OTM Server. If you order Access Server, it is not 
necessary to order any Set Expansion Packages, if all that you require is to use the 
Access Server mode. Of course, if OTM management functionality, such as 
Station Administration, is required, then it may be necessary to order Set 
Expansion Packages.

For more information on the Access Server option, see “Access Server” on 
page 153.
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Chapter 2
Common services

Services

OTM Windows Navigator

OTM Windows Navigator and OTM Web Navigator are the two main graphical 
user interfaces (GUIs) to OTM. These two GUIs provide access to most of the 
OTM systems and services. 

OTM Windows Navigator windows

OTM Windows Navigator, which uses the Microsoft Windows interface, shows 
the names and types of all systems available to the current user, and allows you to 
group the systems into sites for more convenient access. Once grouped, the 
systems can be viewed by site as shown in the example of the OTM Windows 
Navigator (Figure 7), or by gatekeeper zone (Figure 8 on page 68).

Note: A gatekeeper provides endpoint management, including 
registration/unregistration, authentication, address resolution (DN to IP, 
and endpoint to gateway), and maintains a list of endpoints currently 
active on the network. Each gatekeeper controls one H.323 zone; each 
H.323 zone consists of many H.323 IP clients. For more information on 
gatekeepers and gatekeeper zones, see Meridian Internet Telephony 
Gateway (ITG) Line 1.0/IP Telecommuter (553-3001-119).
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The gatekeepers are only displayed in the Gatekeepers Zones view. Although 
primarily used for Succession CSE 1000 systems, Meridian 1 systems can be 
assigned to a gatekeeper zone. This functionality is intended for Meridian 1 
systems that are equipped with ITG applications that support gatekeeper 
operation.

In the Sites view (Figure 7), Media Gateways appear in their associated site folder 
as well as in the Media Gateways folder within the appropriate Succession 
CSE 1000 folder. In the Media Gateways folder, the Media Gateway name is 
composed of the Site name and the system name. If the Call Server and Media 
Gateway are in the same site, the Media Gateway only appears in the Media 
Gateways folder of the associated Succession CSE 1000 system.

In the Gatekeeper Zones view (Figure 8 on page 68), Media Gateways appear 
within the Media Gateways folder of the associated Succession CSE 1000 system.

In the Sites view, Survivable IP Expansion cabinets appear in their associated site 
folder as well as in the Survivable Cabinets folder within the appropriate 
Option 11C main cabinet folder. If the main cabinet and Survivable IP Expansion 
cabinet are in the same site, the Survivable IP Expansion cabinet only appears in 
the Survivable Cabinets folder of the associated Option 11C system.

In the Gatekeeper Zones view, Survivable IP Expansion Cabinets only appear 
within the Survivable cabinets folder of the associated Option 11C system. 

Note: OTM does not display the survivable status of Media Gateways 
and Survivable IP Expansion cabinets. Also, OTM does not display the 
status of Gatekeepers (Primary/Alternate/Out of Service).
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Figure 7   OTM Windows Navigator—Sites view
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Figure 8   OTM Windows Navigator—Gatekeeper Zones view

The OTM Web Navigator, which uses the Web (http) interface, provides access to 
OTM’s Web-based features and services. For more information about the OTM 
Web Navigator and the features and services to which it provides access, see 
“OTM Web Navigator” on page 317.

OTM Windows Navigator allows you to do the following:

• Display a “tree” structure for the Gatekeeper Zones on the network that you 
manage. Access systems in a particular zone by opening the zone.
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• Display a “tree” structure for the Sites and Systems on the network that you 
manage. Access systems at a site by opening that site.

• Launch the System Window.

• Launch System Web Sites (Succession CSE 1000 systems only).

• Configure and administer OTM data: Sites and Systems, Users.

• Configure and administer OTM Services, such as Integrated Telephony 
Gateway.

• Launch utility applications, such as the Scheduler, Corporate Directory, and 
Alarm Notification.

• Display the licensing and release information for all installed OTM 
applications.

• Print reports.

Figure 9 illustrates these functions.     

Note: Double-click the System Window icon to launch the OTM system 
window containing the OTM Windows applications.

Note: Double-click the System Web Sites icon to launch the element 
management Web pages on the associated Signaling Server.

Note: Double-click a Gatekeeper to launch the associated management 
Web page.

Note: Access to the Command Line Interface (CLI) on the Signaling 
Server is not included in the tree. You can create a generic system for this 
purpose.
Using Optivity Telephony Manager Release 2.0x



70 Common services
Figure 9   OTM Windows Navigator functions

9970EA

System Windows

Navigator

Launch

Services

PC Event Log

Scheduler and Queues

Corporate Directory

Alarm Notification

Site

System

Services

User Name and Password

System Modem Scripts

Event Notification

Reports

Application Information

Launch

Launch

Configure

Print

Display
553-3001-330 Standard 3.00 November 2002



Common services 71
Using OTM Windows Navigator 

OTM Windows Navigator allows you to access any Meridian 1 or Succession 
CSE 1000 system or other systems that your user group privileges allow. In OTM 
Navigator, you open the site, or gatekeeper zone, of interest to choose a system on 
which to work. Double-click a system to open its System window and launch any 
of the OTM applications to work on that system. 

Open a site by double-clicking its name or clicking the plus sign (+) next to the 
site. The plus sign (+) changes to a minus sign (-) when the site opens. An open 
site displays all systems at that site. Close a site by clicking the minus sign (-).

Open a gatekeeper zone by double-clicking its name or clicking the plus sign (+) 
next to the zone. The plus sign (+) changes to a minus sign (-) when the zone 
opens. An open gatekeeper zone displays all of the systems associated with the 
zone. Close a zone by clicking the minus sign (-).

For Meridian 1 and Succession CSE 1000 systems, the components that make up 
the system appear in the system window. OTM displays a terminal emulation 
window for systems defined as “Generic.”

For information about using the OTM Web Navigator, see “OTM Web Navigator” 
on page 317.

Logging in and launching OTM Windows Navigator

From the Start menu, in the Windows Programs list, select Optivity Telephony 
Manager > OTM Navigator. The login dialog box appears (Figure 10). Enter your 
Login Name and Password. The OTM Windows Navigator window appears 
(Figure 11 on page 72). 

Figure 10   Login dialog box
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OTM Navigator menus

Detailed descriptions of the functions of each command in the Navigator menus 
are available by clicking the context-sensitive Help button in the toolbar. 

Figure 11   OTM Navigator window

Services folder

The Services folder contains applications and services available for sites and 
systems defined and accessible by the OTM PC. 
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IP Telephony Gateway applications

Table 4 lists the OTM IP telephony applications and the corresponding ITG 
hardware and software that are supported by various releases of X11 and 
Succession CSE 1000 system software.

The following OTM applications provide configuration and maintenance for the 
IP Telephony Gateway (ITG) cards.

• ITG IP Phones 

This application is used to configure and maintain the ITG gateway card for 
IP telephones. The IP telephones are true Internet telephones that are 
connected to a Meridian 1 or Succession CSE 1000 system through an 
IPE-to-ITG gateway card. The configuration of IP telephones is accomplished 

Table 4   OTM supported ITG applications by system software release

Supported system software releases

OTM application
ITG application 
and cards X11 Releases

Succession
CSE 1000
Releases

19 20 21 22 23 24 25.15 25.30 25.40 1.0 1.1 2.0

ITG IP Phones
ITG Line 2.0 Yes Yes Yes

ITG Line 2.1 Yes Yes Yes Yes Yes

ITG Line 2.2 P3 P3 Yes P3 Yes

ITG IP 
Telecommuter / 
e-Mobility

ITG Line 1.0 Yes Yes Yes Yes Yes Yes

802.11 Wireless Yes Yes Yes Yes

ITG ISDN IP 
Trunks

ITG Trunk 3.0 Yes Yes Yes

ITG Trunk 2.0 Yes Yes Yes

ITG Line 3.0 IP Line 3.0 P1 P1 P1 P1 L2

ITG M1 IP Trunk ITG Trunk 1.0 Yes Yes Yes Yes Yes Yes Yes

P1—Partial Support - The ITG Line 3.0 application can be configured on an X11 release 25 or CSE 1000 Release 1.1 system for the 
feature set equivalent to the ITG Line 2.2 application.

L2—Limited functionality for the ITG Line 3.0 application is supported - Base line configuration is performed by accessing the web server 
providing Succession CSE 1000 Element Management. OTM and Succession CSE 1000 Element Management support Operational 
Measurement reports. Corporate Directory on the Succession CSE 1000 requires OTM 2.0 and later.

P3—Partial support - When using earlier releases of the X11 and Succession CSE 1000 system software, partial support exists for the ITG 
feature set. The i2050 telephone is not supported on these releases.
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through the Station Administration application in OTM. For more 
information, refer to Meridian 1 and Succession Communication Server for 
Enterprise 1000 IP Line, Description, Installation, and Operation 
(553-3001-204).

• ITG IP Telecommuter / e-Mobility

This application is used to configure and maintain the ITG line card for IP 
Telecommuter. This application is used to configure the IP Line gateway and 
the gatekeeper, but not the H.323 IP terminal or PC-based software client. For 
more information, refer to Meridian Internet Telephony Gateway (ITG) Line 
1.0/IP Telecommuter (553-3001-119).

This application is also used for the configuration and maintenance of the ITG 
line card for wireless service. For more information, refer to 802.11 Wireless 
IP Gateway for Meridian 1 (553-3001-206)

• ITG ISDN IP Trunks

This application is used to configure and maintain the 24-port or 32-port ITG 
trunk card that resides in the IPE shelf of the Meridian 1. The card appears to 
the switch as a trunk card with ISDN Signaling Link (ISL) and D-channel 
signaling. The card has a 10/100 baseT connection to carry packetized voice 
and fax calls over IP data networks. For more information refer to Meridian 
Internet Telephony Gateway (ITG) Trunk 2.0/ISDN Signaling Link (ISL) 
(553-3001-202), and Addendum to Meridian Internet Telephony Gateway 
(ITG) Trunk 2.0/ISDN Signaling Link (ISL) (P0941974).

• ITG Line 3.0

This application is used to configure and maintain the 32-port Succession 
Media Card and the Voice Gateway Media Card. For more information, refer 
to IP Line: Description, Installation, and Operation (553-3001-204).

• ITG M1 IP Trunks

This application is used to configure and maintain the 8-port ITG (trunk) card 
that resides in the IPE shelf of a Meridian 1 system. The card has a 10/100 
baseT connection to carry packetized voice and fax calls over IP data 
networks, and can serve as a toll bypass to the traditional PSTN. For more 
information, refer to Meridian Internet Telephony Gateway (ITG) Trunk 1.0/
Basic Per-Trunk Signaling (553-3001-116).
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Toolbar

The OTM Navigator toolbar includes several buttons that act as shortcuts to the 
commands available in the menus. The function of each button in the toolbar 
appears when you move the mouse over the button (Figure 12).

Figure 12   OTM Navigator toolbar

Status bar

A status bar is located at the bottom of the window. To display or hide the status 
bar, use the status bar command in the View menu. 

The status bar describes actions of the menu commands as you use the mouse to 
navigate through menus. It also describes the actions of the Toolbar buttons as you 
press them. When you choose a menu command, the status bar describes the 
progress of the command while it executes. For example, the status bar shows 
Printing text when you choose Print from the File menu.

Working with the OTM System Window

From OTM Navigator, double-click the system on which you want to work. The 
System Window for that system appears (Figure 13). 
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Figure 13   System Window

OTM System window allows you to launch the following applications (some of 
these applications are purchased separately):

• Alarm Banner 

• Events

• System Terminal (Ethernet or PPP)

• System Terminal VT220 (serial)

• Station Administration

• Traffic Analysis

• Telecom Billing System

• Call Tracking
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• ESN Analysis and Reporting Tool

• Maintenance Windows

• Inventory

• LDAP Synchronization

• General Cost Allocation System (GCAS)

• Consolidated Reporting System (CRS)

• Consolidated Call Cost Reports (CCCR)

OTM System Window menus

Detailed descriptions about the functions of each command in the OTM System 
window menus are available by clicking the context-sensitive Help button in the 
toolbar.

Security management

OTM provides easy access to users for personal, system, site, or network-wide 
management of Meridian 1 and Succession CSE 1000 systems. The Administrator 
determines what level of access the users in a particular User Group have to the 
features within OTM. You also determine which sites and systems the members of 
the User Group are able to manage. It is the responsibility of the Network 
Administrator to ensure that only authorized users are able to access the OTM 
Server and its associated Meridian 1 and Succession CSE 1000 systems. This 
section outlines the issues related to security management within OTM.

Note: For information on security provided by the Microsoft Windows 
NT operating system, see “Security guidelines for Windows NT” in 
“Chapter 3: Windows NT reference” of Installing and Configuring 
Optivity Telephony Manager (553-3001-330).
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Authentication

In OTM, Windows and Web users are authenticated using the settings configured 
either on the User Authentication Web page or in the User Authentication dialog 
box. The information that appears on the Web page and in the dialog box is 
identical. The Web link to the User Authentication page is found under Web 
Administration in the OTM Web Navigator tree. The User Authentication dialog 
box is accessed from the Security menu in the OTM Windows Navigator.

The following user authentication methods are available:

• Local OTM Server account

• Windows NT Domain account

• LDAP authentication

You can select any one of the three methods or a combination of the these methods 
to authenticate users on all OTM platforms: OTM Server, OTM Windows Client, 
and OTM Web Client.

Note: For a standalone OTM system utilizing the Windows 98 operating 
system, OTM Windows users are authenticated using the information 
stored for the user’s account in the OTM Users window. This method is 
similar to the method used in previous releases of OTM.

Note: The Administrator account is always authenticated as a 
Windows NT or Windows 2000 local account. This is due to the fact that 
the Administrator account is the default account on these Windows 
platforms.

Note: The default authentication method is “Local OTM Server 
account.” Since this method does not require a search of the OTM 
Directory to find the user’s assigned User Group, the “Local OTM 
Server account” method provides the best login performance.

Note: If you choose multiple authentication methods, OTM respects the 
order configured; however, it should be noted that the best performance 
is achieved by using the “Local OTM Server account” method.
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For information on configuring authentication methods using the User 
Authentication Web page, see “User authentication” on page 356.

For information on configuring authentication methods using the User 
Authentication Windows dialog box, see “User authentication” on page 144.

Password policy

Authentication requests are passed to OTM Watchdog, which applies the 
configured authentication method and creates a session for the user. For 
authentication on “Local OTM Server account” or “Windows NT Domain 
account,” the standard Windows Security Provider is used. For authentication 
using LDAP, the Login Name and the Password are passed to the LDAP Server.

Password security during transport across the network is accomplished in the 
following manner:

• OTM Windows Client passwords are encrypted using Crypto APIs prior to 
being transmitted. The same private key is used by both the client and the 
server.

• For OTM Web Clients, by default, clear text passwords are used; however, if 
the OTM Server has the proper certificate installed, you can force the use of 
secure socket layer (SSL) encrypted transport during authentication. This is 
accomplished by protecting specific virtual directories on the OTM Server 
and selecting the “Use password encryption for selected methods” check box 
either on the User Authentication Web page or in the User Authentication 
dialog box.

Note: If password encryption is selected, Web login is performed using 
https://... instead of http://... and traffic is encrypted. The OTM Server 
automatically switches to non-SSL transport once the user is successfully 
authenticated.

Note: OTM provides a default private/public key. Use this key if you do 
not have the required certificate. OTM also includes a script to configure 
SSL processing on the appropriate Web directories.
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• If LDAP authentication is used, the following sequence is used:

— The OTM Server tests to determine whether the Directory Server offers 
SSL-based authentication.

— If SSL is supported by the Directory Server, passwords are encrypted 
before being transmitted using a Public-Private key pair negotiated 
through the LDAP mechanism.

— If SSL is not supported, passwords are transmitted as clear text.

• All passwords, including the passwords used to access the Meridian 1 and 
Succession CSE 1000 systems, are stored in the OTM database in an 
encrypted format. Crypto API, the standard Windows Security Provider 
encryption service, is used for this purpose. 

User Management

There are two major categories of users within OTM — Navigator users and end 
users. You control access for these users by configuring Navigator users in the 
OTM Users window, and end users in the Employee Editor.

Navigator users

OTM Windows Navigator and Web Navigator users are managed through OTM 
User administration. Users are created and assigned to a particular User Group. 
This User Group assignment controls access to OTM Windows and Web 
applications.

Note: OTM does not support blank passwords.

Caution: There is a known bug in Windows 2000 with Service Pack 2. If 
users set their password to blank using the Windows User Manager tool, 
they can log in with any password.

Note: In previous versions of OTM, User Groups were referred to as 
Templates in the Windows interface, and Access Profiles in the Web 
interface.
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There are two different types of Navigator users:

• Local — Local Navigator users have accounts that exist on the OTM Server. 
When a user is added, an OTM user account and a corresponding local 
Windows NT or Windows 2000 user account are created on the OTM Server. 
The new user is assigned to the selected Windows NT or Windows 2000 user 
group.

Delete an OTM user account to remove the user account from the 
Windows NT or Windows 2000 account list, as well as from all relevant 
database tables.

• Remote — Remote Navigator users have accounts that reside on a domain 
controller or in an LDAP Directory. You use OTM User administration to 
assign the Remote Navigator user’s Login Name to an OTM user group.

For information on configuring Navigator users, see “Configuring OTM 
Navigator users” on page 139.

End users

End users access the OTM Desktop Services Web site to view information on, and 
make changes to, their telephones.

Although end users can be given an OTM user account similar to Navigator users, 
they typically are authenticated via a Windows NT Domain account or an 
LDAP-compliant directory.

For end users, the following attributes are entered into the users record in the 
OTM Directory via the Employee Editor:

• Login Name — The Login Name is used to associate the end users with their 
telephones.

• User Group — The User Group assignment determines what the end users can 
view and change on their telephones.

• Reporting Access Rights — Reporting Access Rights controls access to the 
Web TBS telecom billing reports.

For information on using the Employee Editor to configure end users for access to 
OTM, see “Enable Web desktop access” on page 172.
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Login process

This section describes the activities performed by OTM to authenticate and log in 
OTM users.

1 The user accesses the Windows login dialog box or the Web login page.

2 User enter their Login Name and Password.

3 OTM performs authentication respecting the configured order.

4 If authentication is successful, User Group resolution is performed as follows:

Navigator login — Windows or Web

— If the user is authenticated using a local OTM Server account, User Group 
resolution is performed using the Windows NT or Windows 2000 Local 
Account Database.

— If the user is authenticated using a Windows NT Domain account, User 
Group resolution is performed using the OTM User database. If the User 
Group mapping is not found in the OTM User database, the OTM 
Directory is used.

— If the user is authenticated using an LDAP Directory, User Group 
resolution is performed using the OTM User database. If the User Group 
mapping is not found in the OTM User database, the OTM Directory is 
used.

End users — Web only

— User Group resolution is performed using the OTM Directory. If users are 
not found, they are assigned to the “Default” User Group.

User Groups

OTM User Groups provide the mechanism to control access to the following OTM 
resources:

• OTM Windows Navigator — Navigator and site/system level applications

Note: If the user cannot be mapped to a User Group, OTM displays the 
following message: “You have not been assigned to an OTM User 
Group. Please contact the OTM Administrator.”
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• OTM Web Navigator — Navigator and site/system level applications

• Access to Web Station Administration — Web Desktop Services for end users

In addition, OTM provides the following user management functions:

• The ability to create/delete Users and User Groups (Windows user interface 
only)

• The ability to configure Web Desktop Services for end users (Web user 
interface only)

Creating a User Group

The Windows User Group application was known as User Templates in early 
versions of OTM. New User Groups are created using an existing User Group as 
the base. See “Creating a User Group” on page 139 for the procedure to follow 
when creating a new User Group.

User Groups page in the Web Navigator

While User Groups can only be added and deleted using the OTM Windows 
Navigator, they can be modified via the User Groups page in the OTM Web 
Navigator.

The User Groups page in the Web Navigator provides access to the Java 
application that is used to configure User Group Properties. User Group Properties 
are separated into two major categories:

• Navigator — Controls access to sites, systems, and applications for both the 
Windows Navigator and the Web Navigator.

For information on configuring Navigator access using the OTM Web 
Navigator, see “Navigator access” on page 361.

• Telephones — Controls access to telephones properties for Web Station 
Administration and Web Desktop Services.

Note: This configuration can also be performed via the User Group 
Properties in Windows-based OTM. See step 4 on page 141 in “Creating 
a User Group.”
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For information on configuring telephone access, see “Telephone access” on 
page 363.

User Groups provided with OTM

The following User Groups and access definitions are shipped with OTM:

• Administrators — This User Group has read/write access to all sites, systems, 
and applications. The Administrators User Groups cannot be changed, 
renamed, or deleted.

• HelpDesk — This User Group has the following access privileges:

— Access to all Web Navigator tree items except those located under the 
Web Administration branch

— Full access to Web Desktop Services, including read/write and 
synchronization capabilities

— Full access to the Windows Navigator applications with the exception of 
ITG Services

• EndUser — This User Group has the following access privileges:

— No access to the OTM Windows or Web applications

— Web Desktop Services is read-only; however, all except 21 of the most 
commonly used features are set to “Hidden”

• Default — This User Group has no access to any OTM features or 
applications.

Migrating User Templates from earlier versions of OTM to User 
Groups

The migration from User Templates to User Groups has required that several 
changes be made to existing users profiles and access privileges. This section 
highlights these changes.

Note: The telephone access configuration can only be created and 
modified using the Java application in Web-based OTM.

Note: The other User Groups provided with OTM can be changed, but 
they cannot be renamed or deleted.
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During the installation process, all users who were assigned to the Administration 
template in earlier releases of OTM are migrated to the Administrators User 
Group. The old Administration template is deleted. Only users who were assigned 
to the Administration template in the OTM Users window are migrated 
automatically. Administration template users in the OTM Directory must be 
updated manually after the upgrade. 

The HelpDesk, EndUser, and Default User Groups are migrated to the newer 
version of OTM with their Web access rights preserved. Windows access rights 
for these groups are assigned the default values described in the previous section, 
“User Groups provided with OTM.”

Any new telephone features are assigned Read/Write access for members of the 
Administrators User Group. These new features are “Hidden” for members of all 
other User Groups.

All other templates that you may have created in earlier versions of OTM are 
migrated to User Groups in the new version with the Windows access rights 
preserved. In OTM 2.0, all access rights to Web applications for these users are set 
to NoAccess. Entries are created for these users in the Web Station database for 
telephone access; however, the access rights for the members of these groups are 
set to NoAccess.

In early versions of OTM, access rights did not exist for the ITG applications. All 
users had Read/Write access to these applications. When migrating a template 
from an earlier version of OTM to a User Group in the new version, the access 
rights for the ITG applications are set to Read/Write for members of the 
Administrators User Group and NoAccess for all other users.

The ADMIN user account from earlier versions of OTM is migrated with no 
restrictions. This account can be renamed, deleted, or modified.

Note: Use the Directory Update feature to find all users assigned to the 
Administration User Group, and perform a global change to migrate 
them to the Administrators User Group. See “Directory Update page” on 
page 335 for more information.

Note: This change only impacts access to end user Web pages.
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During the migration process, if the same user or user group exists in the 
Windows NT or Windows 2000 OS, you receive a warning message with the 
options to either Ignore or Retry. If you select Ignore, the user or user group is not 
migrated. Alternatively, you may choose to manually delete the user or user group 
from the OS, and then select Retry to proceed with the migration.

Only the four Web Station Administration Access Profiles from pre-Release 2.0 
versions of OTM (Administrators, HelpDesk, EndUser, and Default) are migrated 
to become User Groups.

User management recommendations

The Administrator user account for the Windows NT or Windows 2000 OS does 
not appear in the OTM Users window. This is to prevent users from changing the 
Administrator account password from within OTM.

Nortel Networks strongly recommends that a new user group be created in OTM 
based on the Administrators user group. OTM users should be assigned to this 
new user group instead of adding them to the Administrators user group. This is a 
security measure to ensure that a user with administrative access to OTM does not 
also have access to the OS on the OTM Server as a member of the Administrators 
group.

User Group and OTM Directory interactions

Since User Groups can be assigned to users in the OTM Directory, there are a 
number of interactions that you should be aware of when adding systems and User 
Groups in the OTM Windows Navigator.

• When you add a new system, the system’s OTM Directory is created with the 
appropriate list of valid User Groups.

• When you add a new User Group, the User Group is added to the OTM 
Directory in all of the existing systems. While this process is taking place, you 
are presented with an informational message (Figure 14).

Note: Even though it is not listed in the Users window, you can always 
use the OS Administrator account to log in to OTM.
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Figure 14   Synchronizing OTM Directory informational message

• When you rename a User Group, OTM displays the Rename User Group 
dialog box (Figure 15).

Figure 15   Rename User Group dialog box

If you select OK, the informational message shown in Figure 14 appears.

If you select Cancel, the renaming of the User group is canceled.

• When you delete a User Group, OTM displays the Delete User Group dialog 
box (Figure 16).

Figure 16   Delete User Group dialog box

If you select OK, the informational message shown in Figure 14 appears.

If you select Cancel, the User Group is not deleted.
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• You can use the Directory Update application in the Web Navigator to update 
the User Group assignment for an individual user or a group of users. For 
information on using the Directory Update application, see “Directory Update 
page” on page 335.

• You can also update a user’s User Group assignment by going to the OTM 
Directory entry for the user, and changing the User Group manually. For 
information on manually updating a User’s User Group assignment, see 
“Employee Editor” on page 169.

Authentication for Succession CSE 1000 Element Manager Web 
applications

When accessing the Element Manager Web application, the Login Name and 
Password stored for Customer 0 in the System Properties of the Succession 
CSE 1000 system is used. If the Login Name and Password are correct, the login 
page is bypassed. If the Login Name and Password are incorrect, OTM displays 
the login page.

Installation

The security infrastructure introduced in OTM 2.0 requires that certain changes be 
made in the area of installing OTM.

Fresh installation

In a fresh installation, three new user groups are created in Windows NT or 
Windows 2000. OTM utilizes HelpDesk, EndUser, and Default user groups along 
with the existing Administrators Windows NT/Windows 2000 user group.

For OTM Windows Clients, the OTM Server’s host name must be provided during 
installation. The host name is saved in the registry.

Note: This automatic login process is not available to Standalone OTM 
systems operating on the Windows 98 platform.

Note: There is no automatic login to Gatekeeper management URLs.
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Upgrade

Existing OTM Windows Templates are created as User Groups. By default, these 
groups do not have access to OTM Web Navigator applications.

A Windows NT/Windows 2000 local server account is created for each existing 
OTM Windows user. The new account is assigned to the appropriate 
Windows NT/Windows 2000 user group.

Existing OTM Telephone Access Profiles, which were based on Windows NT/
Windows 2000 user groups, are migrated from the Web Navigator database to the 
new User Group database. This assumes that the corresponding Windows NT/
Windows 2000 groups related to them already exist.

These User Groups are also migrated to the Web Station database; however, new 
User Groups do not have access to Web Station Administration. You must 
configure access to Web Station Administration using the User Groups Web page. 
See “User Groups” on page 359.

Configuring Sites, Systems, and User accounts

This section provides instructions for changing the default login password 
(Windows 98 only) and defining your own OTM sites, systems, and user accounts. 
Only OTM administrators have authorization to perform these tasks.

Caution: To ensure security, you must change the default password. 
Follow the steps in this procedure to select a new password.
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Changing the default login password (Windows 98 only)

The default login password (Admin) should be changed immediately after OTM is 
installed to ensure security. Follow these steps if you have not changed the 
password.

1 If OTM is not already running, follow these steps to start OTM and log in 
using the default login password:

• Choose Start > Programs > Optivity Telephony Manager > 
OTM Navigator.

The OTM login dialog box appears. 

• Enter the default system administrator Login Name and Password. For 
security purposes, the password does not appear as you type it in the 
Password box.

Login Name: ADMIN

Password: ADMIN  

• Click OK.

After OTM accepts your Login Name and Password, the OTM Navigator 
window opens. 

Note: The following information is applicable to Windows 98 standalone 
systems only. Windows NT and Windows 2000 users are authenticated 
using either a local account on the OTM Server, a Windows domain 
account, or LDAP. There is no default Login Name and Password for 
these systems. See “Initial log in on Windows NT and Windows 2000 
systems” on page 91 for information on logging in to non-Windows 98 
systems.

Note: The password is case sensitive, and must be entered in all 
uppercase letters.

Note: For security purposes, the password does not appear as you type in 
the Password box.
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2 In the Navigator window, choose Security > Change Password to open the 
Change Password dialog box (Figure 17). 

Figure 17   Change Password dialog box

3 Enter the old password in the Old Password box.

4 Type a new password in the New Password box.

5 Retype the new password in the Confirm Password box.

6 Click OK. 

7 A message box informs you that the password was successfully changed. 
Click OK.

8 OTM requires the new password the next time you log in.

Initial log in on Windows NT and Windows 2000 systems

Windows NT and Windows 2000 users are authenticated using either a local 
account on the OTM Server, a Windows domain account, or LDAP. There is no 
default Login Name and Password for these systems.

Any user account that is a member of the local Administrators group will always 
be able to log in to OTM, for example, Administrator. In a new OTM installation, 
use any local Administrators group account, Administrator for example, for your 
initial log in. 

After logging in to OTM for the first time, you can set up additional users and user 
groups. To add user groups, select Security > User Groups from the OTM 
Navigator window, and then select Configuration > Add User Group... from the 
User Groups window. See “Creating a User Group” on page 139 for detailed 
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instructions on adding OTM user groups. To add users, select Security > Users 
from the OTM Navigator window, and then select Configuration > Add User... 
from the OTM Users window. See “Adding a user” on page 142 for detailed 
instructions on adding OTM users.

Site and system administration

The system administrator defines the sites and systems that appear in the 
Navigator window. Sites and systems must be defined before users can connect to 
a system and perform maintenance tasks. A site typically represents a physical 
location containing one or more systems. Systems are defined as Meridian 1 or 
Generic (non-Meridian 1 systems). Succession CSE 1000 systems are defined 
using the Meridian 1 system type. The Generic system configuration provides 
access through VT220 Terminal Emulation to systems such as Meridian Mail. 
Meridian Passport and MSL-100 are examples of additional systems that you can 
add to OTM (refer to the appropriate chapter within this user guide for more 
information). The Navigator Configuration menu allows the system administrator 
to add, change, and delete sites and systems.

Adding a site

You can add up to 3000 sites to the Navigator window. 

1 In the Navigator window, choose Configuration > Add Site. The New Site 
Properties dialog box appears (Figure 18).

Note: Users that are not created from within OTM, Administrator for 
example, will not appear in the OTM Users window.

Note: For more information about the Navigator and System windows, 
see “OTM Windows Navigator” on page 65.
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Figure 18   New Site Properties dialog box

2 Enter the Site Name and Short Name (these are required fields).

The Site Name appears in the Navigator tree. The Short Name is an 
abbreviated site name that appears in the Alarm Banner.

3 In the Site Location box, fill in the site address information.

4 In the Contact Information box, fill in the contact name and related 
information. Click Apply.

5 To add a new system to this site:

a Click Add System. 

b Follow the instructions for “Adding a Meridian 1 or Succession CSE 1000 
Release 1.x system” next.

6 When you have finished entering Site information, click one of the following 
buttons to add the site to the Navigator tree:
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• OK adds the site and closes the property sheet.

• Cancel closes the dialog box without adding the site.

• Apply adds the site and leaves the property sheet open allowing you to 
add another system to this site (you may repeat step 5 to add another 
system).

Adding a Meridian 1 or Succession CSE 1000 Release 1.x system

You can add as many as 256 systems (including non-Meridian 1 systems) to a site. 
You must have administrator privileges to add a system.

1 In the Navigator window, select the desired site.

2 Choose Configuration > Add System, or use the right mouse button pop-up 
menu.

The Add System dialog box opens (Figure 19).

Figure 19   Add System dialog box

3 In the Add System dialog box, select Meridian 1, and then click OK.  

Note: If you are adding a new system from within the New Site 
Properties window, skip to step 3 in this procedure.

Note: You must select Meridian 1 as the system type for Succession 
CSE 1000 Release 1.x systems.
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The System Properties dialog box opens with the General tab displayed 
(Figure 20).

Figure 20   System Properties dialog box—General tab

4 Enter the System Name and Short Name (required fields) and other 
information as needed. Click Apply.

Note: You may need to install additional software to enable other 
system types not listed in Figure 19. Follow the installation instructions 
included with your order.
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You can make system location and contact information the same as site 
information by clicking the Same as Site check box.

5 To add a new communications profile, click the System Properties—
Communications tab.

This tab defines the types of communications profiles that can be applied to 
system applications (one profile can be used for multiple applications).

6 Click Add.

The Add Communications Profile dialog box appears (Figure 21). 

Figure 21   Add Communications Profile dialog box

Select a communications type from the Type box and enter a Profile Name, 
and then click OK to go back to the Communications tab.

Note: Bold fields indicate required information. To change a value, edit 
the field. Some fields may have a list of predefined choices. An arrow 
within a field indicates a drop-down list of choices. Press the arrow to 
select from the list. For more detailed information, refer to the online 
Help.

Note: OTM is shipped with a default communication profile. The 
Default profile is an Ethernet profile, and it cannot be deleted.
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7 Fill in the communications information for the new profile:

• For Ethernet (Figure 22):

— Select the appropriate network protocol.

— Enter the IP address that you configured on the Meridian 1 system.

— Click Apply.

Figure 22   System Properties—Communications tab—Ethernet Profile
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• For PPP (Figure 23):

— Enter all modem parameters and dial-up information.

— Select PPP in the Modem Script text box.

— Set the IP address to the local IP address, as configured on the 
Meridian 1 system.

— Click Apply.

Figure 23   System Properties—Communications tab—PPP Profile
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• For Serial (Figure 24):

— Enter all modem parameters and dial-up information.

— Select the appropriate value in the Modem Script drop-down box. 
This will usually be “None” unless a specific value is defined for your 
system.

— Click Apply.

Figure 24   System Properties—Communications tab—Serial Profile
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8 Click the System Data tab.

The System Properties dialog box—System Data tab appears (Figure 25). 
Enter the machine/system type and release version for the system, and enable 
or disable feature packages. For example, if your Meridian 1 is an Option 61C 
running X11 Release 25.25 software, use the drop-down boxes to select 61C 
in the Machine box and 25 in the Release box, and enter 25 in the Issue box. 
When you have finished entering the information in the System Data tab, click 
Apply.

Figure 25   System Properties dialog box—System Data tab
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9 Click the Applications tab.

The System Properties dialog box—Applications tab appears (Figure 26). 

This tab defines the OTM applications that appear in the System window and 
the communications profile to be used with each application. 

Note: For a Succession CSE 1000 Release 1.x system, select 11C as the 
machine type. Release 1.x systems are configured as Meridian 1 Option 
11C systems, and their Media Gateways are configured as Survivable IP 
Expansion (SIPE) Cabinets.

Note: You can copy this data directly from an installed switch by 
scheduling an upload using File > Update System Data in the System 
window. Update System Data uses the communication profile for Station 
Administration. However, you should configure the Release number here 
first to allow available applications to show up properly in the 
Applications Tab.

Note: In the System Parameters box, the PDT Password edit box allows 
you to set the Level 2 password for the Problem Determination Tool 
(PDT). If you change this password, you must manually change the PDT 
password on the system so that they match.

Note: You must enable an application for it to be available in the System 
window.

Note: Communication profile settings are defined on a site/system basis 
and are shared by the OTM Server and its Clients. Consequently, if you 
define a serial communication profile for an OTM application, then both 
the OTM Server and OTM Client PCs must have a physical serial 
connection between the site/system and themselves. An OTM Client PC 
cannot use the COM ports of the OTM Server. Any communication task 
uses the resources of the PC on which it is running.
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Figure 26   System Properties dialog box—Applications tab

To enable an application:

a Select the application in the Applications tab dialog box.

b Select a Communications Profile from the drop-down list in the Selected 
Application box.

A check mark appears next to the application and the Enabled box is also 
checked.

To disable an application:

a Select the application in the Applications tab dialog box.
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b In the Selected Application box, click the Enabled check box to remove 
the check mark.

When you have finished entering the information in the Applications tab, 
click Apply.

10 Click the Customers tab.

The System Properties dialog box—Customers tab appears (Figure 27).

Figure 27   System Properties dialog box—Customers tab
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This tab lists the customers currently defined for this Meridian 1 system. You 
can add new customers, delete customers, or review the properties of a 
selected customer. When you add a new customer, you configure the 
Meridian 1 features and numbering plans that are available to the customer. 
This information is not automatically updated on the Meridian 1 system and 
must be updated by using the LD 15 customer overlay. LD 15 is the overlay 
interface that allows customers to configure their systems on the Meridian 1. 
For more information on overlay interfaces, see the System online Help.

.

11 To add a customer:

a Click Add in the System Properties dialog box—Customers tab.

b Select a Customer number.

c Click OK.

The Customer Properties dialog box opens with the General tab displayed 
(Figure 28).

Note: Customer information is required for Station Administration/
CPND and ESN applications.
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Figure 28   Customer Properties dialog box—General tab

d Fill in the general information for the customer.

e Click the Features tab.

Note: You can copy this data directly from an installed switch by 
scheduling an upload using File > Update System Data in the System 
window. Update System Data uses the communication profile for Station 
Administration. However, you should configure the Release number in 
the System Data tab first to allow available applications to show up 
properly in the Applications Tab.

Note: Enter User information in the Scheduler System ID text box if 
you are using applications with scheduled activities, such as Station 
Administration/CPND, ESN, and Traffic Analysis.
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The Customer Properties dialog box—Features tab appears (Figure 29).

Figure 29   Customer Properties dialog box—Features tab

f Fill in the feature information for the customer.

g Click the Numbering Plans tab.

The Customer Properties dialog box—Numbering Plans tab appears 
(Figure 30).
553-3001-330 Standard 3.00 November 2002



Common services 107
Figure 30   Customer Properties dialog box—Numbering Plans tab

h Fill in the numbering plan information for the customer.

To make additional entries in the numbering plan:

— Click Add.

— Use the drop-down list to select the DN Type.

— Enter the range of DNs.

The numbering plan information is used to validate DNs in Station 
Administration.

i When you have finished entering the customer information, click one of 
the following buttons to save the information:

— OK adds the customer and returns to the System properties sheet.

— Cancel closes the dialog box without adding the customer.
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— Apply adds the customer and leaves the Customer Properties dialog 
box open so that you may add other information for this customer.

12 To delete a customer, click Delete in the System Properties dialog box—
Customers tab. A delete confirmation box opens. Click OK.

13 To modify customer information, click Properties in the System Properties 
dialog box—Customers tab. The Customer Properties dialog box opens with 
the General tab displayed. Modify information in the appropriate tabs, and 
then click OK.

14 Click the Network tab.

The System Properties dialog box—Network tab opens (Figure 27).

Note: The Network tab is used to both add and delete Survivable IP 
Expansion Cabinets and Survivable Media Gateways. On Meridian 1 
systems, all SurvivableIP Expansion Cabinets must be deleted before the 
main Meridian 1 system can be deleted.
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Figure 31   System Properties dialog box—Network tab

a If the system is a Succession CSE 1000 Release 1.x system or a 
Meridian 1 with a Gatekeeper compatible ITG node, select the 
Gatekeeper Zone from the drop-down list.  

Note: If the system does not contain a Gatekeeper-compatible ITG Trunk 
node and you continue, you add the system to a Gatekeeper Zone for 
display in the OTM Windows and Web Navigators only.

Note: For information on managing Gatekeeper Zones, see “Managing 
gatekeeper zones” on page 132.
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b If the system is not a pre-Release 2.0 Succession CSE 1000 or a 
Meridian 1 Option 11C with Survivable IP Expansion cabinets, go to 
step 15.

c If the system is a pre-Release 2.0 Succession CSE 1000 or a Meridian 1 
Option 11C that is being configured to support Survivable IP Expansion 
cabinets, click Add to add a cabinet.

The Add Survivable IP Cabinet dialog box opens (Figure 32).

Figure 32   Add Survivable IP Cabinet dialog box

d Select the Site and Cabinet number from the drop-down lists, and enter 
the System Name, System Shortname, and IP Address for this cabinet.

For additional information on Option 11C survivable expansion cabinets, 
see Option 11C Planning and Installation (553-3021-210).

For additional information on the Succession CSE 1000 Media Gateway, 
see Succession Communication Server for Enterprise 1000 Planning and 
Installation (553-3023-210).

e Click OK.
553-3001-330 Standard 3.00 November 2002



Common services 111
A new System Properties dialog box opens.

f Enter the requested information for the General and Communications tabs 
(see steps 4 through 7 in this procedure).   

g Click the Network tab. The System Properties dialog box—Network tab 
appears (Figure 33).

Note: The Applications tab settings are copied from the Main Cabinet 
system properties. If the Default Ethernet communication profile is 
selected for the applications on the Main Cabinet that are likely to be 
used by the Survivable IP Expansion Cabinets, you can click OK to add 
the SIPE Cabinet and return to the System Properties dialog box—
Network tab for the Main Cabinet (step 14b).

Note: The IP address entered in the Add Survivable IP Cabinet dialog 
box is copied into the default Ethernet communication profile.

Note: The System Data and Customers tabs are read-only. These tabs 
contain the information from the main cabinet.
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Figure 33   Survivable Cabinet System Properties dialog box—Network tab

h Select the Main Cabinet and the Cabinet Number from the drop-down 
lists.

i Click OK to close the System Properties dialog box for the Survivable IP 
Expansion cabinet and return to the System Properties dialog box—
Network tab for the Main Cabinet.

15 In the System Properties dialog box, click one of the following buttons:

• OK adds the system and closes the dialog box.

• Cancel closes the dialog box without adding the system.

• Apply adds the system and leaves the dialog box open.

• Help provides online Help.
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The new system is added to the tree under the selected site.

Adding a Release 2.0 and later Succession CSE 1000 system

You can add as many as 256 systems (including non-Succession CSE 1000 
systems) to a site. You must have administrator privileges to add a system.

1 In the Navigator window, select the desired site.

2 Choose Configuration > Add System, or use the right mouse button pop-up 
menu.

The Add System dialog box opens (Figure 34).

Figure 34   Add System dialog box

3 In the Add System dialog box, select CSE 1000 and click OK. 

Note: Pre-Release 2.0 Succession CSE 1000 systems that were added in 
an earlier version of OTM cannot be converted to a Succession 
CSE 1000 Release 2.0 system. You must delete the pre-Release 2.0 
system and add a new Succession CSE 1000 Release 2.0 system.

Note: If you are adding a new system from within the New Site 
Properties window, skip to step 3 in this procedure.

Note: You may need to install additional software to enable other 
system types not listed in Figure 34. Follow the installation instructions 
included with your order.
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The System Properties dialog box opens with the General tab displayed 
(Figure 35).

Figure 35   System Properties dialog box—General tab

4 Enter the System Name and Short Name (required fields) and other 
information as needed. Click Apply.
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You can make system location and contact information the same as site 
information by clicking the Same as Site check box.

5 To add a new communications profile, click the System Properties dialog 
box—Communications tab.

This tab defines the types of communications profiles that can be applied to 
system applications (one profile can be used for multiple applications).

6 Click Add.

The Add Communications Profile dialog box appears (Figure 36). 

Figure 36   Add Communications Profile dialog box

Select a communications type from the Type box, enter a Profile Name, and 
then click OK to return to the Communications tab.

Note: Bold fields indicate required information. To change a value, edit 
the field. Some fields may have a list of predefined choices. An arrow 
within a field indicates a drop-down list of choices. Click the arrow to 
select from the list. For more detailed information, refer to the online 
Help.

Note: OTM is shipped with a default communication profile. The 
Default profile is an Ethernet profile, and it cannot be deleted.
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7 Fill in the communications information for the new profile:

• For Ethernet (Figure 37):

— Select the appropriate network protocol.

— Enter the IP address that you configured on the Succession CSE 1000 
system.

— Click Apply.

Figure 37   System Properties—Communications tab—Ethernet Profile
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• For PPP (Figure 38):

— Enter all modem parameters and dial-up information.

— Select PPP in the Modem Script text box.

— Set the IP address to the local IP address, as configured on the 
Succession CSE 1000 system.

— Click Apply.

Figure 38   System Properties—Communications tab—PPP Profile
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• For Serial (Figure 39):

— Enter all modem parameters and dial-up information.

— Select the appropriate value in the Modem Script drop-down box. 
This is usually “None” unless a specific value is defined for your 
system.

— Click Apply.

Figure 39   System Properties—Communications tab—Serial Profile
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8 Click the System Data tab.

The System Properties dialog box—System Data tab appears (Figure 40). 
Enter the machine/system type and release version for the system, and enable 
or disable feature packages. For example, if your system is a Succession 
CSE 1000 Release 2.0, use the drop-down boxes to select CSE 1000 in the 
Machine box and 2 in the Release box. When you have finished entering the 
information in the System Data tab, click Apply.

Figure 40   System Properties dialog box—System Data tab
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.  

9 Click the Applications tab.

The System Properties dialog box—Applications tab appears (Figure 41). 

This tab defines the OTM applications that appear in the System window and 
the communications profile to be used with each application. 

Note: You can copy this data directly from an installed switch by 
scheduling an upload using File > Update System Data in the System 
window. Update System Data uses the communication profile for Station 
Administration. However, you should configure the Release number in 
the System Data tab first to allow available applications to show up 
properly in the Applications Tab.

Note: In the System Parameters box, the PDT Password edit box allows 
you to set the Level 2 password for the Problem Determination Tool 
(PDT). If you change this password, you must manually change the PDT 
password on the system so that they match.

Note: You must enable an application for it to be available in the System 
window.

Note: Communication profile settings are defined on a site/system basis 
and are shared by the OTM Server and its Clients. Consequently, if you 
define a serial communication profile for an OTM application, then both 
the OTM Server and OTM Client PCs must have a physical serial 
connection between the site/system and themselves. An OTM Client PC 
cannot use the COM ports of the OTM Server. Any communication task 
uses the resources of the PC on which it is running.
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Figure 41   System Properties dialog box—Applications tab

To enable an application:

a Select the application in the Applications tab dialog box.

b Select a Communication Profile from the drop-down list in the Selected 
Application box.

A check mark appears next to the application, and the Enabled box is also 
checked.

To disable an application:

a Select the application in the Applications tab dialog box.
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b In the Selected Application box, click the Enabled check box to remove 
the check mark.

When you have finished entering the information in the Applications tab, 
click Apply.

10 Click the Customers tab.

The System Properties dialog box—Customers tab appears (Figure 42).

Figure 42   System Properties dialog box—Customers tab
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This tab lists the customers currently defined for this Succession CSE 1000 
system. You can add new customers, delete customers, or review the 
properties of a selected customer. When you add a new customer, you 
configure the Succession CSE 1000 features and numbering plans that are 
available to the customer. This information is not automatically updated on 
the Succession CSE 1000 system and must be updated by using the LD 15 
customer overlay. LD 15 is the overlay interface that allows customers to 
configure their systems on the Succession CSE 1000. For more information 
on overlay interfaces, see the System online Help.

.

11 To add a customer:

a Click Add in the System Properties dialog box—Customers tab.

b Select a Customer number.

c Click OK.

The Customer Properties dialog box opens with the General tab displayed 
(Figure 43).

Note: Customer information is required for Station Administration/
CPND and ESN applications.
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Figure 43   Customer Properties dialog box—General tab

d Fill in the general information for the customer.

e Click the Features tab.

Note: You can copy this data directly from an installed switch by 
scheduling an upload using File > Update System Data in the System 
window. Update System Data uses the communication profile for Station 
Administration. However, you should configure the Release number here 
first to allow available applications to show up properly in the 
Applications tab.

Note: Enter User information in the Scheduler System ID text box if 
you are using applications with scheduled activities, such as Station 
Administration/CPND, ESN, and Traffic Analysis.
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The Customer Properties dialog box—Features tab appears (Figure 44).

Figure 44   Customer Properties dialog box—Features tab

f Fill in the feature information for the customer.

g Click the Numbering Plans tab.

The Customer Properties dialog box—Numbering Plans tab appears 
(Figure 45).
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Figure 45   Customer Properties dialog box—Numbering Plans tab

h Fill in the numbering plan information for the customer.

The numbering plan information is used to validate DNs in Station 
Administration.

12 When you have finished entering the customer information, click one of the 
following buttons to save the information:

• OK adds the customer and returns to the System properties sheet.

• Cancel closes the dialog box without adding the customer.

• Apply adds the customer and leaves the Customer Properties dialog box 
open so that you can add other information for this customer.

13 To delete a customer, click Delete in the System Properties dialog box—
Customers tab. A delete confirmation box opens. Click OK.

14 To modify customer information, click Properties in the System Properties 
dialog box—Customers tab. The Customer Properties dialog box opens with 
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the General tab displayed. Modify information in the appropriate tabs and 
click OK.

15 Click the Network Tab.

The System Properties dialog box—Network tab opens (Figure 46).

Figure 46   System Properties dialog box—Network tab

Note: The Network tab is used to both add and delete Survivable Media 
Gateways and Branch Offices.
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a Select the Gatekeeper Zone from the drop-down list, and enter the IP 
address or host name for the Primary Signaling Server. You can also 
define an Alternate (redundant) Signaling Server.

b To add a Survivable Media Gateway or Succession Branch Office, click 
Add.

The Add Associated Equipment dialog box opens (Figure 47).

Figure 47   Add Associated Equipment dialog box

c To add a Survivable Media Gateway:

Select Survivable Media Gateway and click OK.

The Add Survivable Media Gateways dialog box opens (Figure 48).

Note: For information on managing Gatekeeper Zones, see “Managing 
gatekeeper zones” on page 132.
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Figure 48   Add Survivable Media Gateways dialog box

Select the Site and Cabinet number from the drop-down lists, and enter 
the System Name, System Shortname, and IP Address for this Media 
Gateway.

Click OK.

For additional information on the Succession CSE 1000 Media Gateway, 
see Succession Communication Server for Enterprise 1000 Planning and 
Installation (553-3023-210).

d To add a Succession Branch Office:

In the Add Associated Equipment dialog box (Figure 47 on page 128), 
select Succession Branch Office and click OK.

A new System Properties dialog box opens (Figure 49). 

Note: A Branch Office contains a call processor for connection to the 
local PSTN and for analog devices such as FAX machines. IP telephones 
are located at the Branch Office; however, under normal conditions, call 
processing for these telephones is handled by the Call Server at the main 
office. The Branch Office and the Main Office are connected by IP 
Trunks, Virtual Trunks, or through trunks to the PSTN.
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Enter the information in the System Properties dialog box—General, 
Communications, System Data, Applications, and Customers tabs as 
outlined in steps 4 through 13 of this procedure 

For additional information on the Branch Office feature, see Succession 
Communication Server for Enterprise 1000 Branch Office Guide 
(553-3023-221).

Click the Network tab.

The System Properties dialog box—Network tab opens (Figure 49).

Note: IP telephones must be configured on both the Main Office and the 
Branch Office. Use Station Administration to add the telephones to both 
systems. You can copy and paste a telephone from one system to the 
other.

Note: Unlike a Media Gateway, a Branch Office has its own copy of call 
processing code, and may be running a different version of system 
software. For this reason, you need to configure the System Data and 
Applications tabs as you do for a Call Server.

Note: A Branch Office must be associated with a Succession CSE 1000 
Main Office and both must be in the same Gatekeeper Zone.
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Figure 49   Branch Office System Properties dialog box—Network tab

Select the Main Office from the drop-down list.

Click the Signaling Server radio button and enter the IP address or host 
name for the Signaling Server. You may also define an Alternate 
(redundant) Signaling Server.

Note: You can click Properties to display the System Properties of the 
selected Main Office.
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Use the drop-down list to select whether this Branch Office should be 
displayed as a Main Office or a Survivable Gateway in the OTM Windows 
and Web Navigators.

Click OK.

16 In the System Properties dialog box, click one of the following buttons:

• OK adds the system and closes the dialog box.

• Cancel closes the dialog box without adding the system.

• Apply adds the system and leaves the dialog box open.

• Help provides online Help.

The new system is added to the tree under the selected site.

Managing gatekeeper zones

The Gatekeeper Zones dialog box is used to add, delete, and change gatekeeper 
zones.

To add a gatekeeper zone:

1 In the System Properties dialog box—Network tab for a Meridian 1 system 
(Figure 31 on page 109) or a Succession CSE 1000 Call Server (Figure 46 on 
page 127), click Edit located next to the Gatekeeper Zone drop-down list.

The Gatekeeper Zones dialog box opens (Figure 50).
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Figure 50   Gatekeeper Zones dialog box

2 Enter a Zone Name. The Zone Name is required and must be unique. The 
Zone Name appears in the Windows and Web Navigators.

3 Enter the IP Address of the Primary Gatekeeper.

4 Enter the management URL for the Primary Gatekeeper.

5 Use the drop-down list to select the type of gatekeeper:

• CSE 1000 - for a Succession CSE 1000 call server

• CS 3000 - for a Succession CS 3000

• Other - for a third-party non-Nortel Networks gatekeeper

6 Enter a Name, Contact, and Location for the gatekeeper. These fields each 
have a maximum length of 30 characters. The Gatekeeper Name is required. 
The Contact and Location fields are optional.

7 If desired, you may assign an optional Alternate Gatekeeper to the zone by 
repeating steps 2 through 6 for the Alternate Gatekeeper.
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8 Click Add to add the new gatekeeper zone to the list.

9 Click OK to close the Gatekeeper Zones dialog box and return to the System 
Properties dialog box—Network tab.

To modify the information on a gatekeeper zone:

1 In the System Properties dialog box—Network tab for a Meridian 1 system 
(Figure 31 on page 109) or a Succession CSE 1000 Call Server (Figure 46 on 
page 127), click Edit located next to the Gatekeeper Zone drop-down list.

The Gatekeeper Zones dialog box opens (Figure 50 on page 133).

2 Select a gatekeeper zone from the list.

3 Edit the fields as desired.

4 Click Change.

5 Click OK to close the Gatekeeper Zones dialog box and return to the System 
Properties dialog box—Network tab.

To delete a gatekeeper zone:

1 In the System Properties dialog box—Network tab for a Meridian 1 system 
(Figure 31 on page 109) or a Succession CSE 1000 Call Server (Figure 46 on 
page 127), click Edit located next to the Gatekeeper Zone drop-down list.

The Gatekeeper Zones dialog box opens (Figure 50 on page 133).

2 Select a gatekeeper zone from the list.

3 Click Delete.

4 Click OK to close the Gatekeeper Zones dialog box and return to the System 
Properties dialog box—Network tab.

Adding a Generic system or device

You can add as many as 256 systems (including non-Meridian 1 systems) to a site. 
You must have administrator privileges to add a system.

1 In the Navigator window, select the desired site.

2 Choose Configuration > Add System, or right-click and select Add System.

The Add System dialog box opens (Figure 51).
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Figure 51   Add System dialog box—Generic

3 Select Generic in the System Type box.

4 Click OK.

5 Complete the System Properties—General and System Properties—
Communications dialog boxes as you do for a Meridian 1 or Succession 
CSE 1000 system. See “Adding a Meridian 1 or Succession CSE 1000 
Release 1.x system” on page 94, or “Adding a Release 2.0 and later 
Succession CSE 1000 system” on page 113.

6 Click the Application tab.

The System Properties dialog box—Applications tab for non-Meridian 1 
devices opens (Figure 52).

Note: You may need to install additional software to enable other system 
types not listed in Figure 51. Follow the installation instructions included 
with your order.
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Figure 52   System Properties dialog box—Applications tab

7 In the System Properties dialog box—Applications tab, define the 
applications available for the device as follows:

• In the System Terminal section, select the communications profile. 
Typically, this is an Ethernet profile. Once defined, the user can 
double-click the system in the Windows Navigator to launch the Windows 
System Terminal, or open a Web-based terminal window from the OTM 
Web Navigator Systems page, or both.

• In the System Application section, you have the option of launching a 
Windows executable or Web browser page for managing the device.
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If a Windows executable is selected, it can only be accessed from the 
Windows Navigator. If a URL is selected, the web site can be accessed from 
either the Windows or Web Navigators.

The availability of a terminal connection, executable, or Web site depends on 
the device.

Changing site information

You can change any information about a site, including the site name, address, and 
contact. You must have administrator privileges to change site information.

1 In the Navigator window, select the desired site.

2 Choose File > Properties, or use the right mouse button pop-up menu. The 
Site Properties dialog box opens with the General tab displayed.

3 Bold fields indicate required information. To change a value, edit the field. 
Consult the online Help for details on any field.

4 To add a new system to this site, click Add System, and fill in information for 
the new system. See “Adding a Meridian 1 or Succession CSE 1000 Release 
1.x system” on page 94, or “Adding a Release 2.0 and later Succession 
CSE 1000 system” on page 113.

5 Click one of the following buttons:

• OK saves the information and closes the dialog box.

• Cancel closes the dialog box without saving.

• Apply saves the information and leaves the dialog box open.

• Help provides online Help.

Changing system information

You can change any information about a system or its communications 
connection. You must have Administrator privileges to change any system 
information.

1 In the Navigator window, select the desired system.

2 Choose File > Properties, or use the right mouse button pop-up menu. 

The System Properties window opens. 
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3 Select the tab containing the information that you want to change. 

Bold fields indicate required information. To change a value, edit the field or 
select a different item from a field pop-up menu. An arrow within a field 
indicates a drop-down list of choices. Press the arrow to select from the list. 
Consult the online Help for details on any field.

4 Click one of the following buttons:

• OK saves the information and closes the dialog box.

• Cancel closes the dialog box without saving.

• Apply saves the information and leaves the dialog box open.

• Help provides online Help.

Moving an Option 11C or Succession CSE 1000 system

OTM does not allow you to move a Succession CSE 1000 system with associated 
Media Gateways from one site to another. This same limitation also applies to 
Option 11C systems with Survivable IP Expansion Cabinets. You must remove the 
Media Gateways (Succession CSE 1000) or Survivable IP Expansion Cabinets 
(Option 11C) before moving the Call Server (Succession CSE 100) or Main 
Cabinet (Option 11C).

Deleting a site or system

You must have administrator privileges to delete a site or system from the 
Navigator window. A record of the deletion is stored in the PC event file.

1 In the Navigator window, select the site or system.

To delete all sites and systems, select the Sites icon at the top of the tree.

2 Choose Edit > Delete.

3 Click OK to confirm.

Note: The Application data is not lost during this process.

Warning: Deletion of a site also deletes all of its systems.
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Changing your password

You can change your password at any time. If your password has expired, OTM 
prompts you to enter a new password when you attempt to log in. Refer to 
“Changing the default login password (Windows 98 only)” on page 90.

Configuring OTM Navigator users

OTM allows you to create User Groups to speed the process of adding users 
accessing the OTM Windows Navigator and certain OTM Web-based 
applications. In the User Group Properties dialog box, you define most aspects of 
a certain kind of user, such as level of access to sites and systems, and automatic 
connection to particular systems. You can create as many User Groups as you 
need. You assign individual users to a User Group when you add users to the OTM 
database.

There are two types of users — local users and remote users. Local users have 
accounts on the OTM Server. When you add a new local user, an OTM user 
account and a local Windows NT/Windows 2000 user account are created and the 
account is assigned to the specified User Group. Deletion of a user removes the 
user account from the account list in Windows NT/Windows 2000, as well as from 
all relevant database tables. Remote users have accounts that exist on a domain 
controller or in an LDAP-compliant directory. For these users, OTM is used to 
assign the Login Name for the account to an OTM user group.

Creating a User Group

1 In the Navigator window, choose Security > User Groups to display the User 
Groups window (Figure 53).

Note: Access to OTM Windows and Web applications is provided 
through the Windows NT/Windows 2000 server. A Windows NT 
Domain account or an LDAP-compliant directory can also be used to 
authenticate OTM users for Web Services. Refer to “Web Services” on 
page 317.
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Figure 53   User Groups window

2 Choose Configuration > Add User Group. The new User Group is created 
with the same access privileges as the highlighted User Group. The New User 
Group Properties dialog box opens (Figure 54).

Note: The Administrators, Default, EndUser, and HelpDesk User 
Groups are always available and cannot be deleted. You can modify all 
groups except for Administrators. The Administrators User Group has 
access to all Windows-based and Web-based OTM applications.
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Figure 54   New User Group Properties dialog box

3 Enter a name for this User Group. 

4 For each site, system, and application in the tree, use the right mouse button to 
assign user privileges (Read-write, Read-only, or No Access). Each click of 
the right mouse button causes the access privileges and corresponding icon to 
change (Table 5). Select the Administrator box, if appropriate. The site and 
system icons change to reflect the access level.

Note: Access privileges defined for sites or systems at higher levels in 
the tree structure are applied to all subordinate items.

Note: The question mark icon indicates that the sub-items belonging to 
the item displaying the question mark icon have mixed access settings.
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Table 5   Access privilege icons

5 Enter values in the Login Name and Password text boxes to allow members of 
this user group to connect to this system without having to enter a Login 
Name and Password each time they connect.

6 Click OK to save changes and close the User Group Properties dialog box.

Adding a user

1 In the OTM Users window, choose Configuration > Add User.

The User Properties dialog box opens (Figure 55). 

Icon Explanation

Read and write access

Read only access

No access

Indicates that the access privileges in the branch are 
mixed between one or more of the above levels

Note: User accounts should be added here rather than through the 
Windows NT or Windows 2000 user management tools.

Note: The “Administrator” user account for the Windows NT or 
Windows 2000 OS does not appear in the OTM Users window. This is to 
prevent users from changing the Administrator account password from 
within OTM.

Note: Even though it is not listed in the Users window, the OS 
Administrator account can always be used to log in to OTM.
553-3001-330 Standard 3.00 November 2002



Common services 143
Figure 55   User Properties dialog box

2 Select a User Type from the drop-down list.

• Local - Users who are authenticated using an account on the OTM Server

• Remote - Users who are authenticated using either a Windows NT 
Domain account or LDAP

3 Enter a Login Name.

4 From the User Group drop-down list, select the group to which this user will 
be assigned.

5 Fill in other data as required.

6 Click Apply. OTM prompts you to enter a password. 

Note: When Remote is selected, the Change Password button, as well as 
the Status and Current Status controls, are disabled.
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7 Click Change Password to change the OTM login password for this user only.

8 Click OK. The new user appears in the OTM User window. Close the OTM 
User window.

Deleting a user group

You can delete a user group only after all associated members of that group are 
either deleted or reassigned to another user group.

Restricting user access permission levels

You can restrict a user from having access to sites, systems, and applications. 
However, when a user is defined as being restricted from any access to all sites, 
systems and applications in the Navigator, the user can, in fact, see all the sites and 
systems in the Navigator tree and has read-only access to their properties. If 
restricted users try to open a system, they see a System Window with no 
applications visible.

Sites and systems displayed in user groups

When adding or modifying a user group, only systems that have applications 
enabled are presented. If no applications are enabled for the systems within a 
given site, the site and system(s) do not appear in the User Group Properties 
dialog box.

User authentication

You can select any of the following three methods or combination of these 
methods to authenticate OTM users:

• Local OTM Server account

Note: You cannot delete the account that you used when you logged in 
to your current session.

Note: For information on configuring End Users for access to the OTM 
Web site, see “Enable Web desktop access” on page 172.
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• Windows NT Domain account

• LDAP authentication   

To configure authentication:

1 From the OTM Windows Navigator, select Security > User Authentication.

The User Authentication dialog box opens (Figure 56).

Note: The Administrator account is always authenticated through the 
local server account because it is a default account on all supported 
Windows platforms.

Note: The default authentication method is the Local OTM Server 
account. This method provides the best login performance because there 
is no requirement to search the OTM directory for the user’s assigned 
User Group.

Note: You can also configure user authentication using the OTM Web 
Services. For information, see “User authentication” on page 356.
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Figure 56   User Authentication dialog box

2 Use the check boxes to select one or more of the available authentication 
methods.

a If you select Windows NT Domain account, enter one or more domains in 
the Domain text box. Separate the domain names with a comma.

b If you select LDAP authentication, use the drop-down list to choose either 
EmployeeID (uid), or EMail (email).

3 Use the drop-down lists to assign the order in which the authentication 
methods are performed.

Note: If you choose multiple authentication methods, OTM respects the 
order configured; however, it should be noted that the best performance 
is achieved by using the “Local OTM Server account” method.
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4 To use the secure socket layer (SSL) during the authentication process, click 
the “Use SSL for Web login authentication” check box.

The selected method(s) are used to authenticate users on all OTM platforms: OTM 
Server, OTM Client, and OTM Web Client.

Maintenance tasks

The following guidelines and tables indicate suggested scheduling of various 
OTM operating procedures.

Telecom Billing System

Refer to Using Optivity Telephony Manager Telemanagement Applications 
(553-3001-331) for complete details of the schedules for data collection, database 
maintenance, and data management. The database maintenance schedules 
outlined in this chapter should also be used for OTM Corporate Directories.

Call Tracking

Table 6 provides guidelines for scheduling Call Tracking maintenance tasks. 

Note: If the OTM Server has the required certificate installed, setting 
the encryption check box and protecting specific virtual directories on 
the OTM Server causes OTM to use SSL encrypted transport during 
authentication. In this case, Web login is performed using https:// rather 
than http://, and the traffic is encrypted. The OTM Server automatically 
switches to non-SSL transport once the user is successfully 
authenticated.

Table 6   Call Tracking maintenance tasks

Maintenance task Schedule

Data collection (real time) Continuously

Data collection (from a file) Hourly

Review Alarm Log No set schedule. review as needed
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Traffic Analysis

Table 7 provides guidelines for scheduling Traffic Analysis maintenance tasks.

OTM Site/System data

Table 8 provides guidelines for scheduling OTM Site/System data maintenance 
tasks.

Backup and archive Call Tracking database The main Call Tracking database is part 
of the site/system data files. This is 
backed up/archived with the other 
databases.

Restore Call Tracking database As necessary

Table 7   Traffic Analysis maintenance tasks

Maintenance task Schedule

Data collection (through direct connection to the 
Meridian 1 or Succession CSE 1000 system)

Hourly

Data collection (through buffer box or DBA) Daily

Backup/Archive Traffic database Archive the Traffic database monthly. 
Remember to purge old or unneeded 
data from the working directory during 
this Archive procedure.

Restore Traffic database As necessary

Table 8   OTM Site/ System data maintenance tasks

Maintenance task Schedule

Backup Employee database Weekly

Backup all other databases (OTM Corporate 
Directories) for site/system

Monthly

Restore databases for site/system As needed

Since the Employee database is usually edited more frequently, you should back up the 
database on a weekly instead of monthly basis (as with the other OTM databases).

Table 6   Call Tracking maintenance tasks (continued)

Maintenance task Schedule
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Compact and Repair Utility

The Compact and Repair Utility is usually not run on a set schedule. This utility is 
used to help repair and compact MS Access database files in OTM that may be 
corrupted or have taken too much disk space. You should, therefore, run this 
utility at any time you have deleted or purged a large number of records from one 
of the system databases. For example, if you deleted a large number of call records 
from the Call Database, or if you made major edits to the Employee Database 
(especially deletions), then you should run the Compact and Repair Utility 
databases. This optimizes your disk space and repairs any possible flaws in these 
MS Access database files.

Regional Settings

Currency Settings, located under Regional Settings, includes information about 
local and alternate currencies. The Optivity Telephony Manager (OTM) 
applications use this information to display costs.

Local Currency

The Local Currency tab contains information about the local currency that is used 
to display costs in the Optivity Telephony Manager (OTM) applications. This is 
useful in situations where a single system manages and processes data from many 
countries and you want to report costs in different currencies across different 
systems. Each system can represent sites in different countries. Their costs can 
then be expressed in their respective local currency.

Currency information, by default, is derived from the client PC’s regional settings. 
However, there are cases where systems are required to operate with different 
currencies. To facilitate this, OTM allows you to define currency settings for any 
system as required. In addition, you can configure default settings from the OTM 
Navigator main window, which can also be used by the OTM systems. These 
default settings are used by any system that does not have its own settings defined. 
This is useful in an installation where the majority of systems are operating in a 
common currency and only a few are operating in a different currency. In this 
case, you can set the default currency settings for the majority of the systems, and 
you only need to configure the exceptions.
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To define the local currency, select Configuration > OTM Regional Settings in 
either the OTM Navigator window or the system window. Select from the 
following options:

Use System Setting (Navigator level only): Turn on this check box to have OTM 
use the currency settings defined in the client PC’s Windows Regional Settings. 
Notice that the remaining fields are updated with the Windows Regional Settings 
currency information and appear grayed (read-only). You cannot edit these fields 
if you select this option. Since this option is only available at the Navigator level, 
you can only select this option for the Navigator main window. By default, this 
option is enabled (the check box is checked).

Use Default Setting (System level only): Turn on this check box to have the 
system use the default currency settings that you defined in the Navigator window. 
Notice that the remaining fields are updated with this default (or shared) currency 
information and appear grayed (read-only). You cannot edit these fields if you 
select this option. This option is only available from a system window.

Enter the local currency values in the following fields:

Currency Name: In this field, enter a descriptive name of this currency (for 
example, US Dollars).

Appearance Samples: These read-only fields display samples of the costs based 
on the selected currency settings (for example, $123,456.78 and ($123,456.78)).

Currency Symbol: In this field, enter the symbol for this currency (for example, 
$). The symbol appears next to the cost values on report summaries. If your 
keyboard does not support the currency symbol that you want to use, then you 
may need to enter it using alternate key codes. For example, to enter the symbol 
for the Euro dollar, press and hold the [Alt] key and enter 0128 on your numeric 
keypad. The Euro dollar symbol appears. If a black square appears instead of the 
symbol, then your system font does not support this character. It should, however, 
still appear correctly on the printed report.

Position of Currency Symbol: From this drop-down list box, select how the 
currency symbol will appear next to cost values. The “*” represents where the 
symbol appears with respect to the value. For example, *1.1 indicates that the 
currency symbol will appear before the values (for example, $1.00).
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Negative Number Format: From this drop-down list box, select how negative 
values will appear. For example, (*1.1) indicates that negative numbers appear 
with parentheses around them (for example, ($1.00)).

Decimal Symbol: In this field, enter the symbol that will be used for the decimal 
(For example, for the amount $1,000.00, enter .).

Number of Digits after Decimal: In this field, enter the total number of digits 
that will appear after the decimal (for example, for the amount $1,000.00, enter 
2).

Digit Grouping Symbol: In this field, enter the symbol that will be used to 
separate digit groups when displaying currency values (for example, for the 
amount $1,000.00, enter ,).

Number of Digits in Group: In this field, enter the number of digits that will be 
separated by the digit grouping symbol (e.g., for the amount $1,000.00, enter: 3).

Once you have entered these settings, click Apply to save them and remain in this 
tab. Click OK to save these settings and exit to the previous window.

Alternate Currency

The Alternate Currency tab contains information about any alternate currencies 
used when displaying costs in OTM reporting. This is useful in situations where 
you want to have reports display monetary values in two separate currencies. For 
example, European countries could display summary costs in their local 
currencies and in the new Euro currency.

You can either define the alternate currency settings for specific systems, or have 
them use the default settings defined in the Navigator level. The alternate currency 
defined in the Navigator window is used as the default alternate currency. Any 
systems that do not have alternate currency settings defined for them use the 
default currency settings defined at the Navigator level. As well, you can specify 
that a system should use the default currency settings.

To define the alternate currency, select Configuration > OTM Regional Settings 
from either the OTM Navigator window or the system window. Select from the 
following options:
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Use Default Setting (System level only): Turn on this check box to have the 
system use the default alternate currency settings you entered in the Navigator 
window. Notice that the remaining fields are updated with this currency 
information and appear grayed (read-only). You cannot edit these fields if you 
select this option. This option is only available from a system window.

Enable Alternate Currency (Navigator and System level): Check this check 
box to enable alternate currency settings to appear on system billing reports. If 
you disable this option (that is, uncheck this check box), the remaining fields 
appear grayed (read-only), and the alternate currency is not included in your 
reports.

Enter the alternate currency values in the following fields:

Currency Name: In this field, enter a descriptive name of this currency (for 
example, US Dollars).

Appearance Samples: These read-only fields display samples of the costs based 
on the selected currency settings (for example, $123,456.78 and ($123,456.78)).

Currency Symbol: In this field, enter the symbol for this currency (for example, 
$). This appears next to the cost values on report summaries. If your keyboard 
does not support the currency symbol that you want to use, then you may need to 
enter it using alternate key codes. For example, to enter the symbol for the Euro 
dollar, press and hold the [Alt] key and enter 0128 on your numeric keypad. The 
Euro dollar symbol appears. If a black square appears instead of the symbol, then 
your system font does not support this character. It should, however, still appear 
correctly on the printed report.

Position of Currency Symbol: From this drop-down list box, select how the 
currency symbol will appear next to cost values. The “*” represents where the 
symbol appears with respect to the value. For example, *1.1 indicates that the 
currency symbol appears before the values (for example, $1.00).

Negative Number Format: From this drop-down list box, select how negative 
values will appear. For example, (*1.1) indicates that negative numbers appear 
with parentheses around them (for example, ($1.00)).

Decimal Symbol: In this field, enter the symbol that will be used for the decimal 
(for example, for the amount $1,000.00, enter .).
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Number of Digits after Decimal: In this field, enter the total number of digits 
that will appear after the decimal (for example, for the amount $1,000.00, enter 
2).

Digit Grouping Symbol: In this field, enter the symbol that will be used to 
separate digit groups when displaying currency values (for example, for the 
amount $1,000.00, enter ,).

Number of Digits in Group: In this field, enter the number of digits that will be 
separated by the digit grouping symbol (for example, for the amount $1,000.00, 
enter: 3).

Currency Exchange Rate: In this field, enter the exchange rate for this currency 
against the local currency. For example, if the local currency is the U.S. dollar 
(US$), and the alternate currency is the Canadian dollar (Can$), and the exchange 
rate is 1.49, then enter 1.49 in this field. This means that US$1.00 is equivalent 
to Can$1.49.

Once you have entered these settings, click Apply to save them and remain in this 
tab. Click OK to save these settings and exit to the previous window.

Access Server

The Access Server provides a command line interface (CLI) for remote access to 
the OTM Server. From a remote terminal, you can dial in through a modem or 
through a direct serial connection to access the OTM Server.

Once successfully logged in, you can do the following:

• Change Windows NT user passwords.

Caution: Access Server must be run under the Windows NT or 
Windows 2000 Operating System, as it does not function properly under 
any other operating system.
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• Connect to different sites and systems as configured in Virtual Terminal 
Service. See “OTM Web Virtual System Terminal” on page 370.

CLI status window

The CLI launches at OTM Server startup. The status window displays CLI status 
messages.

To view the CLI status window:

The CLI status window opens (Figure 57).

The following status messages may appear in the CLI window:

• Waiting for incoming call

• Answer call and authentication process in progress 

Note: CLI needs a dedicated modem. CLI cannot share the modem with 
Win NT RAS or other services.

Caution: If you are not using Access Server, be certain that the Auto 
Launch check box is unchecked (Figure 58 on page 156). This action 
prevents unnecessarily tying up a COM port on the server.

From the Start menu, choose Programs > Optivity Telephony Manager > 
Command Line Interface.
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Figure 57   CLI status window

CLI configuration

The CLI configuration dialog box is used to define the following OTM Server 
COM port settings:

Port - list of COM ports on the OTM Server
Data Speed of COM port - 4800, 9600, 19,200, 38,400
Data Bits - 5, 6, 7, 8 bits
Parity - None, Odd, Even Mark, Space
Stop Bits - 1, 1.2, 2 bits
Session timeout (secs)- If current session is idle for the specified time, CLI 
disconnects the call.
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To open the CLI configuration dialog box:

The CLI configuration dialog box opens (Figure 58).

Figure 58   CLI configuration dialog box

CLI Log File dialog box

The CLI Log File dialog box allows you to turn the log option on or off and 
specify the log file location (Figure 59). The Log File logs all activities: user 
login, commands, and so on.

Select Options > Configure... in the CLI status window.
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To open the CLI Log File dialog box:

Figure 59   CLI Log File dialog box

CLI Operation

From a PC other than the OTM Server, dial into CLI on the OTM Server using 
HyperTerminal or an equivalent Telnet application. Enter an OTM Login Name 
and Password to log in. Once logged in the following commands are available:

• Help or ?- lists all commands

• Status - lists all VTS ports associated with configured systems

• Connect - connects to a system

• Exit - disconnects 

Figure 60 and Figure 61 show the CLI commands.

Select Options > Log File... in the CLI status window.
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Figure 60   CLI Help commands

Figure 61   CLI Status and Connect commands

Communication

Both the Terminal Server (OTM Server) and Terminal Client (Remote PC) can 
detect when their TCP socket connection is lost. In that case, they log the error or 
notify the user, or both, and reset themselves for another connection.
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The base port number determines the range of socket ports used to communicate 
with the Terminal Client. Under normal conditions, this should be left as is, and 
should not be changed unless the default port conflicts with another network 
application.

By default, the Terminal Server and Terminal Client communicate using network 
ports 4789 through 5045 (4789 to send connection requests, 4790-5045 for up to 
256 terminal sessions). The number of ports actually used depends on the number 
of virtual ports configured.

To change the range of port numbers:

1 From the Start menu, choose Programs > Optivity Telephony Manager > 
Terminal Server.

The Terminal Server dialog box opens (Figure 62).

Figure 62   Terminal Server dialog box

2 Click Terminals... .

The Terminal Properties dialog box opens (Figure 63).
Using Optivity Telephony Manager Release 2.0x



160 Common services
Figure 63   Terminal Properties Base Port parameter

3 Enter the new Base Port number, and then click OK.

4 Edit the HTML page containing the applet. Make sure the applet’s Base Port 
parameter matches the one in the Terminal Properties (default = 4789). 

Encryption

Data is encrypted, so that someone monitoring the network traffic does not see 
plain ASCII data (which may contain user login, password, or other sensitive 
information).

Every packet sent between the Terminal Server and the Terminal Client is 65 
bytes, and contains data that is masked with a key. This ensures that data is not 
easily readable, while keeping the overhead low for constant character I/O.

Before sending a packet, the application picks a random location in a 256-byte key 
(known only to the server and the client), and uses the subsequent bytes to mask 
the character data. In essence, every packet is masked with one of 256 possible 
keys.

Directory Services

The OTM Directory feature allows you to input end user data through the OTM 
applications, such as Station Administration and Telecom Billing System, directly 
into the customer’s server. OTM Directory contains employee and organization 
details, with a number of fields that are common to both Directory and Station 
Administration.
553-3001-330 Standard 3.00 November 2002



Common services 161
OTM Directory provides a number of tools to configure your company structure 
and create an employee database:

• An Organization Hierarchy editor to define your business organization

• An Employee Selector to manage user data

• An External Parties editor to configure external party records

• A Roles/Project editor to create role and project groups within the 
organization

• Synchronization utilities to update Station Administration with all the 
changes made to Directory data

Access OTM Directory

You access OTM Directory from within the Station Administration System 
window using one of the following methods:

• Choose Employee Selector, External Parties, Roles/Project, or Organizational 
Hierarchy in the View menu.

• Double-click an individual station in the Station Administration System 
window, and click Directory in the station graphic. The Entity Selector dialog 
box opens (Figure 64).

Note: The data is scheduled for synchronization from the Utilities menu 
in the Navigator window. See “LDAP Synchronization” on page 291.
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Figure 64   Entity Selector dialog box

• You may also access the OTM Directory from within the Telecom Billing 
System (TBS) Edit menu. For details, see “Telecom Billing System” in Using 
Optivity Telephony Manager Telemanagement Applications (553-3001-331).

Organizational Hierarchy Editor

The Organizational Hierarchy Editor allows you to create and edit the structure of 
your company. You build an organization tree representing the different 
organization nodes in your corporation, such as divisions, departments, projects, 
and project teams. You can place each organization node at its level in the 
hierarchy. After defining an organization node in the structure, you can assign 
employees to the node using the Org. Path field in the Employee Editor.

Note: The links between Station Administration and OTM Directory are 
described in more detail in “Station Administration links to the OTM 
Directory” on page 482.
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Access the Organizational Hierarchy Editor

To access the Organizational Hierarchy Editor, select Organizational Hierarchy 
under the View menu in the Station Administration window. 

The Organizational Hierarchy window is where you define the structure of your 
organization. The left side of the window shows the organization hierarchy tree. 
The right side of the window is the Employee Selector providing a list of 
employees related to the selected organization node.

Figure 65   Organizational Hierarchy Editor—Levels tab
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Define organization levels

Before you begin adding organization nodes to the tree, define the levels of the 
organizations in your company. The levels represent the structure of your 
company. For example, the company can have divisions, departments within 
divisions, and projects within departments. You can define a maximum of 20 
different levels.

1 Click the Levels tab. The tree displays the levels defined for the structure. If 
you have not yet entered the structure for your organization, the window 
contains a default menu tree with the Organization, Division, and Department 
levels.

2 Click the level where you want to define a new level.

3 Right mouse click to open the Add New Level dialog box.

4 Type the name of the new level and click OK.

To delete a level, select the entry and click the Delete key on the toolbar. 

As shown in the example in Figure 65, the levels are defined as:

• Corporation

• Divisions within the corporation

• Departments within the division

• Projects within the department

• Employee teams within the project 

Add an organization node

To add an organization node:

1 Select the Organizations tab (Figure 66).

Note: You must define an organization level before you can add an 
organization node at that level. See “Define organization levels” on 
page 164.
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2 Select the name of the organization in the tree where you want to add a new 
organization node. For example, if adding a new department to a division, 
select the name of the division.

3 Click the right mouse button and select Add New Node, or click the Add icon 
(the toolbar button with the plus sign). The new node appears in the tree. For 
example, if adding a new division, Division appears in the tree.

4 Click the right mouse button and select Rename to give the new node a name. 
Type over the name.

Figure 66   Organizational Hierarchy Editor—Organizations tab

Delete an organization node

To delete an organization node:

1 Select the organization node in the tree.

2 Click Delete (toolbar button with the X). The node disappears from the tree.
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Employee Selector Window

The right pane of the Organizational Hierarchy window consists of the Employee 
Selector window. 

This window displays the list of current Employee entities in the Directory 
database, and allows you to create a new employee entity, add it to your 
organizational node, and edit the details of an existing entity.

The icons in the Organization Hierarchy toolbar allow you to edit the Employee 
records listed or create new Employee, Roles/Projects, or External Parties records 
to be added to your organizational node. As they appear from left to right, they 
allow you to:

• Add new record: Select a record type (Employee, External Party, Role/
Project) from the Entity Selector. You can then add a new Employee record to 
the database (which opens the Employee Editor), or add a new Roles/Projects 
record (which opens the Roles/Projects Editor) or a new External Party record 
(which opens the External Parties Editor).

• Delete record: Delete the selected record from the database. See “Delete 
employees” on page 167.

• Edit Record: Edit the selected record. This opens the Employee Editor 
window, in which you can edit the Employee details 

• Find: Search for a specific record. Enter a text string and select a field from 
‘ID’, ‘Entity Type’ or ‘Name’ by which to search the database. See “Search 
for an employee” on page 168.

• Sort Ascending: Sort the employee records in ascending order. See “Sort the 
employee list” on page 169.

• Sort Descending: Sort the employee records in descending order.

• Refresh View: Refresh the list following changes.

• Move First/Previous/Next/Last: Move the cursor to the top of the list, to the 
previous entity to the one selected, to the next entity to the one selected, or to 
the end of the list.

• Help: Consult the Online Help system.

Note: The Employee Selector window also appears as an individual 
window by clicking Directory in the Station Set window.
553-3001-330 Standard 3.00 November 2002



Common services 167
Add an employee to an organization node

To add an employee to an organization node: 

1 Select the organization node in the tree.

2 Click Add (the toolbar button with the plus sign). The Entity Type Selector 
window opens.

3 You have the option to add a new Employee, External Party or Role/Project. 
When you select a type, the Editor for that type appears. In this case, select 
Employee.

4 The Employee Selector window opens. Select the employee you want to 
assign to the selected organization node.

Edit employee data

To edit employee data:

1 Select the organization node in the tree. The names of the employees appear 
in the Employee Selector window.

2 Select the name of the employee you want to edit.

3 Click Edit (the toolbar button with the pencil). The Employee Editor opens. 
See “Edit employee data” on page 176.

Delete employees

To delete an employee from an organization node:

1 Select the organization node in the tree. The names of the employees appear 
in the Employee Selector window.

2 Select the employee you want to delete.
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3 Click Delete (the toolbar button with the X). The employee disappears from 
the list.

Search for an employee

To search for a specific employee:

1 Select the organization node in the tree.

2 Click Search (the toolbar button with the flashlight). The Find and Replace 
dialog box opens (Figure 67).

Figure 67   Find and Replace dialog box

3 Select the field you want to search from the drop-down list.

Note: This action deletes the Employee from the Organizational Node, 
but the Employee Entity still exists in the OTM Directory database. The 
Entity can only be removed from OTM Directory through the Employee 
Selector window, as accessed through the Directory button in Station 
Administration. For more details on the link between Station 
Administration and OTM Directory, see “Station Administration links to 
the OTM Directory” on page 482.
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4 Enter the character string to search for in the Find What box.

5 Click one of the following buttons:

• Find First - Finds the first occurrence of the character string

• Find Next - Finds the next occurrence of the character string

• Close - Ends the search

If the search finds a match, the employee’s name appears highlighted in the 
Employee Selector window.

Sort the employee list

To sort the employee list:

1 Select the organization node in the tree.

2 Click the column header of the column you want to sort in the Employee 
Selector window.

3 Click Sort Up or Sort Down (the toolbar buttons with AZ Up or AZ Down). 

Employee Editor

The Employee Editor allows you to add new employees and update employee 
personal and job related data. The tabs on the right side of the window allow you 
to define the assets assigned to the employee. You can also define the property 
assigned to the employee, such as telephone and terminal numbers. 
Using Optivity Telephony Manager Release 2.0x



170 Common services
Figure 68   Employee Editor dialog box—Employee tab

Access the Employee Editor

There are several ways to access the Employee Editor:

• Click the Add or Edit button in the Organizational Hierarchy Editor window.

• Double-click an employee’s name in the Employee Selector window.

To add a new employee:

1 The Employee Editor dialog box opens with the Employee tab selected. The 
fields are blank. Enter the employee data as follows:

• Enter the employee information in the appropriate fields.
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• How you access the Employee Editor determines if the Org. Path field 
shows a drop-down selection box or not. If the drop-down box is active, 
the organization structure tree displays. Select the organization node for 
the employee from the tree. If the drop-down box is not active, type the 
path to the organization node for the employee. 

• The Manager field has a drop-down box where you select the employee’s 
manager.

• Click the envelope icon next to the Email field to enter the employee’s 
default e-mail address or type the e-mail address. This sends e-mail to the 
employee with a corporate LDAP compliant server.

• Click the Publish check box to share the employee information. Do not 
click the check box if the information is private.

2 Enter the asset information as follows:

• Select New Asset in the Type column. The edit boxes below the grid 
become active.

• Select the type of asset from the drop-down list in the Type field.

The asset types available identify the employee in the different OTM 
applications. Select from Account Code, Authorization Code, Extension, 
Phone Number, or Trunk Number. Based on the type selected, a 
corresponding field entry appears, into which you enter a value. 

• If the employee will be the prime user of this asset, turn on the Prime 
check box. This allows several employees to use the same asset, while one 
employee in particular is the main owner of the asset and is assigned the 
cost.

• Click the Publish check box to share the employee asset information. Do 
not click the check box if the information is private

• Click Apply.

Click one of the following buttons:

• OK - Saves the employee information and closes the window.

• Apply - Applies the information configured.

Note: Click the Publish check box to enable synchronization with an 
LDAP-compliant server.
Using Optivity Telephony Manager Release 2.0x



172 Common services
• Apply/New - Saves the employee information and leaves the window 
open. The window is blank so you can add another new employee.

• Cancel - Closes the window without saving the employee information.

• Help - Accesses the online Help system.

Enable Web desktop access

You can give EndUsers an account on the OTM Server using the same process that 
is used to allow Administrators and HelpDesk users to access the Windows and 
Web Navigators; however, EndUsers are typically authenticated through a 
Windows NT domain account or LDAP. EndUsers do not normally have accounts 
on the OTM Server. For information on configuring User Groups for Web access, 
see “User Groups” on page 359. When the Windows NT domain or LDAP 
authentication method is used, use the OTM directory to map the following 
attributes:

• Login Name - Required to associated users with their telephones

• User Group - Determines what the user can see and changes that they can 
make on their telephones

• Web Reporting Access Rights - Controls access to Web TBS billing reports

To enable Web desktop access:

1 From Station Administration, select View > Employee Selector.

2 Double click an employee’s name in the Employee Selector window.

The Employee Editor window for the selected employee opens.

3 Click the Additional Info tab in the Employee Editor dialog box. The 
Employee Editor dialog box—Additional Info tab opens (Figure 69).
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Figure 69   Employee Editor dialog box—Login Name attribute

4 Select <New Attribute> in the Attributes pane.

5 Select Login Name from the Type drop-down box.

6 Enter the user’s Windows NT Login Name for the attribute Value (If NT is the 
authentication method chosen for desktop users).

7 Click the Publish check box to enable synchronization with an optional LDAP 
compliant server.

8 Click Apply in the Attributes pane.

9 Select <New Attribute> in the Attributes pane.

10 Select User Group from the Type drop-down box (Figure 70).
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Figure 70   Employee Editor dialog box—User Group attribute

11 Select “EndUser” from the drop-down box for the attribute Value to enable 
End User Web desktop user access - both for LDAP and Windows NT access.

Select “HelpDesk” from the drop-down box for the attribute Value to enable 
Help Desk Web desktop user access - both for LDAP and Windows NT 
access.

12 Click Apply in the Attributes Pane.

13 Select <New Attribute> in the Attributes pane.

14 Select Web Reporting Access Rights from the Type drop-down box 
(Figure 71).

15 Select one of the following access levels from the drop-down box for the 
attribute Value:
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• All - Users assigned this role have the authority to view all the reports for 
the site/systems to which they are assigned. This is the access level that 
you typically assign to an Administrator.

• Peer - Users assigned this role have the authority to view the reports for 
all the entities in the same node in the Organizational Hierarchy and all its 
sub-nodes. See “Organizational Hierarchy Editor” on page 162. This is 
the access level that you typically assign to a person who manages several 
departments.

• Managed - Users assigned this role have the authority to view their own 
reports and the reports for all of the entities in the subnodes below their 
organization node in the Organizational Hierarchy. See “Organizational 
Hierarchy Editor” on page 162. This is the access level that you typically 
assign to a department manager.

• Personal - Users assigned this role have the authority to view their own 
data. This is the access level that you assign to a non-managerial 
employee.

• No Access - If no role is assigned for a user, their reporting access rights 
default to No Access.
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Figure 71   Employee Editor dialog box—Web Reporting Access Rights attribute

Edit employee data

To edit employee data:

1 Click the Employee tab in the Employee Editor window. The selected 
employee data appears.

2 Edit the employee data as follows:

• Edit the employee information in the appropriate fields.

• How you access the Employee Editor determines if the Org. Path field 
shows a drop-down selection box or not. If the drop-down box is active, 
the organization structure tree displays. Select the organization node for 
the employee from the tree. If the drop-down box is not active, type the 
path to the organization node for the employee. 
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• The Manager field has a drop-down box where you select the employee’s 
manager.

• Click the envelop icon next to the Email field to automatically enter the 
employee’s default e-mail address or type the e-mail address.

• Click the Publish check box to share the employee information. Do not 
click the check box if the information is private.

Click one of the following buttons:

• OK - Saves the employee information and closes the window.

• Apply/New - Saves the employee information and leaves the window 
open. The Up and Down arrows appear on the right side of the window. 
Use these arrows to scroll to another employee record for updating.

• Cancel - Closes the window without saving the employee information.

3 Edit the property information as follows:

• Select the property you want to edit from the list of property in the grid at 
the right of the window. The edit boxes below the grid display the current 
values. 

• Change the information in the edit boxes. If the property is new, the 
system automatically checks the Prime field

• Click Update.

Delete employee property

To delete property assigned to an employee:

1 Select the property you want to delete from the list of property in the grid at 
the right of the Employee Editor window.

2 Click the Delete key located below the grid.

Excess DN report

An employee listing in the Directory lists all the extensions associated with the 
employee. Normally, each of these extensions matches a DN in Station 
Administration. However, when a set (and with it the DN) is deleted from Station 
Administration, the corresponding entry in the Directory is not removed. The old 
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extensions remain in the Directory to provide information to billing department. 
Thus there is a possibility that some of the extensions in the Directory do not 
match with any DNs in Station Administration. These extensions are termed 
Excess DNs.

Station Administration has a facility to print off a report which lists these excess 
DNs against their owner employee.

This report can be run by selecting File > Reports > Excess DNs in the Station 
Administration window (Figure 72).

Figure 72   Excess DNs menu
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Corporate Directory

OTM’s Corporate Directory is a flexible tool for defining and generating reports 
of station data associated with a terminal number. Report data is provided by 
Station Administration. Data can include about 100 different data fields, including 
the name, extension, location, and department associated with each terminal 
number.

Defining and generating reports

To access the Corporate Directory tool:

The Corporate Directory window appears where you can view and manage 
reports. 

You can use predefined reports or define new reports.

To define a report:

The New Report property sheet appears, where you can define data fields, 
column names, column order, and directory location for the report.

To generate a report: 

1 Select File > Generate Report. 

2 Choose one of the following:

• Select Now to immediately display the report in a Microsoft Excel 
window, print the report, or save it to a file.

• Select Schedule to have the report automatically generated to a printer or 
Excel file at a later time.

Note: Corporate Directory requires that you have Station 
Administration and Microsoft Excel 95 or later. 

Select Utilities > Corporate Directory in the Navigator window.

Select Configuration > Add Report.
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You may highlight a report, and select File > Generate > Open to display the most 
recently generated version of that report.

See “Generating reports” on page 583 for more information.

Corporate Directory window

The Corporate Directory main window presents a graphical way to work with 
station information. Use this window’s commands from the drop-down menus or 
the toolbar to view, manage, and generate your reports. You see a list of 
predefined report formats the first time the main Corporate Directory window is 
launched (Figure 73).

Figure 73   Corporate Directory Window

Note: Before you can generate reports, Station Administration data 
must be downloaded from the switch and you must have at least one 
customer configured for each system.
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Each report format has the following attributes, as noted by the column headers: 

• Report Name - Names of available reports

• Type - Notes if the report is either predefined or customized

• Number of systems - Number of systems for which the report will be 
generated

• Number of Data Fields - Number of data fields in the report

• Last Generated - Date and time when the report was last generated

Working with the Corporate Directory window

Use this window’s commands from the drop-down menus or the toolbar to view, 
manage, and generate your reports.

Menu selections

Commands in Corporate Directory are available from the pull down menus. The 
tables below describe the available commands.    

Note: Double-click a report name to display that report’s property sheet. 
See “Report properties” on page 188.

Table 9   File menu selections

Selection Description

Generate Report/ 
Now

Shows a dialog box where the user selects a 
display method for the report. The user may 
display a report in a spreadsheet, print it to a 
default printer, or save it to a text file.

Generate Report/ 
Schedule

Shows a dialog box where the user selects a 
report destination and a specific date and time 
and other scheduling properties for the report.

Generate Report/
Open

Opens a previously generated and saved report 
for the selected item and displays it in a 
spreadsheet format. If no such report is 
available, a message box appears asking the 
user to verify the path and file name of the 
export file or regenerate the report.
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Properties Opens the property sheet for the selected report 
and allows the user to configure the report.

Close Saves the window’s current settings and exits 
the application.

Table 10   Edit menu selections

Selection Description

Undelete Report Recovers the last deleted user-customized 
report.

Delete Report Removes the selected user-customized report. 
Predefined reports cannot be deleted.

Table 11   View menu selections

Selection Description

Toolbar Displays or hides the tool bar. The menu shows 
a check mark next to the item when the toolbar 
appears.

Status Bar Displays or hides the status bar. The menu 
shows a check mark next to the item when the 
status bar appears.

Filter Toolbar Displays or hides the filter bar. The menu shows 
a check mark next to the item when the filter bar 
appears.

Table 12   Configuration menu selections

Selection Description

Add Report Displays a new report property sheet. Use this 
to create a customized report.

Column Name Displays a dialog box where the user defines 
column names for data fields.

Table 9   File menu selections (continued)

Selection Description
553-3001-330 Standard 3.00 November 2002



Common services 183
Toolbar

The toolbar provides another way of executing menu commands. Common tasks 
are available from the toolbar (Figure 74).

Figure 74   Corporate Directory toolbar

Table 14 describes the function of each button.

Table 13   Help menu selections

Selection Description

Help Topics Displays the index of Help topics.

What’s This Provides context-sensitive Help on the next item 
you select. Click anywhere else to go to the first 
topic in the Help topic list.

About Corporate 
Directory

Displays information about the application.

Table 14   Toolbar buttons

Button Description

Add Report

Open Report

Generate Report

Schedule Report

Delete Report
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Filter bar

Use the filter bar to show reports in the Corporate Directory window, based on 
their type. The default setting displays all reports (Figure 75).

Figure 75   Filter toolbar

The available settings are:

• All Reports: Displays all reports, predefined and customized

• Predefined: Displays only the predefined reports

• Customized: Displays only the customized reports

Pop-up menus

Pop-up menus show the available commands for a selection. Pop-up menus are 
activated by clicking the right-mouse button while the cursor is in the report list 
portion of the Corporate Directory window. Unavailable commands are dimmed. 
Menu items from the pop-up menu behave identically to the menu items in the 
pull-down menus (Figure 76).

Undelete Report

Properties: Displays information about the application

Help Topics: Displays the index of Help topics

Context Help: Provides context-sensitive help on the next item 
you select. Click anywhere else to go to the first topic in the Help 
topic list.

Table 14   Toolbar buttons (continued)

Button Description
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Figure 76   Pop-up menu

Generating reports

The Corporate Directory feature lets you view, manage, and generate reports using 
available station information from systems configured with at least one user. 
Reports can be viewed on screen, printed, or saved to a file. Report layout and 
formatting is done through Microsoft Excel. See Figure 77 for an example of a 
typical report format.
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Figure 77   Typical report format

You can either generate a report immediately or with a defined schedule with 
specific dates, times, and intervals. Generated reports use the data extracted from 
the OTM data base. These reports are automatically saved with a system default 
name to the default location unless you specify another name or location. A total 
of ten reports can be automatically saved in this manner. Subsequent saved reports 
overwrite the earliest ones saved as the system recycles through its default names.

Generate reports now

To generate a report immediately, select the report name from the window and 
click on the Generate Report Now tool bar button. This displays the Generate 
Report dialog box. Select one of the three destination options. Click OK to start 
the report generation process or Cancel to abort the process (Figure 78).
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Figure 78   Generate Report Now dialog box

Generate reports by schedule

Select the report name from the window and click on the Schedule Report tool bar 
button. This displays the Schedule Report Generation dialog box. Use this dialog 
box to select one of two destination options (Figure 79).

Table 15   Generate Report Now dialog box controls

Control Description

Generate report and display 
in MS Excel

Generates a new report and displays it in MS Excel
Note: You must have MS Excel installed and configured to 
use this option.

Generate report and send to 
printer

Generates a new report and sends it to a specified printer

Generate report only Generates a report and saves it to disk

OK Starts the report generation process and closes the 
window

Cancel Exits the dialog box without generating a report

Help Displays the online Help topic associated with this dialog 
box
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Figure 79   Schedule Report Generation dialog box

Click Schedule in this window to open the Scheduling window. Use the 
Scheduling window to specify when and how often to generate the report.

Figure 80   Scheduling window

Report properties

Each report shows a specific set of station data. Corporate Directory provides a set 
of reports whose properties are already defined. See “Predefined reports” on 
page 195. You can create customized reports for your specific needs. See 
“Customized reports” on page 196.
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View report properties by double-clicking or clicking the right mouse button and 
selecting Properties on an available report in the Corporate Directory window. 
This opens a property sheet with three tabs titled General, Data Fields, and 
Output. The property sheet contains information specific to the selected report. 

There are four buttons common to each property sheet:

• OK - Saves any changes and exits the property sheet

• Cancel - Exits the property sheet without saving any changes

• Apply -Saves the changes without exiting the property sheet

• Help - Displays Help topics for the property sheet

General tab

Use the General tab to view or define a report name. Additionally, use the General 
tab to specify multiple sites and systems for which the report will be generated. 
All available sites and systems are listed. Click on the check box next to an entry 
to include it in the report. Click on a marked check box to deselect it and exclude 
it from the report. Reports are generated with data from all included sites and 
systems (Figure 81).
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Figure 81   General Tab in the Report Properties sheet

Controls in the General tab include:

• Report Name - Displays the report name. New report names are entered here. 
Users are limited to report names of up to 100 characters.

• Save As - Saves the current report as a new customized report. The “Type” 
notation automatically changes from Predefined to Customized as needed.

• Directory Members

— Sites/System/Customer - Displays available sites and system names. 
Check boxes indicate if the site or system is included in the report.

Note: The new report name must be unique. Otherwise, the Save As 
command fails.
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— Include All - Selects all sites and systems; all boxes are checked.

— Exclude All - Deselects all sites and systems; all boxes are unchecked.

— Show Selected Only check box - Toggles the list to display selected items 
only or all items.

• Comments - Accepts user comments up to 256 characters for customized 
reports only.

• Last Updated - Displays when the last change was made to the report.

• Last Generated - Displays when the report was last generated. This field is 
empty if the report has never been generated.

Data Fields tab

Use the Data Fields tab to configure the report’s data fields and column names. 
Supported station data fields appear. See “Supported data fields” on page 197.

Click the check box to include that particular field in the report. For each data 
field, you can specify a column name; otherwise the report uses the default 
mnemonic (Figure 82).
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Figure 82   Data Fields tab in the Report Properties sheet

Controls in the Data Fields tab include:

• Data Fields - Lists all the available station data fields at the corporate level. 
Use the check box to select or deselect a data field.

• Include All - Selects all data fields; all boxes are checked.

• Exclude All - Deselects all data fields; all boxes are unchecked.

• Show Selected Only - Toggles the list to display selected items only or all 
items.

• Edit - Displays a dialog box to edit the column names for the data fields.

Output tab

Use the Output tab to define the report’s output format and export destination for 
the results (Figure 83).
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Figure 83   Output tab in the Report Properties sheet

The Output page displays the order the columns appear in the report (left to right). 
Additionally, it displays the file and path name to be used when the report is 
generated and saved to a file. Type the path and filename or use Browse to 
navigate the directory structure to find the desired file.

Controls in the Output tab include:

• Move Up - Moves the selected column name up the list by one position

• Move Down - Moves the selected column name down the list by one position

• File Name - Allows the user to enter the path and file name for the export file

• Browse - Allows the user to navigate the directory structure to search for a 
path and file name
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Upload tab

The Upload tab is used in conjunction with the Corporate Directory feature for 
M3900 Series and IP telephones. This tab only appears in the property sheet for 
the M1 Corporate Directory predefined report (Figure 84). Use the Upload tab to 
configure the target system, upload members, dialing prefix, and upload schedule. 
The Upload Members frame contains a list of available systems. Use the check 
boxes to select the systems that are to receive the corporate directory data. Once a 
system is checked, a Target Selection dialog box appears. This box contains a list 
of the available target systems. Use the check boxes to select the systems from 
which you want to collect the corporate directory data, and then click OK.

The Dialing Prefix frame allows you to set any access codes required for dialing 
between systems. Choose whether to obtain the dialing prefix directly from the 
Meridian 1 or Succession CSE 1000 system or to set the prefix manually. If you 
select the Get Prefix Manually option, you must then use the Dialing From/To 
drop-down box to select your systems and enter the dialing prefix. If no dialing 
prefix is required, you can leave this field empty. If you select Get Prefix 
Automatically, the dialing prefix is retrieved from the Meridian 1 or Succession 
CSE 1000 system.

The Upload frame allows you to schedule the upload of corporate directory data. 
If the Disable automatic upload and schedule upload time check box is not 
checked, the corporate directory data is uploaded automatically after the corporate 
directory report is generated. If this check box is checked, the Schedule button is 
enabled, and you can schedule the upload independent of the report generation.
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Figure 84   Upload tab in the Report Properties sheet

Predefined reports

In addition to the M1 Corporate Directory predefined report, see “Corporate 
Directory feature for M3900 Series and IP telephones” on page 201. Corporate 
Directory includes four commonly generated reports as predefined reports. These 
are listed below, along with their data fields and column names: 

• Automatic Call Distribution Stations report

— ACS - Position IDT

— CLS - Trunk/Call Type Access Restriction

— SPID - Supervisor Position ID
Using Optivity Telephony Manager Release 2.0x



196 Common services
— LOC - Location

— TN - Terminal Name

— LNAME - Last Name

• Telephone Directory report

— LNAME - Last Name

— FNAME -First Name

— PRIMEDN - Directory Number

— DEPT - Department

• Directory of Prime DNs report

— PRIMEDN - Directory Number

— INST - Instrument Type

— TN - Terminal Number

— LOC - Location

— LNAME - Last Name

— FNAME - First Name

• Listing of Used DNs report

— PRIMEDN - Directory Number

— LNAME - Last Name

— FNAME -First Name

— LOC - Location

— TN - Terminal Number

Customized reports

Use Corporate Directory to create new report formats for your specific reporting 
needs. On the Report Properties dialog box, select the data fields for the sites and 
systems.

You can create a customized report by starting with an existing report format. Use 
the Report Properties dialog box to revise the existing report. Be sure to save the 
customized report with a new name.

Click Add Report to create a new report. This command displays a blank Report 
Properties dialog box with all options set to “off” by default. The Report Name 
field is mandatory. The screen presents an error message if this field is left empty 
when you click OK or Apply. 
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Supported data fields

The table below lists the acronym and data fields supported by Corporate 
Directory:

Table 16   Supported data fields

Data field Description

LNAME Last Name

FNAME First Name

INST Instrument

LOC Location

DEPT Department

CNUM Customer Number

PRIMEDN Prime DN

CAT Category

USER0

USER1

USER2

USER3

USER4

USER5

USER6

USER7

USER8

USER9

Comment

EQUIPMENT Equipment

SSTAT Sync Status

AOM Number of Add on Modules

ECOST Equipment Cost

COSTID Cost ID

DIV Division

DIGS Dial Intercom Groups
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ACDS Key Assigned to Automatic Call Distribution 
(ACD)

ADN All Directory Numbers

EHTK External Hunt DN

EFDK External Forward DN

AAA Automatic Answer Back

AEFD Alternate External Flexible Call Forward

AEHT Alternate External Hunt DN

AGTA ACD Agent Analog Telephone

AHNT Alternate Hunt DN

ALDR M3000 Directory Lock - Discontinued

AOS observation of Supervisor

AUTU Station Specific Authcodes

CCSA Controlled Guest Telephone

CDEN Card Density

CFHA Call Forward/Hunt Override

CFTA Call Forward by Call Type

CFXA Call Forward External

CLS Trunk/Call Type Access Restriction

CNDA Call Party Name Display

CNIA Call Number Information

CRCS Flexible Code Restriction Class

CWA Call Waiting - from Incoming Trunk

CWNA ACD Call Waiting Notification Set

DDGA Present/Restrict Calling Number

DDS Digit Display

DELA Dealer Allowed

DES 1–6 Character Designator

DIG Dial Intercom Group<space>Member

DN Station Directory Number

DNDA Dialed Number Name Display

Table 16   Supported data fields (continued)

Data field Description
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DPUA Directory Number Pickup

EFD CFNA DN for External Calls with CFTA

EHT Hunt DN for External Calls with CFTA

FBA Call Forward Busy for DID Calls

FCAR Force Charge Account

FDN Flexible Call Forward No Ans DN

FNA Call Forward No Answer

GPUA Group Pickup

HBTA Hunt by DID Call Type

HFA Hands Free

HSPA Hospital Room with DID Management

HTA Hunting

HUNT Hunt DN - All Calls, or Internal Calls Forward

IAMA Intercept Computer Answering Machine

ICT Intercept Computer Terminal/Printer

IPNA Intercept Position

IRGA Intercept Computer Interrogation Set

LANG Language for Automatic Wake Up

LDN Departmental LDN

LHK Last Hunt Key for Short Hunt

LNA Last Number Redial

LPA Message Waiting Lamp

MCRA Multiple Call Arrangement DN

MCTA Malicious Call Trace

MLWU_LANG Language for Automatic Wake Up

MRA Message Registration

MTA Maintenance Set

MWA Message Waiting at Message Service

NAMA Present/Restrict Calling Name

NCOS Network Class of Service

Table 16   Supported data fields (continued)

Data field Description
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PDN Calling Line ID from Prime DN

PRI ACD Agent Priority Level

PUA Call Pickup

RCC Restricted from Receiving Collect Call

RNPG Ringing Number Pick-up Group

RTDA Call Redirection by Time of Day

SCPW Station Control Password

SFA Second Level CFNA

SFDN Secretarial Forwarding DN

SFLT Secretarial Filtering Boss/Secretary

SGRP Scheduled Access Restriction Group

SPID Supervisor Position ID

SPV ACD Supervisor/Agent

SSU System Speed Call List Number

TEN Multi-Tenant Number

TENA Tenant Service

TGAR Trunk Group Access Restriction

TN Terminal Number

TSA Three Party Service

USMA Meridian 911 Position

VISI Visiting Portable

VMA Virtual Message Agent

WRLS Wireless

XLST Pretranslation

XRA Ring Again

Table 16   Supported data fields (continued)

Data field Description
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Corporate Directory feature for M3900 Series and IP telephones

The Corporate Directory feature allows M3903, M3904, M3905 and IP telephone 
sets to display and access a corporate-wide directory. For this feature to function 
across a network of Meridian 1 and Succession CSE 1000 systems, each system 
must access corporate directory data from the other Meridian 1 and Succession 
CSE 1000 systems on the network. For a description on how to use the Corporate 
Directory feature on the M3903, M3904, and M3905 telephones, see M3900 
Series Meridian Digital Telephones; Description, Installation, and Administration 
(553-3001-216). For information on IP telephones, see Internet Terminals: 
Description (553-3001-217).

OTM Corporate Directory supports combining station data from multiple 
Meridian 1 and Succession CSE 1000 systems, and uploading this data to a 
Meridian 1 or Succession CSE 1000 system. The Corporate Directory feature 
allows you to select from which systems the data will be collected, the “target” 
systems, and to which systems the data will be uploaded, the “upload members.”

When a system is newly configured, the Corporate Directory database does not 
exist. You must use OTM to extract the Station Administration data from the OTM 
database to form a new database called the Corporate Directory database. Extract 
data from the following fields: name, phone number, listed directory number, 
customer number, and department number. The Corporate Directory database is 
then uploaded to the Meridian 1 or Succession CSE 1000 system where it 
becomes activated for use by that system’s M3903, M3904, M3905, and IP 
telephone users. You should update the Corporate Directory database with the 
latest Station Administration data on a regular basis. Regular updates to the 
Corporate Directory database ensure that telephone user additions and deletions 
are captured. You can manually schedule the update for a predefined time, or to 
automatically occur after the OTM report is generated.

Requirements

1. Upload members (systems to which the corporate directory data will be 
uploaded), must be X11 Release 25 or higher for Meridian 1 systems. Upload 
members that are Succession CSE 1000 systems must be Release 2.0 or higher 
and must be equipped with IP Line 3.0.
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2. Target systems can be Meridian 1 systems on any X11 release or Succession 
CSE 1000 systems. Station data from target systems will come from the OTM 
Station Administration database for those systems. Be sure the station data is 
synchronized with the Meridian 1 or Succession CSE 1000 system by retrieving 
station data from within Station Administration.

Upload configuration

The Corporate Directory upload is configured using the predefined M1 Corporate 
Directory report in OTM Corporate Directory. To configure the upload:

1 From the OTM System window, select Utilities > Corporate Directory.

The Corporate Directory window opens (Figure 85).

Figure 85   Corporate Directory window

2 In the Corporate Directory window, select the M1 Corporate Directory 
predefined report.
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You cannot add a new field, modify the existing fields, or delete any fields in 
this report.

3 Use one of the following three methods to access the report properties 
window:

• Double-click on the highlighted line.

• Click on the properties button in the toolbar.

• Select File > Properties. 

Any of these selections display the report properties.

4 Click the General tab.

The Directory Members list shows the systems that are available to configure 
(Figure 86).

Note: It is very important that you select the M1 Corporate Directory 
Predefined report. This report is the only report that can be uploaded to 
Meridian 1 and Succession CSE 1000 systems for use with the Corporate 
Directory feature.
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Figure 86   General tab in the Report Properties sheet

5 Check the boxes corresponding to the systems from which you will be 
collecting data.

6 Click the Upload tab to configure the upload members, target systems, dialing 
prefix, and upload schedule (Figure 87).

Note: The Data Fields and Output tabs are fixed: you cannot change the 
information in these tabs.
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Figure 87   Upload tab in the Report Properties sheet

The Upload Members frame contains a list of available Meridian 1 and 
Succession CSE 1000 systems.

7 Check the boxes corresponding to the systems to which you want the 
corporate directory data uploaded.

Once a system is checked, a Target Selection dialog box appears with a list of 
available target Meridian 1 and Succession CSE 1000 systems (Figure 88).
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Figure 88   Target Selection dialog box

8 In the Target Selection dialog box, check the Meridian 1 and Succession 
CSE 1000 systems from which you want to collect the corporate directory 
data.

9 Click OK.

The Dialing Prefix frame allows you to set any access codes required when dialing 
between systems.

10 Click the appropriate radio button to choose whether to get the dialing prefix 
automatically from the Meridian 1 or Succession CSE 1000 system, or to set 
the prefix manually.

• If you choose the Get Prefix Manually option, you must then use the 
Dialing From/To drop-down box to select your systems, and then type in 
the dialing prefix.

• If you choose Get Prefix Automatically, the dialing prefix is retrieved 
from the system, but the upload may take longer than using the Get Prefix 
Manually option.

Note: If no dialing prefix is required, such as when you are using 
Coordinated Dialing Plan, where no extra digits are required to call 
between systems, you can leave this field empty. 
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The Upload frame allows you to schedule upload of corporate directory data.

11 Determine whether you want to automatically upload data or schedule the 
upload to occur at a specific time:

• If the Disable automatic upload and schedule upload time check box is 
unchecked, the corporate directory data is uploaded automatically after 
the corporate directory report is generated.

• If the Disable automatic upload and schedule upload time check box is 
checked, the Schedule button becomes enabled and you can schedule the 
upload to occur separately from the report generation.

Report Generation and Upload

To generate a corporate directory report and upload the data to the upload 
members:

You can choose to run the report now or schedule the report to run later. If you 
have automatic upload enabled, the upload occurs when report generation 
completes.

Dialog boxes indicate the progress of report generation and upload as these tasks 
run. The amount of time it takes to upload the corporate directory data differs 
based on the number of stations you are uploading. Also, if you have chosen to get 
the dialing prefix automatically from the Meridian 1 or Succession CSE 1000 
system, the upload takes longer than the manual method.

Note: If automatic upload is not disabled, your request is sent to the 
scheduler queue after the report is generated. The scheduler executes the 
task within the next minute. If there are tasks in the queue that have a 
higher priority and are scheduled to be executed at the same time, they are 
executed first.

Choose File > Generate Report.

Note: If you select Now, your request is sent to the scheduler queue, 
which executes the task within the next minute. If there are tasks in the 
queue that have a higher priority and are scheduled to be executed at the 
same time, they are executed first.
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Once the upload is complete, open the file Uploader.log in the Local Data 
directory to check the upload status. The contents of this file indicate whether the 
upload was successful.

Event Log Viewer

This section contains a general overview of the Event Log Viewer. It describes its 
functions and purpose. For complete details on how to use the Event Log Viewer, 
refer to the online Help.

Overview

Use the Event Log Viewer to view the records of all operations that are run from 
the Optivity Telephony Manager. The Event Log Viewer displays the event 
records stored in the Event Log. The Event Log Viewer also has features such as 
event sorting and filtering.

Interface

Select Event Log Viewer from the Maintenance menu of the OTM Navigator 
window. The main window of the Event Log Viewer displays the Event Log data 
in a report layout (Figure 89). Column headings display text describing the 
meaning of the data it contains. You can change the size of columns by dragging 
on the divisions that separate the headings.
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Figure 89   Event Log Viewer window

File menu

The File menu contains commands to open and close Event Logs, print Event Log 
reports, and maintain the Main Event Log.

View menu

The View menu commands allow you to change the way you view an Event Log.
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Options menu

The Options menu allows you to save the settings you entered in the File and View 
menus.

Tools menu

The Tools menu allows you to access the SNMP Trap Setting window (Figure 90).

Figure 90   SNMP Trap Setting window

The Trap Setting option enables SNMP Trap Setting and contains the following 
options:

Trap Source:

Agent IP Address: An agent is an SNMP entity located on the managed node. 
The Agent IP Address is the IP address of the agent entity (that is, the equipment 
sending the trap). 
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Enterprise OID: The Enterprise OID is a unique value assigned to your 
organization by the Internet Assigned Number Authority (IANA).

Trap Destination:

Manager IP Address: The Manager IP Address is the IP address of the PC that 
hosts the target SNMP Manager and receives the trap. The Manager IP address is 
typically the IP address of the OTM Server.

Community Name: This name identifies the community string. The default name 
is “Public.”

Timeout: The Timeout value is a time interval in milliseconds and determines the 
length of time that applications wait for an SNMP agent entity to respond to a 
request. 

Number of Retries: The number of times the system attempts to connect to the 
SNMP Manager.

Trap Option:

Critical Events: This error indicates that the event resulted in a loss of data or 
system functionality.

Major Events: This error indicates the termination of a process that can result in 
other processes being terminated (for example, a corrupt DLL).

Minor Events: This error indicates that the event was not necessarily significant 
but might point to possible future problems.

System Terminal

System Terminal helps you perform overlay-based tasks directly through the 
Meridian 1 TTY interface. System Terminal provides online, context-sensitive 
Help for overlays, prompts, and error messages. System Terminal also provides a 
terminal emulation capability.

In the Web environment, Terminal Client provides the same functionality as 
System Terminal. For information on Web Virtual System Terminal, see “OTM 
Web Virtual System Terminal” on page 370.
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There are two versions of System Terminal to support two different connection 
types—Ethernet or PPP and Serial—as follows:

• Overlay Passthru is available on X11 release 22 and later systems connected 
to OTM using Ethernet or PPP. Overlay Passthru only supports access to the 
overlays. 

• VT220 provides similar functions for any Meridian 1 system using serial 
connections, as well as terminal emulation for all application modules (such 
as Meridian Mail). VT220 is discussed in “VT220” on page 223.

In Release 22 and later Meridian 1 systems, you access the overlays using the 
System Terminal (Ethernet or PPP required) and access the application modules 
via VT220. In pre-Release 22 Meridian 1 systems, you access both the overlays 
and application modules via VT220.

Launching System Terminal (Ethernet or PPP required)

Once you connect to the system of interest, to launch System Terminal:

1 Select System Terminal from the Maintenance menu or toolbar in the System 
window. 

2 Enter your system Login Name and Password in the System Login dialog box. 
Figure 91 shows the System Terminal window.
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Figure 91   System Terminal window

The System Terminal window displays all system events as they occur. It also 
gives you direct access to any overlay.

Note: For Ethernet or PPP connections, each active System Terminal 
connection requires a pseudo-TTY (PTY) port. PTYs are software-only 
I/O ports. The System Terminal and Maintenance Windows applications 
use these ports to access the overlays.

Note: Ethernet and PPP are available only for X11 Software Release 22 
and above with packages 296 and 243 equipped.
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Configuring a pseudo-TTY (PTY) port

OTM applications require that you configure a pseudo-TTY (PTY) port on the 
Meridian 1 or Succession CSE 1000 system for access to the overlays. TTY ports 
differ from PTY ports in that a TTY port has physical hardware that interfaces 
with an external device. A PTY port is a software emulation of a serial port 
connection to a device or application through an IP network.

To configure a PTY port in LD 17, you must have an unused device number 
(DNUM) available. There are 16 DNUMs available on the Meridian 1 or 
Succession CSE 1000 system that must be shared by all input/output devices. 
These device types include TTY, PRT, PTY, AML, and DCH.

To configure a PTY port with LD 17:

1 In the OTM system window, on the toolbar, click the System Terminal icon.

The System Terminal Selection dialog box opens.

2 Click Ethernet/PPP (Overlay Passthru), and then click OK.

The System Terminal window opens.

3 Log in with your administrator’s Login Name and Password. 

You must have appropriate access privileges to use LD 17.

4 Enter:
ld 17

The system responds REQ.

5 Enter:
chg

Note: Physical TTY ports do not need to be installed to support PTY 
ports. There is no connection between these two types of ports. The 
primary requirement is that you have a device number (DNUM) 
available for configuring the PTY port.

Note: Option 11C and Succession CSE 1000 systems can be configured 
to support a maximum of four PTY ports.
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The system responds TYPE.

6 Enter:
cfn

The system responds ADAN.

7 Enter:
new tty <n>

where n is a device number between 0–15. The system responds TTY_TYPE.

8 Enter:
pty

The system responds PORT.

9 Enter:
<n>

where n is an available port between 0–15 for most large Meridian 1 systems. 
This range varies according to the system option and card/port type. For 
Option 11C and Succession CSE 1000 systems, this range is limited to 0–3. 
The system responds DES.

10 Enter:
ether

This is a suggestion. You can enter any name that you want to use to describe 
the port. The system responds FLOW.

11 Enter:
no

The system responds USER.

12 Enter:
mtc bug sch

The system responds TTYLOG.

Note: It does not matter which user types you enter. OTM makes any 
required changes when you establish a connection. For example, when 
the Station Administration application accesses a Meridian 1 over a PTY 
port, only the user type SCH is set for the PTY port.
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13 Enter:
no

The system responds BANR.

14 Enter:
yes

15 Log out and close the system terminal window.

To determine how many PTY ports you need to support OTM, determine how 
many OTM clients need to access the Meridian 1 or Succession CSE 1000 system 
at the same time. In a normal environment, two or three PTY ports should be 
sufficient. If you have configured three PTY ports, and all three of the ports are in 
use, a fourth user attempting to access the system receives a message requesting 
that they try the connection later.

OTM has been designed to make efficient use of the available TTY ports. Most 
OTM applications access a system on an “as required” basis. These applications 
include Station Administration, CPND, ESN, Corporate Directory, Database 
Backup and Restore, and Traffic. The applications make an Ethernet connection to 
a system and set up a virtual serial connection for access to the system overlays as 
required.

Applications such as Alarm Banner, Event Browser, and DBA do not require a 
PTY port. A special interface exchanges data between the system and OTM for 
these applications. There are two exceptions: Overlay Passthru/Virtual Terminal 
and Maintenance Windows. For Overlay Passthru and Virtual Terminal, when a 
connection is requested, the connection is established between OTM and the PTY 
port on the system. This port is locked until the connection is terminated. 
Maintenance Windows does not require access to a PTY port when the application 
is launched. When you execute a maintenance overlay command, a connection is 
established to execute the command. Once the command has been executed, the 
connection is terminated.

OTM System Terminal window

The System Terminal window includes the following:

• An Enter Command edit box in which you type overlay commands

• A Command Results list box that displays your interaction with the overlays 
and the results
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• Links to online Help are available for the following:

— Help on the current overlay

— Help on the current prompt

— Help on the last or selected error message

— One-line description of prompts in the status bar

You use overlays just as you did before a system management tool was available. 
The one minor difference is that you type into an edit box rather than the last line 
of the screen as with TTY and Terminal Emulation applications. You still use the 
<Enter> key to send the typed-in data (an overlay command or response to a 
prompt).

Using System Terminal

You can do the following from System Terminal:

• Load an overlay as you normally would on a TTY or Terminal Emulation 
application.

• Cut or copy system events or overlay command results to the clipboard.

• Save or capture the command results to a file.

• Get help on a Meridian 1 error message.

• Get help on an overlay.

• Get help on a prompt.

• Monitor system events.

Advantages over a TTY

You now have the following advantages over the old TTY:

• You can type in lower case and use the backspace key.

• Copy and Paste in the Enter Command box (useful for repeated commands 
with only a TN change).

• Scroll back in the command results.

• Copy and Print the command results.

• Capture output to a file as well as to the screen.

• Save the command results to a file.
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Getting help on the current overlay

You can get more help on the currently loaded overlay using the Current Overlay 
command in the Help menu. The Help file is organized in a similar fashion to the 
Meridian 1 system’s Software Input/Output Guide (553-3001-311 and 
553-3001-511), and the Succession CSE 1000 system’s Software Input/Output 
Guide (553-3023-311 and 553-3023-511).

Example:

If you are in overlay 10, you can select Current Overlay from the Help menu, and 
then navigate within Help to the CPND prompt sequence. You can click any 
prompt in the sequence. This displays the Help window for that prompt—the same 
as Help on Current Prompt.

Getting help on the current prompt

Figure 92 shows an example of the Help you can get on an administration overlay. 
You load the overlay and respond to the prompts, one at a time. This Help guides 
you as you load the overlay and respond to the prompts.

Note: The Current Overlay button or menu item is disabled when you 
are not in an overlay.
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Figure 92   Current prompt help example

If an overlay is currently loaded, the Status Bar at the bottom of the window 
provides a short description of the current prompt.

If the one-line description is not enough, you can read a full description of the 
prompt in OTM Windows Navigator Help. Choose Current Prompt from the Help 
menu.

To get help on any other prompt, choose I/O Navigator from the Help menu.

Getting help on an error message

System Terminal can distinguish error messages from the other text in the 
Command Results list box. The Error Message command in the Help menu 
provides the error description in OTM Windows Navigator Help.

You can get help on an error message in the following ways:

• Double-click an error message anywhere in the Command Results.

Note: Help on the current prompt is disabled if you are not in an 
administration overlay.
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• Select the Error message command in the Help menu to get help on the last 
error message (even if it is scrolled off the screen).

• Select an error message anywhere in the Command Results, and then select 
the Error message command in the Help menu.

• Select the I/O Navigator from the Help menu.

The error message Help window appears when you select the Error message 
command in the Help menu.

System Terminal menus

Detailed descriptions about the functions of each command in the System 
Terminal menus are available by clicking Context-sensitive Help in the toolbar. 
System Terminal menus consist of:

• File

• Edit

• View

• Help

Toolbar

The System Terminal toolbar offers several useful shortcuts to the menu 
commands (Figure 93). 

Figure 93   System Terminal toolbar

Note: You can also get Help on Meridian Mail System Error and Event 
Reporting (SEER) messages using the I/O Navigator.

Note: The Find and Find Next icons in the toolbar allow you to search 
the Command Results for the text string that you enter in the Find box. 
Find is case sensitive. The search begins at the current location.
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Using the I/O Navigator

The I/O Navigator displays a dialog box that allows you to quickly jump to help 
on any overlay, prompt, command, or error message. Select I/O Navigator from 
the overlay’s Help menu or from the I/O Navigator buttons in the appropriate Help 
files.

The I/O Navigator allows you to navigate through I/O reference Help independent 
of your current context within the overlays. For example, you do not need to be 
logged into a system to look up an error message using the I/O Navigator 
(Figure 94).

Figure 94   I/O Navigator dialog box

1 Type the overlay number, error message number, or prompt in the text entry 
field 

2 Click OK. 

Help information for the specified overlay, prompt, or error message appears.

The Topics button displays the general reference Help index (Figure 95).
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Figure 95   Example Help Index for an error message

The Cancel button cancels a search.

Enter an overlay (LD XX) or error code mnemonic (ERR, BUG) to go to the 
contents page of the appropriate Help file. Enter the error code (BUG3001) or 
an LD number, and a prompt takes you to the Help topic page.

• If the prompt or error message you specify does not exist, the Help search 
dialog box appears with the nearest match selected.

• If the overlay number or error message type do not exist, a “Help file not 
found” information dialog box appears.

• The I/O Navigator command can be used from within Help. You do not 
need to be connected to a switch.

• There are some combination overlays (for example, one Help file 
describes two overlays). You can enter either of the overlay numbers. 
These cases are:

— LD 36 and LD 41

— LD 40 and LD 42
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— LD 20, LD 21, and LD 22

— LD 84 and LD 85

• Leading zeros are not required in error messages. For example, entering 
SCH22 or SCH022 finds the description for SCH0022.

• To look up Meridian Mail System Error and Event Reporting (SEER) 
messages, enter XXXYY (where XXX is the message class, and YY is 
the message number—no mnemonic is required). For example, enter 
11102.

VT220

The VT220 application models the VT100/220/320 series of terminals to set up 
communications between your PC and the Meridian 1 system. With VT220, you 
can connect to the Meridian 1 system using a serial, PPP (point to point protocol), 
or Ethernet connection. It supports the transfer of ASCII data during a 
communications session and provides normal TTY and VT220 access to overlays 
that are not supported by the OTM applications.

Features

VT220 supports the following features:

• Double-height, double-width, blinking, bold and underlined characters

• Complete graphic character set, including a special font for representing 
control characters

• Scrolling regions

• 80 and 132 column modes

• Echo, no echo, local mode, and autowrap on/off

• Reverse video characters and reverse video screen

• Cursor types—block, underline, vertical line, or none

• Selectable cursor blink rate

• User-definable Tab stops

• Programmable function keys

• Display control mode

• National character sets
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Accessing VT220

Before accessing VT220, you must first select the type of terminal emulation 
session you require. To do so, perform the following steps:

1 Click once on the system name in the OTM Navigator to highlight it, and click 
Properties from the File drop-down menu (or simply right-click on the system 
name and click Properties).

2 From the System Properties window, click the Communications tab and select 
the desired settings file from the Terminal Emulation VT220 Settings 
drop-down list box (e.g., MMAIL.INI).

3 Click the Applications tab and click once on System Terminal (VT220) in the 
Applications list box to highlight it.

4 Select a communications profile for System Terminal (VT220) by clicking on 
the desired profile name in the Communications Profile drop-down list box.

5 Click OK to select these settings and return to the OTM Navigator.

To access VT220, perform the following steps:

1 From the OTM Navigator, select the desired site and system and click System 
Terminal from the Maintenance drop-down menu.

2 From the System Terminal Selection dialog box that appears, click Serial 
(VT220), and then click OK.

VT220 attempts to connect to the terminal based on the communications 
criteria entered in the System Properties Serial Communications Profile for 
this system. Once it establishes this connection, the VT220 main window 
appears listing the commands and graphical tools required for the emulation 
session (Figure 96). 
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Figure 96   VT220 window

The following sections briefly list the main functions of VT220:

File menu

The File menu contains functions used to save the VT220 configuration, print the 
contents of the terminal window, record and replay VT220 terminal emulation 
sessions, and close the system.

The following is a summary of these functions:

• Save Configuration

• Save Configuration As

• Print

• Print Setup

• Printer Fonts

• Capture

• Playback

• Close
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The Save Configuration and Save Configuration As menu items are only available 
if you have selected a user-defined terminal type (as defined as the Other VT220 
type from the OTM System Properties Communications tab). Otherwise, they 
appear grayed.

Edit menu

The Edit menu contains editing commands used to manipulate the text appearing 
in the main window.

The following is a summary of these functions:

• Copy

• Paste

• Select All

Configuration menu

Once you start VT220 from the system window of the OTM Navigator with a user 
defined type of terminal (as defined as the Other VT220 type from the OTM 
System Properties Communications tab), then you can use the Configuration 
functions to customize the VT220 settings to suit your needs. The purpose of 
having the Other type is to allow you to create multiple types of settings based on 
generic settings.

If you do not select Other or a user-defined type, then you do not require these 
functions to run VT220. The Configuration command, therefore, appears grayed.

Before you can customize the VT220 settings, you must first select the custom 
VT220 settings file OTHER.INI using the Communications tab from the OTM 
Navigator System Properties application. Refer to “Accessing VT220” on 
page 224 for more details on selecting this option. This file appears in the VT220 
settings drop-down list box. When you launch VT220 from this customizable 
terminal, you can then use the commands which appear in the Configuration 
drop-down menu to change the settings for VT220.

Once you have edited the VT220 settings using these functions, you must then 
save the customized configuration file using the Save Configuration As command. 
Use this command to enter the name of this configuration file for use in later 
sessions.
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VT220 includes a number of setting files that are predefined, depending on the 
system to which you are connected. For example, M1.INI is a predefined setting 
file used for a VT220 terminal emulation session with the Meridian 1 system, and 
MMAIL.INI is a predefined setting file for Meridian Mail. These setting files 
provide the required VT220 settings and cannot be edited.

The following is a summary of the Configuration functions:

• Terminal Setup

• National Replacement Character Set

• Map Keyboard

• Program Keys

• Tab Setup

• Options

• Status Bar

View menu

The View menu contains toggles to adjust the display of the VT220 window, as 
well as hide and display the Tool Bar, Status Bar, and Keys Window.

The following is a summary of these toggles:

• Terminal

• Hide/Show Tool Bar

• Hide/Show Status Bar

• Hide/Show Keys Window

Terminal menu

The Terminal menu contains commands used to connect and disconnect VT220 
for a temporary communications setup. The Connect and Disconnect commands 
start and stop the terminal emulation. The Temporary Communication Setup 
function temporarily creates a terminal emulation session based on customizable 
connection criteria. This setup is only temporary for the current session. When 
you access VT220 again, it uses the criteria defined for this system in the OTM 
System Configuration function.
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The following is a summary of these commands:

• Connect

• Disconnect

• Temporary Communication Setup

Help menu

In addition to the standard online help features for VT220, this Help menu 
contains topics that provide help with the Overlay Enhancer and I/O error 
messages.

The following is a summary of these Help items:

• Help Topics

• Current Overlay

• Current Prompt

• Error Message

• I/O Navigator

• About VT220

The Help Topics menu item displays the Help topics for VT220 only if you select 
a user-defined terminal type (as defined as the Other VT220 type from the OTM 
system Properties Communications tab). Otherwise, it displays the Help topics for 
the Meridian 1 system.

The Current Overlay, Current Prompt, and Error Message menu items are only 
enabled if you are running a VT220 terminal emulation for the M1.INI terminal 
type, and the system is in overlay mode.

The I/O Navigator Help function allows you to obtain information on specific 
error messages.

The Overlay Enhancer is an online context-sensitive Help function, which allows 
you to obtain quick and direct access to overlay information while in an active 
terminal session with the Meridian 1 system.

The following Overlay Enhancer Help commands appear in the Help drop-down 
menu:
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• Current Overlay

• Current Prompt

• Error Message

The Current Overlay and Current Prompt commands are only available if an 
overlay program is loaded and the terminal session is of type Meridian 1, PPP, or 
Ethernet. Otherwise, they are disabled and appear grayed. The Error Message 
command is available if the terminal session is of type Meridian 1, PPP, or 
Ethernet. Otherwise, it is disabled and appears grayed.

Keyboard mappings

VT220 uses standard keyboard mappings, which when incorporated into a 
terminal session, match the appropriate VT keys and actions. These default 
mappings, as shown in the following tables, allow you to run a terminal emulation 
session using the appropriate keys on a standard 101- or 102-key keyboard.

For example, if you are using VT220 to run Meridian Mail, the Meridian Mail 
softkeys (which appear at the bottom of the menus and screens) correspond to the 
appropriate function keys on your keyboard. The Meridian Mail softkeys 
correspond to the function keys F6 through F10 on a standard 101- or 102-key 
keyboard. Therefore, in a Meridian Mail session, you press F6 to select Softkey 1, 
F7 to select Softkey 2, and so on. For more information on the Meridian Mail 
softkeys, refer to the Meridian Mail System Administration Guide.

Note: Selection of an error message in the VT220 window is not 
sufficient to access the Overlay Enhancer help. Unlike the Overlay 
Passthru application, which displays online Help when you double-click 
the error message, the VT220 Help requires that you first click to select 
the error message, and then select Error Message in the Help drop-down 
menu. This then displays Help for the selected error message.
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Table 17 through Table 19 list the keyboard mappings for VT220 on standard 101- 
and 102-key keyboards.    

Table 17    Keyboard mappings - VT key

VT key PC key

PF1 Num Lock

PF2 Numpad Slash

PF3 Numpad Star

PF4 Numpad Minus

Find Insert

Insert Home

Select Delete

Up Arrow Up Arrow

Down Arrow Down Arrow

Left Arrow Left Arrow

Right Arrow Right Arrow

F6 F6

F7 F7

F8 F8

F9 F9

F10 F10

F11 F11

F12 F12

F13 Sys Rq

F14 Scroll Lock

Help F2

Do F3

F17 Ctrl-F7

F18 Ctrl-F8

F19 Ctrl-F9

F20 Ctrl-F10
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Table 18   Keyboard mappings - VT action

VT Key PC Key

Remove Page Up

Next Screen Page Down

Prev Screen End

Hold Screen F1

Compose Unmapped

Delete Backspace

Keypad Command Numpad Plus

Keypad Enter Numpad Enter

Break F5

Long Break Shift-F5

Control Break Ctrl-F5

Print Screen Unmapped

Keypad 0 Numpad 0

Keypad 1 Numpad 1

Keypad 2 Numpad 2

Keypad 3 Numpad 3

Keypad 4 Numpad 4

Keypad 5 Numpad 5

Keypad 6 Numpad 6

Keypad 7 Numpad 7

Keypad 8 Numpad 8

Keypad 9 Numpad 9

Keypad Minus Ctrl-Numpad Minus

Keypad Period Numpad Del

Table 19    Keyboard mappings - VT action scroll

VT key PC key

Scroll Left Ctrl-Left Arrow

Scroll Right Ctrl-Right Arrow
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System Monitor

The OTM System Monitor is a Microsoft Windows executable program that runs 
in the background on the OTM Server. System Monitor displays the PC’s 
resources (such as memory and CPU usage), and issues alarms when system 
resources are low. The System Monitor utility allows you to do the following:

• Turn a system alarm on or off and define the conditions (where, when, and 
what type of alarm) for sending alarm messages.

• Enable the System Monitor to automatically start when Navigator starts.

• View the virtual, physical, and total memory available.

• View the total CPU usage information.

• View the processes now running on the system.

• View the applications now running on the system.

• View the performance of the NT server.

• Ping another machine to test network connections.

Access System Monitor

Access the OTM System Monitor with the Microsoft Windows Run command. 
The path depends on your installation. However, you can locate the System 
Monitor executable, SystemMonitor.exe, in the Nortel\Common Services\Program 
Files folder.

Double-click the System Monitor executable file. The System Monitor icon 
appears on the Windows task bar, and the System Monitor starts (the window is 
minimized on your screen). From this window, you can perform all of the System 
Monitor functions.

To enable or disable the System Monitor, from the Options menu in the System 
Monitor window, select Options.

Scroll Up Ctrl-Up Arrow

Scroll Down Ctrl-Down Arrow

Table 19    Keyboard mappings - VT action scroll (continued)

VT key PC key
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View the virtual, physical, and total memory available

To view memory information, select the Memory tab on the System Monitor 
window.

The tab displays the amount of virtual and physical memory available, the total 
memory limit, and the total memory now in use. The progress bar at the bottom of 
the tab graphically displays the Memory Usage percentage.

Figure 97   System Monitor window—Memory tab
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View Disk Usage information

To view usage information for the disk, select the Disk Usage tab on the System 
Monitor window (Figure 98). 

Figure 98   System Monitor window—Disk Usage tab

View CPU information

To view usage information for the CPU, select the Processes tab on the System 
Monitor window.
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The tab displays five columns of information for each process that is running 
(Figure 99). The CPU usage appears graphically at the top of the tab. The tab 
displays the following information:

• Processes: The name of the process

• ID: The process ID

• CPU%: The percentage of the CPU used for the process

• MEM USAGE: The amount of memory used for the process

• VM SIZE: The amount of virtual memory used for the process

Figure 99   System Monitor window—Processes tab
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View and disable applications running on the system

To view and disable applications running on the system, select the Applications 
tab on the System Monitor window (Figure 100).

To stop an application from running, select the application, and then click End 
Task.

Figure 100   System Monitor window—Applications tab
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View the performance of the server

To view the server performance, select the Network tab on the System Monitor 
window. The tab displays the number of bytes received and sent per second by the 
server (Figure 101). 

To view the performance of other equipment: 

1 Select the Network tab on the System Monitor window.

2 Enter the IP address of the equipment you want to view. 

3 Click Ping. The performance for the equipment appears.

Figure 101   System Monitor window—Network tab
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Set up alarms

You can set up where to send alarm messages when system resources are low, and 
set the conditions for sending alarm messages. 

To configure alarms: 

The Alarm window opens (Figure 102).

Figure 102   Alarm window

Select Configure... from the Alarm menu in the System Monitor window.
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Data Buffering and Access

The OTM Data Buffering and Access (DBA) application provides a Windows 
interface to start a live data buffering session and define the session properties for 
collecting data from a Meridian 1 or Succession CSE 1000 system. A network or 
PPP connection allows collection of CDR and Traffic data. A serial connection 
allows collection of ASCII data only.

With a PPP or network connection, you can perform the following tasks:

• Schedule a single or routine backup of your Meridian 1 or Succession 
CSE 1000 system’s database files.

• Schedule the retrieval of buffered CDR and Traffic data from a Meridian 1 or 
Succession CSE 1000 system.

• View collected CDR and Traffic data.

• Back up and restore a Meridian 1 or Succession CSE 1000 system’s database 
to and from a remote device for database recovery.

If you lose a connection or have connection problems during a live data session, 
the Meridian 1 and Succession CSE 1000 systems save the CDR and Traffic data. 
You can retrieve the data when the connection is restored.

With a serial connection, you can perform the following tasks:

• Set up the actions and rules for generating alarms. 

• View collected serial data.

If you lose a connection or have connection problems during a live serial data 
session, data is lost.

Use the DBA application to schedule the following tasks:

• Archive CDR and Traffic from the Meridian 1 or Succession CSE 1000 
system.

Note: A serial connection does not support the DBA Backup and 
Restore functions.
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• Perform Meridian 1 or Succession CSE 1000 Database Disaster Recovery 
(backup only).

Access DBA

To access DBA, from the Utilities menu in the OTM Navigator window, select 
Data Buffering and Access.

The DBA main window appears (Figure 103).

Figure 103   DBA main window

DBA menus

Descriptions of each command in the DBA menus are available online. Use the 
Help command to get detailed descriptions of the commands. 

DBA Toolbar

The DBA Toolbar provides easy access to many of the menu commands.
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Right-click the mouse in the session window to view the pop-up menu containing 
a subset of the menu items.

Start a new live data session

To collect live data, you must start and configure a live data session (an active 
connection to a Meridian 1 or Succession CSE 1000 system). The DBA 
application runs continuously during the session, providing access for session 
configuration and a window for monitoring session information. Special 
operations, such as Meridian 1 or Succession CSE 1000 database backup, can be 
run immediately or scheduled to run within a session.

For Option 11C systems with survivable expansion cabinets and Succession 
CSE 1000 systems with survivable media gateways, it is possible to have live data 
delivered to DBA from the main cabinet or call server. When the systems are 
operating in normal mode, there is no call processing taking place on the 
expansion cabinets or the media gateways; therefore, no CDR data is sent from the 
expansion cabinets or media gateways.

To start a new live data session:

1 Select New Session from the File menu in the DBA main window.

The Select a System for Live Data dialog box opens (Figure 104).

Note: To maintain a live data session, you must keep the DBA main 
window open continuously. To minimize screen congestion, hide the 
DBA main window to remove it from the Windows Desktop. See “Hide 
and restore the DBA main window” on page 263.
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Figure 104   Select a System for Live Data dialog box

2 Select the Meridian 1 or Succession CSE 1000 system for the session from 
the tree and click OK, or double-click the selected system.

The Session Properties dialog box opens (Figure 105).

Figure 105   Session Properties dialog box
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Define session properties for a network connection

Session properties for a network connection are defined as follows: 

1 (Required) The name of the selected Meridian 1 or Succession CSE 1000 
system appears in the Host Name box.

2 (Required) Select network connection in the Connect Using box. 

3 (Required) The IP address for the selected Meridian 1 or Succession 
CSE 1000 system appears in the IP Address box.

4 (Optional) Enter your Meridian 1 or Succession CSE 1000 login name in the 
Login Name box.

5 (Required) Enter your Meridian 1 or Succession CSE 1000 login password in 
the Password box.

6 The Host Name, IP Address, Login Name, and Password data exist for the 
selected Meridian 1 or Succession CSE 1000 system in OTM Navigator. The 
DBA application automatically fills these fields with values from the OTM 
database. Any changes made in this dialog box are temporary and lost when 
the session window closes.

7 Check the Collect boxes to select the types of data (CDR or Traffic, or both) 
that DBA will buffer.

8 Select Connect Now to connect to the selected Meridian 1 or Succession 
CSE 1000 system and begin a live data session.

If you do not buffer all available data types, a dialog box appears asking you 
to confirm your selection.

A new window opens within your DBA main window. The host name of the 
connected Meridian 1 or Succession CSE 1000 system appears on the title 
bar. DBA uses this session window to provide information about the live data 
session. (See “View session data” on page 258.)

Note: To change your system selection, click Change to return to the 
Select a System for Live Data dialog box.
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Leave the session window open to maintain the live data session. If you close 
the window, the live session terminates. If the session terminates, the 
Meridian 1 or Succession CSE 1000 system begins sending buffered data to 
one of the following devices, depending on the session parameters you set 
when establishing the connection:

• Hard drive (not recommended for Option 11C and Succession CSE 1000 
systems)

• PCMCIA card (Option 11C, and Succession CSE 1000 systems)

Define session properties for a serial connection

Session properties for a serial connection are defined as follows:

1 (Required) The name of the selected Meridian 1 or Succession CSE 1000 
system appears in the Host Name box.

2 (Required) Select serial port connection in the Connect Using box. 

3 Select the data rate for the connection in the Data Rate box.

4 Select the data bit setting for the connection in the Data Bits box.

5 Select the parity setting for the connection in the Parity box.

6 Select the stop bits for the connection in the Stop Bits box.

Note: Nortel Networks recommends using a live connection, rather than 
using a hard drive, to collect data from large Meridian 1 systems.

Note: To change your system selection, click Change to return to the 
Select a System for Live Data dialog box.

Note: If you select a serial connection, use the Rules Manager window 
to define the actions taken when a specific data pattern appears in the 
data stream. See “Configure actions and rules” on page 245.
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7 Enter the name of the file to store data collected from the serial port in the File 
Name box. The file exists under the selected site and system. Enter a new file 
name or select one of the following files from the drop down list. 

• detail1.img - File used for CDR data

• traffic.dmp - File used for Traffic data

8 Rule File is a read-only field containing the name of the rules file for this 
DBA session. Edit the field with the Clear and Configure buttons.

• Clear - Removes the file name from the Rule File field.

• Configure - Opens the Rules Manager window shown in Figure 106. You 
can create a new rules file or open and edit an existing rules file. If you 
create a new rules file, you must define the actions taken when a specific 
data pattern appears in the data stream. See “Configure actions and rules’ 
next.

Configure actions and rules

Actions and rules are configured for serial connections. The Rules Manager 
window allows you to:

• Define the file you want to save or load into the Rules Manager

• Configure new actions or update or delete existing actions

• Configure new rules or update or delete rules, and set the order for applying 
rules
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Figure 106   Rules Manager—General tab

Define the Rules Configurations file

Use The General tab to select the rules configuration file you want to save and 
load into the Rules Manager (Figure 106).

1 The File Name box is a read-only field displaying the path and file name of 
the current rules configuration file. To use a different rules configuration file, 
click one of the following buttons:

• New - Resets the Rules Manager dialog box to blank. If changes have 
been made to the current configuration, you are prompted to save the 
changes.

• Open - Opens the standard file dialog box, which allows you to select a 
rules configuration file. If you change the current configuration, you are 
prompted to save the changes.
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• Save As - Opens the standard file dialog box allowing you to save an 
existing rules configurations file under another file name. Enter the new 
name and click Save. The Rules Manager window appears with the name 
of the file in the File Name box.

2 After you define the configurations file, use one of the following buttons:

• OK - Saves the rules configuration file and closes the Rules Manager 
window.

• Cancel - Discards any changes to the rules configuration file and closes 
the Rules Manager window.

• Apply - Saves the rules configuration file. The file remains open in the 
Rules Manager window, allowing you to make changes to the file.

• Help - Displays online Help.

Configured Actions

Use the Actions tab to define new actions or update or delete existing actions 
(Figure 107).
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Figure 107   Rules Manager dialog box—Actions tab

1 Select an action from the displayed list and click one of the following buttons:

• Add - Opens the New Action dialog box shown in Figure 108. See 
“Define a New Action” on page 249.

• Edit - Opens the dialog box to edit configurations for the selected action. 

• Delete - Select the action, and then click Delete to delete the action.

2 After you define the actions, use one of the following buttons:

• OK - Saves the actions in the configuration file and closes the Rules 
Manager window.

• Cancel - Discards any changes to the actions and closes the Rules 
Manager window.

• Apply - Saves the actions in the configuration file. The file remains open 
in the Rules Manager window, allowing you to make changes to the file.
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Define a New Action

The New Action dialog box (Figure 108) provides a list of configurations you can 
apply to the selected action. You can configure the SNMP trap and Write to File 
actions. Based on the configuration you select, another dialog box, such as SNMP 
Trap, displays for you to define the configuration for the action.

Figure 108   New Action dialog box

SNMP Trap dialog box

The SNMP Trap dialog box (Figure 109) defines the destination for the SNMP 
Trap action. Select the radio button for the destination of the trap. The valid 
selections are a local IP address or a user-defined address. The destination address 
must be running an application capable of taking the SNMP trap sent from DBA. 
When you select a local IP address (the default), it sends all traps to the same 
system running DBA and the Trap Server.
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Figure 109   SNMP Trap dialog box

The local IP address does not exist in the Rules Manager configurations file. You 
can change the local IP address without resetting the value in the defined action in 
the configuration file.

Write to File dialog box

The Write to File dialog box (Figure 110) allows you to define the destination for 
a Write to File action. Enter a name for the action and the name of the file for 
storing the action. The file is in the OTM Common Data Directory in the system 
level folder. Since the file exists in the common data directory, multiple sessions 
defined for different sites and systems can use the same Rules Manager file. You 
can copy the file to another OTM system.

Figure 110   Write to File dialog box
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Configure Rules

Use the Rules tab to define new rules, update or delete rules, and set the order for 
applying rules to the data stream (Figure 111).

Figure 111   Rules Manager dialog box—Rules tab

1 Select an event from the displayed list, and then click one of the following 
buttons.

• Up or Down - Moves the selected event up or down one position in the 
list.

Note: The order in which the rules appear is important. You should 
order the rules so that the more specific pattern matches occur before the 
more generic ones. If a generic pattern rule is matched before a more 
specific pattern rule is tested, the action associated with the generic rule 
is executed and no additional rule matches are done.
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• Add - Opens the New Rule dialog box (Figure 112). See “Define a New 
Rule” next.

• Edit - Opens the dialog box to change the selected rule. 

• Delete - Select the event, and then click Delete to delete the rule.

After you define the rules, use one of the following buttons:

• OK - Saves the rules in the configuration file and closes the Rules 
Manager window.

• Cancel - Discards any changes to the rules and closes the Rules Manager 
window.

• Apply - Saves the rules in the configuration file. The file remains open in 
the Rules Manager window, allowing you to make changes to the file.

Define a New Rule

The New Rule dialog box (Figure 112) provides a list of the types of rules you can 
define. You can configure the rules for an M1 Alarm, Meridian Mail Alarm, or a 
generic event. For example, an M1 Alarm rule can match a Meridian 1 or 
Succession CSE 1000 system alarm code. A match records the data provided with 
the alarm. A rule for a generic event is for a system other than those listed.

Figure 112   New Rule dialog box

M1 Alarm dialog box

The M1 Alarm dialog box (Figure 113) defines the values for an M1 Alarm rule.
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The Event edit box defines the text that will be used to determine if a match is 
found in the data stream. The Event field accepts regular expressions for 
performing complex text comparisons. The menu button beside the field provides 
a list of regular expression options.

The Severity field contains a list of predefined severity values. The values 
provided are Info, Warning, Minor, Major, Critical and Clear. The default value is 
Info.

The Action Name field contains a list of actions by action name. This list is 
dynamically created using the actions defined on the Actions page of the 
Configuration Property Sheet. The default value is blank meaning no action will 
occur if an event match occurs.

Figure 113   M1 Alarm dialog box

Meridian Mail Alarm dialog box

The Meridian Mail Alarm dialog box (Figure 114) defines the values for a 
Meridian Mail Alarm rule. The Severity Level field contains a list of predefined 
severity levels. The values provided are Information (INF), Minor (*), Major (**), 
Critical (***), Clear (OFF), and All. This allows the user to define the Meridian 
Mail severity level in the data stream, which is used in addition to the Event, to 
determine if a match is found. The option to chose All for severity level was added 
to allow the user to match the event regardless of the severity level sent from 
Meridian Mail. 
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The Event field defines the text that will be used to determine if a match is found 
in the data stream. The Event field accepts regular expressions for performing 
complex text comparisons. The menu button beside the field provides a list of 
regular expression options.

The Severity field contains a list of predefined severity values. The values 
provided are Info, Warning, Minor, Major, Critical, and Clear. The default value is 
Info.

The Action Name field contains a list of actions by action name. This list is 
dynamically created using the actions defined on the Actions page of the 
Configuration Property Sheet. The default value is blank meaning no action 
occurs if an event match occurs.

Figure 114   Meridian Mail Event dialog box

Generic Event dialog box

The Generic Event dialog box (Figure 115) allows you to define the values for a 
generic event rule. Generic systems are not Meridian 1 or Succession CSE 1000 
systems.
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The Event edit box defines the text that will be used to determine if a match is 
found in the data stream. The Event field accepts regular expressions for 
performing complex text comparisons. The menu button beside the field provides 
a list of regular expression options.

The Number of Lines in Event field defines the number of lines in the data stream 
to capture. The values are 1–5 (0 is the default). A value of zero records the event 
only.

The Severity field contains a list of predefined severity values. The values 
provided are Info, Warning, Minor, Major, Critical, and Clear. The default value is 
Info.

The Action Name field contains a list of actions by action name. This list is 
dynamically created using the actions defined on the Actions page of the 
Configuration Property Sheet. The default value is blank, which means that no 
action occurs if an event match occurs.

Figure 115   Generic Event dialog box
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Schedule a backup or retrieval

DBA allows you to schedule a single or routine backup of your Meridian 1 or 
Succession CSE 1000 system’s database files. On an Option 11C or Succession 
CSE 1000 system, you can schedule the retrieval of buffered CDR and Traffic data 
from the Meridian 1 or Succession CSE 1000 system to the PC. 

The following procedure describes how to schedule either operation in DBA:

1 Select File > Schedule in the DBA main window.

The Select a System for Scheduling dialog box opens. 

2 Use the dialog box tree to select the Meridian 1 or Succession CSE 1000 
system you want to schedule.

3 Click OK, or double-click on the selected system, to confirm your selection.

The Scheduled Job Properties dialog box opens (Figure 116).

Figure 116   Scheduled Job Properties dialog box

4 To change your system selection, click on Change to return to the last dialog 
box.

Note: A scheduled job does not configure the Meridian 1 or Succession 
CSE 1000 system. Use the correct LD 117 settings (DBK and BUF) for 
the Meridian 1 or Succession CSE 1000 system.
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5 (Optional) Enter the Host Name of the System in the indicated field.

6 Click on the check box of the operation you want to schedule:

PBX Database Backup - Back up Meridian 1 or Succession CSE 1000 
database files.

Data Retrieval - Retrieve buffered CDR and Traffic data from the Meridian 1 
or Succession CSE 1000 system.

7 Click OK to confirm your settings.

The Scheduling dialog box opens (Figure 117). 

Note: The Host Name, IP Address, Login Name, and Password data for 
the selected Meridian 1 or Succession CSE 1000 system are stored in the 
OTM database. The DBA application automatically fills these fields with 
the values from the OTM database. In the Scheduled Job Properties 
dialog box, these fields are read-only. If the values are not correct, enter 
the correct values in the OTM Navigator System Properties.

Note: The Data Retrieval check box only functions for Option 11C and 
Succession CSE 1000 systems. Data retrieval is only available for 
systems that are defined as Option 11C, Option 11C Mini, or Succession 
CSE 1000 in the OTM Navigator database.
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Figure 117   Scheduling dialog box

8 Schedule the job by completing the items in the Scheduling dialog box and 
clicking OK.

View session data

In a live session, you can view the collected CDR, Traffic, and serial data, and the 
session data collection statistics (Figure 118).
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Figure 118   Sample session window displaying Statistics

From the View menu, select one of the following:

• CDR Data to display a snapshot of CDR data collected by DBA (up to the last 
15 minutes)

• TRF Data to display a snapshot of Traffic data collected by DBA (up to the 
last 15 minutes)

• Statistics to display the average number of CDRs per minute, the time of the 
last Traffic Sample, and the time of the last serial data connection

• Refresh to update CDR, Traffic, and serial data views with the latest collected 
data

You can use the following Edit menu commands to handle text in the session 
window:

• Copy to copy text from the session window.

• Select All to select all text in the session window.

• Find to locate selected text in the session window.
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Retrieving CDR data from Survivable IP systems

When in survival mode, the survivable expansion cabinets and survivable media 
gateways operate as if they are standalone Option 11C or Succession CSE 1000 
systems. Call Detail Records (CDR) and Traffic Measurements (TRF) are only 
generated by the expansion cabinets and the media gateways when the systems are 
operating in survival mode.

In the event that an expansion cabinet or media gateway enters survival mode, it is 
possible to collect CDR records from the expansion cabinet or media gateway. 
These records must be manually retrieved, using the XModem procedure, when 
the expansion cabinet or media gateway returns to normal mode.

XModem procedure

Call Detail Records (CDR) are only generated by the Option 11C survivable 
cabinets and the Succession CSE 1000 survivable media gateways when the 
system is running in survival mode. The CDR are deleted from the survivable 
cabinet or survivable media gateway once they have been successfully transferred 
to the PC. The XCDR command in LD 143 transfers the CDR file from the 
Option 11C expansion cabinet or the Succession CSE 1000 media gateway 
directly to the OTM PC. There is one CDR file stored on each expansion cabinet 
or media gateway.

To retrieve the CDR files stored on the survivable expansion cabinets or the 
survivable media gateways using XModem:

1 Establish a connection between the PC and the main cabinet of the 
Option 11C or the call server of the Succession CSE 1000.

This may be done either remotely through the use of a modem or directly 
through the use of a serial cable and a modem eliminator.

2 Use a terminal emulation program such as HyperTerminal to begin a TTY 
session with the Option 11C or the Succession CSE 1000 system using either 
the modem or SDI cable.

3 From the PC, go to LD 143 and type XCDR.

4 When the system asks for an expansion cabinet number, enter the number 
assigned to the expansion cabinet or media gateway that contains the dba.cdr 
file that you want to retrieve.
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The system responds:

Getting CDR file for EXP_CAB <num>
Ready to transmit...

5 You must invoke the XModem protocol on the PC to receive the CDR file. For 
example, use the HyperTerminal transfer function to receive the file using 
XModem protocol.

6 Name the file.

You may give any name you want to the file being received.

7 Parse the file into the main cabinet or call server’s database on the PC.

For information on importing CDR data into Billing applications, refer to Using 
Optivity Telephone Manager Telemanagement Applications (553-3001-331).

PBX Database Disaster Recovery

PBX Database Disaster Recovery provides a quick way to perform a Meridian 1 
or Succession CSE 1000 database backup and restore, or to schedule a database 
backup. You can schedule or manually start a backup operation, and the 
application connects to the switch and retrieves the database files. You can 
manually start a restore operation to restore the database file to the Meridian 1 or 
Succession CSE 1000 system. Before performing the restore operation, you must 
establish a live session with the switch.

The PBX Database disaster recovery feature is available for all Meridian 1 and 
Succession CSE 1000 systems that are configured in the OTM Navigator. Since 
survivable expansion cabinets and survivable media gateways are configured as 
separate systems in the Navigator, the Disaster Recovery feature is available to 
both the main cabinet, or call server, and the survivable expansion cabinets, or 

Note: Use a file name that will not overwrite any DBA-specific files if 
DBA is used to retrieve CDR/Traffic files from the main cabinet of the 
Option 11C or the call server of the Succession CSE 1000 system.

Note: PBX Database Disaster Recovery runs separate from the normal 
Meridian 1 and Succession CSE 1000 database backup feature: 
Electronic Data Dump (EDD).
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media gateways. You do not need to backup the expansion cabinets and media 
gateways. Any data that is restored to an expansion cabinet, or media gateway, 
while it is operating in survival mode is overwritten by the database of the main 
cabinet, or call server, when the system returns to normal mode.

To perform a database backup or restore:

1 Open and select a session window.

2 Select PBX Database Disaster Recovery from the File menu.

The PBX Database Disaster Recovery dialog box opens (Figure 119).

Figure 119   PBX Database Disaster Recovery dialog box

Click one of the two radio buttons to select an operation:

— Backup - Back up Meridian 1 or Succession CSE 1000 database files 
to the PC.

Note: A backup can be run on a PC that is not the PC used for collecting 
live CDR or Traffic data, or both.
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— Restore - Transfer earlier backed-up Meridian 1 or Succession 
CSE 1000 database files from the PC to the Meridian 1 or Succession 
CSE 1000 system.

3 Select one of the following buttons:

• Run Now to begin the selected operation.

• Schedule to indicate a time for routine database backup. You cannot 
schedule a restore. The OTM Scheduling dialog box opens. Use the dialog 
box to schedule your database backup. See “Schedule a backup or 
retrieval” on page 256.

The DBA application displays the status of the backup or restore 
operation.

Hide and restore the DBA main window

To maintain a live data session, you must keep the DBA main window open 
continuously. To minimize screen congestion, hide the DBA main window to 
remove it from the Windows Desktop. DBA remains active and the DBA tray icon 
continues to appear on the Windows Toolbar.

To hide the DBA main window, do one of the following:

• Select Hide Application from the View menu.

• Click Hide Main Window on the toolbar.

• Double-click the DBA tray icon.

To restore your DBA main window, double-click the tray icon.

You can right-click the tray icon to display a pop-up menu containing the menu 
items, Hide Window or Restore Window. Use these commands to hide or restore 
the DBA main window, or select Exit to end the program.

Warning: The Restore operation overwrites the existing database files 
on the Meridian 1 or Succession CSE 1000 system. Before you use the 
Restore operation:

• Make sure that your backup files are valid

• Make sure that no other PC is performing a Backup or Restore
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Utilities

Scheduler

This section contains a general overview of the Scheduler. For more information 
about how to use the Scheduler windows, refer to the Scheduler online Help.

The Scheduler schedules an Optivity Telephony Manager activity (or any 
Windows application activity) for processing at a later date and time. With 
Scheduler, you can define the intervals you want to run the activity. If there are 
multiple tasks in a job, you can assign the tasks in a sequential order using the 
queue function.

The Scheduler normally runs in background mode. This means that if an OTM 
application is due to run at a certain time, the Scheduler automatically runs it at 
that time without interrupting current sessions.

Access the Scheduler

There are two ways to access the Scheduler:

• From the OTM Navigator, choose Utilities > Scheduler and schedule the 
activity directly.

• From any supported application, select the Schedule command where it 
appears in that application. For example, you can click Schedule in the 
Reporting dialog box of the Telecom Billing System. You can use the 
Scheduler functions to enter the information to schedule this application.

Note: Changes that are input using Web Station are scheduled using the 
web-based scheduling tool. See “Schedule button” on page 390.

Note: The Scheduler must be running in the Windows environment at 
the time an event is to run. You can start the Scheduler application any 
time. An event and its tasks do not execute if the Scheduler is not 
running at the scheduled time.
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Jobs and tasks

The Scheduler represents scheduled activities (such as, data collection, 
synchronization and reporting) as jobs and tasks.

What is a job?

A job contains the scheduling properties of an activity. This includes such 
information as the activity’s initial execution time; interval for additional 
executions; status; name; and queue assignments. The job also contains the actual 
task that identifies the activity’s actions. That is, each task that runs that actual 
activity is assigned to a job. This way, the task can be scheduled. Only jobs can be 
scheduled; individual tasks cannot be scheduled without a job.

What is a task?

A task contains the actual command used to invoke the activity from the OTM 
application. This includes such information as the activity’s command line (the 
code used to invoke the activity); its priority in the list of tasks (when it should be 
executed in relation to any other tasks in the list); and any dependencies associated 
with it (physical resources on your PC that are needed to execute the activity).

In most cases, one job has one task. This simplifies the process of defining and 
scheduling activities. You simply schedule the activity, assign it as a task to a job, 
and then enter its scheduling criteria. There are instances, however, when it is 
beneficial to assign multiple tasks to a single job (e.g., in situations where you 
want to run multiple tasks all at the same scheduled time). The Scheduler allows 
you to assign multiple tasks to each job after they have been defined.

Execution of tasks in the Scheduler queue

Any task in the Scheduler queue can be executed immediately by right-clicking 
the task in the Scheduler window and selecting Start Now. Tasks in the queue that 
have the same priority and are scheduled to occur at the same time are executed 
simultaneously. When tasks in the queue have different priorities and are 
scheduled to occur at the same time, the higher priority tasks execute first and are 
followed by the lower priority tasks.
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About the Scheduler window

The following sections describe the Scheduler window and the menus of the 
Scheduler.

The main Scheduler window (Figure 120) contains sections that list the scheduled 
jobs and queues. These sections provide the interfaces for the Job, Queue, and 
Dependency Queue Managers, and list the running tasks for each job. Use these 
sections to view and access your jobs and queues.

Figure 120   Scheduler window

The main Scheduler window contains the following information sections:

Scheduled jobs section

The Job Manager displays the details of all of the scheduled jobs in the top-left 
section of the window. The display shows the job name, scheduled date and time 
for initial execution, intervals, and number of tasks in the job.
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Job in the queue section

The Queue Manager displays the current status of jobs in the queue in the 
bottom-left section of the window. When the last task of a job completes, the 
queue record disappears.

Dependency resource section

The top-right section of the window displays the current status of the dependency 
queues whose tasks are executing. The Dependency Queue Manager displays the 
information. A dependency queue is a collection of tasks requiring the same 
system resource (e.g., two tasks need to access a COM port at the same time).

The following list describes the properties of a dependency queue’s tasks:

• Each task in the dependency queue is a top task of some queue.

• The order of tasks in the task list of a dependency queue defines the order of 
task execution.

• You can move tasks in the list up or down or edit tasks, except a task that has 
started processing.

• When a task completes, its record disappears from the task list.

• Tasks requiring more than one system resource appear in more than one 
dependency queue. If you delete a task record from one dependency queue, 
the task record is automatically deleted from other dependency queues.

Tasks running section

The bottom-right section shows the tasks that are running now. From here, you 
can delete any running tasks. When deleted, a task is no longer monitored by the 
Scheduler. If you delete a task, the application containing that task continues to 
run.

File Menu

From the File menu commands, you can manage the Scheduler jobs and queues 
and exit from the Scheduler. Use the Help command to get detailed descriptions 
about the functions of each command.
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Edit Menu

The Edit menu allows you to manage defined jobs or queues. Use its commands to 
enable or disable the defined jobs or queues. Use the Help command to get 
detailed descriptions about the functions of each command.

View Menu

The View menu allows you to:

• Display or hide the Scheduler’s toolbar and status bar

• View the task list of the highlighted job or queue

• Arrange the jobs or queues within each section of the window

Import and Export utilities

This section contains a general overview of the Import and Export utilities. It 
describes their basic function and purpose.

The Import and Export utilities are used to import and export data to and from the 
Optivity Telephony Manager (OTM) data base files. These tools allow you to 
share data between the OTM data bases and other applications.

The following are examples of situations in which the Import and Export utilities 
are useful:

• If you are installing a new Meridian 1 or Succession CSE 1000 system, and 
already have a source that contains user data (i.e., Names, Departments, 
Managers), you may import these fields into the OTM Directory. You can then 
use Station Administration to assign telephones to the imported user records.

• Synchronize with an LDAP database to complete the unique identifier (UID) 
fields.

• The OTM Directory can be exported for external telephone book generation 
or for importing into other external data bases.
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Import utility

The Import utility is used to import data records from an external source to a 
specific site/system and convert them to a format compatible with the OTM data 
bases. This function is useful for quickly updating your data bases with data from 
another application.

When importing data, you can select from a predefined import configuration or 
you can define your own configuration. The following paragraphs outline how to 
import data using a predefined and custom configuration. Review the information 
later in this section for details on the functions and dialog boxes used to perform 
these steps.

Import data using a predefined configuration

To import data using a predefined configuration, you must first select the 
configuration and its component values. This configuration outlines the 
parameters of the data being imported. This includes such information as the 
format of the data, the types of records, and their field parameters (character 
length, position, and so on). OTM includes a set of predefined import 
configurations for common data base types. You can then select the source from 
where you will import the data (for example, disk drive, CD-ROM, and so on).

The following is a summary of the steps required to import data using a predefined 
configuration:

1 Access the Import utility. See “Access the Import utility” on page 270.

2 Select the import configuration components. See “Selecting import 
configuration components” on page 270

3 Define the import configuration. See “Defining an import configuration” on 
page 271

4 Import the data. See “Import data” on page 273
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Import data using a custom configuration

To import data using a custom configuration, you must first define the import 
configuration. This configuration outlines the parameters of the data being 
imported. This includes such information as the format of the data, the types of 
records, and their field parameters (character length, position, and so on). You can 
then select from where you will import the data (for example, disk drive, 
CD-ROM, and so on).

The following is a summary of the steps required to import data using a custom 
configuration:

1 Access the Import utility. See “Access the Import utility”, next.

2 Define the import configuration components. See “Import configuration list” 
on page 271.

3 Define the import configuration. See “Defining an import configuration” on 
page 271.

4 Import the data. See “Import data” on page 273.

Access the Import utility

To import data using a predefined or custom configuration, access the Import 
utility. Based on which application you are using, the Import utility may be 
accessed from several locations.

For example, if you are accessing the Import utility from the OTM Telecom 
Billing System, you select File > Import from the TBS main window. If you are 
accessing the Import utility from the System Window, you select Utilities > 
Import. The Import dialog box appears allowing you to select from a list of 
predefined configurations or add your own custom configuration. Once you have 
selected the predefined configuration and the source directories, click Go to 
import the data.

Selecting import configuration components

The Import (Select an Import Configuration) function is used to select a 
predefined import configuration. To select a predefined import configuration:
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1 Click the import configuration name from the Select an Import Configuration 
drop-down list box. 

2 To define the components of the imported file, click the ellipsis command 
button (…). The Import Configuration Definition dialog box appears allowing 
you to select the tables or data bases you want to import. 

3 Once you have selected the predefined configuration and the source 
directories, click Go to import the data.

Import configuration list

If you are creating a new import configuration, then clicking the ellipsis command 
button (…) accesses the Import Configurations List dialog box. The Import 
Configurations List dialog box contains a list of predefined import configurations. 
To create a new configuration:

1 Click Add. This accesses the Import Configuration Definition dialog box 
where you can enter the importing information. 

2 To select an import configuration, click the name of the import configuration 
name to highlight it in the list, and click OK to select it.

Defining an import configuration

The Import Configuration Definition function is used to select and define the type 
of data being imported into the OTM data bases. Enter the following information 
to define the import configuration:

1 Configuration Name: Enter the name of this configuration. The name helps to 
identify this configuration from others in the Import Configurations List.

2 Tables/Database menu tree: Select the type of tables into which the data will 
be imported. For example, if you are importing data into the OTM Telecom 
Billing System, you can select from Call Records; Organization Levels; and 
Tax Types to import data into these data bases.

Note: To edit an existing configuration, click the name of the 
configuration and click Edit. Again, this accesses the Import 
Configuration Definition dialog box where you can enter the new 
definition.
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3 File/Database Type: From this drop-down list box, select the type of data 
being imported. Select from the following:

— dBase IV

— Excel 5

— Microsoft Access

— ODBC Data Source

— Text File (Comma Separated Values)

— Text File (Fixed Width)

4 File/Database Location: To select the source of the imported data base file 
(i.e., the directory or drive from which the file will be imported), click the 
ellipsis command button (…) next to the File/Database Location field. From 
the Directory Location Form dialog box that appears, select the drive and 
directory of the data base file being imported, and then click OK. Notice that 
this appears in the File/Database Location field.

5 Import Profile Format: To select the format of the imported file, click Format. 
This accesses the Import Format dialog box in which you can select the field 
properties for the imported file.

6 File/Table Name: From this drop-down list, select the filename of the data 
base being imported.

7 Update Activity: This option determines how this data base is updated. Select 
from the options listed in Table 20.

Table 20   Import update activity options

Option Meaning

Append non matching Appends non-matching records

Update matching Updates matching records

Update matching or append Either updates or appends as 
appropriate

Delete matching! Deletes matching records

Delete all rows then append! Purges entire table before appending

Recreate table then append! Drops and recreates table before 
appending
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8 Purge records after writing: Turn on this check box to delete the records from 
the source file after they have been successfully written to the destination file.

9 Description: This field describes the contents of the table selected from the 
Tables/Database Name menu tree.

10 Once you have entered this information, click OK to save these edits and 
return to the previous dialog box.

Import data

11 Once you have selected the import information, click Go to proceed. The 
Import utility then attempts to import this data into the site/system files.

Example data import

The following example demonstrates how to import data using a predefined 
configuration:

This example outlines how to import data from the MAT Call Accounting 
Employee Database to a site/system while running the OTM Telecom Billing 
System. This example uses a fictitious import configuration entitled MAT Import. 
For this example, the Employee Database file is located in C:\MAT. The filename 
is EMPLOY1.DAT.

a From the Telecom Billing System main window, click File | Import. The 
Import dialog box appears.

b From the Select an Import Configuration drop-down list box, select MAT 
Import.

c To select the import values, click the ellipsis command button (…). The 
Import Configuration dialog box appears.

d From the data base name menu tree, select Employee Database.

e To select the source of the imported data base file, click the ellipsis 
command button (…) next to the File/Database Location field.

Note: This action is irreversible. Therefore, use caution if selecting this 
option.
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f From the Directory Location Form dialog box, select C:\MAT, and then 
click OK.

g From the File/Table Name drop-down list box, select EMPLOY1.DAT.

h From the Update Activity drop-down list box, select the default Append 
All.

i To proceed with the data import, click Go.

Restore Call Database using Import utility

This example demonstrates how to restore the Telecom Billing System’s Call 
Database from drive A. To restore the Call Database, perform the following steps:

a Access the Import utility by clicking File | Import from the Telecom 
Billing System main window.

b Select Merge CDR/Costed Data as the Import Configuration.

c To define the parameters for this restore operation, click the ellipsis 
command button (…) next to this list box. The Import configuration 
dialog box appears listing CDR/Costed Data Merge as the destination (To 
Telecom Billing System).

d In the File/Database Location field, enter the source of this restore 
operation. For example, enter: A:\ for a floppy disk drive. Click the 
ellipsis command (…) to view a list of available drives.

e If you want to restore a range of call records based on their dates, then 
click the ellipsis command (…) next to the Filter drop-down list box.

f In the Filters dialog box that appears, create a new filter definition and 
enter the range of call dates for this filter.

g Select this new filter name from the Filter drop-down list box.

h Click Go to proceed with the restore operation.

Export utility

The Export utility is used to export data from the OTM data bases to an external 
source. This is useful for archiving a range of data for later retrieval. For example, 
if you want to archive a range of CDR data to an external source, then you use the 
Export utility to select a range of data and specify the external source.
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When exporting data, you can select from a predefined export configuration, or 
you can define your own custom configuration.

Export data using a predefined configuration

To export data using a predefined configuration, you must first select the 
configuration and its component values. This configuration outlines the 
parameters of the data being exported. This includes such information as the 
format of the data, the types of records and their field parameters (character 
length, position etc.). OTM includes a set of predefined export configurations for 
common data base types. You can then select to where you will export the data 
(for example, disk drive, CD-ROM, and so on).

The following is a summary of the steps required to export data using a predefined 
configuration:

1 Access the Export utility. See “Access the Export utility” on page 276.

2 Select export configuration components. See “Select export configuration” on 
page 276.

3 Define export configuration. See “Export configuration definition” on 
page 277.

4 Export the data. See “Export data” on page 278.

Export data using a custom configuration

To export data using a custom configuration, you must first define the export 
configuration. This configuration outlines the parameters of the data being 
exported. This includes such information as the format of the data, the types of 
records, and their field parameters (character length, position etc.). You can then 
select to where you will export the data (for example, disk drive, CD-ROM, and so 
on).

The following is a summary of the steps required to export data using a custom 
configuration:

1 Access the Export utility. See “Access the Export utility”, next.

2 Define export configuration components. See “Export configurations list” on 
page 276.
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3 Define export configuration. See “Export configuration definition” on 
page 277.

4 Export the data. See “Export data” on page 278.

Access the Export utility

To export data using a predefined or custom configuration, access the Export 
utility. Based on which application you are using, the Export utility may be 
accessed from several locations.

For example, if you are accessing the Export utility from the Telecom Billing 
System, then you select File > Export from the TBS main window. If you are 
accessing the Export utility from the system window, select Utilities > Export. 
The Export dialog box appears allowing you to select from a list of predefined 
configurations or add your own custom configuration. Once you have selected the 
predefined configuration and the source directories, click Go to export the data.

Select export configuration

The Export (Select an Export Configuration) dialog box is used to select a 
predefined export configuration. To select a predefined export configuration, 
follow these steps:

1 Click the export configuration name from the Select an Export Configuration 
drop-down list box. 

2 To define the components of the exported file, click the ellipsis command 
button (…). The Export Configuration Definition dialog box appears allowing 
you to select the tables or data bases that you want to export. 

If you are creating a new export configuration, then clicking the ellipsis 
command button (…) accesses the Export Configurations List dialog box. 

3 Once you have selected the predefined configuration and the destination 
directories, click Go to export the data.

Export configurations list

The Export Configurations List dialog contains a list of predefined export 
configurations. To create a new configuration, follow these steps: 
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1 Click Add. This accesses the Export Configuration Definition dialog box 
where you can enter the exporting information. 

2 To select an export configuration, click the name of the export configuration 
to highlight in the list, and then click OK to select it.

Export configuration definition

The Export Configuration Definition dialog box is used to select and define the 
type of data being exported from the OTM data bases. Enter the following 
information to define the export configuration:

1 Configuration Name: In this field, enter the name of this configuration. This is 
for informational purposes and helps to identify this configuration from others 
in the Export Configurations List.

2 Tables/Database menu tree: From this menu tree, select the type of tables 
from which the data will be exported.

3 File/Database Type: From this drop-down list box, select the type of data 
being exported.

4 File/Database Location: To select the destination of the exported data base file 
(i.e., the directory or drive to which the file will be exported), click the ellipsis 
command button (…) next to the File/Database Location field. From the 
Directory Location Form dialog box which appears, select the destination 
drive and directory. Click OK. Notice that the destination you selected 
appears in the File/Database Location field.

5 Export Profile Format: To select the format of the exported file, click Format. 
This accesses the Export Format dialog box in which you can select the field 
properties for the exported file.

6 File/Table Name: From this drop-down list box, select the filename of the data 
base being exported.

Note: To edit an existing configuration, click the name of the 
configuration and click Edit. Again, this accesses the Export 
Configuration Definition dialog box where you can enter the new 
definition.
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7 Update Activity: This option determines how this data base is updated. Select 
from the following options (Table 21):

8 Purge records after writing: Turn on this check box to delete the records from 
the source file after they have been successfully written to the destination file.

9 Description: This field describes the contents of the table selected from the 
Tables/Database Name menu tree.

10 Once you have entered this information, click OK to save these edits and 
return to the previous dialog box.

Export data

11 Once you have selected the export information, click Go to proceed. The 
Export utility then attempts to export this data from the site/system files to the 
external device or file.

Archiving Call Database using Export utility

This example demonstrates how to archive the Telecom Billing System’s Call 
Database to drive A. To archive the Call Database, perform the following steps:

Table 21   Export update activity table

Option Meaning

Append non matching Appends non-matching records

Update matching Updates matching records

Update matching or append Either updates or appends as 
appropriate

Delete matching! Deletes matching records

Delete all rows then append! Purges entire table before appending

Recreate table then append! Drops and recreates table before 
appending

Note: This action is irreversible. You should, therefore, use caution if 
selecting this option.
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1 Access the Export utility by clicking File | Export from the Telecom Billing 
System main window.

2 Select Archive CDR/Costed Data as the Export Configuration.

3 To define the parameters for this archive operation, click the ellipsis command 
button (…) next to this list box. The Export configuration dialog box appears 
listing CDR/Costed Data as the source (from Telecom Billing System).

4 In the File/Database Location field, enter the destination of this archive 
operation. For example, enter: A:\ for a floppy disk drive. Click the ellipsis 
command (…) to view a list of available drives.

5 If you want to archive a range of call records based on their dates, then click 
the ellipsis command (…) next to the Filter drop-down list box.

6 In the Filters dialog box that appears, create a new filter definition and enter 
the range of call dates for this filter.

7 Select this new filter name from the Filter drop-down list box.

8 Select the Purge Records After Writing option to delete the range of call 
records from the original Call Database once the call records have been 
copied to the external source. This clears up disk space on your PC.

9 Click Go to proceed with the archive operation.

Database Compact/Repair utility

This section describes the functions and purpose of the OTM Database Compact 
and Repair utility. For complete details on using this utility, refer to the online 
Help included with the software.

Use the Compact and Repair utility to compact or repair the OTM database files 
for specific sites and systems. This utility compacts or repairs any Microsoft 
Access format database files of the same version as OTM (for example, 
Access 97).

The following are two common reasons to compact data base files:

• Increase in size
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CDR data that is accessed by OTM Telecom Billing System and OTM 
Directory is stored in data base files. These database files grow as records are 
added and deleted. Periodically, the database files should be compacted to 
increase access performance. This is especially true of very active files, such 
as CDR database files.

• File fragmentation

As you update the OTM data bases, the files can become fragmented and use 
more disk space than necessary. Use the Compact command to compact these 
data bases and optimize the disk space used by these data base files. 
Compacted data bases can often be accessed more quickly. This saves time 
and system resources when you perform such operations as database backups.

In some cases, the OTM data bases can become corrupted and may no longer be 
accessible by the OTM applications. Use the Repair command to try and repair 
these databases so they can be accessed by these applications.

To compact a data base:

1 Click the desired system in the OTM System menu tree. 

2 Select Compact from the Utilities menu. The Compact Database dialog box 
appears. 

3 Specify the files you want to compact or repair, and then click Compact.

Caution: This utility creates a temporary copy of the databases as they 
are compacted. Therefore, you must have enough disk space for both the 
original and the duplicate databases. This operation fails if the system 
runs out of disk space.

Note: You cannot run this utility for a specific system if you are running 
an application within that system. Before proceeding with this utility, 
exit from the application that is running within that system.
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Figure 121   Access Database Compact/Repair Utility window

Backup and Restore

OTM’s Backup and Restore utilities provide convenient options for safeguarding, 
cloning, and restoring OTM data on a PC. The Backup utility lets you create a 
OTM backup file of PC-based system property and application data for any or all 
sites and systems. The Restore utility lets you restore a backup file to the same or 
different sites and systems on the same or other PCs.

Note: The Backup and Restore utilities have no effect on Meridian 1 or 
Succession CSE 1000 data. To secure OTM data that has been uploaded 
to the system, you must use OTM’s Electronic Data Dump feature 
described on page 312.
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Media, files, and data types

You can create an OTM backup file on the PC’s hard drive, a network drive, disks 
and other removable disks, or any other available media that meets your 
requirements for convenience and file space.

All backup data is written to a single folder for each backup operation. This folder 
includes the following files:

• Zip file (*.ZIP), the backup file in compressed format

• Log file (*.LOG), providing the backup file’s date; type; OTM version; and 
sites, systems, and applications by name

You can back up and restore data for all or any combination of the following OTM 
applications:

• Telecom Billing System

• Call Tracking

• ESN

• Station Administration

• Traffic Analysis

The Full OTM backup also includes:

• Web Navigator data such as User Groups

• Client list

You can back up and restore data for these applications across multiple sites and 
systems at the same time.

Applications are associated with specific sites and systems. All backups of 
application data include the system property data associated with the selected site 
or system.
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When you restore data from a backup file, you have the option not to restore 
system property data. This option is useful in cases where the destination site or 
system is preconfigured, and you do not want to overwrite its system property 
data. For example, system property data such as communication ports, modem 
configuration, and user ID and password may be different from one PC to the 
next.

Benefits

The Backup and Restore utilities provide several key benefits:

• cloning

• moving data offsite

• disaster recovery

Cloning

The process of copying system property and application data associated with one 
site or system to another site or system is called cloning. Copying data to another 
site or system can be a great timesaver. It can save you from having to enter a large 
amount of similar data one item at a time.

After cloning selected data, you can simply focus on making whatever changes 
are necessary to the cloned data. This operation is very flexible. The destination 
site or system can be new or already exist, and it can be on the same PC or on 
another PC.

Moving data offsite

If you want to maintain or occasionally modify OTM data offsite, an OTM backup 
file provides the solution. You can restore the backup file on any PC that has the 
same version of OTM installed.

Note: If you back up data from one PC and restore it to another, you 
must perform this operation under the same version of OTM. You cannot 
back up data from a PC with an older version of OTM and then restore 
the data to a PC with OTM. Upgrade the older version of OTM before 
performing this type of cloning operation.
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When you finish modifying OTM data, create a new backup file. Then you can 
restore the modified data to the original or primary PC where OTM is installed.

Disaster recovery

An important part of safeguarding your OTM data is having a disaster recovery 
plan. This plan should consider who makes the backups, what is backed up, how 
often, on what media, and where the backups are stored.

The full OTM backup is a more comprehensive backup option that is designed for 
disaster recovery. This option automatically backs up all sites, systems, and 
applications, as well as LDAP settings, DBA, the Client list, and Web Navigator 
data such as user groups. Custom Help and Alarm Notification registry settings 
are not backed up. In addition, the full OTM backup saves user-created files, such 
as scripts and customized reports. Consider performing this type of backup at least 
once a month and storing the backup file in a safe place.

In the event of unrecoverable data loss, restore your full OTM backup file first. All 
file contents are restored to the PC. Then, if you have backups for selected sites, 
systems, and applications that are more recent, restore them next.

Note: This operation works particularly well for modifying application 
data. Remember not to restore system property data from one PC to 
another if the PCs need to have different configurations for the 
corresponding sites and systems.

Note: You should back up the Alarm Notification control and script files 
separately. The shipped files may be replaced during a software upgrade.

Note: OTM executables and files that can be reinstalled from the OTM 
CD are excluded in a disaster recovery backup. If OTM executables have 
been damaged or lost due to a hard-disk crash, for example, you must 
reinstall OTM on your repaired or replaced PC before restoring your full 
OTM backup.
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Backing up a single Succession CSE 1000 system

A backup of a single Succession CSE 1000 system includes the Call Server and all 
of its applications, the Gatekeeper Zone (Gatekeeper IP addresses), and Signaling 
Server IP address(es). All Media Gateways belonging to the system are included 
in the backup, as well as all enabled Media Gateway applications. You are not 
given the option of selecting the applications that you want to have backed up. 

Backing up a Branch Office

Although a Branch Office is linked to a Succession CSE 1000 Call Server, it is 
backed up like a separate system with the following exceptions:

• When you back up a single Branch Office, the linked Succession CSE 1000 
system and the association between the two is backed up. Note in Figure 122 
that Branch Office appears as a system type.

• In a Full OTM backup, the Succession CSE 1000 system and its associated 
Branch Office(s) are backed up. The relationship between them is saved.

Note: You cannot back up or restore an individual Media Gateway. The 
Media Gateways are only backed up and restored as components of the 
Succession CSE 1000 system to which they belong.

Note: The backup operation backs up OTM data. This backup operation 
does not back up the actual Succession CSE 1000 or Branch Office.

Note: When you back up a single Succession CSE 1000 system, its 
Media Gateways are backed up; however, its Branch Offices are not.
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Figure 122   OTM Backup Wizard—Branch Office

Running the Backup utility

To run the Backup utility:

1 Select Backup from the Utilities menu of the Navigator window. This invokes 
a wizard to help you define the following parameters:

• Type of backup (single site, single system, all sites and systems, or full 
OTM backup)

• Applications (TBS, Call Tracking, ESN, Station, Traffic, GCAS)

• Destination directory for backup files

• Temporary directory for working files created during the operation

Note: The destination and temporary directory screens display a 
computed space requirement for the files. You can back up and restore 
data for these OTM applications across multiple sites and systems at the 
same time.
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2 The next screen to appear is a dialog box (Figure 123) that summarizes your 
choices. Click OK to start the backup operation, or click Cancel to return to 
the wizard and change your options.

Figure 123   OTM Backup Information dialog box

Restoring a Succession CSE 1000 system

There are two different scenarios for restoring a Succession CSE 1000 system:

• Replace - Deletes the existing Call Server and its Media Gateways, and 
creates a new system from the backup file

• Clone - Creates a new Call Server and its Media Gateways from the backup 
file
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The backup file may contain a different list of Media Gateways than the system 
you are replacing. Also, the Media Gateways in the backup file may now belong 
to a different Call Server. For these reasons, before creating a Media Gateway 
from the backup, a check is made using the site-system name to determine 
whether or not the Media Gateway already exists. If OTM finds that the Media 
Gateway already exists, the OTM Restore Wizard dialog box opens (Figure 124).

Figure 124   OTM Restore Wizard dialog box

When you click Yes, the Create New Media Gateway System dialog box 
(Figure 125) opens, and you are prompted to enter a new site-system name for the 
Media Gateway that is in the backup file.
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Figure 125   Create New Media Gateway System dialog box

If the gatekeeper zone for the Succession CSE 1000 system does not exist, OTM 
creates it. If the gatekeeper zone does exist, but is different from the zone in the 
backup file, OTM prompts you before overwriting the zone.

Table 22 shows an example of the changes that occur when you restore a 
Succession CSE 1000 system using the replace scenario.

Table 22   Using the restore utility to replace a Succession CSE 1000 system

Backup file Existing Result

CSEa_BK CSEa CSEa_BK

MGa_BK MGa MGa_BK

MGb_BK MGc MGb_BKnewName

CSEb CSEb

MGb MGb
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In this example, MGc no longer exists since it was not in the backup file. There is 
no change made to MGb, which is currently associated with CSEb. Since MGb is 
now associated with CSEb, MGb_BK is restored with a new site-system name as 
MGb_BKnewName.

Restoring a Branch Office

Although a Branch Office is linked to a Succession CSE 1000 Call Server, it is 
restored up like a separate system. When you restore a Branch Office from either a 
Full OTM backup or a single Branch Office Backup, the relationship between the 
Branch Office and its associated Succession CSE 1000 system is recognized. If 
the Succession CSE 1000 system has been deleted, the OTM Restore Wizard 
dialog box opens (Figure 126).

Figure 126   Restore Branch Office dialog box

Click Yes. The list of Succession CSE 1000 systems opens (Figure 127).

Figure 127   List of available Succession CSE 1000 systems

Note: When you restore a single Succession CSE 1000 system, its 
Media Gateways are restored; however, its Branch Offices are not.
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Running the Restore utility

To run the Restore utility:

1 Select Restore from the Utilities menu of the Navigator window. This invokes 
a wizard to help you define the following parameters:

• Type of restore (single site, single system, all sites and systems, or full 
OTM backup)

• Specific backup file and destination directory

• Temporary directory for working files created during the operation

2 The next screen to appear is a dialog box that summarizes your choices. Click 
OK to start the restore operation, or click Cancel to return to the wizard and 
change your options.

LDAP Synchronization

In this section, LDAP server refers to an external corporate directory that is 
Lightweight Directory Access Protocol (LDAP) compliant. This is a protocol 
which is used to synchronize data between a master server database and client 
databases. The information is entered into a database once and then synchronized 
to populate the other instances of the data. OTM plays the role of an LDAP client 
in that it can be configured to map certain data fields to a corporate LDAP server. 
Through the use of synchronization, the data is automatically pushed/pulled 
between the databases.

The LDAP Synchronization utility synchronizes user data between the OTM 
Directory, Station Administration data base, and the LDAP directory. LDAP 
Synchronization is a scheduled activity that runs in the background, or can be 
performed manually.

OTM supports four types of LDAP servers:

• Netscape Directory

Note: When restoring user accounts, if the user group and password 
information contained in the operating system data is different, OTM 
does not change the OS data. Instead, a log file is created to inform the 
administrator of the discrepancies.
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• Exchange Server

• Novell NDS

• Active Directory 

There are two parts to LDAP synchronization:

• LDAP synchronizations are set up and scheduled from the Utilities menu in 
the Navigator window. 

• When a new user is added to the LDAP-compliant external corporate 
directory, you can manually add the user entry to the OTM directory for the 
appropriate Meridian 1 or Succession CSE 1000 system. Use the LDAP 
Synchronization menu in the System window.

Before attempting to set up LDAP Synchronization, you must know the address of 
the LDAP server, and also values for the Search Root, Bind to Server as, and 
Password boxes. In addition, you must know the server type and attribute names. 
OTM must be given the ability to write to the LDAP server.

LDAP Synchronization is enabled for OTM Directory entries that are in the 
“Published” status. Only entries in the LDAP-compliant external corporate 
directory that have matching unique identifiers (UIDs) in the OTM Directory are 
synchronized. You can manually enter the UIDs in the OTM Directory entries or 
import them using the procedure outlined in “Import and Export utilities” on 
page 268.

Note: Each type of LDAP server supported by OTM has specific 
constraints regarding the maximum number of characters that you are 
allowed to enter for a given attribute. Synchronization and update 
operations may fail if these limitations are not taken into consideration 
when entering data in the OTM directory.

Note: To deploy LDAP Synchronization, you must be knowledgeable 
about Directory Server configuration and maintenance, LDAP attribute 
customization, and how to work with LDAP-enabled applications. 
Information related to these topics is beyond the scope of this document.
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Setting up LDAP synchronization

To access the LDAP Server Setup dialog box:

The LDAP Server Setup dialog box opens with the Directory Server tab 
displayed (Figure 128).

Figure 128   LDAP Server Setup dialog box—Directory Server tab

Directory Server tab

The Directory Server tab (Figure 128) defines the LDAP Server.

Choose Utility > LDAP Setup and Logs in the OTM Navigator window.
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Enter the server information, then click Test Connection to verify the settings.

Mapping tab

The Mapping tab (Figure 129) identifies how the data between the OTM Directory 
and the LDAP Server is synchronized.

Figure 129   LDAP Server Setup dialog box—Mapping tab

Note: The Test Connections button tests whether the server responds 
and verifies the LDAP Server IP address and port number only.

Caution: You must click Apply to apply any changes made in the 
Directory Server tab before selecting another tab.
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To refresh the displayed attributes on the Server Attribute drop-down menu, 
highlight one item from the Attribute List, and then click Get Attributes.

To map individual data items, click the OTM data element in the list, select the 
mapping direction, and select the associated attribute in the LDAP Server. See 
“OTM fields and LDAP attributes” on page 299 for more information.

Only elements that you enable via the check box are synchronized during the 
scheduled synchronization periods.

Synchronization tab

Use the Synchronization tab (Figure 130) to schedule the synchronization 
between the OTM directories and the LDAP Server. The list contains all 
Meridian 1 and Succession CSE 1000 systems defined in the OTM Navigator. 

Note: You must select an attribute in the Attribute List box before you 
click Get Attributes in the Selected Attribute box.

Note: On a new OTM installation, the Display Name field is not visible 
in the Attribute list. The Display Name is added to the OTM Directory 
after synchronization with the Meridian 1 or Succession CSE 1000 
system. You should perform LDAP synchronization after 
synchronization with the Meridian 1 or Succession CSE 1000 system.

Note: It is not necessary to schedule a separate synchronization for each 
site or system. Also, when you add new systems to the OTM Navigator it 
is not necessary to schedule additional synchronization tasks. Nortel 
Networks recommends that you modify your existing synchronization 
task to include the new systems.

Note: If an LDAP synchronization is in the queue and scheduled for a 
system or systems, and a change in one of the systems is required, 
change the selection of the systems to be synchronized in the currently 
scheduled job rather than scheduling a second synchronization. When 
the synchronization is run at the scheduled time, it will pick up the latest 
selection.
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Figure 130   LDAP Server Setup dialog box—Synchronization tab

Check the systems to be synchronized and set the schedule. You can choose to 
compare the data only, or to actually perform updates.

Note: Scheduled synchronization only synchronizes OTM Directory 
entries for which the “Published” attribute has been enabled. 
Synchronization also only compares or updates entries that have the 
same Unique Identifier (UID) between OTM Directory and the LDAP 
Server. A UID can be manually set up using the LDAP Synchronization 
Utility (see “LDAP Synchronization Utility” on page 298), or by using 
the Import / Export capability (see “Importing LDAP ID (UID) Using an 
Entity’s Extension Number (DN)” on page 302).
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Logs tab

A background routine performs synchronization at the scheduled time, and stores 
the results in a log in an OTM directory. The Logs tab (Figure 131) displays the 
log files. You can open a file for viewing, or delete a file.

Figure 131   LDAP Server Setup dialog box—Logs tab

Note: Synchronization results can also be viewed from the Web. See 
“Sync Tasks and Logs page” on page 339.
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LDAP Synchronization Utility

You can use the LDAP Synchronization window (Figure 132) to manually 
synchronize data between the LDAP Server and an OTM directory. In doing so, 
you assign a Unique Identifier (UID) for each OTM Directory Entity. To start the 
utility, double-click on the LDAP Synchronization icon in the System Window.

You can perform manual synchronization when a new employee is added in the 
LDAP Server and you want to add the employee data into the appropriate OTM 
directory.

Figure 132   LDAP Synchronization window
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To delete a record that you may have added to the OTM Directory in error, you 
must use OTM Directory Services. See “Delete employees” on page 167 for more 
information. 

OTM fields and LDAP attributes

LDAP attributes are mapped to OTM fields during synchronization (or manually 
by clicking on the Sync button, or at a scheduled time). The fields are mapped 
according to the configuration set in the Mapping table (see Figure 129).

When you click Add in the LDAP Synchronization dialog box, the LDAP 
attributes are copied to the corresponding OTM fields. 

Note: The LDAP Synchronization window does not provide a report of 
success or failure in synchronizing data.

Note: During the synchronization process, you are not provided with a 
indication of progress. To estimate the time required for the 
synchronization process, check the start and end times for past 
synchronizations in the PC Event list.

Note: Only the fields that are mapped from LDAP to OTM are copied 
when you click Add.

Caution: UID, Last Name, and First Name must be mapped. You receive 
a warning message when you exit the Mapping tab if they are not mapped.
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Table 23 provides the recommended mapping between LDAP Directory attributes 
and OTM Directory attributes. 

Table 23   LDAP recommended mapping

OTM Directory attribute

Allowed 
mapping 
direction

Typical LDAP Directory 
attribute Comment

Unique Identifier (uid - new 
directory cross referenced 
field)

linkage uid, or cn (Active Directory) “uid” or “cn” must be entered in 
the OTM Directory before the 
synchronization routine can 
synchronize the entry with 
LDAP.

Identification (UsrID) both employeeNumber, or 
employeeID (Active Directory)

Last Name (EmpLName) both sn

First Name (EmpFName) both givenName

Middle Name (EmpMName) both Initials Not mapped by default. 

Department (derived) both departmentnumber (Netscape, 
Active Directory),
department (Exchange), or
orgnaizationalUnitName (Novell)

Department is the end “node” 
of the organization path in the 
OTM Directory.

Email (Email) both mail

Manager (ManagedBy) both manager (Netscape, Novell)

<== manager (Exchange, Active 
Directory)

Job Title (JobTitle) both title

Station Location (derived: 
site-system-cross reference 
field)

==> otmFullPhoneID Must be present if telephone 
attributes (extension number, 
external telephone number, 
Terminal Number, etc.) are 
mapped. Telephone Location 
consists of a “Site-System- 
PhoneID” string formed from 
the OTM site and system and 
the location configured in 
Station Administration. This 
allows you to uniquely identify 
a telephone. This is not a 
regular field in LDAP. If desired, 
define as a new field in LDAP 
for OTM.
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Display Name 
(NameDisplay) (new cross 
referenced field)

both otmTelephoneNameDisplay This is not a regular field in 
LDAP. This field contains the 
display name (CPND) for the 
Directory Numbers belonging 
to the user. If desired, define as 
a new field in LDAP for OTM.

Extension (cross referenced 
field)

both otmTelephoneNumber

External Telephone Number 
(ExternaltelephoneNumber 
(derived)

==> otmExternalTelephoneNumber Not a regular field in LDAP. If 
desired, define as a new field in 
LDAP for OTM.

ESN Telephone Number 
(ESNtelephoneNumber 
(derived))

==> otmESNtelephoneNumber Not a regular field in LDAP. If 
desired, define as a new field in 
LDAP for OTM.

Terminal Number 
(TelephoneTerminalNumber 
(derived))

==> otmTelephoneTerminalNumber Not a regular field in LDAP. If 
desired, define as a new field in 
LDAP for OTM. Typical 
mapping direction: LDAP to 
OTM.

Account Code (cross 
referenced field)

both otmTelephoneAccountCode Not a regular field in LDAP. If 
desired, define as a new field in 
LDAP for OTM. Typical 
mapping direction: LDAP to 
OTM.

Authorization Code (cross 
referenced field)

both otmTelephoneAuthCode Not a regular field in LDAP. If 
desired, define as a new field in 
LDAP for OTM. Typical 
mapping direction: LDAP to 
OTM.

Street/No (address) both postalAdress Typical direction LDAP to OTM

City (City) both l Typical direction LDAP to OTM

Prov/State (Prov/State) both st Typical direction LDAP to OTM

Country (Country) both co Typical direction LDAP to OTM

Postal/Zip (Postal) both postalCode Typical direction LDAP to OTM

Table 23   LDAP recommended mapping (continued)

OTM Directory attribute

Allowed 
mapping 
direction

Typical LDAP Directory 
attribute Comment
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Importing attributes to OTM Directory

Use the Import/Export Utility to import data from external sources to the OTM 
Directory. The example that follows shows how to import a UID from an LDAP 
database to a user with an extension number in OTM Directory. You can use the 
same method to import a UID using other data, such as Manager’s Name, E-Mail 
Address, and so on.

Importing LDAP ID (UID) Using an Entity’s Extension Number (DN)

In the following example, the LDAP ID of a user (Bill President) is imported 
using his extension number (7000).

1 Create a text file that maps the extension number of the entity to his or her 
UID. The first row should state the name of the column: in this case, column 1 
is Extension, and column 2 is the UID. More records can be added to the file. 
In this example, the file is named C:\extuidmap.txt, and contains the following 
text:

“Extension”, “UID”
7000, bpresldapid

2 Launch the Import utility. This utility can be launched from a number of 
applications. In this example, the Import dialog box (Figure 133) was opened 
by selecting File > Import... in the Telecom Billing System (TBS) application.

Figure 133   Import dialog box

a Select “Corporate Directory Import” from the drop-down list of Import 
Configurations.

b Click the ellipsis button.

Note: The entity should be the prime owner of the extension for this 
import to be successful.
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The Import - Telecom Billing System(GB) dialog box opens (Figure 134).

Figure 134   Import - Telecom Billing System(GB) dialog box

3 In the Import - Telecom Billing System(GB) dialog box (Figure 134), select 
Corporate Directory Views and check the All Assets box.

4 Select Text File (Comma Separated Values) from the drop-down list of 
available File/Database Types.

5 Click the ellipsis button, and select the File/Database Location. In this 
example, the file created in step 1 is stored in C:\.

6 Use the drop-down list to select the File/Table Name. In this example, the file 
is called extuidmap.txt.

7 Select Update Matching from the Update Activity drop-down list. This 
indicates that only records satisfying the search criteria will be updated.

8 Click Format to open the mapping dialog box (Figure 135).

The next steps in the procedure map the extension and UID fields in the 
corporate directory to the correct columns in the text file.
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9 Use the left double arrow button to clear the Selected Columns list.

10 Select the Extension Field by clicking the Extension Asset in the Available 
Columns List, and then clicking the right arrow button. This is the field in the 
Corporate Directory.

11 To map this field to the column in the text file that was created, select the 
proper External Column Name. In this example, the first column in the text 
file was called “Extension”.

12 Check the Include in Alternate Key check box. This indicates that the 
extension is used as the search criteria. The system adds the LDAP ID to the 
entity owning this extension (i.e., the Prime Owner).

Figure 135   Mapping extensions and UID field to Corporate Directory

13 Use the same procedure to select the Unique Identifier Asset and map it to the 
UID External Column Name. Do not check the Include in Alternate Key 
check box for this field.

14 Click OK to close the dialog box, and click GO in the configuration dialog 
box (Figure 133 on page 302) to begin the import process.
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When the import is completed, the Corporate Data Import summary dialog 
box appears (Figure 136).

Figure 136   Corporate Directory Import summary

In this example, the summary indicates that one record was read in and one 
record was updated.

15 The final step is to verify that the Unique Identifier Asset (LDAP ID) was 
added into the employee record for Bill President. From Station 
Administration, choose View > Employee Selector. Double-click the record 
for Bill President, and verify that the Unique Identifier Asset for this 
employee (bpresldapid) is listed (Figure 137).
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Figure 137   Employee Editor dialog box

LDAP troubleshooting tips

Table 24 provides information that you will find useful if you encounter problems 
in the integration of OTM with your LDAP server.

Table 24   LDAP troubleshooting tips

Problem Suggestion(s)

Test connection fails • Ensure that the IP address or Hostname 
of the LDAP server is correct.

• Ensure that Bind to Server as and 
Password are correct.

Cannot retrieve data from OTM directory • Ensure that attributes are mapped and 
enabled.

Cannot retrieve data from LDAP server • Ensure that Server Type, Search Root, 
and Port Number are correct.

Cannot update data in LDAP server • Ensure that Bind to Server as and 
Password are correct.
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Table 25 provides a list of frequently asked questions related to the integration of 
OTM with your LDAP server.

Data is not synchronized • Ensure that Publish field is checked.
• Ensure that data in OTM and LDAP 

directories have the same UIDs. (Note 
that UIDs are case sensitive.)

• Ensure that fields are mapped correctly 
and enabled.

• Ensure that Mapping Direction is 
correct.

• Ensure that the Compare and Update 
field is checked.

• Check the log file for details.

Log file does not appear in the Logs tab of 
the LDAP Server Setup dialog box

• The synchronization logs view does not 
automatically refresh itself. Update the 
list of files by closing and reopening the 
LDAP Server Setup dialog box.

Table 25   LDAP frequently asked questions

Question Answer

How do I verify that the LDAP server 
information is correct?

Use the Address Book utility in Netscape or 
the Find People utility in Outlook Express to 
verify
Netscape:
1. Setup LDAP Server: Communicator > 

Address Book > File > New Directory > 
Enter LDAP Server details.

2. Perform lookup: Enter search filter in the 
Show Name Containing field and click 
on the directory name under Directory 
to begin the search.

Outlook Express:
1. Setup LDAP Server: Tools > Account > 

Add > Directory Service > Enter LDAP 
Server’s IP address.

2. Perform lookup: Find > People > Select 
LDAP Server > Enter Search filter and 
click the Find Now button to begin the 
search.

Table 24   LDAP troubleshooting tips (continued)

Problem Suggestion(s)
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Can OTM sync to more that one LDAP 
server?

No, OTM is designed to sync to only one 
LDAP server.

What LDAP version does OTM support? LDAP v3.

What default I/O port does OTM use for 
LDAP?

The default port is 389. Your corporate 
LDAP server may use a different port.

What LDAP directory servers does OTM 
support?

• Netscape Directory (v3.0 and above)
• Exchange Server (v5.5 and above)
• Novell NDS (v7.09 and above)

• Active Directory (v1.0 and above)

How much network bandwidth does LDAP 
synchronization use?

The maximum network bandwidth required 
for LDAP synchronization is 720 Kbps per 
Meridian 1 or Succession CSE 1000 
system. Nortel Networks recommends that 
synchronization be scheduled to occur once 
each week during off hours.

Can a third-party server be given direct 
access the OTM directory?

No, the OTM Server is not LDAP enabled. 
OTM provides an LDAP client and a sync 
agent to synchronize with external LDAP 
servers. It is not possible to use a 
third-party LDAP client to connect to the 
OTM directory as you would a real directory 
such as Netscape Directory.

How do I add new users to the OTM 
directory?

There are two methods for adding new 
users:
• Manual add from the LDAP Sync Utility

• Bulk add through the Import Utility

What file/database types does OTM 
support for Import/Export?

• dBase IV
• Microsoft Excel (v5 and above)

• Microsoft Access
• ODBC data source
• Text file (comma separated)

• Text file (fixed width)

How do I create the OTM directory for a new 
customer?

1. Export the customer’s date using one of 
the supported Import/Export file/
database types.

2. Use the Import Utility to import the data 
into OTM.

Table 25   LDAP frequently asked questions (continued)

Question Answer
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What Meridian 1 or Succession CSE 1000 
services/parameters can I change using 
LDAP Synchronization?

The LDAP Synchronization Utility 
synchronizes user data between the OTM 
directory, Station Administration database, 
and the LDAP compliant directory. No other 
parameters are currently supported. For a 
list of the supported parameters, or 
attributes, see Table 23 on page 300.

What kind of scripts can I develop for use 
with LDAP Synchronization?

OTM does not support scripting for LDAP 
Synchronization.

What LDAP standards based features are 
supported by OTM?

OTM only supports lookup and 
synchronization to an LDAP directory using 
the application tools within OTM.

How can I perform mass changes in OTM? The Global Update function within OTM 
allows you to change common data values 
across multiple stations. Data import/export 
can also be used to manage large data 
transactions.

Can I perform mass changes using LDAP 
Synchronization?

The function of LDAP Synchronization 
Utility is to keep data aligned, not to import 
data. When you perform a lookup on an 
LDAP server and link a subscriber for 
synchronization, many of the subscriber’s 
properties are copied to the OTM directory; 
however, this is done one subscriber at a 
time. The Import/Export utility is better 
option for bulk import operations.

Does OTM use a proprietary database? If 
so, can I use ODBC-compliant SQL 
commands to perform synchronization?

OTM utilizes several databases in its 
various applications. These databases are 
not accessible to you except through OTM 
applications and the Import/Export utility.

How do I use the Import/Export Utility to 
populate user data in the OTM directory?

1. Use data import to import a set of Last 
Names and UIDs. For an example, see 
“Importing LDAP ID (UID) Using an 
Entity’s Extension Number (DN)” on 
page 302.

2. Pull in all of the remaining attributes 
during the first sync routine.

I want to synchronize the fields in both 
directions from LDAP server to OTM and 
from OTM to LDAP server. Is this possible?

Yes, synchronization in both directions is 
one of the choices and is configurable for 
each field. For a list of fields and the 
recommend sync direction, see Table 23 on 
page 300.

Table 25   LDAP frequently asked questions (continued)

Question Answer
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Client Utility

Use the Client Utility to update the OTM database when the host name or IP 
address of an OTM Client computer has changed. You also use the Client Utility 
to remove an OTM Client computer from the OTM database when you want to 
reassign the Client license to a new OTM Client.

To launch the Client Utility:

Does OTM LDAP synchronization work with 
CallPilot?

No, CallPilot does not support 
synchronization with an LDAP server, and 
does not support LDAP clients as an LDAP 
server.

I am adding a new messaging system 
(CallPilot or Meridian Mail). How do I import 
user information from the OTM Directory to 
the new messaging system?

1. Use the Import/Export utility to export 
relevant user data, such as Last Name, 
First Name, and Department, from the 
OTM directory to a comma separated 
file.

2. Edit the file to add the mailbox number 
for each user.

3. Use the edited file as the data file for 
importing to CallPilot using the AutoAdd 
function or to Meridian Mail using the 
AutoAdmin utility. Refer to the CallPilot 
or Meridian Mail administration guides 
for details.

Select Utilities > Clients in the OTM Navigator window.
The dialog box shown in Figure 138 opens.

Table 25   LDAP frequently asked questions (continued)

Question Answer
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Figure 138   Client Utility dialog box

To change the host name or IP address assigned to an OTM Client:

1 Select an OTM Client from the Client Utility dialog box.

2 Click Edit.

The Client Properties dialog box opens (Figure 139).

Figure 139   Client Properties dialog box

3 Edit the host name or IP address as required.

4 Click OK to update the OTM database.
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To remove an OTM Client:

1 Select an OTM Client from the Client Utility dialog box.

2 Click Remove.

A confirmation dialog box opens.

3 Click OK to remove the OTM Client from the database.

Equipment Data Dump

OTM’s Equipment Data Dump (EDD) is a critical data base update operation on 
the Meridian 1 and Succession CSE 1000 systems. This operation dumps (saves) 
modified data from the switch’s resident memory to data base files on the switch’s 
hard disk. These data base files contain the active configuration information for 
phone-system terminals and users.

Synchronizing and securing data

Use OTM’s Station Administration and ESN applications to modify station data, 
Call Party Name Display (CPND) data, and Electronic Switched Network (ESN) 
data. OTM stores these changes in its PC data base files. The phone system cannot 
recognize these changes, however, until you upload the modified data to the 
Meridian 1 or Succession CSE 1000 system. This operation synchronizes switch 
data with current OTM data on the PC.

Updating the switch’s data is a two-step process. The first step is to transmit 
modified OTM data from the PC to the switch’s resident memory. OTM’s Station 
Administration and ESN applications include a Synchronize menu for this 
purpose. The second step is to use OTM’s EDD feature to dump modified data 
from the switch’s resident memory to the switch’s hard disk.

To secure modified data on large, non-Option 11C Meridian 1 systems, you must 
dump it to the switch’s hard disk. Optionally, your distributor technician can set 
up the switch so that you also dump data to a disk that you insert in the switch’s 
floppy drive.
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Power interruptions erase all data in resident memory. When power is restored, 
switch data is automatically restored from its data base files on the hard disk. 
Modified data that was not previously dumped to these data base files is lost at the 
switch. Further, this data may be difficult to isolate in the PC’s OTM applications, 
since all previously uploaded data shares the same TRN (transmitted) status. For 
these reasons, always perform or schedule data dumps after uploading data to the 
switch.

Accessing EDD

You can access EDD from the File menu of the System window. The EDD 
selection is called Data Dump. This selection has its own submenu with the 
options Now, Schedule, and View Log.

You can select Now to perform the data dump immediately, Schedule to set up the 
operation to run automatically, or View Log to review status and error information 
from the most recent data dump.

The data-dump operation takes just a few minutes. While modified OTM data is 
being dumped at the switch, status and error information about the data dump is 
actively logged to the PC. Both Now and View Log open the EDD Data Dump 
dialog box for viewing or reviewing, respectively, this status and error 
information. This log is saved to the PC’s hard disk and each data dump 
overwrites the existing log file.

Note: If you select Now, your request is sent to the scheduler queue, 
which executes the task within the next minute. If there are tasks in the 
queue that have a higher priority and are scheduled to be executed at the 
same time, they are executed first.

Note: To access error information, open the Events window after the 
data dump, and double-click each error event of interest. This invokes 
help that is specific to each error.
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Figure 140   EDD Data Dump dialog box

The Schedule option opens the Scheduling dialog box. Here you can select when 
and how often you want to dump data at the switch. It is best to schedule this 
operation for a time soon after uploading OTM data to the switch. The OTM 
Scheduler sends the job to the Queue Manager at the designated time.

Responding to a connection failure

If you are connected to a Meridian 1 or Succession CSE 1000 system and that 
connection fails, a warning message appears (Figure 141).
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Figure 141   Connection Failure dialog box

You are given the following options:

• Close all system windows and reconnect to the system.

• Leave the system windows open so that you can copy or print any or all of the 
following information:

— Command results in the System Terminal window or any open 
Maintenance window

— Alarms or events in the System Event Log

— Maintenance window objects, such as network loops within the Network 
Loops window

• Attempt to reconnect to the system.

Note: When you have finished printing the desired information, close 
the system window and reconnect to the system.
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Chapter 3
Web Services

OTM provides both Web (http) and Microsoft Windows versions of many of its 
applications. This chapter discusses the Web versions of those applications:

• OTM Web Navigator

• OTM Web Alarm Browser

• OTM Maintenance Pages

• Customizable Web Help

• User Access and Session Monitor pages

• Web System Terminal

• Desktop Services (an end-user application that provides web pages that 
display the configuration of the user’s telephone as well as provide telephone 
troubleshooting and feature information. With appropriate permissions, the 
end user is also provided with the ability to change keys and features.)

OTM Web Navigator

Access to the OTM Web Navigator utilizes the users and groups functionality in 
Windows NT and Windows 2000. User authentication can also be accomplished 
using Windows NT domain accounts or LDAP. Domain accounts and LDAP 
authentication are normally used for EndUsers who will be accessing Web 
Desktop Services to administer their telephones.

The OTM Web Navigator provides the following:

• A list of systems and devices; users click on a system or device to:

— Open a Web System Terminal or URL to manage a system or device

— Open Maintenance Pages for performing maintenance operations on 
Meridian 1 or Succession CSE 1000 hardware
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• Web-based alarm browser to view alarms and events from multiple systems 
and devices

• The ability to locate telephones, view and change configuration data

• Web-based Maintenance Pages to perform maintenance operations (enable, 
disable, etc.) on Meridian 1 or Succession CSE 1000 system hardware

• OTM Web configuration pages (login access, LDAP sync reports, and so 
forth)

The OTM administrator has the responsibility of installing, configuring, and 
maintaining OTM Web Services. 

User Login and Security

Users log in to the OTM Web Navigator using their Microsoft Windows NT 
userID and password. Login security for OTM Web Services ensures protection 
against unauthorized entry and enforces access permissions for logged on users.

There are three categories of users:

• Administrators — OTM administrators

• HelpDesk — OTM Help desk users

• EndUser — OTM end users

In addition, there is a Default user category. Default users are able to successfully 
log in to the Web Navigator, but they do not have an User Group defined in their 
Directory record.

OTM administrators and Help desk users have user accounts in a Windows NT 
domain. End users may have accounts either in a Windows NT domain or through 
an LDAP server.

OTM administrators and Help desk users can access and change their own 
telephones through either the Web Navigator or the Desktop Services end user 
pages. Access to the end user pages requires the appropriate OTM directory setup 
(user login and user group) for these administrators and Help desk users.
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OTM Web application access permissions are controlled by the Administrator on 
a per-Windows NT user group basis. For example, the administrator may limit the 
OTM users access to only some of the OTM Web-based functionality. The OTM 
Web Navigator controls access to applications by shielding Web links that the user 
does not have access to. The directories and files comprising those applications 
are similarly protected.

The administrator configures Windows NT user groups and individual users using 
the Windows NT user interface. The administrator then determines the access 
permissions for each user group by using the OTM Web Navigator page. For more 
information about setting user access, refer to “User Groups” on page 359.

When Web Navigator users first point a browser to the OTM Navigator Web site, a 
check is performed to see if the user has the required OTM Java plug-in. If the 
plug-in is not installed, the administrator or Help desk user is given the option of 
downloading and installing the plug-in. This operation is similar to the standard 
download operations in that the user must download the plug-in to their hard disk 
then it self installs onto the machine.

While the plug-in check is being performed, the OTM splash screen appears. If the 
plug-in is installed, or after installation of the plug-in, the user is taken to the login 
page.

The default OTM URL is the end user login page. To navigate to the administrator 
login page, place /admin after the OTM IP address or host name.

Figure 142 shows the OTM Login page. If the login is successful, a blank OTM 
Web home page appears. If login is denied, an error message appears.

Note: As a security precaution, with any upgrade or reinstallation of 
OTM software, access properties for all user groups are reset to the 
default values.
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Figure 142   OTM Navigator Administrator Login page

Access properties

When OTM starts for the first time, the Administrator, HelpDesk, EndUser, and 
Default user groups are the only active user groups. You must assign access 
properties for any other Windows NT Groups that you have set up on the OTM 
Server.

Administrator Group access properties

Persons belonging to the Administrators user group on the OTM Server can log in 
to the OTM Web site and get unrestricted access. The Administrators group has 
unrestricted access by default. You are not able to alter access permissions for the 
Administrators user group.
553-3001-330 Standard 3.00 November 2002



Web Services 321
Users of the OTM Administration Site belong to a distinct user group and are 
assigned the security profile for that user group. For example, the Administrators 
user group has access to all Web applications.

User group access rights

The Administrator logs in to the OTM Administration web site and assigns access 
rights to the other user groups. By default, a member of the Administrators user 
group has access to all OTM Web Applications. HelpDesk users have access to all 
applications except those listed under Web Administration. No other user groups 
have any access to OTM Web Applications unless you specifically grant that 
group appropriate permissions.

From the User Groups page, you grant or deny access to web applications to a 
group, not to individual users. To change the security access for individual users, 
their group membership should be changed. For new groups, the Administrator 
must assign access rights for web applications before any users from that group 
can log in. For information about setting user access, refer to “User Groups” on 
page 359.

With the exception of Administrators, do not place a person in multiple groups. 
The first group detected by OTM is used to determine access permissions. There 
is no restriction on the Administrators group. Users may belong to other groups, 
but if they belong to the Administrators group, the Administrators profile 
overrides all other profiles. 

While assigning access permissions, be certain that you select the top level 
application for every subapplication that you assign. For example, if you are 
selecting “System Alarms,” you must also select “Equipment.” Failure to do so 
can result in members of the user group being denied access to the web site.

Note: Important advice for localized operating systems — The name of 
the administrators user group in the French and German operating 
systems is not Administrators. These names are localized by Microsoft 
in the regional operating system software. In a default French installation 
of Windows NT or Windows 2000, the local administrators user group is 
Administrateurs. In the German version this user group is 
Administratoren. When installed on a French or German OS, the OTM 
predefined administrators user group will be named Administrateurs or 
Administratoren to match the OS.
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Equipment

The Equipment heading in the OTM Web navigator tree provides links to the 
OTM Status page, the Web-based System Navigator, and the Alarm browser.

OTM Status

The OTM current status page is shown in Figure 143. As the administrator, you 
can access this page at any time by clicking Home.

The OTM Status page contains:

• Release version of the OTM software

• Last login date and time

• Real time status of OTM Server applications:

— Started

— Running

— Not Responding

— Stopped

• Number of logged in users
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Figure 143   OTM Status page

System Navigator

The OTM System Navigator page shows the names and types of all systems 
available to the current user, and allows you to group the systems into sites for 
more convenient access. Once grouped, the systems can be viewed by site as 
shown in the example of the OTM System Navigator in Figure 144, or by 
gatekeeper zone as shown in Figure 145. The sites, systems, and applications 
shown are dependent on the software packages installed, your security access 
permissions, and the type of system device you select.

The gatekeepers only appear in the Gatekeepers Zones view. Although primarily 
used for Succession CSE 1000 systems, Meridian 1 systems can be assigned to a 
gatekeeper zone. This functionality is intended for Meridian 1 systems that are 
equipped with ITG applications that support gatekeeper operation.
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In the Sites view, Media Gateways appear in the tree under their associated site, as 
well as under the heading Media Gateways beneath the appropriate Succession 
CSE 1000 system. Under the Media Gateways heading, the Media Gateway name 
is composed of the Site name and the system name. If the Call Server and Media 
Gateway are in the same site, the Media Gateway only appears under the Media 
Gateways heading of the associated Succession CSE 1000 system.

In the Gatekeeper Zones view, Media Gateways only appear beneath the Media 
Gateways heading of the associated Succession CSE 1000 system.

In the Sites view, Survivable IP Expansion cabinets appear in the tree under their 
associated site, as well as under the heading Survivable Cabinets beneath the 
appropriate Option 11C main cabinet. If the main cabinet and Survivable IP 
Expansion cabinet are in the same site, the Survivable IP Expansion cabinet only 
appears under the Survivable Cabinets heading of the associated Option 11C 
system.

In the Gatekeeper Zones view, Survivable IP Expansion Cabinets only appear 
beneath the Survivable cabinets heading of the associated Option 11C system. 

Note: OTM does not display the survivable status of Media Gateways 
and Survivable IP Expansion cabinets.
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Figure 144   OTM Web Navigator—Sites view
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Figure 145   OTM Web Navigator—Gatekeeper Zones view

The OTM Windows Navigator, which uses the Microsoft Windows interface, 
provides access to OTM’s Windows-based features and services. For more 
information about the OTM Windows Navigator and the features and services to 
which it provides access, see “OTM Windows Navigator” on page 65.

The OTM Web Navigator allows you to do the following:

• Display a “tree” structure for the Gatekeeper Zones on the network that you 
manage. Access systems in a particular zone by opening the zone.

• Display a “tree” structure for the Sites and Systems on the network that you 
manage. Access systems at a site by opening that site.
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• Launch Web applications such as Maintenance Pages and the Alarm Browser.

For Meridian 1 and Succession CSE 1000 systems:

— Web Dect Application - Launches the Digital Enhanced Cordless 
Telecommunications (DECT) system management tool. The DECT 
product is not distributed in North America.

— TBSWEB - Provides access to the Telecom Billing System Web 
Reporting application.

— Web Alarm Mgmt. - Opens the Systems Alarms page with only the alarms 
for the selected Meridian 1 or Succession CSE 1000 system displayed.

— Web Maint. Windows - Opens the Web-based Maintenance Pages 
application.

— Web Common Services - Launches a web-based Virtual System Terminal 
connection to the overlays and includes online Help.

For generic systems:

— Web-based Telnet connection.

— Management URL for the system.

— Alarms for the selected system. This opens the Systems Alarms page with 
only the alarms for the selected generic system displayed. 

Note: Double-click the System Applications to launch the associated 
OTM Web application in a new browser window (for example, 
double-click on Web Maint. Windows to launch Maintenance Pages).

Note: Double-click the System Web Sites to launch the element 
management web pages on the associated Signaling Server.

Note: Double-click a Gatekeeper to launch the associated management 
web page.
Using Optivity Telephony Manager Release 2.0x



328 Web Services
The list of applications is determined by the OTM System Properties in the OTM 
Windows Navigator and the Virtual Terminal Setup. See “OTM Web Virtual 
System Terminal” on page 370.

Web Maintenance Windows

You can use Web Maintenance Windows to perform maintenance operations on 
Meridian 1 or Succession CSE 1000 system hardware. To launch Web 
Maintenance Windows, click the “Web Maint. Windows” link under the target 
system on the System Navigator page. Figure 146 shows the browser page that 
opens when you launch Web Maintenance Windows. For more information on 
OTM Web Maintenance Windows, See “Web-based maintenance” on page 741.

Note: The dongle on the OTM Server is checked each time a user 
attempts to launch an OTM Web application. If the user login fails 
because the dongle is missing, the message “Login failed because the 
OTM Server is missing the required security device” appears.
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Figure 146   Maintenance Pages

Alarms

The Alarm browser page contains a list of alarms received by the Alarm Manager 
Service running on the OTM Server. The list contains alarms and events from 
multiple systems and devices. You can perform the following actions:

• Sort the alarms by clicking on a column header.

• Resize the columns.

• Filter the list via the Show check boxes.

• Page through the list via the First/Last/Next/Previous buttons, or use the Page 
drop-down box to jump to a particular page.

• Set the auto refresh interval.

• Double-click an alarm for help.
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• Single-click an alarm to view full alarm details in the Alarm details pane.

See Chapter 5, “Alarm management,” on page 653 for more information.

Figure 147   OTM Alarm browser page

Note: Access to the Alarm browser page is controlled at the Web 
Navigator level for each User Group. The users in the User Group either 
have access to the alarms for all monitored devices, or no access to 
alarms.
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Web Station

The Web Station heading in the OTM Web navigator tree provides links to the 
Telephones pages, the Directory Update page, and the Sync Tasks and Logs page.

Telephones

The Telephones pages are used to find a telephone or a group of telephones and 
perform administrative tasks on them. Use the Find Telephones page to locate the 
telephone(s) that you want to administer. The results of the Find operation appear 
in the Find Results page. From the Find Results page, you can access the 
telephone pages for an individual telephone.

Find Telephones page

The Find Telephones page (Figure 148) allows you to search for telephones in the 
OTM station database. If allowed by the system administrator, other user groups, 
typically HelpDesk users, may also have access to this page. See “User group 
access rights” on page 321. To launch the Find Telephones page, click the 
Telephones link located under Web Station in the OTM Web Navigator tree. Select 
a system, and enter the desired search criteria. The search returns a list of 
telephones.

• The drop-down list of systems contains all Meridian 1 and Succession 
CSE 1000 systems supported by this web site. The list contains both the site 
and system names as defined in the OTM Windows Navigator. 

• The station database search only retrieves Prime DNs.

• The default search is by Last Name. 

Note: Leave the text box empty to perform a find all operation. Do not 
use the wildcard character “*” as you do in Directory Update.
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Figure 148   OTM Administrator Find Telephones search page

If a user group has access to the Find Telephones page but does not have access to 
the Web Station Admin application for any system, the Find Telephones page 
appears (Figure 149). All elements are disabled and a message at the top of the 
page explains the problem.

Note: Telephones is a Web Navigator level application; however, access 
to particular sites and systems can be controlled at the User Group level. 
To accomplish this, set the Telephones application to “ReadWrite,” and 
set the Web Station application for each site-system to “ReadWrite” or 
“Access Denied,” as appropriate. The systems for which access is denied 
do not appear in the Site-System drop down list.
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Figure 149   Find Telephones page with no system access

Find Results page

The Find Results page displays the list of telephones matching the search 
parameters.

• By clicking on the Location link, you open up a new browser window, which 
displays the Telephone pages for the telephone set. These are the same pages 
that appear when a desktop user displays his telephone using Web Desktop 
Services (see “Web Desktop Services” on page 381).

• Above the results, the number of items found and the numbers associated with 
the currently displayed items appears.
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• You can sort on any field via the “Sorted by” drop-down list. When you select 
a new sort, the results appear starting at the first page.

• Click Find Again to go back to the Find Telephones page.

• If there are no telephones matching the search parameters, a “Found None” 
message appears with a Find Again button (that takes you back to the Find 
Telephones page).

Figure 150   OTM Administrator Find Telephones results page

Note: After you modify a telephone’s location on the General page in 
the Telephone pages, you should click Refresh from Database on the 
Find Results page. This updates the Location information and the HTML 
link to the Telephone pages. See “Telephone General page” on page 394.
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Directory Update page

This page is used to perform global changes on the following OTM Directory 
fields:

• User Group

• Login

• Reporting access group

• Publish status

The User Group field determines the degree of access that the user has to the 
Desktop Services Web pages, as well as to Windows and Web-based OTM 
applications. You may set the User Group field to Administrators, HelpDesk, 
Default, EndUser, or to any customized user group that you may have configured 
in OTM. For information on the degree of access provided to the different user 
groups, see “User Groups” on page 359.

The login field is the user’s Windows NT login name. When the user logs in to the 
Desktop Services web pages, OTM validates the login with Windows NT. If login 
is successful, OTM looks up the user’s Desktop User Group field in the OTM 
Directory to determine which telephone features to display.

The reporting access group field determines the user’s access to the Web reports 
feature in Telecom Billing Services. You may set this field to All, Peer, Managed, 
Personal, or No Access. See “Telecom Billing Services” in Using Optivity 
Telephony Manager Telemanagement Applications (553-3001-331) for 
information on the Web reports feature.

The Publish status field determines whether information on an employee or entity 
in the OTM Directory is synchronized with the LDAP server. Only employees 
who are published are synchronized with the LDAP server.

To make a Directory update:

1 Click Directory Update, which is located under Directory in the OTM web 
navigator tree.
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The Directory Update page opens (Figure 151). Use this page to select the 
Meridian 1 or Succession CSE 1000 system and to find the directory entries 
that you want to change.

Figure 151   Directory Update - find entries

Note: If a user group has access to the Directory Update page but does 
not have access to the Web Station Administration application for any 
system, the Directory Update page appears (Figure 152). All elements 
are disabled and a message at the top of the page explains the problem.
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Figure 152   Directory Update with no system access

2 From the drop-down menu, select the Meridian 1 or Succession CSE 1000 
system that contains the directory that you want to update.

3 Click the radio button next to the field that you want to use as your search 
criteria. Only one field may be selected for each search.

4 Based on the search criteria selected in step 2, do one of the following:

• Enter a first name in the First Name edit box.

• Enter a last name in the Last Name edit box.

• Enter a manager’s name in the Manager edit box.

• Enter a user’s login name in the Login Name edit box.

Note: You may enter the wildcard character “*” in the fields with edit 
boxes. For example, both jo* and j*h find directory entries with the first 
name John.
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• Enter a user group in the User Group edit box.

• Select True to find all published employees, or select False to find all 
private employees in the Published drop-down menu.

• Select an access level from the Reporting Access Group drop-down menu.

5 Click Next.

The Directory update page opens (Figure 153). Use this page to set the new 
value and select the directory entries that you want to change.

Figure 153   Directory Update - set value

6 From the Change drop-down menu, choose the field that you want to change.

7 Based on the field selected in step 6, do one of the following:

Note:  The publish flag is supported for employees only. Directory 
update does not support the publish flag for an entity’s assets.
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• Enter a user group.

• Enter a login name.

• Select a reporting access group, All, Peer, Managed, Personal, or No 
Access.

• Select a publish status, Published or Not Published.

8 From the table of Directory entries, select the entry or entries to change.

9 Click Submit to make the change.

Sync Tasks and Logs page

Sync tasks are used to synchronize changes made in Web Station with the 
information that is stored on the Meridian 1 or Succession CSE 1000 system. This 
synchronization process is not related to the sync tasks in Windows Station 
Administration. Click the Sync Tasks and Logs link under Web Station to open the 
Sync Tasks and Logs Web page. The page contains two tabs, Sync Tasks and Sync 
Logs. When the page opens, it defaults to the Sync Logs tab (Figure 154).

Note: The table only supports shift-click for multiple selections; 
therefore, you can only select a contiguous block of entries. 

Note: To make the same change for entries in the table that are not 
contiguous, go back to step 1. The search criteria from the previous 
change are retained. Click Next. Select a second block of contiguous 
entries, and click Submit.
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Figure 154   Sync Tasks and Logs page—Sync Tasks tab

Sync Tasks

The Sync Tasks page is divided into three sections, OTM Task Status: OTM 
Queue Status, and Resource Status. Since tasks and queue status are dynamic in 
nature, this page is set to automatically refresh every 30 seconds.
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To refresh the page immediately:

To change the refresh interval:

1 Enter a new interval time in the Refresh Interval text box.

2 Click Change. 

OTM Task Status

The upper section of the Sync Tasks page contains the OTM Task Status table. 
The OTM Task Status table lists the pending sync tasks that have been scheduled 
using Web Station. From OTM Task Status, you can run a task ahead of its 
scheduled time, or you can delete pending tasks.

To run a task ahead of its scheduled time:

1 Click the check box in the left column for the task or tasks that you want to 
run.

2 Click Run.

Click Refresh at the bottom of the page.

Note: Click Change to refresh the page.

Note: The new refresh interval is valid for the current user login session.

Note: You can choose all of the tasks with a single click by clicking the 
check box in the column header.
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To delete a task:

1 Click the check box in the left column for the task or tasks that you want to 
delete.

2 Click Delete.

Task Details

The task name in the Name column of the Sync Tasks page is a link to the Task 
Details page for the task.

To view the Task Details for a task:

The Task Details page opens (Figure 155).

Figure 155   Task Details page

Note: You can choose all of the tasks with a single click by clicking the 
check box in the column header.

Click the task name.
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The Task Details page varies in appearance depending upon whether the 
scheduled time has occurred. For the task in Figure 155 on page 342, the time has 
not yet occurred. The status is listed as Ready, and you may alter the scheduled 
date and time, if you so desire. The link in the Location column opens the 
Telephone pages for the telephone associated with the task.

A task that is running or waiting in queue will have its status listed as Running or 
Waiting in Queue. You cannot change the Schedule time of a task that is running 
or waiting in queue. Since the telephone is locked by the synchronization 
application, in this situation, the Location column does not contain a link to the 
Telephone pages.

OTM Queue Status

The middle section of the Sync Tasks page contains the OTM Queue Status table. 
When a task begins running, it moves from the OTM Task Status Table to the 
OTM Queue Status table. There are two types of queues that may appear in this 
table: Site-System-Application based queues and Resource-based queues.

Site-System-Application based queues

The purpose of Site-System-Application based queues is to serialize access to a 
given system. There is one queue per application for each site-system 
combination. This queue ensures that no two tasks destined for the same system 
run at the same time resulting in switch overlay conflict.

Resource-based queues

Resource-based queues make sure that two tasks requiring the same resource do 
not run at the same time. This ensures that the resource is available and the task 
can be executed successfully. The example in Figure 154 on page 340 shows two 
tasks that are in queue to use the same com port. The task at the top of the queue is 
either using the resource or waiting for the resource to become available if it is in 
use by a non-OTM application. Once the first task has finished, the second task 
runs.
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Resource Status

The lower section of the Sync Tasks page contains the Resource Status table. This 
table lists the resources that are in use by OTM scheduled tasks. In the example in 
Figure 154 on page 340, although the two tasks are running on two different 
systems, they both require the COM1 port. The tasks are executed in the order 
indicated in the Tasks List column.

Sync Logs

The Sync Logs page is used to access three types of synchronization logs:

• Transmit tasks scheduled from Windows Station Administration

• Transmit tasks scheduled from Web Station

• LDAP sync reports

Access the Sync Logs page by clicking the Sync Logs tab on the Sync Tasks and 
Logs page. The Sync Logs page opens (Figure 156).
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Figure 156   Sync Tasks and Log page—Sync Logs tab

To view a log of transmit tasks scheduled from Windows Station Administration:

1 Click the radio button located beside “View log of transmit tasks scheduled 
from Windows Station for.”

2 Select a system from the drop-down list.

3 Click Display.

To view a log of transmit tasks scheduled from Web Station:

1 Click the radio button located beside “View log of transmit tasks scheduled 
from Web Station for.”

2 Select a system from the drop-down list.

Note: Only tasks that were scheduled from Windows using Windows 
Station Administration appear in this log.
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3 Click Display.

The Sync Log details page opens (Figure 157).

Figure 157   Sync Log details

To view the LDAP sync report:

1 Click the radio button located beside “View LDAP sync report.”

2 Click Display.

The LDAP Sync Report page opens (Figure 158).

Note: Only tasks that were scheduled in Web Station appear in this log.
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Figure 158   LDAP Sync Report page

Web Administration

The Web Administration heading in the OTM Web navigator tree provides links to 
the Custom Help pages, the User Authentication page, the User Groups page and 
Java-based User Properties application, and the Session Monitor.

Custom Help

The Custom Help page allows you to customize Help text for OTM Web-based 
applications. Typically, you only customize Help that is for end users. 

All Web-based Help files can be customized. You can either:

• Replace them with customized help provided by you (the administrator) 

• Annotate the help files
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The custom Help page provides a list of all Web-based Help files. You can use a 
custom Help file instead of the standard Help by copying and then editing and/or 
annotating the standard Help.

OTM includes sample HTML files that you can use to create customized Help for 
the end user. Sample Help files are provided for the following Help topics: 

• Dialing plans

• System speed call lists

• Flexible feature codes

Each individual Help page has Content and Index buttons to return you to the Help 
table of contents or index. Next and Previous buttons allow you to navigate to the 
next Help for topic. A Java applet shows the table of contents and index as 
navigation frames. Versions of the table of contents and index are also available 
without frames.

Customizing standard Help files

The following procedure shows how to create and annotate a custom Help file. All 
Help customization pages appear in the Content frame of the Web Navigator.

To create and annotate a custom Help file:

1 Click Custom Help under Desktop Services in the Web Navigator tree.

The Help Groups page opens (Figure 159).
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Figure 159   Selecting the standard OTM Help files - Help Groups

2 Click a Help Group. In this example, click StationFeatures.

The Help Subgroup page for StationFeatures opens (Figure 160).
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Figure 160   Selecting the standard OTM Help files - StationFeatures subgroups

3 Click a Help Subgroup. In this example, click Keys.

A page that displays a list of the Help files for all key-based features opens 
(Figure 161).
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Figure 161   Customizing standard Help files

Table 26 explains the function performed by each of the buttons in the Custom 
Help feature.
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Table 26   Custom Help buttons

4 Click Copy in the Custom column for ACD Answer Agent (AAG).

The buttons in the Custom and Annotate columns change (Figure 162).

Button Explanation

Copy the standard Help file to the custom directory.

Annotate the Help file in the custom directory.

Edit the annotated Help file.

Delete the annotation or delete the entire custom Help file.

View the custom Help file.

Enable end user viewing of the custom Help file.

Disable viewing of the custom Help file and use standard Help.
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Figure 162   Copy a standard Help file

5 Click Add in the Annotation column to add your annotation.

The annotation entry page opens (Figure 163).
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Figure 163   Annotating custom Help files

6 Add your annotation and press Submit.

Note: Only custom Help files can be annotated. 
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7 Click Enable to enable viewing of your annotated file.

8 Click View to display your annotated file.

The custom Help file appears (Figure 164).

Figure 164   Viewing an annotated Help file

Additional Help topics

In addition to Help on features and keys, Web-based Help is available for a variety 
of maintenance and administrative tasks that can be performed using OTM. 
Figure 165 shows the Web-based Help file for overlay 02.
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Figure 165   Sample Web-based Help screen

User authentication

You can select any of the following three methods or combination of these 
methods to authenticate OTM users:

• Local OTM Server account

• Windows NT Domain account

• LDAP authentication   

Note: The Administrator account is always authenticated through the 
local server account because it is a default account on all supported 
Windows platforms.
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To configure authentication:

1 From the OTM Web Navigator tree, select User Authentication.

The User Authentication page opens (Figure 166).

Figure 166   OTM User Authentication page

Note: The default authentication method is the Local OTM Server 
account. This method provides the best login performance because there 
is no requirement to search the OTM directory for the user’s assigned 
User Group.
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2 Use the check boxes to select one or more of the available authentication 
methods:

a If you select Windows NT Domain account, enter one or more domains in 
the Domain text box.

b If you select LDAP authentication, use the drop-down list to choose either 
EmployeeID (uid), or EMail (email).

3 Used the drop-down lists to assign the order in which the authentication 
methods are performed.

4 To use the secure socket layer (SSL) during the authentication process, click 
the “Use SSL for Web login authentication” check box.

Note: If you choose multiple authentication methods, OTM respects the 
order configured; however, it should be noted that the best performance 
is achieved by using the Local OTM Server account method.

Note: If the OTM Server has the required certificate installed, setting 
the check box and protecting specific virtual directories on the OTM 
Server causes OTM to use SSL encrypted transport during 
authentication. In this case, Web login is performed using https:// rather 
than http://, and the traffic is encrypted. The OTM Server automatically 
switches to non-SSL transport once the user is successfully 
authenticated.
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The selected method(s) are used to authenticate users on all OTM platforms: OTM 
Server, OTM Client, and OTM Web Client.

For information on configuring users for desktop access, see “Enable Web 
desktop access” on page 172.

User Groups

Navigator access is controlled by user group. A user’s User Group assignment 
determines which features are available on the Telephone features page. You also 
use the User Groups page to indicate which users are permitted to make changes 
to the General and Keys pages. 

User groups must be added and deleted in the OTM Windows Navigator. See 
“Creating a User Group” on page 139.

OTM is shipped with the following User Groups and corresponding access rights:

• Administrators

— Full read/write access rights. Access rights cannot be changed for this 
user group.

• HelpDesk

— Full access to all Web Navigator tree items except those under Web 
Administration.

— Full Access to Web Desktop Services, including read/write and 
synchronization capabilities.

— No access to Windows Navigator applications.

• EndUser

— No access to Web or Windows Navigator applications.

Note: Authentication methods can also be configured using the 
Windows navigator. See “User authentication” on page 144.

Note: The migration from User Templates to User Groups has required 
that several changes be made to existing users profiles and access 
privileges. For more information, see “Migrating User Templates from 
earlier versions of OTM to User Groups” on page 84.
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— Web Desktop Services is read only. Only 21 features are available; the rest 
are hidden.

• Default

— No access.

To view the available User Groups:

The User Groups page opens (Figure 167).

Figure 167   User Groups page

Click the User Groups link located under Web Administration in the OTM 
Web Navigator tree.
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Navigator access

Access to the sites, systems, and applications available in the both the Windows 
and Web Navigators is controlled on a user group basis through the User Group 
Properties Java application.

To modify the access rights of a user group:

1 Click to select a User Group.

2 Click Edit.

The User Group Properties Java application launches and the User Group 
Properties dialog box for the selected user group opens (Figure 168).

Note: Alternatively, you may double-click the user group to display the 
User Group Properties dialog box for the selected user group.
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Figure 168   User Group Properties dialog box—Navigator tab

The Access Right column lists the level of access allowed for each site, system, 
and application. This is the same tree structure and performs the same function as 
the Windows-based User Groups dialog box (Figure 54 on page 141).

To modify access rights:

1 Use the drop-down list to select ReadWrite, ReadOnly, or No Access for each 
item in the tree.

2 Click Apply.

Note: The question mark indicates that the subitems belonging to the 
item displaying the question mark have mixed access settings.
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Telephone access

The Telephone tab in the User Group Properties dialog box is used to control 
access to the telephone pages on the Web for each user group (Figure 169).

For information on the telephone pages, or to view examples of telephone pages, 
see “Telephone pages” on page 387.

Figure 169   Telephone access properties dialog box—General Tab

The options that are configured in the upper section of this dialog box are 
applicable to all of the tabs in telephone pages. These options included:
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• Allowing or denying this group the ability to synchronize changes with the 
Meridian 1 or Succession CSE 1000 system. If synchronization is denied, you 
must manually synchronize the changes with the Meridian 1 or Succession 
CSE 1000 system using Windows-based Station Administration or Web 
Station.

• Determining whether the troubleshooting link appears at the top of the 
telephone page for members of this group.

• Allowing or denying this group the ability to restore changes that have been 
made to a telephone.

To configure telephone access options:

1 Use the drop-down list to select either “User can sync changes” or “User 
cannot sync changes”.

2 Click the Show Trouble Shooting link check box to enable this option.

For EndUsers, clicking the link displays the Telephone Troubleshooting Help 
page, which includes a reset button (Figure 195 on page 397).

For Web Navigator users, clicking the link displays the maintenance page for 
the telephone with all of the available commands. See “Telephones/PE Units 
maintenance” on page 767.

3 Click the “Allow users to restore pending changes” check box to permit the 
users in this group to restore the changes made to a telephone.

4 Click Apply to apply your changes.

General tab

In the General tab, you use check boxes to determine whether the Telephone—
General page appears for this user group, and whether the users in this group can 
make changes to this Telephone page. The Telephone—General page contains 
information such as site, system, location, and TN, which may not be appropriate 
for or valuable to end users.

Note: If you allow users to restore pending changes, they will be able to 
undo any changes that have been scheduled by the Administrator or 
HelpDesk but have not yet occurred. For more information on restoring 
pending changes, see “Restore button” on page 392.
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To configure the Telephone—General page:

1 Click the “Show this page” check box to allow this user group to be able to 
view the Telephone—General page (Figure 193 on page 395).

2 Click the “Page is read/write” to allow users in this group to make changes to 
the information that appears in this telephone page.

3 Click Apply to apply your changes.

Keys tab

In the Keys tab (Figure 170), you use the check box and lists of key-based features 
to determine whether the Telephone—Keys page appears and, if so, which keys 
the users in this group are able to change.
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Figure 170   Telephone access properties dialog box—Keys tab

To configure the Telephone—Keys page:

1 Click the “Show this page” check box to allow this user group to be able to 
view the Telephone—Keys page (Figure 196 on page 399).

2 Use the “Move” and “Move All” buttons to move the key-based features that 
can be changed by this user group into the left column.

Put keys into the left column to allow users in this group to interchange these 
key types and change the key parameters.

Note: If the user selects a key that is not in the left hand column while 
viewing the Telephone—Keys page, the Change button does not appear. 
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3 Click Apply to apply your changes.

Features tab

In the Features tab (Figure 171), you use the check box and list of features to 
determine whether the Telephone—Features page appears and, if so, which 
features the users in this group can view and change. The list of features contains 
all the non-key features listed alphabetically by prompt in LD10 and LD11. Each 
feature is assigned a restriction of Hidden, ReadOnly, or ReadWrite. If Hidden, 
the feature does not appear in the end user Feature drop-down list. 

Note: Read/Write capability requires the OTM Premium package.
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Figure 171   Telephone access properties dialog box—Features tab

To configure the Telephone—Features page:

1 Click the “Show this page” check box to allow this user group to be able to 
view the Telephone—Features page (Figure 216 on page 416).

2 Use the drop-down lists in the Restrictions column to configure each feature 
as ReadWrite, ReadOnly, or Hidden.

3 Click Apply to apply your changes.

Note: The “Show” drop-down list contains: All, Hidden, ReadOnly, and 
ReadWrite. This is used to limit the size of the list.
553-3001-330 Standard 3.00 November 2002



Web Services 369
Details tab

In the Details tab (Figure 172), you use the check box to determine whether the 
Telephone—Details page appears (Figure 217 on page 417, and Figure 218 on 
page 418).

Figure 172   Telephone access properties dialog box—Details tab

Session Monitor

Login security prevents the web pages from being accessed without first 
successfully providing a valid login name and password combination. The Session 
Monitor page (Figure 173) contains a list of logged in users with the login time 
and IP address.
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The administrator may log out users by clicking the corresponding Log Out check 
boxes and then clicking Log out.

Figure 173   OTM Administrator Session Monitor screen

OTM Web Virtual System Terminal

The Web Virtual System Terminal provides a single point of connectivity for a 
Web-based terminal window. Launch the OTM Web Navigator from Internet 
Explorer or Netscape Navigator, and select the system to connect to from the GUI. 
This does not require knowledge of such items as IP addresses and serial port 
settings because the information is stored on the server. You determine who gets 
access to what, and you can change the settings without interrupting everyday 
operation.
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The OTM server connects to devices over IP network and serial ports on the OTM 
server. Web Virtual System Terminal supports connection primarily to a 
Meridian 1 or Succession CSE 1000 system via:

• Meridian 1 or Succession CSE 1000 system pseudo-TTY (PTY) port

• Direct serial connection

• Telnet

The Web Virtual System Terminal resembles the OTM Windows System Terminal 
application. When you connect to a Meridian 1 or Succession CSE 1000 system, it 
provides similar context-sensitive Help for the overlays and error messages. When 
you connect to other devices, it provides a basic Telnet connection. The Web 
Virtual System Terminal is a Java applet embedded in an HTML page. Once 
connected to the Terminal Server, the Web Virtual System Terminal 
communicates with the selected device through the Terminal Server. Only the first 
client that connects to a port can send character input to the host. 

The Web Virtual System Terminal displays most messages in a window. However, 
some messages that do not require immediate attention appear between the < > 
characters in the terminal screen (Figure 174). These messages are not sent to the 
host device or logged on the server. The messages can be:

• Status of this client (connected, disconnected, read-only connection, and so 
on)

• Status of other client (monitoring this port, disconnected)

• Broadcast message (received from another client, sent to another client) 
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Figure 174   Terminal Client showing messages

OTM Web Virtual System Terminal menus

The OTM Web Virtual System Terminal window has the following menu items:

Terminal menu

• Connect - Connect to a virtual port. This item appears when the client is not 
connected to a port.

Note: For a non-administrator user, if a port is already in use by 
someone else, then the connection is not allowed.
If you have administrator privilege, you may connect to a port already in 
use by someone else. However, you may only monitor the session, and 
cannot send text to the host.
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• Disconnect - Disconnect from a virtual port. This item appears when the client 
is connected to a port.

• Disconnect Others - Disconnect all other clients from a virtual port. This item 
appears only for a user with administrator privilege. 

• Send Message - Display a Send Message dialog box. This allows you to 
“broadcast” a message to all other users on the same virtual port.

Figure 175   Send Message dialog box

• Parse M1 Output - This menu has a check mark to enable parsing of overlay 
interaction to provide the context-sensitive Help. To reduce some unnecessary 
CPU overhead, you should uncheck this menu item for a “Generic” device. If 
it is checked, then the Help > Current Overlay and Help > Current Prompt 
menu items become visible to provide context-sensitive Help for the 
Meridian 1 and Succession CSE 1000 overlays.

Edit Menu

• Copy - Copy the selected text to the clipboard.

• Select All - Select all text in the output window.

Note: If you select Terminal > Disconnect Others, then all other clients 
to the virtual port are disconnected, and you are then allowed to send text 
to the host.
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View Menu

• Look & Feel - Cascading menu determines the look of and feel of the user 
interface. You can choose:
   Java
   Windows
   Motif

• Overlay Passthru - Make the applet behave like the MAT System Terminal 
application. It provides a separate edit box to enter commands, which allows 
for backspace while working in the M1 overlay environment.

Help Menu

• Current Overlay - Display Help for the current overlay in a separate browser 
window. The OTM Web System Terminal monitors character I/O to keep 
track of the overlay information.

• Current Prompt - Display Help for the current overlay prompt in a separate 
browser window. The OTM Web System Terminal monitors character I/O to 
keep track of the overlay information.

• I/O Navigator - Display the Overlay Enhancer dialog box. This allows you to 
search for Help on an overlay, overlay prompt, or error message.

Note: If this menu item is checked, then the Help > Search M1 Help 
Files menu item becomes visible. If this menu item is unchecked, then it 
behaves like a standard terminal window.

Note: Like the OTM System Terminal, the OTM Web Virtual System 
Terminal has context-sensitive Help. It monitors system input and output 
to determine the current overlay and prompt. You can also search for 
help for an overlay (LD22, for example), overlay prompt (LD22 REQ, 
for example), or M1 message (AMH0007, for example). You can either 
highlight text in the terminal screen and then select Help > Search, or 
select Help > Search, and then type in the string to search for.
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Figure 176   I/O Navigator Overlay Enhancer dialog box

Terminal Server

The Terminal Server application is a Windows application that uses the OTM 
database to obtain site, system, and IP address information. The Terminal Server 
supports direct serial connections and Meridian 1 or Succession CSE 1000 
overlay connection over an IP network. If you connect over an IP network to a 
Meridian 1 or Succession CSE 1000 system, you can customize the Meridian 1 or 
Succession CSE 1000 port user types (SCH, MTC, BUG, TRF).

Terminal Server setup

To launch the Terminal Server application:

The Terminal Server dialog box opens (Figure 177).

From the Start menu, select Programs > Optivity Telephony Manager > 
Terminal Server.
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Figure 177   Terminal Server dialog box

The Terminal Server window displays two lists:

• configured systems

• configured ports

The configured systems list displays information on the virtual port that is 
configured:

• Name:
As defined in the OTM Windows Navigator

• Number of clients:
The number of terminal clients using the port

When you select an entry in the Configured Ports list, the Clients on Port list 
displays the following information for each terminal client using the port:

• From:
IP address of the terminal client
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• Duration:
How long the connection has been in use

The Disconnect button next to the Clients on Port list allows you to terminate the 
connection to one or more terminal clients.

The Terminal Server application also has the following buttons:

• Hide - Hide the application window. During normal operation, the Terminal 
Server application runs without user input, so hiding its window frees up 
some desktop space. You can view the window at any time by double-clicking 
the Terminal Service icon in the Task Bar tray.

• Systems - Configure the virtual ports. See “Virtual ports” next.

• Terminals - Configure the starting network socket port number for 
communications between the OTM Server and the OTM Web System 
Terminal (Figure 178). The default is 4789. Typically, you will not need to 
change this.

• Help - Get context-sensitive Help on the application.

Figure 178   Terminal Properties dialog box

Virtual ports

In the Terminal Server application, the Virtual Ports Properties window allows 
you to enable or disable connection to a particular device. It displays the virtual 
port number for each configured device, and the corresponding serial or network 
settings.
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In the Virtual Port Properties window, a tree displays the devices that can be 
connected via a virtual port. For serial ports, the window retrieves the available 
serial ports from the Registry. For network connections, the window retrieves the 
site and system information from the OTM database. The virtual port for a system 
uses the same IP address assigned to System Terminal. The tree mirrors the tree in 
the OTM Navigator. It uses the communication profile in System Properties, 
determined as follows:

• For a Generic system, it uses the profile (serial or network) selected in the 
Application page in System Properties. 

• For a non-Generic system, it uses the communication settings from the profile 
(serial or network) assigned to VT220 in the Applications page in System 
Properties.

• For any system, if a network (Ethernet) profile is selected, Terminal Server 
uses a Telnet connection.

To configure virtual port connection for a device, click Systems in the Terminal 
Server window, or double-click a Configured System in the list (this selects the 
corresponding device in the Virtual Port Properties window allowing you to 
quickly change the settings for a particular device).

To enable virtual port connection for a device, do one of the following:

• Double-click the disabled port in the tree.

• Select the item and check the Enabled check box.

• Click Enable All. This enables all the items listed in the tree with the default 
configuration. The item becomes bold to show that it is enabled.

The field to the right of the Enabled check box automatically fills in the Site - 
System name for the selected device. This is the name displayed in the Terminal 
Server’s main window.

To disable a virtual port, do one of the following:

• Double-click an enabled item in the tree.

• Select the item and uncheck the Enabled check box.

• Click Disable All. This disables all the devices listed in the tree. The item is 
no longer bold, and does not appear from the Terminal Server main window 
when you click OK.
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Serial connections

The Terminal Server application supports all the serial ports on the OTM Server 
PC plus the systems configured in the OTM Navigator. However, while more than 
8 serial ports may be configured, the Terminal Server is limited to 8 simultaneous 
serial connections. (The limit depends on the OTM server hardware, the network 
capacity, the server’s CPU capacity, and so on.)

For a serial connection, Direct to Com x appears, where x is the com port number. 
The fields for serial settings are enabled. The default is the serial settings from the 
OTM database. You can change the settings in the dialog box (Figure 179).

Figure 179   Virtual Port Properties (Serial with Logging enabled)
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Network connections

For a network connection, the IP address appears. It also indicates whether the 
system is a Meridian 1, Succession CSE 1000, or Telnet (Figure 180).

• Make sure the IP address is correct. If the IP address is different from the 
OTM database’s setting, click Refresh to update all of the network ports with 
the latest settings from the OTM database.

• If you select an M1 System, the fields for M1 port settings are enabled 
(default = SCH). The Telnet port field is disabled.

• If you select a non-M1 System, the fields for both serial and M1 port settings 
are disabled. The Telnet port field is enabled.

• Check the Log check box to turn on data capture. The log file name defaults to 
the Site - System name plus a .txt extension. The path and the file name can be 
changed by typing in the edit box or clicking Change.

• The maximum size of the log file is customizable (in the Size field) on a 
per-system basis, and defaults to 256 K. Once the file size reaches the limit, 
the Terminal Server starts from the beginning of the file, overwriting the 
oldest logs.

• Due to the circular nature of the log, the Terminal Server writes an end-of-file 
marker (customizable in the Marker field) at the end of the log entries.

• The log records the time and date of when a client connects and disconnects to 
the virtual port, and writes all text received from and sent to the host. This 
allows a network administrator to keep an activity log of the virtual port 
connection.

• If this ASCII log is to be viewed from a web browser, the file should be stored 
in a web-accessible path.
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Figure 180   Virtual Port Properties (Network with Logging disabled)

Web Desktop Services

OTM Web Desktop Services allows users to view and modify the configuration of 
their telephones via a web browser.

The Web display includes a graphical view of the telephone, and shows the 
configured features. Help text is available for the features configured on the 
telephone. See “User Groups” on page 359 for information on your ability to 
restrict the display of certain features to specific user groups. For example, most 
Class of Service “features” are irrelevant for end users; therefore, you should 
specify that they not appear.
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Installation and configuration of Desktop Services

The following procedure outlines the steps that you must take to install and 
configure Desktop Services:

1 Install OTM. See Installing and Configuring Optivity Telephony Manager 
(553-3001-230).

2 Create Windows NT accounts for EndUser and HelpDesk users as required.

3 Log on to the Web Navigator as Administrator and go to the User 
Authentication page.

4 Configure authentication method(s) using the User Authentication page. See 
“User authentication” on page 356.

5 Go to the User Groups page and configure the Navigator and Telephone 
access properties for the HelpDesk, EndUser, and Default user groups. See 
“User Groups” on page 359.

6 For EndUser users, using the Employee Editor in the OTM Windows 
interface, enter the users’ Login Name, User Group, and Web Reporting 
Access Rights in the users’ OTM Directory entry. See “Enable Web desktop 
access” on page 172.

Note: To navigate to the Administrator Login page, place /admin after 
the OTM IP address or host name in your Web Browser.

Note: By default, HelpDesk users are given read/write access to all 
features, and access to all items in the Web Navigator tree except those in 
the Web Administration branch. HelpDesk users have no access to OTM 
Windows applications. EndUser users have read-only access to 21 
features, and no access to the Windows or Web Navigators. Default users 
have no access.

Note: To allow Help Desk users to make changes to other user’s 
telephone configuration data, make sure that they have access to Web 
Station. 
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Appendix A, “Using Optivity Telephony Manager Web Desktop Services,” 
provides reference information for Web Desktop Services end users. You may 
want to distribute copies of this appendix to the end users once you have installed 
and configured Desktop Services.

User Login page

Login security ensures protection against unauthorized entry and enforces access 
permissions for logged on users.

When a user points a web browser to the OTM end user URL a login page appears 
(Figure 181). If login is successful, the user’s personal Desktop Service main page 
appears.

Figure 181   User Login page
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EndUser Main Page Layout

The Web Desktop Services end user main page includes the following common 
elements: 

• Information Banner (top): Contains the Nortel Networks logo, plus a Help, 
Logout, and Home button. The Help button takes you to general help on how 
to use these web pages. The Home button takes you to the My Profile page. 
The logout button takes you to the login page.

• Navigation Bar (left side): Lists hypertext links to various Desktop Service 
pages. When you single-click on an item in the Navigation bar, the related 
page appears in the Content Frame of the standard Web page.

• Content Frame: Contains the page based on the selection in the Navigation 
bar. There are four types of pages:

Home page - General information about the user (name, department, and so 
on). The information displayed is determined by the administrator.

Telephone pages - Contains telephone configuration data. A user may have 
more than one telephone; however, configuration data can appear for only one 
telephone at a time. The information displayed is determined by the 
administrator.

Billing Reports - The TBS Web Reporting application displays billing reports 
in the content frame. For information on TBS Web Reporting, see Optivity 
Telephony Manager Telemanagement Applications (553-3001-331).

Other Links - Contains links provided by the Administrator.

A line is placed at the bottom of each content page to visually indicate the end of 
the page. If vertical or horizontal scrolling is required, the entire page is scrolled.

Note: In the rare situations where a user has telephones on different 
switches managed by the OTM Server, the Navigation Tree expands to 
include the systems as the main nodes. The user selects the My Profile or 
Telephone(s) in the desired system.
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My Profile page

Once a user who is a member of the EndUser user group logs in to the User Login 
page, the My Profile page opens. This page contains general information about the 
user. The system retrieves this information from the OTM Directory. Click Home 
in the Banner or My Profile in the Navigation bar to go to this page.

The information that appears is fixed and cannot be changed. If there is no 
information for a field, it is left blank. Hidden fields do not appear. Only fields 
that are listed as read-only are visible.

• Employee first, middle, and last name

• Identification (employee ID)

• Job Title

• Org Path (this is extracted from the Organization Path in the OTM directory)

• Manager

• E-mail address

• Login Name

• User Group

• Web Reporting Role

• Address fields

• Description

Figure 182 shows an example of a My Profile Page.
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Figure 182   My Profile page
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Telephone pages

Administrators and HelpDesk users access the Telephone pages by logging into 
the Web Navigator and using the Find Telephones page. See “Find Telephones 
page” on page 331 for more information. End users access the Telephone pages by 
logging in to the end user pages as described in “User Login page” on page 383.

Once logged in, the end user is presented with a list of telephones in the 
Navigation Bar. The telephones are identified by prime DN. To get this list, the 
Web Server scans all the employee databases, one per Meridian 1 or Succession 
CSE 1000 system, on the server. If the employee has telephones in different 
systems, served by different OTM servers, then the employee must log in to the 
different servers to access these telephones.

When a user clicks on a telephone in the Navigation Bar, the Telephone page 
appears in the Content Frame.

The Telephone page has a small graphic in the top left corner. This graphic is 
detailed enough for the user to recognize the type of telephone. The user’s name 
and the prime DN of the telephone also appear.

The telephone has up to four sub-pages, accessed by links below the small 
telephone graphic. The capabilities provided by these web pages depends on the 
telephone type.

If a user’s User Group settings do not allow access to at least one of the Telephone 
pages, the user receives a message indicating the problem (Figure 183).

Note: When using the Find telephones page to access the Telephone 
pages, the Information Banner and the Navigation Bar shown in 
Figure 182, as well as the My Profile page, do not appear.
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Figure 183   Telephone page for user with no access

Current Configuration/Pending Changes

When the information for the telephone has been changed, but the changes have 
not been synchronized with the Meridian 1 or Succession CSE 1000 system, a 
Show Current configuration/Pending changes drop-down box allows the user to 
select which configuration is shown.

When there are pending changes, and the users have been assigned the “Allow 
Synchronization” and “Allow user to restore pending changes” options in their 
User Group properties, the drop-down box appears along with Schedule and 
Restore buttons. If the user’s access properties allow changes to the General, 
Keys, or Features pages, the Validate button also appears (Figure 184).

Figure 184   Configuration indication with synchronization allowed
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Validate button

The Validate button is available to users who are allowed to make changes to the 
General, Keys, or Features pages. The Validate button is not available when the 
user is viewing the current configuration of a telephone. When a telephone has 
been marked for deletion in the OTM database, the Telephone pages show the 
deleted configuration. The Validate button is not available when the user is 
viewing the deleted configuration. The user clicks Validate to validate the changes 
that have been made to the configuration. The validation process determines 
whether there are any errors that can cause problems during synchronization with 
the Meridian 1 or Succession CSE 1000 system. When the user clicks Validate, if 
there are no errors, the page shown in Figure 185 opens. If there are errors, the 
Station Validation Results indicate the errors that are present in your telephone 
configuration (Figure 186).

Figure 185   Station Validation Results with no errors
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Figure 186   Station Validation Results with errors

Schedule button

For telephones with pending changes, the user clicks Schedule to schedule 
synchronization with the Meridian 1 or Succession CSE 1000 system. When the 
user clicks Schedule, the Schedule Changes dialog box opens (Figure 187).

Note: Synchronization tasks are handled by the Windows scheduler on 
the OTM Server. The client requesting the sync does not need to be 
connected to the OTM Server when the task is run.
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Figure 187   Schedule Changes dialog box

To schedule a sync task:

1 Enter a Task Name in the Task Name text box.

There is no limit on the number of characters in the name.

2 Use the Task Time text boxes to set the start time for the task.  

3 Click the “Do not transmit if the telephone is busy” check box to have the 
sync task check the status of the telephone before making changes to the 
telephone configuration. 

Note: The boxes are pre-filled with a time value that is 2 minutes ahead 
of the current time.

Note: If the Task Time passes before you click Next, the task is accepted 
and run immediately after you click Next.

Note: If the box is not checked, and the telephone is busy, the telephone 
call is dropped. This is a limitation of the PBX.
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4 Click Next.

The Schedule Changes confirmation dialog box opens (Figure 188).

Figure 188   Schedule Changes confirmation

Restore button

When the user clicks Restore, the Restore changes dialog box opens (Figure 189).

Figure 189   Restore Changes dialog box

Note: If the telephone is busy, the changes are not made and the event is 
logged in the appropriate transmit log. The transmit is not automatically 
rescheduled. It is up to the user to check the log and reschedule the 
transmit.
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If the user clicks Cancel, the dialog box closes. If the user clicks Next, the Restore 
Changes confirmation dialog box opens (Figure 190).

Figure 190   Restore Changes confirmation

When there are pending changes and the user does not have the Allow 
Synchronization option, the drop down-box along with the Validate and Restore 
buttons appear (Figure 191). The user is not allowed to schedule synchronization.

Figure 191   Configuration indication with synchronization not allowed

When the telephone and the Meridian 1 or Succession CSE 1000 system are 
synchronized, “Current Configuration” appears at the top of the page, and the 
drop-down box no longer appears (Figure 192).
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Figure 192   Configuration indication when there are no pending changes

Telephone General page

The General page provides general information about the telephone. The 
following information appears on the Telephone General page:

• Station Location - A text field similar in purpose to the System field. You 
may want to use this to provide more user friendly names.

• System - Identifies the site, system, and customer number, if applicable, 
where the phone is connected. This information is retrieved from OTM 
common services and appears in the format “Site - System - Customer x”.

• Phone type (M2317, M2616, M3903, and so on)

• Terminal Number (TN): Address of the telephone

• Key Based Modules

Note: If you use Find Telephones to access the Telephone pages, you 
should click Refresh from Database button on the Find Results page after 
you modify a telephone’s location. This updates the Location 
information and the HTML link to the Telephone pages. See “Find 
Results page” on page 333.
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• Designation - A unique 1–8 character telephone identifier. This data is stored 
in station data and the overlays. This field is often used to identify the location 
of the phone within the building (for example, cable pair), and is the response 
to the prompt DES in LD 10 and LD 11.

Figure 193 shows an example of the Telephone General page.

Figure 193   Telephone General page

The following fields may be changed by users if allowed by their User Group’s 
Telephone access properties:

• Station Location

• Display Based Modules
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• Key Based Modules

• Designation

If the user changes one or more of these fields and clicks Submit, the Confirm 
Changes dialog box opens (Figure 194).

Figure 194   Confirm changes to the General Phone Properties page

The user verifies the information and clicks Confirm. If there are no errors, a 
change confirmation page opens. See “Change confirmation pages” on page 419 
for more information. If there is an error in the proposed change, error details 
appears instead of the change confirmation page.

Telephone Troubleshooting page

The Troubleshoot Problems link, at the top of the Telephone pages, provides 
access to the Telephone Trouble Shooting page. You can access the Telephone 
Troubleshooting page from the Telephone pages via the Troubleshoot Problems 
link. The Telephone Troubleshooting page is shown in Figure 195. The Reset My 
Phone button performs an enable and status command on this telephone via a 
Maintenance Windows API.

Note: For the Troubleshoot Problems link to function properly, the 
user’s User Group must be configured to allow access to the switch.
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Figure 195   Telephone Troubleshooting page

Telephone Keys page

The Telephone Keys page displays a graphical layout of the function keys 
assigned to the telephone. The layout varies for different telephone types.

All current feature key assignments are always visible. The key labels on the 
graphic match the labels in Station Administration. For M3900 series and IP 
telephones these labels match the soft labels on the set, and the text is shortened to 
7 characters. When the page first appears, key 0 is selected. You can select other 
keys by clicking on a key. Click the Shift key to access the second layer of keys on 
the M3903, M3904, and IP telephones. From the second layer of keys, you can 
access the display-based or key-based expansion module keys. Figure 196 shows 
an example of the first layer of keys on the Telephone Keys page for an M3904 
telephone.
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When a key is selected, the following occurs:

• The key is highlighted. The method used to highlight depends on the phone 
type.

• The name of the key and its configurable parameters, if any, appear beside the 
telephone graphic.

A Help button takes you to help on how to use the selected key.
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Figure 196   Telephone Keys page

If the telephone has a display-based expansion module, a graphic indicates which 
set of keys appears. Use the Next and Previous buttons to “scroll” the graphic 
from one set of keys to the other. 

Figure 197 shows the user interface for the keys associated with a display-based 
expansion module attached to the M3904 shown in Figure 196.
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Figure 197   Telephone Keys page — display-based expansion module keys

Changing a key

If permitted by your User Group access properties, when you click Change after 
selecting a key, a new browser window opens with the appropriate controls for 
changing the key you selected. In this browser window, a list of the possible key 
choices appears (Figure 198). This list is dynamic and is based on both the 
telephone type and the key selected. For example, key 17 on an M2317 telephone 
must be a transfer key.
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Figure 198   Select Auto Dial key type

The Help button is context-sensitive and accesses the information in the Input/
Output guide on configuring a key for the selected feature or service.

The key’s parameters, if any, appear on subsequent pages of the wizard.

Changing the parameters of an Auto Dial key

Use the following procedure to change the telephone number assigned to an Auto 
Dial key:

1 Click an Auto Dial key in the graphic on the Telephone Keys page.

2 Click Change. The Key Change Wizard launches.

3 Click “ADL — Auto Dial” in the list of key types (Figure 198).

Note: The Clear button removes the key function and takes the user to 
the next page in the key change wizard. As shown in Figure 198, if the 
telephone key that you have selected is currently unassigned (null), the 
Clear button does not appear.
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4 Click Open.

5 Type the new maximum number of autodial digits and the new Autodial DN 
in the edit boxes (Figure 199). 

Figure 199   Autodial key change wizard

6 Click Submit.

The key change summary page opens (Figure 200).

Note: If you change the Number of Auto Dial digits to a value that is 
greater than the default number in the Meridian 1 or Succession 
CSE 1000 system, or if you enter an Auto Dial Number that has more 
digits than the default value, you receive a validation error.

Note: You use the Find DN button to look up Directory Numbers. It 
appears whenever there is a DN edit box. For information on using the 
Find DN button, see “Finding Directory Numbers” on page 411.
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Figure 200   ADL key change summary

7 Click Confirm.

A confirmation page appears. See “Change confirmation pages” on page 419.

Changing the parameters of an MCR DN key

Use the following procedure to change the first name and last name parameters 
associated with an MCR DN key:

1 Click an MCR DN key in the graphic on the Telephone Keys page (Figure 196 
on page 399).

2 Click Change.

The Key Change Wizard launches. The current key type, “MCR - Multiple 
Call Ringing,” is highlighted (Figure 201).
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Figure 201   Select Multiple Call Ringing key type

3 Since you are not changing the key type, simply click Open.

The key change wizard displays the current parameters for the selected key 
(Figure 202).

Note: You can only modify the DN, CPND, and CLID. You may not 
view or change the DN’s Voice Mailbox, ANI, or MARP. 

Note: When the Name Display Link to Directory check box is checked 
in Station Administration, the values for the First Name and Last Name 
fields are obtained from the directory and are not editable.

Note: If the key change wizard does not display a Directory Number, or 
if you want to change the Directory Number, see “Finding Directory 
Numbers” on page 411.
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Figure 202   Current parameters for Multiple Call Ringing DN key

4 Change the First Name and Last Name (Figure 203).

Figure 203   Changed parameters for Multiple Call Ringing DN key
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5 Click Submit.

A summary page opens that displays your changes (Figure 204).

Figure 204   MCR key change summary page

6 Click Confirm. A confirmation page appears. See “Change confirmation 
pages” on page 419.

Changing a feature key type

Use the following procedure to change a Conference key to a Call Forward key:

1 Click the Conference key in the graphic on the Telephone Keys page 
(Figure 196 on page 399).

2 Click Change.

The Key Change Wizard launches. The current key type is highlighted 
(Figure 205).
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Figure 205   Key Change Wizard displaying current key type

3 Click “CFW - Forward All Calls” in the list of key types (Figure 206).

Figure 206   Select the Forward All Calls key type

4 Click Open.
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5 Enter the Redirection DN Length and Redirection DN in the edit boxes 
(Figure 207).

Figure 207   Forward All Calls Key Change Wizard

6 Click Submit.

The key change summary page opens (Figure 208).

Note: When changing a key type, the default values do not appear. If 
you enter a Redirection DN length that is greater than the default value in 
the Meridian 1 or Succession CSE 1000 system, or if you enter a 
Redirection DN that has more digits than the default value, you receive a 
validation error.
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Figure 208   CFW key change summary page

7 Click Confirm.

A confirmation page appears. See “Change confirmation pages” on page 419.

Removing a key

Use the following procedure to remove the function associated with a key, 
creating a blank, or unassigned, key:

1 Click a key in the graphic on the Telephone Keys page (Figure 196 on 
page 399).

2 Click Change.

The Key Change Wizard launches. The function associated with the selected 
key is highlighted in the list (Forward All Calls in this example) (Figure 209).
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Figure 209   Current key function displayed in the Key Change Wizard

3 Click Clear.

The key change summary page appears (Figure 210).

Figure 210   Unassigned key change summary page

4 Click Confirm.

A confirmation page appears. See “Change confirmation pages” on page 419.
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Finding Directory Numbers

You use the Find DN button to look up used or unused Directory Numbers. It 
appears next to the edit box for any DN key.

Find Unused Directory Numbers

1 Click Find DN (Figure 202 on page 405). The Find Directory Numbers page 
appears (Figure 211).

Figure 211   Find Directory Numbers page

2 Click Find Unused DNs.

3 Enter a range of DNs on which to search.

Note: You must have a Numbering Plan defined in the System 
Properties in OTM Windows Navigator to use the Find Unused DNs 
feature. If the Numbering Plan is not defined, or if there are no unused 
DNs, an error message appears (Figure 213).
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4 Click Find. If unused DNs are found, a page similar to the example shown in 
Figure 212 appears. If there are no unused DNs found, the message shown in 
Figure 213 appears.

Figure 212   Find results when Unused DNs exist

Note: Only the unused DNs belonging to the same site, system, and 
customer as the telephone are shown.

Note: If you click Find Again, you return to the previous page, and you 
can enter a different range of DNs.
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Figure 213   Find results when no Unused DNs exist

Find Used Directory Numbers

1 Click Find DN (Figure 202 on page 405). The Find Directory Numbers page 
opens (Figure 211 on page 411).

2 Click Find Used DNs.

3 Click the radio button that corresponds to your search criteria.

• To search by DN, enter a range of DNs on which to search.

• To search by last name, enter the last name of the person whose name is 
assigned to the DN you are seeking.

• To search by first name, enter the first name of the person whose name is 
assigned to the DN you are seeking.

4 Click Find. If DNs that match your search criteria are found, a page similar to 
the example shown in Figure 214 appears. If there are no DNs that match your 
search criteria, a message similar to the one shown in Figure 215 appears.
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Figure 214   Find results when there are matching used DNs

Figure 215   Find results when there are no matching used DNs
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Telephone Features page

The Telephone Features page allows you to view and change features that are not 
assigned to keys. Features are related to individual prompts in LD 10 or 11, with 
one or more configurable parameters.

The administrator determines which features the user can see in the list. If the 
User Group access properties allows changes, the Submit and Reset buttons 
appear (Figure 216).

Whenever possible, a drop-down list box containing all possible values for the 
feature is provided. In cases where this is not possible, for example when entering 
a call forward DN, an edit box is provided.
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Figure 216   Telephone Features page
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Telephone Details page

The Telephone Details page provides a summary of the complete telephone 
configuration. It consists of two tables, one for the keys (Figure 217), and one for 
the features (Figure 218).

Figure 217   Telephone Details layout (Keys)
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Figure 218   Telephone Details layout (Features)
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Change confirmation pages

A confirmation page appears when you click Confirm in the change summary 
page for the General, Keys, or Features tab. The confirmation page varies based on 
the User Group access properties.

When the User Group access properties allow the Meridian 1 or Succession 
CSE 1000 synchronization option, the page shown in Figure 219 appears.

Figure 219   User confirmation with automatic synchronization

If the User Group access properties do not permit automatic synchronization, any 
changes that have been input occur the next time you perform a synchronization, 
and the page shown in Figure 220 appears.

Figure 220   User confirmation when system administrator approval is required

Note: Use Station Administration to view pending changes. Revert any 
scheduled changes that you do not want to occur prior to 
synchronization.
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If there is a validation error, the user is presented with an error message similar to 
the example shown in Figure 221.

Figure 221   Example of a validation error message

Telephone change procedure for an End User

The following procedure outlines the steps that a user, who is a member of the 
EndUser user group, takes to make changes to their telephone.

1 Launch a supported web browser and navigate to the OTM host name or IP 
address provided by the System Administrator.

2 Log in to Desktop Services using the end user Windows NT login name 
provided by your System Administrator.

The My Profile web page appears. This contains your OTM Directory 
information (Figure 182 on page 386).

3 Click a telephone extension link in the Navigation Bar.

The General page appears. If allowed by your System Administrator, you can 
change the Station Location, Key Based Modules, and Designation fields 
(Figure 193 on page 395). To make a change:

a Enter the new value and click Submit.

A page containing a summary of the changes opens (Figure 194 on 
page 396).

b Click Confirm.
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A confirmation message appears (Figure 219 through Figure 221 
beginning on page 419).

4 Click Keys.

The Keys page appears. If allowed by your System Administrator, you can 
change the key-based features, or functions, assigned to any of the keys. To 
make a change:

a In the graphical representation of your telephone, click the key you want 
to change (Figure 196 on page 399).

b Click Change.

A list of the available choices for the selected key appears in the Key 
Change Wizard (Figure 198 on page 401).

c Select a new key-based feature to assign to the key, and then click Open.

d If required, the Key Change Wizard opens a page that requests you to 
enter the parameters for the selected key (Figure 199 on page 402).

e Enter the parameters and click Submit.

A page containing a summary of the changes appears (Figure 200 on 
page 403).

f Click Confirm.

A confirmation message appears (Figure 219 through Figure 221 
beginning on page 419).

5 Click Features.

Note: The sync status of the telephone appears at the top of the 
Telephone pages. When the information for the telephone has been 
changed, but the changes have not been synchronized with the 
Meridian 1 or Succession CSE 1000 system, a Show Current 
configuration/Pending changes drop down box allows you to select 
which configuration is shown. Once the telephone and the Meridian 1 or 
Succession CSE 1000 system have been synchronized, “Current 
configuration” appears at the top of the page, and the drop-down box no 
longer appears.
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The Features page appears. If permitted by your System Administrator, you 
can change the allowed/denied status or settings of features assigned to your 
telephone (Figure 216 on page 416). To make a change:

a Do one of the following:

• Select the appropriate value for the desired feature from the drop-down 
box.

• Enter the value of the parameter associated with the desired feature in the 
edit box.

b Click Submit.

A page containing a summary of the changes appears.

c Click Confirm.

A confirmation message appears (Figure 219 through Figure 221 
beginning on page 420).

6 Click Details. Information on the Keys and Features currently assigned to 
your telephone is presented on the Details page. This page is always read only 
(Figure 217 on page 417, and Figure 218 on page 418).

7 If a Schedule button appears at the top of the Telephone pages, your System 
Administrator has permitted you to automatically synchronize all of the 
changes you have made with the information stored on the Meridian 1 or 
Succession CSE 1000 system. If there is no Schedule button, your System 
Administrator will review your changes and manually synchronize the 
changes with the Meridian 1 or Succession CSE 1000 system. If the Schedule 
button is present:

a Click Schedule.

b Assign a Task Name, and then click Next to accept the default Task Time, 
2 minutes from now.

c Wait 2 minutes for the changes to be transmitted to the system.

d Click Refresh in your browser.

Note: Click the “Do not transmit if the telephone is busy” check box to 
avoid disconnecting an active call on your telephone.
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When the Show Current configuration/Pending changes drop-down list no 
longer appears, all of your changes have been made and the telephone has 
the new configuration.

8 If allowed by your network administrator, click the Billing Reports link in the 
Navigation bar to view your telephone billing reports from the Telecom 
Billing System (TBS). For information on the TBS Web Reporting 
application, see Optivity Telephony Manager Telemanagement Applications 
(553-3001-331).

Telephone change procedure for a Web Navigator User

The following procedure outlines the steps that a Web Navigator user takes to 
make changes to a telephone.

1 Launch a supported web browser and navigate to the OTM host name or IP 
address, provided by the System Administrator, with “/admin” appended to 
the address.

2 Log in to the Web Navigator using the login name provided by your System 
Administrator.

3 Click the Find link under Telephones in the Navigation Bar.

The Find Telephones page opens.

4 Perform a search to locate the record for the telephone you want to change.

See “Find Telephones page” on page 331 for information on how to perform a 
search.

5 On the Find results page, click the link in the Location column that 
corresponds to the telephone you want to change.

The General page for the telephone appears. If allowed by your System 
Administrator, you can change the Station Location, Key Based Modules, and 
Designation fields (Figure 193 on page 395). To make a change:

a Enter the new value and click Submit.

A page containing a summary of the changes appears (Figure 194 on 
page 396).

b Click Confirm.
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A confirmation message appears (Figure 219 through Figure 221 
beginning on page 419).

6 Click Keys.

The Keys page appears. If allowed by your System Administrator, you can 
change the key-based features, assigned to any of the keys. To make a change:

a In the graphical representation of the selected telephone, click the key you 
want to change (Figure 196 on page 399).

b Click Change.

A list of the available choices for the selected key appears in the Key 
Change Wizard (Figure 198 on page 401).

c Select a new key-based feature to assign to the key, and then click Open.

d If required, the Key Change Wizard opens a page that requests you to 
enter the parameters for the selected key (Figure 199 on page 402).

e Enter the parameters and click Submit.

A page containing a summary of the changes appears (Figure 200 on 
page 403).

f Click Confirm.

A confirmation message appears (Figure 219 through Figure 221 
beginning on page 419).

7 Click Features. The Features page appears. If allowed by your System 
Administrator, you can change the allowed/denied status or settings of 
features assigned to the telephone (Figure 216 on page 416). To make a 
change:

Note: The sync status of the telephone appears at the top of the 
Telephone pages. When the information for the telephone has been 
changed, but the changes have not been synchronized with the 
Meridian 1 or Succession CSE 1000 system, a Show Current 
configuration/Pending changes drop down box allows you to select 
which configuration is shown. Once the telephone and the Meridian 1 or 
Succession CSE 1000 system have been synchronized, “Current 
configuration” appears at the top of the page, and the drop-down box is 
no longer displayed.
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a Do one of the following:

• Select the appropriate value for the desired feature from the drop-down 
box.

• Enter the value of the parameter associated with the desired feature in the 
edit box.

b Click Submit.

A page containing a summary of the changes opens.

c Click Confirm.

A confirmation message appears (Figure 219 through Figure 221 
beginning on page 419).

8 Click Details. Information on the Keys and Features currently assigned to the 
telephone appears on the Details page. This page is always read only 
(Figure 217 on page 417, and Figure 218 on page 418).

9 If a Schedule button appears at the top of the Telephones pages, your system 
administrator has permitted you to automatically synchronize all of the 
changes you have made with the information stored on the Meridian 1 or 
Succession CSE 1000 system. If there is no Schedule button, your System 
Administrator will review your changes and manually synchronize the 
changes with the Meridian 1 or Succession CSE 1000 system. If the Schedule 
button is present:

a Click Schedule.

b Assign a Task Name, and then click Next to accept the default Task Time, 
2 minutes from now.

c Wait 2 minutes for the changes to be transmitted to the system.

d Click Refresh in your browser.

Note: Click the “Do not transmit if the telephone is busy” check box to 
avoid disconnecting an active call.
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When the Show Current configuration/Pending changes drop-down list no 
longer appears, all of your changes have been synchronized and the 
telephone has the new configuration.

Billing Reports

The Billing Reports link is visible in the Navigation bar if the user has a Web 
Reporting Role other than “No Access” defined in their OTM Directory record. 
Web Reporting Roles are: All, Peer, Managed, Personal and No Access. If the 
Web Reporting Role is No Access, or if it is left blank, the Billing Reports link is 
not displayed. Billing Reports requires the Billing Enhanced Package and is 
available with all three levels of OTM, General, Enhanced, and Premium.

Other Links

You can define the Other Links button of the Navigation Bar for Web Desktop 
Services users. If you do not define links, then this section is not visible. To define 
Other Links edit the HTML file (Figure 222). The file is located in 
<Nortel>\OMServices\OMStation\EndUser\Eng.

To launch web pages from the Windows or Web Navigator, double-click on the 
item in the Navigator. You are asked whether you are launching a Terminal or an 
Application. If you select Application, a web browser window opens. The URL 
for the application is set in the Web URL field in the Properties—Applications tab. 
This process automatically adds a Generic system in OTM.

To launch an executable file from the Windows Navigator, double-click on the 
item in the Navigator. You are asked whether you are launching a Terminal or an 
Application. If you select Application, the executable file will launch. The 
location for the executable is set in the path field in the Properties—Applications 
tab.

Note: If the Show Current configuration/Pending changes drop-down 
box continues to appear, locate the record for the telephone using the 
Find Telephones page. If the changes have been transmitted to the 
Meridian 1 or CSE 1000 system, the sync status for the telephone 
appears as TRN. Any other value in the sync status column indicates that 
the synchronization process has failed. You should either resubmit the 
request or review the log files on the OTM server.
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Figure 222   Other Links

Meridian Mail

One possible item that could go into the Other Links section is a link to Personal 
Mailbox Administration (PMA). This link takes users to the URL for logging in to 
the Meridian Mail web pages. Users must enter the mailbox number and password 
to proceed. Once logged in, users can view and change their mailbox 
configuration. This feature is available with Meridian Mail 13 and later releases.
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Figure 223   Meridian Mail Login
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Chapter 4
Station Administration

Optivity Telephony Manager (OTM) provides system administrators with 
powerful tools for maintaining and updating Meridian 1 and Succession 
CSE 1000 systems. The OTM software package consists of OTM Common 
Services and several OTM applications, each of which provides specific system 
management capabilities. This chapter describes the OTM Station Administration 
application.

Overview

The Station Administration application helps administer databases that define 
end-user stations (telephones) on Nortel Networks Meridian 1 and Succession 
CSE 1000 systems. The Station Administration application contains the following 
modules:

Station Administration

This module allows you to change station data on an individual or selected 
group basis.

CPND

Use this module to manage Call Party Name Display (CPND) data.

List Manager

Use this module to manage data for Speed Call, Group Call, and Group Hunt 
lists.
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Report Generator

This module allows you to create and produce standard or customized reports.

Conversion utility

This module provides import and file rebuild capabilities. 

Communications

This module synchronizes system data. It is used to copy OTM data to 
Meridian 1 and Succession CSE 1000 systems, and to copy system data to 
OTM.

Related OTM documents

The information presented in this chapter should be read in conjunction with 
Installing and Configuring Optivity Telephony Manager (553-3001-230), which 
describes the installation and configuration of OTM. Refer to Chapter 2, 
“Common services,” for information on how to operate and maintain the different 
applications within the OTM suite.

OTM Directory

The OTM Directory feature allows you to share common user data (Name, 
Department, and so on) between OTM applications such as Station 
Administration and Telecom Billing System. OTM Directory Services is 
described more fully in Chapter 2, “Common services,” beginning on page 160.

OTM Desktop Services

OTM Desktop Services allows end users to view and modify the configuration of 
their telephone through a web browser.
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The OTM Web Navigator provides many of the same functions available in the 
OTM Windows Navigator. The OTM Windows Navigator allows you to view, 
configure, and administer sites, systems, and users. Although the Web Navigator 
does not offer all of the same features, the presentation of Meridian system and 
feature information is easy to navigate. OTM Web security meets the same criteria 
as provided by Windows NT.

One of the advantages of the OTM Web interface is the ability for users to 
configure their telephones through their web browser. As an administrator, using 
Web Desktop Services, you can also block end-user access to configuration 
screens. A particularly useful Desktop Services feature is the ability to customize 
the Help files to suit specific customer needs. The web display of telephone data 
includes a graphical representation of the telephone (Figure 224). The page shows 
the features that are configured for the telephone, and provides access to Help text 
for telephone features.

Figure 224   Telephone Keys Page
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For more information on Web Desktop Services, refer to “Web Desktop Services” 
on page 381.

Web-based Station Administration

A subset of the functionality available in Station Administration is also available 
using the Web interface. Table 27 outlines the features that are available using 
Windows-based Station Administration and which of these features are supported 
through the Web-based Station Administration interface. For information on 
additional features that are available with Web-based Station Administration, see 
Chapter 3, “Web Services,” on page 317.
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Table 27   Comparison of Windows and Web-based Station Administration

Functionality

Supported in 
Windows-based 
interface

Supported in 
Web-based 
interface

Station Administration
Record View A

Addition of a new telephone

Deletion of an existing telephone
Swapping of two telephones
Restore B

Global Update C

Modify a telephone
— Modify telephone owner

— Modify customer number
— Modify location
— Modify key configuration

• Key feature list
• DN list

— Modify feature/CLS configuration E

• Feature list
• TN list F

— Modify admin fields G

— Modify value for number of key-based expansion modules
— VMB, MARP, ANIE configuration

— CPND name configuration for a DN
— Interaction with Employee Editor I

Validation of a telephone

Forms interface or Power User tool
Form editor J

Designation strips K

Print reports L

Yes
Yes

Yes
Yes
Yes

Yes

Yes

Yes
Yes

Yes
Yes

Yes
Yes

Yes
Yes
Yes

Yes
Yes
Yes

Yes
Yes
Yes

Yes

Yes
No

No
No
Yes

No

No

No
Yes

Yes
Yes D

Yes
No

No
Yes
No

Yes H

Yes
Yes 

No
No
No

No

Templates
Template configuration M

— Addition/deletion/modification/validation Yes No

Hardware
Hardware configuration N

— Addition/deletion/modification/validation Yes No
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Functionality

Supported in 
Windows-based 
interface

Supported in 
Web-based 
interface

CPND Customer Configuration
CPND Customer Configuration O

— Addition/deletion/modification/validation Yes No

CPND Name Configuration
CPND Name Configuration P

— Addition/deletion/validation
— Modification

— Interaction with Employee Editor

Yes
Yes

Yes

No
Partially Q

Yes

Synchronization with Meridian 1 or Succession CSE 1000 systems
Transmission of telephone changes to the system

Retrieval of telephone information from the system
Synchronization of CPND customer data
Synchronization of CPND name data

Yes

Yes
Yes
Yes

Yes R

No
No
No

Employee Editor User Interface
Employee Editor UI S

— Addition of new employee

— Modification of existing employee
— Deletion of an employee

Rebuild directory
Audit - full/partial V

Yes
Yes

Yes
Yes

Yes
Yes

Partially T

No

Partially U

No

No
No

Report Generator
Report Generator W Yes No

Conversion Utility
Conversion Utility X Yes No

Station Administration Options
Operation mode - Installation/Maintenance Y

Operation mode - Ignore numbering plan/hardware check z
Yes
Yes

No
No

Online Help/Documentation
Station Administration Help Yes Yes

Notes:
A Reading station data records and displaying the selected information in tabular form.

B Changes made by the administrator are rolled back.

C Making changes to multiple telephones.

Table 27   Comparison of Windows and Web-based Station Administration (continued)
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Notes: (continued)

D Search provided for used/unused DNs in Web-based Station Administration.

E CLS = Class of Service; Feature = non-key based features.

F Shows list of TNs and associated location if the TN is assigned.

G Non-Meridian 1 or Succession CSE 1000 data fields used to store administration related 
information.

H Only the CPND name associated with a DN that is assigned to a key can be modified.

I The Employee Editor needs to be updated whenever the DN, Location, or TN for a telephone is 
modified.

J A tool to create custom forms.

K Printed labels that are used on telephone keys to indicate the associated feature.

L Canned reports based on Mnemonics, Feature Groups, and so forth.

M Templates that can be used to create new telephones with predetermined feature/key 
configurations.

N Hardware view of Windows-based Station Administration is used to manage the information about 
digital and analog line cards.

O CPND view of Windows-based CPND Administration stores customer information related to CPND 
name.

P CPND Name view of Windows-based CPND Administration stores CPND Name information 
associated with DNs.

Q Can be modified while modifying a key configuration in Web-based Station Administration.

R Only Schedule Now option available. Each task can transmit the changes for only one telephone.

S Provides the capability to add/modify/ delete employees to the Station Administration employee 
database.

T Provided as the “Directory Update” application in Web-Based OTM.

U Only the User Group, Published, Login, and Report Access Group fields can be modified.

V Brings Station Administration and Directory into sync.

W Generated custom reports based on Station/CPND database.

X Utility to run database conversion. Usually runs during the end of installation; however, you can also 
launch it from Windows-based Station Administration.

Y In maintenance mode, you are provided with an option to schedule the transmission of changes the 
very next moment after you apply changes to a telephone. In installation mode, you configure all of 
the telephones and then schedule a bulk transmission of the changes.

Z Provides options to turn off validation of DNs against the numbering plan and validation of TNs 
against hardware data.

Table 27   Comparison of Windows and Web-based Station Administration (continued)
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Before you start

Before you can start using OTM Station Administration, you must retrieve station, 
customer, and other associated data files from the Meridian 1 or Succession 
CSE 1000 system. The following summarizes the steps to follow before you can 
use OTM Station Administration.

Ensure site and system information is defined

The properties of sites and systems must be defined before you can use Station 
Administration. See Chapter 2, “Common services” for detailed procedures.

• Define site properties in the New Site Properties sheet.

• Define system properties in the System Properties dialog box. Be sure to 
completely define information in the following tabs:

— General tab - Include system name and short name.

— Communications tab - Include at least one communications profile.

— System Data tab - Add information on the system type and release. 
Identify System Parameters and enable software Packages.

— Applications tab - Be sure to enable the Station Administration 
application and a corresponding communication profile.

— Customers tab - Be sure to add at least one customer (usually Customer 0) 
and define this customer’s properties to include a customer name, user ID, 
and password. You must define unique names, IDs and passwords for 
each customer added. 

— Numbering Plans tab - Define a numbering plan for each customer using 
the Numbering Plans tab found under the Customer Properties sheet. 
Station Administration uses information entered here to provide a list of 
available extensions (DNs), and validates the extensions against the 
applicable feature (for example, ACD DN).

— Network tab - Define Gatekeeper Zones and Survivable Cabinets in 
Meridian 1 systems. Define Gatekeeper Zones, primary and alternate 
Signalling Servers, as well as Media Gateways and Branch Offices for 
Succession CSE 1000 systems. This tab appears in the System Properties 
dialog box for Call Servers, Meridian 1 systems, Media Gateways, 
Survivable Cabinets, and Branch Offices.
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Once defined, sites and systems appear as icons in the OTM Navigator and 
System windows.

Update the system data

To update the system data:

1 From the OTM Navigator window, double-click on the system to open the 
system window for the system you want to update.

2 Choose File > Update System Data. The Update System Data dialog box 
opens (Figure 225).

Figure 225   Update System Data dialog box

When you update the system data, your X11 packages, Customer Data Block 
information, and Configuration Record information are brought over to OTM.

3 Click OK to update the system data.

Note: If you have configured a Succession CSE 1000 system as a 
Succession Branch Office but have not enabled Package #390, the update 
process is aborted. The following error appears in the event log “Error: 
Branch Office Package #390 is not present: Aborting ‘Update System 
Data’.” To correct this problem, enable Package #390, or reconfigure the 
system as a non-Branch Office system.
Using Optivity Telephony Manager Release 2.0x



438 Station Administration
Retrieve customer station data

Open the System window. View the applications available for the system you have 
defined and open the Station Administration application under the Stations icon. 
With the Station Administration window open, retrieve station data for the system. 
Choose Synchronize-Retrieve-All from the menu bar.

Retrieve Reserve Unit TNs

With the Station Administration window open, retrieve Reserve Unit TN 
information. Choose Synchronize > Retrieve > Reserve Unit TNs. The 
Synchronization window opens. Click OK to begin retrieval.

Retrieve CPND configuration

Open the System window. View the applications available for the system you have 
defined and open the CPND application under the Stations icon. The CPND Name 
window appears listing names of users on the system. Choose View > CPND from 
the menu bar. The CPND window appears. 

Choose Synchronize > Retrieve > Specify from the menu bar. The Call Party 
Name Display Retrieve window opens. Enter the customer number. Click OK. 
The Synchronization window opens. Click OK to begin retrieval.

Retrieve CPND names

With the CPND window open, choose View > CPND Name. The CPND Name 
window appears. With the CPND Name window open, retrieve CPND data for 
each customer on the system. Choose Synchronize > Retrieve > All from the 
menu bar. The Synchronization window opens. Click OK to begin retrieval.

Note: When station data is retrieved, the primary Directory Number and 
names from the name display assigned to station prime Directory Number 
are used to populate the OTM Directory. Refer to “OTM Directory 
services” on page 479 for further detail.
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Repeat this step for each customer on the system.

Additional considerations

While getting started with Station Administration, you communicate with the 
Meridian 1 or Succession CSE 1000 system. For further information, see 
“Communicating with the Meridian 1 or Succession CSE 1000 system” on 
page 557.

Retrieval of information from large systems can be time consuming and 
negatively affect system performance. You can use the Scheduler utility to plan 
when to perform these tasks, usually during hours when the number of users on 
the system are low, to minimize the effect of this operation on the system’s 
performance.

Using Station Administration

Before using OTM Station Administration, you must install and configure the 
software. Refer to Installing and Configuring Optivity Telephony Manager 
(553-3001-230) for installation instructions.

Overview

OTM Station Administration supports creation, maintenance, change, and 
reporting of single and multi-line station data and Call Party Name Display 
(CPND) information. Station data defines the setup for each user (telephone) 
connected to the Meridian 1 or Succession CSE 1000 system.

Station data can be collected from the Meridian 1 or Succession CSE 1000 
system, or can be created within OTM. You can change this data within OTM and 
upload it to update the Meridian 1 or Succession CSE 1000 database.

Note: CPND names are automatically retrieved as part of customer 
Station data retrieve. This step is not necessary if you have performed a 
customer Station data Synchronize > Retrieve > All.
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Each system has a number of stations. You can set up each station individually. In 
practice, many stations have features in common. All features of any station can 
be set individually, or in groups with common criteria. The Station Administration 
module lets you create many stations with identical features using templates. 
However, those features that can be considered unique for a station (such as DN, 
TN, name, and location) are accessible through a dialog box that graphically 
represents the appearance of the instrument at that station. All other features are 
accessible from this dialog box through function buttons.

Station data considerations

You should be aware of the following considerations when operating the Station 
Administration module:

Location

The OTM application uses one field (Location) in the station data base to identify 
and index a station record. Station data records are stored and retrieved by the 
value in this field. Since this is the primary identifier for a station within OTM, 
each station must be assigned a unique Location value. A new station cannot be 
created in OTM until you assign a unique Location value. Furthermore, Location 
is the only station record field that is required by OTM (see “DES” next). OTM 
validates this field during data entry and does not allow non-unique values or no 
value.

The Location field is not stored in the Meridian 1 or Succession CSE 1000 
system. Data retrieved from Meridian 1 or Succession CSE 1000 system 
containing stations not currently defined in OTM has the fully qualified Terminal 
Number field value (with dashes for separators instead of blanks) assigned to the 
Location field. You can edit this value to conform with your Location value rules. 

DES

The DES field is a required field for station data residing on the Meridian 1 or 
Succession CSE 1000 system. It is possible to create station data within OTM that 
has no DES field value (this 1–6 character designator value can be assigned 
through the Administration feature of the Features function in Station 
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Administration). In such cases, OTM attempts to assign the first 6 characters of 
the Location value to DES. If this value contains non-alphanumeric values OTM 
leaves the DES field blank (location can contain all Windows-acceptable 
characters, but DES can have only letters and numbers). 

Any station with no DES value causes an error during transmission of OTM data 
to the Meridian 1 or Succession CSE 1000 system. The Validation utility checks 
the DES and any other field values that can cause transmission failures. Refer to 
“Station data validation” on page 478.

Meridian 1 or Succession CSE 1000 station data retrieved from a system always 
has a DES value. 

Sync status

The Station list includes the current Synchronization status. Values include:

• NEW: A station that has been created on OTM but not yet transmitted to the 
Meridian 1 or Succession CSE 1000 system.

• TRN: A station that has been synchronized with the Meridian 1 or Succession 
CSE 1000 system. The OTM software has determined that the version of this 
station in the OTM PC data base is consistent with the version of this station 
on the Meridian 1 or Succession CSE 1000 system.

• CHG, or RPL: A station that has been changed (or marked for replacement) on 
the Meridian 1 or Succession CSE 1000 system. The OTM system has 
determined that the station has been updated on the OTM PC data base and 
that the version on the Meridian 1 or Succession CSE 1000 system does not 
yet reflect the OTM update activity.

• OUT: A station that has been marked for deletion on the OTM PC data base. It 
will not be deleted from the OTM PC data base until the station has been 
OUTed (deleted) on the Meridian 1 or Succession CSE 1000 system during a 
Synchronization/Transmit operation. An OTM user may update a station 
marked OUT. The OTM system asks whether the station is to be restored 
before allowing you to update the station.

• CUR: A duplicate record containing all of the original configuration of a 
record that is in the process of being modified. The CUR record is created 
when the user double clicks on a record whose sync status is TRN, CHG, or 
RPL. If there is no change made and the sync status is TRN, the CUR record is 
deleted.
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• SWP: A station that has been marked to have its Terminal Number swapped 
with the Terminal Number of a different station. If the previous sync status of 
the two stations is not NEW, their sync status is changed to SWP.

The OTM Delete or Cut operation works slightly differently depending on the 
station’s synchronization status. A station marked NEW can be deleted 
immediately from the OTM PC data base, since it has not been configured on the 
Meridian 1 or Succession CSE 1000 system. A station with any other status is 
marked OUT, since the station must be OUTed on the Meridian 1 or Succession 
CSE 1000 system before the station may actually be deleted from the OTM PC 
data base. A station marked OUT will continue to appear in the list of stations 
until it has been successfully OUTed from the Meridian 1 or Succession 
CSE 1000 system. A station with a status of OUT on the OTM PC database on 
which you apply Edit - Cut or Edit - Delete continues to be marked OUT until it 
has been successfully synchronized.

Synchronization considerations

If the Station Administration module is in Maintenance mode (set from Options - 
Mode in Station Administration module), you are prompted to schedule data 
transmission to Meridian 1 when any modifications are made to the data stored in 
OTM.

You can schedule synchronization when prompted, or schedule later.

Reports and text files

All log report activity is performed, by default, in the current working directory 
for the System (the system subdirectory in your PC system). Other reports are sent 
to the PC directory of your choice. Here is a list of text files with the appropriate 
extension found in the working directory:

• Report Forms (filename.FRM)

• Reports (filename.TXT)

• Communications Logs (filename.LOG)

Note: You need only supply the filename when prompted to save these 
files; OTM automatically supplies the appropriate extension.
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• Validation Data (you provide the extension)

• Designation Strips (you provide the extension)

Parsing retrieved data

Meridian 1 or Succession CSE 1000 data retrieval is actually a two-stage task. 
OTM first retrieves the data to a file in the system subdirectory, and then it parses 
the file to conform with the OTM data base rules.

The connection to the Meridian 1 or Succession CSE 1000 system is only required 
during the retrieval stage. If you are connected to the system through a modem, 
OTM disconnects the modem immediately after the retrieval and before the parse. 
The parsing takes place on the PC only. If you interrupt the parse, for example, by 
turning off or rebooting the PC, it can be restarted by using Synchronization 
Retrieve - Parse Only.

Multi-Tenant

If the TENA package is equipped, you must supply a tenant number (TEN).

System Hardware

During station data retrieval, the system hardware information is updated with 
cards that will support the type of stations being retrieved. This may not actually 
match the hardware used (although it will be compatible). If an exact match is 
required, you must manually update the hardware data in the Station Hardware 
view.

Station Administration window

When you start Station Administration, the OTM Station Administration window 
opens, allowing access to station data for a single Meridian 1 or Succession 
CSE 1000 system. Figure 226 shows the OTM Station Administration window.
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Figure 226   Station Administration window

The OTM security system allows the system administrator to make functions 
available on a user-by-user basis. Those menu items that are not available to you 
are shown dimmed. The menu bar contains the following drop-down menus:

• File

• Edit

• View

• Synchronize

• Forms

• Options

• Help
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File menu

Use the File menu to access the station data of a selected system. 

Reports: Lets you design and generate reports based on existing station data. This 
item includes the Report Generator and two existing reports, as follows: 

• Bridges: A list of bridges on the system.

• Multiple appearances: A list of multiple-appearance stations.

• Excess DNs: A list of DNs in the OTM Directory that do not have matching 
DNs in Station Administration.

Desig. Strip: Sends data for labeling buttons and keys on an instrument to an OTM 
viewer where you can browse and print the data.

Print: Sends the station list to an OTM viewer (described in “Generating reports” 
on page 583) where you can browse and print the data. Choose from the following 
display formats: 

• Short Format: One-page abbreviated list of station data.

• By Feature Group: Station data by Feature Group.

• By Field Mnemonic: Station data by Meridian 1 or Succession CSE 1000 field 
mnemonic.

Validate: Validates field values (full or partial, selectable in a submenu) for 
selected station records: 

• Partial: Checks selected fields in the station records that, if incorrect, can 
cause a transmission failure during synchronization.

• Full: Checks all fields in the selected station records.

Audit: Synchronizes records in the OTM Directory and Station databases: 

• Partial: Checks the OTM Directory data base for all changed employee 
records and updates the Station database.

• Full: Attempts to bring the Station database into full synchronization with the 
OTM Directory database by cross-checking each Station record with the OTM 
Directory.
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Rebuild Directory: Rebuilds the OTM Directory database. Select From CPND 
Database to use the information stored in the CPND database, or From Station 
Database to use the information store in the Station Administration database. This 
option has been provided to allow you to overcome a situation in which the OTM 
Directory database has become corrupt.

Conversion utility: Launches the conversion utility, used to update OTM data. For 
more information, see “Conversion utility” on page 430. 

Close: Closes Station Administration and returns to the OTM window. OTM 
automatically saves station updates as they are made. This means that you need 
not close an open system before quitting the application.

Edit menu

Use the Edit menu to change data within an open system. The OTM-specific 
actions include:

Add / Delete / Update / Restore: Adds/removes/modifies/restores stations for the 
currently open system.

Global Update / Select / Select All: Allows you to modify selected fields in a group 
of selected stations.

User Field Names: Assigns names for the 10 user-defined fields for the current 
system.

View menu

Use the View menu to choose the station data parameters you want to view. The 
currently selected view is indicated by a check mark against the menu selection 
and appears in the status bar of the main window.

Station: This option displays a list of all stations defined for this system. When 
you choose an Edit function, the highlighted station record is opened. If none are 
defined, you can only choose Edit > Add.

Note: See “OTM Directory services” on page 479 for more information 
on database synchronization and updating.
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Pending: This option shows all pending records. This provides a list of all stations 
that are not synchronized with the Meridian 1 or Succession CSE 1000 system.

Template: This option accesses templates that contain station definitions that the 
open system may use frequently.

Hardware: This option displays line cards used in the system. The Reserve TN 
feature adds new fields in this view to reserve units on the supported card types.

Employee Selector: This option launches the Employees editor.

External Parties: This option launches the External Parties editor.

Roles/Projects: This option launches the Roles/Projects editor.

Organizational Hierarchy: This option launches the Organizational Hierarchy 
editor.

Sort: This option appears when the Station or Pending view is selected. The list 
can be sorted by a criterion selected from a submenu that appears when you 
choose this item. The criteria include

• Name

• Directory Number

• Location

• Terminal Number

• Instrument (telephone) Type

• Sync Status

• Department

Note: Sorting only affects the displayed list. It does not change the actual 
order of the station records within the data base.
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Synchronize menu

Use the Synchronize menu to schedule communications with the Meridian 1 or 
Succession CSE 1000 system. The Synchronize menu lets you set up reception or 
transmission of station data using the OTM communications functions. See 
“Communicating with the Meridian 1 or Succession CSE 1000 system” on 
page 557.

Retrieve: Allows selection of station data for retrieval from the Meridian 1 or 
Succession CSE 1000 system into the station data base. You can define criteria to 
select stations for download from the Meridian 1 or Succession CSE 1000 system. 
Retrieve also allows a Parse Only option that formats retrieved data for OTM.

Transmit: Allows selection of station data for transmission to Meridian 1 or 
Succession CSE 1000 system.

Reconcile: Compares discrepancies between station data and the OTM data base 
and deletes invalid set information from the OTM data base. Information about 
deleted sets is recorded in a log file. See “Communications logs” on page 573.

Forms menu

Use the Forms menu to configure form-based station administration. 

Forms Interface: Enable or disable form-based station administration. 

Select Form: Select which form to be used by form-based station administration. 

Edit Custom Form: Run the station form editor. 

Note: Before using Reconcile, be sure to Retrieve the latest station data 
first. This ensures the station data is compared to the latest OTM data 
base.
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Options menu

Use the Options menu to configure options that affect the operation of the Station 
Administration and CPND Administration modules. 

Mode: Invoke the mode function to configure the operational mode and optional 
station data validations. 

Help menu

Use the Help menu to display documentation to help you understand and use the 
application. 

Contents: Displays the Contents page of the online documentation system.

Search Help On: Allows you to type in key words and select a topic of interest 
from the list of Help topics. 

How to Use Help: Provides basic instructions about using the online documentation 
system. 

Accessing Station data

Choose View - Station to display the list of stations defined for the system. Each 
line in the list contains the following information for one station. Refer to 
“Managing station data” on page 458 for a more complete description of these 
fields.

Location: A unique station identifier. OTM uses the value here as an index to the 
station.

Type: The instrument defined for the station. 

Sync Status: An indication of whether Meridian 1 or Succession CSE 1000 data 
and the data in OTM are synchronized. The following list defines the 
synchronization status for station data:

• NEW: A station defined in OTM that has never been uploaded to the 
Meridian 1.
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• TRN: The station is synchronized with the Meridian 1 or Succession 
CSE 1000 system.

• CHG: The station has been modified in OTM but not in Meridian 1 or 
Succession CSE 1000 system.

• RPL: A station defined in OTM to replace synchronized station data.

• OUT: A synchronized station deleted from OTM but not yet from the 
Meridian 1 or Succession CSE 1000 system.

• CUR: The station is synchronized with the Meridian 1 or Succession 
CSE 1000 system.

• SWP: The station has been modified in OTM but not in the Meridian 1 or 
Succession CSE 1000 system.

Prime DN: The prime directory number.

Terminal Number: The station terminal number, representing the address within 
the Meridian 1 or Succession CSE 1000 system.

Last/First Name: The station user's name.

Department: The department in which the station is used.

This represents part of the data record for a station so that you can identify that 
station in the listing. The rest of the station data is available as described in 
“Managing station data” on page 458.

The Pending View

The Pending View shows all pending records, that is, all Station records that have 
not yet been synchronized with the switch. Only CHG, RPL, NEW, OUT, and 
SWP records are available in this view. Pending shows both the CHG and CUR 
versions of a station.

The Template view

Choose View > Template to display a list of station templates defined for the 
system. The list contains the same information for a template as the Station view 
contains for a station, with one exception, the Sync Status field is not shown in 
Template view. The value of the Location field in the list is the actual name of the 
template as displayed in the template list field of the Add Station dialog box.
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The Hardware view

Choose View > Hardware to display a list of line cards, for station TN assignment. 
If Hardware Validation is active, then the TN added to each set is validated against 
the TN card type. The cards defined under the hardware view are also used for 
automatic TN assignment. 

The Reserve TN dialog box is accessed through the Hardware Configuration 
dialog box. Click Reserve Units.

New stations

You can add new stations to the list in the Station Administration view. Use a 
template that defines data for the station or stations that you are adding, or add 
each station individually. You must give each new station a unique Location field 
value. 

If OTM is in Maintenance mode, you are prompted to schedule communication 
with Meridian 1 or Succession CSE 1000 system whenever you add new stations 
in OTM. You can synchronize the system data now, schedule a time for 
synchronization, or cancel the prompt and schedule synchronization later. See 
“Communicating with the Meridian 1 or Succession CSE 1000 system” on 
page 557.

Station template

Data that is common to many stations can be stored in a template. In a single 
operation, using a template, you can define multiple stations that have data in 
common. The only data that must be added to stations defined with a template is 
the Location field value, so that each station added using the template can be 
identified in the list and by the Station Administration module. A template can 
contain all or part of a station definition and stations defined using templates can 
be changed in the same way as stations defined individually. You can change 
template data in exactly the same way as station data.

Add stations

To add new stations, choose Edit > Add from the Station Administration window 
Station view. The Add Station dialog box opens (Figure 227).
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Figure 227   Add Station dialog box

At any time, you can click Cancel to return to the Station list window without 
adding stations.

When the data for this dialog is complete, click OK to display one of the two 
dialog boxes listed below: 

Adding a single station

If you are adding a single station, the dialog box for the selected set opens. You 
can update the station data now, or just give it a unique identifier in the Location 
field and click OK to accept the current data and update later if required. See 
“Managing station data” on page 458.

Note: The Instrument field and the Template field are mutually exclusive. 
An instrument would be defined in the template. If an instrument is 
selected, there can be no selected template.
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Adding a phantom station

The Phantom Terminal Number (PHTN) feature permits you to define and 
configure TNs with no associated physical hardware. This feature, when used in 
conjunction with the Call Forward All Calls (CFW) and Remote Call Forward 
(RCFW) features, allows a call to a phantom station to be redirected to an existing 
telephone. For more information on phantom Terminal Numbers, see X11 
Features and Services (553-3001-306).

To add a phantom station, a phantom loop must be defined first. Phantom stations 
can only be added to existing phantom loops. Use LD 17 to create a phantom loop. 
Retrieving station data from a system with existing phantom stations preserves the 
phantom loops defined for those phantom stations. Phantom loops can only 
contain phantom stations. 

Choose View > Hardware from the Station Administration window Station view. 
The Hardware view appears. Choose Edit > Add. The Hardware Configuration 
view appears. Select the phantom card from the drop down list. Phantom cards 
have the prefix PHT. If you do not enter values, OTM enters the next available 
loop-shelf-card information not used by the selected card into the appropriate 
fields. Click OK to return to the Hardware Configuration view. 

Choose View > Station to return to the Station view. Choose Edit > Add. The Add 
Station dialog box appears. In the Instrument field, select an analog type set (for 
example, the 500 set). Click the Phantom check box. Click OK. The Station Data 
dialog box appears.

Note: Cards must have unique loop-shelf-card combinations.

Note: Phantom TNs can only be assigned to analog sets.
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Enter the terminal number for the station in the Terminal Number field. Each 
station must have a unique TN. Double-click in the Terminal Number field to 
display the Terminal Numbers window listing available terminal numbers 
associated with this loop. If no phantom cards are defined, this window is blank. 
Double-click on an available terminal number on the list to enter that value into 
the Terminal Number field in the Station Data dialog box.

Adding multiple stations

If you are adding more than one station, the Multiple Station Add dialog box 
opens (Figure 228). This dialog box lets you define some aspects of each station 
to be added. If you used a template for station definition, much of the station data 
may already be defined

Figure 228   Multiple Station Add dialog box

The dialog box contains an updatable list box containing the stations. The 
following data fields allow you to define or update the stations in the list.
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Adding stations

When you have defined the station or stations that you want to add, click OK in 
the dialog box. If the Location field for one or more of the stations is not unique, 
an error box appears. Click OK in the error box to return to the previous dialog 
box to make the correction.

OTM adds the accepted station or stations to the OTM station data base. If OTM is 
in maintenance mode you are prompted, in a Synchronization dialog box, to set up 
communication with the Meridian 1 or Succession CSE 1000 system. See 
“Communicating with the Meridian 1 or Succession CSE 1000 system” on 
page 557.

Click Cancel in the Synchronization dialog box to return to the Station 
Administration list. The new stations are added with a status of NEW. In this case, 
you can use the Synchronize menu at a more convenient time to set up 
communications.

Deleting stations

You can select stations for deletion from the Station list view. Use one of the 
following methods to remove them from the OTM data base:

• Press the Delete key.

• Choose Edit > Delete. 

• Choose Edit > Cut.

Each method displays a Yes/ No confirmation prompt before removing the 
stations. If you click Yes, OTM removes the stations from the OTM station data 
base.

There are special considerations to bear in mind when deleting stations that 
contain references to Voice Mailbox directory numbers. Refer to “Voice Mailbox” 
on page 538 for more information.
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If the stations to be deleted have never been synchronized with the Meridian 1 or 
Succession CSE 1000 system (Sync status is NEW) they are removed from the list 
in the window. In this case, you can bring the stations back by choosing Edit > 
Undo Delete. This undelete is only available until you perform another edit 
function on the station list.

If the Sync status is not NEW, deleted stations are marked for deletion from the 
Meridian 1 or Succession CSE 1000 system at sync time by setting the sync status 
to OUT. These stations will not be deleted from the list until synchronization. If 
you attempt to change such stations, you are prompted to bring them back before 
the update can be performed. If you do bring them back, the status is reset to the 
original sync status. Attempts to delete stations with sync status OUT are ignored.

To delete a station with sync status of CHG, select the associated CUR record and 
choose Edit > Restore.

Swap

The Swap function allows you to swap the terminal numbers (TNs) of two 
telephones. A CUR record is created for both telephones. The sync status of the 
telephones is changed SWP if their previous sync status is not NEW.

You can swap only two telephones at a time. CUR records cannot be swapped. 
The telephones that are swapped with each other should have compatible line card 
types. For example, a digital telephone cannot be swapped with an analog 
telephone.

A group of telephones that are swapped to each other is called a swap group. For 
example, if Telephone A is swapped with Telephone B, and at a later time, 
Telephone B is swapped with Telephone C, Telephones A, B, and C form a swap 
group. When a telephone is selected for transmit from a swap group, you are 
asked to transmit the remaining telephones in the swap group.

SWP records cannot be deleted in Station Administration. The sync status of SWP 
records can be changed to TRN or NEW through a global update. SWP records 
can be restored to their original values by selecting Edit - Restore. This action 
impacts the transmit results of the other telephones in the swap group.
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Terminal number is disabled for SWP records. When you select a form file to run 
a report, check boxes are added for sync status TRN, NEW, OUT, RPL, CHG, 
CUR, and SWP. When the check box is checked, the records with the 
corresponding sync status are included in the generated report. The SWP check 
box is checked by default.

Adding a station template

You can use a template of station data to add multiple stations (or a single station) 
with common data. To create a template, choose Edit > Add in the Station 
Administration list view window with the View > Template option selected. This 
displays an Add Template dialog box containing a list of instruments (telephone 
types) that you can use with this particular system (Figure 229). 

Figure 229   Add Template dialog box

Select an instrument that you want to use for this template, and then click OK to 
display the dialog box for the instrument. You can change the data in this template 
as if it were a regular station. See “Managing station data” on page 458.
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If your Meridian 1 is configured for the Virtual Office feature available on M3900 
Series Meridian Digital Telephones, select the appropriate instrument and click 
the Phantom check box to add a Virtual Terminal template, or click the Host 
Terminal check box to add a Host Terminal template.

You are still required to insert a unique identifier in the Location field before the 
template is accepted. The data entered is used by OTM as the template name 
(displayed in the Add Station dialog box).

If you want to modify an existing template, proceed as if it were a single station. 
Choose Edit - Update in the Station Administration window with View - Template 
selected.

Managing station data

OTM displays individual station data in a dialog box that graphically represents 
the set used at that station. If the telephone has feature keys, these are displayed 
and can be selected like all other fields. Some data entry fields (those that use DN 
or TN data, for example) can be double-clicked to display options for that field.

Data change is described for a typical set (M2616). Most other instruments 
contain a subset of the data for this instrument, and the update procedure for each 
field and function is the same as that described here.

Whenever you modify station data that has already been synchronized with the 
switch, the Sync Status for that station is set to CHG. This is an indication that 
OTM and Meridian 1 or Succession CSE 1000 system are not in sync. 

If OTM is in maintenance mode, you are prompted to set up communication with 
the Meridian 1 or Succession CSE 1000 system. You can synchronize the data at 
this time, schedule a time for synchronization or cancel the prompt and schedule 
synchronization later. See “Communicating with the Meridian 1 or Succession 
CSE 1000 system” on page 557.
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Updating stations

OTM displays a list of stations for the selected system in the Station 
Administration module when you choose View > Station. You can update the data 
for any station by selecting the desired station and choosing Edit > Update. This 
displays the dialog box for the set that the station currently uses. You can update 
multiple stations at one time. See “Global Update” on page 544.

Station data

The dialog box shown in Figure 230 is for an M2008 digital telephone. In addition 
to the normal OK, Cancel, and Help buttons, the set dialog box can have other 
function buttons, such as Features and Admin. These functions are described in 
“Features button” on page 470 and “Administration” on page 474 respectively.

Figure 230   Station Data dialog box

Functions and options assignment is described in “Key assignments” on page 462. 
An additional Key Features Edit field appears for analog sets to allow you to 
assign key functions. This field is described in “Key Features field” on page 473.
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The data fields for an instrument are a subset of the following:

First Name / Last Name
The First Name and Last Name fields are linked to the OTM Directory. These 
fields cannot be edited in the Station Data dialog box. The Directory button 
provides a link to the OTM Directory record which contains this data. See “OTM 
Directory services” on page 479.

Customer
You can select one of a drop-down list that contains the customers associated with 
the site.

Location (required)
The Location is a unique identifying code for this station, up to 12 characters. 
OTM does not let you assign a code that is already in use for this site. 

Note that if you have not defined DES (OTM data only), then OTM assigns the 
first six alphanumeric characters of the Location field when you synchronize 
OTM data with the Meridian 1 or Succession CSE 1000 system.

Note also that on receiving data that is not defined in OTM from the Meridian 1 or 
Succession CSE 1000 system, the Location field is assigned the full TN value, 
including hyphen separators, of the station.

Department
This field displays the department information that has been entered into the OTM 
Directory. This information may not be edited in the Station Data dialog window. 
The Directory button provides a link to the OTM Directory record which contains 
this data. See “OTM Directory services” on page 479.

Terminal Number
This field contains four separate numeric fields that represent the Meridian 1 
system address (the terminal number contains values for Loop, Shelf, Card and 
Unit) that this station uses.

Note: For Meridian 1 Option 11C, and Succession CSE 1000 systems, 
the TN format is Card, 0, 0, Unit.
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Hunt to / External Hunt to
You can enter a DN in these fields that will receive calls if this station is busy. 
Note that you can use any telephone number, even one that is external to this site. 
However, you can double-click this field to display the DN list defined in the 
Customer’s Number Plan for this site and choose one of those. The External Hunt 
is for incoming calls that are not from a DN in the Numbering Plan.

Call Forward to / External Call Forward to
You can enter a DN in these fields that will receive calls if there is no answer at 
this station after a predetermined number of rings. These fields operate in the 
same way as the Hunt to and External Hunt to fields (see DN Assignment).

Add on feature key modules

In addition to these fields, a station may have feature/option keys or key lamps. 
Some sets can have additional keys as add-on modules. In such cases, one of the 
following fields is available in the dialog box: 

DBA (Display-Based Add-on module)

This field is only available on the M3904 and M3905 telephones. It allows you to 
program key features for an add-on soft-labeled key module. Enter the number 1, 
which indicates the presence of the Display-Based Add-on attached to the set. An 
additional function button, called ADD On 1, appears when you enter 1 in the 
DBA field.

Click Add On 1 to display a dialog box that graphically represents the keys of the 
Display-Based Add-on. You assign features to the add-on module the same way 
that you assign features to keys on the telephone.

Key-Based Access (Add-on modules)

This field is only available for M2000 Series and M3900 Series digital telephones. 
It allows you to program key features for add-on key modules. You can enter a 
number in the range 0–2, which indicates the number of add-on modules attached 
to the set. Additional function buttons (for example, Add On 1) may appear on the 
dialog box, based on the entry in this field.
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You can click these additional buttons to display a dialog box that graphically 
represents the keys of the add on module. You assign features to the add-on 
modules the same way that you assign features to keys on the set.

Key Lamp Strips

This field is only available for QSU60 digital telephones. It is a numeric field that 
can contain a number in the range 1–7. The default value is 1 which represents the 
key lamp strip on the basic telephone. If you enter a number up to 7 in this field, 
the new number is validated when the cursor is moved out of the field. That 
number of additional key lamp strips (less the one on the telephone), labeled KLS 
2-7, appears in the dialog box. You can select one of these buttons to display a 
dialog that graphically represents the keys of the add-on module. Assigning 
features to the add-on keys is the same as for the regular keys on the telephone.

For sets that do not have keys or key lamps, the available features assignment 
dialog box appears within the set dialog box itself. The assignment procedure is as 
described in “Key assignments” on page 462.

Key assignments

In addition to the data fields, the set may have keys to which you can attach 
feature functions. When you select a key, a Key Assignments dialog containing a 
single-selection scrollable list of Key Features appears (Figure 231). The features 
listed are defined for this set using the Features button on the station data dialog 
box. 
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Figure 231   Key Assignments dialog box

In addition to the usual OK, Cancel, and Help buttons, the dialog box has a Clear 
button that you can use to remove any feature attached to the selected key on the 
set (to assign a different feature, it is not necessary to first clear the current 
feature). You may also enter the first letter of the Key Feature of interest to move 
to that section in the list.

The dialog box contains a single-selection Key Features list. The currently 
selected feature is highlighted. Select using the mouse or the up/down arrow keys.

Click Cancel at any time to return to the station data dialog box without changing 
the current key assignment. Click OK to assign the selected feature to the key.

Some of the features require you to enter additional information. When you select 
one of these, text entry boxes appear in the dialog box. You can double-click on a 
DN text entry box to display the list of DNs in the customer's Numbering Plan that 
are available to the selected feature. For more information, see “Directory Number 
assignment” next.
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Directory Number assignment

There are three kinds of DNs:

1 A DN assigned to the station. This must be in the customer’s Numbering Plan 
as defined for the system.

2 A DN referred to by this station (message center, for example) that must be in 
this customer’s Numbering Plan.

3 A DN referred to by this station (Call Forward, for example) that can be the 
number for any station—external or within the Numbering Plan.

To enter a DN for a selected station, you can type the number into the Directory 
Number field or double-click within the Directory Number field to select from a 
list of DNs used in the Numbering Plan for the customer (Figure 232).

A manually entered number for DN categories 1 and 2 above will not be accepted 
if it is not contained in the Numbering Plan, unless the Numbering Plan validation 
has been turned off (Option > Mode).

Figure 232   Directory Numbers dialog box
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If you are assigning a DN to this station (versus referring to the DN of another 
station as in forwarding or hunting options) the dialog box allows functions in 
addition to the usual Cancel, Help, and OK buttons: 

• Assign: Assigns the highlighted DN to the key.

• MARP: If the assigned DN is being used by another station you can assign 
incoming calls to that DN to this station with the Multiple Appearance 
Redirection Prime (MARP) button. To assign incoming calls to the other 
station, you must update the other station and select the MARP function there. 
This button toggles the current MARP assignment.

• CPND: A Call Party Name Display (CPND) display dialog box allows you to 
define how calls from this station are displayed to the receiving station. See 
“CPND data considerations” on page 499

• VMB: A Voice Mailbox (VMB) display dialog box allows data to be associated 
with a DN (which serves as a mailbox ID) rather than a TN. You can modify 
the VMB data from any station that has an appearance of the mailbox DN. 
Refer to “Voice Mailbox” on page 538.

The dialog box contains a single-selection list of DNs defined in the numbering 
plan for this system. Those numbers that are already assigned also have MARP 
and Location data listed. The currently selected DN is highlighted. If you are 
assigning a DN to this station, the dialog box also contains a display-only box 
with the current DN assignment entered.

At any time, click Cancel to return to the previous window without changing the 
current assignment. Click OK to assign the DN and return to the previous window.
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Terminal Number assignment

The Terminal Number (TN) is the full hardware address of the port to which this 
station is attached. If the Terminal Number field requires an entry, you can type 
the number into the Terminal Number field, or you can double-click within the 
field and select from a list of available TNs. The data entry must be in the 
following format:

lll s cc nn

where:
lll= The number of the Meridian 1 loop
s= The number of the system shelf
cc= The number of the shelf card position
nn= The number of the card circuit (unit)

The range of numbers available depends on the hardware configuration and 
software release in use at the system.

The list shows the Location for all TNs that are already assigned (Figure 233).

Note: For Meridian 1 Option 11C, and Succession CSE 1000 systems, 
the TN format is:

cc 0 0 nn
553-3001-330 Standard 3.00 November 2002



Station Administration 467
Figure 233   Terminal Numbers window

The dialog box contains a single-selection list of TNs defined in the Station 
Hardware view that permit access to the set defined for this station. The current 
selection is highlighted.

At any time, click Cancel to return to the previous window (Set dialog box) 
without changing the current assignment. Select a TN and click OK to assign the 
TN and return to the set dialog. The OTM system validates the TN for availability 
and permissibility using the Hardware assignments stored under the Station 
Hardware view, and assigns the TN.

Note: Automatic TN Assignment will not assign any units in the 
Hardware View that are marked as a RUT. See “Reserve TN feature” on 
page 468.
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Reserve TN feature

This feature allows users to assign TNs to support instrument types on a station 
line card and mark these units as reserved for a given unit type. These types, 
referred to as Reserve Unit Type (RUT), include the following:

• ATT (Attendant Console)

• 1250 (1250 Digital Attendant Console)

• 2250 (2250 Digital Attendant Console)

• R232 (RS232C Units)

• R422 (RS422 Units)

• OOSSLT (Out of Service Single Line Terminal)

• OOSMLT (Out of Service Multiple Line Terminal)

• PWR (Power for Attendant Console)

• OTHER (as defined by the user)

When a unit is reserved as one of these types, it is not assigned during Automatic 
TN Assignment and appears in the TN Selection List Box accordingly. The 
Automatic TN Assignment will not assign any units in the Hardware View that are 
marked as a RUT. RUTs are validated at the field and global levels. RUTs are 
marked by the user in the Hardware View and by the Station Retrieval Module. 
The Reserve TN feature shows existing Usage Fields at the card level in the 
Hardware view.

To access the Reserve Units dialog box, click Reserve Units in the Hardware 
Configuration dialog box (Figure 234).

Note: Reserved Units TNs are skipped during Automatic Terminal 
Assignment.
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Figure 234   Hardware Configuration dialog box

The Station Retrieval Module recognizes RUTs and updates the Reserved Units 
fields in the Hardware View with the RUT value during an initial retrieval. 
Discrepancies are handled in the same way as other retrieved fields with the 
Meridian 1 or Succession CSE 1000 value overwriting the OTM data base value. 
RUTs do not appear in the Retrieval Specify by Type field since they are not 
treated as Station Types.

Use the Reserve Units dialog box to assign RUTs (Figure 235).
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Figure 235   Assigning values in the Reserved Units dialog box

Features button 

The Features button is located in the Station Data dialog box (Figure 230 on 
page 459). Click the Features button to open the Features dialog box (Figure 236). 
The Features dialog box lets you examine and update station features and options 
defined for your system. This is the function you use to assign a value to the DES 
field in OTM. It allows you to set feature key assignments. The Features dialog 
box contains a single-selection list of features or feature groups that you can 
scroll.
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Figure 236   Features dialog box

Select the appropriate radio button to sort by either Features or Feature Groups. 
“Features” sorts the features alphabetically by Meridian 1 or Succession 
CSE 1000 mnemonic. “Feature Groups” organizes the features into related 
categories.

The dialog box contains Select, Done and Help function buttons. Help displays 
online Help for this dialog box. Done returns to the station data dialog box, and 
Select displays a dialog box associated with the selected feature. Use the feature 
dialog box to define parameters for the feature, and assign the feature to a key.

Use one of the following methods to select a feature: 

• Select a single feature with a mouse click. 

• Use the arrow keys to move the highlight bar to the desired feature. 

• Type the first letters of the feature mnemonic (for example, SCR). 

• Click and drag the highlight bar to the desired feature. 

Use the Page Up and Page Down keys to browse the feature list. 

When you click Select, OTM displays a dialog box for the selected feature. You 
can enter data in the dialog box. When you click OK, OTM modifies the feature 
based on your input, and returns to the Features list. 
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While the Features list is open, you can examine and modify other features. When 
you finish modifying features, click Done to return to the Station Data dialog box 
(Figure 230 on page 459). The keys that you assigned are labeled appropriately. 

When you are finished defining or examining features, click Done to return to the 
Station Data dialog box. If you have assigned keys, the appropriate keys are 
labeled in the Station Data dialog box.

Feature Group category

When you select Search by Feature Group and choose Select in the Features 
dialog box, a dialog box that you use to configure the selected feature appears. 
The dialog box shown in Figure 237 is for the Call Pickup feature. The other 
dialog boxes are similar in appearance.

Figure 237   Feature dialog box (example)

The dialog box contains fields (usually text boxes associated with drop-down 
selection lists) that define the functionality of the feature. If the feature can be 
assigned to a key, the dialog box also contains a Key Features list of functions that 
can be assigned to a key for this feature.
553-3001-330 Standard 3.00 November 2002



Station Administration 473
Forced targets

Some entries in the Feature dialog box will force a change in the class of service 
(CLS) of the selected station. For example, filling in the “Flexible Call Forward 
No Answer DN (FDN)” field of call redirection forces “Call Forward No Answer 
(FNA) to “Allowed”. This target enforcement occurs only when the feature dialog 
box is exited.

Key Features field

The Key Features field is a single-selection list of features associated with this 
feature group. You can assign the function selected in this list to a key for the 
selected station.

You assign features to a key from the Key Assignments dialog box. Double-click 
the desired function in the Key Features list of the Features dialog box to open the 
Key Features Edit dialog box (Figure 238) for the selected function.

The dialog box shows a single-selection list of key numbers. Each key in the list 
shows any already-assigned feature (and associated DN, if applicable). The list is 
dimmed except for any assignment made during this session. 

Note: You can only make key assignments to sets with feature keys. Key 
assignments cannot be made to Type 500 or 2500 stations.
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Figure 238   Key Features Edit dialog box

The Key Features section of the dialog box contains two function keys, Set and 
Clear. If the selected key is already assigned, the Set function is dimmed. Use the 
Clear function to remove a key assignment. Use the Set function to assign the 
current feature to an unassigned key.

At any time, click Cancel to return to the Features definition dialog box without 
changing the current key assignments. Click OK to assign key function and return 
to the Features Definition dialog box.

Administration

Click Admin in the Station Data dialog box (Figure 230 on page 459) to open the 
Administration dialog box (Figure 239). The Administration dialog box allows 
you to assign values to fields that OTM uses in classifying and administering 
station data. These fields are not part of the Meridian 1 or Succession CSE 1000 
system data block. The user fields and their labels are assigned using Edit > User 
Field Names. These headings allow you to define values for your own situation. 
This option contains text boxes so that you can assign specific values to these 
fields for this station. 
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Figure 239   Administration dialog box

The data entry fields in this dialog box include the following: 

Category: A drop-down list of line connection types for this station.

Color: A drop-down list of colors available for this instrument.

Pwr Fail TN: A text box for the TN used if the system power fails.

LDN Index: Radio buttons to define which of three indexes contains the DN for this 
station. A DN index is set up at the system level when the Numbering Plan is 
defined. The index is used while viewing and printing designation strips for this 
instrument.

Admin Fields: The Admin fields are used by the Telecom Billing System (TBS) 
data base for billing purposes and other types of cost allocation. Refer to Using 
Optivity Telephony Manager Telemanagement Applications (553-3001-331) for 
information on the TBS application.
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Designation Strips

A telephone can have many features and services available by function buttons 
(keys) and indicators. A Designation Strip is a printout of labels that can be 
attached to the telephone to indicate the function of the various buttons and 
indicators on the set (and also the DN of the station using the set). You can create 
files that let you examine and print Designation Strips created from the data 
defining the stations using File > Desig. Strip. 

A Designation Strip typically contains the directory number for a single line set. 
In addition, sets with key caps that designate a DN (for multi-line sets) or 
reference other DNs also appear in the Strip.

Designating Directory Numbers

A station on a Meridian 1 or Succession CSE 1000 system can have up to three 
listed directory numbers (LDN). The system Numbering Plan defines whether 
ranges of directory numbers (DN) are set for direct inward dialed (DID). 
Typically, a station DN, as defined for the Designation Strip, is a regular 10-digit 
telephone number with an extension:

(aaa) xxx-aaaa Ext bbbb

where:

The Designation Strip utility examines the System Configuration Customer data 
to determine the LDN used by the station. The utility determines whether the 
station DN is in a DID range defined in the system Numbering Plan. The 
following are the two possible results:

Non-DID number: The Strip prints the LDN and uses the station DN for the 
extension.

aaa Represents the area code

xxx Represents the exchange

aaaa Represents the number

bbbb Represents the extension
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DID Number: The Strip gets the area code (aaa) from the LDN, the exchange (xxx) 
from the DID number, the number (aaaa) from the station DN.

Display of Designation Strips

Choose File > Desig. Strips from the Station list window to open the Strip 
Selection dialog box (Figure 240).

Figure 240   Strip Selection dialog box

The dialog box contains a single-selection scrollable list of Designation Strip 
types created by OTM. The current selection is highlighted. Cancel returns to the 
Station list window. Help displays online Help for the dialog box. Test Pattern 
sends a single page dummy strip to the Viewer. Use this to print on the appropriate 
form and ensure that the form is aligned correctly in the printer. Strip sends Strips 
for stations selected in the Station Configuration view to the OTM Viewer. From 
the Viewer window, print the strip by selecting File > Print from the menu bar.

Designation Strips are printed on special forms. The following separate form 
layouts are used by OTM:

• Unity     For Unity 1 and Unity 2 sets

• Unity 3    For Unity 3 sets

• Compact For older SL-1 type sets

• SL-1/500 For normal SL-1 type sets

• Digital     For M2000 series digital sets (not M3000 series)
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Station data validation

The station data base contains one record per station. Some of the field values in a 
record depend on the system properties, the instrument used, and features and 
options enabled. In addition, the OTM application contains “rules” that define 
possible values, sizes, and ranges for the fields.

The Station Administration module includes a Validation utility that checks that 
the values assigned to certain fields are compatible with the configuration and the 
OTM data rules.

The Validation function checks the currently selected station records in the Station 
list view before uploading to the Meridian 1 or Succession CSE 1000 system. 
There are two options—partial and full validation. Full validation checks every 
field and may require considerable time.

Validating the data

Select the stations for validation in the Station list view and choose File - Validate 
to display a cascading submenu. Choose Partial (checks the values defined 
previously) or Full (checks all field values) to start the Validation check.

Note: All other sets use the SL-1/500 Strip layout. Stations with ACD 
keys have both the ACD DN and the Position ID printed. It is up to the 
user to attach the desired label to the appropriate key.

Note: You can validate the data for each station individually using the 
Validate function key on the set dialog box. This button examines the 
entries for the current open station only. Any errors are noted. Perform a 
Station Validation to capture any data entry issues that may result in a 
transmission error when synchronizing with the Meridian 1 or Succession 
CSE 1000 system.
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While OTM performs the checks, a status box indicates progress in single record 
increments. At any time, click Cancel in the status box to halt the task. 

When the task is complete, the OTM Viewer displays the validation data. You can 
save this to a text file (in a user-defined file name and location), print it, or simply 
browse and discard it (see “Generating reports” on page 583 for a description of 
the Viewer).

When the task is complete, you should send all the new or modified station and 
CPND information to the Meridian 1 or Succession CSE 1000 system. You may 
select all of the NEW or CHG stations, for example. You should apply the 
Validation process from the File menu to the selected stations to ensure that the 
entered data is consistent across all stations. See “Communicating with the 
Meridian 1 or Succession CSE 1000 system” on page 557.

OTM Directory services

The OTM Directory is a data base for storing employee and organizational data. 
Portions of this data are shared with the Station Administration and Telecom 
Billing System applications.

This section presents information on the interaction between the OTM Directory 
and the Station database. For additional information on the OTM Directory, see 
“Directory Services” on page 160.

The OTM Directory contains the following employee attributes:

• Employee first, middle, and last name

• Identification (employee ID)

• Job Title

• Department

• Manager

• E-mail address

• Mailing address

Note: Click Cancel to discard the validations already completed.
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• List of telephone extensions

• LDAP Unique Identifier (UID)

LDAP UID is used to link an OTM Directory entry to a Corporate LDAP 
Directory entry. The linkage is done using LDAP synchronization utility or 
import. Refer to “LDAP Synchronization” on page 291 for further details.

• Additional information on each telephone extension

The Station data base stores the following employee attributes for telephones:

• Employee first and last name

• Department

In the Station database, a telephone or Directory Number (DN) may be linked to 
an employee in the OTM Directory. When a change is made to the name in the 
OTM Directory, the Station data is updated using the Station/OTM Directory 
synchronization mechanism.

The Meridian 1 or Succession CSE 1000 system stores employee first and last 
names for use with Call Party Name Display (CPND). When an employee name 
which is linked to a DN is changed, the Station data is updated and flagged as 
“changed.” This information is updated in the Meridian 1 or Succession 
CSE 1000 system during the next synchronization.

In Station, the linked employee names and departments are read-only. A link is 
provided to the OTM Employee Editor. In the Employee Editor, you can view and 
edit the employee data in the OTM Directory.

Architecture

There is one OTM Directory database and one Station database per Meridian 1 or 
Succession CSE 1000 system. The OTM Server supports multiple Meridian 1 and 
Succession CSE 1000 systems.

The Lightweight Directory Access Protocol (LDAP) synchronization process runs 
in the background of the OTM server at a scheduled time. It synchronizes 
employee data between the OTM Directory and the optional LDAP server. The 
updates may occur in either direction depending on the mapping defined by the 
administrator (Figure 241).
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Figure 241   OTM Directory Service architecture

For more information on LDAP synchronization, see “LDAP Synchronization” on 
page 291.

Display Name

The primary function of OTM is to act as the user interface to the PBX. The 
primary function of an LDAP server is to act as the master repository of employee 
data for an organization. With regards to a person’s first and last names, OTM 
should receive the formal first name and last name of an individual from the 
organization’s LDAP server.

If there is no LDAP server in an organization, OTM performs the function of 
being the master repository for employee name data. The first and last name 
stored in the Employee Editor are the official first and last name for the individual 
(for example, “Timothy Smith”). The CPND application determines how the 
individual’s name appears on a telephone display (for example, “Tim Smith”).
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The CPND dialog box (Figure 243) contains a Link to Directory check box. If this 
box is checked, the First Name and Last Name edit boxes are locked, and the 
name that appears on telephone displays matches the name that is stored in the 
OTM Directory. If this check box is not checked, you may edit the first and last 
names. In this example, you want to ensure that the Link to Directory check box is 
not checked and that “Tim Smith” was entered into the first and last name edit 
boxes. 

When name changes are made directly on the PBX and then synchronized with 
OTM, the name that is stored on the PBX is loaded into the CPND database. The 
Link to Directory check box is disabled since the information is not able to flow 
backwards into the OTM application. The OTM Directory is still the source for 
the official name whether this is driven by synchronization with an LDAP server 
or through direct entry into the Employee Editor.

Station Administration links to the OTM Directory

Prior to the introduction of the OTM Directory Service, each telephone can be 
assigned a first name, last name, and department in Station Administration. When 
defining the DN key on the telephone, the CPND name can be linked to the 
display name of the employee associated with the telephone.

In OTM, the employee name and department are now linked to the OTM 
Directory. Links are provided from Station Administration to the Employee Editor 
within the OTM Directory.

Note: The M1 Corporate Directory feature for the M3900 series and IP 
telephones uses the first and last names in the Employee Editor, not the 
name that appears in CPND.
553-3001-330 Standard 3.00 November 2002



Station Administration 483
Figure 242   Station Data dialog box

Figure 242 shows the layout of a Station Data dialog box. The First Name, Last 
Name, and Department fields are read-only when the station is linked to an 
employee in the OTM Directory. Click the Directory button to bring up a list of 
employees for the current system with this employee selected. You may open the 
Employee Editor to change the employee data. Changes in the OTM Directory are 
updated in the Station database immediately.

Click Clear to empty the First Name and Last Name fields and remove the link to 
the OTM Directory. These fields cannot be edited; they can only be linked to the 
OTM Directory.

When a change is made to the First Name, Last Name, or Department fields in the 
OTM Directory, the Station database is updated as follows:

• If the OTM Windows Navigator is running, the Station database is updated 
automatically in the background.

• If the OTM Windows Navigator is not running, the Station database is 
updated when you open the Station property page for the affected station.
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The CPND dialog box, shown in Figure 243, contains a Link to Directory check 
box. Check this box to place the First and Last name information from the OTM 
Directory into the CPND Name for this DN. Now you cannot edit the names 
fields. To enter a different CPND display name for the Directory Number, 
uncheck the link and enter the new name.

Figure 243   Call Party Name Display Name dialog box

Note: Only the First Name and Last Name in the OTM Directory are 
synchronized with the Meridian 1 or Succession CSE 1000 system. The 
name and department information is used by the OTM Corporate 
Directory application. To ensure that the Directory and Station databases 
are synchronized, select Partial Audit from the File menu.
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OTM Directory Integration

Directory Services gives a common point of entry for common directory data and 
synchronization with Corporate LDAP servers. The OTM Directory database is 
designed to contain end-user data. Common data is shared among different OTM 
applications and the administrator can input data using the different editors. 

Typical attributes of an entity include First Name, Last Name, Job Title, and 
e-mail address. Other attributes to be assigned using the editors are the place of 
the entity within the Organizational Hierarchy, and Roles/Projects or External 
Parties assigned to the entity. A directory entity can also be assigned such assets as 
Extension (telephone number and account code). Note that only the Employee and 
Roles and Projects attributes can be assigned to an extension or telephone set. 

With the integration of Station Administration and OTM Directory, common data 
is now shared and synchronized. Some of the attributes that were in Station 
Administration, such as Last Name and First Name, have effectively moved to 
OTM Directory. Assets such as Terminal Number and Station Location have been 
added to OTM Directory. The references to the Extension Number, Terminal 
Number, and Display Name in the Directory Entity record are sourced from 
Station Administration because the Station database contains the true 
representation of these values.

OTM Directory can be launched from the Set display in Station Administration. 
This enables you to assign the set to a Directory Entity (that is, employees and 
Roles/Project). Synchronization between the Station and Directory database 
enables the two databases to update each other with any changes. The Station 
Administration Display Name database is kept in sync with changes in the 
corresponding Corporate LDAP Server. OTM Directory also synchronizes 
directly with the LDAP Server.

Launching the Directory Selector and Editors

The OTM Directory Selector in Station Administration is launched using the 
Directory button in the Station Data dialog box (Figure 242 on page 483).

The Directory button accesses the OTM Directory of entities, and allows you to 
assign an entity to this set. If the set is already assigned, the Directory is initialized 
to that particular Entity in the list.
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The Directory button opens the Employee Selector window. Here it is possible to 
edit the Entity attributes, add a new Directory Entity, or delete an existing Entity. 
If a deleted Entity had been assigned to a Station, the Last Name, First Name, and 
Department fields are set to blank when viewed in Station Administration.

The Employees, Organizational Hierarchy, External Parties, and Roles/Projects 
Editors are launched from both Station Administration and CPND through the 
View menu.

Common Fields between Station Administration and 
OTM Directory

Station Administration interacts with the following fields in OTM Directory:

• Name attributes: Last Name, First Name for employees, and Name attribute 
for Roles and Projects

• Organization Path, which interacts with the Department attribute in Station

• Extension Number

• Terminal Number

• Display Name

When a set or a role/project is assigned to an employee, the Name and Department 
fields are copied from OTM Directory to Station Administration. Simultaneously, 
the Extension Number and Terminal Number of the set are copied from Station to 
OTM Directory. The Display Name field in OTM Directory is given the name of 
the first CDNP DN on the set.

The CPND set interface features a Link to Directory check box. When checked, 
this ensures that the CPND name for this DN is the same as the Display Name of 
the Directory Entity owning that set. To modify the CPND, you must first uncheck 
the box.

If no display name exists for the Directory Entity, the check box is grayed out.
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Department Field

The Department field in Station Administration derives from the last node in the 
ORG patch in OTM Directory. This may not correspond exactly to the OTM 
Directory Department setting. For example, if Department is configured as the 
second-last node in the Directory ORG path, Station Administration assigns 
whatever is the last node in the ORG path as Department, and so the two fields do 
not correspond.

For additional information on OTM Directory Services, refer to “Directory 
Services” on page 160.

Excess DN report

An employee listing in the Directory lists all the extensions associated with the 
employee. Normally, each of these extensions would match with a DN in Station 
Administration. However, when a set (and with it the DN) is deleted from Station 
Administration, the corresponding entry in the Directory is not removed. The old 
extensions remain in the Directory to provide information to your billing 
department. Thus, there is a possibility that some of the extensions in the 
Directory do not match with any DNs in Station Administration. These extensions 
are termed Excess DNs.

Station Administration has a facility to print off a report that lists these excess 
DNs against their owner employee.

This report can be run by selecting File > Reports > Excess DNs in the Station 
Administration window (Figure 244).
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Figure 244   Excess DNs menu

Station and Directory synchronization

There are synchronization methods used by Station Administration to stay in sync 
with OTM Directory:

• Polling

• Messaging

Polling

There are two polling methods available in the File, Audit menu option in the 
main Station window: Partial and Full.
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Partial Audit polls the Directory for all the changed Employee records and update 
the Station Database. Thus, a Partial Sync deals with all Directory changes.

A Full audit polls the Directory for all changed Employee records, update the 
Station database, and also brings the Station database into complete sync with 
OTM Directory. 

If there are any discrepancies in the Station database (for example, a failure to 
update the database by OMMessageSync resulting in Directory changes not being 
flagged), a Full Audit resolves them. Full Audit cross-checks every Station record 
against Directory entries, and may be time-consuming.

Polling does not deal with changes relating to the deletion of Employees. This 
function is handled by OMMessageSync.

Messaging

When a change occurs in OTM Directory, Directory automatically sends a 
Windows message to OMMessageSync, a 32-bit application that is launched 
immediately once you begin OTM Navigator. OMMessageSync then processes 
this message and updates the Station database.

OMMessageSync continues to run in the background, so that the Station and 
CPND views are updated constantly with Directory changes by OMMessageSync.

Directory changes are synchronized with the Station database even if Station 
Administration is not running, as OMMessageSync operating concurrently with 
OTM Navigator. 

Changes made using the Station Administration interface reflect directly in the 
OTM Directory. This means that once the Station modification is confirmed, the 
OTM Directory is immediately updated.

Note: Synchronization also takes place whenever a set associated with an 
Employee or with Roles/Projects is opened for editing purposes. Once the 
editing begins, all fields are automatically synchronized.
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Retrieval of Station Data

When synchronizing databases, the Directory database must be updated as a 
separate process. This happens immediately after the name parsing process.

For a Station set to be added to the OTM directory, it must have at least one CPND 
Display Name. For more information, see “CPND overview”, next. 

In Station Administration, the Display Name is the first CPND assigned to that 
set. The Display Names associated with the various keys on the set are added to 
the list of extensions of the Directory Entity.

Rebuilding the Directory

The OTM Directory can be rebuilt from the data present in the Station 
Administration database. The File, Rebuild Directory option has been provided to 
overcome the situation where the Directory database has, for whatever reason, 
become corrupt. The process involves a “walk-through” of every Station record 
and may be time-consuming for large Station databases.

Call Party Name Display

CPND overview

Call Party Name Display (CPND) displays the name of the calling party of an 
incoming call to the called station user. The CPND data is associated with a DN, 
and not with any particular station. If CPND data is assigned to a DN, it may be 
associated with multiple stations.

Note: For OTM to have CPND functionality on a specific system, 
Package 95 (Call Party Name Display) must be enabled on the Meridian 1 
or Succession CSE 1000 system.
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The CPND Administration module is separate from the Station Administration 
module. CPND Administration lets you create, maintain, change, and report on 
single- and multi-line CPND information. CPND Administration data defines the 
setup for each customer’s CPND configuration and CPND Name data defines the 
display parameters for DNs used by a particular customer. Station configuration 
data and CPND data are separate within the Meridian 1 or Succession CSE 1000 
system and are treated as separate files within OTM. 

CPND data for a station is accessible through the Station Administration module. 
Check the check box to have the CPND Name linked to the Display Name in the 
OTM Directory. See Figure 247 on page 506. The CPND button in the DN list of 
the Station module allows you to maintain CPND information directly from the 
DN list. This is particularly convenient if several DNs are to be linked back to the 
name for this station.

CPND is provided as a separate module to allow you to directly enter CPND data 
for DNs, Dial Intercom Groups, or DNIS IDC. The display of OTM CPND 
records shows the synchronization status and can be used to selectively 
synchronize this data with the Meridian 1 or Succession CSE 1000 system.

Terminology

This section defines terms that will be useful in understanding CPND.

CPND name

Calling Party Name Display information that is used in LD 95, LD 10, and LD 11 
on the PBX. This is also the name information that is contained in OTM’s CPND 
application.

Display Name

A single display name is associated with an employee and can be synchronized 
with a corporate LDAP server. If an employee has more than one DN, and there 
are different display names associated with each of the DNs, then either none or 
only one of the names is shown as the Display Name attribute of the Employee 
Directory. The name that appears as the Display Name attribute is taken from the 
entry in the CPND application that has the Link To Directory check box checked. 
To view the display name in the Employee Directory, click the Additional Info 
tab, and select Display Name in the attributes list.
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Employee Directory

Employee Directory refers to the database of employee information.

Employee Editor

The user interface to the Employee Directory is referred to as the Employee 
Editor. Employee Directory and Employee Editor are used interchangeably to 
indicate the employee database information.

Employee name

The employee name is the created from the First Name and Last Name fields that 
appear in the Employee tab of the Employee Editor. This is the name of the owner 
of the telephone.

Employee

An employee is a user of assets on a PBX. An employee will have one employee 
name and either none or only one Display Name attribute. An employee may have 
a different CPND name for each DN. However, for every DN that has the Link To 
Directory check box checked, the CPND name matches the Display Name 
attribute.

LDAP

Lightweight Directory Access Protocol (LDAP) is a protocol that is used to 
synchronize data between a master server database and client databases. The 
information is entered once, in the master server database, and then synchronized 
to populate the client databases. OTM operates as an LDAP client in that it can be 
configured to map certain data fields to a corporate LDAP server and then 
synchronized to have data automatically pushed or pulled between the server and 
client databases.
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Link To Directory

In the CPND application, if the Link To Directory check box is checked, OTM 
will pull the Display Name attribute from the Employee Editor and use this name 
as the CPND name for the DN. If the Link To Directory check box is unchecked, 
OTM allows the CPND name for the DN to be different from the Display Name 
attribute for the employee that owns the DN.

OTM Functionality

When you add a new telephone with a CPND name by using the overlays and then 
synchronizing with OTM, the telephone is added to Station Administration. The 
name is added to the CPND application and may also be added to the Employee 
Editor in both the Employee Name and Display Name fields. Addition to the 
Employee Editor is dependent on conditions that are described in this section.

When the Link To Directory check box is checked, the CPND name that appears 
in the CPND application is the same as the Display Name attribute in the 
Additional Info tab of the Employee Editor. The CPND name is the name that will 
appear on telephone displays for calls made from the associated DN.

Subsequent changes or modifications to the CPND name associated with a DN on 
an existing telephone are governed by the conditions that are described in this 
section. If a CPND name change to an existing telephone is initiated through the 
overlays, when OTM synchronizes with the PBX the change is populated in the 
CPND application only. When changing the CPND name on the PBX through the 
overlays, the Link To Directory check box in the CPND application will become 
unchecked since the CPND name no longer matches the Display Name attribute in 
the Additional Info tab of the Employee Editor.

In the CPND Name dialog box (Figure 247 on page 506), when you uncheck the 
Link To Directory check box, the First Name and Last Name fields become 
editable. After changing the data in these fields and exiting the dialog box, OTM 
modifies the Display Name attribute in the Additional Info tab of the Employee 
Editor if and only if the employee’s display name does not appear as the CPND 
name on another DN through the use of the Link To Directory check box for that 
DN. In the situation where there is only one CPND name/DN combination (in 
other words, there is no other CPND name with Link To Directory checked which 
would lock the Display Name attribute for the employee), once you make the 
modification in the CPND Name dialog box and click OK, OTM checks the check 
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box within the CPND application so that the next time the dialog box is opened 
the Link To Directory check box will be checked. At this point, the CPND name 
in the CPND Name dialog box and the Display Name attribute in the Additional 
Info tab of the Employee Editor match. This activity has no impact on the First 
Name and Last Name fields in the Employee tab of the Employee Editor. They 
will remain as originally entered.

OTM offers a simple method of making modifications to data on existing 
telephones, for example, class of service, features, and keys. If you are using OTM 
to perform these types of activities, Nortel Networks recommends that you not use 
the overlays to perform these same activities. The reason for this recommendation 
is that you would need to perform a synchronization with OTM before the changes 
entered through the overlays would be reflected in OTM. The overlays can be 
used to modify certain telephone features without modifying names; however, 
modifying names in the overlays or performing moves, adds, or changes using the 
overlays will cause the Link To Directory check box to become unchecked. This is 
manageable only if there is a process in place to record the changes and manually 
update OTM later, or if you do not want the CPND name to be reflected in the 
Display Name attribute or the employee name. In this situation, the CPND name 
(the name appearing on telephone displays) will be different from the employee 
name in Station Administration and in the Employee tab of the Employee Editor.

Summary

The name captured in LD 10, LD 11, or LD 95 on the PBX is the CPND name on 
the telephone. A Display Name attribute is associated with an Employee Editor 
record; however, it is not necessarily the same as First Name and Last Name in the 
Employee Editor, and it could also be different from the CPND name for a given 
DN. The CPND name appears in the CPND application and as the Display Name 
attribute in the Employee Editor if there is only one DN and the Link To Directory 
check box is checked. The employee name appears in Station Administration 
indicating the owner of the DN and in the First Name and Last Name fields in the 
Employee Editor as the proper name for the employee. The First Name and Last 
Name can be synchronized with a corporate LDAP server. The master repository 
for the employee name will usually be the corporate LDAP server; however, the 
information for the Display Name attribute for an employee may come from either 
the corporate LDAP server or from OTM. 
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Telephone changes, other than a change to name information, may be made 
through the overlays and then synchronized to pull the information into OTM. If 
you choose to make changes to the CPND name using the overlays, you should 
understand the effect this will have on the information contained in the Employee 
Editor and in the Station Administration and CPND applications. In this situation, 
you will need to develop and follow an appropriate process to resynchronize the 
data in OTM as necessary.

How names are populated in OTM

Names are populated in OTM using one of the following three methods:

• By retrieving telephone information from the PBX for telephones that are not 
defined in OTM

• By adding new CPND names using the CPND application

• By retrieving CPND names from the PBX using the CPND application

Retrieving telephone information from the PBX

Retrieval of the telephone information takes place in two phases. First, a 
command is issued to write the TNB data block information to a file, and then the 
file is parsed to update the OTM database.

While parsing the telephone information, OTM will search from Key 0 onwards to 
locate the first multiple appearance DN with MARP set to yes. This is the MARP 
DN. The CPND name associated with this DN is used to search the Employee 
Editor database for the first employee with a matching Display Name attribute, 
and the telephone is assigned to this employee. If no match is found, OTM next 
searches for a matching First Name and Last Name, and the telephone is assigned 
to this employee. If there is still no match found, OTM will create a new employee 
record and assign the telephone to this employee. When the new employee is 
created, the CPND name information is also entered into the Display Name 
attribute and in the First Name and Last Name fields in the Employee Editor.

If the telephone does not have any MARP DNs, the CPND name information for 
the Primary DN (Key 0) will be used to determine the owner of the telephone.
Using Optivity Telephony Manager Release 2.0x



496 Station Administration
If the telephone does not have and MARP DNs or a Primary DN, the telephone 
will not be assigned to any employee.

Adding new CPND names

You can directly add the CPND name for a DN using the CPND application. If the 
DN is associated with an employee in the Employee Editor, and there is no 
Display Name attribute for the employee, you can type the name into the First 
Name and Last Name Fields in the CPND Name dialog box and check the Link To 
Directory check box. This will automatically populate the Display Name attribute 
in the Employee Editor with the CPND name once you click OK in the CPND 
Name dialog box.

Retrieving CPND names from the PBX

You can retrieve CPND names from the PBX using the CPND application. From 
the System Window for the desired system, double-click CPND (which is located 
under Stations in the navigation tree) to launch CPND Administration. From the 
CPND Administration window select Synchronize > Retrieve. You can retrieve all 
records or specify the records you want to retrieve. If the DN is associated with an 
employee in the Employee Editor, the Link To Directory check box will be 
available in the CPND Name dialog box. This will allow you to determine 
whether or not the CPND name is propagated to the employee’s Display Name 
attribute.

Modifying names in OTM

The following five activities will modify the various names associated with a 
telephone in OTM:

• Changing the owner of a telephone

• Changing the owner’s name

• Changing the owner’s Display Name attribute

Note: For ACD telephones, OTM does not use the CPND name 
associated with the ACD DN to form employee names in the Employee 
Editor. OTM will ignore the ACD DN and use the next MARP DN on the 
telephone.
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• Retrieving modified CPND names from the PBX

• Changing CPND names using the CPND application

Changing the owner of a telephone

If you change the owner of a telephone by selecting a different employee in the 
Employee Editor, OTM will analyze all the CPND names associated with the 
multiple appearance DNs (MARP DNs) on the telephone. If the CPND names 
have the Link To Directory check box checked, the CPND names will be updated 
with the name in the new owner’s Display Name attribute.

Changing the owner’s name

When you change an employee name using the Employee Editor, OTM 
automatically updates the Display Name attribute for the employee and the CPND 
names for all associated DNs that have the Link To Directory check box checked. 
This is also true when the employee name is changed as part of an LDAP 
synchronization. The reverse is not true, in other words, making a change to the 
Display Name attribute will not change the employee name.

Changing the owner’s Display Name attribute

When you change the Display Name attribute for an employee, OTM 
automatically updates the CPND names for all associated DNs that have the 
Linked To Directory check box checked. This is also true when the Display Name 
attribute is change as part of an LDAP synchronization. The employee name in the 
Employee Editor does not change.

Retrieving modified CPND names from the PBX 

If you change the CPND name on the PBX using the overlays, and the 
modifications are retrieved by OTM, the CPND name in OTM will be updated 
with the new name. This will not change the employee name in the Employee 
Editor. OTM will uncheck the Link To Directory check box while changing the 
CPND name in the CPND application. Additionally, since the Link To Directory 
check box is unchecked, the Display Name attribute associated with the employee 
will not be updated.
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Changing CPND names using the CPND application

You can change the CPND names independently using the CPND application. If 
the Link To Directory check box is checked, OTM will not allow you to change 
the CPND name, and the First Name and Last Name fields are read-only. When 
the Link To Directory check box is checked, these fields are populated by the 
information in the Display Name attribute in the Employee Editor, and you must 
uncheck the box to proceed.

If you uncheck the Link To Directory check box, change the CPND name, and 
click OK, OTM will backfill the Display Name attribute in the Employee Editor if 
and only if there is no other DN associated with this employee that has the Link 
To Directory check box checked. This activity will not change the employee name 
in the Employee Editor.

You can also access the CPND Name dialog box from within the Station 
Administration application by clicking the CPND button in the Directory 
Numbers dialog box. See Figure 232 on page 464.

Impact on names when deleting telephones

When you delete all of the telephones belonging to an employee, OTM will 
automatically delete the Display Name attribute for the employee. This is done 
because the Display Name attribute is displayed as the CPND name for each of 
these telephones when the Link To Directory check box is checked. An OTM 
retrieval from the PBX will use the CPND name from the PBX as a reference to 
search for a matching employee by comparing the CPND name with Display 

Note: It is possible to have more than two different names associated 
with the owner of a telephone in OTM if the Link To Directory is 
unchecked. This occurs because, with the Link To Directory check box 
unchecked, the CPND name does not necessarily match the Display 
Name attribute. With multiple DNs on the telephone, each DN that does 
not have the Link To Directory check box checked could have a unique 
CPND name. If the Link To Directory check box is checked in the CPND 
Name dialog box for all DNs on the telephone, then only two different 
names can exist in OTM; the employee name, and the Display Name 
attribute which is also propagated to the CPND name for all associated 
DNs.
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Name attribute of the employees listed in the Employee Editor. By deleting all of 
the telephones belonging to an employee, and thereby deleting the Display Name 
attribute associated with the telephones, any subsequent retrievals from the PBX 
will handle the retrieved telephone information in the following manner:

• If a telephone that was just deleted in OTM is retrieved from the PBX, and 
there is no other employee with a Display Name attribute that matches the 
CPND name on the telephone, and the CPND name on the telephone matches 
an employee name in the Employee Editor, and this employee name is unique 
(there is only one occurrence of this employee name in the Employee Editor), 
the telephone will be associated with the same employee.

• If a telephone that was just deleted in OTM is retrieved from the PBX, and 
there is no other employee with a Display Name attribute that matches the 
CPND name on the telephone, and the CPND name on the telephone does not 
match any employee name in the Employee Editor, a new employee entry will 
be entered in the Employee Editor and the telephone will be associated with 
the new employee. In this instance, the CPND name from the retrieved 
telephone will also be entered as the employee name and the Display Name 
attribute in the Employee Editor.

• If a new telephone has been set up on the PBX with a CPND name, during the 
retrieval the CPND name will first be compared to the Display Name 
attributes in the Employee Editor. If there is no match found, the CPND name 
will be compared to the employee names in the Employee Editor until the first 
match is found. When a match is found, the telephone will be associated with 
the matching employee. If no match is found, a new employee entry will be 
entered in the Employee Editor and the telephone will be associated with the 
new employee. In this instance, the CPND name from the retrieved telephone 
will also be entered as the employee name and the Display Name attribute in 
the Employee Editor

• If a new telephone has been set up on the PBX without a CPND name, then no 
new employee entries are created in the Employee Editor, and the telephone is 
only established within the Station Administration application.

CPND data considerations

You should be aware of the following considerations when using the CPND 
Administration function of Station Administration.
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CPND Names versus Station Names

The name defined for CPND need not necessarily be the same as that defined for a 
station end user on the face of the station graphic. The Station Configuration 
Name is only maintained in OTM and is not stored in the Meridian 1 or 
Succession CSE 1000 system. The name stored by OTM is the CPND associated 
with a particular DN.

In most cases, the name on the station graphic is also the name associated with a 
DN of the station. OTM can automatically link the name on the graphic with one 
or more of the DNs on the station. To link the name on the graphic with a DN, 
check the Link To Directory check box in the CPND Name dialog box.

The Station Retrieve module automatically parses and updates the Meridian 1 or 
Succession CSE 1000 system’s CPND Name information. Changes to the name 
on the station do not affect the station’s Sync Status but do update any CPND 
name entry to RPL. 

If the name data is linked in this manner, the first and last names in the CPND 
Name dialog box are filled in and grayed. The data can only be changed from the 
station graphic. To remove the linkage, uncheck the Link To Directory check box 
in the CPND Name dialog box.

The CPND Name information is accessed in either the Station module (from a 
CPND function button in the DN list dialog box) or the CPND module. All CPND 
data is synchronized with the Meridian 1 or Succession CSE 1000 system using 
LD 95.

CPND synchronization

CPND and Station synchronization are separate functions. They are only 
connected if CPND data is defined from the Station DN list, or if the CPND name 
is taken from the Name field of the Station Administration module.

If OTM is in Maintenance mode, the system automatically attempts to 
synchronize the new CPND information when the station is transmitted. In 
installation mode, you must synchronize CPND data separately from within the 
CPND module.
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CPND module

The OTM CPND Administration module allows access to the CPND data for a 
single Meridian 1 or Succession CSE 1000 system. When you open the CPND 
module, a list of name data contained within OTM appears. If the data has not yet 
been retrieved from the Meridian 1 or Succession CSE 1000 system, or added to 
the OTM database, the window contains no data. 

Figure 245 shows the OTM CPND Administration window as it first appears.

Figure 245   CPND Administration window

Accessing CPND data

The OTM CPND Administration window allows you to configure CPND blocks. 
After CPND blocks are configured, you can configure Name data for DNs. 

From the View menu, the following list views for CPND data are available: 

• Customer Configuration list (CPND Administration)

• Name display list (CPND Name)
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The Customer Configuration list contains only a few items (just one in many 
cases). This view lists the CPND blocks configured on this system. The Name 
display list may have many items, probably more than will fit in the current 
window. This is the scrollable list of names whose display parameters are defined 
for CPND.

CPND Administration view

With View > CPND selected, the CPND Administration window displays the list 
of CPND blocks configured for the system. The following information is 
displayed for each customer: 

• Customer: The customer number as defined in the system configuration

• Sync Status: The synchronization status of the station’s data between the 
Meridian 1 or Succession CSE 1000 system and OTM

The data in the window is part of the CPND Administration data stored in OTM. 
The complete configuration data for this system is available as described in the 
CPND Data Change section of this document.

CPND Name view

With View > CPND Name selected, the CPND Administration window shows a 
list of names defined in the system. The following headings define the data for 
each station displayed:

• Customer: The customer number that uses this DN

• Sync Status: The synchronization status of the station’s data between the 
Meridian 1 or Succession CSE 1000 system and OTM

• Number: The DN using the CPND data

• Name: The defined CPND name

• Location: The optional unique station Location Code from the Station Data 
dialog box (see Figure 242 on page 483)
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Sync Status: An indication of whether Meridian 1 or Succession CSE 1000 
system data and the data in OTM are synchronized. The following list defines the 
status for CPND data:

• NEW: CPND data defined in OTM that has never been uploaded to the 
Meridian 1 or Succession CSE 1000 system.

• TRN: The CPND data is synchronized with Meridian 1 or Succession 
CSE 1000 system.

• CHG: Data has been changed in OTM but the change has not been sent to the 
Meridian 1 or Succession CSE 1000 system.

• RPL: Data defined in OTM to replace synchronized name data.

• OUT: Synchronized CPND data deleted from OTM but not yet removed from 
the Meridian 1 or Succession CSE 1000 system.

• CUR: The CPND data is synchronized with the Meridian 1 or Succession 
CSE 1000 system.

• SWP: Data defined in OTM to replace synchronized name data.

The data in the window is part of the name display data stored in OTM. The 
complete name data is available as described in CPND Data Change. 

CPND records can be sorted and displayed in a number of ways. In the CPND 
Administration window, select View > Sort. Records can be sorted by the 
following:

• Directory Name

• Last Name

• First Name

• Sync Status

Note: When upgrading from a previous release of OTM, any CPND 
name that is linked to a directory entry will not sort by first name and last 
name since names linked to stations in this way are not stored in the 
CPND data base. Perform a station retrieval to resolve this discrepancy.
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Recommended usage

You cannot build CPND Name data until the CPND data block is defined. First 
you must configure, or retrieve from the Meridian 1 or Succession CSE 1000 
system, the CPND data block for the selected customer.

When the customer’s CPND data block is defined, you can create, or retrieve from 
the Meridian 1 or Succession CSE 1000 system, the CPND Name display 
information. 

CPND data change

You can change the data associated with the selected CPND view. The selected 
item in the list view is highlighted. Select an item using a mouse click, or use the 
up/down arrow keys to highlight the desired item. You can also double-click the 
desired item.

Choose Edit > Delete to remove the selected CPND list item. Choose Edit > 
Update or Edit > Add to display a dialog box that allows you to update the data 
fields for the selected view.

Updating the Customer Configuration data

With View > CPND selected, you can change the selected customer’s CPND data. 
The selected CPND block is highlighted in the customer list window.

Choose Edit > Update to display the Call Party Name Display dialog box 
(Figure 246).
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Figure 246   Call Party Name Display dialog box

Updating the Name display data

Choose Edit - Update in the CPND Name view window (or double-click the item 
in the list) to display the CPND Name dialog box for the selected station name 
(Figure 247).
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Figure 247   CPND Name dialog box

The Link To Directory check box indicates that the CPND for this name is the 
Display Name of the Directory Entity that owns the set to which this DN is 
assigned. To modify this CPND, you must uncheck the Link To Directory box.

When the Display Name associated with a CPND is removed from a set, the link 
to Directory is broken and the above box is unchecked.

List Manager

This section contains information about how to use List Manager. The List 
Manager module allows you to work with the following list types: 

• Speed Call and System Speed Call—Allows a user to place a call to a 
telephone number by dialing a short code. These codes are managed as entries 
in a Speed Call list. 

• Group Call—Allows a user to place a call to a list of DNs at the same time by 
pressing the Group Call key. 
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• Group Hunt—Allows the system to route an unanswered call to the next idle 
DN in a prearranged hunt chain (or list), based on the Group Hunting Pilot 
DN linked with the station’s Prime DN.

Summary of List Manager

List Manager allows you to perform the following functions: 

• Create and modify lists.

• Create multiple lists with one operation.

• Copy and paste lists from one system to another.

• Work with list templates.

• Set default properties for all lists of a given type.

• Assign a station to a list (In the Stations module you can assign a list to a 
station).

• Assign a Pilot DN to a list.

• Print reports on list usage.

Open List Manager

Figure 248 shows where to access List Manager from within the System Window. 

Note: The Group Hunt feature is not applicable to the North American 
market.
Using Optivity Telephony Manager Release 2.0x



508 Station Administration
Figure 248   OTM System Window

To open List Manager for a system: 

1 From the OTM Navigator, open the system window for the selected system. 

2 In the System window tree control, open Stations. 

3 Double-click the List Manager icon. 

The List Manager window opens. 

Download list data from the Meridian 1 or Succession 
CSE 1000 system

If list data is present on the system, download the list data to OTM the first time 
you open List Manager. You can synchronize each list type separately or 
synchronize all list types at once. 

To download list data from the Meridian 1 or Succession CSE 1000 system: 

1 Select a list type in the List Type view, or select the item called 
“List Manager” to download data for all list types. 
553-3001-330 Standard 3.00 November 2002



Station Administration 509
2 Choose Synchronize > Retrieve > Now.

The List Manager Sync window opens (Figure 249).

Figure 249   List Manager Sync window

Note: Your request is sent to the scheduler queue, which executes the 
task within the next minute. If there are tasks in the queue that have a 
higher priority and are scheduled to be executed at the same time, they are 
executed first.
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List Manager automatically logs in to an idle TTY port and downloads list 
data to the OTM PC. 

3 Wait until the Synchronization Status section displays the following message: 

Logged out from the switch

4 Click Close. 

Synchronization considerations

You can transmit data to program a Meridian 1 or Succession CSE 1000 system 
with relevant list data defined in OTM’s List Manager application. List Manager 
can also retrieve list data from a Meridian 1 or Succession CSE 1000 system, 
where it can be viewed and modified. 

If you have a Meridian 1 or Succession CSE 1000 system with list data already 
programmed, you should first download the data to OTM. See “Download list data 
from the Meridian 1 or Succession CSE 1000 system” on page 508. Then you can 
modify the data and upload the changes to the Meridian 1 or Succession 
CSE 1000 system. 

Use the Synchronize menu to schedule communications with the system. 
Synchronization is a task that ensures the list data in OTM matches the data on the 
Meridian 1 or Succession CSE 1000 system. Synchronization can be achieved in 
one of two ways, as follows: 

• Retrieve data from the Meridian 1 or Succession CSE 1000 system to OTM 
(download).

• Transmit data from OTM to the Meridian 1 or Succession CSE 1000 system 
(upload).

Note: Generally, you should transmit list data before transmitting station 
data. This ensures that the list is present on the system before Station 
Administration assigns feature key access to the list. 
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Synchronization status

When OTM performs a data retrieval, the synchronization status of each list 
determines whether the data is updated. The following status indicators define 
how the list is affected during a synchronization: 

• NEW: Data has been defined, but not uploaded to the Meridian 1 or Succession 
CSE 1000 system.

• TRN (transmit): Data is synchronized with the Meridian 1 or Succession 
CSE 1000 system.

• OUT: Data is removed from OTM and will be deleted from the Meridian 1 or 
Succession CSE 1000 system during the next synchronization.

• CHG (change): Data has been changed, but the changes have not been 
uploaded to the Meridian 1 or Succession CSE 1000 system.

• RPL (replace): Data in the Meridian 1 or Succession CSE 1000 system is 
replaced with new data during the next synchronization. 

List Manager automatically sets the synchronization status of each list. For 
example, if you modify parameters of an existing list, the synchronization status is 
set to CHG (change). 

Change synchronization status

You can change the synchronization status of each list in List Manager. For 
example, if you change parameters for a list, but do not want the changes to take 
affect on the system right away, you can change the synchronization status of the 
list to TRN. 

To change the synchronization status of a list in List Manager: 

1 Select a list. 

2 Choose Edit > Change Status to and choose a new status from the available 
choices. 

Station synchronization versus List synchronization

List Manager synchronization is a separate task from Station Administration 
synchronization. After you synchronize list data, you should synchronize station 
data. 
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Transmit list data to the switch before transmitting station data. Some List 
Manager settings make changes in OTM’s Station Administration module (for 
example, feature key assignment). You must ensure the list data is present on the 
system so that station validation does not fail. 

Synchronize List Manager with the system

You must periodically synchronize List Manager data with data on the Meridian 1 
or Succession CSE 1000 system. 

Upload

To upload data from OTM List Manager to the Meridian 1 or Succession 
CSE 1000 system: 

1 In the List Type view, select the list type that you want to synchronize or 
select “List Manager” to synchronize all list types. 

2 Choose Synchronize > Transmit > Now. The List Manager Sync window 
opens (Figure 249).

3 When the Synchronization status area displays “Logged out from the switch,” 
click Close. 

The selected list type is synchronized with the Meridian 1 or Succession 
CSE 1000 system. 

Download

To download data from the Meridian 1 or Succession CSE 1000 system to OTM 
List Manager: 

1 Select the list type that you want to synchronize or select “List Manager” to 
synchronize all list types. 

Note: Your request is sent to the scheduler queue, which executes the 
task within the next minute. If there are tasks in the queue that have a 
higher priority and are scheduled to be executed at the same time, they are 
executed first.
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2 Choose Synchronize > Retrieve > Now. The List Manager Sync window 
opens (Figure 249).

3 When the Synchronization Status area displays “Logged out from the switch,” 
click Close. 

The selected list type is synchronized with the Meridian 1 or Succession 
CSE 1000 system. 

List Manager window

The List Manager window is divided into two sections: 

• List Type view—Allows you to select a list type. Lists of the selected type 
appear in the List Detail view. You can also select List Manager to perform 
global operations. 

• List Details view—Allows you to select one or more lists of a specific type. 
You can select a list and edit its properties, or copy the list data. 

Figure 250 shows the List Manager window. 

Note: Your request is sent to the scheduler queue, which executes the 
task within the next minute. If there are tasks in the queue that have a 
higher priority and are scheduled to be executed at the same time, they are 
executed first.

Note: If you choose menu View - Templates, the List Details view shows 
list templates.
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Figure 250   List Manager window

Figure 250 calls out the following List Manager components: 

• Title bar—Identifies the system and contains standard Windows controls to 
minimize, maximize, and close the window 

• Menu bar—Provides easy access to List Manager commands

• Toolbar—Provides easy access to List Manager commands

• List Type view—Allows you to select which type of list to access

• List Details view—Displays all lists of the selected type, including the list 
number, synchronization status, list type, and list name

List Details view

Choose View > Lists to display the lists defined for the system. Each list contains 
the following information: 

List Number: Unique number used to identify the list on the system.

Title bar Menu bar Toolbar

List Type view List Details view
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Type: Type of list, based on the Meridian 1 or Succession CSE 1000 feature it 
supports (Speed Call, System Speed Call, Group Call, Group Hunt). 

Sync Status: An indication of whether the Meridian 1 or Succession CSE 1000 
system’s data and the data in OTM are synchronized. The following information 
defines the synchronization status for each list:

• NEW: List data defined in OTM, but not uploaded to the Meridian 1 or 
Succession CSE 1000 system

• TRN: List data is synchronized with the Meridian 1 or Succession CSE 1000 
system

• CHG: List data has been modified in OTM but not in Meridian 1 or Succession 
CSE 1000 system

• RPL: List data defined in OTM to replace synchronized station data

• OUT: A synchronized list deleted from OTM but not yet from the Meridian 1 
or Succession CSE 1000 system

Name: A name entered in List Manager, used to identify this list. 

The Template view

Choose menu View - Templates to display list templates defined for the system. 
The display contains the same information for a template as the List view contains 
for a list. 

Templates provide data that is common among many individual lists. In a single 
operation, using a template, you can define multiple lists which have data in 
common. A template can contain all or part of a list definition. You can change 
template data in exactly the same way as station data.

List Manager menus

List Manager’s menus consist of the following: 

• File

— Open: Display the property sheet of the selected list or template. 

— New: 

— List: Create a new list. Displays the New List property sheet. 
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— Multiple Lists: Create more than one new list. Displays the Multiple 
List Creation dialog box.

— Template: Create a new template. Displays the New Template 
property sheet.

— Print Setup...: Select a printer and a printer connection.

— Reports: Select a Report.

— Properties: Display the property sheet of the selected list or template. 

— Close: Close the List Manager window.

• Edit

— Undo: Reverse the most recent command.

— Cut: Remove the selected list(s) or text and place it on the clipboard.

— Copy: Place a copy of the selected list(s) on the clipboard.

— Paste: Insert a copied list into the List Details view.

— Delete: Remove the selected list(s) from the List Manager window.

— Select All: Selects all lists in the List Manager Display View. 

— Change Status to: 

— NEW: Change the synchronization status of the selected list to NEW. 
Data has been defined, but not uploaded to the Meridian 1 or 
Succession CSE 1000 system.

— TRN: Change the synchronization status of the selected list to TRN 
(transmitted). Data is synchronized with the Meridian 1 or Succession 
CSE 1000 system.

— OUT: Change the synchronization status of the selected list to OUT. 
Data is removed from OTM and will be deleted from the Meridian 1 
or Succession CSE 1000 system during the next synchronization.

— CHG: Change the synchronization status of the selected list to CHG 
(change). Data has been changed, but the changes have not been 
uploaded to the Meridian 1 or Succession CSE 1000 system.

— RPL: Change the synchronization status of the selected list to RPL 
(replace). Data in the Meridian 1 or Succession CSE 1000 system is 
replaced with new data during the next synchronization.

• View

— Toolbar: Displays or hides the Toolbar.

— Status Bar: Displays or hides the Status Bar.

— Lists: Change the display view to show lists.
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— Templates: Change the display view to show templates.

• Synchronize
— Transmit: 

— Now: Transmit data from OTM to the Meridian 1 or Succession 
CSE 1000 system.

— Schedule: Schedule a transmission of data from OTM to the 
Meridian 1 or Succession CSE 1000 system.

— View Last Transmit: Display a log file showing results of the last data 
transmission. 

— Retrieve: 

— Now: Retrieve data from the Meridian 1 or Succession CSE 1000 
system to OTM.

— Schedule: Schedule a retrieval of data from the Meridian 1 or 
Succession CSE 1000 system to OTM. 

— View Last Retrieve: Display a log file showing results of the last data 
retrieval. 

• Tools

— Delete Unused Lists: Display the Delete Unused Lists dialog box. 

— Options: Displays the Options dialog box.

• Help

— Help Topics: Display the list of Help topics. 

— What’s This: Provides context-sensitive Help on the next item you select. 
Clicking anywhere else takes you to the first topic in the Help topic list. 

— About List Manager: Display release information for the List Manager 
window. 

Toolbar

The List Manager toolbar includes several useful buttons. The function of each 
button in the toolbar appears when you hold the mouse cursor over the button. 
Toolbar buttons provide shortcuts to some of the same commands found in the 
menus.
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Work with List Manager

This section provides procedures to help you use List Manager to perform 
common tasks. 

Create a new list

You can create a new list in List Manager and upload the data to the Meridian 1 or 
Succession CSE 1000 system. The synchronization status of the new list is NEW. 
You must transmit the list data to the Meridian 1 or Succession CSE 1000 system 
for the new list to become active. 

To create a list: 

1 In the List Type view, select the type of list you want to create. 

2 Select File > New > List.

The New List (General) property sheet opens (Figure 251). 

3 Select either a template or an existing list to use as a basis from which to 
create the new list. 

4 Enter a list name (up to 50 characters, alphanumeric). 

5 Select the list type. 

6 Click OK or Apply. 

Note: The New List property sheet for each list type is the same as the 
standard property sheet for that list type. Some default values for the new 
list are automatically entered. 

Note: You can edit some of the default values for a new list. To edit the 
list number, the option for Auto List Number Allocation (Tools - Options) 
must be unchecked. 
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Figure 251   Speed Call list properties (General)

7 Click Apply if you want to modify list parameters. Click the tabs along the top 
of the property sheet to view various parameters. 

Create a list template

You can create a list template or modify an existing template. Templates provide 
data that is common among many individual lists. A template allows you to define 
multiple lists that share common elements. 

To create a list template: 

1 Choose View > Templates. 

2 Choose File > New > Template.

The New Template dialog box opens with the General tab displayed 
(Figure 252).
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3 Select either a template or a list to use as a basis from which to create the new 
template. 

4 Enter a template name (up to 50 characters, alphanumeric).

5 Select the list type to which this template applies. 

6 Click OK or Apply. 

Figure 252   New Template dialog box

Create multiple lists

You can create multiple lists with a single operation. You must have a valid 
template that corresponds to the list type that you want to create. After creating 
the lists, you should modify each list to provide its unique parameters. 

Figure 253 shows the Multiple List Creation dialog box. 

Note: The List Number field does not apply when creating a template.
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Figure 253   Multiple List Creation dialog box

To create multiple lists: 

1 Choose menu View - Lists. 

2 Choose menu File - New - Multiple Lists. The Multiple List Creation dialog 
box appears (Figure 253). 

3 Select a template or click New to create a template on which to base the new 
lists. The template provides common data shared among the lists. 

4 Set the number of lists to create. 

5 Select the list numbers of the lists to create. Select a range of numbers in the 
Available Lists field and click the right arrow. 
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List Manager places the correct number of lists into the Selected Lists field. 

6 If there are not enough list numbers available in the selected range, select 
another range and click the right arrow. Continue until you reach the correct 
number of lists to create. 

7 Click OK. 

Delete lists

You can select a list or a template and delete it from the system. You can delete all 
unused lists from the system with one command. The next time you synchronize 
List Manager lists, the deleted lists are removed from the system. 

To delete a list from the system:

1 Choose View > Lists. 

2 In the List Type view, select the list type. In the List Details view, select the 
list. 

3 Choose Edit > Delete. A confirmation box appears, stating, 

“Are you sure you want to delete the list(s)/template(s)”. 

Note: In the Available List field and the Selected List field, list numbers 
are represented as ranges. For example, a range of list numbers from 11 to 
20 is represented as follows: 

11...20

If you want to create 25 lists and you select the above range, you must still 
select 15 more list numbers. Select another range to continue adding list 
numbers to the Selected Lists field. List Manager automatically stops 
adding list numbers when you reach the correct number, as set in the 
Number of Lists field.

Note: You can select a subset of a list range. After moving a range from 
one side to the other, use the right mouse button to double-click on the 
selected range. You can edit the range to select a subset of the range. For 
example, if the selected range is 2...10, you can enter 2...9 or 3...8 (but not 
1...11).
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4 Click Yes. 

To delete a template from List Manager: 

1 Choose View > Templates. 

2 In the List Type view, select the list type. In the List Details view, select the 
template. 

3 Choose Edit > Delete.

A confirmation box appears, stating, “Are you sure you want to delete the 
list(s)/template(s)”. 

4 Click Yes. 

To delete all unused lists of a specific type from the system:

1 In the List Type view, select the list type. 

2 Choose Tools > Delete Unused Lists.

The Delete Unused Lists dialog box appears. All unused Speed Call lists 
appear. 

3 Select the lists you want to delete. 

4 Click OK. 

The synchronization status of the deleted lists is changed to OUT. 

Manage list data

OTM displays list data in a property sheet that graphically represents the list data. 
You can manage individual list entries. Data change is described for a typical list. 
Most lists contain a subset of the data for this example, and the update procedure 
for each field and function is the same as that described here.

Whenever you modify list data that has already been synchronized with the 
switch, the Sync Status for that list is set to CHG. This is an indication that OTM 
and Meridian 1 or Succession CSE 1000 system are not in sync. 
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View and modify list (or template) details

Each list has various properties that define the list. Some properties are shared 
among all lists of a given type; some properties are unique to a specific list. List 
Manager property sheets allow you to view and modify all of the various list 
properties.

To view list details and modify list details: 

1 Choose View > Lists. 

2 In the List Type view, select a list type. 

3 In the List Details view, double-click a specific list.

The property sheet for the selected list appears. 

4 Make changes as desired. Click the various tabs to view and modify different 
list parameters. 

5 Modify data in the appropriate fields. If you make changes, click Apply 
before you move from one tab to the next. 

6 When you have completed the changes, click OK. 

Set advanced properties

You can change advanced properties for a specific list. Most of the advanced 
properties have default values that are set in the Options dialog box (see “Set 
global list options” on page 534). 

To set advanced properties for a list (Speed Call and Group Hunt): 

1 Select a list and choose File > Properties. The Properties dialog box for the 
selected list appears with the General tab selected (Figure 251 on page 519). 

Note: You can choose menu View - Templates to work with List 
Manager templates. 
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2 Click Advanced Properties. The Advanced Properties dialog box appears 
(Table 28).  

1 Make your desired changes. 

2 Click OK.

Modify list entries

You can view and modify list entries within each list. 

To modify list entries: 

1 Choose View > Lists. 

2 In the List Type view, select a list type. 

3 In the List Details view, double-click a specific list.

The property sheet for the selected list appears. 

4 Click the List Entries tab.

The List Entries tab lets you modify parameters for each list entry number 
(Figure 254). 

Table 28   Advanced properties for Speed Call lists and Group Hunt lists

Field Description

Network Class of 
Service

Select a Network Class of Service, as defined on the Meridian 1 or 
Succession CSE 1000 (applies to System Speed Call lists). 

Max. DN Size Select the maximum length of DNs in the list. The default value is set 
in the Options dialog box (Tools - Options). 

Max. List Size Select the maximum number of entries allowed in the list. The default 
value is set in the Options dialog box (Tools - Options). 

Memory Usage - in Words

Free Memory 
Available

Indicates how much Meridian 1 or Succession CSE 1000 system 
memory is available for all lists, as of the last synchronization. 

Used by List Meridian 1 or Succession CSE 1000 system memory required for this 
list. 
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Figure 254   Speed Call List properties (List Entries)

5 Use the List Entries buttons to modify list entries (Table 29).  

Table 29   List Entries buttons

Button Description

Add Add a new entry to the list. 

Modify Modify the selected list entry. 

Clear Clear the selected list entry. 

Move Up

Move Down

Use these buttons to change the entry number of the selected entry. 

CAUTION: Be careful when you make changes to list entry numbers. 
This operation re-orders the entry numbers in a list. For example, if you 
move entry number 10 up to number 2, then entry number 2 becomes 
number 3, number 3 becomes number 4, and so on. 
For Speed Call lists, these changes affect the short key used to dial 
each list entry. 

For Group Hunt lists, these changes affect the order of the hunt chain. 
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6 Click OK or Apply. 

Work with stations

Use the List properties dialog box—Associated Stations tab to assign a feature 
and its associated list to one or more stations (telephones). 

Figure 255 shows the Associated Stations tab for Speed Call Lists. 

Figure 255   Speed Call List properties dialog box—Associated Stations tab

Note: This operation modifies the entries in the Station Administration 
module. You must synchronize stations from Station Administration to 
change these settings on the Meridian 1 or Succession CSE 1000 system.
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Assign stations

To change feature key assignments for stations:

1 Select a list and choose File > Properties.

The List Properties (General) dialog box appears.

2 Choose the Associated Stations tab.

Any stations displayed have the feature assigned. 

3 Click Add.

The Add Stations dialog box appears. 

4 In the Select Stations list, select the station(s) and feature key(s) you want to 
assign the feature and its associated list. 

5 Click Add.

The selected stations are moved from the Select Stations list (bottom) to the 
Selected Stations list (top). 

6 Click OK. 

Note: List Manager sets the feature key assignment in OTM’s Station 
Administration module. Therefore, you must transmit the data from 
Station Administration for the feature key assignment to take effect.
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Figure 256   Add Stations dialog box

Modify feature key properties

To change the feature key properties for a station:

1 Select a list and choose File > Properties.

The List Properties (General) dialog box appears.

2 Choose the Associated Stations tab.

Any stations displayed have the feature assigned. 

3 Select a station and click Modify.

The Modify Station Details dialog box appears (Figure 257).
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Figure 257   Modify Station details dialog box (Speed Call)

4 For Speed Call, select either User or Controller to change the access type, if 
desired. 

5 Click OK. 

Remove station assignment

To remove the feature associated with this list from a station: 

1 Select a list and choose File > Properties. The List Properties (General) dialog 
box appears. 

2 Choose the Associated Stations tab. Any stations displayed have the feature 
assigned. 

3 Select a station or stations and click Remove. 

4 Click OK. 

Work with Pilot DNs

Pilot DNs provide access to Speed Call Lists. A Pilot DN can also activate Group 
Hunting. 

Note: List Manager sets the feature key assignment in OTM’s Station 
Administration module. Therefore, you must transmit the data from 
Station Administration for the feature key assignment to take effect. 
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Assign a Pilot DN

To assign a Pilot DN to a list: 

1 Select a Speed Call list and choose File > Properties.

The property sheet for the selected list appears. 

2 Click the Pilot DNs tab (Figure 258).

Figure 258   Speed Call list properties (Pilot DNs)
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3 Use the buttons to Add, Modify, or remove Pilot DNs associated with this list. 

4 Click OK or Apply. 

Associate Pilot DN to a Group Hunt list

To associate a Pilot DN with a Group Hunt list: 

1 Select a Group Hunt list and choose File > Properties. The property sheet for 
the selected list appears. 

2 On the property sheet General tab, enter the pilot DN into the Pilot DN field. 

3 Click OK or Apply. 

Copy and paste lists

You can use the copy and paste commands to duplicate a list. Then you can 
modify the new list to make it unique. You can also paste the list into the List 
Manager window for a different system. 

When you copy and paste a list, the synchronization status of the new list is set to 
NEW. The new list is added to the system during the next synchronization. 

Duplicate a list

To duplicate a list: 

1 Choose View > Lists. 

2 Select a list and choose menu Edit > Copy. 

Note: Pilot DNs must conform to the customer Numbering Plan. To 
check the customer Numbering Plan, do the following:

– In the Navigator, select the system and choose menu File - Properties.

– Click the Customers tab.

– Select the customer and click Properties. 

– Click the Numbering Plans tab. 
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The list data is saved to the PC clipboard. 

3 Choose Edit > Paste. 

a Click Change Properties and give the pasted list a new list number. 

b Make any other changes that are appropriate. 

c Click OK. 

Copy a list from one system to another

To copy a list and paste it to another system: 

1 Choose View > Lists. 

2 Select one or more lists and choose Edit > Copy. 

The list data is saved to the PC clipboard. 

3 Open another system’s List Manager application. 

4 Choose View > Lists. 

5 In the List Type view, select the appropriate list type. 

6 Choose Edit > Paste. 

a Click Change Properties and give the pasted list a new list number. 

b Make any other changes that are appropriate. 

c Click OK. 

Caution: A confirmation dialog box asks if you want to overwrite the 
current list with the copied list. Normally, you do not want to overwrite 
the current list.

Caution: If the list number of the list you copied is present on this 
system, a confirmation dialog box asks if you want to overwrite the 
current list with the copied list. Normally, you do not want to overwrite 
the current list. 
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Set global list options

Use the Options dialog box to set general parameters that apply to all lists of a 
specific type.

To display the Options dialog box:

The Options dialog box has separate tabs for Speed Call, Group Call, and Group 
Hunt lists. Some options apply only to lists of a specific type. 

List Manager options apply when you create new lists. For a specific list, you can 
override most of these options. Click Advanced Properties on the property sheet 
(General) tab.

Default options

Default options allow you to manage list allocation efficiently: 

• List size—Default number of entries created for a new list.

• Network Class of Service (System Speed Call)—Default Network Class of 
Service associated with entries in a new list.

• DN size—Default maximum length of Directory Numbers associated with 
entries in a new list.

• Originator Control over list (Group Call)—Determines if the originator of the 
Group Call can terminate the call.

• Max. length of queue (Group Hunt)—Default maximum number of calls that 
can be queued against the Pilot DN for new lists.

• Call Forward All Calls (Group Hunt)—Check to allow Group Hunt to 
terminate at a station that has Call Forward All Calls allowed. 

Memory optimization

The following options help you manage system memory on the Meridian 1 and 
Succession CSE 1000 systems. These options allow you to restrict the amount of 
system memory required to support the lists: 

Choose Tools > Options.
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— Maximum List Size—Maximum number of entries allowed in a new list.

— Memory Water Mark—Memory threshold. When the system memory 
used by lists is at or above the Memory Water Mark, the Auto Increase 
List Size check box is set to Off. 

— Auto Increase List Size—When checked, lists are allowed to grow as new 
entries are added (until the Memory Water Mark is reached). 

— Read Only Auto List Number—When checked, List Manager allows you 
to edit the automatically generated list numbers as you create new lists. 

Available list numbers

Options for Speed Call and Group Hunt lists include controls where you can set 
the available list ranges. These options let you restrict the total number of lists 
allowed for the system. Enter the starting list number and ending list number in 
the range. 

Work with reports

List Manager lets you view, manage, and generate reports using list data from 
systems configured in OTM. You can view each report on screen, print the report, 
or save the report to a file. Report layout and formatting is done through Microsoft 
Excel. 

You can generate a report immediately. You can schedule report generation with 
specific dates, times, and intervals. Generated reports use the data extracted from 
the OTM data base. These reports are automatically saved with a system default 
name to the default location unless you specify otherwise. 

Each report format has the following attributes, as noted by the column headers: 

• Report Name - Names of available reports

• Type - Notes if the report is either predefined or customized

• Number of systems - Number of systems for which the report will be 
generated

• Number of Data Fields - Number of data fields in the report

• Last Generated - Date and time when the report was last generated
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Each report shows a specific set of list data. List Manager provides a set of reports 
whose properties are predefined. 

Reports and text files

All log report activity is performed, by default, in the current working directory 
for the System (the system subdirectory in your PC system). Other reports are sent 
to the PC directory of your choice. Here is a list of text files with the appropriate 
extension found in the working directory:

• Reports (filename.TXT)

• Communications logs (filename.LOG)

You need only supply the filename when prompted to save these files—OTM 
automatically supplies the appropriate extension. 

Generate reports

You can generate a report and display it immediately, send it to a printer, or save it 
to a file. You can schedule report generation to take place at predefined intervals. 

To generate a report:

1 Choose File > Reports.

The Reports window appears. 

2 Select a report in the window display. 

3 Click one of the following buttons: 

• Print—Print the report to the selected printer. 

• Print Preview—View the report on the OTM PC. 

• Print Setup—Select a printer to print reports. 

• Schedule—Display the Schedule window. Use this window to specify 
when and how often to generate the report. 

To save a report to a file:

1 Choose File > Reports.

The Reports window appears. 
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2 Select a report in the window display. 

3 Check Print to File. 

4 Click Print.

The Export dialog box appears. 

5 Select a file format and destination type. 

6 When the Choose Export File dialog box appears, enter a file name (or use the 
default name), and select a directory in which to place the file. 

7 Click Save.

List Manager saves the report to the file name and location specified. 

Predefined reports

List Manager includes several predefined reports. These are listed below along 
with a short description of each report type. You cannot customize List Manager 
reports. 

List Manager provides the following report forms: 

Group Call

• Group Call lists—Group Call lists, sorted by list number

• Group Call lists by name—Group Call lists, sorted by list name

• Group Call lists with entries—Group Call lists including information about 
their entries

• Group Call lists with associated DNs—Group Call lists including information 
about their associated DNs

Group Hunt

• Group Hunt lists—Group Hunt lists, sorted by list number

• Group Hunt lists by name—Group Hunt lists, sorted by list name

• Group Hunt lists with entries—Group Hunt lists including information about 
their entries

Options

• List Manager Options—List options for each list type
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Speed Call

• Speed Call list by name—Speed Call lists, sorted by list name

• Speed Call lists—Speed Call lists, sorted by list number

• Speed Call lists by list type—Speed Call lists, sorted by list type (Speed Call 
or System Speed Call)

• Speed Call lists by SYNC status—Speed Call lists, sorted by synchronization 
status

• Speed Call lists with associated DNs—Speed Call lists including information 
about their associated DNs

• Speed Call lists with entries—Speed Call lists including information about 
their entries

Voice Mailbox

Overview

Voice Mailbox (VMB) data is similar to CPND in that it exists as a separate entity 
within OTM. However, it is associated with a Directory Number (which serves as 
a mailbox ID), and modifications to the VMB data can be made from any station 
that has an appearance of the mailbox DN. The station provides a means of access 
to data that is not a part of the station itself.

Voice mailbox differs from CPND in that it does not have a dedicated overlay. 
CPND information can be modified using overlay 95 as well as overlays 10 and 
11 (OTM uses overlay 95). Voice mailbox information is only accessible from 
overlays 10 and 11.

VMB data considerations

VMB data is accessible from the Station Administration module (DN list dialog 
box). VMB data is retrieved and transmitted with station data. There is no separate 
VMB communications task as there is for CPND.

Note: Voice Mailbox is not applicable to Succession CSE 1000 systems. 
Meridian Mail is not supported on Succession CSE 1000.
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When you delete a station that has one or more single-appearance DNs with 
associated mailboxes, you are prompted to delete the mailbox(es) on the Meridian 
Mail system. This information is used to respond to a VMB prompt when the 
station is OUT’ed on the system.

VMB data can be modified at the Meridian 1 system through the Meridian Mail 
interface. OTM synchronization is a two-step process, as follows: 

1 The Meridian 1 data base must be synchronized by uploading the information 
from Meridian Mail using LD 48.

2 A station retrieval synchronizes the OTM data base with the Meridian 1. See 
“Communicating with the Meridian 1 or Succession CSE 1000 system” on 
page 557.

Administering VMB

VMB data administration in OTM is provided within Station Administration from 
the DN assignment function.

Adding/changing stations

When adding or changing stations, you can access VMB data by choosing the 
VMB button from the DN assignment dialog box, similar to CPND. There is no 
VMB button in this dialog box for systems without feature package 246. There is 
also no VMB button for multi-line stations when the key is not SCR, SCN, MCR, 
or MCN. Click the VMB button in the Directory Numbers dialog box (Figure 232 
on page 464) to open the Voice Mailbox dialog box (Figure 259).
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Figure 259   Voice Mailbox dialog box

The title bar of this dialog box shows the DN associated with the mailbox. If it is 
an existing mailbox, the data fields contain information from that mailbox record, 
including the following: 

Sync Status: This is the sync status of the VMB record, which might be different 
from the sync status of the station.

Class of Service: Numeric entry field (0–127). This field is required when the 
mailbox is in NEW status, and there is no default value.

Second DN: DN entry field. Double-click the box to display the DN list dialog 
box.

Third DN: DN entry field. Double-click the box to display the DN list dialog box.

Keep Messages: Drop-down list box containing YES and NO (NO is default). 
This field is only available when the VMB sync status is NEW.

The VMB sync status indicates which operation is required at the VMB prompt in 
overlay 10 or 11.

• NEW: VMB does not exist on Meridian 1 and will be added at upload time.

• CHG: VMB exists on Meridian 1 and will be changed.

• OUT: VMB exists on Meridian 1 and will be removed.

• TRN: VMB exists on Meridian 1 and no update is required.
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Use the Remove button to change the VMB sync status to OUT. This operation is 
confirmed with a message box. When a VMB is in OUT status, no further updates 
are allowed (except for UNDO).

If a VMB is modified or added from an existing station, that station’s sync status 
becomes CHG to allow the VMB update to occur as part of a station update.

Deleting stations

When you remove a station that has a single-appearance DN with an associated 
mailbox, you are prompted to determine if the mailbox should be deleted on 
Meridian Mail as well. To respond to this prompt, OTM also prompts you for this 
information when you delete stations. However, to avoid possible synchronization 
problems, a different method is used.

When you delete stations in OTM, the delete confirmation dialog box appears. On 
systems with VMB, this dialog box contains a Delete VMB check box that 
defaults to checked (YES).

Your YES or NO response is used to continue or cancel the deletion. The delete 
VMB information is stored as part of the delete transaction, so that it applies to all 
affected stations. OTM uses this information to respond to any DELETE_VMB 
prompts presented during transmission of the deleted stations.

The implications of this approach are as follows:

• You are prompted for this information even if none of the stations being 
deleted has a single appearance DN. In this case, the information is never 
used.

• If you want to delete two stations but give different responses to 
DELETE_VMB for those stations, two separate Edit - Delete operations are 
required.

This guarantees that the correct information is stored in the station that actually 
gets the DELETE_VMB prompt. In cases where all occurrences of a 
multiple-appearance DN are deleted within the OTM data base, only the last 
station transmitted receives the DELETE_VMB prompt. Since it is not possible to 
know which station will be transmitted last in all situations, the DELETE_VMB 
information must be stored with all the stations.
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This procedure prevents accidental deletion of mailboxes when the OTM and 
Meridian 1 data bases are not completely synchronized. Since OTM prompts you 
on any deletion (even if no single appearance DNs are involved), the 
DELETE_VMB information is available if the Meridian 1 prompts for it 
unexpectedly. For example, the OTM database has two appearances of a DN, but 
the Meridian 1 database has only one (due to a change done in LD 10 or LD 11).

Changing DNs

When you change a DN on a station, its associated mailbox must be removed from 
the VMB file if the DN prior to the change was single appearance. You should 
delete the VMB record when you commit to the station update by clicking OK on 
the Station dialog box. To warn you when a mailbox record is to be deleted, a 
confirmation dialog box appears.

The confirmation dialog box appears when a station change results in one or more 
mailboxes being deleted. If you choose to cancel at this point, the entire station 
update is canceled. If you choose to continue with the operation, the mailbox can 
be restored later by performing an undo of the station update.

Since a single mailbox can be updated from multiple stations and those stations 
can be transmitted to the Meridian 1 system in any order, there are some 
synchronization issues that cannot be resolved by OTM. Some of these issues are 
described in the examples below.

All of the following examples involve two transactions, which, by default, are 
transmitted on a first-come-first-served basis. The ambiguities described below 
only occur if you schedule the second transaction to be transmitted before the first.

VMB data synchronization

Consider the following examples when scheduling synchronizing station data 
associated with Voice Mailbox data: 
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Example 1—Deleting stations

Station A and Station B have the only two appearances of DN 2000, which has an 
associated voice mailbox.

1 Delete station A and respond YES to the Delete VMB dialog box.

2 Delete station B and respond NO to the Delete VMB dialog box.

If station A is scheduled before station B, the mailbox is not deleted on Meridian 
Mail. If station B is scheduled before station A, the mailbox is deleted.

Example 2—Adding a mailbox

Station A has single appearance of DN 2000, which has an associated voice 
mailbox in TRN status.

1 Change DN on station A to 2001 (this deletes the VMB record for 2000).

2 Add station B with DN 2000 and create a new voice mailbox for it.

If station B is scheduled before station A, the transmit fails when it attempts to 
create a new mailbox for DN 2000. It exists on the system until station A is 
transmitted.

Example 3—Changing a DN

Station A and station B both have an appearance of DN 2000, which has an 
associated voice mailbox. Station B is in TRN status.

1 Update the mailbox through station A.

2 Before transmitting station A, change DN 2000 to 2001 on station A.

When station A is transmitted, the updates to the voice mailbox are not made, 
because station A no longer has an appearance of DN 2000.
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Global Update

Overview

The Global Update function is available in both the Station Administration and the 
CPND Administration modules. It lets you change common data values in each of 
selected items in the main application window (Station list or CPND list) either 
directly or through a confirmation option.

The Global Update procedure involves the following steps:

1 Select those list items that you want to update. You can use the Select feature 
to select stations based on specific criteria.

2 Select a field for update.

3 Define the update or updates to perform on a selected field in the selected 
items.

4 Execute the change.

You can perform the update on all selected items directly, or you can do it through 
a confirmation option on an item-by-item basis.

If you are running in Installation mode, you are prompted to set up 
communication with the Meridian 1 or Succession CSE 1000 system whenever 
you modify a data record. You can synchronize the data now, schedule a time for 
synchronization, or cancel the prompt and schedule synchronization later. See 
“Communicating with the Meridian 1 or Succession CSE 1000 system” on 
page 557.

Selecting data items

In a data list window of Station Administration or CPND Administration, select 
the items you want to update. You can change the current selection as follows:

1 Click to select a single item. 

2 Use the space bar to turn off all selections and select only the first station in 
the list. This method of selection turns off all other selections, leaving only the 
single current selection.
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3 To select multiple stations, hold down the <Shift> key and click a station, or 
press the space bar, to toggle the selection status of that station without 
affecting other selections.

Choose Edit - Select All to select all items, or you can define criteria to select 
a group of stations using Edit - Select. 

Define selection criteria

To define criteria for record selection, choose Edit - Select in the Station view of 
the Station Administration window or in the CPND Administration window. This 
displays a Record Selection Criteria dialog box in which you enter the expression 
defining the selection criteria.

Figure 260   Record Selection Criteria dialog box

An expression is a formula that follows standard mathematical conventions 
regarding the use of brackets ({}) and the order of operations (add, subtract, 
multiply, or divide). Operations can act on numeric data or on field values from 
the OTM database. Field names must be exactly as defined in the OTM database. 
You can enter the desired expression by typing it in the text box directly, or by 
using the selection criteria and operation buttons provided.

The dialog box has buttons that allow you to select fields, operators, and functions 
to build a valid expression. You may have to modify the position of brackets when 
completing the expression. 

When you have finished creating a valid expression, click OK to display the 
Station Administration window. Those items that fit the criteria are highlighted. 
You can still modify this selection as described in “Selecting data items” on 
page 544. 
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Select Data Field

When you choose Data Field, a list of available fields appears in the Select Data 
Field dialog box (Figure 261). 

Figure 261   Select Data Field dialog box

Select the desired station or CPND field name, and then click OK to paste the field 
into the Select Criteria expression text box at the current cursor position. You can 
type a letter to scroll the listing to the next item starting with that letter.

Select System Field

When you choose System Field, a list of available fields appears in the Select 
System Field dialog box (Figure 262).

Note: Global update is not supported on the following fields: LNAME, 
FNAME, and DEPT.
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Figure 262   Select System Field dialog box

Select the desired field name, and then click OK to paste the selected field name 
into the Select Criteria expression text box at the current cursor position.

Select Function

A function can generate a value on its own, or it may act on the field directly after 
it in the expression to produce a value that depends on that field value. When you 
choose Function, a list of available functions appears in a Select Function dialog 
box (Figure 263).

Figure 263   Select Function dialog box

Select the desired field name, and then click OK to paste the selected function 
name into the Select Criteria expression text box at the current cursor position.
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Select Operator

An operator causes a mathematical combination of field values (arithmetic, 
Boolean, conditional, and so on). When you choose Operator, a list of available 
operators is displayed in an Operators dialog box (Figure 264).

Figure 264   Operators dialog box

Select the desired operator, and then click OK to paste it into the Select Criteria 
expression text box at the current cursor position.

Selecting the items for change

When you have completed the selection criteria expression, click OK to return to 
the Administration list window. All items that meet the defined criteria are 
highlighted.

Example expressions

Below are examples of selection expressions to help you understand the Select 
feature.

Example 1

Select all stations that have been changed in the OTM database since the last 
transmission to the switch.
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The SYNC field shows synchronization for the sets in relation to the Meridian 1 
or Succession CSE 1000 system’s data base. If the sync status of the set is TRN 
(for transmitted) then all changes have been transmitted to the switch and the data 
is synchronized with the switch. Any other status (NEW, OUT, CHG, RPL) 
identifies a set that has been changed on OTM and needs to be transmitted to the 
switch (see the Sync Status section for details.)

To select all stations that need to be transmitted, you can either select all stations 
in NEW, OUT, CHG or RPL status or you can simply select all sets that are not in 
TRN status. The selection is the same in either case. For this example, choose all 
sets that are not in TRN status:

1 Choose Edit > Select. 

2 From the Data Field list, choose SSTAT. 

3 Click <> (not equal to) from the Operator list (or simply type in <>). 

4 Type “TRN”. (Note: All strings must be enclosed in quotes. Column 2 in the 
Data Field List identifies the field as either a string or numeric). 

The complete command in the Record Selection Criteria edit box is as 
follows: 

STATION->SSTAT<>”TRN”

Note that instead of following steps 2 to 4, you can simply type the expression 
above.

5 Click OK. 

All stations are selected except those in TRN status.

Example 2

Select all stations with a prime DN between 4000 and 5000.

To select all stations within this range, select all sets with PRIMEDN>4000 and 
PRIMEDN<5000. OTM will allow you to do this by following these steps:

1 Choose Edit - Select. 

2 Select PRIMEDN from the Data Field list. 

3 Select > from the Operator list (or simply type >). 
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4 Type “4000”. 

5 From the Operator list, select .AND.

6 Select PRIMEDN from the Data Field list. 

7 Select < from the Operator list (or simply type <). 

8 Type “5000”. 

The complete command is as follows: 

STATION->PRIMEDN>”4000”.AND.STATION->PRIMEDN<“5000”

9 Click OK. 

All stations that have a prime DN between 4000 and 5000 are selected.

Example 3

Select all M2616 sets with class of service CFXA.

1 Choose Edit > Select. 

2 Select INST from the Data Field list. 

3 Select = from the Operator list (or simply type it in). 

4 Type “M2616” (criteria is case sensitive; make sure you use a capital M). 

5 Select .AND. from the Operator list. 

6 Select CFXA from the Data Field List (the mnemonic CFXA represents Call 
Forward which can be either allowed “CFXA” or denied “CFD”). 

7 Type =“CFXA”.

The complete command is as follows:

STATION->INST=”M2616”.AND.STATION->CFXA=”CXFA”

8 Click OK. 

All M2616 type stations with Call Forward External Allowed (CFXA) are 
selected.
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Specify the change

You can perform a global update on a single field in each item selected in the list 
window. Once you have selected the desired items for update, you select the field 
to change.

Select the field to change

When you choose Edit - Global Update, the Select Data Field dialog box appears. 
The fields listed include only those that can be changed globally. For example, the 
Instrument (INST) field is not included in this list because some of the fields and 
their values in the record depend on the instrument. 

When you have selected the field to change, click OK to display the Global 
Change Specification dialog box. The selected field name appears in the 
Mnemonic box. The example in Figure 265 shows the entries required to allow 
Call Forward No Answer on all selected station on which it is currently denied. 

Figure 265   Global Change Specification dialog box
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The Global Change Values edit box lets you set up the changes in the field values 
of the field indicated by the Mnemonic box. The box contains a list of changes 
that you define by entering values in the Old Value and New Value fields. 

Perform the global change

When you click OK in the Global Change Specification dialog box, the Global 
Change dialog box opens (Figure 266). This dialog box gives the current status 
only (you cannot edit any of the fields).

Figure 266   Global Change dialog box

The dialog box contains a Station Definition area to identify the station currently 
being changed. The Change area displays the Old and New Values.

If you are not using change confirmation, a “percentage done” bar informs you of 
the progress of the changes.

Note: The Old and New Value text boxes are case sensitive. The values 
must be entered in the same case as is used in the OTM data base. For 
example, XYZ and xyz are not the same values.
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While the change is in progress, the dialog box displays the Cancel and Help 
buttons. Help displays help for this dialog box, and Cancel halts the change task.

When the task is complete, the Cancel button is replaced by an OK button.

Change confirmation

If you elected to confirm changes, a Confirmation dialog box asks you whether to 
“Change this record?” for each station record in turn. The Global Change dialog 
box contains Station identification and Change identification data for the current 
field.

You can move this dialog box in the same way as other Windows dialog boxes to 
see the progress bar and function buttons in the Global Change dialog box.

The Confirmation dialog box displays the following buttons:

• Change: Perform the change indicated in the Global Change data box and 
proceed to the next station.

• Skip: Proceed to the next station without changing the current one.

• Change All: Proceed with all remaining changes without confirmation.

• Cancel: Cancel all remaining changes.

During the change process, the progress bar changes and the Global Change data 
area is updated.

Change completion

When the Global Change task is complete, the Confirmation box is cleared, the 
Global Change box indicates 100 percent completion, and the Cancel button is 
replaced by an OK button.

Click OK in the Global Change dialog box to return to the list window.

Warning: If you click Cancel, there is no way of controlling which 
records are changed and which are not.
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Global Update—wildcards, matching, and allowed fields

If you choose Edit > Global Update, you build a list of changes for a single field 
on the selected records. The list of changes is built by adding requests to change 
Old Value to New Value for the chosen field. To improve efficiency and to shorten 
the list of changes, you can use * (asterisk), the wildcard character. The wildcard 
matches any value in the field.

Wildcard matches that you specify are always done after the other Old Value 
matches have failed. Otherwise, matches are attempted in order. For each selected 
record, the first change request that matches the Old Value is implemented.

Key* allows you to update a feature when the key on which the feature resides is 
unknown. For example, suppose you want to update the Conference key on all sets 
to No Hold Conference/Autodial. The Conference key may exist on any key of the 
selected station(s). Key* allows you to update the key feature without knowing the 
key number. OTM searches for the first occurrence of the feature specified, and 
updates that key per the instructions. See “Global Update—examples” on 
page 554 for more detail.

Certain fields on the station may not be changed with the Global update facility:

• Location must be unique for each station, so Global update is not permitted.

• Station type may not be changed with global update.

• Certain administrative features of a station, including color and type cannot be 
changed.

Global Update—examples

A few examples are provided below to help you use the Select and Global Update 
features. These examples provide the basic steps for selecting stations based on 
certain criteria and updating common fields. These methods can be applied to a 
variety of Global Update situations.
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Example 1

Suppose you want to change all DNs in the range 4000–4999 to a 5-digit 
54000–54999. You want to apply this change to all stations for Customer 1.

1 Global Update is applied to selected stations only. You should, therefore, 
select all stations for Customer 1. Choose Edit - Select. Click on Data Field 
and choose the Customer Number field to build the expression 
STATION->CNUM = 1. (The STATION->CNUM portion is provided 
automatically when you select Customer Number from the list of Data 
Fields).

If there is only one customer on the Meridian 1 or Succession CSE 1000 
system, use Edit > Select All to select all the stations for this DN change.

2 Choose Edit > Global Update to specify the DN change.

• Specify the field to be changed in the Select Data Field dialog box. OTM 
provides a special field called All Directory Numbers. You can move the 
highlight in the Select Data Field dialog box until the All Directory 
Numbers field is highlighted. Click OK to select the All Directory 
Number field.

• In the Global Change section, you are asked to build a list of each old 
value and the new value with which to replace it. The Mnemonic field 
shows that we are working with the field All Directory Numbers (ADN).

• Enter the DN range 4000–4999 in the Old Value box. Move to the New 
Value box and enter 54000–54999. To enable this change, click Add. The 
requested change appears in the Global Change Values box. (You can 
Update or Delete each entry in the Global Values box by clicking the 
appropriate button.)

• When you are satisfied with this change request, click OK.

• OTM examines each station to see if any changes need to be made. A 
meter marks OTM’s progress through the stations. Click Cancel to halt 
the updating process.

• For any applicable station, the Global Change dialog box displays 
identifying information for the station and the old and new values that are 
to be modified.
Using Optivity Telephony Manager Release 2.0x



556 Station Administration
Example 2

Suppose you want to change all Conference keys (A03) on all stations to No Hold 
Conference/Autodial keys (CA). Conference may currently be configured on any 
key on the selected stations.

1 Select the stations to be updated. Since all stations need to be changed, choose 
Edit > Select All.

2 Choose Edit > Global Update to specify the desired change. Choose 
KEYGUPD (Key Global Update) from the Select Data Field window. (You 
can move immediately to the KEYGUPD mnemonic by typing in the first 
letter of the mnemonic, K.) The Global Update window opens. A list box 
allows you to specify which key to change. Since you are not sure which key 
on each station is equipped with Conference, use Key*, the default for this 
list, to update the feature regardless of the key number.

3 Enter the existing value of the key to be changed in the Old Value box, A03 
and press <Tab>. (If the key you want to change has parameters, tabbing 
brings up the parameter fields.) Conference does not have parameters, so tab 
moves you to the New Value box. Enter the mnemonic of the new feature (in 
this case, CA for No Hold Conference Autodial). Press <Tab> to display edit 
boxes for the parameters associated with the new feature. Enter the 
appropriate data in the parameter fields.

4 You can choose to confirm each change. Once you click OK, OTM begins the 
updates. OTM searches each selected station for the first occurrence of A03. 
If A03 is encountered, OTM changes the key to the new value: CA.

Example 3

Suppose you want to add a feature to the first blank key on each set, but the first 
blank key may be a different key number on each set.

Note:  If the station contains multiple Conference keys, only the first one 
will be changed. You can run a second global update to change the second 
appearance of a feature.
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The choice of Key* for your Global Update criteria tells OTM to look for the first 
occurrence of a particular feature on each set selected. When OTM encounters 
that specified feature, it changes that first occurrence to the specified new feature 
and then proceeds to the next set. In this example, the feature you are looking for 
is a blank feature. Perform the following steps:

1 Select all the stations you want to change. 

2 Select Edit > Global Update.

3 Choose KEYGUPD (Key Global Update) from the criteria list. 

4 Choose the key number Key* (this is the default). 

5 Enter nothing (blank) in the Old Value, enter the new feature mnemonic and 
appropriate parameters in the new value. Select Add to add to the Global 
Update list. 

6 Click OK. All stations selected have the new feature added to the first blank 
key. If a selected set does not have any blank keys, the feature is not added to 
that particular set.

Communicating with the Meridian 1 or Succession 
CSE 1000 system

Overview

Meridian 1 and Succession CSE 1000 systems can be programmed with relevant 
station data, list data, and CPND data from the OTM application. The OTM 
application can also retrieve data from a Meridian 1 or Succession CSE 1000 
system. For example, you can create an OTM data base for a system and then 
upload relevant data to program a Meridian 1 or Succession CSE 1000 system. 
You can make modifications within OTM and upload these to the system. At any 
time, you can download system data to OTM for record-keeping or verification 
purposes. If you have a Meridian 1 or Succession CSE 1000 system and want to 
start using OTM to administer the data, you download the data from the system 
and update the data in OTM to include all OTM administrative and record-keeping 
data.
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Your PC uses a modem to communicate, through normal telephone wires, with a 
modem connected to the Meridian 1 or Succession CSE 1000 system. OTM can 
also use an Ethernet connection on the Succession CSE 1000 system and, if it is 
available, on the Meridian 1 system. The communications protocols must be 
predefined for each system. From the OTM Navigator window, select the desired 
system. Choose File - Properties to display the System Properties window. Select 
the Communications tab to define the appropriate communications protocols for 
this system.

Station Administration, CPND, and List Manager use the Synchronize menu to 
schedule communications with the system.

Communications considerations

Retrieving data is a two-stage process. The Meridian 1 or Succession CSE 1000 
system’s data is first downloaded and stored in the current working directory (the 
OTM system subdirectory). Parsing converts the data into the OTM data format. 
This new data overwrites (synchronizes) the OTM data base for the system with 
the data from the Meridian 1 or Succession CSE 1000 system. The Meridian 1 or 
Succession CSE 1000 system’s data can be parsed at any time after retrieval.

OTM requests a customer number for all data retrievals in order to enforce the 
Meridian 1 and Succession CSE 1000 system’s Limited Access to Overlays 
(LAPW) restrictions. If the login password associated with the entered customer 
number is restricted from the print routines needed for synchronization, the data 
will not be retrieved.

Station synchronization vs. list synchronization

List Manager synchronization is a separate task from Station synchronization.

Some List Manager settings make changes in OTM’s Station Administration 
module (for example, feature key assignment). You must ensure the list data is 
present on the system so that station validation does not fail. 

Note: Synchronize list data before synchronizing station data. 
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Station retrieval—TTY Port configuration

During the synchronization retrieval operation, OTM requests a print of the 
information on the Meridian 1 or Succession CSE 1000 system through the SDI 
port. The port used for OTM data retrieval should be configured only as a Service 
Change port. The OTM System Terminal application can be used to access LD  17 
to temporarily configure the TTY port as SCH only (not required for Ethernet 
connections). If the port is configured for other data such as Traffic or 
Maintenance messages, OTM attempts to distinguish this data from relevant 
station data. The retrieval log gives errors when data is not recognized as station 
data.

Data retrieval—Log window

During data retrieval, the amount of activity in other Windows tasks should be 
limited.

During long data retrievals, or if there is enough activity in other Windows 
processes, the capacity of the communications buffer can be exceeded. This 
condition terminates the retrieval process to prevent erroneous data from being 
entered into the OTM data base.

To prevent this occurrence, the Log Window automatically minimizes itself. The 
icon is labeled “Log Window:” and contains the current site and system names. 
You should wait momentarily and restore the Log Window to check the progress 
of the retrieval.

The Log Window remains on the screen longer if you resize it to contain fewer 
lines. The amount of window resizing and moving during data retrieval should be 
limited, since these activities prevent the retrieval activity from processing 
incoming characters.

If the capacity of the communications buffer is exceeded during the retrieval, 
necessary data is being lost. The OTM software displays a message and terminates 
if the buffer is exceeded. In this case, stations are not added to the OTM PC 
database. The message is printed to the log file, warning that the data has been 
lost.
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Repeat the retrieval to add the new data. It is possible to retrieve a portion of the 
stations on the Meridian 1 or Succession CSE 1000 system by choosing 
Synchronize > Retrieve > Specify.

The Communications task

Synchronization is a task that ensures that the OTM data base reflects the data on 
the Meridian 1 or Succession CSE 1000 system. The task can be achieved in two 
ways:

• Retrieve the Meridian 1 or Succession CSE 1000 system’s data to the OTM 
data base (download). 

• Transmit OTM data to the Meridian 1 or Succession CSE 1000 system 
(upload). 

Whenever you require access to a Meridian 1 or Succession CSE 1000 that is 
defined as a system for OTM, use the Synchronize menu of the OTM module you 
are currently using (Station Administration, CPND, or List Manager). You can use 
this menu to schedule upload or download of selected data, or you can define 
criteria to download or upload specific data. Whenever you modify the OTM data 
base, you are prompted to set up a transmit task to upload the new or modified 
data to the Meridian 1 or Succession CSE 1000 system.

Synchronization

Whenever a communication task has been defined, you are prompted in a 
Synchronization dialog box to set up a schedule for the task (Figure 267). 

Note: Nortel Networks recommends that you turn off all TTY messages 
(including bug messages) during download or upload.
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Figure 267   Synchronization dialog box

The following data can be entered to schedule a task:

Priority

The Priority drop-down list box contains the numbers 1 through 10, representing 
the priority level for the task. The number 1 represents High, 6 represents 
Medium, and 10 represents Low. The default is Medium. Change the priority by 
selecting an item, or enter the number in the text box.

The Priority number determines where, in the current communications task queue, 
this task is placed.

Hold Till

Hold Till is made of two text box fields that determine when this task is sent to the 
communications queue.

Date

The date for the task in the format MM/DD/YY, where MM is the two-digit month 
in the range 01–12, DD is the two-digit day in the range 01–31, and YY is the 
two-digit year. The default entry is the current date (leading zeroes are dropped 
when the input is validated).
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Time

The time for the task in the format HH:MMXX, where HH is the two-digit hour in 
the range 01–12, MM is the two-digit minutes in the range 00–59, and XX is AM 
or PM representing before or after 12:00 noon. The default entry is the current 
time.

Description

Station Update - Station Transmit

CPND Name Update - CPND Name transmit

CPND Update - Configuration transmit

Do not transmit if the telephone is busy

Transmission of changes while a telephone is busy disconnects the active call. If 
you check this check box, it causes the sync task to check the status of the 
telephone before transmitting changes. If the telephone is busy, the change is not 
transmitted and the event is logged in the appropriate transmit log. It is up to the 
user to check the logs and reschedule the change.

Change as replace

This field is only available if OTM is in Maintenance mode. See “Synchronization 
considerations” on page 442.

If you accept the default entries, the task is scheduled immediately.

Click OK to send the task to the Scheduler module of the OTM application. If the 
task is not immediate, the Scheduler runs iconized on the desktop. The Scheduler 
must be running at the scheduled time for the task to be sent to the 
communications task queue.

You are not required to schedule a task at any particular time. You can click 
Cancel in this dialog box and use the Synchronize menu at any time to schedule a 
task.
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Download

This task updates the OTM data base with selected data from the Meridian 1 or 
Succession CSE 1000 system. You can select data items in the current list window 
(Station or CPND) or you can define criteria for system data to be retrieved.

When you choose Synchronize - Retrieve, a submenu allows you to select criteria 
for downloading selected station data. The submenu contains the following items:

All: All data for stations or CPND in the system.

Selected: Only items selected in the current list of CPND or stations.

Since: Only stations on the system that have changed since a specified date (not 
applicable to CPND).

Specify: Define criteria for stations or CPND data on the system for download.

Reserved Unit TNs: Terminal Number units that have been reserved for non-station 
instrument types that do not apply to a particular customer (for example, PWR, 
OOSSLT, OOSMLT).

Parse Only: Lets you access raw data retrieved from the Meridian 1 or Succession 
CSE 1000 system and parse it into the correct format. Note that the parsed data 
will overwrite the current Station Administration data.

Log: View or clear a log of communications activity.

Retrieving all data

You can set up communications with the system to retrieve all data (station or 
CPND) that pertains to a single customer in the Meridian 1 or Succession 
CSE 1000 system.

Station Retrieve All

Choose Synchronize > Retrieve > All in the Station Administration module to 
display the Station Retrieve All dialog box (Figure 268).
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Figure 268   Station Retrieve All dialog box

The dialog box contains the following data entry field:

Customer

A drop-down text box with a list of the customer numbers defined for the open 
system. The text box contains the currently selected item.

When you click OK, you are prompted to set up the communications task.

CPND Name Retrieve All

Choose Synchronize > Retrieve > All in the CPND Name view to display the 
CPND Retrieve dialog box (Figure 269).

Figure 269   CPND Name Retrieve dialog box

Note: During station retrieval, the hardware list is updated with cards that 
support the type of stations being configured in OTM. These might not be 
the exact type of hardware cards actually installed in the Meridian 1 or 
Succession CSE 1000 system. However, they will be cards with 
equivalent function as the installed cards.
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The CPND Retrieve dialog box contains the following data entry fields:

Customer Number: A single-line drop-down text box with a list of the 
customer numbers defined for the open system. The text box contains the 
currently selected item. 

Language: A single-line drop-down text box with a list of languages defined for 
the open system. The text box contains the currently selected item.

DNIS DCNO: A text box in which you can enter the DNIS IDC table number and 
DNIS IDC for this group of CPND entries.

Display Format: A single-line drop-down text box with a list of the CPND 
name display formats defined for the open system. The text box contains the 
currently selected item.

When you click OK, you are prompted to set up the communications task.

Selecting data to retrieve

You can select items in the Station list or CPND list window that you want to 
download from the Meridian 1 or Succession CSE 1000 system. See “Global 
Update” on page 544. Meridian 1 or Succession CSE 1000 system data overwrites 
the data currently stored in the OTM data base for the selected items. When you 
choose Synchronize - Retrieve - Selected, you are prompted to set up the 
communications task.

Retrieve Since option

In the Station Administration module, choose Synchronize > Retrieve > Since to 
display the Retrieve Since dialog box (Figure 270). 
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Figure 270   Station Retrieve Since dialog box

In addition to the Customer field from the Station Retrieve All dialog box, this 
dialog box contains a new field:

Date: This text box contains the date in the format MM/DD/YY, where MM is the 
two-digit month in the range 01–12, DD is the two-digit day in the range 01–31, 
and YY is the two-digit year.

When you click OK, you are prompted to set up the communications task. The 
task retrieves all data that has changed since the specified date.

Specifying data to retrieve

Advanced users can specify stations or CPND (Name or Administration) or 
Reserved Unit Type (RUT) data with a one-to-one correspondence of data in 
certain fields for retrieval. 

Note: During the Synchronization Retrieval operation, OTM requests a 
print of the information on the system through the SDI port. OTM 
attempts to distinguish relevant data from other messages that may also be 
passed through the same port. Examples include traffic and maintenance 
messages. You may find that it helps the accuracy of the OTM retrieval 
process to temporarily disable other uses of this port.

Note: When you retrieve Station Data, CPND names are also retrieved, 
and the Station View is updated accordingly.
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Station Retrieve Specify

Choose Synchronize > Retrieve > Specify option in the Station module to display 
the Station Retrieve Specify dialog box (Figure 271). Enter the data pertinent to 
those stations on the system that you want to download. By default, all fields in 
the dialog box are blank. All stations are downloaded if no data is specified.

Figure 271   Station Retrieve Specify dialog box

Criteria you can set for station selection include:

Customer

A drop-down text box with a list of the customer numbers defined for the current 
system. The text box contains the currently selected item.

Type

A drop-down text box with a list of the instrument types (telephones) available for 
the current system. The text box contains the currently selected item.

Note: Station Retrieval—Using Type = 2000

You can use this Meridian 1 feature to retrieve all 2000 type sets from the 
Meridian 1 system. In the Retrieve Specify dialog box, move to the Type 
box. You can type 2000, although it does not appear in the list box. OTM 
correctly responds to the Type prompt during retrieval.
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Terminal Number

Enter a TN or partial TN to retrieve only those stations attached to the part of the 
Terminal Number entered.

Card Density

This text box allows you to enter the card type. The card type value is associated 
with the terminal number.

Designator

Enter a designator value in this field to retrieve all stations with this Designator.

Tenant

Enter a Tenant value in this field to retrieve all of that Tenant’s stations.

Date

This field accepts a date in the format MM/DD/YY, where MM is the month in the 
range 01–12, DD is the day in the range 01–31, and YY is the two-digit year. This 
retrieves all stations modified after the specified date.

Note: If you request a retrieval from a large Meridian 1 or Succession 
CSE 1000 system, using Specify and the Type, the system can take a long 
time to select the appropriate stations. If the time-out period (set in system 
properties) is not long enough, OTM determines that no more information 
is being sent by the system and halts the retrieval. 

The number of stations retrieved is stated in the Retrieval Log. The 
time-out parameter can be lengthened to give the Meridian 1 or 
Succession CSE 1000 system sufficient time to find the appropriate 
stations to transmit. However, a long time-out period also lengthens the 
time required by OTM to correctly identify that the system has no more 
information to send. You need to be patient if you extend the time out 
period beyond the default values.
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CPND Name Retrieve Specify

If you want to define the CPND name data for downloading, choose Retrieve - 
Specify in the CPND Name view window to display the CPND Name Retrieve 
dialog box (Figure 272).

Figure 272   CPND Name Retrieve dialog box

Display Format: Prior to Release 19 of the Meridian 1 X11 software, the 
Display Format was required for name retrieval. Beginning with Release 19, 
Display Format can be part of each CPND entry. Therefore, for Meridian 1 
systems prior to Release 19, you are prompted for Display Format during name 

Note: OTM is able to retrieve selected stations. You can also retrieve all 
stations, or choose Synchronize - Retrieve - Specify, using a partial TN.

Note: CPND Name Retrieval—Synchronization prompt

When retrieving CPND names from the Meridian 1 or Succession 
CSE 1000 system (using LD 95), OTM prompts you for additional 
information necessary for retrieval. The additional information differs 
depending on the release of the software on the Meridian 1 or Succession 
CSE 1000 system.
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retrieval. For Meridian 1 systems beginning with X11 Release 19 and for 
Succession CSE 1000 systems, you are prompted for Display Format only if OTM 
does not find a valid Display Format. If OTM does not prompt for the Display 
Format, the applicable format is displayed, but not enabled for modification.

The criteria you can set for CPND name selection include the following:

Customer Number

A single-line drop-down text box with a list of the customer numbers defined for 
the open system. The text box contains the currently selected item.

Language

A single-line drop-down text box with a list of languages you can use for the 
display. The text box contains the currently selected item.

Entry Type

A selection field containing three radio buttons for the type of entry for this 
station. The choices include:

Directory Number: Required to enter Directory Number

Dial Intercom Group: Required to enter Group and Member, separated by a space

DNIS DCNO: Required to enter DNIS IDC table number and DNIS IDC

Directory Number

A numeric field that accepts up to 9 digits that represents the DN for this station. 
You can double-click this field to display the list of currently assigned numbers in 
the numbering plan for the open system. You can select the number for this station 
in the Directory Numbers dialog box. This is described in “Directory Number 
assignment” on page 464.

Display Format

A single-line drop-down text box with a list of the CPND name display formats 
defined for the open system. The text box contains the currently selected item.
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When you click OK, you are prompted to set up the communications task.

Synchronization status and retrieval

If OTM performs a retrieval, including station and CPND name, the 
Synchronization Status determines whether the OTM data is updated. In all cases, 
the Retrieval log contains a record of the retrieval and the results of any 
comparisons with an existing Meridian 1 or Succession CSE 1000 system. 

• NEW: The data for this station should not exist on the Meridian 1 or 
Succession CSE 1000 system, and the station will not be updated.

• TRN: The data for this station in OTM should agree with the data in the 
Meridian 1 or Succession CSE 1000 system. The OTM data is updated to 
reflect the current configuration on the Meridian 1 or Succession CSE 1000 
system.

• CHG, RPL: The data for this station has been changed since the last time OTM 
and the Meridian 1 or Succession CSE 1000 system have been synchronized. 
The station is not updated.

• OUT: The OTM user has marked this station for deletion, the current 
configuration of the station on the Meridian 1 or Succession CSE 1000 system 
is not relevant and, therefore, OTM is not updated.

• CUR: The data for this station in OTM should agree with the data in the 
Meridian 1 or Succession CSE 1000 system.

• SWP: The data for this station has been changed since the last time OTM and 
the Meridian 1 or Succession CSE 1000 system have been synchronized. The 
station is not updated.

Current Record

When you select a CPND record for editing (a record with a sync status of TRN, 
CHG or RPL), Station Administration copies the record and saves the copy in the 
database with a Sync Status of CUR. The TRN status then changes to CHG. The 
CUR record contains the original station configuration and can be used as a 
backup. 

Note: When you retrieve Station Data, CPND names are also retrieved, 
and the Station View is updated accordingly.
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If you change a record’s status from CHG or RPL to TRN, NEW or OUT, the 
associated CUR record is deleted.

If you double-click the CPND name but do not make any changes, the CUR 
record is deleted.

The CUR record can be viewed but not modified or updated. To restore the 
original station configuration, select one or a multiple of CUR records, and choose 
Restore from the Edit menu. When the CUR record is restored, the CHG record is 
deleted (if one exists) and the record status changes to TRN.

The CUR record is primarily used for web-based Station Administration, where 
the interface must show the current configuration of the switch, as opposed to a 
configuration with information pending.

CUR Record and Global Update

A record with a CUR status will not change to another state (CHG, RPL, OUT, 
NEW, TRN) and a record with another status will not change to CUR following a 
Global Update of the database.

Generating Reports

When you select a form file to run a report, you are presented with check boxes 
for each of the Sync statuses. Check the box to include records with the 
corresponding status in the subsequent report.

List Manager and Corporate Directory

List Manager and Corporate Directory allow you to associate a set of stations to a 
list, and generate customized directory reports. Neither application includes CUR 
records in reports or lists.

Forms Interface

When using the Forms interface to view a CUR record, the OK button in the 
Update dialog box is disabled, as CUR records cannot be modified.
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Upload

This task updates the Meridian 1 or Succession CSE 1000 system data block with 
selected data from the OTM database. You can select data items in the current list 
window (Station or CPND).

When you choose Synchronize - Transmit in the Station or CPND module, a 
submenu allows you to select criteria for uploading data to the Meridian 1 or 
Succession CSE 1000 system. The submenu contains the following items:

Selected: Upload only selected items in the current list of CPND or stations.

Log: View or clear a log of communications activity.

Selecting data to transmit

You can select items in the Station list or CPND list window to upload to the 
Meridian 1 or Succession CSE 1000 system (refer to “Global Update” on 
page 544). The OTM data overwrites the data currently residing in the Meridian 1 
or Succession CSE 1000 system for the selected items. When you choose 
Synchronize - Transmit - Selected, you are prompted to set up the 
communications task.

Communications logs

All communications activity is recorded in log files that are stored in the current 
working directory of your OTM administration modules. There are five separate 
log files. The names follow normal PC conventions, as follows:

• RTRSTN.LOG: Station data retrieve

• TRNSTN.LOG: Station data transmit

• RTRNAME.LOG: CPND data retrieve

• TRNNAME.LOG: CPND data transmit

• OVL81RTR.LOG: Reconcile data transmit noting deleted sets information

Each of these logs is accessed from the Log menu in the appropriate module’s 
Synchronization - Transmit or Receive menu.
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When you choose Log, a submenu provides the following items:

View: Sends the log file to the viewer so you can browse or print the log. Log 
activity is appended to the end of the file, so the most recent activity is at the 
bottom of the viewer. See “OTM file Viewer” on page 590.

Clear: Clears the log file. You should do this occasionally so that the file does not 
get too large. 

Note: There is no limit to the size of the log files, but there is a limit to 
the size of log files that the viewer can handle. There is a 100-page limit 
on log files for viewing from Synchronize - Log - View.
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Viewing large log files

There is currently a 100-page limit on the size of log files and reports that can be 
displayed on the screen. This limit affects Synchronization - View - Log and 
Reports menu items. A message appears to warn you that the file is too large to be 
viewed in its entirety, and only the first 100 pages appear.

Note: During station retrieval, you should limit the amount of activity in 
other Windows tasks. During long station retrievals, or if there is 
sufficient activity in other Windows processes, the capacity of the 
communications buffer can be exceeded. This condition terminates the 
retrieval process to prevent erroneous data from being entered into the 
station data base. 

You may notice that the Log window minimizes itself to prevent this 
occurrence. As the communications buffer starts to fill excessively, the 
Log window is minimized to allow faster processing of the incoming data. 
You should wait momentarily and restore the Log window to check the 
progress of the retrieval.

The Log window remains on the screen longer if you resize it to contain 
fewer lines. Similarly, you should minimize the amount of window 
resizing and moving during station retrieval, since these activities 
momentarily prevent retrieval activity from processing the incoming 
characters.

If the capacity of the communications buffer is exceeded, necessary data 
is lost to OTM. OTM displays a message and terminates the station 
retrieval process. You will notice that the stations were not added to the 
OTM PC data base.

You can repeat the retrieval to add the new station data. Alternatively, you 
can choose Synchronization - Parse Only to add the downloaded data to 
the OTM PC data base, and continue the retrieval process from where it 
stopped. It is possible to retrieve a portion of the stations on the system by 
choosing Station Retrieve - Specify. 
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You can avoid this limit by doing the following:

• Periodically, use Synchronization Log - Clear to prevent text from old 
retrievals or transmissions from unnecessarily adding to the size of the log 
file.

• Test large reports on a portion of the data, using the Filter feature in the 
Report Form menu. For example, you can limit the report to the first 200 
records by opening the report form and selecting the Options - Report Filter. 
To limit the number of records, click System Fields, select the REC_COUNT 
field, and build the expression SYS->REC_COUNT <= 200. If a Report Filter 
already exists, this clause can be added using the .AND. operator.

• View large files with another program. Note that these files are too large to be 
viewed using the Windows Notepad.

Transmission errors during retrieval

You should inspect the Retrieval Log after performing a synchronization. This log 
reports the number of stations added, the number of stations compared, and the 
number of stations with discrepancies from that comparison. In addition, the 
Retrieval Log may contain warnings from unrecognized data during the 
transmission. The unrecognized data may be the result of transmission problems.

Compare the expected number of stations to be retrieved to the number of stations 
actually retrieved. If too few stations were retrieved, look for warnings in the log 
file that indicate that not enough data was correctly received to recognize the 
station.

You should also note the number of compared stations. The first retrieval into the 
OTM PC database should only be adding stations. If any stations were compared, 
it may indicate a transmission error in the TN field that caused OTM to treat this 
station as an update to an existing station, instead of creating a new station.

Reconcile TN feature

This tool corrects synchronization problems that may arise when changes are 
made to station data outside of OTM. These changes may include Set Removal, 
Set Relocation done through a TTY using LD 10 or LD 11. The switch data base 
is changed but the OTM database on the local PC is left unchanged.
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OTM users launch the Reconcile TN feature from the Synchronize menu in the 
Station Administration window. OTM compares the listed sets information with 
information in the OTM database against the switch data base to determine which 
TNs are valid. Invalid TNs are removed from OTM. All removed TNs are noted in 
a log file viewable by selecting Synchronize > Reconcile > Log > View 
(Figure 273).

Figure 273   Viewing the log file

Conversion utility

Overview

The OTM Conversion utility provides two functions:

• Rebuild of station data to the current OTM file structure. You may need to run 
this conversion if you have copied system data to your current release 
directories that was built in an earlier release.

Note: The Reconcile TN feature requires some time to complete its 
function and can degrade system performance. Do this task when switch 
traffic is low or after hours to minimize the effect on the system’s 
performance. Users should back up the existing database before starting 
this function.
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• Import of station data from other applications.

Starting the Conversion utility

When you choose File - Conversion utility in the Station Administration module, 
the OTM Conversion utility window opens.

Figure 274   Conversion utility window

The window initially contains no data in the workspace. The menu bar contains 
the following drop-down menus:

• File

• Rebuild File

• Help

You can select the desired menu using the mouse (click) or keyboard (Alt+ 
underlined character) in the normal way.

File menu

The File menu provides the following functions:
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Import: Lets you insert station data from another database into the current 
system.

Close: Quits the Conversion utility.

Rebuild File menu

OTM administration can change the file structure of certain files. This can cause 
file errors during system maintenance. The Rebuild Files menu lets you check the 
individual files of system data and convert them to conform with the current file 
structure being used by OTM, if necessary:

All Systems: This option automatically searches the PC system for OTM systems 
and transforms selected files, if necessary.

Auto: This option automatically checks and transforms all files for each system, if 
necessary.

Select Files: This option lets you select OTM data files that will be checked for all 
systems, and transformed, if necessary.

Current System: This option checks selected files of the current system and 
transforms them if necessary.

Auto: This option automatically checks and transforms all files for the current 
system, if necessary.

Select Files: This option lets you select OTM data files that will be checked and 
transformed for the current system.

Help menu

The Help menu provides on-line Help for the Conversion utility.
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Rebuilding files

The OTM administrator can modify the file structure used in OTM. This can result 
in File Errors during OTM processing. When this occurs, you can use the 
Conversion utility to rebuild the files, making their structure correspond with the 
current OTM file structure. In practice, the Conversion utility checks the structure 
of selected files and rebuilds only if necessary.

Accessing the files

To access the OTM data files for the Rebuild option, choose Rebuild File - All 
Systems or Rebuild File - Current System. Each option displays a cascading 
secondary menu that lets you choose to automatically detect files that require 
rebuilding or to manually select files for rebuild.

If you choose to select files, a Select Files dialog box appears. This dialog box 
contains a multi-selection list of files that comprise the OTM data. Selected files 
are indicated by highlight bars. Use the Windows vertical scroll bar to browse the 
entire list of files. Mouse click an item to toggle its selection status.

Click OK in the Select File dialog box to start the rebuilding task for the selected 
files of all systems or the current systems as required.

Monitor rebuilding files

The Conversion utility checks all the selected files in each system and rebuilds all 
files it finds that require rebuilding. During this task, a status dialog box appears 
that informs you of the progress of the task.

Upon completion, a status of Success appears. At any time you can click Cancel in 
the Status dialog box to halt the rebuilding task. This may result in some files not 
being rebuilt. Another attempt at Rebuilding Files now completes the task.
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Importing station data

Station data is stored in accordance with the file structure and data base rules 
defined in the OTM application. The Conversion utility provides a merge function 
(Import) that lets you update station data, and add new stations, from a data source 
other than a Meridian 1 or Succession CSE 1000 system (data defined in DBASE 
or CPLUS, for example).

Note that the merge function uses the DN as the key so that any imported data 
must include a DN field. Also note that, if the supplied DN is not currently used in 
the open system, the record is not added unless a valid unique Location field 
(LOC) value is supplied. This means that to create a new record, you must supply 
both a currently unused DN and a unique Location.

Data for import must have a Fields Definition file (default but not limited to files 
with.FLD extension), as well as a comma delimited data file (default but not 
limited to files with .TXT extension). The Fields Definition file identifies which 
items in the data file belong to which OTM fields.

Note that the Fields Definition file must have the exact field names as defined in 
OTM. These can be found in the Select Data Field dialog box in the Global 
Update function. The fields are in the order in which the data is listed in the data 
file.

Considerations when merging key values and features

If you want to add or modify features for a particular record, you must identify a 
FTR field for each feature being modified. The values must be as identified in the 
Features dialog box when accessing multi-line telephone sets in the Meridian 1 or 
Succession CSE 1000 system. For example, Call Forward, when the forward DN 
is a four-digit number, is CFW 4 in the Meridian 1 or Succession CSE 1000 
system.

If you want to add or modify key functions to a single line telephone, you must 
identify the key as KEY n, where n is the key number (include the space). If the 
value represents a Single Call Ringing key, then the field entry is SCR nnnn, 
where nnnn is the selected DN.
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Select a data file

To select data to import, choose File - Import in the Conversion utility to display 
the Select an Import Text File dialog box. The Text File Selection dialog box lets 
you select the location and file name of the desired data file. By default, the dialog 
box tries to locate files with .TXT extension, but you can actually use any 
extension in the File Name text box.

Click OK in this dialog box to accept the data file name selection and display the 
Field File Selection dialog box.

Select a field file

Click OK in the Select an Import Text File dialog box to display the Select an 
Import Field File dialog box. The Field File Selection dialog box lets you select 
the location and file name of the desired field definition file. By default, the dialog 
box tries to locate files with .FLD extension, but you can actually use any 
extension in the File Name text box.

Click OK in this dialog box to initiate the merge function.

Perform the merge

When you have completed selection of the data and field files for merging to the 
current system data, click OK in the Select an Import Field File dialog box to 
initiate the merge function and display a progress status message box that has a 
percent completion bar. This dialog box has a Cancel button that will stop the 
merge before completion. When the progress bar indicates 100 percent, the 
Cancel button changes to OK. Click OK to return to the Conversion utility 
window.

The data is now part of the system and is available through the Station 
Administration module.

Example of import data

A typical import file might contain the following data:

• “3452”, “Robert”, “Williams”, “Accounting”

• “3497”, “Marie”, “Astor”, “Marketing”
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• “8732”, “Lee”, “Smith”, “Accounting”

• “8743”, “Arthur”, “McKinley”, “Facilities”

• “3469”, “Mary”, “Owens”, “Marketing”

where each record has four fields that would be defined in a separate file, as 
follows:

• DN

• FNAME

• LNAME

• DEPT

Note that the merge function uses the DN as the key so that any imported data 
must include a DN field. Also note that if the supplied DN is not currently used in 
the system, the record is not added unless a valid unique Location field (LOC) is 
supplied.

Generating reports

Overview

The Report Generator module lets you create, view, print, and change custom 
reports. Access the Report Generator module by choosing File - Reports in the 
CPND and Station Administration modules.

OTM supplies several standard report forms for reporting OTM data. In addition, 
the Reports Generator module contains a form editor that lets you create custom 
report forms or edit existing forms. It also contains a viewer that lets you print 
reports or browse reports on the screen. A report executor lets you run the reports 
to the viewer for screen display, to a file, or to a printer. Custom selectable criteria 
allow you to tailor the report listing.
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Reports considerations

All report activity is performed in the current working directory—the system 
subdirectory. All forms are stored in this directory with a “.FRM” extension. 
Exported reports are also saved in this directory and are automatically given a 
“.TXT” extension. This means that you need supply only the filename (up to eight 
characters) when prompted to save a report to a file.

The OTM Report Generator requires that a printer be configured in the Windows 
software environment, although it is not necessary for the PC running OTM to be 
equipped with a printer.

Starting the Reports function

Choose File > Reports > Report Generator in the Station or CPND module to 
display the OTM Report Generation window (Figure 275).

Figure 275   Report Generation window
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There is no data in the work area when the window first appears. The window 
contains a menu bar with drop-down menus that let you perform global actions 
within the Report Generator:

• File Menu

• Form Menu

• Report Menu

• Help Menu

File menu

The only function available from this menu is the following:

Close: Closes the Report Generator.

Forms menu

This menu lets you choose a current report form or create a new form.

New Report Format...: Lets you design a new form for a report.

Open Existing Report Format...: Lets you open a predefined form for the 
selected data in the system.

Reports menu

This menu allows access to the report executor.

Run Report...: Displays a dialog box that lets you access a report form that you 
can run (to the screen, to a printer, or to a file).

Running reports

Running a report involves selecting a report to run and selecting a destination for 
the report. Selection criteria for the records you want to choose are contained 
within the report form. If you desire different criteria, you can edit the form or 
create a new one. See “Report criteria” on page 613. You can send a report to a 
viewer for screen display, to a file, or to a printer.
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Select a report

Select a report to run by choosing Report > Run Report in the Report Generator. 
The Select a Form File dialog box opens with a single-choice scrollable list of 
report forms on your system (Figure 276).

Figure 276   Select a Form File dialog box

Some reports in the list may be reports you have defined or modified for your 
needs. Default reports supplied with OTM include the following:

• Automatic Call Distribution Stations

• Class of Service

• Dial Intercom Group

• Telephone Directory by Department

• Telephone Directory by Directory Number

• Telephone Directory by Location

• Telephone Directory by Name

• Telephone Directory by Terminal Number

• Directory of All DNs

• Equipment Inventory

• Hunt Patterns
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• Key Assignments

• Message Centers

• CPND Name by Directory Number

• CPND Name by Name

• CPND Name by Location

• CPND Name by Synchronization Status

• Telephone Directory (Phone Book)

• Private Line

• List of Power Failure Phones

• Ringing Number Pickup Group

• Speed Call Groups

• System Speed Call Groups

• Used DNs

The currently selected form is highlighted. Select a form and click OK to run a 
report using the currently selected form.

Select a destination

When you have selected a form and have chosen Report > Run Report, an Output 
Device dialog box provides a list of possible destinations for the report 
(Figure 277).

Figure 277   Output Device dialog box

The dialog box displays a list of destinations for the report:

• Screen

• Printer

• Export File
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Select a destination, and then click OK to run the selected report.

View report

If you select Screen for the report destination, a viewer appears with the report in 
the work area (Figure 278).

The Viewer has the following menus:

File: Lets you display a report summary, print the report, or exit the viewer.

Search: Lets you find text contained in the report.

Help: Lets you access online Help for the viewer.

See “OTM file Viewer” on page 590 for more information.

You can print the report from the viewer to the printer defined in the report form, 
or to a printer you choose from the Viewer. You can also save the report to a file 
selected from the Viewer.
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Figure 278   Example Report in the Viewer

Print report

If you selected Printer for the report destination, the OTM Report Generator uses 
the Windows print function to direct the report to its default printer. The default 
printer for the report is identified in the form when it is created or edited. If you 
want to check or change the printer destination or setup, you must do this from the 
Form editor before you run the report. Alternatively, you can send the report to the 
screen and print from the viewer.
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During printing, a Printing status box appears. You can stop the print job by 
clicking Cancel. A Report Viewer status box alerts you when the job is finished. 
Click OK to return to the Report Generator.

Export report

If you chose Export File for the report destination, the report output can be saved 
in a comma-delimited ASCII file. Export File displays a dialog box that lets you 
choose a name for the report file (Figure 279).

Figure 279   Export File Name dialog box

You can enter a file name up to eight characters. Click OK to send the report to the 
Viewer. See “View report” on page 588 for more information. Filename.TXT, a 
comma-delimited text file with the Filename as entered in the text box, is saved to 
the current PC directory.

OTM file Viewer

Overview

The Viewer lets you browse, print, and save OTM files accessed during Station 
Administration tasks. You cannot access the Viewer as a separate module. It is 
invoked when you attempt to print or display files created during OTM database 
administration. The files that can be viewed include the following:
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• Reports

• Designation Strips

• Station Validation Log

• Communication Logs

• Station and CPND Administration list views

Viewing a file

When the File Viewer starts, the scrolling Viewer window contains the data from a 
file created during OTM data base administration (Figure 280). The Viewer does 
not allow editing, so the viewed data is in a fixed format.

You can browse and print the data using the menus, as follows:

Viewer File menu

The File menu lets you display a file summary, save the file to a selected directory, 
print the file, or exit the viewer.

Save as: Lets you save the displayed data as a text file to your PC system.

Summary: Displays a file summary of the displayed data.
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Figure 280   File Viewer window

Print: Sends the file to the default printer (the printer is normally the default 
printer as defined in Windows). However, for reports, the printer is defined in the 
form.

Printer Setup: Allows you to select a print destination and set printer options.

Close: Closes the Viewer and returns to the window that invoked it.

Viewer Search menu

The Search menu lets you find a text string that might be contained in the 
displayed data.
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Find: Lets you define a text string to find. The Find function is not case sensitive.

Find Again: Lets you find the next occurrence of the currently defined string. 
This option is dimmed until you have searched for a string.

Changing viewed data

The data displayed in the viewer is in a fixed format, defined in OTM, for the file 
being viewed.

Browsing the file

The OTM Viewer is a line viewer with the current line highlighted. You can use 
the arrow keys or <Page Up> and <Page Down> to move the highlight one line or 
one screen at a time. You can also use the Windows vertical scroll bars to scroll 
the report, moving the highlight bar as you scroll. The Windows horizontal scroll 
bar lets you browse entire lines when the lines are too long for the window.

Use the Search menu to find selected text. A successful Find highlights the line 
containing the search text.

Save As

The file appears in the Viewer with a default file name in the title bar. You can 
save the data as an ASCII text file. Choose File > Save As to save the current file 
with a different name or location.

Select a file name

The Save As dialog box (Figure 281) is the standard window used to specify the 
file name and file location (for a full description of this dialog box, refer to your 
Windows documentation). The dialog box contains a scrollable drop-down list of 
disks that your PC can access. Select a disk to display the list of directories on the 
disk in a scrollable Directories list field. Select a directory to display a scrollable 
list of files in that directory. Select an item from the File Name list or type in a file 
name.
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Figure 281   Save As dialog box

At any time, click Cancel to return to the Viewer without saving the file. Click OK 
to save the file with the specified file name.

The saved file uses the current default Windows font for character formatting. Any 
character formatting in the original file (from a Report, for example) is not saved.

Display a file summary

Choose File > Summary to display a File Summary status box (Figure 282).

Figure 282   File Summary status box

This summary gives the number of lines for a text file (or number of records for a 
data base report file) and the number of pages in the file. Click OK in the status 
box to return to the Viewer.

Print from the Viewer

You can print the file (exactly as displayed) to a default printer directly, or you can 
select another printer for the task. Choose File > Print to print the contents of the 
Viewer to one of the following destinations:
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• If the Viewer is displaying a report, the print destination is the destination 
defined in the report. If your PC cannot find this printer, OTM displays a 
status message. Click OK in the Status message box to return to the Viewer.

• If no printer is defined in the file being viewed, the print destination is the 
current printer defined in Windows. This can be the Windows default or a 
printer selected in the File - Print Setup option of the Viewer.

A progress status message appears while the file is printing (or sent to a print 
spool if applicable). Click Cancel in the Status box to stop printing. When the task 
is complete, OTM returns to the Viewer window.

Search the file

Choose Search > Find to display a dialog box that lets you enter text you want to 
find (Figure 283). If Find Again is available, the dialog box contains the previous 
search data.

Figure 283   Find Text dialog box

Click OK to accept the data in the dialog box and proceed with the search. Click 
Cancel to return to the Viewer window. Click Help to display online Help for this 
dialog box.

The text box accepts any input. The find function is not case sensitive.

The Viewer highlights the line containing the first occurrence of the text that you 
specified in the Find Text dialog box. The Find function always starts at the top of 
the report, regardless of the current cursor position.

When the first search is complete, Search > Find Again is available. If you choose 
this item, the highlight bar moves to the next occurrence of the text. You can 
repeat this until a status message indicates that are no more occurrences. Click OK 
in this status box to return to the Viewer.
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When you finish searching, click Cancel to return to the Viewer.

Printer setup

To define the printer destination and setup from the Viewer, choose File > Print 
Setup. The Printer Selection dialog box opens (Figure 284).

Figure 284   Printer Selection dialog box

The Printer Selection dialog box contains a scrollable list of printers accessible to 
your PC. Click OK to accept the selected printer and return to the Viewer window. 
Click Cancel to return to the Viewer window. Click Help to display online Help 
for this dialog box.

The Setup button opens the standard Windows printer setup dialog box for the 
currently selected printer. Refer to your Windows documentation for information 
on Print Setup.

Click Cancel in the Print Selection dialog box to return to the Viewer without 
changing the Print setup. Select a printer and click OK to set the selected printer 
as the Viewer default and return to the Viewer. This new printer destination is only 
valid for this viewer session. The report form still retains the original print setup.

Exit the Viewer

Choose File > Close to close the Viewer and return to the Report Generation 
window.
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Designing report forms

Overview

The OTM application includes several predesigned forms you can use to run the 
most common reports. OTM also includes a Report Generator module that 
includes a Forms editor. The editor lets you modify existing forms or create your 
own forms for customized reports.

The Forms editor lets you generate a customized layout for a report by piecing 
together predefined report sections.

Form section concepts

The Report Generator organizes a report by sections. A report form can contain 
one or more sections:

• Report Header

• Page Header

• Sort Header(s)

• Detail Section

• Page Footer

• Sort Footer(s)

• Report Footer

Each of these sections is optional, but a form must contain at least one section and 
can have only one of each type. Each section allows an internal free layout of data. 
The only restriction is the position a section occupies on the report in relation to 
the other sections. 

When you insert a new section in a form, it automatically positions itself correctly 
relative to other sections. This position is indicated in the Editor window by a line 
with the section title printed on it. This line is not part of the form, it merely serves 
as the top boundary of the section it indicates. The list above indicates the order in 
which the sections appear in the form.
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Arranging sections within a form is described in “Validating the data” on 
page 478. 

Forms Editor

The Forms Editor is an application within the Report Generator that lets you 
design and customize a report using the current database.

Choose Form > New Report Format to display the Forms Editor, with a blank 
form in the working area. Choose Form > Open Existing Report Format to display 
a dialog box that lets you select from a list of forms for the current system 
database (Figure 285).

Figure 285   Select a Form File dialog box

The currently selected form is highlighted. Select a form from the list, and then 
click OK to open the Forms Editor. The Forms Editor contains a menu of actions 
to perform. 

File menu

This menu contains commands for saving the current report file and specifying the 
report parameters.

Select Report View: Lets you select the key selection criteria that determine the 
content of the report at runtime.

Save: Store the current report form to a file. If it is a new form, you are prompted 
for a filename (up to eight characters followed by a period and an extension of up 
to three characters).
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Save As...: Store the current report form to a file. Report form files must be stored 
in the common data directory. OTM does not allow changes to the path for these 
files.

Printer Setup: The Windows default printer is automatically assigned to the 
current form when you save it. This selection lets you select a different printer and 
printer configuration to be associated with the current form from a list of installed 
printers.

The printer options that you select here determine the width and height of the 
report. The width of the report is indicated by the length of the section separation 
lines in the form editor window.

Exit: Close the Forms Editor and return to the Report Generation window. If the 
current form has not been saved since the last change, you are prompted to save it 
before exiting the editor.

Edit menu

This menu contains miscellaneous edit and cursor navigation functions:

Insert Line After/Before: Puts a blank line following/preceding the current cursor 
position. 

Delete Line: Removes the current line, moving all successive lines up.

Highlight Off: Turns off any highlighting in the current form (lets you deselect text 
and fields).

Beginning/End of Line: Moves the cursor to the left/right end of the current line.

Next/Previous Word: Moves the cursor to the beginning of the next/previous word 
or field in the form, going to the next/previous line if necessary.

Section menu

This menu contains commands to insert, edit, and delete report sections.

New...: Lets you add a section to the current form. Sections include:
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• Report Header: Appears at the top of the report only

• Page Header: Appears at the top of each page of the report

• Detail Section: Defines data to be reported

• Page Footer: Appears at the bottom of each page of the report

• Sort n Header: The nth sort criterion field for the report (n = 1–9)

• Report Footer: Appears at the end of the report only

The section title appears at the current position of the selected section on the form. 
This line indicates the Forms Editor cursor location. It does not appear on the 
printed form.

Edit Current...: Lets you define the layout of the section in which the Forms Editor 
cursor is currently positioned. It displays a dialog box containing check boxes for 
defining section layout at runtime. Choices include:

• Start new page before this section

• Start new page after this section

• Do not include blank lines

• Suppress trailing (or leading) blanks in a field

• Titles on every page of the report

Delete Current...: Removes the section in which the cursor is currently positioned.

Sort Field...: Lets you change the current sort field selection. This selection is not 
available unless the form has sort fields defined (use the Section New function to 
insert sort fields).

Break Field...: In a typical report, the break field is the same as the sort field. This 
selection lets you define a field for a section break that is not a sort field.

Field menu

This menu contains options to insert, modify, delete, and maintain fields.

Insert New Field: Displays a submenu that lets you choose a field type for insertion 
into the form at the cursor position. Field types include the following:

• Data Field: Displays a list of data fields in a record of the system database
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• Calculation Field: Displays a box for entering a formula for the field

• System Field: Displays a list of OTM system fields

Edit Current Field...: Lets you modify attributes for the current field.

Edit Field Expression...: If you have a calculated field at the cursor position, this 
selection lets you modify the formula.

Options menu

This menu lets you define the appearance of the report and select data records for 
inclusion in the report.

Report Parameters...: Brings up a dialog box that allows you to specify certain 
report parameters:

• Name of the report (This is not the Windows filename.)

• Margins for the printed page

• Output of some trial records for form layout adjustment

• Default date format for input and during execution

Report Filter...: This option allows you to enter a filter criteria for the report. Each 
data record is tested with the expression that you provide here. A record is 
selected only if this expression evaluates to a TRUE value. For example, if the 
expression was DN->amount>1000, then only records with a DN higher than 
1000 are included in the report.

Fonts menu

This menu contains formatting commands for highlighted characters (and field 
values) at runtime.

Normal: Removes character formatting, if any.

Formatting: Normal, Bold, Underline, Italic, Superscript, Subscript, Strike.

Fonts: Lets you select font and size for highlighted characters and fields. The 
report generator allows only fixed space fonts. You should be careful that 
columnar text uses the same font size and spacing to maintain column alignment.
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Changing sections

Figure 286 shows an example of a blank form with all sections in place. The 
sections are divided by a line labeled with the section name. These lines are place 
indicators only and do not appear on the printed report.

Figure 286   Example blank report form

The Section menu lets you change the sections as described below.

Insert a section

To insert a section in a form, choose Sections > New with the cursor anywhere in 
the Forms Editor window. The Select New Section dialog box opens listing the 
available sections. Only the sections that do not appear in the form are presented 
(Figure 287).
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Figure 287   Select New Section dialog box

The currently selected Section is highlighted. Select a section, and then click OK 
to insert the section in the current form.

At insertion time, each section contains one blank line. Use the Edit > Insert Line 
After/Before functions to change the section size at any time while the cursor is in 
the work area of the section (below the section title line and above the next section 
title line).

Define section parameters

You can set runtime parameters for the section at the current cursor position. 
Choose Section > Edit Current to display an Edit Section Info dialog box 
(Figure 288). This dialog box contains check boxes that let you set or clear section 
parameters

Figure 288   Edit Section Info dialog box

Select the appropriate check box to toggle parameter selection. The parameters 
include the following:

• Advance Page Before Printing the Section: The section is printed at the top of 
the next page.
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• Advance Page After Printing the Section: Causes a printer Form Feed after 
this section.

• Suppress Blank Lines: Causes blank lines not to be printed.

• Trim Extra Spaces from Fields: If a field value is shorter than the field 
maximum length, this selection causes the field length to be truncated to the 
length of the value. 

Report Header / Footer

These are printed only once, at the beginning/end of the report. The header is 
generally used as a title and description of the report. The footer may be used as a 
report summary. A report header and footer can contain free text and fields, such 
as System Date and Time.

Page Header / Footer

These are printed at the top/bottom of every page in the report (beneath the Report 
Header on the first page and above the report footer on the last page). The header 
may contain text such as Report title, column headers and any other pertinent text 
as well as fields, such as System Page Number, Date, and so on. The footer may 
be used for page numbers and page by page field totals or other pertinent data or 
text.

Sort Header / Footer

Each of these sections indicate a field that the report uses for a sort break. The 
field you choose is not printed. You can place text or fields or both text and fields 
at these section breaks to describe the sorts being used in the report.

Detail Header

This section contains a list of data for each record of the database, selected and 
sorted according to defined criteria.

Note: If you are using a columnar format, this parameter may cause 
misalignment of columns.
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Edit a form

Text and data are added at the current position of the cursor within the form. Move 
the cursor using the mouse or the keyboard arrow keys. The status line at the 
bottom of the window gives the cursor position by line (row) down and character 
(column) across. The <Ins> key toggles the insert/overtype mode. The status line 
indicates INS for insert mode (text moves everything to the right of the cursor to 
the right) or OT for overtype mode (text replaces existing text at the cursor 
position).

Type to insert text. There is no automatic line wrapping. If you insert a carriage 
return (<Enter>), the cursor is returned to the beginning of a new blank line.

You can use the Edit menu to move the cursor within a line, as follows:

• Start of Line: Left end of line

• End of Line: Right of the last character on the line

• Next Word: First letter of the word to the right of the cursor

• Previous Word: First letter of the word to the left of the cursor.

To insert and edit a field at the current cursor position, use the Field menu.

Insert a field

Choose Field - Insert New Field to display a submenu with a list of data field 
types to paste at the current cursor location. This option is not available when the 
cursor is positioned on a section separation line or on an existing field.

The selected field appears at the current cursor location as a series of “x” symbols 
that represent the maximum number of characters in the field, as defined in the 
database. You can delete any number of field symbols to reduce the field length. 
To increase the field length, position the cursor on any field symbol except the 
first one, and type spaces. You can change the current field attributes by choosing 
Field - Edit Current Field. 
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Insert a data field

A data field is one field in each record of the current database. If you choose Field 
- Insert New Field - Data Field, a list of data fields is displayed in a Select Data 
Field dialog box. See “Selecting data items” on page 544 for further details.

Click OK to paste the selected field into the form at the current cursor position.

Insert a calculation field

A Calculation field contains an expression that is a combination of data, functions, 
and operators. At runtime, the expression result is output for each record. You 
must supply a name for the field as well as the expression to be evaluated. The 
Field - Insert New Field - Calculation Field option first prompts you for the name 
of the field in a Calculation Field Name dialog box (Figure 289).

Figure 289   Calculation Field Name dialog box

You can enter up to 48 alphanumeric characters (not blanks) in the text box to 
represent the calculated field name.

Click OK to enter an expression for the calculated field. The procedure for 
expression entry is the same as for “Define selection criteria” on page 545.

Insert a system field

A System field contains OTM system-dependent information, such as date, time, 
report page number, and record count. This information is typically in the report 
or page header or footer. One System field, WRAP_OVERFLOW allows a data 
field to overflow to the next line or lines. For example, a comment field of 30 
characters can contain 10 characters in the data field itself and 10 in each of two 
WRAP_OVERFLOW fields (generally placed directly under the data field itself).
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If you choose Field - Insert New Field - System Field, a list of System fields is 
displayed in a Select System Field dialog box. The procedure is the same as in 
“Select Data Field” on page 546.

Click OK to paste the current highlighted field in the form at the cursor position.

Edit field attributes

This option, available by choosing Field > Edit Current Field, is used to edit the 
attributes for the current field. This option is available only when the cursor is 
positioned on a field. The field name appears in the status bar of the form window. 
The option displays a set of attributes that can be modified for the current field. 
You can modify the field attributes as needed.

The attributes that you can modify depend on the type of field. Field types 
include:

• Text (alphanumeric characters)

• Numeric (numbers, including thousand separators and decimal point)

• Date (date in predefined formats)

Edit text field attributes

If the cursor is located within a text field and you choose Field - Edit Current 
Field, a Text Field Parameters dialog box displaying the current attributes for the 
field opens (Figure 290).

Figure 290   Text Field Parameters dialog box
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The following parameters can be modified:

Field Alignment: By default, text data at runtime is left-aligned. You can use the 
radio buttons to select left, center, or right alignment.

Wrap: If the field length on the form is too short to accommodate the data at 
runtime, you can select a wrap option to run the text to a WRAP_OVERFLOW 
System field that you have already defined. The Wrap option breaks at the end of 
the current field, and the Word Wrap option breaks at the end of the last word 
before the end of the field. The default attribute has no wrap option selected.

Capitalization: By default, all text in the data field is printed as stored in the 
database. You can change this to all capitals, leading capitals, or all lowercase, by 
selecting the appropriate check box.

Trim Extra Spaces: This check box trims the field length to the length of the data 
that is entered at runtime. 

Edit numeric field attributes

If the cursor is located within a numeric field and you choose Field > Edit Current 
Field, a Numeric Field Parameters dialog box displaying the current attributes for 
the field opens (Figure 291).

Note: If you are using columns, this option may cause columns to 
become misaligned.
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Figure 291   Numeric Field Parameter dialog box

The following attributes can be modified:

Field Alignment: By default, numbers are left-aligned at runtime. You can use the 
radio buttons to select left, center, or right alignment.

Number of Decimal Places: If the field contains a real number, this option lets you 
select the number of digits printed to the right of the decimal point.

Currency Symbol: If the field represents money, you can use this option to define 
the currency symbol.

Sign Representation: This option lets you select how to represent negative and 
positive number values. You can enter a character for prefix and suffix for both 
positive and negative numbers.

Zero Values: Check the Suppress Zero Values check-box to suppress printing this 
field if it contains a value of zero. Check the Pad with Zeroes check box if you 
wish to align the number to the right of the field and fill with leading zeroes. 
Check the Use Comma Format check box to insert a comma between thousand 
values in the field.
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In addition to these attributes, you can edit the following attributes for fields that 
are located in the footer section of the report:

Summarization Type: A numeric field in the footer could require the report to print 
a summary value. This option is a function selector that displays a list of possible 
summary values, such as total, average, maximum, minimum, or count. You can 
also print the actual value for the field by selecting Value.

Retain Value After Printing: If the footer is a page footer, you can check this option 
to print “running” values instead of the value for each page.

Edit date field attributes

If the cursor is located within a Date field and you choose Field > Edit Current 
Field, a Field Name Edit dialog box displaying the current attributes for the field 
opens (Figure 292).

Figure 292   Date Field Edit dialog box

You have a choice of four formats for the Date output, selectable by radio button:

MMDDYY
DDMMYY
MMDDYYYY
MMMDDYYYY

You can also define the date delimiter by entering a required one-character 
delimiter in the Date Delimiter text box (/ or - , for example).
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Edit calculation field expression

This option is available only when the cursor is positioned on a calculation field 
and you choose Field - Edit Field Expression, or when you are first inserting a 
calculation field in the form. The option shows the existing calculation expression, 
if any, in a dialog box and allows you to make modifications. The action of this 
dialog box is the same as that for “Define selection criteria” on page 545.

Setting report parameters

The Forms Editor Options menu lets you set parameters for the report. These 
parameters are stored with the form and will be operative at runtime. 

Figure 293   Report Parameters dialog box

The parameters are defined in the Report Parameters dialog box (Figure 293). To 
open the dialog box, choose Options > Report Parameters in the Forms Editor. 
Parameters include the following:

Report Name: A text box that lets you enter up to 36 contiguous alphanumeric 
characters. This name is used in the OTM system as the name for the report and 
the form. This is not the same as the Windows filename.

Default Date Format: A pair of radio buttons that lets you define the format in 
which dates are printed at runtime. The two formats are MM/DD/YY or DD/MM/
YY.

Print Trial Records: Run the report with just a few records. This enables you to 
check that the form generates a report with a suitable appearance and layout.
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Margins: Four text boxes that let you set the page margins. Enter numeric data 
only, and ensure that the page layout is valid.

Character formatting

You can set the appearance of printed text using the Fonts menu. By default, text 
and fields are output in the Windows default font with Normal (unmodified) 
attributes.

A selection from this menu acts on the selected data. To highlight data (text and 
fields) place the cursor at one end of the data to be highlighted, hold down the left 
mouse button and move the cursor to the other end of the data. To turn off 
highlighting, click anywhere in the form that is not highlighted.

Use the Fonts menu to display a list of character enhancements. Select one to print 
the highlighted text with that enhancement. Enhancements include the following: 

Normal, Bold, Underline, Italic, Superscript, Subscript, Strike.

When you apply an enhancement, highlighting is removed. If you desire more that 
one enhancement for any text, you must highlight the text again and select another 
enhancement. To remove an enhancement, highlight the text and choose Font > 
Normal. 

Font selection

Choosing Fonts > Fonts... opens the Font Selection dialog box (Figure 294) from 
which you can select a font for the highlighted text.

Figure 294   Font Selection dialog box
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The Face Name box contains the name of the font for the selected text. A list box 
shows available fonts with the current font highlighted. Click the desired font to 
change the current font in the Face Name box. Use the arrows to help find the 
desired size, and click to select the font size.

Click OK to set the highlighted text to the currently selected font and size.

To use a single font for the entire report, select the font face and click the Default 
Font check box. This becomes the Normal enhancement selection.

Report criteria

The Forms Editor Options menu lets you select criteria for record selection in the 
report. The criteria cannot be set at runtime, and are stored with the form in which 
the selection is made. The criteria are defined in an expression that displays in a 
Select Record Criteria dialog box when you choose Options > Record Criteria. 
The action of this dialog box is the same as for “Define selection criteria” on 
page 545.

Building a report in the OTM Report Generator - Form Editor

Reports in OTM are built using report forms. The report form contains the 
information that allows the same report to be run repeatedly with new or updated 
data. The report form stores information that fully describes the report to the OTM 
software. A report form is comprised of several sections that describe different 
aspects of the report. A number of standard report forms are provided with the 
OTM software to provide some commonly used reports. 

This section describes a typical session to build a new report form. As an 
illustration, it produces a modified version of one of the OTM standard reports: 
Telephone Directory by Department. The report prints the department name once 
and prints the station information for each department underneath the department 
heading. 

This section describes a step-by-step process to produce a report form. As you 
become more proficient using the Report Generator, you may find that you use a 
different series of steps to build or modify reports. Perform the following steps to 
build a report form: 
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1 Decide what information needs to be displayed on the report.

2 Select the Report View that best provides the information.

3 Place the individual data fields on the report.

4 Decide if the report lines should be sorted. 

5 Specify any special printer considerations for this report.

6 Apply the finishing touches. 

7 Save the report and test the results.

To work with Report Forms, start the Report Generator (choose File > Reports > 
Report Generator). Choose Form > New Report Format. This example shows how 
to create a new form. The report generator places an empty report form on the 
screen (Figure 295). 

Figure 295   Empty Report Form
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Decide what information needs to be displayed on the report

As you will see in the next section, information in OTM is organized into several 
logical databases. A report can use any one of these logical databases. There is 
also OTM system-dependent data that can appear on a report. This data includes 
date, system name, page number. Reports also can contain fixed text, typically 
headings or other constant text information.

In this example, you are using station information (as distinguished from CPND 
or VMB information). You can sketch out a rough picture of the report as a guide 
to what will fit on the page and how much heading information will be included. 

The basic model of the Report Generator is to read each record in the logical 
database, decide if it should be included in the report (according to the Report 
Filter). Some reports sort the records (according to the Sort Header sections). 
Finally, the records are printed. Some reports print out a line for each record 
included in the report (specified in the Detail section). Some reports print out 
summary information (specified in the Sort Header or Sort Footer section), such 
as the total number of particular instrument types. Some reports combine the 
detail and summary information

Select the Report view that best provides the information

After deciding to build a report focusing on station data, pick an appropriate 
Report View (Figure 296). Views provide alternative ways of looking at the data. 
Some of the report views describes the type of data. If the report describes CPND 
configuration information, then choose the CPND view; for CPND Name 
information (by Directory Number or Group) use the CPND Name view; for 
VMB information (by Directory Number) use the VMB view. 

Figure 296   Select Report View dialog box
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Station data is provided with some alternative views. If the report should print one 
line for each station, then choose the Station view. If the report should print one 
line for each Assigned Directory Number, then choose the Station DN view. If the 
report should print one line for each station key, then use the Station Key view. (In 
the Station Key view, single line information is included by assigning “pseudo key 
numbers” to the single line key features.) The SysSpdCall view is a special view 
primarily designed for the System Speed Call Report. It provides one record for 
each system speed call list user. If the report is selecting only certain records from 
the database or printing only summary data, then it will not actually print a line for 
each record, but the view describes how the selecting and sorting process 
examines the records in the database.

Place the individual data fields on the report

Once the Report View has been chosen and the basic design of the report has been 
defined, it is time to place the data on the report page. The Report Generator 
Forms Editor shows the current form broken into its logical sections. Initially, the 
Page Header section and the Detail section appear. As other sections are 
incorporated into the form, they appear as well. In this example, the report 
contains the following sections:

Page Header: This section contains the information displayed at the top of each 
page. Typically, it contains the report title, the column headings over the data, the 
page number, the system name.

Detail: The detail section describes the data items that appear on each line in the 
body of the report. Typically, it contains data from each record in the database that 
is included in the report. The data may be data items from the record or calculated 
fields built from the data fields. Calculations allow the report to create specially 
formatted names or other special expressions.

Sort Header: The sort header sections (there can be several) describe how the 
lines in the report are ordered. Sort 1 Header describes the primary sort, if two 
records have the same value for the sort field, then Sort 2 Header can be used to 
refine the order of the report. A report that should be ordered by name might 
specify LastName in Sort 1 Header and FirstName in Sort 2 Header.
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It is often easier to design the report by specifying the Detail section first. This 
allows you to lay out the data on the page before placing the column headers. 
Treat the screen as a blank report page and position the cursor in the Detail section 
where the field should be placed. Choose Field > Insert New Field > Data Field to 
see a list of available data items (Figure 297). 

Figure 297   Inserting Data Field in the Details section

Choose Field > Insert New Field > Data Field to display a list of the fields that 
apply to this report view (Figure 298). This Select Data Field list also appears in 
other situations where you need to select a field. Several data fields have been 
added specially to help produce reports and some fields have special meanings 
that affect their use in reports. Some examples of special reporting data fields 
include the following: 

ADN - All Directory Numbers: A list of all the Directory Numbers assigned to the 
station. This field creates a text field with the DNs separated by a space. 
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ACDS: Keys Assigned to Automatic Call Distribution, showing both the ACD DN 
and Position ID.

DN: The Directory Number assigned to a single line station. The PRIMEDN field 
contains the Directory Number assigned to a single-line station and the Directory 
Number assigned to Key 0 on a multi-line station.

Figure 298   Select Data Field dialog box

Use a calculated data field to tailor the information from the data record. To use a 
calculated field in a report, choose Field > Insert New Field > Calculation Field. A 
dialog box opens (Figure 299), prompting you to name the newly calculated field. 

Note: Key features should be reported from the Station Key view and not 
from KEYGUPD or FTRGUPD.
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Figure 299   Calculation Field Name dialog box

The Field Name dialog box is followed by a dialog box that allows you to 
construct an expression that performs the calculation. It can be built from existing 
data fields, functions, and operators. The example in Figure 298 constructs a field 
that contains “Last Name, First Name.”

Figure 300   Defining a Calculation field

Note that the TRIM function is used to remove extra spaces and the “+” operator 
is used to concatenate the two fields. You can type the expression directly in the 
box or you can select the fields (from the Data Field or System Field buttons), the 
functions, and the operators. The expression is built as the pieces are selected.

Note that some functions apply to text fields and some functions apply to numeric 
fields. The Select Data Field list shows whether a field is numeric or text. In 
general, functions should not be applied to the System fields. 

After the detail section has been specified, you can design the Page Header 
section. The text for the column labels can be placed over the appropriate data. 
The Page Header section often uses the System data fields: page number, system 
name, date, and time. Choose Field > Insert New Field > System Field to open the 
Select System Field dialog box (Figure 301). 
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Figure 301   Select System Field dialog box

The Page, Date, Time, and System_Name fields are commonly used in the Page 
Header section. Other system fields are discussed in the section titled “Some 
special techniques” on page 627. 

Decide if the report lines should be sorted

Many reports require the data to be sorted. Since there is no sort information on a 
new report form, choose Section > New Section. The Select New Section dialog 
box opens (Figure 302). Select Sort 1 Header in the dialog box. This adds a sort 
section to the report.

Figure 302   Select New Section dialog box

The first sort section specifies the data field that provides the primary ordering of 
the data. The data value to use for sorting will be selected from the list of data 
fields.

Other sort sections are applied only to provide secondary order levels within the 
primary ordering. To order a report by alphabetizing the names of people in a 
department, the report should use Department for Sort 1 Header, LastName for 
Sort 2 Header, and FirstName for Sort 3 Header. 
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Figure 303   Select Data Field dialog box

To modify a Sort Header after it has been specified, choose Section > Sort Field. 
(It will only be available if the cursor is positioned in a Sort Header.) From this 
dialog box, press Sort Field to display the list of data fields (Figure 303).

Summary information can be specified in the Sort Fields, as well. On a report 
sorted by department, it is possible to print each department name once, by 
specifying the Department field in the Sort Header section and not in the Detail 
section (Figure 304).

Figure 304   Adding summary information in the Sort Header section
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The Sort Header section prints only when the Sort Header's field value changes. It 
uses the data field on the first record in the new sort group. Typically, the data field 
chosen to print in the Sort Header should be the same field on which the data are 
being sorted.

Specify any special printer considerations for this report

The Report Generator allows each report form to contain special printer 
information. Some reports might be designed to print in landscape mode, while 
others should print in portrait mode. Some reports may require a special printer 
(an impact printer with special forms, for example).

Choose File > Print Setup to select a printer and press the Properties button to 
specify special print instructions (Figure 305). 

Figure 305   Printer Properties dialog box
23
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This information is stored with the form so that it applies each time the report is 
printed. When the Report Generator actually builds the report from the form and 
the data, you can override this printer information.

Apply the finishing touches

The Form Editor provides some additional capabilities to tailor the report. As you 
examine the almost complete report, you may want to modify the appearance of 
the report.

Lengthening and shortening data fields

You can adjust the width of the data fields in the report. The area for each data 
field is marked on the form with the small letter “x”. The data is printed in that 
marked area. If the actual data is longer, it will be truncated to fit in the area; if it is 
shorter, the rest of the marked area is filled with blanks. In the example report, you 
must lengthen the area set aside for the calculated field which holds the name. You 
may want to shorten a field to try to squeeze another field onto the report.

To adjust the width of a data field, place the cursor in the marked area. To shorten 
the field, press <Delete> or <Backspace>. To widen the field, press any other key. 
It appears on the form as the small letter “x”. 

Adding and deleting blank lines

The Form Editor allows you to add and delete blank lines on the report. On a new 
form, the data in the Detail section is, by default, double-spaced. To make a 
single-space report, position the cursor on the extra blank line and choose Edit > 
Delete Line (Figure 306). 
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Figure 306   Deleting a blank line from the Detail section

Other items in the Edit menu allow you to insert blank lines either above or below 
the line on which the cursor currently rests.

Report Parameters

There are a few more options available to complete the report. Choose Options > 
Report Parameters to specify the name of the report as it will appear in the list of 
available reports. It also allows you to specify margins and other report -wide 
options.

The Print Trial Records is used for reports that require that the paper be correctly 
aligned in the printer. It has no effect until you send the report to the printer. At 
that time, the Report Generator asks whether it should print a Trial Report. The 
Trial Report contains the Header and Footer sections and a single line from the 
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Detail Section. Each data field is replaced with a string of the letter “X” of the 
appropriate length. You are asked to print the Trial Report until you click No. This 
allows you to adjust the paper in the printer until it is properly aligned. Then the 
full report can be printed.

Report Filter

The Report Filter selects which records are to be included in the report. Choosing 
Options > Report Filter displays the Record Selection Criteria dialog box 
(Figure 307). This dialog box helps you to build an expression, typically from the 
data fields. As the Report Generator reads each record in the database, it evaluates 
the expression. When the expression is true, the record is included in the report. 

Figure 307   Record Selection Criteria dialog box

The Record Selection Criteria dialog box operates very much like the Calculation 
Field dialog box. However, you should build an expression, usually including a 
comparison operator (=, >, <, <>). In the example, you are selecting all records for 
which there is a Prime DN. The expression tests whether the PrimeDN field is not 
equal (<>) to blank (“ “).

Modifying fields

As part of the final tuning, you may want to specify more exactly how the fields 
are to be displayed. Choose Field > Edit Current Field.
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The Alignment options operate within the area of the data field, marked by the 
letter “x”. The Wrap options should apply when the field will not fit in the area 
allowed. The section titled “Some special techniques” (page 627) discusses how 
to wrap text. Similar display options, such as whether to use commas, control the 
printing of numeric fields.

Save the report and test the results

With the initial specification of the form complete, it is time to save the form and 
test it with the data from the system. Choose File >Save or File > Save As to save 
the form. Choosing File > Close returns control to the Report Generator. To test 
the form, choose Report > Run Report and select the report form you want to run 
(Figure 308). 

Figure 308   Select a Form File dialog box

The Select a Form File dialog box uses the report names specified in the Form 
Editor’s Option/Report Parameters dialog box. If you did not specify a name for a 
new form, this list displays the file name. If you modified an existing form and 
saved it with a new file name but did not change the Report Name, that Report 
Name appears twice. In this case, you should go back into the Form Editor to give 
your modified report a new Report Name.

As you run the report, you may find that you want to modify the form. From the 
Report Generator choose Form > Open Existing Report Format to return to the 
Form Editor and modify the form.
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Some special techniques

The following are a few special techniques available in the Form Editor to help 
you customize your reports:

Sort Header section /Break Field

If the cursor is placed in a Sort Header section, the Section > Break Field menu 
item is enabled. The Break Field is a data field that causes the Sort Header section 
and the Sort Footer section to print. By default (and almost always) the Break 
Field is the same as the Sort Field that was specified when the Sort Header section 
was created.

Word wrap

If the data field will not fit in the area allowed for it on the form, you can specify 
that the field should wrap. By default, data which will not fit in the allotted space 
will be truncated. Wrapping is especially useful for a field like ADN (the list of all 
Directory Numbers assigned to a station), which can be either quite long or quite 
short. 

Wrapping the data field requires two steps: 

1 Mark the field as one that should be wrapped using the Field/Edit Current 
Field dialog box. (Wrapping only applies to text fields.) Choose the Wrap 
Text box to cause the field to wrap at a word. 

2 Specify where to position the wrapped portion of the field. Position the cursor 
directly below the field that is to be wrapped and choose Field - Insert New 
Field - System Field.

You can include several overflow areas directly below each other. If you wish to 
include the line for the overflow only if it is needed, choose Section - Edit Current 
Section. This dialog box includes an option to Suppress Blank Lines that only 
prints the line with the Wrap_Overflow field if it is used.

Modifying a standard report

If you choose to modify one of the standard reports distributed with OTM, you 
will notice that there are numbers in the headers instead of text (Figure 309). 
These numbers allow the reports to translate automatically to another language. 
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Figure 309   Example Report

To see the actual text within the Form Editor, position the cursor on the octothorp 
character (#) and choose Field > View Field Translation. A box displays the text 
that appears on the printed report. 

A quick description of some section types not used in the example

Sort Footer section: Data fields placed in the Sort Footer section can be used 
like summary data in the Sort Header section. The fields in the Sort Footer section 
are only printed if the value changes (except that it prints after the detail lines). In 
addition, Sort Footer data can contain totals and other summary statistics. After 
placing a data field in the Sort Footer, you are prompted with a list that contains 
Value (to print the value from the last record in the group) or various summary 
statistics (include Total, Average, Count, Max, Min). These summary statistics 
also can be specified by choosing Field > Edit Current Field in the Footer Field 
box.
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Report Header, Report Footer: These sections can be used to specify data 
that should print only once at the beginning or the end of the report.

Power User tool

The standard OTM Station Administration window allows you to easily add or 
modify a few stations at a time. However, creating or maintaining large groups of 
stations quickly (as when establishing a new system) is better handled using the 
Power User tool. 

The Power User Forms window minimizes the actions required to add a station, 
eliminates up-front configuration of line cards and numbering plan, and allows 
you to create specialized installation forms that include only the station fields that 
you decide you need to configure stations. 

Concepts for the Power User tool

The concepts of forms, templates, and filters are important to understand before 
using the Power User tool.

Forms and templates

A form (a file that you can design) acts as a filter to determine which fields (of the 
hundreds possible) are displayed in the Power User Forms window for you to edit. 
When it’s time to use the form, you fill in the station values as needed for the first 
station, save them, and move to the form for the next station in the group that you 
are adding. You create a form file (a list of only those station-definition fields you 
want to see in the order in which you want to see them) using the Forms Editor.

Note: At any time while using the Forms window, you can press <F1> 
for online reference information on the current field.
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A template places default values in some of these fields to save you the repetitive 
task of adding the same value to station after station. You create a template file (a 
partially filled-in station) using the template view in the Station Administration 
module.

This means that a form, used in conjunction with a template, provides you with a 
station-definition window including only those fields that you want to edit, and 
with many fields already configured by the template with values of your choosing. 

To lessen clutter on the screen, the fields configured by the template do not appear. 
This means that you work with only those fields that must be “personalized” for 
this station. You do not waste time moving through already configured fields.

You view and edit these station-configuration fields in the Forms Interface 
window. 

Filters

There are hundreds of fields for a station, yet you are probably interested in only a 
few. The Form File that you define acts as a filter to allow only the fields of 
interest to appear in the forms interface station definition window. 

OTM automatically performs a second filtering to determine which of the station 
fields defined in the Form File actually apply to the current station. This 
applicability filter is based upon Meridian 1 or Succession CSE 1000 system data 
(software release, option packages, customer options), and the telephone type 
assigned to the current station. 

There are two important benefits to this applicability filter, as follows: 

• Form files are independent of systems, and, therefore, X11 software release, 
options packages, and customer options.

For example, a form file may contain fields that apply to X11 Release 20, but 
not to Release 19. You can safely use this form with Release 19 systems, since 
the Release 20 fields do not appear.

Note: The function of templates is identical in the standard Graphical 
User Interface and the Forms Interface.
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• Form Files are independent of station types

A single Form File can include both single line features (FTRs) and multi-line 
keys. If the form is used to display a single line station, then the FTRs (but not 
the keys) appear. If the same form is used to display a multi-line station, then 
the keys (but not the FTRs) appear.

Using the Power User Forms interface

You use the Forms interface to add one or many stations to a system, as described 
in this section. “Designing forms and templates using the forms editor” on 
page 648 describes the process of creating forms and templates.

Forms interface window buttons

The following buttons appear at the top of the Forms interface window: 

• OK: (Single station adds only) Saves the current station and closes the 
window.

• Next: (Multiple station adds only) Saves the current station, and opens the next 
blank station form.

• Previous: (Multiple station adds only) Saves the current station and opens the 
previously-created station.

• Cancel: Cancels any changes to the current station and closes the window. 
Any stations created before the current station while using this form are still in 
place.

• Validate: Validates all current station values.

• Print: Prints a short form for the current station. This printout shows all values 
in the station, not just those on the form. (This is a quick way for you to check 
the value of a field not on the form.)

• Help: Opens Windows Help. 

Forms interface message bar

The message bar at the bottom of the window has two panels. The left panel 
provides a description of the current field. The right panel displays hint text for the 
current field (for example, the hot keys to invoke the DN and TN lists where 
appropriate).
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Keyboard shortcuts

In the procedures that follow, keyboard shortcuts are shown in brackets. 

Adding a single station or template

1 Choose Forms > Forms Interface.

This is a toggled menu item. Click it to place a check mark next to the name 
(selects it), and click it again to remove the check mark (deselects it).

2 Choose Forms > Select Form.

The Select Form dialog box opens (Figure 310). This is a standard Windows 
file open dialog box. 

Figure 310   Select Form dialog box

3 OTM provides the following example forms for you to use in creating forms 
that meet your needs: 

• ARIESDTA.SFM: Designed for M2xxx and M3xxx data stations.

• VOICE.SFM: Designed for all types of voice stations (single and 
multi-line).

• Default form: A general-purpose form that includes most station fields. 
This is a good starting point for a form with many fields. You choose to 
use this form by selecting the Default Form check box.

4 Select the form from the list box, or select the Default Form check box. Click 
OK. 

5 Choose View > Station to add a station or select Template to add a template. 
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The existing stations (or templates) for the system appear in the OTM Station 
Administration window.

6 Choose Edit > Add. 

The Add Station dialog box (or Add Template dialog box) opens (Figure 311). 

Figure 311   Add Station dialog box

7 If you are adding stations, follow these steps:

• Enter “1” in the Number of Stations to Add field. 

• Select the Customer Number in the pull-down box.

• Choose a template or instrument. 

If you choose a template, some fields are filled in with the default values 
that you chose when designing the template.

• Click the check boxes to automatically assign DN or TN, as desired.

• Click the Phantom check box to add a virtual station, or click the Host 
Terminal check box to add a host station for the Meridian 1 Virtual Office 
Feature available on M3900 Series telephones.

8 If you are adding a template, select a template from the list (Figure 312). 
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Figure 312   Add Template dialog box

9 Click OK to open the Forms Interface window. 

The single station add form opens (Figure 313). 
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Figure 313   Single station add form

10 Fill in the fields as described in “Station fields” on page 640.

11 When you have entered all desired values, click OK.

This saves the station and closes the forms interface window.

12 For stations: If OTM is in Maintenance mode, the synchronization dialog box 
appears. Fill in the dialog box in the same way as with the standard interface. 
Click OK.

To invoke synchronization manually if you are in Installation mode, use the Sync 
menu.
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Updating a single station (or template)

1 Choose Forms > Forms Interface.

This is a toggled menu item. Click it to place a check mark next to the name 
(selects it), and click it again to remove the check mark (deselects it).

2 Choose View > Station.

(To modify a template, select Template.)

The existing stations (or templates) for the system appear in the OTM Station 
Administration window.

3 In the OTM Station Administration window, double-click the station (or 
template) of interest.

The single station add form (or the template add form) opens. 

4 Modify the fields as required.

5 Click OK.

6 For stations: If OTM is in Maintenance mode, the synchronization dialog box 
appears. Fill in the dialog box in the same way as with the standard interface. 
Click OK.

To invoke synchronization manually if you are in Installation mode, use the Sync 
menu.

Adding multiple stations

1 Choose Forms > Forms Interface.

This is a toggled menu item. Click it to place a check mark next to the name 
(selects it), and click it again to remove the check mark (deselects it).

2 Choose Forms > Select Form.

The Select Form dialog box appears. This is a standard Windows file open 
dialog box (Figure 321). 

OTM provides the following predefined forms: 

• ARIESDTA.SFM: Designed for M2xxx and M3xxx data stations

• VOICE.SFM: Designed for all types of voice stations (single and 
multi-line).
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• Default form: A general-purpose form that includes all station fields. This 
is a good starting point for a form with many fields. You choose to use this 
form by selecting the Default Form check box.

OTM provides these predefined forms as starting points for your own 
special-purpose forms. You can create forms that include just the fields 
you need, and templates that set values that you define. See “Creating a 
new form” on page 648, and “Editing an existing form” on page 650.

3 Select the form from the list box or select the Default Form check box. Click 
OK. 

4 Choose View > Station.

The existing stations for the system appear in the OTM Station 
Administration window.

5 Choose Edit > Add.

The Add Station dialog box opens. 

6 Enter the number of stations that you want to add.

7 Select the Customer Number in the drop-down box.

8 Choose a template or instrument. 

If you choose a template, some fields are filled in with the default values that 
you chose when designing the template.

9 Click the check boxes to automatically assign DN or TN, as desired.

10 Click OK to open the Forms Interface window. 

The multiple station add form opens (Figure 314). 
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Figure 314   Multiple station add form (default form)

11 Fill in the fields as described in “Station fields” on page 640.

12 When you have entered all desired values, click Next.

This saves the station and opens the next blank station form. The Next button 
changes to a Finish button while you edit the last station in the group. The 
Finish button saves the station and closes the forms interface window.

13 If OTM is in Maintenance mode, the synchronization dialog box appears. Fill 
in the dialog box in the same way as with the standard interface. Click OK.

To invoke synchronization manually if you are in Installation mode, use the 
Sync menu.
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Validating station data

You can validate by field or by station, same as the standard interface. In addition, 
you have the option to relax numbering plan and hardware validations to ease the 
process of adding multiple stations at one time.

Field validation

The current field is automatically validated when you move to another field. If the 
validation fails, an error message appears, and the focus returns to the erroneous 
field.

Station validation

In the Forms Interface window, click Validate to validate all values for the station. 
This performs the same operation as when you choose File > Validate.

Validating the numbering plan and hardware

You can relax the numbering plan and hardware validation when you choose 
Options > Mode and adjust the items in the Mode dialog box (Figure 315) as 
follows: 

• Turn off numbering plan validation. This allows you to assign a DN not 
defined in the numbering plan, without generating an error.

• Turn off hardware validation. This allows you to assign a TN for which there 
is no corresponding circuit card, without generating an error.

Note: These validation settings affect both the forms interface and the 
standard interface.
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Figure 315   Mode dialog box

Station fields

This section provides detail on the station fields that you fill in using the Forms 
Interface.

Online Help

At any time while using the Forms window, you can press <F1> for online 
reference information on the current field.

Types of station field

The following basic types of station fields can appear in the Forms Interface:

• Class of service

• Multi-line keys

• Single line features (FTRs)

• Prompts: These are all fields that do not fall into one of the above categories 
(for example, TN, NCOS, and TGAR).

Class of service field

The Class of service control appears as a CLS text box, which can contain 
multiple values (the approach taken by LD 10 and LD 11). Enter all CLS 
mnemonics for this station in the CLS text box.
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You can enter multiple mnemonics for the same class of service in the CLS text 
box (for example, CFXA and CFXD). In this case, whichever mnemonic appears 
last (furthest to the right) takes precedence. This is consistent with the operation 
of LD 10 and LD 11.

The values of some Class of service fields may not be visible on the form when it 
appears. Instead, the form shows only those classes of service that are not equal to 
default values. You can modify this partial configuration by adding new 
mnemonics or changing existing ones.

Press <Fl> while within any class of service field for a complete list of class of 
service mnemonics in Windows Help format.

Printing the class of service configuration

The Print button on the form window allows you to print a short form that shows 
the complete class of service configuration.

Multi-line keys

Keys for multi-line stations appear as drop-down boxes containing all key 
mnemonics. As you move through the list of mnemonics, the key description 
appears in the message bar at the bottom of the window. Additional parameter 
controls appear automatically if a mnemonic requires them (and for FTRs set to 
Yes).

You can also type a mnemonic directly into the box. OTM tracks your typing and 
automatically enters the first matching key (and any associated parameter 
controls).

Alternately, type the first letter of the mnemonic, followed by the down arrow key. 
The selection moves to the mnemonic starting with that letter. Press the down 
arrow key again to scroll down the list starting at that point.

Single line FTRs

FTRs appear as drop-down boxes containing the choices Yes and No. You can also 
type directly into the box. Additional parameter fields appear automatically if you 
set an FTR to Yes. When you move the cursor into a parameter field, the 
parameter description appears in the message bar at the bottom of the window. 
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Prompts

Prompt fields appear as either drop-down lists or as edit boxes, depending on the 
type of the field. Fields with a small number of predefined values appear as 
drop-down lists (for example, FCAR and DTR). Numeric fields and other fields 
with a wide range of possible values appear as edit boxes (for example, DES and 
FDN). 

DN and TN fields

DN and TN fields allow you to use lists of values to fill in the fields. In addition, 
extra fields appear as needed to allow you to enter parameter values.

TN fields

When you edit a field with a TN type value, press <Ctrl> T (or double-click in the 
field) for a list of Terminal Numbers compatible with the current station type 
(Figure 316). 

Figure 316   Terminal Numbers value list
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DN fields

In addition to station fields, you need to modify fields that are not directly 
associated with the current station, but which are associated with DNs that appear 
on the station. You can use the following DN fields in the forms interface:

• MARP

• CPND

• VMB

Press <Ctrl> D while in a DN field (or double-click in the field) for a list of 
Directory Numbers (Figure 317). In the standard interface, MARP, CPND, and 
VMB appear as buttons on the DN list dialog box. In the forms interface, MARP, 
CPND, and VMB appear as fields on the main form.

Note: DN data is applicable to stations only, not templates. Therefore, 
the MARP, CPND, and VMB controls described below appear only on a 
form when operating on stations. Templates do not actually have DNs. 
Even if a template is configured with a fully specified DN, no DN record 
will be added to the database until a station is created using the template. 
Therefore, at the time a template is created, there is no way to store any 
DN data.
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Figure 317   Directory Numbers value list

MARP

The MARP drop-down list appears below the DN field with which it is associated. 
Multiple appearance DNs can have values of Yes or No. Single appearance DNs 
can have a value of Yes. The MARP field appears below the DN field of a 
single-line station and below the following multi-line keys:

• MCN

• MCR

• PVN

• PVR

• SCN

• SCR

• HOT_L_2WAY
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• HOT_D_2WAY

CPND

The CPND name field is a single drop-down list (additional fields appear to the 
right if you choose a CPND value that requires them) (Figure 318). A CPND field 
appears below the DN field of a single line station, as well as below the following 
multi-line keys: 

• MCN

• MCR

• SCN

• SCR

You can choose one of the following values from the drop-down list:

• None: Performs no CPND operation

• Add: Creates a new CPND name (appears only if no name exists yet for the 
DN)

• Delete: Removes an existing CPND name

• Update: Modifies an existing CPND name

CPND parameter fields

As you move the cursor into a parameter field, the parameter description appears 
in the message bar at the bottom of the window (Figure 318).

Note: The following Meridian 1 releases do not support MARP; 
therefore, MARP does not appear on their forms:

• North American releases 14 and 17

• International release 16.9X G
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Figure 318   CPND parameter fields

The following parameter fields appear to the right of the CPND field when you 
choose a value other than None: 

• Get from location: Drop-down list containing Yes and No

• First name: Text box

• Last name: Text box

• Expected length: Text box. This field is only added if the name has Sync 
Status NEW, and static allocation is enabled in the CPND Administration 
module.

• Format: Drop-down list containing FIRS and LAST

• Language: Drop-down list containing ROM and KAT. This field appears only 
if package 211 (Multi-language CPND) is enabled for the system.

Some additional attributes of the name controls follow:

• If the Get From Location field is Yes, then the First Name and Last Name 
controls are dimmed and disabled, and contain the name from the First Name 
and Last Name fields of the station.

• If the operation is Delete, then the additional name controls are dimmed and 
disabled. This allows you to view the name which is to be deleted, but not to 
modify it.

Note: CPND depends on package 95 (Call Party Name Display). If 
package 95 is not enabled for a Meridian 1 or Succession CSE 1000 
system, the CPND field does not appear on the form.
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VMB

VMB appears initially as a drop-down list (additional fields appear as needed) 
(Figure 319).

Figure 319   VMB fields

A VMB appears below the DN field of a single line station, and below the 
following multi-line keys: 

• MCN

• MCR

• SCN

• SCR

The drop-down list contains the VMB operation to be performed, and allows the 
following values:

• None: Perform no VMB operation.

• Add: Create a new VMB (appears only if no VMB exists yet for the DN).

• Delete: Remove an existing VMB (appears only if a VMB does exist).

• Update: Modify an existing VMB (appears only if a VMB does exist).

If you select an operation other than None, then additional fields appear to the 
right of the VMB field. The additional fields are listed below in the order in which 
they will appear from left to right:

• Class of service (text edit field)

• Second DN (text edit field)
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• Third DN (text edit field)

• Keep messages (drop-down list containing No and Yes). This control is only 
added if the voice mailbox has Sync Status NEW.

As you select a VMB field, the description appears in the message bar at the 
bottom of the window. Additional parameter fields appear automatically if a VMB 
requires them.

If the VMB operation is Delete, then the additional fields are dimmed. This allows 
you to view the VMB that is to be deleted, but not to modify it. 

Designing forms and templates using the forms editor

The OTM application assumes that station Form Files are located in the Common 
Data subdirectory, using a “.SFM” file extension. You can, however, place these 
form files anywhere you want.

OTM provides the following predefined forms: 

• ARIESDTA.SFM: Designed for M2xxx and M3xxx data stations.

• VOICE.SFM: Designed for all types of voice stations (single and multi-line).

• Default form: A general-purpose form that includes most station fields. This 
is a good starting point for a form with many fields. Instead of selecting this 
form in the file-selection box, you select this form by selecting the Default 
Form check box.

Creating a new form

To create a form, perform the following steps:

Note: VMB depends on package 246 (Voice Mailbox Administration). If 
this package is not enabled for a Meridian 1 system, then the VMB fields 
do not appear on the form.

Note: VMB is not applicable to Succession CSE 1000 systems.
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1 Choose Forms > Forms Interface.

2 Choose Forms > Edit Custom Form.

The FormEdit window appears.

3 Choose File > New to open a new form.

The FormEdit window appears with no fields in the Form Fields list. 

Figure 320   FormEdit window for a new form

4 From the Available Fields list, select the first field you want to include in the 
form, and click Add. 

The field moves to the Form Fields list. 

Alternately, you can select one or several fields to drag from the Available 
Fields list to the Form Fields list. 

5 Move all the desired fields to the Form Fields list.

To change the order of the fields, click and drag items up or down in the list. 

To remove an item from the list, click and drag from the Form Fields list to the 
Available Fields list, or select the item and click Remove.

6 When the Form Fields includes all the desired fields in the correct order, type 
a descriptive phrase in the Form Description text box. 

This is a phrase to help you remember the form’s usage, not the filename.
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7 Choose File > Save to save the form file.

The Save As dialog box opens, allowing you to name the new form. Enter a 
filename and click OK.

Alternately, to exit the forms editor without saving the form, choose File > 
Close. A warning box asks whether you wish to save the changes before 
exiting the editor. 

Editing an existing form

To edit an existing form, follow these steps:

1 Choose Forms > Forms Interface.

2 Choose Forms > Edit Custom Form.

The FormEdit dialog box appears.

3 Choose File > Open to install a form.

The Open Form dialog box opens (Figure 321). 

Figure 321   Open Form dialog box

OTM provides the following predefined forms: 

• ARIESDTA.SFM: Designed for M2xxx and M3xxx data stations.

• VOICE.SFM: Designed for all types of voice stations (single and 
multi-line).
553-3001-330 Standard 3.00 November 2002



Station Administration 651
• Default form: A general-purpose form that includes most station fields. 
This is a good starting point for a form with many fields. You choose to 
use this form by selecting the Default Form check box.

4 Select the form from the list box. Click OK.

The FormEdit window opens (Figure 322). 

Figure 322   FormEdit window (M2xxx and M3xxx data stations)

5 From the Available Fields list, select the field you want to include in the form, 
and click Add. 

The field moves to the Form Fields list. 

Alternately, you can select one or several fields to click and drag to move from 
the Available Fields list to the Form Fields list. 

6 Move all the desired fields to the Form Fields list.

Note: The sample forms provided with OTM are a good starting point for 
customized forms that you may want to create. Be sure to rename the 
forms when you save them. Subsequent versions of OTM will use the 
default filenames, so any files you create that use the default file names 
are overwritten during the next reinstallation or upgrade.
Using Optivity Telephony Manager Release 2.0x



652 Station Administration
To change the order of the fields, click and drag the item up or down in the 
list. 

To remove an item from the list, click and drag from the Form Fields list to the 
Available Fields list, or select the item and click Remove.

7 When the Form Fields includes all the desired fields in the correct order, type 
a descriptive phrase in the Form Description text box. 

This is a phrase to help you remember the form’s usage, not the filename.

8 Choose File > Save As to save the modified form file.

Alternately, to exit the forms editor without saving the form, choose 
File > Close. A warning box prompts whether you want to save the changes 
before exiting the editor.
553-3001-330 Standard 3.00 November 2002



653
Chapter 5
Alarm management

Overview

OTM alarm management provides an alarm collection and processing center for 
multiple systems and devices. OTM receives SNMP traps from systems, such as 
Meridian 1 systems, Succession CSE 1000 systems, and Call Pilot, and stores 
them in a circular log file on the OTM Server. The OTM Alarm Notification 
application monitors the incoming traps and notifies the appropriate people of 
important events and alarms.

Alarm management components

OTM alarm management has the following components:

• A web-based alarm browser server that supports the viewing of alarms from 
multiple systems and devices. HTML Help is provided for individual alarms.

• A Windows alarm browser (Event Monitor) you use to view Meridian 1 or 
Succession CSE 1000 system specific alarms. Windows Help is provided for 
individual alarms.

• An Alarm Notification application that provides a scripting language to 
generate notifications on selected incoming traps. Notification types include 
pagers, e-mail, and the forwarding of SNMP traps to an upstream processor 
(such as Optivity NMS). Notification is triggered by trap data, such as alarm 
severity, device type, and time of day. A Script Wizard application simplifies 
the creation of Alarm Notification scripts.
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• A Text Handler application that parses maintenance TTY output and 
generates traps on selected error messages. This is intended primarily for 
legacy Meridian 1 systems (Release 21 and earlier) and Meridian Mail 
systems that cannot generate traps. Text Handler rules can be created by the 
user to support other serial devices.

• A PC Event Log and Viewer for viewing events and alarms generated on the 
OTM Server and all of its Windows clients. This Windows application can 
also generate SNMP traps based on the event severity level. 

Figure 323 shows the main components of OTM alarm management. The Trap 
Master is responsible for handling the SNMP traps from the systems and storing it 
on the server for retrieval by the Alarm Browser client. The Trap Server 
distributes traps to applications registered to receive traps, such as Alarm 
Notification.

The Trap Master and Trap Server are run as Windows NT Services on the OTM 
Server.

Figure 323   OTM alarm management main components
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Alarm management configurations

OTM is the collection point for alarms from Meridian 1 and Succession CSE 1000 
workgroup devices. It provides an integrated system view of these alarms. It also 
provides a gateway to monitor, access, and correct faults for those devices. 

You can configure OTM alarm management to met the needs of different users. 
Typically, there are three levels of administrative responsibilities:

• A single system such as the Meridian 1 or Succession CSE 1000

• Multiple systems in one or more sites

• A large network of voice and data products

The following sections provide an overview of how OTM alarm management can 
meet the needs of these different users.

System and device level management

You can configure the Meridian 1 or Succession CSE 1000 system to send SNMP 
traps to the OTM Server (X11 Release 22 and later for the Meridian 1). You can 
also configure the Meridian 1 or Succession CSE 1000 system to filter the traps 
being sent (for example, only send critical alarms to OTM). The user responsible 
for the Meridian 1 or Succession CSE 1000 system can use the OTM Windows 
Alarm Browser to see all the Meridian 1 or Succession CSE 1000 system events 
and alarms.

You can configure other Meridian products to send traps to OTM. OTM can 
recognize these traps and provide help for individual alarms. Refer to the 
respective product documentation for current software release and configuration 
procedures for the following Meridian products:

• IP Telephony Gateway (ITG)

• Call Pilot

• Symposium Call Center Server (SCCS)

• Meridian Mail 13

The user responsible for these devices can use the OTM Web Alarm Browser to 
display alarms from a single device.
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Site level management

OTM collects alarms from multiple devices in one or more sites. You can use the 
Web Alarm Browser to view all of these alarms.

Use the Alarm Notification application when critical alarms occur to identify the 
notices that are sent and to whom they are sent. Figure 324 shows devices 
transmitting alarms to the OTM Server.

Figure 324   Site alarms

Network level management

The devices represented in Optivity NMS are OTM Servers that manage 
individual Meridian 1 and Succession CSE 1000 voice elements. The OTM 
Servers are manually added to the Optivity NMS network by the administrator. 
OTM is integrated with Optivity NMS 9.0.1 and later. 

The OTM Alarm Notification application reformats, filters, and forwards traps to 
Optivity NMS. Because OTM forms the main representative agent for Meridian 1 
systems, Succession CSE 1000 systems, and related voice devices, all alarms 
received by Optivity NMS result in the change of status state of OTM depicted in 
the Optivity NMS InfoCenter. The traps are reformatted into the open alarm II 
format. Typically, only critical alarms are forwarded to Optivity NMS.
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When Optivity and OTM coreside on the same server, the OTM trap system 
disables its Trap Server and instead sends traps to the Optivity Trap Server.

Figure 325 shows alarms being forwarded from OTM Servers to Optivity NMS.

Figure 325   Network alarms
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You can configure the Optivity Telephony Manager as an object in InfoCenter, 
representing the Meridian 1 and Succession CSE 1000 systems that it manages. 
OTM-connected systems forward faults to InfoCenter. The fault color represents 
the fault status of the device.

The applications that you can open for a device depend on the settings in the 
Application Launch application. For more information on using Application 
Launch, see the Optivity NMS Application Launch online Help system.

To resolve faults on switches managed by an OTM server, launch the OTM 
application. This starts a web browser session with the OTM server. You can then 
access the web applications available on the server through the OTM Web 
Navigator.

The Path Trace feature discovers and displays the connections between resources 
in the network, including physical and logical paths, and also graphically 
identifies faults.

The Fault Summary feature displays the faults (or traps) for a single device, 
multiple devices, or the entire network. Based on the information provided, you 
can use other Optivity NMS applications to take corrective actions.

Web-based alarm management

Web-based alarm management provides a list of alarms and events from multiple 
systems and devices. 

Alarm Browser page

The Alarm Browser page is used to retrieve, view, sort, and view help on alarms 
received by the OTM Server.

Log in to the Alarm Browser

To view the alarms for all systems monitored by OTM:

1 Log in to OTM from the Administrator Login page.
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The OTM Administrator Current Status page opens.

2 Choose Equipment > System Alarms.

The Alarm Browser page opens. This page displays the alarms for all systems 
monitored by OTM.

To view the alarms for a single system monitored by OTM:

1 Log in to OTM from the Administrator Login page.

The OTM Administrator Current Status page opens.

2 Choose Equipment > System Navigator.

The System Navigator page opens. This page displays the systems managed 
by OTM.

3 Select the system for which you want to view alarms.

4 Choose Applications > Alarms.

The Alarm Browser page opens (Figure 326). This page displays the alarms 
for the selected system.

You can perform the following actions within the Alarm Browser page:

• Filter the list based on severity and system.

• Page through the list.

• Sort the alarms.

• Resize a column to see more information.

• View Help on an alarm.
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Figure 326   Alarm Browser page

The list of alarms is not dynamic. Use the OTM Alarm Browser Options dialog 
box (Figure 327) to set the auto refresh interval and select the number of alarms to 
be displayed on each page.

System Alarms table

The System Alarms table in the Alarm Browser page (Figure 326) displays six 
fields associated with each alarm entry. These fields are Time (received), Severity, 
Source, Code, Device, and Data. Click the appropriate column heading to sort the 
entries by the field of your choice. Double-click the alarm entry to display online 
Help for the alarm.
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Alarm Filter pane

Use the Alarm Filter pane in the Alarm Browser page (Figure 326) to select alarm 
severity, monitored system, and to set Alarm Browser options.

Select alarm severity and monitored system

Use the Show check boxes to select the severity of the alarms that are to be 
retrieved from the OTM Server. You may select the All check box or any 
combination of the other five check boxes. 

Use the System drop-down list to select the system to be monitored. You may 
select All to view alarms from all systems, including all the devices configured in 
the Devices.txt file.

The default selections are all systems and all alarms.

When the status of a check box is changed or a new selection is made from the 
System drop-down menu, the change is reflected in the next auto refresh or when 
the Refresh or Apply Filter buttons are clicked. The Refresh and Apply Filter 
buttons initiate a new retrieval and reset the polling timer.

Set Alarm Browser options

To set the Alarm Browser options:

1 Click Options in the Alarm Filter pane.

The Alarm Browser Options dialog box opens (Figure 327).
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Figure 327   Alarm Browser Options dialog box

2 From the drop-down list, select a refresh interval between 3 minutes and 10 
minutes. The default value is 3 minutes.

3 Enter the number of alarms you want OTM to display on each alarm browser 
page in the Alarms per page box. The number must be in the range 10–100. 
The default value is 10 alarms per page.

4 Click OK.

Alarm details

When an alarm entry is selected, the alarm information and data associated with 
the alarm appear in the Alarm details pane of the Alarm Browser page 
(Figure 326).

The left side of the Alarm details pane displays the complete information for the 
selected alarm.

Note: The Auto refresh check box in the System Alarms pane of the 
Alarm Browser page must be checked for auto refresh to occur.

Note: The settings in the Alarm Browser Options dialog box and the 
Alarm Filter pane are temporary. These settings revert to the default 
values when the browser is closed and reopened.
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The Operator data box contains all other data for the selected alarm. In addition to 
operator data, this box may include expert data and sequence number.

Status bar

The status bar at the bottom of the Alarm Browser page provides a visual 
indication that new alarms are being retrieved from the OTM Server.

Windows-based alarm management

Alarm management consists of a number of components that improve handling of 
system-generated alarms and events. On Meridian 1 systems, alarm management 
is only available for systems running X11 Release 22 or later that are configured 
with the alarm management package (296). 

The Meridian 1 and Succession CSE 1000 alarm management components are:

• Text Handler

• Alarm Banner dialog box

• Events Monitor window

Text Handler

For older Meridian 1 systems, you can use the Text Handler to parse maintenance 
TTY output and generate traps on error messages. The Text Handler is intended 
primarily for Meridian 1 systems running X11 Release 21 and earlier and for 
Meridian Mail systems that cannot generate traps. You can also use the Text 
Handler to create rules to support serial devices. The Text Handler is a part of the 
Database Buffering and Access (DBA) application. Refer to “Data Buffering and 
Access” on page 239 for details.

Note: To view information about the menus, toolbar, column headings, 
and other functions available on the Alarm browser page, use Help.
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Alarm Banner dialog box

You can determine system status by reviewing the history file to look for 
problems, and by issuing a number of status commands in various overlays to look 
for disabled or faulty hardware. The Alarm Banner dialog box automatically alerts 
you to this information in a simple, direct manner.

The Alarm Banner dialog box alerts you to new critical alarms and gives you the 
count of all new alarms. To learn more about an alarm, you can open the Events 
Monitor window. If there are no alarms, you can log out or leave the Alarm 
Banner displayed and go on to another task. 

When a new critical alarm arrives, the system beeps if the notification option has 
been set, and the Alarm Banner title bar icon and Events Monitor window task bar 
icon flash. The flashing continues until you click anywhere in the Alarm Banner 
dialog box or Events Monitor window. 

Opening the Alarm Banner dialog box

To open the Alarm Banner dialog box:

• Choose Maintenance > Alarm Banner.

• Double-click the Alarm Banner icon in the System window toolbar.

The Alarm Banner dialog box opens (Figure 328). 

Figure 328   Alarm Banner dialog box

Do one of the following:
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The items in the Alarm Banner dialog box are described in Table 30.

The Alarm Banner keeps you informed about the current status of the system. You 
might typically check the current status of the system for the following reasons:

• Standard operating procedure (for example, check every morning)

• Investigating a suspected or reported problem

• Checking and monitoring the system while performing other tasks

Alarm Banner notifications

The primary function of the Alarm Banner is to notify you when a new alarm 
arrives in the following ways:

• The outline of the boxes displaying the critical, major, and minor alarm counts 
flash to indicate the arrival of new alarms. 

• The event counts in the Alarm Banner are incremented appropriately.

• One or more beeps sound. This is optional. See “Creating an Event Preference 
definition” on page 674.

• If you have closed the Alarm Banner dialog box, the sound notification is 
provided by the Events Monitor window. The window is not brought to the 
front, because this may interfere with your current task.

Table 30   Alarm Banner dialog box items

Item Description

Critical An alarm that requires your immediate attention.

Major An alarm that needs your attention.

Minor An alarm that you can address anytime.

Close Closes the dialog box.

Events Displays more information about the events that triggered the alarms.

Note: The Events Monitor window must be active for the beep to sound.
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There is no alarm notification beep if the sound has been disabled. The count field 
outline still flashes and the count increments to indicate the arrival of a new alarm.

Events Monitor window

The Events Monitor window displays the Meridian 1 or Succession CSE 1000 
system’s Event Log, allowing you to view all recent system alarms and events 
previously stored in the Meridian 1 or Succession CSE 1000 system’s history file. 
The Events Monitor window displays active events in a way that lets you quickly 
view the most important events. System events with a severity of critical, major, or 
minor are considered alarms—alarms are events which may require some 
corrective action. System events with a severity of Info are for informational 
purposes only and are not considered alarms.

Using the Events Monitor window

Once you open the Events Monitor window, you can do the following:

• Obtain a description of an event.

• Acknowledge an alarm you intend to clear—this communicates your intention 
to others who may be working on the system.

• Locate an alarm in the Event file to identify the cause of the problem.

• Learn more detail about an alarm.

• Mark an alarm as cleared in the list after you have corrected the problem.

• Change system event preferences for all subsequent alarms:

— Severity of the alarm

— Escalation threshold for an alarm type

Opening the Events Monitor window

To open the Events Monitor window:

Note: The Event Log is preserved during and after a sysload and 
initialization of a Meridian 1 or Succession CSE 1000 system.

Choose Maintenance > Events.
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If you are not connected to a Meridian 1 or Succession CSE 1000 system, the 
connection login window appears.

Once you have connected, the Events Monitor window appears (Figure 329).

Figure 329   Events Monitor window

An event remains displayed in the list until expired by the Meridian 1 or 
Succession CSE 1000 system. The column headings identify and describe the 
events.

Sorting the event list

Alarms and events are listed in order of occurrence. You can sort the list according 
to another column by clicking in that column heading. This is useful for 
prioritizing your work when you deal with a large number of alarms.

Note: To view detailed information about the menus, toolbar, buttons, 
and other functions available in the Events Monitor window, use online 
Help.
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Click to sort in ascending order; click again for descending order. An arrow in the 
column heading indicates the current sort column and sort order.

Resizing a column in the event list

If the data does not all fit in a column, you can resize a column by dragging the 
column divider. You can also choose File > Properties to display complete 
information about a selected event.

Double-click an alarm, or click What’s This to see reference information in 
Windows Help.

New critical alarms are indicated by an icon located to the left of the word 
“Critical” in the Severity column. The icon disappears when the alarm is 
acknowledged.
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Using the shortcut menu

When you right-click an alarm, a shortcut menu opens. Table 31 describes the 
shortcut menu commands.

Event list

The event list provides information about each active alarm. You can resize a 
column by dragging the column divider to make more room for text. Table 32 
describes the event list columns. 

Table 31   Shortcut menu commands

Command Description

Copy an alarm Copies selected events to the clipboard. You can then 
insert the text into another document. Copy is 
unavailable when no text is selected.

Select All alarms Selects all events in the list. You can print the selected 
text or copy it to the clipboard and insert it into another 
document.

Acknowledge an alarm Changes the status of the selected alarm to 
Acknowledged. This informs technicians on other OTM 
systems that the problem is being investigated.

Mark as Cleared Changes the status of the selected alarm to Marked as 
Cleared. This informs users on other OTM systems 
that the problem is solved.

Learn the Properties of an alarm Displays complete information about the selected 
event.

What’s This? general help option Changes the cursor to a “question mark” cursor and 
displays help on the next item you select.

Table 32   Columns in the event list

Column Description

Severity The alarm severity (critical, major, or minor) or a non-alarm event 
(info). An icon indicates an unacknowledged critical alarm.

Sequence All events are given a unique sequence number. 

Code A code that identifies the event. It includes the error category (for 
example NWS) and a 5-digit error number.

Time The date and time that the alarm occurred.
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Determining the cause of an alarm

An alarm may be caused by another system event, such as a BUG message. By 
examining the events immediately preceding an alarm, you may be able to isolate 
the source of the problem. Use the scroll bar to browse through the event list.

To display Help on a selected alarm:

• Right-click on an alarm and choose Learn the Properties of an alarm from 
the shortcut menu.

• Double-click the alarm.

Acknowledging an alarm that you plan to clear

You can acknowledge a new alarm to inform others that you will investigate the 
problem and clear the alarm. Your acknowledgment appears in the Status column 
of the event list. The events are updated for all OTM users.

To acknowledge an alarm:

1 Select the desired alarm(s) in one of the following ways:

Status Current alarm status (appears with a dash “-” for non-alarms).

New indicates an alarm has not been acknowledged or cleared.
Acknowledged indicates an alarm in the process of being cleared.
Marked as Cleared indicates the alarm has been manually cleared.

Operator Data Data produced by the equipment that generated the event. Its 
contents may vary. Typically, it includes a description of the event and 
the equipment affected (component ID information, such as the loop 
number or TN).

Do one of the following:

Note: You cannot acknowledge, or mark as cleared, events with a status 
of Info. You cannot acknowledge alarms that have been marked as 
cleared.

Table 32   Columns in the event list (continued)

Column Description
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• Click to select a single alarm.

• [Shift]+click to select a range of alarms.

• [Ctrl]+click to select multiple alarms.

• Choose Edit > Select All to select all alarms.

2 Change the status to acknowledged in one of the following ways:

• Choose Maintenance > Acknowledge.

• Right-click and choose Acknowledge an alarm from the shortcut menu.

Once you acknowledge an alarm, the Status field for all selected alarms in the 
Events Monitor window is marked “Acknowledged.”

Marking an alarm as cleared

After you fix a problem, you typically mark the associated alarm as cleared. The 
term Mark as Cleared is used because clearing an alarm only indicates that the 
problem has been fixed—it does not actually fix the problem.

To mark an alarm as cleared:

1 Select the desired alarm(s) in one of the following ways:

• Click to select a single alarm.

• [Shift]+click to select a range of alarms.

• [Ctrl]+click to select multiple alarms.

• Choose Edit > Select All to select all alarms.

2 Change the status to acknowledged in one of the following ways:

• Choose Maintenance > Mark as Cleared.

• Right-click and choose Mark as Cleared from the shortcut menu.

Note: You can usually save time by displaying the type of alarm of 
interest using the Filter bar before selecting individual alarms.

Note: You can usually save time by displaying the type of alarm of 
interest using the Filter bar before selecting individual alarms.
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3 Click OK to confirm.

Acknowledgment and clearing of alarms is optional. You can clear alarms without 
first acknowledging them. If you do not clear alarms, the oldest alarms are deleted 
by the system when it reaches the maximum number of alarms.

When you clear an alarm, the following happens:

• The Alarm Status field for all selected alarms is updated in the System Event 
File with “Marked as Cleared.”

• The counts in the Alarm banner dialog box are adjusted appropriately for all 
users. 

Getting details about an alarm

To learn more about selected alarms:

• Choose File > Properties.

• On the toolbar, click Properties.

• Double-click on an alarm to see online Help information.

Changing alarm severity or escalation

To specify the severity of events (critical, major, minor, or info) on a per-system 
basis:

Note: Nortel Networks recommends that you clear alarms as you fix 
problems so that the Events Monitor window accurately reflects the state 
of the system. Events with a status of Info cannot be acknowledged or 
marked as cleared. Alarms that have been marked as cleared cannot be 
acknowledged.

Do one of the following:

Choose Configuration > Event Preferences.
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The system uses an Event Default Table that predefines the severity of all events. 
Typically, you modify these settings only when you install or upgrade the system. 
See “Creating and customizing event preferences” on page 674.

Viewing the Event Default Table

The Event Default Table contains the default severity settings of all system events. 
Use the table to verify default settings before you add event preferences.

To display the Event Default table:

1 Choose Configuration > Event Preferences.

2 Choose Event Default Table from the Help menu in the Event Preferences 
window.

The Event Default Table window opens (Figure 330).

Figure 330   A portion of the Event Default Table window
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Creating and customizing event preferences

You can change alarm severities for this system by changing the default alarm 
severity and escalation threshold using the Event Preferences window. The 
escalation setting defines the maximum number of times an event can occur 
within a defined period of time before it escalates to the next higher level of 
severity. For example, if you set escalation to “10 occurrences in 1 minute” for a 
minor alarm, the alarm escalates to a major alarm when it occurs more than 10 
times within a 1-minute period. See “Creating an Event Preference definition” on 
page 674 for steps describing how to set escalation parameters.

Before changing an alarm definition, you may want to look up the default settings 
in the Event Default Table. See “Viewing the Event Default Table” on page 673.

To open the Event Preferences window:

The Event Preferences window opens (Figure 331).

Figure 331   Event Preferences window

Creating an Event Preference definition

1 Choose Configuration > Add Event Preference.

Choose Configuration > Event Preferences.
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The Event Preference dialog box opens with the General tab displayed 
(Figure 332).

Figure 332   Event Preference Properties dialog box—General tab
 

2 In the Code field, type the alarm or event ID.

The ID includes the event category, such as BUG, or NWS, and the 5-digit 
event number.

You may use the wildcard symbol ? to represent a group of error code 
numbers. For example, NWS3?? represents all error codes between NWS300 
and NWS399.

3 To change the alarm severity, from the severity list, choose a severity type.
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4 To change the escalation threshold, check the Escalate box, and type a number 
in the Escalation field.

The escalation setting defines the maximum number of times an event can 
occur within a defined period of time before it escalates to the next higher 
level of severity. This defined period of time is determined by the Meridian 1 
or Succession CSE 1000 system’s Global Window Timer. For example, if you 
set escalation to “10 occurrences in 1 minute” for a minor alarm, the alarm 
escalates to a major alarm when it occurs more than 10 times within a 
1-minute period.

5 Click OK.

Configuring alarms on the Meridian 1 or Succession 
CSE 1000 system

The Events Monitor window displays the events stored in the Meridian 1 or 
Succession CSE 1000 system’s Event Log. To display the system’s events in the 
OTM web-based Alarm Browser, you must enable the open alarms feature in 
LD 117. You may also want to suppress minor and informational alarms going to 
the OTM Server.

Enabling Meridian 1 system alarms with LD 117

To enable alarms with LD 117:

1 In the OTM system window, on the toolbar, click the System Terminal icon.

The System Terminal Selection dialog box opens.

2 Click Ethernet/PPP (Overlay Passthru), and then click OK.

The System Terminal window opens.

3 Log in with your administrator’s user name and password. 

You must have appropriate access privileges to use LD 117.

Note:  The Global Window Timer is set in Overlay 117 and can range 
from 0–60 minutes. In this example, the Global Window Timer is set to 
1 minute.
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4 Enter:
ld 117

The => prompt appears in the Command Results pane indicating that the 
system terminal application is ready to accept your input.

5 Enter:
prt open_alarm

A list of slots currently in use appears. Slots are numbered from 0–7, for a 
total of 8 available slots. Note the number of the next available slot.

6 Enter:
set open_alarm <n> <IP_address>

where n is the next available slot number, and IP_address is the IP 
address of your OTM Server. See “Determining the OTM PC’s IP address” on 
page 678 for more information.

7 Enter:
prt open_alarm.

The list of slots and IP addresses receiving alarms appears. Verify that your 
particular slot and IP address are included.

8 Enter:
prt suppress
prt suppress_alarm

This shows the current alarm suppression settings.

9 Enter:
chg suppress_alarm <n>

This sets the alarm suppression, where n is 0 = All, 1 = Minor, 2 = Major, 
3 = Critical. For example, to suppress all alarms except critical, enter 3.

Caution: If you assign your IP address to a slot currently in use, you 
disconnect the current user from the system, and prevent them from 
receiving alarm information.

Note: LD 117 accepts abbreviations of the various commands. For 
example, you can type the abbreviation prt op instead of 
prt open_alarm.
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10 Enter:
prt suppress
prt suppress_alarm

This allows you to verify the changes. 

11 Enter:
prt timer

This allows you to view the Global Window Timer setting.The escalation and 
suppression thresholds are based on the Global Window Timer. The default 
value is one minute. To change the timer, enter chg timer <n>, where n 
is 0–60 minutes.

12 Log out and close the system terminal window.

Determining the OTM PC’s IP address

To find your PC’s IP address:

1 From the Windows Start menu, choose Settings > Control Panel.

The Control Panel window opens. 

2 Double-click Network. 

The Network dialog box opens with the Configuration tab displayed.

3 Select the TCP/IP network component used by your PC.

4 Click Properties.

The TCP/IP dialog box opens with the IP address tab displayed. 

5 Note the IP address shown.

This is the IP address unique to this PC. Enter this information in LD 117 to 
specify where the alarm event will be received. 
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Sample LD 117 session

The following is a representative sample of a system terminal session using 
LD 117 to enable alarms. In this example, the OTM PC that will receive alarms 
has the IP address 47.82.40.6. Slots 0 and 1 are already in use by other PCs. Use 
the next available slot 2 to enter the new OTM PC IP address. Note the => prompt 
used by the overlay. All IP addresses are for example purposes only. Additional 
information about LD 117 is available in the online Help.

login admin1
PASS?
WARNING: THE PROGRAMS AND DATA STORED ON THIS SYSTEM ARE LICENSED 
TO OR ARE THE PROPERTY OF NT/BNR AND ARE LAWFULLY AVAILABLE ONLY TO 
AUTHORIZED USERS FOR APPROVED PURPOSES. UNAUTHORIZED ACCESS TO ANY 
PROGRAM OR DATA ON SYSTEM IS NOT PERMITTED. THIS SYSTEM MAY BE 
MONITORED AT ANY TIME FOR OPERATIONAL REASONS. THEREFORE, IF YOU 
ARE NOT AN AUTHORIZED USER, DO NOT ATTEMPT TO LOGIN. 
BSD000 
.ld 117
OAM000
=> prt open_alarm
Open Alarm destination #0 is 47.82.40.237
Open Alarm destination #1 is 47.82.40.119
=> set open_alarm 2 47.82.40.6
=> prt op
Open Alarm destination #0 is 47.82.40.237
Open Alarm destination #1 is 47.82.40.119
Open Alarm destination #2 is 47.82.40.6

Alarm Notification application

The Alarm Notification application uses the existing OTM architecture to connect 
to Meridian 1 systems, Succession CSE 1000 systems, and other supported 
systems and equipment that can generate SNMP events, to detect specified events. 
For Meridian 1 and Succession CSE 1000 systems, the SNMP Open Alarms 
package (315) must be present and activated, along with the packages required for 
OTM.
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OTM alarm notification process

The Alarm Notification application receives SNMP events from designated 
network equipment over an Ethernet network and sends out alarm notifications 
when specified event conditions are detected. Received events are compared to a 
set of rules which may activate notifications of different types. These notifications 
include the following:

• SNMP traps or events transmitted to predefined destinations

• Text notification over a modem

• Pager notification to alpha or numeric pagers

• Electronic mail using Simple Mail Transfer Protocol (SMTP)

• Log

SNMP events appear at the OTM PC in the Alarm Notification window. You can 
also view events with a web browser connected to a configured web server. When 
the application starts, three application control files are loaded: a devices file, a 
configuration file, and a scripts file.

The devices file specifies the SNMP devices to be monitored. You must define the 
devices file before you can start alarm monitoring. A sample devices file, 
Devices.txt, is provided in the OTM directory.

The configuration file defines the event information (SNMP traps) that may be 
received. The file should contain definitions for all SNMP traps that may be sent 
by devices specified in the devices file. Event values are mapped to variable 
names, which you may use in the scripts file. You must define the configuration 
file before you can start alarm monitoring. A sample configuration file, Config.txt, 
is provided in the OTM directory.

Note: The log is not an alarm notification but is included because it 
describes system events.

Note: These control files must be present and configured for the Alarm 
Notification application to work correctly. See “Setting up alarm 
notification” on page 683.
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The scripts file defines how alarms are processed and which notifications are used.

Figure 333 shows a functional overview of the Alarm Notification application.

Figure 333   Overview of Alarm Notification application

A scripting language is included within the application to allow you to define 
alarm processing and notifications. An external text editor is required to create 
scripts.

Use the scripting language to define the following:

• How to process events

• New responses and notifications to predefined events

Note: Events from undefined devices are ignored.

Control files:
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Opening the Alarm Notification window

To access the Alarm Notification window:

The Alarm Notification window opens (Figure 335).

Figure 334   Welcome to Alarm Notification dialog box

The Alarm Notification window opens (Figure 335).

or

The online Help for setting up the control files opens (Figure 336).

Choose Utilities > Alarm Notification.

Note: The first time you start the Alarm Notification application, the 
welcome dialog box opens (Figure 334). Subsequent sessions do not 
display this dialog box.

Click Continue.

Click Help.
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Figure 335   Alarm Notification window

The top pane of the Alarm Notification window, the Network Events browser, 
displays all events received since starting the application. The bottom pane, called 
the console, displays notifications defined in the script sent to con.

To view information about the menus, toolbar, column headings, window panes, 
and other functions available in the Alarm Notification window, use Help.

You use the Alarm Notification window to do the following:

• Start, stop, and restart alarm processing.

• Specify the control files used by the application.

• View events as they are received from defined systems and devices.

• View script and notification output in the console as they are received.

• View received events.

Setting up alarm notification

Before alarm notification can function correctly, you must set up control files. 
Control files include the devices file, the configuration file, and the scripts file.

Console
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Network
event
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Filter toolbar
Toolbar

Menu bar
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To set up alarm notification, complete the following tasks:

• Make sure you have the control files correctly installed and the Run Options 
defined. See “Setting up a devices file” on page 685 for more information.

• Determine the IP address of your OTM PC on which you will view the events. 
This PC must have Alarm Notification correctly installed. The PC must be 
networked with the system to be monitored. See “Determining the OTM PC’s 
IP address” on page 678 for information on determining the IP address.

• Use LD 117 to enable alarms to be sent to your OTM PC. See “Enabling 
Meridian 1 system alarms with LD 117” on page 676.

Installing Alarm Notification control files

Make sure you have the control files correctly installed. Control files define which 
systems are monitored and which events are processed. For detailed instructions 
about defining Run Options, consult the online Help (Figure 336).

Figure 336   Help for setting up control files
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Setting up a devices file

The devices file contains the list of monitored systems. SNMP traps that a device 
sends must be defined in the configuration control file. You can add reference 
information to monitored systems specifying the following:

• The IP address of the system or its system name

• An alias for any system name or IP address

See Appendix C, “Control files included with alarm notification,” for more 
information about the contents of the devices file.

To set up a devices file:

1 In the Windows Explorer, rename a copy of the sample Devices.txt file, 
located in the OTM directory:

X:\Nortel\Common Data\Alarm Notification\Control Files

For example, the new filename might be my_devices. 

2 In the Alarm Notification application, choose Configuration > Run Options.

The Alarm Notification Run Options dialog box opens with the General tab 
displayed.

3 Click the Control Files tab (Figure 337).

Note: Within the Alarm Notification application, you can reference 
systems by the specified alias.

Caution: Do not work directly in the sample Devices.txt file. This file is 
overwritten when OTM is reinstalled or upgraded and any changes will 
be lost.
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Figure 337   Alarm Notification Run Options window—Control Files tab
 

4 Next to the Devices field, click Browse.

The Open dialog box opens.

5 Find and select the new devices file, and then click Open. 

6 Replace the IP address following “Meridian1” with the IP address of your 
Meridian 1 or Succession CSE 1000 system.

You may also provide an alias.

7 For each additional Meridian 1 or Succession CSE 1000 system or 
non-Meridian device to be monitored, enter a device type name, an IP address, 
and (optionally) an alias.

• Device type represents the type of device (for example, XYZrouter). You 
use this name in the configuration file to identify SNMP traps.

• IP address or PC host file name. If the PC host file is used, the address is 
obtained from the PC host file.

• Aliases are alternate names you can define that identify each device 
within the Alarm Notification window.
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8 Save the file as text and close the window.

Example of device file entries listing monitored Meridian 1 systems:

Meridian1 147.114.45.6 nmkpy716
Meridian1 147.114.45.4 
Meridian1 nmkpy711 myM1

Setting up a configuration file

A sample configuration file for Meridian 1 or Succession CSE 1000 systems is 
provided. Complete the following procedure only if you want to monitor 
additional devices, such as routers or printers. Otherwise, you may skip this 
procedure. See Appendix C, “Control files included with alarm notification,” for 
more information about the contents of the configuration file.

To set up a configuration file:

1 In the Windows Explorer, rename a copy of the sample Config.txt file, located 
in the OTM directory:

X:\Nortel\Common Data\Alarm Notification\Control Files

For example, the new filename might be my_config. 

2 In the Alarm Notification application, choose Configuration > Run Options.

The Alarm Notification Run Options dialog box opens with the General tab 
displayed.

3 Click the Control Files tab (Figure 337 on page 686).

4 Next to the Configuration field, click Browse.

The Open dialog box appears.

Note: Keep a backup copy of your devices file on your local drive.

Caution: Do not work directly in the sample Config.txt file. This file is 
overwritten when OTM is reinstalled or upgraded, and any changes will 
be lost.
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5 Find and select the new configuration file, and then click Open.

6 To add a new SNMP trap, type the word device followed by the device name 
(as defined in the devices file), followed by the major and minor trap types 
associated with the device (refer to the device manual), or the appropriate 
SNMP MIB.

7 Below the device name, enter the following information for each event to be 
monitored on the device:

• Object identifier associated with the event (refer to the device manual to 
find this information).

• Variable type (only “integer” and “string” are supported).

• Variable name (you use the variable name to refer to this event in 
notification scripts).

• Event name (in quotations). This name identifies the event in the Alarm 
Notification window.

See “Example of configuration file entries for Meridian 1 systems:” on 
page 689.

You may use the standard Meridian 1 and Succession CSE 1000 system 
event definitions (variable type, variable name, and event name) to define 
similar variables for non-Meridian devices. The standard Meridian event 
names map the event values to corresponding fields within the Alarm 
Notification window and Event Properties sheet. If non-standard 
definitions are used, event information appears in the Additional 
Information field.

8 Repeat steps 6 and 7 for each non-Meridian 1 or Succession CSE 1000 device 
to be monitored.

9 Save the file as text and close the window.

The following example shows the standard configuration file to process 
Meridian 1 and Succession CSE 1000 system events. Modify this file to add other 
systems to be managed. Users should be familiar with scripting logic and 
programming principles to effectively use and extend this application’s 
capabilities. 
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Example of configuration file entries for Meridian 1 systems:

device Meridian1 6.10 {
1.3.6.1.4.1.562.3.3.7.1.0 integer $CurrentAlarmSeqNum
1.3.6.1.4.1.562.3.3.7.2.0 string $CurrentAlarmTime
1.3.6.1.4.1.562.3.3.7.3.0 integer $CurrentAlarmSeverity "Severity"
1.3.6.1.4.1.562.3.3.7.4.0 string $CurrentAlarmErrorCode "Error Code"
1.3.6.1.4.1.562.3.3.7.5.0 string $CurrentAlarmComponentId
1.3.6.1.4.1.562.3.3.7.6.0 string $CurrentAlarmComponentAddress
1.3.6.1.4.1.562.3.3.7.7.0 string $CurrentAlarmDescriptiveText "Text"
1.3.6.1.4.1.562.3.3.7.8.0 string $CurrentAlarmOperatorData "OperatorData"
1.3.6.1.4.1.562.3.3.7.9.0 string $CurrentAlarmExpertData "Expert Data"
1.3.6.1.4.1.562.3.3.7.10.0string $CurrentAlarmCounts
}

Contained in the configuration file is a set of SNMP trap definitions, each 
followed by a list of the monitored devices of that type. Each trap definition 
begins with the word device, followed by the device name, and followed by a list 
of variables for the defined trap. For the example above, the designated name is 
Meridian 1, and the trap number is 10. 

The next lines contain SNMP object identifiers, followed by a variable type, and 
followed by a variable name and an optional printable name in quotes. The 
variable name may be referenced in the scripting language and the printable name 
appears in the Network Event browser pane in the Alarm Notification window.

Setting up a scripts file

The scripts file defines alarm processing and notification. A sample scripts file is 
provided, which you can modify. See Appendix C, “Control files included with 
alarm notification,” for more information about the contents of the scripts file.

To set up a scripts file:

1 In the Windows Explorer, rename a copy of the sample Scripts.txt file, located 
in the OTM directory:

X:\Nortel\Common Data\Alarm Notification\Control Files

Note: Only integer and string values are supported in the device 
definition entries.
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For example, the new filename might be my_scripts. 

2 In the Alarm Notification application, choose Configuration > Run Options.

The Alarm Notification Run Options dialog box opens with the General tab 
displayed.

3 Click the Control Files tab (Figure 337 on page 686).

4 Next to the Scripts field, click Browse.

The Open dialog box appears.

5 Find and select the new scripts file, and click Open.

6 Use the sample script as a guide to create your own notification script file.

For an example of scripts files, see “Sample Alarm Notification scripts” on 
page 725, and Appendix C, “Control files included with alarm notification.”

7 Save the file as text and close the window.

A script includes variables, rules, notifications, functions and logical expressions 
that evaluate and may apply to event data. See “Scripting” on page 692. Values 
defined within a script are exclusive and visible only to that script. The script 
container is delimited by “curly” brackets {}. You can define global values that 
are visible to all scripts.

When the Alarm Notification application starts, each script is executed in the 
order defined in the script file.

Setting up auto-start for scripts

Once the control files are defined, use the following procedure to automatically 
load the scripts when you start the Alarm Notification application:

1 In the Alarm Notification application, choose Configuration > Run Options.

The Alarm Notification Run Options dialog box opens with the General tab 
displayed.

Caution: Do not work directly in the sample Scripts.txt file. This file is 
overwritten when OTM is reinstalled or upgraded, and any changes will 
be lost.
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2 Click the box marked “Auto-start scripts on program launch.”

The scripts are automatically loaded each time that you start the application.

Events processing

Events received appear in the network event pane. As each event is received, it is 
placed in a queue for processing by the application. Each event is checked to see if 
it originates from a defined system or supported equipment. Events received from 
undefined systems devices are ignored and discarded from the queue.

The application executes every applicable script for each specific event type. If a 
rule is matched to an event type, the output appears in the Alarm Notification 
window console pane or is sent as one of the other available notification types (for 
example, e-mail or pager), according to the script. Output to the console pane 
occurs immediately, but notifications are written to disk.

The notification process periodically polls the notifications and sends them to the 
specific device or function for this notification type. If directed by the script, 
results of the notification appear in the console pane. If a failure occurs due to 
power interruption or software or hardware error, the unprocessed notifications 
are completed on restart.

Viewing event properties

The Alarm Notification application receives events from many different systems 
and devices. Each event source may have different characteristics requiring you to 
enter different information to fully define an event source. You can identify the 
event source in the Event Properties dialog box. 

To view event properties:

1 In the network event pane, select an event.

2 Click Properties.

The Event Properties dialog box opens with the General tab displayed. 
(Figure 338)
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Figure 338   Event Properties dialog box—General tab
 

For information on the fields in the Event Properties dialog box, refer to online 
Help. 

The Alarm Notification application processes events you have defined in the 
configuration file from specific systems or devices you have defined in the devices 
file. Events from undefined systems or devices are ignored.

Scripting

Scripting is the process of using the syntax of the programming language in the 
Alarm Notification application to create text files specifying that certain actions 
be taken for defined events. A script includes one or more logical expressions that 
evaluate event data and provide notification instructions. The script file may 
contain many scripts. When the Alarm Notification application starts, all scripts 
are run against each new event as it is received. 

Scripts are run in the order defined in the script file. To cause a script to be 
skipped when it is not applicable, use the when operator. You must be familiar 
with scripting logic and programming principles to effectively use and extend this 
application’s capabilities.

Note: The Event Properties dialog box is optimized for Meridian 1 and 
Succession CSE 1000 system events.
553-3001-330 Standard 3.00 November 2002



Alarm management 693
Scripting syntax includes the following:

• Data types

• Referencing variable names from Config.txt

• Scripts

• Operators

• Notifications

• Conditional expressions

• Rules

• Comments

• Functions

The syntax is described in the following sections. Consult the online Help for 
specific examples of scripting syntax.

Variable types

The scripting language supports three variable types: counter, timer, and string. 
The names of these variables must begin with an alpha character and may be of 
any length.

Counter

Counters contain signed integer values. You may assign values to counters when 
you define them, and you may include multiple variables of the same data type in 
the same statement. Counters can be global to a script or local to a function.

Syntax:
counter variable_name:=0;

Note: The indentations in the examples presented in this section 
facilitate reading the script and do not affect how the script is interpreted 
by the application.

Note: Variables are case sensitive.
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Example:
counter n;
n:=n+1;
if(n=5)
{
.../*Send notification*/
}

Timer

Timers are counters that are automatically incremented when the time changes. 
Default timers increment once every minute. You may define specific update 
intervals other than the default increment. Timers cannot be defined in a function; 
they must be used globally in a script.

Syntax:
timer variable_name;

Example:
script SampleScript {

/*Notification Counters definition*/
counter count_ns_Meridian1:=0;

/*Notification Timer definition*/
timer time_Meridian1;

..........

if(time_Meridian1>3) /*i.e. after 3 minutes*/
{
.../*Send notification*/

}
}

String

Strings contain arbitrary alphanumeric data. A default string contains up to 80 
characters. If more data is placed in a string than the string definition allows, the 
application truncates the entry.
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Syntax:
string variable_name;

Example:
string severity;
if(severity="critical")
{

.../*Send notification*/
}

Referencing variable names from Config.txt

Alarm Notification processes events of a specified type from specified devices. 
These events are SNMP traps. Values contained in SNMP traps are mapped to 
variables that are referenced in Alarm Notification scripts. All relevant variables 
are updated with each incoming event.

Table 33 lists the four variables that are defined for all incoming events.

The configuration file Config.txt contains a device definition for each type of 
device that is monitored by OTM. The Devices.txt file contains a list of monitored 
devices. All events from undefined devices are ignored. See “Defining devices in 
Devices.txt” on page 697.

Note: Longer or shorter strings may be explicitly specified and 
initialized as follows:
string more_stuff[255]:=”Alarm Notification”;

Table 33   Variables included in all incoming events

Name Type Contents

$CurrentTrapSource string Name or IP address of the event source

$CurrentTrapDevice string Name of the device as defined in the 
configuration file

$CurrentTrapMajor string Major trap type

$CurrentTrapMinor string Minor trap type
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The following example shows the standard configuration information required to 
process events from Meridian 1 systems as contained in the Config.txt file:

Config.txt example:
device Meridian1 6.10 {
   1.3.6.1.4.1.562.3.3.7.1.0  integer       $AlarmSeqNum            "Alarm Seq Num"
   1.3.6.1.4.1.562.3.3.7.2.0  string        $DeviceTime             "Device Time"
   1.3.6.1.4.1.562.3.3.7.3.0  integer       $Severity               "Severity"
   1.3.6.1.4.1.562.3.3.7.4.0  string        $ErrorCode              "Error Code"
   1.3.6.1.4.1.562.3.3.7.5.0  string        $SystemComponent        "System Component"
   1.3.6.1.4.1.562.3.3.7.6.0  string        $ComponentAddress       "Component Address"
   1.3.6.1.4.1.562.3.3.7.7.0  string        $Text                   "Text"
   1.3.6.1.4.1.562.3.3.7.8.0  string        $OperatorData           "Operator Data"
   1.3.6.1.4.1.562.3.3.7.9.0  string        $ExpertData             "Expert Data"
   1.3.6.1.4.1.562.3.3.7.10.0 string        $CurrentAlarmCounts
}

Each device definition begins with the word device followed by the device name 
and a list of SNMP traps allowed from the device. The first column contains 
SNMP object identifiers. The second column gives the variable type; only integer 
and string type variables are permitted. The third column lists the variable name, 
and the fourth column provides the optional printable name of the variable. The 
printable name appears in quotes. The variable name is referenced in the scripting 
language while the printable name appears in the Alarm Notification window and 
Alarm browser.

In the following example, the variables $ErrorCode, $DeviceTime, $Text, and 
$OperatorData are referenced from the Config.txt file. $CurrentTrapSource 
is a variable that is defined for all events (Table 33 on page 695).

Example:
send(con,

"--> Critical Meridian1 alarm received!".
$ErrorCode,"-", //M1 error code
$CurrentTrapSource,"-", //Name of this M1
$DeviceTime,"-", //Timestamp from M1
$Text,"-", //Text with error message
$OperatorData //More text with error message

);

You may add definitions to the Config.txt file for non-Nortel Networks devices; 
however, you should not attempt to modify the definitions associated with the 
Nortel Networks devices provided in this file.
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To view the entire contents of the Config.txt file, see “Configuration file” on 
page C-3 of Appendix C, “Control files included with alarm notification.”

Defining devices in Devices.txt

The Devices.txt file contains a list of the devices to be monitored. For each device, 
list the device type as it appears in the Config.txt file, followed by the IP address 
or host name of the device. You may also include an alias for the device. If an alias 
is defined for the device, the device is referenced using the specified alias in the 
Alarm Notification application.

Examples:
Meridian1 192.9.200.1
CALL_PILOT sample_cp
Meridian1 192.9.200.2 Toronto_11C

To view the contents of the Devices.txt file, see “Devices file” on page C-2 of 
Appendix C, “Control files included with alarm notification.”

Scripts

A script is a container for variables, rules, notifications, and functions. Anything 
that is defined within a script is only visible in that script. Variables, rules, 
notifications, and functions may also be defined outside of scripts. These are 
known as global definitions. Global definitions are available to be used in all 
scripts. If a definition with the same name as a global definition exists within a 
script, the script definition takes precedence over the global definition for the 
given script.

At run time, each script is executed in the order in which it is defined.

Example:
script example1 {
}

To skip non-applicable scripts, use the “when” operator. In the following example, 
the code declared within example2 only executes if the incoming event is from a 
device that is defined as being a Meridian 1.
Using Optivity Telephony Manager Release 2.0x



698 Alarm management
Example:
script example2 when ($CurrentTrapDevice=”Meridian1”){
}

Operators

Scripts usually contain a logical expression for testing event data. Logical 
expressions support operators that you can use in any combination. Use 
parentheses to clarify the order of operations. 

The Alarm Notification application supports the operators described in Table 34.

Example:
counter n;
if(

(($CurrentTrapSource="164.164.8.99") or ($CurrentTrapSource="164.164.8.98"))
and ($CurrentTrapDevice="Meridian1") and (($NormalizedSeverity=Critical))

){
n:=n+1;
if(n=3)

{
.../*Send notification*/

}
}

Table 34   Operators

Operator Description

+, -, *, / Addition, subtraction, multiplication, division

<, <= Less than, less than or equal

>, >= Greater than, greater than or equal

=, != Equal, not equal

<> Contains (look for substrings)

and, or Logical and, logical or (case sensitive)

:= Assigns a value to a variable. The data types must agree or a compiler 
error will result when the script is executed. If a value is assigned to a 
string value, the string must be declared large enough to contain the 
new value.

Note: The logical operators “and” and “or” are case sensitive.
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For additional examples of how these operators are used, see “Sample Alarm 
Notification scripts” on page 725, and Appendix C, “Control files included with 
alarm notification.”

Conditional expressions

The following section describes the conditional expressions that are available for 
use in Alarm Notification scripts.

if / else

The if and else expressions can be used with both arithmetic and logical operators.

Syntax:
.
.
if (condition A){
...
}
else
}
.
.

Example:
if($CurrentTrapDevice=”Meridian1” or $CurrentTrapDevice=”CALL_SERVER”){

convertit(); //Any function
}

The following is an example using conditional expressions that is not allowed:
if (condition A){
...
}
else if (condition B){
...
}
else {
...
}
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Instead, use the following:
if (condition A){
...
}
else {

if (condition B){
...
}
else {
...
}

}

The do while loop

The do while loop can only be used inside a function.

Syntax:
do{
...
} while (Condition);

Example:
.
.
counter c;
do{

send(con,
“--> Critical Meridian1 alarm received! ”,
$ErrorCode,” - ”, //M1 error code
$CurrentPCTime,” - ”, //Time that PC received the alarm
$CurrentTrapSource,” - ”, //Name of this M1
$DeviceTime,” - ”, //Timestamp from M1
$Text,” - ”, //Text with error message
$OperatorData //More text with error message

);
c:=c+1

} while (c<3); //Send any (in this case to console) three times
.
.

The for loop

The for loop can only be used inside a function.

Syntax:
for(count:=0;count<n;count:=count+1){
...
}
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Example:
.
.
counter c:=0;
for(c:=0; count<2; c:=c+1){
send(OtmOpenAlarm1,
"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0", "Integer",     $NameSpace,           // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code
"1.3.6.1.4.1.562.50.1.2.6.0", "OctetString", $Site,                // Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", $System,              // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $OriginatingAgent,    // Originating Agent
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $ExpertData,          // Problem Isolation Data2
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $Text                 // Problem Isolation Data3
);

} //Send any notification (in this case a trap) twice
.
.

The when construct

Use the when construct to skip a script when it is not applicable.

Syntax:
script convert when (condition){

function convertit(){
...
}
rule conversion {
...
}

Example:
script convertM1Severities when ($CurrentTrapDevice="Meridian1" or $CurrentTrapDevice=”CALL_SERVER”)
{

function convertit()
{

if ($Severity=1)
{

$NormalizedSeverity:=Minor;
}
else
{

if ($Severity=2)
{

$NormalizedSeverity:=Major;
}
else
{

if ($Severity=3)
{

$NormalizedSeverity:=Critical;
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}
else
{

if ($Severity=4)
{

$NormalizedSeverity:=Unknown;
}
else
{

if ($Severity=5)
{

$NormalizedSeverity:=Warning;
}
else
{

if ($Severity=6)
{

$NormalizedSeverity:=Cleared;
}
else
{

if ($Severity=7)
{

$NormalizedSeverity:=Undetermined;
}
else
{

$NormalizedSeverity:=Info;
}

}
}

}
}

}
}

}

rule severity_conversion {
if ($CurrentTrapDevice="Meridian1" or $CurrentTrapDevice=”CALL_SERVER”)
{

convertit();
}

}

} // end script convertM1Severities

Notifications

Notifications define the message text and the means by which it is conveyed. The 
Alarm Notification application supports the notification types shown in Table 35.

Table 35   Notification types

Name Definition

console Sends output to the console pane in the Alarm Notification window. 
This type of notification is the simplest and contains no fields. 

npager, apager Sends messages to numeric (npager) or alphanumeric (apager) 
pagers.
553-3001-330 Standard 3.00 November 2002



Alarm management 703
Notification types

All notification types except console accept the days and times fields. The days 
field may contain a quoted list of valid days, for example, Sunday, Monday, 
Tuesday, Wednesday, Thursday, Friday, Saturday, or a range of valid days, for 
example, Sunday-Saturday. You may specify different destinations depending on 
the current day, date, time, or alarm notification type.

Use the send syntax to direct Alarm Notification to deliver six types of 
notifications:

• Console

• Pager

• E-mail

• Text (over modem)

• SNMP

• Log file

Console

The console notification type displays a notification in the console pane in the 
Alarm Notification window. No parameters are required. A default console 
notification, con, is provided.

email Sends an e-mail message to a remote system using Simple Mail 
Transfer Protocol (SMTP). For e-mail to work correctly, an 
SMTP-capable host must be accessible to the OTM PC. 

modem (text) Sends message text from the OTM PC to a remote system, such as 
an alarm collection management workstation through an attached 
modem. To use this feature, a modem and a phone line must be 
connected, supported, and available. If the destination is busy, the 
Alarm Notification application retries later or sends the message to an 
alternate destination. Use the Alarm Notification Run Options dialog 
box to define additional actions.

snmp Sends SNMP traps to a remote system.

file Saves the output to disk as a text file.

Table 35   Notification types (continued)

Name Definition
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Example: 

// (no definition necessary)
.
.
.
// send a console notification
if($CurrentTrapDevice=”Meridian1” and $NormalizedSeverity=Critical){

//Print event to console
send(con,"--> Critical Meridian1 alarm received!",
 $ErrorCode," - ", // M1 error code
$CurrentPCTime," - ", // Time that PC received the alarm
$CurrentTrapSource," - " , // Name of this M1

 $DeviceTime," - " , // Timestamp from M1
 $Text," - ", // Text with error message
 $OperatorData);         // More text with error message

);
}

Pager

Alarm Notification supports both alphanumeric and numeric pagers. You define 
the list of paging destinations and supported functionality for each pager. Be sure 
you have a modem and a valid phone line connection. Messages must match the 
pager type: up to 30 characters for alphanumeric pagers and only digits for 
numeric pagers.

Mandatory parameters are:

• phone:="408-555-1212";

The phone number you dial to connect to your pager service.

• pin:="123456"; 

The alpha numeric pager’s PIN number, for the type “apager” only.

Note: This script displays the text “--> Critical Meridian1 alarm 
received!” followed by the values for the listed traps, which includes the 
error code, the current PC time, name of the M1, time when the alarm 
occurred, text associated with the error code, and the Operator data. Note 
the use of con with the send syntax in the script.
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Examples:

The first example shows a script defined to call an alphanumeric pager named 
“my_pager” only on Monday and Thursday through Saturday, from 9:00 a.m. to 
5:00 p.m. The PIN and the pager service number are specified. Note that the 
number needed to access an external phone line (9) is included. The second 
example shows a script defined to call a numeric pager named “numeric_pager” 
only on Tuesdays and Wednesdays from 9:00 a.m. to 5:00 p.m. In this example, a 
PIN is not required.

/* Alphanumeric pager notification definition */
notification apager my_pager
{
   days:="monday,thursday-saturday";
   times:="9am-5pm";
   pin:="123456";
   phone:="9,408-555-1212";
}
.
.
.
// Send an alphanumeric pager notification
send(my_pager,

$CurrentTrapSource,":",severity_level," ",$CurrentTrapMajor,".",$CurrentTrapMinor);

/* Numeric pager notification definition */
notification npager numeric_pager
{

days:="tuesday-wednesday";
times:="9am-5pm";
phone:="9,555-555-5555";

}
.
.
.
//Send a numeric pager notification
send(numeric_pager,"5554321"); /* 2nd parameter is the telephone number that the 
person who is paged should call */

E-mail

You can write a message that the application sends to a specified list of recipients. 
The application uses Simple Mail Transfer Protocol (SMTP) to send the message. 
To make this notification type work correctly, you must have an SMTP-capable 
host connected and accessible to the OTM PC. You must configure the host in 
OTM before activating this feature. Each send statement is treated as a separate 
e-mail message.
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E-mail messages coming from Alarm Notification are sent with “OTM” as the 
sender. The receiving e-mail program may try to match OTM with a 
corresponding local user account and display the closest match in the e-mail’s 
header. Although the header information may not be accurate due to mismatches 
between the term “OTM” and the local user account information, the e-mail 
message still appears as defined by the notification.

Mandatory parameters are:

• from:="OTM";

The sender’s valid e-mail address.

• address:="support@tech.com";

The recipient’s valid e-mail address.

• server:="192.9.200.1";

IP address or host name of SMTP mail server.

Example:

// define an email notification
   notification email my_email {

from:="OTM";
address:="joe@acme.com";

      server:="192.9.200.1";
}
.
.
.
// send an email message
send (my_email,

$DeviceTime,":Device ",$CurrentTrapSource,
" generated a ",$CurrentTrapMajor,".",$CurretTrapMinor,
" trap with severity level: ",severity_level,", ErrorCode:",$ErrorCode,".");

Note: The preceding example defines an e-mail notification named 
“my_email,” which has an associated recipient address and the mail 
server IP address. This script sends e-mail to the address stating the 
source of the alarm, the severity level, and the alarm error code. Note the 
use of the named e-mail notification “my_email” with the send syntax in 
the script.
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Text (over modem)

The text notification type allows you to write a message that the application sends 
to a remote modem. The application connects to the remote modem, usually a 
remote support site that you have defined, and transmits the message. Be sure that 
you have a modem and a valid phone line connection.

If the remote modem is busy, the application stores and notes the message for a 
later delivery or sends it to another specified alternate destination. 

Mandatory parameters are:

• phone:="408-555-4321";

The phone number you dial to connect to the remote modem.

Example:

//define text over modem notification
   notification modem tech_center   {
   phone:="9,555-4321";
  }
.
.
.
//send text over modem notification
send(tech_center,$CurrentTrapSource,"-MPK alarm:",$CurrentAlarmErrorCode);

SNMP

You can request that the OTM PC generate Simple Network Management 
Protocol (SNMP) traps. You define SNMP Object Identifiers (OIDs) as 
parameters in the send syntax. Specify a list of TCP/IP addresses or registered 
host names on the Ethernet network to receive the trap; however, receipt is not 
guaranteed once messages are transmitted. You must be familiar with and 
knowledgeable about SNMP to effectively utilize this notification type.

Note: The preceding example defines a modem notification named 
“tech_center,” which has an associated number to dial to connect to the 
remote modem. This script sends text to the dialed remote modem 
stating the source of the alarm and the alarm error code. Note the use of 
the named modem notification tech_center with the send syntax in the 
script.
Using Optivity Telephony Manager Release 2.0x



708 Alarm management
Mandatory parameters are:

• address:="192.9.200.1";

IP address or hostname of the destination for the trap.

• trap:="6.10";

Trap type in Major type.Trap number format.

This is usually done to forward traps to higher-level network management 
systems such as Optivity NMS and HP OpenView.

For Optivity NMS, the Major type.Trap number format also indicates the 
severity level (Table 36).

Table 36   Optivity NMS severity levels

Major type.Trap number Severity level

6.1 Critical

6.2 Major

6.3 Minor

6.4 Warning

6.5 Info

6.6 Clear
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Example:

In this example, control_center is defined as an SNMP notification.

// define an SNMP notification 
   notification snmp control_center {
      address:="192.9.200.1";
      trap:="6.1";
   }
.
.
.
// send an SNMP notification to the control center with the same trap
//format as the M1
send(control_center,

"1.3.6.1.4.1.562.50.1.2.1.0","Integer",$AlarmSeqNum, //AlarmSeqNo
"1.3.6.1.4.1.562.50.1.2.2.0","OctetString",$DeviceTime, //Date&Time
"1.3.6.1.4.1.562.50.1.2.3.0","Integer",$NormalizedSeverity, //Severity
"1.3.6.1.4.1.562.50.1.2.4.0","Integer",nsOtm, //Name Space
"1.3.6.1.4.1.562.50.1.2.5.0","OctetString",$ErrorCode //Error Code
"1.3.6.1.4.1.562.50.1.2.6.0","OctetString",$Site, //Site
"1.3.6.1.4.1.562.50.1.2.7.0","OctetString",$ComponentAddress, //System
"1.3.6.1.4.1.562.50.1.2.8.0","OctetString",$SystemComponent, //System Component
"1.3.6.1.4.1.562.50.1.2.9.0","OctetString",$CurrentTrapSource, //Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0","Integer",$TrapType, //Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0","OctetString",$AssocUser, //Associated User
"1.3.6.1.4.1.562.50.1.2.12.0","OctetString" $OperatorData,//Problem Isolation Data1 
"1.3.6.1.4.1.562.50.1.2.13.0","OctetString" $ExpertData, //Problem Isolation Data2  
"1.3.6.1.4.1.562.50.1.2.14.0","OctetString" $Text //Problem Isolation Data3

)

Note: The preceding notification should be framed as shown and 
include all OIDs; otherwise, the management station may not properly 
receive the notification. The third parameter, variable name, is different 
for each device. For example, ITG has the variable names for component 
address, text, and expert data set as “na.” Sample trap formats for all 
supported devices are included in “Sample Alarm Notification script 
file” on page C-7 of Appendix C, “Control files included with alarm 
notification.”

Note: The script identifies the value of each variable in the generated 
trap, whether an integer or an octet string.
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Log file

The log file notification type writes a message that the application saves to a text 
file. You specify the storage location of this text file in the script. If no path name 
is specified, the file is saved in the same directory as the Alarm Notification 
application. If the file already exists, the new message is appended to the existing 
file. If the file does not exist, it is created.

Mandatory parameters are:

• filename:=”c:\Normat\sample_log”;

Full path name and filename.

Example:

// define a file notification 
notification file sample_file {
filename  :=  "c:\eventlog.txt";
}
.
.
.
// send a file notification 
send(sample_file, “M1 alarm: “,

$CurrentTrapSource," - " , // Name of this M1
$CurrentAlarmErrorCode," - " ,      // M1 error code (i.e., BUG1234)
$CurrentAlarmTime," - " ,           // Timestamp from M1
$CurrentAlarmDescriptiveText," - ", // Text with error message
$CurrentAlarmOperatorData);         // More text with error message

Rules

Rules allow you to define actions that may be applied to a given event. Rules may 
only be defined in scripts. By default, rules are examined in a top-down manner. 
You may use an infer statement to explicitly specify the order in which rules are 
examined.

Note: The preceding script defines a log file notification named 
sample_file having an associated path name defining a storage location 
on the drive C. The stored file is named eventlog.txt. Note the use of the 
named file notification sample_file with the send syntax in the script.
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A rule consists of an if statement containing a logical expression, followed by an 
instruction. A rule may also include an else statement, which is only executed if 
the logical expression in the if statement is false. Within a rule, a send statement or 
a function may be called. New variables may not be defined within the scope of a 
rule.

Example:

rule check_Meridian1_critical {
if($CurrentTrapDevice="Meridian1" and $NormalizedSeverity=Critical) {

// print event to console
send( con,

"--> Critical Meridian1 alarm received! ",
$ErrorCode," - " ,                  // M1 error code
$CurrentPCTime, " - ",              // Time that PC received the alarm
$CurrentTrapSource," - " ,          // Name of this M1
$DeviceTime," - " ,                 // Timestamp from M1
$Text," - ",                        // Text with error message
$OperatorData                       // More text with error message

);
}
else{

// append event to log file
send(sample_file,"--> Critical alarm received! ",

$ErrorCode," - " ,                  // Error code
$CurrentPCTime, " - ",              // Time that PC received the alarm
$CurrentTrapSource," - " ,          // Name of this device
$DeviceTime," - " ,                 // Timestamp
$Text," - ",                        // Text with error message
$OperatorData                       // More text with error message

);
}

}

While rules may invoke functions, the infer command allows functions to call 
rules. Rules may be invoked in any order and repeatedly until a logical expression 
is satisfied or while a rule has not been triggered.

Note: The preceding script defines the rule check_Meridian1_critical, 
which sends critical Meridian 1 alarms to the console and appends other 
events to the log file sample_file.
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Examples:

infer{Rule1, Rule2, Rule3} until Rule4;

or

infer{RuleA, RuleB, RuleC} while (c>5);

Comments

Comments provide a convenient way of adding informational notes within a 
script. To include comments within a script, use the C convention (begin with /* 
and end with */), or use the C++ convention (begin the comment with //).

For example:

/* This is a comment. */

// This is another comment.

Functions

Functions contain a combination of logical expressions and optional variable 
declarations. They accept parameters and return a single result. You may invoke 
functions either within logical expressions or rules, or within themselves. Within a 
function, assignments may occur along with if and loop statements.

Example:

function counter samplefile(counter n) {
      string severity_level;
      severity_level := AlarmLevelToString($NormalizedSeverity); // Calling another function
      n:=n+1;
      if (n=1) {
         send(nf_samplefile,

$DeviceTime,": Device ",$CurrentTrapSource,
" generated a ",$CurrentTrapMajor,".",$CurrentTrapMinor,
" trap with severity level: ",severity_level,", ErrorCode: ", $ErrorCode, ".");

         n:=0;
       }

 return(n);
}

Note: Many of the scripts presented in this chapter have portions noted 
as comments. Remove the comment tags for the application to interpret 
these as actual scripting code.
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rule r_samplerul {
      if ($CurrentTrapDevice="ITG")

{
           count_samplefile:=samplefile(count_samplefile);
      }
}

Using the sample script files

You have two methods available for writing scripts. You may have a single script 
in the script file and define all of the rules and functions in this one script, or you 
may have multiple scripts in the script file and define rules and functions for each 
script.

Single script

An example of a script file that contains a single script is sample_wizard_script.txt 
included with your OTM software. A printout of this script appears in “Sample 
Alarm Wizard script file” on page C-23 of Appendix C, “Control files included 
with alarm notification.” In this example, there is only one script titled 
“GeneratedScript.” This script has multiple rules to check for a condition and 
perform a defined task when the condition occurs. Typically, if the rule is satisfied, 
the script calls a function that initiates an action. The notifications can be located 
outside the script, and the function can call the notification from inside the script.

Note: The file sample_wizard_script.txt is a file that has been generated 
by the Alarm Script Wizard. You can modify this file manually; however, 
you cannot open it using the Alarm Script Wizard once it has been 
modified. See “Alarm Script Wizard” on page 717.
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Multiple scripts

An example of a script file that contains multiple scripts is sample_an_script.txt, 
which is also included with your OTM software. A printout of this script appears 
in “Sample Alarm Notification script file” on page C-7 of Appendix C, “Control 
files included with alarm notification.” If you are using this method, you define a 
separate script for each activity. For example, you define a script for all e-mail 
notifications, a second script for all console notifications, and a third script for all 
pager notifications. Each script can have multiple rules and functions.

A portion of the sample Alarm Notification script file sample_an_script.txt 
follows. You should add your scripts after the following sections of the file:

// ***************************************************************************************
// Map severities from the various traps that OTM receives into a standard severity list.
// ***************************************************************************************

counter $NormalizedSeverity := 0;

counter Undetermined := 0;
counter Critical := 1;
counter Major := 2;
counter Minor := 3;
counter Warning := 4;
counter Info := 5;
counter Cleared := 6;
counter Unknown := 7;

// ==========================================================================
//                           Map OTM severities
// ==========================================================================
// 1->Critical;2->Major;3->Minor;4->Info;5->Info;6->Cleared;7->Unknown;x->Undetermined

script AssignOTMSeverities when ( $CurrentTrapDevice = "OTM" ) {
function assignit() {

if ($Severity=Critical) {
$NormalizedSeverity:=Critical;

}else{ if ($Severity=Major) {
$NormalizedSeverity:=Major;

}else{ if ($Severity=Minor) {
$NormalizedSeverity:=Minor;

}else{ if ($Severity=Info) {
$NormalizedSeverity:=Info;

}else{ if ($Severity=Unknown) {
$NormalizedSeverity:=Unknown;

}else{ if ($Severity=Warning) {
$NormalizedSeverity:=Warning;

}else{ if ($Severity=Cleared){
$NormalizedSeverity:=Cleared;

}else{
$NormalizedSeverity:=Undetermined;

}}}}}}}
}

Note: Nortel Networks recommends that you save a copy the file 
sample_an_script.txt under a new name (for example notify.txt), and 
modify the copy of the file to create your scripts.
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rule assign_severity {
if ($CurrentTrapDevice="OTM") {

assignit();
}

}
}

// ==========================================================================
// Map severities from Meridian1 and Call Server Open Alarms
// ==========================================================================
// 1->Minor;2->Major;3->Critical;4->Unknown;5->Warning;6->Clear;7->Undetermined;x->Info

script convertM1Severities when ( $CurrentTrapDevice = "Meridian1" or
$CurrentTrapDevice ="CALL_SERVER") {

function convertit() {
if ($Severity=1){

$NormalizedSeverity:=Minor;
}else{ if ($Severity=2){

$NormalizedSeverity:=Major;
}else{ if ($Severity=3){

$NormalizedSeverity:=Critical;
}else{ if ($Severity=4){

$NormalizedSeverity:=Unknown;
}else{ if ($Severity=5){

$NormalizedSeverity:=Warning;
}else{ if ($Severity=6){

$NormalizedSeverity:=Cleared;
}else{ if ($Severity=7){

$NormalizedSeverity:=Undetermined;
}else{

$NormalizedSeverity:=Info;
}}}}}}}

}
rule severity_conversion {

if ( $CurrentTrapDevice = "Meridian1" or $CurrentTrapDevice = "CALL_SERVER"){
convertit();

}
}

}

// ===========================================================================
// Map severities from devices other than OTM, Meridian1, and Call Server
// ===========================================================================
//1->Critical;2->Major;3->Minor;4->(CallPilot::Info, Warning);
//5->(CallPilot::Unknown, Cleared);x->Undetermined

script convertSeverities when ($CurrentTrapDevice!="OTM" and $CurrentTrapDevice!="Meridian1"
and $CurrentTrapDevice!="CALL_SERVER") {

function convertit() {
if ($Severity=1) {

$NormalizedSeverity:=Critical;
}else{ if ($Severity=2){

$NormalizedSeverity:=Major;
}else{ if ($Severity=3){

$NormalizedSeverity:=Minor;
}else{ if ($Severity=4){

if ($CurrentTrapDevice="CALL_PILOT"){
$NormalizedSeverity:=Info;

}else{
$NormalizedSeverity:=Warning;

}
}else{ if ($Severity=5){

if ($CurrentTrapDevice="CALL_PILOT"){
$NormalizedSeverity:=Unknown;

}else{
$NormalizedSeverity:=Cleared;

}
}else{

$NormalizedSeverity:=Undetermined;
}}}}}
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}

rule severity_conversion {
if ($CurrentTrapDevice!="OTM" and $CurrentTrapDevice!="Meridian1"

and $CurrentTrapDevice!="CALL_SERVER") {
convertit();

}
}

}

// ***************************************************************************************
//                                  Assign $NameSpace
// ***************************************************************************************

counter nsOtm               := 1; // Originated from an OTM
counter nsMeridian1         := 2;
counter nsCallPilot        := 3;
counter nsMeridianMail      := 4;
counter nsSl100             := 5;
counter nsPassport          := 6;
counter nsItg               := 7;
counter nsBravo             := 8;
counter nsIss7              := 9;
counter nsMDECT := 10;
counter nsCallServer := 11;
counter nsMediaCard := 12;
counter nsSigServer := 13;
counter nsSccs              := 14;
counter nsMeridianMailLink  := 15;
counter nsGenericOrUnknown  := 16;

script assignNameSpace {

function ns() {
if ($CurrentTrapDevice="OTM") {

// Original $CurrentTrapDevice is retained
}else{ if ( $CurrentTrapDevice = "Meridian1" ) {

$NameSpace := nsMeridian1;
}else{ if ( $CurrentTrapDevice = "CALL_PILOT" ) {

$NameSpace := nsCallPilot;
}else{ if ( $CurrentTrapDevice = "MMCS" ) {  

$NameSpace := nsMeridianMail;
}else{ if ( $CurrentTrapDevice = "ITG" 

or $CurrentTrapDevice = "ITG_ISDN_TRK" 
or $CurrentTrapDevice = "ITG_IP_LINE" 
or $CurrentTrapDevice = "ITG_IP_PHONE" )

{
$NameSpace := nsItg;

}else{ if ( $CurrentTrapDevice = "BRAVO" ) {
$NameSpace := nsBravo;

}else{ if ( $CurrentTrapDevice = "ISS7" ) {
$NameSpace := nsIss7;

}else{ if ( $CurrentTrapDevice = "MDECT" ) {
$NameSpace := nsMdect;

}else{ if ( $CurrentTrapDevice = "SCCS" ) {
$NameSpace := nsSccs;

}else{ if ( $CurrentTrapDevice = "CALL_SERVER" ) {
$NameSpace := nsCallServer;

}else{ if ( $CurrentTrapDevice = "MEDIA_CARD" ) {
$NameSpace := nsMediaCard;

}else{ if ( $CurrentTrapDevice = "SIGNALLING_SERVER" ) {
$NameSpace := nsSigServer;

}else{
$NameSpace := nsGenericOrUnknown;

}}}}}}}}}}}}
}

rule ns1 {  
if (1) {
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 ns();
}

}
}
                             

Alarm Script Wizard

The Alarm Script Wizard is a graphical easy-to-use tool that enables you to 
define, consult, and edit the notifications sent when OTM receives an alarm 
message.

Use the Alarm Script Wizard to create basic script files. To define more elaborate 
notification rules, see “Scripting” on page 692.

Starting the Alarm Script Wizard

To run the Script Wizard:

1 From the Windows Start Menu, choose Programs > Alarm Script Wizard.

The Alarm Script Wizard window opens (Figure 339).

Note: The Alarm Script Wizard generates scripts that can be compiled by 
the Alarm Notification script compiler. The Script Wizard is not able to 
open scripts that are not generated by it. If you edit a generated script file, 
the script is no longer understood by Script Wizard.
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Figure 339   Alarm Script Wizard
.

2 To open a script file, do one of the following:

• Choose File > Open

• On the toolbar, click Open.

The Select script file window opens (Figure 340).
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Figure 340   Select the script file you want to edit dialog box

3 Select the appropriate filename.

4 Click Open.

The script file is loaded into the Script Wizard.

When the existing script is loaded or a new script is created, the main Script 
Wizard screen opens (Figure 341).

Figure 341   Main Script Wizard window
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The three major parts of the main Script Wizard window are identified as:

• Step 1: Define The Notifications

• Step 2: Define The Rules

• Step 3: Generate The Script File

In Step 1, you select the type of notification that you want to generate. See 
“Defining the Notifications” next for information on completing Step 1.

In Step 2, you defines the rules that determine when a notification is to be sent. 
See “Defining the Rules” on page 721.

The final step is to generate the script. See “Generating the Script File” on 
page 724.

Defining the Notifications

A list of available notification types is shown in the Main Script Wizard window. 
There are six available notification types:

• E-Mails

• Numeric Pagers

• Alphanumeric Pagers

• Up-Stream SNMP Managers

• Modems

• Files

Click on one of the notification types to open the corresponding definitions 
window. You use the definition window to edit notification parameters. Figure 342 
shows the E-Mail Notification Definition window.

Note: To view information about the menus, toolbar, buttons, and other 
functions available in the Script Wizard window, use online Help.
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Figure 342   E-Mail Notification Definitions window

 

Defining the Rules

Rules allow you to define actions that will be applied to a given event or 
condition. Each rule is defined by a unique Rule Name. You can add, remove, and 
edit a rule. Rule definition is divided into three sections. The first section, Define 
Condition, is shown in Figure 343. This section defines a test to be applied to each 
alarm processed by the application. A condition is composed of five segments or 
subconditions.

Note: To view information about the menus, toolbar, buttons, and other 
functions available in the Definition windows, use online Help.

Note: A Frequency is associated with each notification. The number 
entered in the Frequency field indicates the number of times the 
notification is called by the program before the action is actually 
executed. In the example shown in Figure 342, the E-Mail will be sent 
after the third occurrence of the notification.

Note: To view information about the menus, toolbar, buttons, and other 
functions available in the Define Condition window, use online Help.
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Figure 343   Define Condition window

The second section, Define Actions If True, describes the actions to be taken if the 
condition defined in the first section is true. This section is shown in Figure 344. 
The action should be a reference to an already defined notification (Figure 342). A 
minimum of one action is required. You may enter up to 3 actions for each type of 
notification for a total of 18 actions.

Note: To view information about the menus, toolbar, buttons, and other 
functions available in the Define Actions If True window, use online 
Help.
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Figure 344   Define Actions If True window

Click Details to display the notification definition (Figure 345).

Figure 345   Email notification details
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The third section, Define Actions If False, describes the actions to be taken if the 
condition defined in the first section is false. This section is shown in Figure 346. 
You are not required to enter any information in this section, but you may enter up 
to three actions for each type of notification.

Figure 346   Define Actions If False window

Generating the Script File

The final step in the Script Wizard is to generate the script file.

A script file is generated using the conditions, actions, and notifications that you 
entered.

Note: To view information about the menus, toolbar, buttons, and other 
functions available in the Define Actions If False window, use online 
Help.

In the Main Script Wizard window (Figure 341 on page 719), click Generate 
The Script File.
553-3001-330 Standard 3.00 November 2002



Alarm management 725
Sample Alarm Notification scripts

This section shows portions of a sample script to illustrate scripting syntax that 
performs common alarm notification tasks. 

Log file

This script uses the file notification and saves all events to the filename 
“sample_log.txt” in the defined location.

notification file sample_file {
   filename:="c:\sample_log.txt";
}

Numeric pager

This script uses the npager notification. Customize this script by typing in your 
numeric pager number:

notification npager sample_numeric_pager {
   phone:="9,555-1212";
}

Alphanumeric pager

This script uses the apager notification. Customize this script by typing in your 
alphanumeric pager number and Personal Identification Number (PIN).

notification apager sample_alpha_pager {
   phone:="9,555-1212";
   pin:="101565";
}

Note: Windows “long” file names are allowed in the scripts but are 
truncated when the system saves the file. Keep your file names to the 
standard 8-character length.
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Severity code descriptions

This script examines error codes generated by the Meridian 1 system and assigns 
descriptive text to them. This portion of the script uses the counter data type and 
the send alarm notification to send alarm notifications to a file and a pager. Note 
the use of rule and send syntax. Note the $Current... references to configuration 
file entries. See “Example of configuration file entries for Meridian 1 systems:” 
on page 689.

/* Provide variables to map M1 severity values into words */
counter info:=0,minor:=1,major:=2,critical:=3,debug:=4;
script SampleScript {

 counter bug3456:=0;

   /* This rule looks for critical M1 events */
   rule check_critical {

      if ($CurrentTrapDevice="Meridian1" and $CurrentAlarmSeverity=critical)

{
         /* print event to console */
         send(con,"M1 alarm: ",

    $CurrentTrapSource," - " ,  // Name of this M1
   $CurrentAlarmErrorCode," - " ,  // M1 error code (i.e., BUG1234)
   $CurrentAlarmTime," - " , // Timestamp from M1
   $CurrentAlarmDescriptiveText," - ",  // Text with error message
   $CurrentAlarmOperatorData); // More text with error message

/* append event to log file */
         send(sample_file,"M1 alarm: ",

    $CurrentTrapSource," - " ,  // Name of this M1
   $CurrentAlarmErrorCode," - " ,      // M1 error code (i.e., BUG1234)
   $CurrentAlarmTime," - " ,           // Timestamp from M1
   $CurrentAlarmDescriptiveText," - ", // Text with error message
   $CurrentAlarmOperatorData);         // More text with error message

Note: The if statement ensures that only critical alarms from the 
Meridian 1 system are processed.

Note: The script displays information about the Meridian 1 system 
alarm in the console pane, including the system where the alarm 
originated, the error code of the alarm, the time of the alarm, any 
descriptive text associated with the alarm, and other text associated with 
the error alarm.

Note: The script saves to a named file on disk the same information 
about the Meridian 1 system alarm that was displayed on the console.
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/* optionally send message to alpha pager */
send(sample_alpha_pager,$CurrentTrapSource,":",$CurrentAlarmCode,"!");
*/

         }
   }

Specific system events

This script examines error codes generated by a Meridian 1 system for a specific 
event code and counts the number of occurrences for this event. For this example, 
BUG3456 is the specific event code. This portion of the script displays to the 
console the time when the error occurred. Customize this script by typing in your 
error code. This script may be of use if you are trying to troubleshoot the system 
for a specific problem.

This rule is named check_specific_event and examines events from the device 
named Meridian 1 for error code BUG3456. If this event is detected, the console 
displays “Found BUG3456 at <alarm time>” where <alarm time> is the 
timestamp provided by the system.

This script uses the rule syntax.

rule check_specific_event {
      if ($CurrentTrapDevice="Meridian1" and 
$CurrentAlarmErrorCode="BUG3456")
         {
         send(con,bug3456,") 
Found ",$CurrentAlarmErrorCode," at ",$CurrentAlarmTime);
         bug3456:=bug3456+1;
         }
   }

Combining scripts

Several scripts are often found in a single script file. The sample scripts in this 
section are combined into a single text file named Script.txt included with the 
application. See “Script files” on page 7. Note the use of comments to document 
the various portions of the script.

Note: The send command contacts the pager named as 
sample_alpha_pager with the error information “M1 : BUG1234” where 
M1 is the name of the Meridian 1 system that has the error and 
BUG1234 is the error type.
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Scripting notes

The scripting language available with Alarm Notification allows tremendous 
flexibility and functionality in defining how the application processes events from 
connected systems. You can use any text editor, such as Notepad, to write your 
script. Use the Control Files tab in the Alarm Notification Run Options dialog box 
to specify the script and other control files you will use.

Customized scripts are interpreted by the Alarm Notification application. Errors in 
the script are noted and related error messages appear in the console pane in the 
Alarm Notification window. Scripting error messages include the line number 
where the error occurred, as counted from the top of the text file, as well as a short 
error description.
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Chapter 6
Maintenance applications

Overview

Meridian 1 and Succession CSE 1000 systems have over 600 overlay-based 
maintenance commands that support their capabilities. OTM Maintenance 
Windows eliminates the need to remember or look up any overlay-based 
commands. The 37 Maintenance Overlays are grouped into 8 hardware-related 
windows to allow you to perform all maintenance tasks. The interface provides a 
comprehensive view of Meridian 1 and Succession CSE 1000 system hardware 
configuration with the following benefits:

• See the equipped hardware at a glance.
The hardware list works like a spread sheet data view—you can scroll through 
the list, sort the list, and select items for changing.

• Select an item from the list and apply a Maintenance command from the 
right-mouse button pop-up menu.

• Print the list or copy it to a spreadsheet.

• Select a TN or DN and print the TN/DN block.

• See Enabled/Disabled status in real time.

For example, to disable a network loop on a Meridian 1 system, you click on the 
loop number and choose the Disable command from the menu. Maintenance 
Windows loads the appropriate overlay, executes the command, and displays the 
result of the action in a window that you can scroll and save.

About this chapter

This chapter provides you with an introduction to the OTM Maintenance 
Windows application as well as an overview of its major functions.
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This section describes functions that are common to all of the Maintenance 
Windows applications. Read this section thoroughly to help you use these 
applications efficiently.

Subsequent sections focus on the eight hardware-related windows. A section is 
included on the Inventory Reporting application, which is based on LD 117. For 
information on the web interface to maintenance applications, see “Web-based 
maintenance” on page 741.

Help

This chapter does not discuss each Maintenance Windows function and command 
in detail. It only discusses the major functions and how they are accessed. For 
detailed information on each Maintenance Windows function, use the online Help 
function. You can use the Help function to obtain help for topics either directly or 
through its index and word-search functions. While running Maintenance 
Windows, you can obtain context-sensitive Help on any topic you require by 
simply clicking Help from a specific dialog box or window.

To obtain help for a topic, click Help from the currently selected dialog box or 
window. This accesses the Windows Help function and displays context-sensitive 
Help information on the current topic.

Once you access Help, scroll through the other Maintenance Windows Help topics 
to search for a specific topic, or print the Help information.

To view a list of Help topics for Maintenance Windows, click Contents from the 
Help drop-down menu. Choose from one of the items in this list to load the Help 
file and display its information.

Launching a Maintenance Windows application

You launch Maintenance Windows applications from the OTM System window. 
Figure 347 shows the OTM System window.
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Figure 347   OTM System window 

Under Core Equipment, double-click the icon for the desired Maintenance 
Windows application to launch that application. The appropriate window appears.

For example, double-click the Network Loops icon to open the Network Loops 
window (Figure 348). Each loop is listed, along with descriptive information. 
From this window, you can sort this information, select a loop and run 
maintenance commands, and get Help on the selected loop.

Note: Each application is described in detail in a separate chapter in this 
document.
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Figure 348   Network Loops window 

Maintenance Windows applications

OTM Maintenance Windows includes the following applications:

Core CPU

The CPU window displays the status of cards in both CPU shelves on the selected 
Meridian 1 system, or the Call Server on the selected Succession CSE 1000 
system. You can perform actions and tasks on cards in the Meridian 1 system’s 
CPU shelf or the Succession CSE 1000 system’s Call Server from the CPU 
window.

I/O Ports

The I/O (Input/Output) Ports window displays the status of all I/O ports on the 
Meridian 1 or Succession CSE 1000 system, and allows you to execute actions 
and tasks on a selected port.
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Network Groups

The Network Groups window displays the status of all Network Group Cards on 
the Meridian 1 system, and allows you to execute actions and tasks on a selected 
card.

Network Loops

The Network Loops window lists all the network loops on the Meridian 1 system. 
It allows you to execute actions and tasks on a selected loop by choosing 
commands from the Maintenance menu.

PE Shelves

The PE Shelves window displays the status of the Peripheral Controller Cards for 
each PE Shelf on a Meridian 1 system, and allows you to execute actions and tasks 
on a selected card.

PE Cards

The PE Cards window displays the status of all EPE and IPE Peripheral 
Equipment cards for each PE Shelf on a Meridian 1, and allows you to execute 
actions and tasks on a selected card. The PE Cards window is also used to display 
the status of the circuit cards associated with each of the Media Gateways on a 
Succession CSE 1000 system.

PE Units

The PE Units window displays information for all PE units and Directory 
Numbers on the Meridian 1 or Succession CSE 1000 system, and allows you to 
execute actions and tasks on a selected unit.

B- and D-channels

The PRI/PRI2 B- and D-channels window displays the B- and D-channels on the 
selected digital trunk (for example, PRI loop), and allows you to execute actions 
and tasks on a selected channel.
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Option 11C Line Size Expansion

The Option 11C Line Size Expansion increases the Option 11C line capacity from 
the current three expansion cabinet configuration to a maximum of five expansion 
cabinets. Along with this expansion, the Option 11C supports an additional 20 IPE 
cards.

Option 11C Mini

The Option 11C Mini affords full Meridian 1 feature functionality to the 20 to 80 
line PBX customer. The three mounting options, wall, rack, and table top, are 
fully OTM and X11 system software compatible. There is an option for an 
expansion cabinet that supports an additional four peripheral slots. OTM 
recognizes this system type as an Option 11C in the Navigator and System 
Properties windows. 

Inventory Reporting

The Inventory Reporting window allows you to generate and download inventory 
files listing cards and telephone sets installed on a Meridian 1 system.

Full documentation in online Help

Each Maintenance Windows application is fully documented in the online Help. 
Each menu command, button, and field is documented. Be sure to consult the 
online Help if you want to get more detail about any of these items.

For Help on an object in a list, select the item and use the right mouse button to 
select What’s This Help. Descriptive information on the item appears. For 
example, ask for help on a TTY object and the window shown in Figure 349 
appears.
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Figure 349   “What’s This” Help on PTY

Performing a maintenance task on an item

To perform a maintenance task on a card, loop, shelf, and so on, follow these 
steps:

1 Open the appropriate Maintenance Windows application.

2 Select the item from the list.

3 Choose a command from the Maintenance menu, the toolbar, or by using the 
right mouse button pop-up menu. A confirmation dialog box appears for 
potentially destructive commands.

4 The script appears in the command result section of the window, followed by 
the overlay output.
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Meridian 1 or Succession CSE 1000 system connection

Maintenance window applications connect to the Meridian 1 or Succession 
CSE 1000 system by a Pseudo TTY (PTY). A PTY is a “software only” TTY that 
uses an I/O port address. PTYs appear in the I/O Ports window. One PTY is used 
for all Maintenance Windows users connected to the system (even from multiple 
PCs). One PTY is used for each System Terminal connection, even if it is not 
logged in to the overlays.

Queueing scripts

If the Meridian 1 or Succession CSE 1000 system is currently processing another 
user’s script, your command is placed in a queue. You must wait until your script 
is finished processing before you can choose another Maintenance menu 
command. However, while you are waiting, you can perform maintenance tasks 
on another type of system component using a different Maintenance Windows 
application.

Cancelling scripts

To remove a command from the queue or to cancel a command in progress, click 
Cancel. Pressing the <Esc> key also removes or cancels a command. If a 
command is in progress, Cancel aborts the current command and overlay by 
sending four stars (****).

Refreshing the hardware status in the list

The hardware status in the list is updated as follows:

• The list is updated every few seconds, even if there is no activity on the OTM 
PC.

• The selected object status updates at every OTM PC after every script 
(therefore, if you disable a port from one PC, the status updates on all other 
PCs).

Note: You specify the interval on a per-window basis. See the About 
Maintenance Windows item in the Help menu.
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• The entire list updates after some scripts because multiple objects are affected 
(for example, Split CPU, Disable MSDL).

• You can manually refresh the hardware status display by pressing <F5>.

Menu commands

Each menu command is fully documented in online Help. The Status Bar provides 
useful information on the script to run (see “Using the Status Bar” on page 739). 

You can also read What’s This Help on any menu command. Press <Shift><F1> 
(or select What’s This from the Help menu), and then select the command for full 
online documentation.

The Maintenance menu is unique for each hardware application, and is also fully 
documented in online Help. In addition to the information provided in the Status 
Bar, you can read What’s This Help on any menu command as described above.

Getting help on an error message

Sometimes, a maintenance command results in a Meridian 1 or Succession 
CSE 1000 system error message, such as NWS010.

To get help on the last error message (even if it has scrolled out of view):

To get help on a previously displayed error message:

• Use the scroll bar to move to the error message. Double-click the error 
message.

or

• Select the error and choose Error Message from the Help menu.

or

• Press <Ctrl>E for information on the last error message.

Choose Error Message from the Help menu.
Using Optivity Telephony Manager Release 2.0x



738 Maintenance applications
Navigating within the maintenance window

You can use the maintenance window in the following ways:

Customizing the window and columns

• Resize the window and columns using standard Microsoft Windows controls.

• Use the horizontal or vertical scroll bars to move around in the alarm display.

• Resize the column by dragging the column divider to make more room for 
text.

• Drag the splitter bar (which divides the window into two display areas) to 
change the sizes of the card list and command results display areas.

Sorting the list

By default, items are listed in an order optimized for that application. You can sort 
the list according to another column by clicking in that column heading. Click to 
sort in ascending order (an “up” arrow appears in the heading); click again for 
descending order (“down” arrow).

Using shortcuts

The application provides convenient keyboard equivalents for many menu 
selections. You can perform the following common tasks by typing the accelerator 
keys:

• <Ctrl>R (Status)—Displays detailed status information for the selected 
hardware device

• <Ctrl>T (Test)—Performs predefined tests on the selected hardware device

• <Ctrl>W (Enable)—Restores the selected hardware device to service

Note: An ellipsis (...) after column text indicates there is more 
information than will fit in the column.

Note: For help on the definition of any column in the list, click 
What’s This in the Help menu, and then click the column title.
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• <Ctrl>D (Disable)—Removes the selected hardware device from service

Using the Toolbar

The Toolbar gives you quick access to selected commands. Each button is 
documented in the online Help (Figure 350).

Figure 350    CPU toolbar

Using the Status Bar

To display or hide the Status Bar located at the bottom of the window, use the 
Status Bar command in the View menu. 

The Status Bar describes actions of the menu commands as you use the mouse to 
navigate through menus. When you select a Maintenance menu item, the status 
bar displays the following information:

• Type of object selected

• First overlay command in the script

When you run a Maintenance menu command, the Status Bar describes the 
progress of the command while it executes. For example, the Status Bar shows 
“Enable command in progress” when you choose an Enable command.

The Status Bar also displays the actions of the Toolbar buttons as you move the 
pointer over them.

Printing

You can print Maintenance Windows information by selecting the lines to print in 
the list or the command results area (or the entire section), and selecting Print 
from the File menu. Select Print to File in the Print dialog box to export the data 
for use in a spreadsheet or other application.
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Supported systems

Maintenance Windows is supported on Succession CSE 1000 systems, and on 
Meridian 1 systems with X11 Release 22 or later and the OTM Management 
Interface package (296).

The following Meridian 1 systems are supported:

• Option 11C

• Option 51C

• Option 61C

• Option 81

• Option 81C

It also supports the Option 11C Compact beginning with X27 Release 1.

Feature limitations

• Not all hardware maintenance commands are supported. See the tables in each 
Maintenance Windows application section for the list of supported hardware 
and commands.

• Only one user can access a maintenance overlay at a time (this is an existing 
limitation of the overlays). Commands issued from a maintenance window are 
queued if:

— A TTY user has loaded a maintenance overlay

— Another maintenance window (same or different user) is running a script 
that uses the same maintenance overlay

— A previous command was issued from a Maintenance window (that is, 
you must wait until the first command is completed before issuing 
another)

One Pseudo TTY port is required for Maintenance Windows (regardless of the 
number of windows and logged-in users). Each instance of the System Terminal 
window (active or inactive) requires an additional Pseudo TTY port. This is in 
addition to the PPP/Ethernet ports required for the basic OTM PC connection.
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Maintenance window menus are not context sensitive to the maintenance state of 
the selected Meridian 1 or Succession CSE 1000 object. For example, the enable 
command is not grayed out if the object is already enabled. You get the same 
response as entering the enable command in the overlay (usually an error message 
stating that the card is already enabled).

Web-based maintenance

Core CPU page

To open the Core CPU page:

1 Click the Core CPU radio button.

2 Click Go.

The Core CPU page opens (Figure 351).
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Figure 351   Core CPU summary page

To perform maintenance operations on a CPU:

1 Click the CPU number link that corresponds to the CPU on which you want to 
perform maintenance operations.

The Core CPU Maintenance Page for the selected CPU opens (Figure 352).
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Figure 352   Core CPU Maintenance page

2 Select a command from the drop-down list.

3 Click Go.

The results appear in the Results frame (Figure 353).
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Figure 353   Core CPU Maintenance command results

Some of the Core CPU cards require that you input additional information prior to 
the execution of the Go command. The following example outlines the procedure 
for sending maintenance commands to a CMDU.

To perform maintenance commands on a CMDU, first select a CMDU:

The Core CPU Maintenance Page for the selected CMDU opens (Figure 354).

Click the CPU number link that corresponds to the CMDU on which you 
want to perform maintenance commands.
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Figure 354   Core CPU Maintenance page for a CMDU

To Test the selected CMDU:

1 Select Test-CMDU from the drop-down list.

2 Click Go.

The Go button is replaced by an Options button (Figure 355).
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Figure 355   Core CPU Maintenance page with Test-CMDU command selected

3 Click Options.

The CMDU Test Options page appears (Figure 356).
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Figure 356   CMDU Test Options

4 Click the radio button corresponding to the type of CMDU test that you want 
to perform.

To perform a basic test of the selected CMDU:
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a Click the radio button corresponding to Basic Test of Selected CMDU.

b Select an option from the drop-down list (Figure 357).

Figure 357   Basic Test of Selected CMDU - Options

c Click OK.

The Options button is replaced with a Go button (Figure 358).
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Figure 358   Core CPU Maintenance page after options have been selected

To perform a read test of the selected CMDU:

a Click the radio button corresponding to Read Test of Selected CMDU.

b Select an option from the drop-down list (Figure 359).

Note: The Test CD-ROM Only option only appears when you are 
connected to a Meridian_1 system running X11 Release 23 or later.
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Figure 359   Read Test of Selected CMDU - Options

c Click OK.

The Options button is replaced with a Go button (Figure 358).

To perform a file level test on both hard drives:

a Click the radio button corresponding to File Level Test on Both Hard 
Drives.

b Click OK.

The Options button is replaced with a Go button (Figure 358).

To perform a sector level test on both hard drives:

a Click the radio button corresponding to Sector Level Test on Both Hard 
Drives.

b Click OK.

The Options button is replaced with a Go button (Figure 358).

5 Click Go.
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The test results are presented in the Results frame (Figure 360).

Figure 360   Core CPU Maintenance test results

I/O Ports page

To open the I/O Ports page:

1 Click the Core I/O Ports radio button.

Note: The Go button is replaced with an Options button since 
Test-CMDU is still selected in the drop-down menu.
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2 Click Go.

The I/O Ports summary page opens (Figure 361).

Figure 361   I/O Ports summary page

To perform maintenance operations on an I/O Port:

1 Click the Type link that corresponds to the port on which you want to perform 
maintenance operations.

The I/O Port Maintenance page for the selected port opens (Figure 362).
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Figure 362   I/O Port Maintenance page

Some I/O Port Maintenance operations require that you select a group number 
prior to execution of the command. To select a group number:

2 Click Options.

3 Select the group number from the drop-down list (Figure 363).
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Figure 363   Group number option dialog box

4 Click OK.

5 Click Go.

The Device Status field is updated to indicate that the card is enabled.

Note: The command that you selected from the select command 
drop-down list appears as the title in the select group number dialog box.
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Groups page

To open the Groups page:

1 Click the Groups radio button.

2 Click Go.

The Groups summary page opens (Figure 364).

Figure 364   Groups summary page
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Loops page

To open the Loops page:

1 Click the Loops radio button.

2 Click Go.

The Loops summary page opens (Figure 365).

Figure 365   Loops summary page

To perform maintenance operations on a Loop:

1 Click the Loop link that corresponds to the loop on which you want to 
perform maintenance operations.

The Loop Maintenance page for the selected loop appears (Figure 366).
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Figure 366   Loop Maintenance page

Some Loop Maintenance operations require that you select a shelf number prior to 
execution of the command. For these operations, the Go button becomes an 
Options button (Figure 367). To select a shelf number:

2 Click Options.

3 Select the shelf number from the drop-down list (Figure 367).
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Figure 367   Loop Maintenance page with shelf number option dialog box

4 Click OK.

5 Click Go.

The test results are returned in the Results frame.

Note: The command that you selected from the select command 
drop-down list appears as the title in the select shelf number dialog box.
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B-channels Maintenance page

To perform maintenance operations on B-channels:

1 From the Loops summary page (Figure 368), select the Loop link for the 
Superloop on which you want to perform maintenance.

Figure 368   Loops summary page with PRI and DTI2 loops

The B-channels summary page for the selected loop opens (Figure 369).
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Figure 369   B-Channels summary page

2 Click the Channel link that corresponds to the channel on which you want to 
perform maintenance operations.

The B-Channel Maintenance page for the selected channel opens 
(Figure 370).

Note: The available maintenance commands are dependent on the type 
of B-Channel selected.
553-3001-330 Standard 3.00 November 2002



Maintenance applications 761
Figure 370   B-Channel Maintenance page

3 Select a command from the drop-down list.

4 Click Go.

The results of the command appear in the Results frame (Figure 371).
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Figure 371   B-Channel Maintenance test results

PE Shelves page

To open the PE Shelves page:

1 Click the Shelves radio button.

2 Click Go.

The PE Shelves summary page appears (Figure 372).
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Figure 372   PE Shelves summary page

PE Cards page

To open the PE Cards page:

1 Click the PE Cards radio button.

2 Click Go.

The PE Cards summary page appears (Figure 373).
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Figure 373   PE Cards summary page

To perform maintenance commands on a PE card:

1 Click the TN link that corresponds to the PE card on which you want to 
perform maintenance commands.

The maintenance page for the selected PE card appears (Figure 352). This 
example shows the maintenance page for TN 001 0 01.
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Figure 374   PE Card Maintenance page

2 Select a command from the drop-down list.

3 Click Go.

The results of the command are placed in the Results box. Once the command 
has been executed, the component state is updated.

Find Telephones and Find PE Units pages

Use the PE Units list to manage Directory Numbers (DNs), and Terminal 
Numbers (TNs). Before the list appears, a find option is provided since it is 
unlikely that you would want to view the entire list. The PE Units list can be 
retrieved from the Station database on the OTM Server, using Find Telephones 
(Figure 375). The PE Units list can also be retrieved directly from the Succession 
CSE 1000 or Meridian 1 system (Figure 376).
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Find Telephones (OTM)

To open the Find Telephones (OTM) page:

1 Click the Find Telephones (OTM) radio button.

2 Click Go.

The Find Telephones page appears (Figure 375).

Figure 375   Maintenance Pages Find Telephones (OTM) page

PE Units

To open the Find PE Units (M1) page:

1 Select the Find PE Units (M1) button.

2 Click Go.
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The Find PE Units - M1 page appears (Figure 376).

Figure 376   Maintenance Pages Find PE Units (M1) page

Telephones/PE Units maintenance

In either the Find Telephones page or the Find PE Units - M1 page:

1 Enter a single DN or TN, or enter a range of DNs or TNs.

2 Click Find.

After you click Find, the results appear as shown in Figure 377 if you entered 
DN(s), or as shown in Figure 378 if you entered TN(s).
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Figure 377   PE Units Find Results (by DN)
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Figure 378   PE Units Find Results (by TN)

3 Click a DN or a TN. A new browser window appears (Figure 379). This 
example shows the maintenance page for TN 001 0 0 00.
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Figure 379   Viewing PE Unit data

4 Select a command from the drop-down list, and then click Go.

The command status goes through the following sequence:

• Ready

• Logging In ...

• Retrieving Results ...

• Updating Status ...

• Logging Out ...

• Ready

In this example, the Enable command is selected. Figure 380 shows that the 
status of this unit has been updated from disabled in Figure 379 to idle in 
Figure 380. 
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Figure 380   PE unit data after applying enable command

5 Select another command, or close the browser window.

Windows-based maintenance

Core CPU window

The Core CPU window displays the status of cards in the CPU shelves on the 
selected Meridian 1 system or the status of the Call Server in a Succession 
CSE 1000 system.
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Launching Core CPU

From the System window, under Core Equipment, double-click Core CPU icon. 
The Core CPU window (Figure 381).

Figure 381   CPU window

The command results area in the lower portion of the window displays the results 
of Maintenance menu commands.
553-3001-330 Standard 3.00 November 2002



Maintenance applications 773
Core CPU column descriptions

The Core CPU window provides columns of information about each card installed 
in the shelf. The Core CPU list is initially sorted by CPU number (there may be 
one or two CPU shelves, depending on the hardware type). Table 37 describes 
each column.

Supported Core CPU commands

Table 38 lists the hardware and Core CPU commands supported. Use System 
Terminal for hardware or commands not supported by the Core CPU window.

Table 37   Core CPU window column descriptions

Column Description

CPU Shelf number associated with the card.

Card CPU card type, the following types are listed:
• Core Processing Unit (CPU) cards

• Core Multi-Disk Unit (CMDU) cards
• Input/Output Processor (IOP) cards
• Clock Controller (Clock) cards

• Fiber cards (Option 11C only)

State A card can be in an active or standby state.

Mode Mode applies only to CPU and CMDU cards:

CPU cards may be in split or shadowed mode. The faceplate may be 
in Normal or Maintenance mode.

CMDU cards may be in Redundancy enabled or Redundancy disabled 
mode.

Status Current status of the card. For a more detailed status report, use the 
Status command in the Maintenance menu.

Table 38   Supported Core CPU commands

Hardware Supported Commands supported

CP cards Yes All, except split and shadow CPU commands

I/O Processor (IOP) 
cards 

Yes All, except disable IOP and Ethernet 
commands
Note: You will lose connection to M1.
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I/O Ports window

The I/O (Input/Output) Ports window displays the status of all I/O ports on the 
Meridian 1 or Succession CSE 1000 system.

Launching I/O Ports

From the System window, under Core Equipment, double-click the I/O Ports icon. 
The I/O Ports window appears (Figure 382).

Figure 382   I/O Ports window

Core Multi-Disk Units 
(CMDU)

Yes All

Clock Controller Yes All

Fiber Link (Option 11C) Yes All, including cabinet enable/disable 
commands

Fiber Link Yes All

System Utility (SUTL) Yes All

Table 38   Supported Core CPU commands (continued)

Hardware Supported Commands supported
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The command results area in the lower portion of the window displays the results 
of Maintenance menu commands.

I/O Ports column definitions

The I/O Ports window provides columns of information about each port in the 
system. The I/O Ports list is initially sorted by port type and number. Table 39 
describes each column.

Table 39   I/O Ports window column descriptions

Column 
name Description

Type Type and number of I/O port:
• Teletype (TTY)
• Printer (PRT)

• Application Module Link (AML)
• D-Channels
• Intercept Computer Update Link (ICP)

• Ethernet Local Area Network (ELAN)
• Single Terminal Access (STA)

• D-channel Digital Signaling Link (DDSL)
• Low Speed Signaling Link (LSSL)

Device Physical address of the card or port.

Designation Port name. 

Card Type Card containing the I/O port:
• Serial Data Interface Card (SDI)

• Enhanced Serial Data Interface Card (ESDI)
• D-channel Interface Card (DCHI)
• Multi-purpose Serial Data Link Card (MSDL)

Port Port number on the card.

Device 
Status

Current maintenance status of the port.
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Supported I/O Ports commands

Table 40 lists the supported I/O Ports hardware and commands. Use System 
Terminal for hardware or commands not supported by the I/O Ports window.

Card Status Current maintenance status of the card. Applies only to MSDL Cards.

User Type Indicates current port usage.
• ACD: Automatic Call Distribution printer

• APL: Auxiliary Processor Link
• ICP: Intercept Computer Update Link
• LSL: Low-speed AUX link

• HSL: High-speed AUX link
• XSM: System monitor
• BGD: Background terminal

• CTY: Call Detail Recording (CDR) TTY for CDR records
• PMS: Property Management System Interface (PMS)
• BUG: BUG messages included on port

• CSC: Automatic Set Relocation and Attendant Administration 
messages (CSC) included on port

• FIL: Output filtered messages included on port

• MCT: Malicious Call Trace messages included on port
• MTC: AUD, BUG, and ERR messages included on port

• NOO: No overlay allowed on port
• SCH: Service Change or any database change included on port
• TRF: Traffic reports included on port

Table 40   Supported I/O Ports commands 

Hardware Supported Commands supported

TTY port on SDI/MSDL card Yes All except test command

XSM (System Monitor) on 
SDI/MSDL card

Yes All

PRT - Printer port on SDI/MSDL card Yes All except test command

PTY - Pseudo TTY port Yes All

Table 39   I/O Ports window column descriptions (continued)

Column 
name Description
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Network Groups window

The Network Groups window displays the status of all Network Group cards on 
the Meridian 1 system.

Launching Network Groups

From the System window, under Core Equipment, double-click the Network 
Groups icon. The Network Groups window appears (Figure 383).

AML - (Application Module Link) on an 
ESDI/MSDL card

Yes All except message 
monitor commands

ACD High Speed Port on SDI/MSDL card Yes All except message 
monitor commands

ACD Low Speed Port on SDI card Yes All except message 
monitor commands

Auxiliary Processor Links on any SDI/
MSDL card

Yes All except message 
monitor commands

Intercept Computer Update ports (ICP) 
on any SDI/MSDL card

Yes All except ICP application 
commands

D-channel on an MSDL/DCHI card Yes All except message 
monitor commands

Single Terminal Access port Yes All

MSDL card Yes All except download 
version x of software

ACD Low Speed Link for Option 11C Yes All

ICCM ELAN for ICCM Yes All

DPNSS DDSL (D-channel) Yes All

APNSS LSSL (D-channel) Yes All

Table 40   Supported I/O Ports commands  (continued)

Hardware Supported Commands supported
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Figure 383   Network Groups window

The command results area in the lower portion of the window displays the results 
of Maintenance menu commands.

Network Groups column definitions

The Network Groups window provides columns of information about each port in 
the system. The Network Groups list is initially sorted by Group number. Table 41 
describes each column.

Table 41   Network Groups window column descriptions

Column name Description

Group Network group identification number.

Card Type Each network group can include the following cards:

• Core to Network Interface cards (2 cards)
• Peripheral Signaling cards (2 cards)
• InterGroup Switch cards (4 cards)

ID Card identification number. ID for CNI cards include the CPU number, 
slot number, and the port number.

Status Current status of the card. For a more detailed status report, use the 
Status command on the Maintenance menu.
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Supported Network Groups commands

Table 42 lists the supported hardware and Network Groups commands. Use 
System Terminal for hardware or commands not supported by the Network 
Groups application.

Network Loops window

The Network Loops window lists all the network loops on the Meridian 1 system.

Launching Network Loops

From the System window, under Core Equipment, double-click the Network 
Loops icon. The Network Loops window appears (Figure 383).

Table 42   Supported Network Groups commands

Hardware Supported Commands supported

Core to Network Interface (CNI) card Yes All

Peripheral Signalling card Yes All

InterGroup Switch card Yes All

Fiber Junctor Interface (FIJI) card Yes All
Using Optivity Telephony Manager Release 2.0x



780 Maintenance applications
Figure 384   Network Loops window

The command results area in the lower portion of the window displays the results 
of Maintenance menu commands.
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Network Loops column definitions

The Network Loops window provides columns of information about each loop in 
the system. The Network Loops list is initially sorted by Loop number. Table 43 
describes each column.

Supported Network Loop commands

Figure 44 lists the supported hardware and Network Loop commands. Use System 
Terminal for hardware or commands not supported by the Network Loops 
window.

Table 43   Network Loops window column descriptions

Column Description

Loop Loop number.1

1 Loop is replaced by slot for Option 11C systems.

Type Type of Loop.

Status Current status of the card. For a more detailed status report, use the 
Status command in the Maintenance menu.

Additional 
Information

Applies only to PRI/PRI2 and International RPE loops:
• For PRI/PRI2 loops, displays the application status, link status, 

and designation for the Primary and Backup D-channels (DCH).

• For 2.0 MB/s RPE loops, displays the RPE group number. 

Table 44   Supported Network Loops commands

Hardware Supported Commands supported

Enhanced PE (EPE) Network Loop card Yes All except test timeslot and 
LD45 XCON commands

Superloop cards Yes All except LD 45 XCON 
commands and enable/
disable background 
continuity tests

Digital Trunk Interface (DTI/DTI2) cards Yes All

Primary Rate Interface (PRI/PRI2) cards Yes All

Remote Peripheral Equipment (1.5 and 
2.0 Mb/s) cards

Yes All
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PE Shelves window

The PE Shelves window displays the status of the Peripheral Controller Cards for 
each PE Shelf on the Meridian 1.

Launching PE Shelves

From the System window, under Core Equipment, double-click the PE Shelves 
icon. The PE Shelves window appears (Figure 383).

Meridian ISDN Signaling Processor (MISP) 
cards

Yes All except application 
download commands and 
Meridian Packet Handler 
commands

DPNSS/DASS2 cards Yes All

APNSS cards Yes All

Conference cards Yes All

Tone and Digit Switch cards Yes All

Conf/TDS cards Yes All

Fiber Remote (FNET) card Yes All

Multifrequency Sender cards Yes All

Phantom loops Yes None. Phantom loops do 
appear in the list of loops, 
but there are no overlay 
commands for these loops. 

Table 44   Supported Network Loops commands (continued)

Hardware Supported Commands supported
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Figure 385   PE Shelves window

The command results area in the lower portion of the window displays the results 
of Maintenance menu commands.

PE Shelves column definitions

The PE Shelves window provides columns of information about each shelf in the 
system. The PE Shelves list is initially sorted by Controller card number. Table 45 
describes each column.

Table 45   PE Shelves window column descriptions

Column name Description

PE Controller Identification number associated with the PE Controller Card.

Type Type of controller card.

Location Location of the PE shelf containing the PE Controller Card.

Status Current status of the PE Controller Card.

Seg 0 to Seg 3 Identifies the loop supported by each of the four PE shelf segments.
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Supported PE Shelves commands

Table 46 lists the supported hardware and PE Shelves commands. Use System 
Terminal for hardware or commands not supported by the PE Shelves window.

PE Cards window

The PE Cards window displays the status of all Peripheral Equipment Cards for 
each PE Shelf on a Meridian 1 system or each Media Gateway on a Succession 
CSE 1000 system.

Launching PE Cards

From the System window, under Core Equipment, double-click the PE Cards icon. 
The PE Cards window appears (Figure 383).

Table 46   Supported PE Shelves commands

Hardware Supported Commands supported

Peripheral Controller (XPEC) cards Yes All

Fiber Remote (CARR) Yes All

Fiber Remote (FPEC) Yes All

Note: You cannot configure the MGate card through OTM. You must 
manually configure the MGate card in LD 11.
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Figure 386   PE Cards window

The command results area in the lower portion of the window displays the results 
of Maintenance menu commands.

PE Cards column definitions

The PE Cards window provides columns of information about each card in the 
system. The PE Cards list is initially sorted by TN. Table 47 describes each 
column.

Table 47   PE Cards window column descriptions

Column name Description

Terminal Number 
(loop shelf card)

Address of the card.

Note: TN is replaced with Slot for Option 11C. Tone Service in slot 0 is for DTR/XTD units 
0–7, and DTR/XTD/MFC or MFR units 8–15. The individual units appear in the PE Units 
window.

Card Type The internal value and type of the various loops, as well as the 
name presented to the user. There are two types of line and 
trunks, one for EPE loops and one for Superloops. Superloops 
have a density of octal.
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Supported PE Cards commands

Table 48 lists the supported hardware and PE Cards commands. Use System 
Terminal for hardware or commands not supported by the PE Cards window.

Card Density Density of the card (this can differ from loop density):
• Single

• Double
• Quad
• Octal

Status Current status of the PE Card. The status is a text string up to 
10 characters. This is the same text as output by the 
overlays.

Table 48   Supported PE Cards commands

Hardware Supported
Commands 
supported

IPE/EPE Line cards Yes All

ISDLC cards Yes All

IPE/EPE Trunk cards Yes All

BRI Line cards Yes All

BRI Signaling Processor (BRSC) cards Yes All

Digitone Receivers (DTR) Yes All

Multifrequency Receivers (DTR) Yes All

Tone Detector cards Yes All

Extended Tone Detector (XTD) cards Yes All

Multifrequency Signaling 
(MFC/MFE/MFVE/MFK5/MFK6) cards

Yes All

Table 47   PE Cards window column descriptions (continued)

Column name Description
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PE Units window

The PE Units window displays information for selected PE units and Directory 
Numbers on the Meridian 1 or Succession CSE 1000 system.

Launching PE Units

1 From the System window, under Core Equipment, double-click the PE Units 
icon. The Find PE Units dialog box (Figure 387) appears to allow you to 
select a range of DNs or TNs. This helps you avoid uploading thousands of 
items.

Mobility:
• EIMC
• MXC

Note: These cards appear in the list of cards. However, 
you must use the Mobility application to access all 
maintenance commands for these cards.

Yes
Yes

None
None

ITG cards Yes All

Table 48   Supported PE Cards commands (continued)

Hardware Supported
Commands 
supported
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Figure 387   Find PE Units dialog box

You can view both TNs and DNs in the PE Units window:

• Viewing by TN is more useful than print TNB.

• Viewing by DN is more useful than print DNB.

2 Make a selection of DN or TN, select a range, and then click OK. The PE 
Units window appears as shown in Figure 383 or Figure 389 (depending on 
whether you selected TN or DN) in the Find dialog box.
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Figure 388   PE Units window (by TN)

Figure 389   PE Units window (by DN)

The command results area in the lower portion of the window displays the results 
of Maintenance menu commands.
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PE Units column definitions

The PE Units window provides columns of information about each DN and TN in 
the system. The PE Units window is initially sorted by DN or TN number 
(depending on what you specified in the Find PE Units dialog box). Table 49 
describes each column.

Table 49   PE Units window column descriptions

Column name Description

TN Terminal number address associated with the card. This address 
includes the loop, shelf, card, and unit number for all systems except 
Option 11. For Option 11, this address includes card and unit.

DN Directory number.

Type Type of PE unit.

Status Current status of the PE unit. For a more detailed status report, use 
the Status command on the Maintenance menu.

Designation Additional information about the unit, such as location or cabling 
details, specified by the person who installed the unit.

Prime DN Directory number (DN) associated with key 0 on the telephone.

DN Name Name associated with the directory number.

Customer Customer number associated with the PE unit.

Date Last date data was updated for this unit.

NCOS Network Class of Service group associated with the unit.

Key Telephone key number associated with the directory number (DN).

MARP Indicates whether this telephone is the Multiple Appearance 
Redirection Prime (MARP).
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Supported PE Units commands

Table 50 lists the supported hardware and PE Units commands. Use System 
Terminal for hardware or commands not supported by the PE Units window.

Table 50   Supported PE Units commands

Hardware Supported Commands supported

500 - 500/2500 telephone Yes All

1250 - M1250 Console Yes All

2003 - 2003 telephone Yes All

2006 - M2006 telephone Yes All

I2004 - i2004 Internet telephone (ITG) Yes All

2008 - M2008 telephone Yes All

2009 - M2009 telephone Yes All

2016 - M2016 telephone Yes All

2018 - M2018 telephone Yes All

2112 - M2112 telephone Yes All

2216 - M2216 telephone (ACD) Yes All

2250 - M2250 Console Yes All

2317 - M2317 telephone Yes All

2616 - M2616 telephone Yes All

3000 - M3000 Touchphone Yes All

3901 - M3901 telephone Yes All

3902 - M3902 telephone Yes All

3903 - M3903 telephone Yes All

3904 - M3904 telephone Yes All

3905 - M3905 Call Center telephone Yes All

3903H - M3903 Virtual Office Host 
Telephone

Yes All

3904H - M3904 Virtual Office Host 
Telephone

Yes All

ADM - Add-on Data Module Yes All

Note: The manual test command is not supported for any trunk type. Option 11C Model 
TNs are not supported.
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AID - AIOD trunk Yes All

ATT - QCW3/4 Console Yes All

ATVN - Autovon trunk Yes All

AWR - Automatic Wake-Up RAN/Music trunk Yes All

CMOD - Class Modem Yes All

BRI - Basic Rate Interface Yes All

COT - Central Office Trunk Yes All

CSA - CCSA trunk Yes All

DIC - Dictation trunk Yes All

DCE - Digital Cordless Set Yes All

DID - DID trunk Yes All

DTD - Dial Tone Detector Yes All

DTR - Digitone Receiver Yes All

FEX - Foreign Exchange trunk Yes All

FGDT - Feature Group D Trunk Yes All

IDA - Integrated Digital Access Yes All

ISA - Integrated Services Access trunk 
(ISDN)

Yes All

ITG - Integrated IP Telephony Gateway Yes All

MCU - Communications Unit Yes All

MDECT - Meridian Digitally Enhanced 
Cordless Telecommunications (DECT)

Yes All

MDM - Modem/Data Module Yes All

MFC - Multifrequency Signaling Yes All

MFE - Multifrequency Signaling for Socotel 
sender/receiver

Yes All

MFK5/MFK6 - Spanish KD3 MF Signaling Yes All

MFR - Multifrequency Receiver (FGD) Yes All

MFVE - Multifrequency versatile units Yes All

MUS - Music trunk Yes All

Table 50   Supported PE Units commands (continued)

Hardware Supported Commands supported

Note: The manual test command is not supported for any trunk type. Option 11C Model 
TNs are not supported.
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OOSS - Out of Service Terminal Yes All

PAG - Paging trunk Yes All

PWR - Power Yes All

R232 - Data Access unit Yes All

R422 - Data Access unit Yes All

RAC - Real Analog Channel Yes All

RAN - Recorded Announcement trunk Yes All

RCD - Recorder trunk Yes All

RDC - Real Digital Channel Yes All

RLM - Release Link Main trunk Yes All

Mobility

• MPORTBL
Note: This card appears in the list of cards. 
However, you can only access the 
maintenance commands using the Mobility 
application.

Yes None

RLR - Release Link Remote trunk Yes All

SL1 sets Yes All

TCON - Tandem Connection for MPH No None

TDET - Tone Detector Yes All

TIE - TIE trunk Yes All

VAC - Virtual Analog Channel Yes All

VDC - Virtual Digital Channel Yes All

WAT - Wide Area Telephone Service trunk Yes All

XTD - Extended Dial Tone Detector and 
Digitone Receiver

Yes All

DN types: ACDN, ADCP, CDN, CDP, CHDN, 
DISA, DSDN, FCC, LDN, MCDN, NARS, 
PARK, RDB, REFx, RLDN, RSA, SFP, SS25, 
T100, TSTx, VNS, IADN

Yes These are DNs that have 
no associated TN. 
Typically, the only 
command is print DN 
block.

Table 50   Supported PE Units commands (continued)

Hardware Supported Commands supported

Note: The manual test command is not supported for any trunk type. Option 11C Model 
TNs are not supported.
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B- and D-channels window

The B- and D-channels window displays the channels on the selected digital 
trunk. It allows you to execute overlay commands for a selected channel by 
choosing commands from the Maintenance menu. The results appear in the 
Command Results area of the window. The Cancel button allows you to terminate 
a command in progress.

The following types of channels appear in the B- and D-channels window:

• B-channel on a PRI/PRI2/DTI/DTI2/DPNSS loop

• D-channel on DCHI Card

• D-channel on MSDL Card

• Real Analog Channel (RAC)

• Real Digital Channel (RDC)

• Virtual Analog Channel (VAC)

• Virtual Digital Channel (VDC)

Launching B- and D-channels

1 From the System window, under Core Equipment, double-click the Network 
Loops icon. Select a PRI/PRI2 loop.

2 From the Maintenance menu or the right mouse pop-up menu, select 
Channels. The B- and D-channels window appears (Figure 390).
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Figure 390   Channels window

The command results area in the lower portion of the window displays the results 
of Maintenance menu commands.

B- and D-channels column definitions

The B- and D-channels window provides columns of information about each loop 
in the system. The B- and D-channels list is initially sorted by Channel number. 
Table 51 describes each column.

Table 51   B- and D-channels window column descriptions

Column name Description

Channel Number associated with the channel. PRI loops may have 0–23 
channels; PRI2 loops may have 0–29 channels.

Type Type of channel.

Status Current status of the channel.
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Supported B- and D-channel commands

Table 52 lists the supported hardware and commands. Use System Terminal for 
hardware or B- and D-channel commands not supported by the B- and D-channels 
window.

Inventory Reporting

The OTM Inventory Reporting application allows you to generate system 
inventory files and download them to your PC. The inventory files list cards and 
sets installed in your system.

You must have Microsoft Excel 95 or later to use the Inventory Reporting 
application. You also need an Ethernet connection to your Meridian 1 or 
Succession CSE 1000 system.

Inventory Reporting is based on LD 117. For additional overlay information, see 
the Software Input/Output guide (553-3001-311 and 553-3001-511).

Launch Inventory Reporting

1 In your OTM Navigator window, open a System Window for the Meridian 1 
or Succession CSE 1000 system that you want to inventory (Figure 391 on 
page 797).

2 Connect to that system. (See “Working with the OTM System Window” on 
page 75 for procedures.)

Table 52   Supported B- and D-channels commands

Hardware Supported Commands supported

The window contains the list of channels 
for the selected loop. You can also access 
D-channels from the I/O ports window. 

Yes All, except enable all channels 
on DTI cards and loopback test 
commands

Note: If you do not connect to a system before opening Inventory 
Reporting, some features are disabled.
553-3001-330 Standard 3.00 November 2002



Maintenance applications 797
Figure 391   Sample System Window

3 Once connected, double-click the System Window Inventory icon.

The Inventory window appears (Figure 392).

Note: If you have not connected to a system, a dialog box appears asking 
if you want to connect. Click Yes to connect to a system, or click No to 
proceed without connecting.
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Figure 392   Inventory window

The main Inventory window contains the PC Files frame and the System Files 
frame. The PC Files frame lists inventory files downloaded from the 
Meridian 1 or Succession CSE 1000 system. The System Files frame provides 
status and statistics for the Meridian 1 or Succession CSE 1000 system.

Main window menus

Inventory Reporting’s main window menus include the following commands:

• File

— Open: Open the file selected in the list view of the PC File frame.

— Delete: Delete the file selected in the list view of the PC File frame.

— Exit: Exit the Inventory window.

• View

— Toolbar: Toggle the Inventory toolbar.

— Status Bar: Toggle the status bar.

— Automatic Status: If selected, Inventory Reporting updates the inventory 
file status displayed on the System File frame every 10 seconds.

• Inventory
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— Abort...: Abort any file generation now running on the system.

— Download...: Download one or more inventory files from the system.

— Generate...: Generate one or more inventory files.

— Status: Query the inventory status of the system.

• Help

— Help Topic: Provide a list of Help topics.

— What’s This?: Change the cursor and display Help information about the 
next item you select.

— About Inventory...: Provide Inventory Reporting application release 
information.

Inventory files

The PC Files frame lists all inventory files downloaded from the Meridian 1 or 
Succession CSE 1000 system. There are two types of inventory files available:

• Card Inventory files

• Set Inventory files

To open a file:

1 Select a file in the list.

2 Click File > Open.

Inventory Reporting creates a temporary report file (*.CSV), which opens in 
Microsoft Excel.

To delete a file from the list:

1 Select a file in the list.

2 Click File > Delete.

Card Inventory files

The Card Inventory file provides columns of information in Excel about each card 
configured in the system. Table 53 describes each column.
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Figure 393   Sample Card Inventory file

The following card types are included in the Card Inventory file:

• All IPE and common equipment cards

• All Meridian 1 or Succession CSE 1000 cards that have a Hardware ID (also 
known as ID PROM)

The following card types are not included in the Card Inventory file:

• Cards manufactured without an ID PROM

Table 53   Card Inventory file column descriptions

Column name Description

TYPE Card type.

TN Terminal number address associated with the card.

ID PROM 32 byte ASCII string whose characters (in order) represent:

• Product Engineering Code (PEC)
• Color (numeric representation)
• Release

• One blank character
• Product Serialization ID
• One blank character

• Other (free field)
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• TTY or PC cards

• Power Supply

• Any non-Nortel Networks (third-party) cards, including those designed to 
simulate included cards

Set Inventory files

The Set Inventory file provides columns of information in Excel about each set 
configured in the system. Table 54 describes each column.

Figure 394   Sample Set Inventory file

Table 54   Set Inventory file column descriptions

Column name Description

TYPE Set type.

TN Terminal number address associated with the set.
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The following sets are included in the Set Inventory file:

ID Prom 32 byte ASCII string whose characters (in order) represent:
• Product Engineering Code (PEC)

• Color (numeric representation)
• Release
• One blank character

• Product Serialization ID
• One blank character
• Other (free field)

DESignator 6-character ASCII string used by Station Administration and LD 11.

Primary DN Primary directory number.

M2006 M2008

M2016 M2616

M2216 M390X

M3110 M3310

M3820 IP telephones

Table 54   Set Inventory file column descriptions (continued)

Column name Description
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The following sets (and data units) are not included in the Set Inventory file:

• SL-1 sets and data units

• 500/2500 sets and data units

• Any other digital sets or data units

• Any non-Nortel Networks (third-party) sets, including those designed to 
simulate included sets

Generate an inventory file

You will System Administrator privileges to generate an inventory file.

To generate an inventory file:

1 In the Inventory window, select Inventory > Generate...

The Select file to generate dialog box appears (Figure 395).

Figure 395   Select file to generate

2 Check Card File to generate the Card Inventory file.

• Data units on: M2006 M2008

M2016 M2616

M2216 M390X

M3110 M3310

M3820
Using Optivity Telephony Manager Release 2.0x



804 Maintenance applications
3 Check Set File to generate the Set Inventory file.

4 Click OK to begin generating the file(s).

Download an inventory file

You need System Administrator privileges to download an inventory file.

To download an inventory file:

1 In the Inventory window, select Inventory > Download...

The Select file to download dialog box appears (Figure 396).

Figure 396   Select file to download

2 Check Card File to download the Card Inventory file.

3 Check Set File to download the Set Inventory file.

4 Click OK to begin downloading the file(s).

Note: If both boxes are checked, both files will be generated.

Note: If both boxes are checked, both files are downloaded.
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Check file generation status

To check file status:

1 In the Inventory window, select Inventory > Status.

The System Files frame information is updated. Set and Card Inventory status 
consists of a state value and a substate value. See Table 55 and Table 56 for 
their interpretations.

Abort file generation

You need System Administrator privileges to abort generation of an inventory file.

To abort inventory file generation:

1 In the Inventory window, select Inventory > Abort.

The Select file to abort dialog box appears (Figure 397).

Table 55   Valid state values

State value Meaning

IDLE There is no activity on the switch involving the inventory files.

BUSY An inventory file is in use.

Table 56   Valid substate values

Substate value Meaning

NONE There is no activity on the switch involving the inventory files.

GENERATING An inventory file is being generated by the switch software.

DOWNLOADING An inventory file is being downloaded from the switch to the PC.
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Figure 397   Select file to abort

2 Check Card File to abort generation of the Card Inventory file.

3 Check Set File to abort generation of the Set Inventory file.

4 Click OK to abort generation of the file(s).

Note: If both boxes are checked, both files are aborted.
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Chapter 7
Traffic Analysis

This chapter provides basic information on setting up and running Traffic 
Analysis. To ensure optimum operation of this application, read the material in 
this chapter before attempting to run Traffic Analysis.

Overview

Traffic Analysis performs the following functions:

— Collects traffic data from a specific Meridian 1 or Succession CSE 1000 
system

— Maintains a database of collected traffic data

— Defines report and graph parameters

— Generates reports to extract significant information from raw traffic data, 
such as trunk usage, peak periods, process loads, and junctor and loop 
traffic

About this chapter

This chapter is intended to be an introduction to the Traffic Analysis application, 
as well as an overview of its major functions. It discusses how you can best use it 
to manage traffic data and generate meaningful reports.
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This chapter does not discuss each Traffic Analysis function and command in 
detail. It only discusses the major functions and how they are accessed. For 
detailed information on each Traffic Analysis function and command, use online 
Help. You can use Help to obtain information for topics either directly or via its 
index and word-search functions. You can obtain context-sensitive Help on any 
topic by simply pressing <F1> during the Traffic Analysis session, or by clicking 
Help in the dialog box or window in which it appears.

Traffic Analysis system sizing guidelines

System sizing for Traffic Analysis must consider several factors to ensure 
adequate capacity and throughput to retrieve, store, and report on traffic data. The 
major factors are as follows:

1 Does the system have enough free disk space to store and maintain the traffic 
data?

2 Is there sufficient communications bandwidth to perform traffic data 
collection from all systems in time?

3 Does the system have sufficient resources to provide reports on time?

Traffic Database capacity

The size of the Traffic Database varies depending on the Meridian 1 or Succession 
CSE 1000 system. The Traffic Database will also grow rapidly depending on how 
much data is kept for reporting purposes. Since the active database should 
normally be archived monthly (thus retaining the previous month’s traffic data for 
reporting, as well as updating statistics on the current month), you should expect 
to store about two months of data in the Traffic Database. Older data should be 
routinely archived and moved to external storage. Since, however, it is normally 
stored transiently on disk as well, you should reserve capacity for the archive 
operation.

The actual size of the database depends on your specific configuration parameters, 
such as the number of loops, trunks, consoles, and so on.
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Use the following example formula to estimate the size of the Traffic Database 
(including a one-month archive). This example formula assumes that traffic data 
collection is scheduled for each hour in the day (that is, you are not excluding any 
time for maintenance on the Meridian 1 or Succession CSE 1000 system), and 
that you have 31 days of archived data and 61 days of active data:

24 hours x (61 days + 31 days of archive) = 2208 Traffic Database 
samples

Thus, you should allow for 2500 samples (this allows for temporary files used 
during reporting). Use the following calculation to determine the total bytes 
required for one (1) Traffic Database sample. Once you have calculated the total 
bytes for 1 sample, you must then multiply it by the total number of samples:

1 Traffic Database sample =

[(Network Loops x 29) + (Junctor Groups x 17) +

((C/S Links + A/M Links) x 240) + (D-Channels x 115) +

(Multi-Purpose ISDN Signaling Processors x 59) +

(Customers x 424) + (Route Lists x 299) +

(Individual Attendants x 39) + (Network Classes of Service x 35) +

(Incoming Trunk Groups x 35) + etc.]

Communications throughput

The amount of time that it takes a system to collect traffic data depends on the 
number of systems to collect, the Meridian 1 or Succession CSE 1000 system 
configuration, the communication line speed, and the number of communication 
ports available on the Optivity Telephony Manager (OTM) system.

Traffic data is produced hourly by the Meridian 1 and Succession CSE 1000 
systems. This data is either collected hourly by Traffic Analysis from the 
Meridian 1 or Succession CSE 1000 system, or daily from an optional data buffer 
device, which is connected to the Meridian 1 or Succession CSE 1000 system and 
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stores the hourly data. Once retrieved, the data is compressed by a 4:1 ratio for 
reporting. After having calculated the size of the database sample, you can 
calculate the time required to transfer the data. These calculations allow for 
dialing, connection, logon, traffic data requests, logout, and disconnect:

— No buffer device—hourly:

Seconds to Collect Sample = [Setup + (Compression Ratio x Size of 
Traffic Sample) ÷ Modem Speed]

— With a buffer device—daily:

Seconds to Collect Sample = [Setup + (Hours per Day x Compression 
Ratio x Size of Traffic Sample) ÷ Modem Speed]

The goal is to ensure that the time required to collect data from all systems, using 
all available communications paths, is less than the interval between collection 
cycles. Note that modem speeds are typically rated by baud rate, which roughly 
translates to bits per second. As a rule of thumb, use 10 bits per byte in calculating 
modem speed. A 2400 baud modem delivers about 240 bytes per second.

Sample calculation 

The following is an example for Traffic Database sizing and a communication 
throughput estimate:

Switch Option 61 + 2400 baud modem (no buffer device)

Note: For both cases, allow 40 seconds for setup, and allow 85% 
throughput on modem speed for buffer protocol.

7 Network Loops x 29 = 203

1 Junctor x 17 = 17

1 Link x 240 = 240

0 D-Channels x 115 = 0

0 MISPs x 59 = 0

1 Customer x 424 = 424

9 Route Lists x 299 = 2691
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Hourly:

Daily:

System resources

The resources required to produce reports are provided by the Windows 
environment and are affected by activities on the system. System loads use CPU, 
memory, disk storage, and bandwidth. A typical application such as a word 
processor or electronic mail may generate little CPU load, but can put large 
demands on memory.

In any Windows environment, memory (RAM) can be extended through the use of 
virtual memory. Virtual memory allows the PC to use disk space as if it were 
RAM. Both RAM and virtual memory must be available in sufficient quantity for 
all concurrent system activities. A shortage of memory either prevents an 
application from running or slows the overall system.

1 Ind. Attendant x 39 = 39

0 NCOS’s x 35 = 0

2 In. Trunk 
Groups

x 35 = 70

3684 bytes total

Disk 
Requirements 

= 2500 x 3,684

= 9,210,000 bytes (assumes two months on-line)

Data Collection 
Duration 

= 40 + (4 x 3684) ÷ (240 x 0.85)

= 112 seconds = 1:52 minutes each hour

Data Collection 
Duration 

= 40 + (24 x 4 x 3684) ÷ (240 x 0.85)

= 1774 seconds = 29:34 minutes each day
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CPU loading depends on the frequency and number of reports. While the system 
is designed to concurrently generate multiple reports (only for multiple systems), 
the system runs at maximum throughput when generating one report at a time.

The Windows Print Manager ensures that data from separate reports are not mixed 
up on the printer. To perform this function, the Print Manager temporarily stores 
reports on disk (the Print Manager has a backlog limit of 99 print jobs). Therefore, 
the CPU speed, available virtual memory, and printer speed dictate the time 
required to produce the reports and the practical system limits to traffic data 
throughput.

Getting started

This section contains information used for running and setting up Traffic Analysis 
for initial use.

Before using Traffic Analysis, you must install and configure it as part of the 
Optivity Telephony Manager (OTM) system. Refer to “Configuring Sites, 
Systems, and User accounts” on page 89 for complete details on configuring 
Traffic Analysis and assigning it to a site and system.

System access

To access Traffic Analysis from the OTM Navigator, click the desired site and 
system, and then click Traffic Analysis in the Telemanagement menu. The main 
Traffic Analysis window appears.

After you have assigned Traffic Analysis to a site and system, you can use it to 
collect traffic data, generate reports and graphs, and maintain its databases.
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Before you can begin collecting traffic data and report on it, you must enter the 
parameters for the data collection and report generation processes. The following 
section provides a complete example of how to accomplish these tasks, as well as 
instructions for scheduling and starting data collection from the Meridian 1 or 
Succession CSE 1000 system.

Traffic Analysis example

The following example is provided to assist you in setting up Traffic Analysis.

This example illustrates how to accomplish the following tasks:

— Run OTM and open a site and system.

— Run Traffic Analysis.

— Set up the Meridian 1 or Succession CSE 1000 system for traffic 
collection.

— Collect traffic data from the Meridian 1 or Succession CSE 1000 system.

— Print a D-Channel Report that contains data for incoming and outgoing 
calls.

Warning: When a Limited Access Password (LAPW) is defined to 
collect traffic data from LD 02, configure the password to have access to 
all customers by setting the CUST prompt to ALL. For more information 
about Limited Access to overlays, see Software Features Guide 
(553-3001-306).

Note: The instructions in this example assume that you have successfully 
installed the OTM software and completed the OTM configuration tasks 
described in Chapter 2, “Common services.”
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Run OTM and open site/system

Before you run Traffic Analysis, you must first run the OTM Navigator and open 
this site and system. You can then select Traffic Analysis from the 
Telemanagement menu in this system’s window.

Perform the following steps to open the site and system.

1 Run the OTM Navigator by clicking the OTM Navigator icon. At the Login 
dialog box that appears, enter your user ID and password, and then click OK 
to continue.

2 To open the site and system for this example (for example, site name is Acme 
Company and system name is Head Office), click Acme Company in the 
OTM Navigator window, and then double-click Head Office from this site.

This accesses the system window for the Head Office (Figure 398).

Figure 398   OTM Navigator system window—Acme Company Head Office

Note: This system must already have been created using the System 
Configuration function. Refer to Chapter 2, “Common services,” for more 
details on the System Configuration function.
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Run Traffic Analysis

Perform the following steps to run Traffic Analysis.

1 From the system window, click the Telemanagement menu item. This displays 
the OTM applications that have been assigned to the system Head Office 
under Telemanagement (for example, Telecom Billing System, Call Tracking, 
and Traffic Analysis).

2 To run Traffic Analysis, double-click Traffic Analysis from this menu. The 
Traffic Analysis main window appears (Figure 399).

Figure 399   Traffic Analysis main window

Assign Traffic Analysis to system (if not already assigned)

If Traffic Analysis has not been assigned to this system, it does not appear in the 
Telemanagement menu. To assign Traffic Analysis to this system, perform the 
following steps.

1 Click Properties from the File drop-down menu to access the System 
Properties dialog box.

2 From the System Properties dialog box, first enter a communications profile 
for Traffic Analysis by clicking the Communications tab. In the 
Communications Profile field, enter a profile for Traffic Analysis.

3 Click the Applications tab to assign Traffic Analysis to this system. From the 
Communications Profile drop-down list box, select the communications 
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profile that you just entered in the Communications tab. Click Traffic 
Analysis in the Applications list box to highlight it and turn on the Enable 
check box. Notice that the flag Yes appears in the Enabled field next to Traffic 
Analysis in this list box.

4 Click OK to assign Traffic Analysis to this system. The Traffic Analysis icon 
appears under Telemanagement for the system Head Office.

Set up the Meridian 1 or Succession CSE 1000 system for 
traffic data collection

Follow these steps to set up the Meridian 1 or Succession CSE 1000 system for 
traffic data collection. You only need to perform this step once when you initially 
set up Traffic Analysis.

1 Click Traffic Data Collection from the Maintenance drop-down menu of the 
Traffic Analysis main window.

2 Turn on the Set up PBX for Traffic check box. This enables the Meridian 1 or 
Succession CSE 1000 system to collect and transmit data.

Collect traffic data from the Meridian 1 or Succession CSE 1000 
system

Follow these steps to collect traffic data from the Meridian 1 or Succession 
CSE 1000 system.

1 Click Traffic Data Collection from the Maintenance drop-down menu.

2 Turn on the Schedule Traffic Collection check box.

3 From this dialog box, click OK to start the traffic data collection. This 
schedules the load of traffic data from the Meridian 1 or Succession 
CSE 1000 system to a temporary data file TRAFFIC.DMP for parsing and 
report processing.

Once the system collects the initial traffic data, it then parses it into files with the 
names TFnnnn.DAT (where nnnn identifies the type of report that will be 
generated).
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Print traffic report for incoming and outgoing calls

Follow these steps to print a report for incoming and outgoing calls.

1 Before requesting a printed report, you must select your printer as the output 
device. From the Traffic Analysis window, click File, and then click Specify 
Output Device from its drop-down menu. In the resulting dialog box, click 
Printer, and then click OK.

2 Click Print Setup from the File drop-down menu to select the printer for this 
report. Click OK to save this information and return to the Traffic Analysis 
main window.

3 To print the report, click System Reports from the Reports drop-down menu. 
The System Reports dialog box appears.

4 Click the Report down arrow to open the list of available system reports. To 
select the D-Channel Report, click D-Channel.

5 Click the Profile down arrow to view a list of available profiles for the 
D-Channel report. Select DCHANL.PRO - D-Channel Report. This is the 
default report profile used to select data for the D-Channel Report.

6 Click Edit next to the Profile list box to access the Profile Editor for the 
DCHANL.PRO report profile. A dialog box appears listing the profile’s 
description, options, and parameters. You can enter information here to tailor 
the report.

7 In the Options list, click to select only the following items:

Incoming
Outgoing

De-select any other highlighted items in the list.

8 To save this default profile to a new profile name, click Save As from the File 
drop-down menu. In the Save As dialog box, type: DCHANL1.PRO for the 
file name.

9 Click Close from the File drop-down menu to exit the Profile Editor and 
return to the System Reports dialog box.

10 Click the Filters down arrow to view a list of available filters for the report. 
Click None. This clears the Filters box so that the report includes all collected 
traffic data.

11 Click OK to print this report. A report status box indicates printing progress.
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Help

As with the other OTM applications, Traffic Analysis contains an extensive Help 
facility, which provides you with details on all of its functions and commands. At 
any time during your Traffic Analysis session, you can press <F1> or click Help to 
access information on a specific topic. You can also click Help Topics from the 
Help drop-down menu of the Traffic Analysis main window, and search for Help 
using the Windows Help search functions.

To obtain Help for a topic, press <F1> or click Help from the currently selected 
dialog box or window. This accesses the Windows Help function and displays 
context-sensitive Help information on the current topic.

Once you have accessed Help, use it to scroll through the other Help topics, search 
for a specific topic, and print Help information.

User reference

This section contains a general overview of the main Traffic Analysis functions as 
they are accessed from its main window. It briefly describes their main function 
and purpose. For complete details on each of these functions and their operation, 
refer to the Traffic Analysis online Help function.

File menu

This menu contains functions used to select an output device, set up a printer, and 
exit from Traffic Analysis.

To access these functions, click File from the main window, and then select from 
the following menu items:

— Select Output Device

— Print Setup

— Close
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Reports and graphs

The Traffic Analysis reports and graphs provide the details for the traffic data 
collected from the Meridian 1 or Succession CSE 1000 system. These can be 
printed to an output device, to the screen for review, or to a disk file. Traffic 
Analysis provides a set of profiles and filters to allow you to tailor the output of 
these reports and graphs to suit your needs. Once you have collected the traffic 
data from the Meridian 1 or Succession CSE 1000 system, use the commands in 
the Reports and Graphs menus (following sections) to generate the required 
reports and graphs.

Reports menu

The Reports menu contains functions and commands to print reports based on the 
collected traffic data.

The following are the reports available from Traffic Analysis:

• System Reports

— Network Loops

— Service Loops

— Dial Tone Delay

— Processor Load

— Selected Terminals

— Junctor Group

— Command and Status Links and Application Module Links

— D-Channel

— Multi-Purpose ISDN Signaling Processor Traffic

— Multi-Purpose ISDN Signaling Processor DCH Management

— Multi-Purpose ISDN Signaling Processor Messages

— ISDN Generic Functional Protocol

— General Microcellular Operational Measurements

— UWIN Operational Measurements

• Customer Reports

— Networks

— Trunks
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— Customer Console Measurements

— Individual Console Measurements

— Feature Key Usage

— Radio Paging

— Parallel Radio Paging

— Serial Radio Paging

— Call Park

— Messaging and Auxiliary Processor Links

— Output Message Traffic

— Input Message Traffic

— Message Attendant Queue

— Telephone Set Status

— Telephone Messaging

— Network Attendant Service

— Semi-Permanent Connection Links Establishment

— Music Broadcast

— RAN Broadcast

• Customer Network Reports

— Route Lists

— Off Hook Queuing

— Call Back Queuing 

— Remote Virtual Queuing

— Network Class-of-Service

— Incoming Trunk Group

• System Threshold Reports

— Dial Tone Speed

— Loop Traffic

— Junctor Traffic

— Super Loop Traffic

• Customer Threshold Reports

— Incoming Matching Loss

— Outgoing Matching Loss

— Average Speed of Answer
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— Percent Last Trunk Busy

— Off-Hook Queue Overflow Threshold

• Customer Summary Reports

— Traffic System Summary

— Trunks Summary

— Customer Console Summary

— Individual Console Summary

Graphs menu

Similar to the Reports menu, the Graphs menu contains functions and commands 
to print graphs based on the collected traffic data.

The following are the graphs available from Traffic Analysis:

• System Graphs

— Network Loops

— Processor Load

• Customer Graphs

— Trunks

— Customer Console Measurement

— Messaging and Auxiliary Processor Links

• Customer Network Graphs

— Route Lists

— Off Hook Queuing

• System Threshold Graphs

— Loop Traffic

— Super Loop Traffic

• Customer Threshold Graphs

— Percent Last Trunk Busy
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Generating reports and graphs

To generate a report or graph, select the report or graph type from the Reports 
menu or the Graphs menu. When the Report or Graph dialog box appears, enter its 
optional profile and filter information, and then click OK to print it.

Figure 400 is a sample dialog box in which you can enter reporting criteria and 
generate the report. The corresponding Graphs dialog box operates similarly.

Figure 400   System Reports dialog box

Click the drop-down button to display a list of the reports or graphs in that 
category. Each entry in the list has one or more associated profiles and filters. 
After you click to select a report (or graph), use the same process to select the 
appropriate profile and filter. Edit buttons next to the Profile and Filter boxes let 
you review and modify the selected profile and filter.

Profiles

Profiles define the kind of information to include in a report or graph. Each report 
or graph requires at least one profile. Traffic Analysis includes several default 
profiles for commonly used reports and graphs. You can define a new profile by 
editing one of the default profiles and saving your work under a new profile name. 
Profile file names use the .PRO extension.

Filters

Filters define the range of traffic data to be included on a report or graph, such as 
data for a specific month. Filter file names use the .FLT extension.
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Exporting Reports

The Export function allows you to export traffic data from its reports to disk files 
in specific formats. This function is invoked when a report is generated to the 
screen.

After you have completed your work with profiles and filters, click one of the 
following buttons to proceed:

• OK to produce the report or graph

• Schedule to specify the time at which the report or graph is to be produced

• Help to obtain help for this function

• Cancel to cancel the request and return to the main window

When you have printed or scheduled the output, the system returns to the Traffic 
Analysis window.

“What-if” menu

In addition to generating reports and graphs, you can use Traffic Analysis to ask 
“What if?” questions on data output from the Meridian 1 or Succession CSE 1000 
system. This is accomplished by defining scenarios and viewing hypothetical 
results. These “What if” scenarios provide different results based on new 
situations that you input into the system.

To define a scenario, select it from the list of available scenarios. Next, select a 
profile to define its contents and a filter to set a range for its data. This process is 
similar to producing a report or graph.

You can define the following “What if” scenarios:

• Processor Load

• Trunk

• Attendant Console

To access this function, open the What-if menu in the Traffic Analysis window.
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Processor Load scenario

The Processor Load scenario provides information on rated capacity for your 
Meridian 1 or Succession CSE 1000 system. It lists overall and itemized 
information on the busy hour and the number of attempts at the busy hour rate 
over the rated capacity. It allows you to adjust the call attempts or the CPU type, 
and view the resulting change in busy hour CPU loading time.

Trunk scenario

The Trunk scenario allows you to determine the offered traffic, monthly cost, and 
probability of blocking a trunk or a set of trunk groups. Use this scenario to 
change the offered traffic or the probability of trunk blocking, and view the results 
for the trunks.

Attendant Console scenario

The Attendant Console scenario provides information on console response and 
service levels. Use this scenario to change response times and service levels, and 
to view the results.

Maintenance menu

Traffic Analysis provides maintenance functions that are used to manually collect 
traffic data; manage the Traffic Database; edit report profiles and filters; and edit 
text files.

Traffic Database

The Traffic Database function is used to archive a range of traffic data, as well as 
to merge, delete, and reindex traffic data files.

Note: In the filter for this scenario, enter a range with a minimum of 24 
hours to make the scenario data valid.
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Traffic Data Collection

The Traffic Data Collection function is used to initiate data collection from the 
current Meridian 1 or Succession CSE 1000 system. Use this function to set up 
the Meridian 1 or Succession CSE 1000 system for traffic collection, and to 
schedule traffic data collection. For a complete list of script files used for traffic 
data collection, refer to Appendix B, “Script file summary,” on page B-1.

Profile Editor

Every report or graph requires a profile that defines the data to be included in a 
report or graph. OTM provides default profiles for common reports and graphs. 
Use the Profile Editor to view and edit the options and parameters in a profile. You 
can also use profiles to store and manage sets of configuration and customization 
information.

Filter Editor

Filters define the range of traffic data to be included in a report or graph. The 
Filter Editor allows you to create or edit report filters.

Text File Editor

In certain cases, you may periodically need to view or edit a text file used by 
Traffic Analysis. For example, you may edit the traffic data file collected from the 
Meridian 1 or Succession CSE 1000 system to correct any errors before the 
system processes the file. Use the Text File Editor command to edit any text files 
for Traffic Analysis.
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Chapter 8
ESN Analysis and Reporting Tool

Overview

Electronic Switched Network (ESN) is the Meridian 1 and Succession CSE 1000 
system’s private network application. The ESN Analysis and Reporting Tool 
(ESN ART) is an OTM application designed to assist you in configuring, 
analyzing, and managing large and complex ESN databases.

ESN ART allows you to retrieve the ESN configuration from a Meridian 1 or 
Succession CSE 1000 system, and convert the overlay-based data into a PC 
database. Use the Windows user interface to easily view, modify, and print the 
data. The PC-based data can then be transmitted back to the Meridian 1 or 
Succession CSE 1000 system.

About this chapter

This chapter is intended to provide you with an introduction to the OTM ESN 
ART application, as well as an overview of its major functions.

Help

This chapter does not discuss each ESN ART function and command in detail. It 
only discusses the major functions and how they are accessed. For detailed 
information on each ESN ART function, use the online Help function. You can 
use the Help function to obtain Help for topics either directly or via its index and 
word-search functions. While running ESN ART, you can obtain context-sensitive 
Help on any topic you require by simply clicking Help from a specific dialog box 
or window.
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To obtain Help for a topic, click Help from the currently selected dialog box or 
window. This accesses the Windows Help function and displays context-sensitive 
Help information on the current topic.

Once you have accessed Help, use it to scroll through the other ESN ART Help 
topics, search for a specific topic, or print the Help information.

To view a list of Help topics for ESN ART, click Contents from the Help 
drop-down menu. Choose from one of the items in this list to load the Help file 
and display its information.

ESN ART allows you to manage the ESN data quickly and easily in the following 
ways:

• ESN data retrieval—You can retrieve ESN data blocks from the Meridian 1 or 
Succession CSE 1000 overlays, and ESN ART converts and stores the data in 
a PC database. You can then view and print the data. 

• ESN data installation—You can clone the PC-based ESN data from an 
existing switch to install a new ESN configuration on a similar switch.

• ESN data modification—You can add, change, or delete the retrieved or 
cloned ESN data using the ESN object managers (windows that simplify ESN 
data definition). You can then transfer the modified ESN data from OTM on 
the PC to the Meridian 1 or Succession CSE 1000 system.

• ESN data reporting—You can create reports ranging from basic data to data 
analysis reports. You can send these reports to the screen, to a printer, or to a 
file.

• Export ESN data—You can export Report data to a file. Various file formats 
are supported (for example, Excel or comma-separated values [CSV] format).

• ESN global change data—You can make global changes to these six ESN 
reference objects: DMI, FCI, FSNI, ITEI, RLI, and ROUT.

Note: ESN data refers to ESN data blocks in LD 86 (except Network 
Attendant Service), LD 87, and LD 90.
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From the System window, double-click the ESN icon to launch the ESN ART 
application. The ESN ART window uses the standard OTM tree control and 
displays a folder for each Meridian 1 or Succession CSE 1000 customer (as 
defined in the OTM System Window properties or retrieved from the Meridian 1 
or Succession CSE 1000 system) (Figure 401). 

Figure 401   ESN ART window

Each customer folder expands to show a list of ESN object manager icons. Each 
icon represents a specific type of ESN data or object, such as Digit Manipulation 
Indexes (DMI). To display or hide the ESN application list, double-click the 
customer folder icon, or single-click the plus sign [ + ] or minus sign [ - ].
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Using ESN ART

To edit the ESN data for a customer, double-click that customer’s folder. If ESN 
data has been defined for that customer, a list of ESN object manager icons 
appears in the tree under the customer. An object manager is a window that 
contains a list of instances of the particular ESN object (for example, a list of DMI 
numbers and their attributes). Double-click a particular ESN object manager icon 
to view and manage the associated ESN data.

If a customer does not have any ESN data defined on the OTM PC, then the 
customer folder expands to show the ESN Setup Wizard. This wizard helps you to 
create the ESN data for the customer. See “ESN Setup Wizard” on page 849.

Working with ESN object managers

The ESN data is made up of many types of objects, such as Route List Indexes 
(RLI), Digit Manipulation Indexes (DMI), and Location Codes. In a typical ESN 
installation, most types of objects have many instances (for example, there are 
several instances of DMI numbers for the DMI object). 

ESN ART uses object managers to assist you in viewing and managing all ESN 
objects. For example, double-click the DMI icon to open the DMI object manager. 
The DMI object manager provides a list of each DMI number defined for the 
customer and the values of the various DMI attributes (Figure 402).
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Figure 402   ESN object manager window (DMI in this example)

Each object manager is a separate window (using the standard OTM list control) 
containing the list of instances of the ESN object. The number and content of the 
columns varies for each object manager. Typically, there is one column for each 
property of the object. Most properties correspond to an overlay prompt.

In the example, the DMI list manager shows you the list of all DMI numbers and 
their attributes. To edit the attributes of a particular DMI number, double-click that 
line in the list. The property sheet (Figure 403) for that DMI number appears. This 
is the dialog box that you use to change the values of the DMI feature prompts. 

Using object manager features

You can perform the following actions in an object manager:

• Double-click an object to view and modify the object’s properties. 
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• Add, change, delete, and undelete the selected objects using the EDIT 
pull-down or pop-up menus. 

• Change the status of selected objects to NEW, TRN, OUT, or CHG using the 
EDIT pull-down or pop-up menus. Use this function only if the status 
between the Meridian 1 or Succession CSE 1000 system and the PC is 
“out-of-sync.”

• Click a column title to sort the column. Click again to reverse the order of the 
sort; an arrow icon in the column title indicates ascending (up arrow) or 
descending (down arrow) sort.

• Resize the window and columns.

• Use a horizontal scroll bar to see all the columns (if required).

• Select all or some rows, and then perform the following operations:

— Copy the text of each selected row to the clipboard.

— Delete the selected objects.

• Print all objects using the basic report for the object manager.

Each object manager in ESN ART works as described above. Some object 
manager windows have more than one list displayed in the window, and some 
property sheets have more than one tab, but the principal is always the same.

Working with Property Sheets

Each instance of an ESN object in the object manager’s list has an associated 
property sheet. The property sheet is a dialog box that allows you to modify the 
ESN data for the object (Figure 403). 
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Figure 403   ESN Property sheet (DMI in this example)

The property sheet contains all attributes of an object. Each attribute typically 
corresponds to a prompt in an ESN overlay. (If the associated X11 package is not 
equipped, its controls are disabled in the property sheet.)

Some ESN property sheets have more than one tab. Click a tab to edit the ESN 
data in that tab.

Note: The Name and Comments fields are exceptions to this convention. 
Any information that you enter into these fields is optional, for your 
reference only, and is saved only in the PC database. This data cannot be 
transmitted to the Meridian 1 or Succession CSE 1000 system.
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Property sheet controls

The attributes of an object are represented as Windows controls, such as edit 
boxes and drop-down list boxes. For example, the Yes/No type of prompts are 
represented as check boxes. The names of prompts appear next to the controls. 
Property sheets share the following controls:

• The appearance of the property sheet for adding a new object is different from 
the appearance when changing an object. The title bar is different and the 
object ID (for example, DMI number) is disabled when you are changing an 
object.

• Edit boxes are used for Object IDs and names; multi-line edit boxes are used 
for the Comments field and some repeating data, such as lists of allowed 
dialed digits. Mandatory edit boxes have bold label text. Optional edit boxes 
typically have a default value. Edit boxes have a tool tip pop-up which 
describes the allowed values (for example, “Enter a value between 1 and 32”).

• Check boxes represent the Yes/No type of prompts, where checked means 
Yes. 

• Drop-down list boxes present a list of choices. These correspond to prompts 
with multiple responses. You can type the first letter to make a selection. The 
text in drop-down list boxes includes the actual prompt response followed by 
a short description. For example: 

— NPA: Area Code

— NXX: Central Office Code

• Each control has an associated Help description. Click a control, and then 
press <F1> for help on the selected control. This displays the description on 
the associated prompt in the I/O guide Help.

• Most ESN objects also have a Last Modified date field and a Synchronization 
Status field. These fields appear as read-only text in the property sheet. The 
Status field can have the following values in OTM:

— NEW: added on the PC but not on the Meridian 1 or Succession 
CSE 1000 system. Deleting a new object removes it from the list because 
this change does not need to be synchronized to the Meridian 1 or 
Succession CSE 1000 system. Changing a New object only changes the 

Note: You must delete an object and re-add it to change the object ID.
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Modified timestamp (that is, it is still New until synchronized with the 
Meridian 1 or Succession CSE 1000 system). See “Synchronizing the 
OTM ESN database and the Meridian 1 or Succession CSE 1000 system” 
on page 838.

— TRN: The object has been synchronized with the Meridian 1 or 
Succession CSE 1000 system. The object has been successfully 
transmitted to or retrieved from the Meridian 1 or Succession CSE 1000 
system.

— CHG: The object has been changed on the PC but not on the Meridian 1 
or Succession CSE 1000 system.

— OUT: The object has been deleted on the PC but not on the Meridian 1 or 
Succession CSE 1000 system. The object remains on the PC until 
successfully removed from the Meridian 1 or Succession CSE 1000 
system.

Example

In the DMI example, you may want to change the Call type (CTYP prompt). The 
following example explains editing the CTYP prompt for a particular DMI:

1 In the DMI list, double-click the DMI instance that you want to change (this 
opens the property sheet for that DMI). 

2 Move to the CTYP list box, and select a new value from the list of appropriate 
values. 

3 Click OK. The data is stored in the OTM database ready for transmission to 
the Meridian 1 or Succession CSE 1000 system. (You can click Cancel to 
close the property sheet without changing the ESN data.) 

4 Later, when you synchronize the data between OTM and the Meridian 1 or 
Succession CSE 1000 system, this change is made in the Meridian 1 or 

Note: The initial state of all objects after being cloned from another 
customer is New.
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Succession CSE 1000 system’s ESN data. See “Synchronizing the OTM ESN 
database and the Meridian 1 or Succession CSE 1000 system” on page 838.

Shortcuts

To open a property sheet for an object, you can double-click the object in the list 
in the object manager window. Alternately, right-click the object to open the 
pop-up menu, and select Properties to open the property sheet for that object.

The right mouse button opens a pop-up menu that allows you to add, delete, and 
undelete an object, open the object’s property sheet, and get Help on the object.

Defining ESN Properties

Some ESN data is defined once per customer. The ESN Properties property sheet 
allows you to configure this data in a property sheet (no object manager is needed, 
since there is only one instance of these values for the customer.) To open the ESN 
Properties property sheet, select ESN Properties from the tree.

The following tabs make up the ESN Properties property sheet:

• General Tab: The General tab contains data from ESN Features sections in 
LD 86.

• Limits Tab: The Limits tab contains data from ESN options in LD 86.

• TOD Schedules Tab: The TOD Schedules tab contains Time of Day 
Schedules and Extended TOD schedules from LD 86. 

• Network Control Tab: The Network Control tab contains data from ESN 
Network Control section in LD 87.

• NCOS Map Tab: The NCOS Map tab contains data from Network Class of 
Service mapping from LD 87.

Note: This document does not cover the details of each object type 
because each object manager and property sheet is designed to be fully 
documented in the online Help. You can also request What’s This? Help 
for any field or button while using ESN ART.
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ESN global change

Global change allows you to change all references to an ESN object. For example, 
use global change to find all places where DMI 3 is used, and optionally change it 
to DMI 11.

Example: Changing references to a DMI

1 Select Global Change in the Configuration menu.

2 Select DMI in the first list box.

3 Enter the DMI number to be changed and its new number.

4 Click Find. This generates a list of ESN objects using the DMI number. DMIs 
occur in RLEs, HLOCs, LSCs, NPAs, NXXs, and SPNs.

5 Click Replace. This performs the change in memory and adds the change to 
the Changes Pending list box. The DMI itself is not changed.

6 Repeat the Find and Replace as desired.

7 Click Save to save the changes. The Save cannot be undone. Click Cancel to 
close the window without saving the changes.
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Figure 404   ESN Global Change window

Synchronizing the OTM ESN database and the Meridian 1 
or Succession CSE 1000 system

When you have finished defining the ESN data for a customer, you are ready to 
transmit the data to the Meridian 1 or Succession CSE 1000 system. Alternately, 
you may be ready to retrieve data from a Meridian 1 or Succession CSE 1000 
system to bring your OTM PC up to date. This is called synchronizing the data—
guaranteeing that the ESN data in OTM and on the Meridian 1 or Succession 
CSE 1000 system are “in sync.”
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Use the Synchronize menu to select Transmit To Meridian 1 or Retrieve From 
Meridian 1. You have the option of scheduled or immediate transmission or 
retrieval. You also have the option to view the last transmit or retrieve.

Preparing the ESN ART Environment for Synchronization

Follow these guidelines to assure seamless synchronization:

• The customer data, system software release, and software package 
information stored in the OTM System Property Sheet must be correct. You 
can define this data manually in the System Property sheet under the System 
Data tab, or by using the Update System Data item in the System window.

• When copying an ESN database, if the X11 release and packages are different 
between OTM and the Meridian 1 or Succession CSE 1000 system, the ESN 
data may be impacted as follows:

— Data is lost if the package is not enabled on the destination.

— Default data is used if the package is not enabled on the source.

• ESN ART does not retrieve LD 16 route data. Transmission errors occur if 
you enter invalid route numbers.

• Nortel Networks recommends that you validate ESN data before you transmit 
it to the Meridian 1 or Succession CSE 1000 system.

Note: To synchronize data, the TTY port on the Meridian 1 must be 
configured with a user type of SCH.

Note: Update System Data retrieves the list of customers from the 
Meridian 1 or Succession CSE 1000 system. This does not include the 
User ID and password for the customer. Before retrieving or transmitting 
data, ensure that the correct User ID and password are defined in the OTM 
System Properties.
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Validating ESN data

Whenever you transmit ESN data to the Meridian 1 or Succession CSE 1000 
system, the ESN ART software automatically examines the data to ensure it is 
valid. However, it is a good practice to validate the data before transmitting. From 
the Configuration menu, select Validate ESN Data. The results of the validation 
process appear in a log file and also appear in Windows Word Pad.

Retrieval and transmission

After you have completed the ESN ART environment for synchronization, you 
can retrieve ESN data from the Meridian 1 or Succession CSE 1000 system, or 
transmit ESN data to the Meridian 1 or Succession CSE 1000 system.

Synchronization — Retrieval

Follow these steps to retrieve data from the Meridian 1 or Succession CSE 1000 
system:

1 Launch the ESN application from the site and system that you want.

2 From the ESN main window, select the customer from whom you want to 
retrieve the data.

3 Select File > Synchronize > Retrieve > Now (or Schedule) from the File 
menu.

The Synchronization application is launched and begins the retrieval process. 
When the retrieval is done, the Synchronization application disconnects from the 
Meridian 1 or Succession CSE 1000 system and parses the downloaded ESN data. 
Select Update DB to store the parsed ESN data into the PC database.

Note: If you select Now, your request is sent to the scheduler queue, 
which executes the task within the next minute. If there are tasks in the 
queue that have a higher priority and are scheduled to be executed at the 
same time, they are executed first.

Note: Selection Update DB deletes all existing ESN data for the selected 
customer before saving the new parsed data.
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All of the new data objects have the status TRN after the database has been 
updated, indicating the data on the PC database and the Meridian 1 or Succession 
CSE 1000 system is synchronized. The data can now be modified using the list 
managers and property sheets, and then transmitted back to the Meridian 1 or 
Succession CSE 1000 system.

Synchronization - Transmit

Follow these steps to transmit data on the PC database to the Meridian 1 or 
Succession CSE 1000 system:

1 Launch the ESN application from the site and system that you want.

2 From the ESN main window, select the customer from whom you want to 
retrieve the data.

3 Select Synchronize > Transmit > Now (or Schedule) from the File menu.

The Synchronization application is launched and begins the transmit process. It 
begins by loading ESN data for the selected customer and validates all the ESN 
data objects (on the PC side). The Synchronization application only transmit ESN 
data objects that have the status OUT, NEW, or CHG. However, not all data 
objects are transmitted and updated in the same manner. Based on the status and 
the data objects, they are transmitted to the Meridian 1 or Succession CSE 1000 
system differently. Other data objects that have the TRN status are not transmitted 
to the Meridian 1 or Succession CSE 1000 system. They remain unchanged on the 
PC database. 

ESN data block

The ESN data block is transmitted in a different order when it has the status OUT 
or NEW. If the ESN data block has the OUT status, it is deleted from the 
Meridian 1 or Succession CSE 1000 system last because the system does not 
allow deletion of the ESN data block when there are data remaining in the ESN 
overlays (LD 86, LD 87, LD 90). This also means that the Synchronization 

Note: If you select Now, your request is sent to the scheduler queue, 
which executes the task within the next minute. If there are tasks in the 
queue that have a higher priority and are scheduled to be executed at the 
same time, they are executed first.
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application must successfully delete (from the Meridian 1 or Succession 
CSE 1000 system) all ESN data for the selected customer to be able to 
successfully delete the ESN data block. However, if an error occurs while 
attempting to delete all the ESN data, the Synchronization application does not 
attempt to delete the ESN data block from the Meridian 1 or Succession 
CSE 1000 system.

If the ESN data block has the NEW status, it is transmitted twice. The first time, 
the NEW response (to an REQ prompt) is used to add the new ESN data block. 
However, the Meridian 1 or Succession CSE 1000 system does not ask for the 
NMAP and the ETOD prompts when a NEW response is used, but does so for a 
CHG response. Therefore, the ESN data block is transmitted a second time using 
the CHG response to transmit all of the NMAP and ETOD.

CHG status

Based on the prompt groups, the transmit behaves differently for the status CHG. 
For the simple prompt groups, when their data objects have the status CHG, they 
are transmitted to the Meridian 1 or Succession CSE 1000 system using the CHG 
response, which is straightforward. For the special (more complex) prompt 
groups, they are first deleted from the Meridian 1 or Succession CSE 1000 system 
using the OUT response, and then added (includes the new changes) back to the 
system using the NEW response. These special prompt groups include FCI, FSNI, 
LOC, NPA, NXX, and SPN.

When these data objects are transmitted to the Meridian 1 or Succession 
CSE 1000 system, they are first deleted from the system, and if the deletion was 
successful, their status is immediately changed from OUT to NEW. Then they are 
added back to the Meridian 1 or Succession CSE 1000 system. If that is also 
successful, their status is immediately changed from NEW to TRN. This way, if 
the PC loses connection to the Meridian 1 or Succession CSE 1000 system, or if 
there is a system failure between the delete and the add, then the next transmit 
adds these prompt groups (with the NEW status) back to the Meridian 1 or 
Succession CSE 1000 system.
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Status updates and transmission errors

During transmission of the ESN data objects to the Meridian 1 or Succession 
CSE 1000 system, the Synchronization application updates the status of each 
prompt group accordingly. The table below lists synchronization status updates 
for before and after a successful transmission:

If the Synchronization application detects errors during transmission of ESN data, 
it does not update the status for that data. The status remains unchanged as prior to 
transmission, and the errors are logged in a file.

Console window

Once synchronization starts, the ESN synchronization console window displays 
the interactions between the OTM PC and the Meridian 1 or Succession CSE 1000 
overlays (LD 86, LD 87, and LD 90). 

Table 57   Synchronization status updates

Synchronization status 
before transmission ESN data

Synchronization status 
update on OTM PC after 
transmission

OUT All Remove from database

NEW All TRN

CHG All (except special prompt 
groups)

TRN

*1. CHG (OUT) Special prompt groups only NEW

*2. CHG (NEW) Special prompt groups only TRN

* The items indicated by this symbol actually have one status CHG, but they are 
transmitted in two steps: deleted from Meridian 1 using the OUT response, and added 
back to the Meridian 1 using the NEW response. For each step completed successfully, 
the sync status is changed and updated to the PC database.
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Figure 405   Synchronization console window

The top part of the console window—the Meridian 1 Data section—allows you to 
view the interactions between the PC and the Meridian 1 or Succession CSE 1000 
system. For example, when retrieving ESN data from the Meridian 1 or 
Succession CSE 1000 system, the printout from the ESN overlays appears in this 
window.
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Synchronization log files

The bottom part of the console window, the Synchronization Status section, lists 
the errors found during transmission, retrieval, or parse operations. When 
retrieving the data from the switch, the interactions include many print sequences. 
This process has the potential to pick up transmission errors or TIMxxx (time 
messages) generated by the Meridian 1 or Succession CSE 1000 system. All 
transmission or retrieval information is saved on the OTM PC in the following 
synchronization files (XX represents the customer number):

Nortel\Common Data\[sitename]\[systemname]\
ESN\ESNRetrieveXX.dld

Nortel\Common Data\[sitename]\[systemname]\
ESN\ESNTransmitXX.log

If you encounter retrieval or transmission problems, you can view the retrieve or 
transmit log file to find the basis for the errors.

Login log file

The login information in the Console window can help you determine the reasons 
for login failures. This information is saved in the following login file:

Nortel\Common Data\[sitename]\[systemname]\ESN\SyncLogin.log

Exiting ESN ART or OTM while synchronizing

If you exit the ESN ART application while synchronizing data, the 
synchronization console stays open to allow synchronization to finish.

If you exit OTM while synchronizing data, a confirmation window lets you know 
that synchronization is still in progress. You are given the option to abort the 
synchronization or to allow synchronization to finish. To protect data integrity, 
Nortel Networks strongly recommends that you allow synchronization to finish 
normally.

Note: To edit synchronization log files containing a .dld extension, you 
must have Microsoft Word 97 installed on the OTM PC.
Using Optivity Telephony Manager Release 2.0x



846 ESN Analysis and Reporting Tool
Updating the V&H table

The V&H table contains all North American NPAs and the associated state or 
province. This information is used by the analysis report, which checks for NPAs 
not covered in the NPA object manager.

Select Update V&H table from the File menu to open the following dialog box, 
which allows you to:

• Import new NPAs from the Call Accounting rate table disk

• Manually update the NPAs via Microsoft Access

Figure 406   Update V&H table dialog box

Importing NPAs

When you select the “Update the NPAs from file Database LBU001.mdb” option 
from the Update V&H table dialog box, the standard File Open dialog box 
appears. Select the LBU001.mdb file (usually on a floppy disk). ESN ART then 
reads the NPAs and updates the appropriate datafile. This operation takes 
approximately one minute. You can click Cancel to close the dialog box without 
updating the datafile. A backup of the datafile is made in case of a PC crash during 
the operation. If this occurs, you can try the update again, or rename the old 
database file (called vhDB.mdb) in the ESN Program folder.
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Manually updating NPAs

When you select the “Update the NPAs manually using Microsoft Access” option 
from the Update V&H table dialog box, ESN ART simply opens the database file 
using Microsoft Access. You can then add, change, or delete NPAs as desired and 
save the file. This operation fails if the PC does not have Access.

Printing ESN reports

ESN ART includes many predefined reports to help you in your work. In the File 
menu, select Reports. The Reports window allows you to select one or more 
reports, configure print settings, and schedule the report(s) for a particular time. 
You can print more than one Basic report at a time. 

Figure 407   Reports window

The following predefined reports are available:

• Basic Reports

— DMI - Digit Manipulation Indexes 
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— DSC - CDP Distant Steering Codes 

— ESN - ESN Properties 

— ESN - Equipped Packages 

— FCAS - Free Calling Area Screening Indexes 

— FSNI - Free Special Number Screening Indexes 

— HNPA/HLOC- Translation Tables Summary 

— ITEI - Incoming Trunk Exclusion Indexes 

— LOC - Location Codes 

— LSC - CDP Local Steering Codes 

— NCOS - Network Class of Service 

— NPA - Numbering plan Area Codes 

— NSCL - Network Speed Call 

— NXX - Central Office Translations 

— RLI - Route List Indexes 

— SPN - Special Number Translations 

— TSC - Trunk Steering Codes 

• Analysis Reports 

— DMI - Duplicate Digit Manipulation Indexes 

— DMI - Unused Digit Manipulation Indexes 

— DMI/RLI - Digit Manipulation Index usage in RLIs 

— ESN - Translation Codes Usage 

— NPA - Area Codes not covered in translation tables 

— NPA - Area Codes with no associated SDRR codes 

— NPA - Invalid Area Codes in FCAS and Translation Tables 

— RLI - Route List Index usage in NPAs, NXXs, SPNs 

— RLI - Route List Index TOD Schedules 

• Grouping Reports

— OVL86 - ESN Basic reports on LD 86

— OVL87 - ESN Basic reports on LD 87

— OVL90 - ESN Basic reports on LD 90

— Special - All ESN specialized analysis reports
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ESN Setup Wizard

The ESN Setup Wizard helps you to set up the ESN database for a Meridian 1 or 
Succession CSE 1000 customer. In the Wizard’s first page, you select one of the 
following methods for creating a database:

• Copy from an existing ESN ART PC database.

• Retrieve data from the Meridian 1 or Succession CSE 1000 system.

• Create an empty database.

Figure 408   ESN Setup Wizard
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Click Next to move to the second page. The second page depends on your choice 
in the first page, as follows:

• Copy from an existing ESN ART PC database: This option displays a tree 
with all sites, system, and customers with a PC-based ESN database. Select 
the customer with the data that you want to copy, and then click Finish. This 
creates the ESN database for the customer. All ESN objects are given a status 
of New. You can then modify the data, such as changing the Home Area Code, 
and then transmit the data to the Meridian 1 or Succession CSE 1000 system 
using the Transmit Now or Scheduled option in the File Menu.

• Retrieve data from the Meridian 1: This option retrieves the ESN data from 
the Meridian 1 or Succession CSE 1000 system. This is the same as using the 
Retrieve Now or Schedule option in the File menu.

• Create empty database: This option creates an empty database. Before the 
database is created, you must fill in the mandatory fields (such as the Home 
Area Code) in the ESN Properties.

The ESN Setup Wizard is designed to be documented fully in the online Help. If 
you have any questions while using the Wizard, click Help. You can also request 
What’s This? Help for any field or button. 

Note: When copying an ESN database, if the X11 release and packages 
are different between OTM and the Meridian 1 or Succession CSE 1000 
system, the ESN data may be impacted as follows:

• Data is lost if the package is not enabled on the destination.

• Default data is used if the package is not enabled on the source.
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ESN ART software dependencies

Table 58 shows all object managers in the ESN window tree. Some items appear 
only if the associated software package is equipped on the Meridian 1 or 
Succession CSE 1000 system. The system must have the multi-customer package 
for the customer folders to appear.

Table 58   X11 packages required for the ESN ART object managers

ESN object manager
Software 
package

Customer x - Customer Name cust

ESN Features and Network Control bars/nars

CDP - Coordinated Dialing Plan cdp

• LSC - Local Steering Codes cdp

• DSC - Distant Steering Codes cdp

• TSC - Trunk Steering Codes cdp

DMI - Digit Manipulation Index bars/nars

FCAS - Free Calling Area Screening Index bars/nars

FNSI - Free Special Number Screening Index fnp

ITEI - Incoming Trunk Group Exclusion Index bars/nars

NCOS - Network Class of Service ncos

RLI - Route List Index bars/nars

Translation Tables bars/nars

• HNPA/HLOC - Home NPA and Location Codes bars/nars

• LOC - Location Codes bars/nars

• NPA - Area Codes bars/nars

• NXX - Central Office Codes bars/nars

• SPN - Special Numbers bars/nars

• NSCL - Network Speed Call nars
Using Optivity Telephony Manager Release 2.0x



852 ESN Analysis and Reporting Tool
553-3001-330 Standard 3.00 November 2002



A-1
Appendix A
Using Optivity Telephony Manager Web Desktop 
Services

OTM Web Desktop Services allows you to view and modify the configuration of 
your telephone via a web browser.

The Web display includes a graphical view of the telephone, and shows the 
configured features. Help text is available for the features configured on your 
telephone.

User Login page

Login security ensures protection against unauthorized entry and enforces access 
privileges for logged in users.

To log in to Desktop Services:

1 Start your web browser.

2 Enter the URL provided by your network administrator.

The OTM User Login page opens (Figure A-1).
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Figure A-1   User Login page

3 Enter the User Login name and Password provided to you by your network 
administrator

Your personal Web Desktop Services main page, titled “My Profile,” opens. 
Figure A-2 shows an example of the main page for Al Jones.
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Figure A-2   My Profile page
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Web Desktop Services main page layout

Your Web Desktop Services main page includes the following common elements: 

• Information Banner (top): Contains the Nortel Networks logo, plus Help, 
Logout, and Home buttons. The Help button takes you to general help on how 
to use the web pages. The Home button takes you to your “My Profile” page. 
The logout button takes you to the login page.

• Navigation Bar (left side): Lists hypertext links to various Desktop Service 
pages. When you click an item in the Navigation bar, the related page appears 
in the Content Frame of your web browser.

• Content Frame: Contains the page based on your selection in the Navigation 
bar. There are three types of pages:

— My Profile page: Contains general information about you (name, 
department, address, and so forth). The information displayed is 
determined by your network administrator.

— Telephone pages: Contains telephone configuration data. You may have 
more that one telephone. The information displayed is determined by 
your network administrator.

— Other Links: Contains additional links that may be provided by your 
network administrator.

A line is placed at the bottom of each content page to visually indicate the end of 
the page. If vertical or horizontal scrolling is required, the entire page is scrolled.

Note: In the rare situations where you have telephones on different 
Meridian 1 and Succession CSE 1000 systems managed by the OTM 
Server, the Navigation Tree expands to include the systems as the main 
nodes. You then select the My Profile or Telephone(s) in the desired 
system.
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My Profile page

Once you log in, the main page, My Profile, opens. This page contains general 
information about you. The system retrieves this information from the OTM 
Directory. Click the Home button in the Banner, or click My Profile in the 
Navigation Bar to return to this page.

The information that appears is fixed and cannot be changed. If there is no 
information for a field, it is left blank.

The following information is presented on the My Profile page:

• Employee first, middle, and last name

• Identification (employee ID)

• Job Title

• Org Path (this is extracted from the Organization Path in the OTM directory)

• Manager

• E-mail address

• Login Name

• User Group

• Web Reporting Role

• Address fields

• Description

Telephone pages

Once you have logged in, you are presented with a list of telephones in the 
Navigation Bar. The telephones are identified by prime DN. To get this list, the 
Web Server scans all the employee databases, one per Meridian 1 or Succession 
CSE 1000 system, on the Server.

If you have telephones on different systems, served by different OTM servers, 
then you must log in to the different servers to access these telephones. Your 
network administrator provides you with a URL, User Login name, and Password 
for each of these OTM servers.
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To open the Telephone pages:

The Telephone pages open in the Content Frame with the General page 
displayed (Figure A-3).

Figure A-3   Telephone—General page

Click a Telephone DN in the Navigation Bar.
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The Telephone pages have a small graphic in the top left corner. This graphic is 
detailed enough for you to recognize the type of telephone. The prime DN, or 
extension number, of the telephone also appears at the top of the page.

The Troubleshoot Problems link provides access to the troubleshooting page. See 
page A-15 for more information.

You have up to four Telephone pages, accessed by links below the small telephone 
graphic. The capabilities provided by these web pages depends on your telephone 
type.

Telephone—General page

The General Page provides general information about the telephone. The 
following information appears on the General page:

• Station Location: A text field similar in purpose to the System field. You may 
want to use this to provide more user-friendly names.

• System: Identifies the site, system, and customer number, if applicable, where 
the phone is connected. This information is retrieved from OTM common 
services and displayed in the format “Site - System - Customer x.”

• Phone type (M2616, M3904, and so on)

• Terminal Number (TN): Address of the telephone

• Key Based Modules (for applicable telephone types)

• Designation: A unique 1–8 character telephone identifier. This data is stored 
in station data and the overlays. This field is often used to identify the location 
of the phone within the building (for example, cable pair), and is the response 
to the prompt DES in LD 10 and LD 11.

If allowed by the network administrator, you may change the following fields:

• Station Location

• Key Based Modules

• Designation

If you change one or more of these fields and click Submit, the Confirm Changes 
dialog box opens (Figure A-4).
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Figure A-4   Confirm changes to General Tab

Verify the information and click Confirm. If there are no errors, a change 
confirmation page opens. See “Change confirmation pages” on page A-38 for 
more information.

The Troubleshoot Problems link provides access to the troubleshooting page. See 
page A-15 for more information.

Current configuration/Pending changes

When the information for your telephone has been changed, but the changes have 
not been synchronized with the Meridian 1 or Succession CSE 1000 system, a 
Show Current configuration/Pending changes drop-down box allows you to select 
which configuration is shown.

When there are pending changes, and you have been assigned the “Allow M1 
Synchronization” option in your access profile, the drop-down box is presented 
along with Schedule and Restore buttons. If your access profile allows you to 
make changes to the General, Keys, or Features pages, the Validate button is also 
presented (Figure A-5).
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Figure A-5   Configuration indication with synchronization allowed

Validate button

The Validate button is not available when you are viewing the current 
configuration of your telephone. When your telephone has been marked for 
deletion in the OTM database, the Telephone pages show the deleted 
configuration. The Validate button is not available when you are viewing the 
deleted configuration. Click Validate to validate the changes that have been made 
to the configuration. The validation process determines whether there are any 
errors that can cause problems during synchronization with the Meridian 1 or 
Succession CSE 1000 system. When you click Validate, if there are no errors, the 
page shown in Figure A-6 opens. If there are errors, the Station Validation Results 
indicate the errors that are present in your telephone configuration (Figure A-7).
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Figure A-6   Station Validation Results with no errors

Figure A-7   Station Validation Results with errors

Schedule button

You click Schedule to schedule synchronization with the Meridian 1 or 
Succession CSE 1000 system. When you click Schedule, the Schedule Changes 
dialog box opens (Figure A-8).
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Figure A-8   Schedule Changes dialog box

To schedule a sync task:

1 Enter a Task Name in the Task Name text box.

There is no limit on the number of characters in the name.

2 Use the Task Time text boxes to set the start time for the task.  

Note: The boxes are pre-filled with a time value that is 2 minutes ahead 
of the current time.

Note: If the Task Time passes before you click Next, the task is accepted 
and run immediately after you click Next.
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3 Click the “Do not transmit if the telephone is busy” check box to have the 
sync task check the status of the telephone before making changes to the 
telephone configuration.

4 Click Next.

The Schedule Changes confirmation dialog box opens (Figure A-9).

Figure A-9   Schedule Changes confirmation

Restore button

When you click Restore, the Restore Changes dialog box opens (Figure A-10).

Note: If the telephone is busy, the changes are not made and the event is 
logged in the appropriate transmit log. The transmit is not automatically 
rescheduled. It is up to you to reschedule the transmit.
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Figure A-10   Restore Changes dialog box

If you click Cancel, the dialog box closes. If you click Next, the Restore Changes 
confirmation dialog box opens (Figure A-11).

Figure A-11   Restore Changes confirmation

When there are pending changes, and you do not have the “Allow M1 
Synchronization” option, the drop-down box along with the Validate and Restore 
buttons appear (Figure A-12). You are not allowed to schedule synchronization. 
Your network administrator reviews your changes and schedules synchronization 
for you.
Using Optivity Telephony Manager Release 2.0x



A-14 Using Optivity Telephony Manager Web Desktop Services
Figure A-12   Configuration indication with M1 synchronization not allowed

When the telephone and the Meridian 1 or Succession CSE 1000 system are 
synchronized, “Current Configuration” appears at the top of the page, and the 
drop-down box no longer appears (Figure A-13).

Figure A-13   Configuration indication when there are no pending changes
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Telephone Troubleshooting page

You can access the Telephone Troubleshooting page from the Telephone pages via 
a link. The Telephone Troubleshooting page is shown in Figure A-14. The Reset 
My Phone button performs an enable and status command on this telephone via a 
Maintenance Windows API.

Figure A-14   Telephone Troubleshooting page
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Telephone—Keys page

The Telephone Keys page displays a graphical layout of the function keys 
assigned to the telephone. The layout varies for different telephone types.

All current feature key assignments are always visible. The key labels on the 
graphic match the labels in Station Administration. For M3900 series telephones 
these labels match the soft labels on the set, and the text is shortened to seven 
characters. When the page first appears, key 0 is selected. You can select other 
keys by clicking on a key. Figure A-15 shows an example of the Telephone Keys 
page for an M3904 telephone.

M3903 and M3904 telephones have two layers of feature keys. Use the Shift key 
on the telephone graphic to toggle between the first and second layer. If you have 
either a key-based expansion module or a display-based expansion module 
installed on your telephone, the keys for the expansion module can be accessed by 
clicking the Next link, located below the graphic representing the second layer of 
feature keys.

You may have up to two key-based expansion modules. Use the Next link below 
the graphic representing the first expansion module to access the keys for the 
second module.

The display-based expansion module has three layers of eight keys that are 
accessed by pressing the page key on the module. In OTM, the three layers of keys 
are represented by three separate pages. Use the Next and Previous links below the 
graphic representing the expansion module (Figure A-17 on page A-19) to move 
between the layers. 

When a key is selected, the following occurs:

• The key is highlighted. The method used to highlight depends on the phone 
type.

• The name of the key and its configurable parameters, if any, appear beside the 
telephone graphic.

A Help button takes you to Help on how to use the selected key.
553-3001-330 Standard 3.00 November 2002



Using Optivity Telephony Manager Web Desktop Services A-17
Figure A-15   Telephone Keys page—first layer

If the telephone has one or two key-based modules, or a display-based module, a 
graphic indicates which set of keys appears. Next and Previous links allow you to 
“scroll” the graphic from one set of keys to another. 
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Figure A-16 shows the user interface for the keys on an M3904 telephone 
equipped with a display-based expansion module. Click the Next link to view the 
features assigned to the first layer of keys on the module (Figure A-17 on 
page A-19).

Figure A-16   Telephone Keys page—second layer with an expansion module link
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Figure A-17   Display-based expansion module keys—first layer
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Changing a key

If permitted by your access profile, when you click Change after selecting a key, a 
new browser window opens with the appropriate controls for changing the key 
you selected. In this browser window, a list of the possible key choices appears 
(Figure A-18). This list is dynamic and is based on both the telephone type and the 
key selected. For example, key 17 on an M2317 telephone must be a transfer key.

Figure A-18   Select Auto Dial key type

The Help button is context sensitive and accesses the information in the Input/
Output guide on configuring a key for the selected feature or service.

The key’s parameters, if any, appear on subsequent pages of the wizard.

Note: The Clear button removes the key function and takes you to the 
next page in the key change wizard. As shown in Figure A-18, if the 
telephone key that you have selected is currently unassigned (null), the 
Clear button does not appear.
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Changing the parameters of an Auto Dial key

Use the following procedure to change the telephone number assigned to an Auto 
Dial key:

1 Click a key in the graphic on the Telephone Keys page.

2 Click Change. The Key Change Wizard launches.

3 Click “ADL — Auto Dial” in the list of key types (Figure A-18).

4 Click Open.

5 Type the new maximum number of digits and the new Autodial DN in the edit 
boxes (Figure A-19). 

Figure A-19   Autodial key change wizard

Note: If you change the Number of Auto Dial digits to a value that is 
greater than the default number in the Meridian 1 or Succession 
CSE 1000 system, or if you enter an Auto Dial Number that has more 
digits than the default value, you receive a validation error.

Note: You use the Find DN button to look up Directory Numbers. It 
appears whenever there is a DN edit box. For information on using the 
Find DN button, see “Finding Directory Numbers” on page A-30.
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6 Click Submit.

The key change summary page opens (Figure A-20).

Figure A-20   ADL key change summary

7 Click Confirm.

A confirmation page appears. See “Change confirmation pages” on 
page A-38.

Changing the parameters of an MCR DN key

Use the following procedure to change the first name and last name parameters 
associated with an MCR DN key:

1 Click an MCR DN key in the graphic on the Telephone Keys page 
(Figure A-15).

2 Click Change.

The Key Change Wizard launches. The current key type, MCR - Multiple Call 
Ringing, is highlighted (Figure A-21).
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Figure A-21   Select Multiple Call Ringing key type

3 Since you are not changing the key type, simply click Open.

The key change wizard displays the current parameters for the selected key 
(Figure A-22).

Note: You can only modify the DN, CPND, and CLID. You may not 
view or change the DN’s Voice Mailbox, ANI, or MARP. 

Note: When the Name Display Link to Directory check box is checked 
in Station Administration, the values for the First Name and Last Name 
fields are obtained from the directory and are not editable.

Note: If the key change wizard does not display a Directory Number, or 
if you want to change the Directory Number, see “Finding Directory 
Numbers” on page A-30.
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Figure A-22   Current parameters for Multiple Call Ringing DN key

4 Change the First Name and Last Name (Figure A-23).

Figure A-23   Changed parameters for Multiple Call Ringing DN key
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5 Click Submit.

A summary page opens that displays your changes (Figure A-24).

Figure A-24   MCR key change summary page

6 Click Confirm. A confirmation page appears. See “Change confirmation 
pages” on page A-38.

Changing a key type

In the following procedure, you change a Conference key to a Call Forward key:

1 Click the Conference key in the graphic on the Telephone Keys page 
(Figure A-16 on page A-18).

2 Click Change.

The Key Change Wizard launches. The current key type is highlighted. 
(Figure A-25).
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Figure A-25   Key Change Wizard displaying the current key type

3 Click CFW - Forward All Calls in the list of key types (Figure A-26).

Figure A-26   Select the Forward All Calls key type

4 Click Open.
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5 Enter the Redirection DN Length and Redirection DN in the edit boxes 
(Figure A-27).

Figure A-27   Forward All Calls Key Change Wizard

6 Click Submit.

The key change summary page opens (Figure A-28).

Note: When changing a key type, the default values do not appear. If 
you enter a Redirection DN length that is greater than the default value in 
the Meridian 1 or Succession CSE 1000 system, or if you enter a 
Redirection DN that has more digits than the default value, you receive a 
validation error.
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Figure A-28   CFW Key Change summary page

7 Click Confirm.

A confirmation page appears. See “Change confirmation pages” on 
page A-38.

Removing a key

Use the following procedure to remove the function associated with a key, 
creating a blank, or unassigned, key:

1 Click a key in the graphic on the Telephone Keys page (Figure A-15 on 
page A-17).

2 Click Change.

The Key Change Wizard launches. The function associated with the selected 
key is highlighted in the list (Forward All Calls in this example) 
(Figure A-29).
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Figure A-29   Current key function displayed in the Key Change Wizard

3 Click Clear.

The key change summary page opens a (Figure A-30).

Figure A-30   Unassigned Key Change summary page

4 Click Confirm.

A confirmation page appears. See “Change confirmation pages” on 
page A-38.
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Finding Directory Numbers

You use the Find DN button to look up used or unused Directory Numbers. It 
appears next to the edit box for any DN key.

Find Unused Directory Numbers

1 Click Find DN (Figure A-22 on page A-24). The Find Directory Numbers 
page opens (Figure A-31).

Figure A-31   Find Directory Numbers page

2 Click the Find Unused DNs radio button.

3 Enter a range of DNs on which to search.

Note: You must have a Numbering Plan defined in the System 
Properties in OTM Windows Navigator to use the Find Unused DNs 
feature. If the Numbering Plan is not defined, or if there are no unused 
DNs, an error message appears (Figure A-33).
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4 Click Find. If unused DNs are found, a page similar to the example shown in 
Figure A-32 appears. If there are no unused DNs found, the message shown in 
Figure A-33 appears.

Figure A-32   Find results when Unused DNs exist

Note: Only the unused DNs belonging to the same site, system, and 
customer as your telephone are shown.

Note: If you click Find Again, you return to the previous page, and you 
can enter a different range of DNs.
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Figure A-33   Find results when no Unused DNs exist

Find Used Directory Numbers

1 Click Find DN (Figure A-22 on page A-24). The Find Directory Numbers 
page opens (Figure A-31).

2 Click the Find Used DNs radio button.

3 Click the radio button that corresponds to your search criteria:

• To search by DN, enter a range of DNs on which to search.

• To search by last name, enter the last name of the person whose name is 
assigned to the DN you are seeking.

• To search by first name, enter the first name of the person whose name is 
assigned to the DN you are seeking.

4 Click Find. If DNs that match your search criteria are found, a page similar to 
the example shown in Figure A-34 opens. If there are no DNs that match your 
search criteria, a message similar to the one shown in Figure A-35 opens.
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Figure A-34   Find results when there are matching used DNs

Figure A-35   Find results when there are no matching used DNs
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Telephone—Features page

The Telephone Features page allows you to view and change features that are not 
assigned to keys. Features are related to individual prompts in LD 10 or 11, with 
one or more configurable parameters.

Your network administrator determines which features you can see in the list. If 
your access profile allows changes, the Submit and Reset buttons appear 
(Figure A-36).

Whenever possible, a drop-down list box containing all possible values for the 
feature is provided. In cases where this is not possible (for example, when 
entering a call forward DN), an edit box is provided.
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Figure A-36   Telephone Features page
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Telephone—Details page

The Telephone Details page provides a summary of the complete telephone 
configuration. It consists of two sections, one for the keys (Figure A-37), and one 
for the features (Figure A-38).

Figure A-37   Telephone Details layout (keys)
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Figure A-38   Telephone Details layout (features)
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Change confirmation pages

A confirmation page appears when you click the Confirm button in the change 
summary page for the General, Keys, or Features tab. The confirmation page 
varies based on your access profile.

When your access profile allows the Meridian 1 or Succession CSE 1000 
synchronization option, the page shown in Figure A-39 appears.

Figure A-39   User confirmation with automatic synchronization

If your access profile does not permit automatic synchronization, the changes 
must be approved by the network administrator, and the page shown in 
Figure A-40 appears.

Figure A-40   User confirmation when network administrator approval is required

If there is a validation error, you are presented with an error message similar to the 
example shown in Figure A-41.
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Figure A-41   Example of a validation error message

Telephone change procedure

The following procedure outlines the steps that you take to make changes to your 
telephone.

1 Launch a supported web browser, and then navigate to the OTM host name or 
IP address provided by your network administrator.

2 Log in to Desktop Services using the Login Name and Password provided by 
your network administrator.

The My Profile web page appears. This contains your OTM Directory 
information (Figure A-2 on page A-3).

3 Click a telephone extension link in the Navigation Bar.

The General page appears. If allowed by your network administrator, you can 
change the Station Location, Key Based Modules, and Designation fields 
(Figure A-3 on page A-6).

To make a change:

a Enter the new value, and then click Submit.

A page containing a summary of your changes opens (Figure A-4 on 
page A-8).

b Click Confirm.
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A confirmation message appears (Figure A-39 through Figure A-41 
beginning on page A-38).

4 Click Keys.

The Keys page appears. If allowed by your network administrator, you can 
change the key-based features, or functions, assigned to any of the keys. To 
make a change:

a In the graphical representation of your telephone, click the key you want 
to change (Figure A-15 on page A-17).

b Click Change.

A list of the available choices for the selected key appears in the Key 
Change Wizard (Figure A-18 on page A-20).

c Select a new key-based feature to assign to the key, and then click Open.

d If required, the Key Change Wizard opens a page that requests that you 
enter the parameters for the selected key (Figure A-19 on page A-21). 
Enter the parameters.

e Click Submit.

A page containing a summary of your changes opens (Figure A-20 on 
page A-22).

f Click Confirm.

A confirmation message appears (Figure A-39 through Figure A-41 
beginning on page A-38).

5 Click Features.

Note: The sync status of the telephone appears at the top of the 
Telephone pages. When the information for the telephone has been 
changed, but the changes have not been synchronized with the 
Meridian 1 or Succession CSE 1000 system, a Show Current 
configuration/Pending changes drop-down box allows you to select 
which configuration is shown. Once the telephone and the system have 
been synchronized, “Current configuration” appears at the top of the 
page, and the drop-down box no longer appears.
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The Features page appears. If permitted by your network administrator, you 
can change the allowed/denied status of features assigned to your extension 
(Figure A-36 on page A-35).

To make a change:

a Do one of the following:

• Select the appropriate value for the desired feature from the drop down 
box.

• Enter the value of the parameter associated with the desired feature in the 
edit box.

b Click Submit.

A page containing a summary of your changes opens.

c Click Confirm.

A confirmation message appears (Figure A-39 through Figure A-41 
beginning on page A-38).

6 Click Details.

Information on the Keys and Features currently assigned to your telephone 
appears on the Details page. This page is always read only (Figure A-37 on 
page A-36, and Figure A-38 on page A-37).

7 If a Schedule button appears at the top if the Telephones pages, your network 
administrator has permitted you to automatically synchronize all of the 
changes you have made with the information stored on the Meridian 1 or 
Succession CSE 1000 system. If there is no Schedule button, your network 
administrator reviews your changes and manually synchronizes the changes 
with the Meridian 1 or Succession CSE 1000 system. If the Schedule button is 
present:

a Click Schedule.

b Wait a few moments for the synchronization to occur.

c Click Refresh in your browser.

When the Show Current configuration/Pending changes drop-down list no 
longer appears, all of your changes have been made and the telephone has 
the new configuration.
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8 If it has been configured by your network administrator, click the Billing 
Reports link in the Navigation Bar to view your telephone billing reports from 
the Telecom Billing System (TBS). TBS Web Reporting is available with 
OTM 1.2 and later.
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Appendix B
Script file summary

This appendix contains a list of all of the script files used for the OTM 
applications. A script is a pre-written program that contains a set of commands 
and functions required to perform specific activities. Some scripts are defined for 
specific PC and Meridian 1 or Succession CSE 1000 configurations and are 
therefore, selected based on each user’s configuration. Most OTM scripts, 
however, are defined for the general operation of the OTM applications and are 
therefore, automatically selected to perform specific functions within OTM.

Common Services scripts

The following script files are used by the OTM Common Services applications. 
They are automatically selected whenever you run OTM and apply to all of the 
OTM applications as a whole. You do not need to select these script files to 
perform a required function:

HAYESMDM.SCR Functional script used by Common Services applications 
for connection with Hayes compatible modems.

CUSTMDM.SCR Functional script used by Common Services applications 
for connection with customized modems.

M1MODEM.SCR Functional support script used to access far-end 
equipment (for example, dispatcher modems).

ERROR.SCR Functional script required for error handling.
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Telecom Billing System scripts

The following script files are used by the Telecom Billing System to perform data 
collection. Select the script file that matches your data collection and processing 
requirements.

Real-time CDR data collection

The following script files are used for real-time CDR data collection from the 
Meridian 1; no buffer unit is required:

CDR data collection from MDR-2000

The following script file is used for data collection from an MDR-2000 buffer 
unit:

Sample data collection

The following script file is used to collect CDR data from a sample file. This is 
used for testing purposes:  

SL1OLD.COL Real-time data collection script for Old format CDR.

SL1NEW.COL Real-time data collection script for New format CDR.

MDR2000.COL Data collection script, which collects New format CDR 
from MDR-2000 to produce normalized CDR (erases 
contents of buffer). MDR-2000 requires a chip that is 
compatible with X11 Release 23.

SAMPLE.COL Data collection script, which collects sample CDR data from 
the sample file in the Telecom Billing System directory.
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Traffic Analysis scripts

The script files used by OTM Traffic Analysis provide the main functions required 
for traffic data collection and report generation. The data collection script files are 
selected when you enter your Meridian 1 or Succession CSE 1000 information 
and communications parameters. The report generation script files are 
automatically selected when you generate reports.

Real-time traffic data collection

The following script files are used for real-time traffic data collection (no buffer 
unit). They are automatically selected when you set up this site for real-time 
traffic data collection (from the OTM Site Configuration application):

Traffic data collection from MDR-2000

The following script files are used for traffic data collection from an MDR-2000 
buffer unit. They are automatically selected when you set up this site for traffic 
data collection through the MDR-2000 buffer unit (from the OTM Site 
Configuration application):

LD2.SCR Main traffic data collection scripts.

LD2INI.SCR Functional script used by LD2.SCR (used to initialize 
Meridian 1 and Succession CSE 1000 systems to have 
collection performed hourly).

LOGSL1.SCR Functional script used by LD2.SCR.

M2K.SCR Main traffic data collection script.

M2KINI.SCR Functional script used by M2K.SCR (used to initialize 
Meridian 1 and Succession CSE 1000 systems to have 
collection performed hourly in pass-through mode).
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Traffic data collection from PollCat II/III

The following script file is used for traffic data collection from the PollCat II/III 
buffer units. It is automatically selected when you set up this site for traffic data 
collection using the PollCat II/III buffer units (from the OTM Site Configuration 
application):

Traffic data collection from AT1/AT2

The following script files are used for traffic data collection from the AT1 and 
AT2 buffer units. They are automatically selected when you set up this site for 
traffic data collection using the AT1 or AT2 buffer units (from the OTM Site 
Configuration application):

Traffic data collection from SEB II

The following script file is used for traffic data collection from the SEB II buffer 
unit. It is automatically selected when you set up this site for traffic data collection 
using the SEB II buffer unit (from the OTM Site Configuration application):

Traffic data collection from Sentinel 2000

The following script file is used for traffic data collection from the Sentinel 2000 
buffer unit. It is automatically selected when you set up this site for traffic data 
collection using the Sentinel 2000 buffer unit (from the OTM Site Configuration 
application):

POLL.SCR Main traffic data collection script.

TSB1.SCR Main traffic data collection script for AT1 buffer unit.

TSB2.SCR Main traffic data collection script for AT2 buffer unit.

SEBTRAF.SCR Main traffic data collection script.

SNLTRAF.SCR Main traffic data collection script.
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Traffic Analysis report generation

The following script files are used for report generation. They are automatically 
selected when you generate Traffic Analysis reports:

The following script files are used for the Data Parser as part of the report 
generation process. They are automatically selected when processing data for 
Traffic Analysis reports:

AUXPLK.SCR AVGSOA.SCR CALPRK.SCR CBKQUE.SCR

CONSOL.SCR CSAML1.SCR CSAML2.SCR CSAML3.SCR

CSAML4.SCR CSAML5.SCR CSAML6.SCR CSAMLI.SCR

CSAMLK.SCR CUSCON.SCR DCHANL.SCR DTDLAY.SCR

DTNSPD.SCR FEAKEY.SCR GLOBAL.SCR GLPTRF.SCR

GMSGAP.SCR GNTLPS.SCR GOHQUE.SCR GPCLTB.SCR

GPROCL.SCR GROUTL.SCR GSUTRF.SCR GTRNKS.SCR

ICONSL.SCR IMTCHL.SCR INPMSG.SCR INTRKG.SCR

ISDNPD.SCR ISDNPM.SCR ISDNPT.SCR JCTRAF.SCR

JCTRGP.SCR LPTRAF.SCR MICRO.SCR MSGATQ.SCR

MUSBRD.SCR NCOSVC.SCR NETLPS.SCR NETWKS.SCR

NTATSV.SCR OHKOVT.SCR OHKQUE.SCR OMTCHL.SCR

OUTMSG.SCR PCTLTB.SCR PRADIO.SCR PROCLD.SCR

RADPAG.SCR RANBRD.SCR RTLREQ.SCR SELTRM.SCR

SLTRAF.SCR SRADIO.SCR SUMCCO.SCR SUMICO.SCR

SUMSYS.SCR SUMTRK.SCR SVCLPS.SCR TMESSG.SCR

TRUNKS.SCR TSETST.SCR WATCON.SCR WPRCLD.SCR

WTRNKS.SCR

TFC000.SCR TFC001.SCR TFC002.SCR TFC003.SCR

TFC004.SCR TFC005.SCR TFC006.SCR TFC007.SCR

TFC008.SCR TFC009.SCR TFC10X.SCR TFC101.SCR

TFC105.SCR TFN001.SCR TFN002.SCR TFN101.SCR
Using Optivity Telephony Manager Release 2.0x



B-6 Script file summary
Call Tracking scripts

The following script files are used by Call Tracking to perform data collection and 
real-time monitoring. Certain script files are automatically selected when you 
enter your configuration parameters in the OTM Site Configuration application. 
These represent the common scripts for data collection.

For example, if you define SDI1 to have real-time CDR data collection performed 
from it, then SDI1 is configured to run the real-time CDR data collection scripts 
SL1.SCR and SL1LOGIN.SCR.

If you collect CDR data from a data file (for example, if you select the File option 
from the Call Tracking Communications database), then you can select the 
filename from which you will collect the CDR data, and then select a script 
filename for that particular format of CDR data. For example, if you select a file 
for data collection that contains normalized CDR data, then you select the script 
file COLLECT.SCR.

Real-time CDR data collection

The following script files are used for real-time CDR data collection from the 
Meridian 1 and Succession CSE 1000 systems. No buffer unit is required:

TFS000.SCR TFS001.SCR TFS002.SCR TFS003.SCR

TFS004.SCR TFS005.SCR TFS007.SCR TFS008.SCR

TFS009.SCR TFS010.SCR TFS011.SCR TFS012.SCR

TFS013.SCR TFS50X.SCR TFS101.SCR TFS102.SCR

TFS105.SCR TFS41X.SCR TRAFFIC.SCR TRFAXS.SCR

TRFCDR.SCR TRFCUS.SCR TRFNET.SCR TRFSYS.SCR

SL1.SCR Real-time data collection script for Old format CDR.

SL1NEW.SCR Real-time data collection script for New format CDR.

SL1NEWX.SCR Real-time data collection script for New format CDR; 
supports X11 Release 23.
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CDR data collection from MDR-2000

The following script files are used for data collection from an MDR-2000 buffer 
unit:

CDR data collection from PollCat II/III

The following script files are used for data collection from the PollCat II/III buffer 
units:

SL1EURO.SCR Real-time data collection script for New format CDR with 
Periodic Pulse Metering.

SL1EUROX.SCR Real-time data collection script for “New” format CDR with 
Periodic Pulse Metering; supports X11 Release 23.

SL1LOGIN.SCR Functional script used by above-mentioned data collection 
scripts.

COLLECT.SCR Data collection script, which collects Old format CDR from 
MDR-2000 to produce normalized CDR (erases contents of 
buffer).

COLLECTX.SCR Data collection script, which collects New format CDR from 
MDR-2000 to produce normalized CDR (erases contents of 
buffer); MDR-2000 requires a chip that is compatible with 
X11 Release 23.

2000FD.SCR Data collection script, which monitors in real-time Old 
format CDR from an MDR-2000.

2000FDX.SCR Data collection script, which monitors in real time New 
format CDR from an MDR-2000; MDR-2000 requires a chip 
that is compatible with X11 Release 23.

POLLCDR.SCR CDR data collection script for PollCat II/III buffer units.

PARSESL1.SCR Functional script used by POLLCDR.SCR.

POLLNEWX.SCR CDR data collection script for PollCat II/III buffer units; 
supports X11 Release 23.

NEWCDRX.SCR Functional script used by POLLNEWX.SCR.
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CDR data collection from AT1/AT2

The following script files are used for data collection from the AT1 and AT2 
buffer units:

CDR data collection from SEB II

The following script files are used for data collection from the SEB II buffer unit:

CDR data collection from Sentinel 2000

The following script files are used for data collection from a Sentinel 2000 buffer 
unit:

AT1CDR.SCR CDR data collection script for AT1 buffer unit.

AT2CDR.SCR CDR data collection script for AT2 buffer unit.

PARSESL1.SCR Functional script used by AT1CDR.SCR and AT2CDR.SCR 
script files.

AT1NEWX.SCR New format CDR data collection script for AT1 buffer unit; 
supports X11 Release 23.

AT2NEWX.SCR New format CDR data collection script for AT2 buffer unit; 
supports X11 Release 23.

NEWCDRX.SCR Functional script used by AT1NEWX.SCR and 
AT2NEWX.SCR script files.

SEB.SCR CDR data collection script for SEB II buffer unit.

PARSESL1.SCR Functional script used by SEB.SCR script file.

SEBNEWX.SCR New format CDR data collection script for SEB II buffer 
unit; supports X11 Release 23.

NEWCDRX.SCR Functional script used by SEBNEWX.SCR script file.

SNLCDR.SCR CDR data collection script for Sentinel 2000 buffer unit.

SNLCDRX.SCR CDR data collection script for Sentinel 2000 buffer unit; 
supports X11 Release 23.
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Call Tracking alarm scripts

The following script files are used for Call Tracking alarms. They are 
automatically selected when you define the Call Tracking alarms:

CDR data collection modem scripts

The following script files are supporting function scripts used by all CDR data 
collection scripts for Call Tracking. The appropriate script is automatically used 
when you select Hayes or Custom as the format for the modem for CDR data 
collection from the OTM Site Configuration application.

If you enter custom modem information when setting up a site, then the custom 
modem script file is updated with the appropriate parameters:

CMALARM.SCR Call Tracking alarm script.

CMPAGER.SCR Call Tracking alarm pager script.

HAYES.SCR Functional script used by all CDR data collection scripts in 
Call Tracking for connection with Hayes-compatible 
modems.

CUSTOM.SCR Functional script used by all CDR data collection scripts in 
Call Tracking for connection with customized modems 
(updated with correct parameters).
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Script usage table

The following table lists the types of scripts that are selected for different 
scenarios for Call Tracking. These represent the main scripts that can be selected 
to suit a particular scenario. All other scripts are automatically selected depending 
on these script selections.

Table B-1   Script usage table

To Use

Perform real-time CDR data collection from Meridian 1 and 
Succession CSE 1000 systems

SL1.SCR

Collect CDR from MDR-2000 buffer unit COLLECT.SCR

Collect CDR from PollCat II/III buffer units POLLCDR.SCR

Collect CDR from AT1 buffer unit AT1CDR.SCR

Collect CDR from AT2 buffer unit AT2CDR.SCR

Collect CDR from SEB II buffer unit SEB.SCR

Collect Traffic data from SEB II buffer unit SEBTRAF.SCR

Collect CDR from Sentinel 2000 buffer unit SNLCDR.SCR
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Appendix C
Control files included with alarm notification

This appendix displays the control files that are loaded into the OTM PC when the 
Alarm Notification application is installed. These files are loaded into the default 
location C:\Nortel\Common Data\Alarm Notification\Control Files unless 
otherwise specified.

Caution: Always use a copy of these files when customizing them for 
your specific environment. Do not use the original files supplied with 
your OTM product. These files are overwritten when OTM is reinstalled 
or upgraded; if you have customized the original files, any changes will 
be lost.
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Devices file

This section shows the content of the Devices.txt file included with the 
application.

# This file contains a list of specific devices to be monitored by 
# Alarm Notification.  As this file may be replaced during a software upgrade,
# it is suggested that any changes be made in a copy and the copy used.
# The following are example definitions:
#
#Meridian1 192.9.200.1 my_m1
#Meridian1 192.9.200.2
#Meridian1 sample_m1

#OTM 47.82.40.57
#MMCS 47.32.164.69
#ITG 47.82.45.161
#ITG_ISDN_TRK 47.82.46.64
#ITG_IP_LINE 47.114.40.31
#ITG_IP_PHONE 47.114.40.31
#ISS7 47.49.4.78
#BRAVO 47.49.4.80
#CALL_PILOT 47.235.12.85
#BS450 47.32.164.80
#MMCS_AP 47.49.4.20
#MMAIL 47.24.42.12
#SCCS       47.44.14.160
#CALL_SERVER 47.147.74.31
#SIGNALLING_SERVER  47.32.164.90 
#MEDIA_CARD 47.147.74.41
#
# User provided devices should be added below this line.

Meridian1 47.114.45.3
Meridian1 47.114.45.5
Meridian1 47.114.45.7
MMCS      47.114.45.2
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Configuration file

This section shows the content of the Config.txt file included with the application.

# These are the SNMP trap definitions for Nortel supported devices.

# This file is replaced during a software upgrade, so we suggest
# that you backup this file before an upgrade and also before changing it.

device BRAVO 6.1 6.2 6.3 6.4 6.5 6.6 {
   1.3.6.1.4.1.562.3.11.4.4.1.7.2.0 string  $SystemComponent        "System Component"
   1.3.6.1.4.1.562.3.11.4.4.1.7.3.0 string  $DeviceTime             "Device Time"
   1.3.6.1.4.1.562.3.11.4.4.1.7.4.0 integer $ActiveListStatus       "Active Status"
   1.3.6.1.4.1.562.3.11.4.4.1.7.5.0 integer $Severity               "Severity"
   1.3.6.1.4.1.562.3.11.4.4.1.7.6.0 integer $AlarmType              "Alarm Type"
   1.3.6.1.4.1.562.3.11.4.4.1.7.7.0 integer $ProbableCause          "Probable Cause"
   1.3.6.1.4.1.562.3.11.4.4.1.7.8.0 string  $ErrorCode              "Error Code"
   1.3.6.1.4.1.562.3.11.4.4.1.7.9.0 string  $OperatorData           "Operator Data"
}

device BS450 0.0 1.0 2.0 3.0 4.0 5.0 {
   1.3.6.1.2.1.2.2.1.1.1 integer            $Port1                  "Port 1"
   1.3.6.1.2.1.2.2.1.1.2 integer            $Port2                  "Port 2"
   1.3.6.1.2.1.2.2.1.1.3 integer            $Port3                  "Port 3"
   1.3.6.1.2.1.2.2.1.1.4 integer            $Port4                  "Port 4"
   1.3.6.1.2.1.2.2.1.1.5 integer            $Port5                  "Port 5"
   1.3.6.1.2.1.2.2.1.1.6 integer            $Port6                  "Port 6"
   1.3.6.1.2.1.2.2.1.1.7 integer            $Port7                  "Port 7"
   1.3.6.1.2.1.2.2.1.1.8 integer            $Port8                  "Port 8"
   1.3.6.1.2.1.2.2.1.1.9 integer            $Port9                  "Port 9"
   1.3.6.1.2.1.2.2.1.1.10 integer           $Port10                 "Port 10"
   1.3.6.1.2.1.2.2.1.1.11 integer           $Port11                 "Port 11"
   1.3.6.1.2.1.2.2.1.1.12 integer           $Port12                 "Port 12"
   1.3.6.1.2.1.2.2.1.1.13 integer           $Port13                 "Port 13"
   1.3.6.1.2.1.2.2.1.1.14 integer           $Port14                 "Port 14"
   1.3.6.1.2.1.2.2.1.1.15 integer           $Port15                 "Port 15"
   1.3.6.1.2.1.2.2.1.1.16 integer           $Port16                 "Port 16"
   1.3.6.1.2.1.2.2.1.1.17 integer           $Port17                 "Port 17"
   1.3.6.1.2.1.2.2.1.1.18 integer           $Port18                 "Port 18"
   1.3.6.1.2.1.2.2.1.1.19 integer           $Port19                 "Port 19"
   1.3.6.1.2.1.2.2.1.1.20 integer           $Port20                 "Port 20"
   1.3.6.1.2.1.2.2.1.1.21 integer           $Port21                 "Port 21"
   1.3.6.1.2.1.2.2.1.1.22 integer           $Port22                 "Port 22"
   1.3.6.1.2.1.2.2.1.1.23 integer           $Port23                 "Port 23"
   1.3.6.1.2.1.2.2.1.1.24 integer           $Port24                 "Port 24"
}

device CALL_PILOT 6.1 6.2 6.3 6.4 {
   1.3.6.1.4.1.562.3.8.2.5.2.1.1.0 integer  $AlarmSeqNum            "Alarm Seq Num"
   1.3.6.1.4.1.562.3.8.2.5.2.1.2.0 string   $DeviceTime             "Device Time"
   1.3.6.1.4.1.562.3.8.2.5.2.1.3.0 integer  $AlarmCode              "Error Code"
   1.3.6.1.4.1.562.3.8.2.5.2.1.4.0 integer  $AlarmType              "Alarm Type"
   1.3.6.1.4.1.562.3.8.2.5.2.1.5.0 integer  $Severity               "Severity"
   1.3.6.1.4.1.562.3.8.2.5.2.1.6.0 integer  $TenantID               "Tenant ID"
   1.3.6.1.4.1.562.3.8.2.5.2.1.7.0 integer  $CustomerID             "Customer ID"
   1.3.6.1.4.1.562.3.8.2.5.2.1.8.0 string   $SystemComponent        "System Component"
   1.3.6.1.4.1.562.3.8.2.5.2.1.9.0 string   $OperatorData           "Operator Data"
}

device ISS7 6.1 6.2 6.3 6.4 6.5 6.6 {
   1.3.6.1.4.1.562.27.2.1.7.2.0 string      $SystemComponent        "System Component"
   1.3.6.1.4.1.562.27.2.1.7.3.0 string      $DeviceTime             "Device Time"
   1.3.6.1.4.1.562.27.2.1.7.4.0 integer     $ActiveListStatus       "Active Status"
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   1.3.6.1.4.1.562.27.2.1.7.5.0 integer     $Severity               "Severity"
   1.3.6.1.4.1.562.27.2.1.7.6.0 integer     $AlarmType              "Alarm Type"
   1.3.6.1.4.1.562.27.2.1.7.7.0 integer     $ProbableCause          "Probable Cause"
   1.3.6.1.4.1.562.27.2.1.7.8.0 string      $ErrorCode              "Ntp Index"
   1.3.6.1.4.1.562.27.2.1.7.9.0 string      $OperatorData           "Operator Data"
}

device ITG 6.1 6.2 6.3 6.4 6.5 6.6 {
   1.3.6.1.4.1.562.3.11.1.4.1.7.2.0 string  $SystemComponent        "System Component"
   1.3.6.1.4.1.562.3.11.1.4.1.7.3.0 string  $DeviceTime             "Device Time"
   1.3.6.1.4.1.562.3.11.1.4.1.7.4.0 integer $ActiveListStatus       "Active Status"
   1.3.6.1.4.1.562.3.11.1.4.1.7.5.0 integer $Severity               "Severity"
   1.3.6.1.4.1.562.3.11.1.4.1.7.6.0 integer $AlarmType              "Alarm Type"
   1.3.6.1.4.1.562.3.11.1.4.1.7.7.0 integer $ProbableCause          "Probable Cause"
   1.3.6.1.4.1.562.3.11.1.4.1.7.8.0 string  $ErrorCode              "Ntp Index"
   1.3.6.1.4.1.562.3.11.1.4.1.7.9.0 string  $OperatorData           "Operator Data"
}

device ITG_ISDN_TRK 6.1 6.2 6.3 6.4 6.5 6.6 {
   1.3.6.1.4.1.562.3.11.2.4.1.7.2.0 string  $SystemComponent        "System Component"
   1.3.6.1.4.1.562.3.11.2.4.1.7.3.0 string  $DeviceTime             "Device Time"
   1.3.6.1.4.1.562.3.11.2.4.1.7.4.0 integer $ActiveListStatus       "Active Status"
   1.3.6.1.4.1.562.3.11.2.4.1.7.5.0 integer $Severity               "Severity"
   1.3.6.1.4.1.562.3.11.2.4.1.7.6.0 integer $AlarmType              "Alarm Type"
   1.3.6.1.4.1.562.3.11.2.4.1.7.7.0 integer $ProbableCause          "Probable Cause"
   1.3.6.1.4.1.562.3.11.2.4.1.7.8.0 string  $ErrorCode              "Ntp Index"
   1.3.6.1.4.1.562.3.11.2.4.1.7.9.0 string  $OperatorData           "Operator Data"
}

device ITG_IP_LINE 6.1 6.2 6.3 6.4 6.5 6.6 {
   1.3.6.1.4.1.562.3.11.5.4.1.7.2.0 string  $SystemComponent        "System Component"
   1.3.6.1.4.1.562.3.11.5.4.1.7.3.0 string  $DeviceTime             "Device Time"
   1.3.6.1.4.1.562.3.11.5.4.1.7.4.0 integer $ActiveListStatus       "Active Status"
   1.3.6.1.4.1.562.3.11.5.4.1.7.5.0 integer $Severity               "Severity"
   1.3.6.1.4.1.562.3.11.5.4.1.7.6.0 integer $AlarmType              "Alarm Type"
   1.3.6.1.4.1.562.3.11.5.4.1.7.7.0 integer $ProbableCause          "Probable Cause"
   1.3.6.1.4.1.562.3.11.5.4.1.7.8.0 string  $ErrorCode              "Ntp Index"
   1.3.6.1.4.1.562.3.11.5.4.1.7.9.0 string  $OperatorData           "Operator Data"
}

device ITG_IP_PHONE 6.1 6.2 6.3 6.4 6.5 6.6 {
   1.3.6.1.4.1.562.3.11.5.4.1.7.2.0 string  $SystemComponent        "System Component"
   1.3.6.1.4.1.562.3.11.5.4.1.7.3.0 string  $DeviceTime             "Device Time"
   1.3.6.1.4.1.562.3.11.5.4.1.7.4.0 integer $ActiveListStatus       "Active Status"
   1.3.6.1.4.1.562.3.11.5.4.1.7.5.0 integer $Severity               "Severity"
   1.3.6.1.4.1.562.3.11.5.4.1.7.6.0 integer $AlarmType              "Alarm Type"
   1.3.6.1.4.1.562.3.11.5.4.1.7.7.0 integer $ProbableCause          "Probable Cause"
   1.3.6.1.4.1.562.3.11.5.4.1.7.8.0 string  $ErrorCode              "Ntp Index"
   1.3.6.1.4.1.562.3.11.5.4.1.7.9.0 string  $OperatorData           "Operator Data"
}

device MDECT 6.1 6.2 6.3 6.4 6.6 6.9 6.10 {
  1.3.6.1.4.1.1417.1.1.1.5.0     string     $DeviceTime             "Device Time"
  1.3.6.1.4.1.1417.1.1.3.2.1.2.0 string     $OperatorData           "Operator Data"
  1.3.6.1.4.1.1417.1.1.3.3.1.4.0 string     $OperatorData           "Operator Data"
  1.3.6.1.4.1.1417.1.1.3.3.1.8.0 string     $OperatorData           "Operator Data"
  1.3.6.1.4.1.1417.1.1.3.9.0     string     $OperatorData           "Operator Data"
  1.3.6.1.4.1.1417.1.1.3.5.1.0   string     $OperatorData           "Operator Data"
  1.3.6.1.4.1.1417.1.1.3.7.0     string     $OperatorData           "Operator Data"
  1.3.6.1.4.1.1417.1.1.2.1.6.0   string     $OperatorData           "Operator Data"
  1.3.6.1.4.1.1417.1.1.3.1.0     string     $ErrorCode              "Error Code"
}

device Meridian1 6.10 {
   1.3.6.1.4.1.562.3.3.7.1.0  integer       $AlarmSeqNum            "Alarm Seq Num"
   1.3.6.1.4.1.562.3.3.7.2.0  string        $DeviceTime             "Device Time"
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   1.3.6.1.4.1.562.3.3.7.3.0  integer       $Severity               "Severity"
   1.3.6.1.4.1.562.3.3.7.4.0  string        $ErrorCode              "Error Code"
   1.3.6.1.4.1.562.3.3.7.5.0  string        $SystemComponent        "System Component"
   1.3.6.1.4.1.562.3.3.7.6.0  string        $ComponentAddress       "Component Address"
   1.3.6.1.4.1.562.3.3.7.7.0  string        $Text                   "Text"
   1.3.6.1.4.1.562.3.3.7.8.0  string        $OperatorData           "Operator Data"
   1.3.6.1.4.1.562.3.3.7.9.0  string        $ExpertData             "Expert Data"
   1.3.6.1.4.1.562.3.3.7.10.0 string        $CurrentAlarmCounts
}

device CALL_SERVER 6.10 {
   1.3.6.1.4.1.562.3.3.7.1.0  integer       $AlarmSeqNum            "Alarm Seq Num"
   1.3.6.1.4.1.562.3.3.7.2.0  string        $DeviceTime             "Device Time"
   1.3.6.1.4.1.562.3.3.7.3.0  integer       $Severity               "Severity"
   1.3.6.1.4.1.562.3.3.7.4.0  string        $ErrorCode              "Error Code"
   1.3.6.1.4.1.562.3.3.7.5.0  string        $SystemComponent        "System Component"
   1.3.6.1.4.1.562.3.3.7.6.0  string        $ComponentAddress       "Component Address"
   1.3.6.1.4.1.562.3.3.7.7.0  string        $Text                   "Text"
   1.3.6.1.4.1.562.3.3.7.8.0  string        $OperatorData           "Operator Data"
   1.3.6.1.4.1.562.3.3.7.9.0  string        $ExpertData             "Expert Data"
   1.3.6.1.4.1.562.3.3.7.10.0 string        $CurrentAlarmCounts
}

device MEDIA_CARD 6.1 6.2 6.3 6.4 6.5 6.6 {
   1.3.6.1.4.1.562.3.11.5.4.1.7.2.0 string  $SystemComponent        "System Component"
   1.3.6.1.4.1.562.3.11.5.4.1.7.3.0 string  $DeviceTime             "Device Time"
   1.3.6.1.4.1.562.3.11.5.4.1.7.4.0 integer $ActiveListStatus       "Active Status"
   1.3.6.1.4.1.562.3.11.5.4.1.7.5.0 integer $Severity               "Severity"
   1.3.6.1.4.1.562.3.11.5.4.1.7.6.0 integer $AlarmType              "Alarm Type"
   1.3.6.1.4.1.562.3.11.5.4.1.7.7.0 integer $ProbableCause          "Probable Cause"
   1.3.6.1.4.1.562.3.11.5.4.1.7.8.0 string  $ErrorCode              "Ntp Index"
   1.3.6.1.4.1.562.3.11.5.4.1.7.9.0 string  $OperatorData           "Operator Data"
}

device SIGNALLING_SERVER 6.1 6.2 6.3 6.4 6.5 6.6 {
   1.3.6.1.4.1.562.3.21.5.4.1.7.2.0 string  $SystemComponent        "System Component"
   1.3.6.1.4.1.562.3.21.5.4.1.7.3.0 string  $DeviceTime             "Device Time"
   1.3.6.1.4.1.562.3.21.5.4.1.7.4.0 integer $ActiveListStatus       "Active Status"
   1.3.6.1.4.1.562.3.21.5.4.1.7.5.0 integer $Severity               "Severity"
   1.3.6.1.4.1.562.3.21.5.4.1.7.6.0 integer $AlarmType              "Alarm Type"
   1.3.6.1.4.1.562.3.21.5.4.1.7.7.0 integer $ProbableCause          "Probable Cause"
   1.3.6.1.4.1.562.3.21.5.4.1.7.8.0 string  $ErrorCode              "Ntp Index"
   1.3.6.1.4.1.562.3.21.5.4.1.7.9.0 string  $OperatorData           "Operator Data"
}

device MMAIL 6.1 6.2 6.3 6.4 {
   1.3.6.1.4.1.562.3.10.2.1.1.0  string     $DeviceTime             "Device Time"
   1.3.6.1.4.1.562.3.10.2.1.2.0  integer    $Severity               "Severity"
   1.3.6.1.4.1.562.3.10.2.1.3.0  integer    $SeerType               "Seer Type"
   1.3.6.1.4.1.562.3.10.2.1.4.0  string     $ErrorCode              "Error Code"
   1.3.6.1.4.1.562.3.10.2.1.5.0  string     $SystemComponent        "System Component"
   1.3.6.1.4.1.562.3.10.2.1.6.0  integer    $SeerNode               "Seer Node"
   1.3.6.1.4.1.562.3.10.2.1.7.0  string     $System                 "System"
   1.3.6.1.4.1.562.3.10.2.1.8.0  string     $OperatorData           "Operator Data"
   1.3.6.1.4.1.562.3.10.2.1.9.0  string     $Text                   "Text"
   1.3.6.1.4.1.562.3.10.2.1.10.0 string     $ExpertData             "Expert Data"
}

device MMCS 6.10 {
   1.3.6.1.4.1.562.3.3.7.1.0 integer        $AlarmSeqNum            "Alarm Seq Num"
   1.3.6.1.4.1.562.3.3.7.2.0 string         $DeviceTime             "Device Time"
   1.3.6.1.4.1.562.3.3.7.3.0 integer        $Severity               "Severity"
   1.3.6.1.4.1.562.3.3.7.4.0 string         $ErrorCode              "Error Code"
   1.3.6.1.4.1.562.3.3.7.5.0 string         $SystemComponent        "System Component"
   1.3.6.1.4.1.562.3.3.7.6.0 string         $ComponentAddress       "Component Address"
   1.3.6.1.4.1.562.3.3.7.7.0 string         $Text                   "Text"
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   1.3.6.1.4.1.562.3.3.7.8.0 string         $OperatorData           "Operator Data"
   1.3.6.1.4.1.562.3.3.7.9.0 string         $ExpertData             "Expert Data"
   1.3.6.1.4.1.562.3.3.7.10.0 string        $CurrentAlarmCounts
}

device MMCS_AP 6.1 6.2 6.3 6.4 6.5 6.6 {
   1.3.6.1.4.1.562.27.2.1.7.2.0 string      $SystemComponent        "System Component"
   1.3.6.1.4.1.562.27.2.1.7.3.0 string      $DeviceTime             "Device Time"
   1.3.6.1.4.1.562.27.2.1.7.4.0 integer     $ActiveListStatus       "Active Status"
   1.3.6.1.4.1.562.27.2.1.7.5.0 integer     $Severity               "Severity"
   1.3.6.1.4.1.562.27.2.1.7.6.0 integer     $AlarmType              "Alarm Type"
   1.3.6.1.4.1.562.27.2.1.7.7.0 integer     $ProbableCause          "Probable Cause"
   1.3.6.1.4.1.562.27.2.1.7.8.0 string      $ErrorCode              "Error Code"
   1.3.6.1.4.1.562.27.2.1.7.9.0 string      $OperatorData           "Operator Data"
}

device OTM 6.1 6.2 6.3 6.4 6.5 6.6 {
   1.3.6.1.4.1.562.50.1.2.1.0  integer      $AlarmSeqNum            "Alarm Seq Num"
   1.3.6.1.4.1.562.50.1.2.2.0  string       $DeviceTime             "Device Time"
   1.3.6.1.4.1.562.50.1.2.3.0  integer      $Severity               "Severity"
   1.3.6.1.4.1.562.50.1.2.4.0  integer      $NameSpace              "Name Space"
   1.3.6.1.4.1.562.50.1.2.5.0  string       $ErrorCode              "Error Code"
   1.3.6.1.4.1.562.50.1.2.6.0  string       $Site                   "Site"
   1.3.6.1.4.1.562.50.1.2.7.0  string       $System                 "System"
   1.3.6.1.4.1.562.50.1.2.8.0  string       $SystemComponent        "System Component"
   1.3.6.1.4.1.562.50.1.2.9.0  string       $OriginatingAgent       "Orig. Agent"
   1.3.6.1.4.1.562.50.1.2.12.0 string       $OperatorData           "Operator Data"
   1.3.6.1.4.1.562.50.1.2.13.0 string       $ExpertData             "Expert Data"  
   1.3.6.1.4.1.562.50.1.2.14.0 string       $Text                   "Text" 
}

device SCCS 6.1 6.2 6.3 6.4 {
   1.3.6.1.4.1.562.3.8.1.5.2.1.1.0 integer  $AlarmSeqNum            "Alarm Seq Num"
   1.3.6.1.4.1.562.3.8.1.5.2.1.2.0 string   $DeviceTime             "Device Time"
   1.3.6.1.4.1.562.3.8.1.5.2.1.3.0 integer  $AlarmCode              "Error Code"
   1.3.6.1.4.1.562.3.8.1.5.2.1.4.0 integer  $AlarmType              "Alarm Type"
   1.3.6.1.4.1.562.3.8.1.5.2.1.5.0 integer  $Severity               "Severity"
   1.3.6.1.4.1.562.3.8.1.5.2.1.6.0 integer  $TenantID               "Tenant ID"
   1.3.6.1.4.1.562.3.8.1.5.2.1.7.0 integer  $CustomerID             "Customer ID"
   1.3.6.1.4.1.562.3.8.1.5.2.1.8.0 string   $SystemComponent        "System Component"
   1.3.6.1.4.1.562.3.8.1.5.2.1.9.0 string   $OperatorData           "Operator Data"
}

device SL100 6.1 6.2 6.3 6.4 6.5 6.6 {
   1.3.6.1.4.1.562.50.1.2.1.0  integer      $AlarmSeqNum            "Alarm Seq Num"
   1.3.6.1.4.1.562.50.1.2.2.0  string       $DeviceTime             "Device Time"
   1.3.6.1.4.1.562.50.1.2.3.0  integer      $Severity               "Severity"
   1.3.6.1.4.1.562.50.1.2.4.0  integer      $NameSpace              "Name Space"
   1.3.6.1.4.1.562.50.1.2.5.0  string       $ErrorCode              "Error Code"
   1.3.6.1.4.1.562.50.1.2.6.0  string       $Site                   "Site"
   1.3.6.1.4.1.562.50.1.2.7.0  string       $System                 "System"
   1.3.6.1.4.1.562.50.1.2.8.0  string       $SystemComponent        "System Component"
   1.3.6.1.4.1.562.50.1.2.9.0  string       $OriginatingAgent       "Orig. Agent"
   1.3.6.1.4.1.562.50.1.2.12.0 string       $OperatorData           "Operator Data"
   1.3.6.1.4.1.562.50.1.2.13.0 string       $ExpertData             "Expert Data"  
   1.3.6.1.4.1.562.50.1.2.14.0 string       $Text                   "Text" 
}

# Add user supplied device definitions below this comment line.
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Script files

This section shows the content of the sample_an_script.txt and the 
sample_wizard_script.txt files included with the OTM application. 

Sample Alarm Notification script file

The content of the file sample_an_script.txt appears below:

// ***************************************************************************************
//
//                                  Alarm Notification Scripts
//
// ***************************************************************************************

// ***************************************************************************************
// Map severities from the various traps that OTM receives into a standard severity list.
// ***************************************************************************************

counter $NormalizedSeverity := 0;

counter Undetermined := 0;
counter Critical := 1;
counter Major := 2;
counter Minor := 3;
counter Warning := 4;
counter Info := 5;
counter Cleared := 6;
counter Unknown := 7;

// ==========================================================================
//                           Map OTM severities
// ==========================================================================
// 1 -> Critical; 2 -> Major; 3 -> Minor; 4 -> Info; 5 -> Info; 6 -> Cleared; 7 -> Unknown; x -> Undetermined

script AssignOTMSeverities when ( $CurrentTrapDevice = "OTM" ) {
function assignit() {

if ($Severity=Critical) {
$NormalizedSeverity:=Critical;

}else{ if ($Severity=Major) {
$NormalizedSeverity:=Major;

}else{ if ($Severity=Minor) {
$NormalizedSeverity:=Minor;

}else{ if ($Severity=Info) {
$NormalizedSeverity:=Info;

}else{ if ($Severity=Unknown) {
$NormalizedSeverity:=Unknown;

}else{ if ($Severity=Warning) {
$NormalizedSeverity:=Warning;

}else{ if ($Severity=Cleared){
$NormalizedSeverity:=Cleared;

}else{
$NormalizedSeverity:=Undetermined;

}}}}}}}
}
rule assign_severity {

if ($CurrentTrapDevice="OTM") {
assignit();

}
}

}
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// ==========================================================================
//                           Map MDECT severities
// ==========================================================================

// All MDECT Alarms should be Critical 

script AssignMDECTSeverities when ( $CurrentTrapDevice = "MDECT" ) 
{
  function assignit() 
  {
    $NormalizedSeverity := Critical;
  }
  rule assign_severity 
  {
    if ($CurrentTrapDevice = "MDECT") 
    {
      assignit();
    }
  }
}

// ==========================================================================
//                 Map severities from Meridian1 Open Alarms
// ==========================================================================
// 1 -> Minor; 2 -> Major; 3 -> Critical; 4 -> Unknown; 5 -> Warning; 6 -> Cleared; 7 -> Undetermined; x -> Info

script convertM1Severities when ( $CurrentTrapDevice = "Meridian1" ) {
function convertit() {

if ($Severity=1){
$NormalizedSeverity:=Minor;

}else{ if ($Severity=2){
$NormalizedSeverity:=Major;

}else{ if ($Severity=3){
$NormalizedSeverity:=Critical;

}else{ if ($Severity=4){
$NormalizedSeverity:=Unknown;

}else{ if ($Severity=5){
$NormalizedSeverity:=Warning;

}else{ if ($Severity=6){
$NormalizedSeverity:=Cleared;

}else{ if ($Severity=7){
$NormalizedSeverity:=Undetermined;

}else{
$NormalizedSeverity:=Info;

}}}}}}}
}
// ----------------------------------------------------------------
rule severity_conversion {

if ($CurrentTrapDevice="Meridian1"){
convertit();

}
}

}

// ===========================================================================
//           Map severities from devices other than OTM, MDECT and Meridian1
// ===========================================================================
// 1 -> Critical; 2 -> Major; 3 -> Minor; 4 -> (CallPilot::Info, Warning); 5 -> (CallPilot::Unknown, Cleared); x 
-> Undetermined

script convertSeverities when ($CurrentTrapDevice != "OTM" 
      and $CurrentTrapDevice != "Meridian1" 
      and $CurrentTrapDevice != "CALL_SERVER" and $CurrentTrapDevice != "MMCS"
      and $CurrentTrapDevice != "MDECT") 
{

function convertit() {
if ($Severity=1) {

$NormalizedSeverity:=Critical;
}else{ if ($Severity=2){
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$NormalizedSeverity:=Major;
}else{ if ($Severity=3){

$NormalizedSeverity:=Minor;
}else{ if ($Severity=4){

if ($CurrentTrapDevice="CALL_PILOT"){
$NormalizedSeverity:=Info;

}else{
$NormalizedSeverity:=Warning;

}
}else{ if ($Severity=5){

if ($CurrentTrapDevice="CALL_PILOT"){
$NormalizedSeverity:=Unknown;

}else{
$NormalizedSeverity:=Cleared;

}
}else{

$NormalizedSeverity:=Undetermined;
}}}}}

}

  rule severity_conversion 
  {
    if ($CurrentTrapDevice !="OTM" and $CurrentTrapDevice != "Meridian1"
          and $CurrentTrapDevice != "CALL_SERVER" and $CurrentTrapDevice != "MMCS"
          and $CurrentTrapDevice != "MDECT") 
    {
      convertit();
    }
  }
}

// ***************************************************************************************
//                                  Assign $NameSpace
// ***************************************************************************************

counter nsOtm               := 1; // Originated from an OTM
counter nsMeridian1         := 2;
counter nsCallPilot         := 3;
counter nsMeridianMail      := 4;
counter nsSl100             := 5;
counter nsPassport          := 6;
counter nsItg               := 7;
counter nsBravo             := 8;
counter nsIss7              := 9;
counter nsMDECT             := 10;
counter nsCallServer    := 11;
counter nsMediaCard    := 12;
counter nsSigServer    := 13;
counter nsSccs := 14;
counter nsMeridianMailLink := 15;
counter nsGenericOrUnknown := 16;

script assignNameSpace {

function ns() {
if ($CurrentTrapDevice="OTM") {

// Original $CurrentTrapDevice is retained
}else{ if ( $CurrentTrapDevice = "Meridian1") {

$NameSpace := nsMeridian1;
}else{ if ( $CurrentTrapDevice = "CALL_PILOT" ) {

$NameSpace := nsCallPilot;
}else{ if ( $CurrentTrapDevice = "MMCS" ) {  

$NameSpace := nsMeridianMail;
}else{ if ( $CurrentTrapDevice = "ITG" 

or $CurrentTrapDevice = "ITG_ISDN_TRK" 
or $CurrentTrapDevice = "ITG_IP_LINE" 
or $CurrentTrapDevice = "ITG_IP_PHONE" )
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{
$NameSpace := nsItg;

}else{ if ( $CurrentTrapDevice = "BRAVO" ) {
$NameSpace := nsBravo;

}else{ if ( $CurrentTrapDevice = "ISS7" ) {
$NameSpace := nsIss7;

}else{ if ( $CurrentTrapDevice = "MDECT" ) {
$NameSpace := nsMDECT;

}else{ if ( $CurrentTrapDevice = "SCCS" ) {
$NameSpace := nsSccs;

}else{ if ( $CurrentTrapDevice = "CALL_SERVER" ) {
$NameSpace := nsCallServer;

}else{ if ( $CurrentTrapDevice = "MEDIA_CARD" ) {
$NameSpace := nsMediaCard;

}else{ if ( $CurrentTrapDevice = "SIGNALLING_SERVER" ) {
$NameSpace := nsSigServer;

}else{
$NameSpace := nsGenericOrUnknown;

}}}}}}}}}}}}
}

rule ns1 {  
if (1) {
 ns();
}

}
}
                             
// ****************************************************************************
//                             Console and Log Files
// ****************************************************************************

// =======================================================================
// This is a sample definition for using a log file.  All events sent 
//   to this notification will be appended to the filename defined below.
//   Please note that Windows "long" file names are not supported. 
// =======================================================================

notification file sample_file {
   filename:="c:\sample_log.txt";
}

script ConsoleAndLog {

rule check_Meridian1_critical {
if ( $CurrentTrapDevice = "Meridian1" and $NormalizedSeverity = Critical ) {

// print event to console
send( con,

"--> Critical Meridian1 alarm received! ",
$ErrorCode," - " ,                  // M1 error code
$CurrentPCTime, " - ",              // Time that PC received the alarm
$CurrentTrapSource," - " ,          // Name of this M1
$DeviceTime," - " ,                 // Timestamp from M1
$Text," - ",                        // Text with error message
$OperatorData                       // More text with error message

);

// append event to log file
send(sample_file,"--> Critical M1 alarm received! ",

$ErrorCode," - " ,                  // M1 error code
$CurrentPCTime, " - ",              // Time that PC received the alarm
$CurrentTrapSource," - " ,          // Name of this M1
$DeviceTime," - " ,                 // Timestamp from M1
$Text," - ",                        // Text with error message
$OperatorData                       // More text with error message

);
}

}
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rule check_CallServer_critical {
if ( $CurrentTrapDevice = "CALL_SERVER" and $NormalizedSeverity = Critical ) {

// print event to console
send( con,

"--> Critical CallServer alarm received! ",
$ErrorCode," - " ,                  // CS error code
$CurrentPCTime, " - ",              // Time that PC received the alarm
$CurrentTrapSource," - " ,          // Name of this CS
$DeviceTime," - " ,                 // Timestamp from CS
$Text," - ",                        // Text with error message
$OperatorData                       // More text with error message

);

// append event to log file
send(sample_file,"--> Critical CallServer alarm received! ",

$ErrorCode," - " ,                  // CS error code
$CurrentPCTime, " - ",              // Time that PC received the alarm
$CurrentTrapSource," - " ,          // Name of this CS
$DeviceTime," - " ,                 // Timestamp from CS
$Text," - ",                        // Text with error message
$OperatorData                       // More text with error message

);
}

} 

rule check_SCCS_critical {
               if ( $CurrentTrapDevice = "SCCS" and $NormalizedSeverity = Critical ) {

// print event to console
send( con,

"--> Critical SCCS alarm received! ",
                                $AlarmCode," - " ,                   // SCCS alam code

$CurrentPCTime, " - ",              // Time that PC received the alarm
$CurrentTrapSource," - " ,          // Name of this SCCS
$DeviceTime," - " ,                 // Timestamp from SCCS
$OperatorData                       // text with error message

);

// append event to log file
send(sample_file,"--> Critical SCCS alarm received! ",

                                $AlarmCode," - " ,                   // SCCS alam code
$CurrentPCTime, " - ",              // Time that PC received the alarm
$CurrentTrapSource," - " ,          // Name of this SCCS
$DeviceTime," - " ,                 // Timestamp from SCCS
$OperatorData                       // text with error message

);
}

}

rule check_CallPilot_critical {
              if ( $CurrentTrapDevice = "CALL_PILOT" and $NormalizedSeverity = Critical ) {

// print event to console
send( con,

"--> Critical CallPilot alarm received! ",
                                $AlarmCode," - " ,                   // CP alam code

$CurrentPCTime, " - ",              // Time that PC received the alarm
$CurrentTrapSource," - " ,          // Name of this CP
$DeviceTime," - " ,                 // Timestamp from CP
$OperatorData                       // text with error message

);

// append event to log file
send(sample_file,"--> Critical CallPilot alarm received! ",

                                $AlarmCode," - " ,                   // CP alam code
$CurrentPCTime, " - ",              // Time that PC received the alarm
$CurrentTrapSource," - " ,          // Name of this CP
$DeviceTime," - " ,                 // Timestamp from CP
$OperatorData                       // text with error message

);
             }

           }
}
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// ****************************************************************************
//                              Numeric and Alpha Pagers
// ****************************************************************************

// =======================================================================
// This is a sample definition for using a numeric pager 
//   To use, the phone number should be changed to your pager number
//   and the notification (as well as the references to it) should be
//   uncommented.
// =======================================================================

/*
notification npager sample_numeric_pager {
   phone:="9,555-1212";
}
*/

// =======================================================================
// This is a sample definition for using an alpha pager 
//   To use, the phone number should be changed to your pager number,
//   your PIN number should be added, and the notification (as well 
//   as the references to it) should be uncommented.
// =======================================================================

/*
notification apager sample_alpha_pager {
   phone:="9,555-1212";
   pin:="101565";
}      
*/

script Pagers {
/*
   function forward_apager() {
      if ($CurrentTrapSource = "SCCS" or $CurrentTrapSource = "CALL_PILOT") {
      send( sample_alpha_pager, $CurrentTrapSource,":", $AlarmCode, "!" );
      }
   else {
   send( sample_alpha_pager, $CurrentTrapSource,":", $ErrorCode, "!" );
   }   
     }
     
     rule forward_apager_critical {
     if ($NormalizedSeverity = Critical ) {
     forward_apager();
     }
  }
*/
}

// 
**************************************************************************************************************
//                             Forwarding Received Traps as OTM Traps to an Optivity server
// 
**************************************************************************************************************

// =============================================
//          Define SNMP Notifications
// =============================================
notification snmp OtmOpenAlarm1 {
   address:="134.177.121.71";
   trap:="6.1";                  // Critical
}
notification snmp OtmOpenAlarm2 {
   address:="134.177.121.71";
   trap:="6.2";                  // Major
}
notification snmp OtmOpenAlarm3 {
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   address:="134.177.121.71";
   trap:="6.3";                  // Minor
}
notification snmp OtmOpenAlarm4 {
   address:="134.177.121.71";
   trap:="6.4";                  // Warning
}
notification snmp OtmOpenAlarm5 {
   address:="134.177.121.71";
   trap:="6.5";                  // Info
}
notification snmp OtmOpenAlarm6 {
   address:="134.177.121.71";
   trap:="6.6";                  // Clear
}

// =======================================================================================================
//                                        Forward Alarms Script
// =======================================================================================================

script ForwardAlarms {

// ---------------------------------------
//      Forward Critical Alarms
// ---------------------------------------
function forwardCriticals() {
if ( $CurrentTrapDevice = "OTM" ) {

send( OtmOpenAlarm1,
"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     $NameSpace,           // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", $System,              // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $OriginatingAgent,    // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1

 "1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $ExpertData,          // Problem Isolation Data2
 "1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $Text                 // Problem Isolation Data3
);

}else{ if ( $CurrentTrapDevice = "Meridian1" 
or $CurrentTrapDevice = "MMCS"
or $CurrentTrapDevice = "CALL_SERVER" )

 {     
send( OtmOpenAlarm1,

"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date And Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm ,               // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code

  "1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
  "1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", $ComponentAddress,    // System

"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component  
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1

  "1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $ExpertData,          // Problem Isolation Data2
  "1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $Text                 // Problem Isolation Data3
);

}else{ if ( $CurrentTrapDevice = "ITG" or $CurrentTrapDevice = "ITG_ISDN_TRK"
or $CurrentTrapDevice = "ITG_IP_LINE" or $CurrentTrapDevice = "ITG_IP_PHONE" 
or $CurrentTrapDevice = "ISS7" or $CurrentTrapDevice = "BRAVO" or $CurrentTrapDevice = "MMCS_AP"
or $CurrentTrapDevice = "MEDIA_CARD" or $CurrentTrapDevice = "SIGNALLING_SERVER" )
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{
send( OtmOpenAlarm1,

"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,                // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", "na",                 // Problem Isolation Data2
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", "na"                  // Problem Isolation Data3

);
}else{ if ( $CurrentTrapDevice = "CALL_PILOT" or $CurrentTrapDevice = "SCCS" ) {

send( OtmOpenAlarm1,
"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,                // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", "na",                 // Error Code
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", "na",                 // Problem Isolation Data2
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", "na"                  // Problem Isolation Data3

);
}else{ if ( $CurrentTrapDevice = "MMAIL" ) {

send( OtmOpenAlarm1,
"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     0,                    // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,                // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $Text,                // Problem Isolation Data2
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $ExpertData           // Problem Isolation Data3

);
}else{ if ($CurrentTrapDevice = "SL100" ) {
    send( OtmOpenAlarm1,

"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     0,                    // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,               // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $Text,                // Problem Isolation Data2
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $ExpertData           // Problem Isolation Data3

);
}}}}}}
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}

rule forward_criticals {
if ( $NormalizedSeverity = Critical ) {

forwardCriticals();
}

}

// ---------------------------------------
//         Forward Major Alarms
// ---------------------------------------
function forwardMajors() {

if ( $CurrentTrapDevice = "OTM" ) {
send( OtmOpenAlarm2,

"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     $NameSpace,           // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", $System,              // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $OriginatingAgent,    // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1

 "1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $ExpertData,          // Problem Isolation Data2
 "1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $Text                 // Problem Isolation Data3
);

}else{ if ( $CurrentTrapDevice = "Meridian1" 
or $CurrentTrapDevice = "MMCS"
or $CurrentTrapDevice = "CALL_SERVER" )

 {     
send( OtmOpenAlarm2,

"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date And Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,                // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code

  "1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
  "1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", $ComponentAddress,    // System

"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component  
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1

  "1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $ExpertData,          // Problem Isolation Data2
  "1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $Text                 // Problem Isolation Data3
);

}else{ if ( $CurrentTrapDevice = "ITG" or $CurrentTrapDevice = "ITG_ISDN_TRK"
or $CurrentTrapDevice = "ITG_IP_LINE" or $CurrentTrapDevice = "ITG_IP_PHONE" 
or $CurrentTrapDevice = "ISS7" or $CurrentTrapDevice = "BRAVO" or $CurrentTrapDevice = "MMCS_AP"
or $CurrentTrapDevice = "MEDIA_CARD" or $CurrentTrapDevice = "SIGNALLING_SERVER" )

{
send( OtmOpenAlarm2,

"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,                // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", "na",                 // Problem Isolation Data2
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", "na"                  // Problem Isolation Data3

);
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}else{ if ( $CurrentTrapDevice = "CALL_PILOT" or $CurrentTrapDevice = "SCCS" ) {
send( OtmOpenAlarm2,

"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,                // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", "na",                 // Error Code
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", "na",                 // Problem Isolation Data2
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", "na"                  // Problem Isolation Data3

);
}else{ if ( $CurrentTrapDevice = "MMAIL" ) {

send( OtmOpenAlarm2,
"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     0,                    // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,                // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $Text,                // Problem Isolation Data2
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $ExpertData           // Problem Isolation Data3

);
}else{ if ( $CurrentTrapDevice = "SL100" ) {
send( OtmOpenAlarm2,

"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     0,                    // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,                // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $Text,                // Problem Isolation Data2
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $ExpertData           // Problem Isolation Data3

);
}}}}}}

}

rule forward_majors {
if ( $NormalizedSeverity = Major ) {

forwardMajors();
}

}
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// ---------------------------------------
//         Forward Minor Alarms
// ---------------------------------------
function forwardMinors() {
if ( $CurrentTrapDevice = "OTM" ) {

send( OtmOpenAlarm3,
"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     $NameSpace,           // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", $System,              // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $OriginatingAgent,    // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1

 "1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $ExpertData,          // Problem Isolation Data2
 "1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $Text                 // Problem Isolation Data3
);

}else{ if ( $CurrentTrapDevice = "Meridian1" 
or $CurrentTrapDevice = "MMCS"
or $CurrentTrapDevice = "CALL_SERVER" )

 {     
send( OtmOpenAlarm3,

"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date And Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,                // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code

  "1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
  "1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", $ComponentAddress,    // System

"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component  
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1

  "1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $ExpertData,          // Problem Isolation Data2
  "1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $Text                 // Problem Isolation Data3
);

}else{ if ( $CurrentTrapDevice = "ITG" or $CurrentTrapDevice = "ITG_ISDN_TRK"
or $CurrentTrapDevice = "ITG_IP_LINE" or $CurrentTrapDevice = "ITG_IP_PHONE" 
or $CurrentTrapDevice = "ISS7" or $CurrentTrapDevice = "BRAVO" or $CurrentTrapDevice = "MMCS_AP"
or $CurrentTrapDevice = "MEDIA_CARD" or $CurrentTrapDevice = "SIGNALLING_SERVER" )

{
send( OtmOpenAlarm3,

"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,                // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", "na",                 // Problem Isolation Data2
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", "na"                  // Problem Isolation Data3

);
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}else{ if ( $CurrentTrapDevice = "CALL_PILOT" or $CurrentTrapDevice = "SCCS" ) {
send( OtmOpenAlarm3,

"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,                // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", "na",                 // Error Code

    "1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", "na",                 // Problem Isolation Data2
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", "na"                  // Problem Isolation Data3

);
}else{ if ( $CurrentTrapDevice = "MMAIL" ) {

send( OtmOpenAlarm3,
"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     0,                    // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,                // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $Text,                // Problem Isolation Data2
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $ExpertData           // Problem Isolation Data3

);
}else{ if ( $CurrentTrapDevice = "SL100" ) {
send( OtmOpenAlarm3,

"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     0,                    // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,                // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $Text,                // Problem Isolation Data2
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $ExpertData           // Problem Isolation Data3

);
}}}}}}

}

rule forward_minors {
if ( $NormalizedSeverity = Minor ) {

forwardMinors();
}

}
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// ---------------------------------------
//         Forward Warning Alarms
// ---------------------------------------
function forwardWarnings() {
if ( $CurrentTrapDevice = "OTM" ) {

send( OtmOpenAlarm4,
"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     $NameSpace,           // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", $System,              // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $OriginatingAgent,    // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1

 "1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $ExpertData,          // Problem Isolation Data2
 "1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $Text                 // Problem Isolation Data3
);

}else{ if ( $CurrentTrapDevice = "Meridian1" 
or $CurrentTrapDevice = "MMCS"
or $CurrentTrapDevice = "CALL_SERVER" )

 {     
send( OtmOpenAlarm4,

"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date And Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,                // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code

  "1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                //  Site
  "1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", $ComponentAddress,    // System

"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component  
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1

  "1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $ExpertData,          // Problem Isolation Data2
  "1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $Text                 // Problem Isolation Data3
);

}else{ if ( $CurrentTrapDevice = "ITG" or $CurrentTrapDevice = "ITG_ISDN_TRK"
or $CurrentTrapDevice = "ITG_IP_LINE" or $CurrentTrapDevice = "ITG_IP_PHONE" 
or $CurrentTrapDevice = "ISS7" or $CurrentTrapDevice = "BRAVO" or $CurrentTrapDevice = "MMCS_AP"
or $CurrentTrapDevice = "MEDIA_CARD" or $CurrentTrapDevice = "SIGNALLING_SERVER" )

{
send( OtmOpenAlarm4,

"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,                // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", "na",                 // Problem Isolation Data2
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", "na"                  // Problem Isolation Data3

);
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}else{ if ( $CurrentTrapDevice = "CALL_PILOT" or $CurrentTrapDevice = "SCCS" ) {
send( OtmOpenAlarm4,

"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,                // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", "na",                 // Error Code
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", "na",                 // Problem Isolation Data2
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", "na"                  // Problem Isolation Data3

);
}else{ if ( $CurrentTrapDevice = "MMAIL" ) {

send( OtmOpenAlarm4,
"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     0,                    // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,                // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $Text,                // Problem Isolation Data2
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $ExpertData           // Problem Isolation Data3

);
}else{ if ( $CurrentTrapDevice = "SL100" ) {
send( OtmOpenAlarm4,

"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     0,                    // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,                // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $Text,                // Problem Isolation Data2
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $ExpertData           // Problem Isolation Data3

);
}}}}}}

}

rule forward_warnings {
if ( $NormalizedSeverity = Warning ) {

forwardWarnings();
}

}

553-3001-330 Standard 3.00 November 2002



Control files included with alarm notification C-21
// ---------------------------------------
//         Forward Info Alarms
// ---------------------------------------
function forwardInfos() {

if ( $CurrentTrapDevice = "OTM" ) {
send( OtmOpenAlarm5,

"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     $NameSpace,           // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", $System,              // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $OriginatingAgent,    // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1

 "1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $ExpertData,          // Problem Isolation Data2
 "1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $Text                 // Problem Isolation Data3
);

}else{ if ( $CurrentTrapDevice = "Meridian1" 
or $CurrentTrapDevice = "MMCS"
or $CurrentTrapDevice = "CALL_SERVER" )

 {     
send( OtmOpenAlarm5,

"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date And Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,                // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code

  "1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                //  Site
  "1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", $ComponentAddress,    // System

"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component  
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1

  "1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $ExpertData,          // Problem Isolation Data2
  "1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $Text                 // Problem Isolation Data3
);

}else{ if ( $CurrentTrapDevice = "ITG" or $CurrentTrapDevice = "ITG_ISDN_TRK"
or $CurrentTrapDevice = "ITG_IP_LINE" or $CurrentTrapDevice = "ITG_IP_PHONE" 
or $CurrentTrapDevice = "ISS7" or $CurrentTrapDevice = "BRAVO" or $CurrentTrapDevice = "MMCS_AP"
or $CurrentTrapDevice = "MEDIA_CARD" or $CurrentTrapDevice = "SIGNALLING_SERVER" )

{
send( OtmOpenAlarm5,

"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,                // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", "na",                 // Problem Isolation Data2
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", "na"                  // Problem Isolation Data3

);
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}else{ if ( $CurrentTrapDevice = "CALL_PILOT" or $CurrentTrapDevice = "SCCS" ) {
send( OtmOpenAlarm5,

"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,                // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", "na",                 // Error Code
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   // Originating Agent
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", "na",                 // Problem Isolation Data2
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", "na"                  // Problem Isolation Data3

);
}else{ if ( $CurrentTrapDevice = "MMAIL" ) {

send( OtmOpenAlarm5,
"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     0,                    // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,                // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                //  Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $Text,                // Problem Isolation Data2
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $ExpertData           // Problem Isolation Data3

);
}else{ if ( $CurrentTrapDevice = "SL100" ) {
send( OtmOpenAlarm5,

"1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     0,                    // Alarm's Seq Number
"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          // Date and Time
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  // Severity
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,                // Name Space
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           // Error Code
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                // Site
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 // System
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     // System's Component
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   // Originating Agent
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,            // Trap Type
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,           // Associated User
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        // Problem Isolation Data1
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $Text,                // Problem Isolation Data2
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $ExpertData           // Problem Isolation Data3

);
}}}}}}

}

rule forward_infos {
if ( $NormalizedSeverity = Info ) {

forwardInfos();
}

}
} // end script ForwardAlarms}
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Sample Alarm Wizard script file

The content of the file sample_wizard_script.txt appears below:

/*

   This script file was generated using the OTM-M script wizard

   WARNING : DO NOT EDIT THIS FILE MANUALY, THE WIZARD WOULD
   NOT BE ABLE TO HANDLE IT ANY MORE.

*/
///start
/* Global Severity levels definition based on Meridian1 alarms */

counter Undetermined := 0;
counter Critical := 1;
counter Major := 2;
counter Minor := 3;
counter Warning := 4;
counter Info := 5;
counter Cleared := 6;
counter Unknown := 7;

/* $NormalizedSeverity is a global severity value that is normalized to OTM severity values.
   It represents the unified value across different devices. */
counter $NormalizedSeverity   := 0;

/* This script assign the global variable $NormalizedSeverity
with the value of $AlarmServerity when current trap device
is of OTM type. */

script AssignOTMSeverities when ($CurrentTrapDevice="OTM")
{

function assignit()
{

//send(con, "$AlarmServerity=", $AlarmSeverity);
if ($Severity=Critical)
{

$NormalizedSeverity:=Critical;
}
else
{

if ($Severity=Major)
{

$NormalizedSeverity:=Major;
}
else
{

if ($Severity=Minor)
{

$NormalizedSeverity:=Minor;
}
else
{

if ($Severity=Info)
{

$NormalizedSeverity:=Info;
}
else
{

if ($Severity=Unknown)
{

$NormalizedSeverity:=Unknown;
}
else
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{
if ($Severity=Warning)
{

$NormalizedSeverity:=Warning;
}
else
{

if ($Severity=Cleared)
{

$NormalizedSeverity:=Cleared;
}
else
{

$NormalizedSeverity:=Undetermined;
}

}
}

}
}

}
}

}

rule assign_severity {
if ($CurrentTrapDevice="OTM")
{

assignit();
}

}

} // end script AssignOTMSeverities

// All MDECT Alarms should be Critical 

script AssignMDECTSeverities when ($CurrentTrapDevice = "MDECT")
{
  function assignit()
  {
    $NormalizedSeverity := Critical;
  }

  rule assign_severity 
  {
    if ($CurrentTrapDevice = "MDECT")
    {
      assignit();
    }
  }
}

script convertSeverities when ($CurrentTrapDevice != "OTM" 
      and $CurrentTrapDevice != "Meridian1" 
      and $CurrentTrapDevice != "CALL_SERVER"  and $CurrentTrapDevice != "MMCS"
      and $CurrentTrapDevice != "MDECT")
{

function convertit()
{

//send(con, "$AlarmServerity=", $AlarmSeverity);
if ($Severity=1)
{

$NormalizedSeverity:=Critical;
}
else
{

if ($Severity=2)
{

$NormalizedSeverity:=Major;
}
else
{
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if ($Severity=3)
{

$NormalizedSeverity:=Minor;
}
else
{

if ($Severity=4)
{

if ($CurrentTrapDevice="CALL_PILOT")
{

$NormalizedSeverity:=Info;
}
else
{

$NormalizedSeverity:=Warning;
}

}
else
{

if ($Severity=5)
{

if ($CurrentTrapDevice="CALL_PILOT")
{

$NormalizedSeverity:=Unknown;
}
else
{

$NormalizedSeverity:=Cleared;
}

}
else
{

$NormalizedSeverity:=Undetermined;
}

}
}

}
}

}

  rule severity_conversion 
  {
    if ($CurrentTrapDevice != "OTM" and $CurrentTrapDevice != "Meridian1" 
          and $CurrentTrapDevice != "CALL_SERVER" 
          and $CurrentTrapDevice != "MMCS" and $CurrentTrapDevice != "MDECT" )
    {
      convertit();
    }
  }

} // end script convertSeverities

script convertM1Severities when ($CurrentTrapDevice="Meridian1" or $CurrentTrapDevice="CALL_SERVER" or 
$CurrentTrapDevice="MMCS")
{

function convertit()
{

//send(con, "$AlarmServerity=", $AlarmSeverity);
if ($Severity=1)
{

$NormalizedSeverity:=Minor;
}
else
{

if ($Severity=2)
{

$NormalizedSeverity:=Major;
}
else
{
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if ($Severity=3)
{

$NormalizedSeverity:=Critical;
}
else
{

if ($Severity=4)
{

$NormalizedSeverity:=Unknown;
}
else
{

if ($Severity=5)
{

$NormalizedSeverity:=Warning;
}
else
{

if ($Severity=6)
{

$NormalizedSeverity:=Cleared;
}
else
{

if ($Severity=7)
{

$NormalizedSeverity:=Undetermined;
}
else
{

$NormalizedSeverity:=Info;
}

}
}

}
}

}
}

}

rule severity_conversion {
if ($CurrentTrapDevice="Meridian1" or $CurrentTrapDevice="CALL_SERVER" or $CurrentTrapDevice="MMCS")
{

convertit();
}

}

} // end script convertM1Severities

// ***************************************************************************************
//                                  Assign $NameSpace
// ***************************************************************************************

counter nsOtm := 1; // Originated from an OTM
counter nsMeridian1 := 2;
counter nsCallPilot := 3;
counter nsMeridianMail := 4;
counter nsSl100 := 5;
counter nsPassport := 6;
counter nsItg := 7;
counter nsBravo := 8;
counter nsIss7 := 9;
counter nsMDECT := 10;
counter nsCallServer    := 11;
counter nsMediaCard    := 12;
counter nsSigServer := 13;
counter nsSccs := 14;
counter nsMeridianMailLink := 15;
counter nsGenericOrUnknown  := 16;
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script assignNameSpace {

function ns() {
if ($CurrentTrapDevice="OTM") {

// Original $CurrentTrapDevice is retained
}else{ if ( $CurrentTrapDevice = "Meridian1") {

$NameSpace := nsMeridian1;
}else{ if ( $CurrentTrapDevice = "CALL_PILOT" ) {

$NameSpace := nsCallPilot;
}else{ if ( $CurrentTrapDevice = "MMCS" ) {  

$NameSpace := nsMeridianMail;
}else{ if ( $CurrentTrapDevice = "ITG" 

or $CurrentTrapDevice = "ITG_ISDN_TRK" 
or $CurrentTrapDevice = "ITG_IP_LINE" 
or $CurrentTrapDevice = "ITG_IP_PHONE" )

{
$NameSpace := nsItg;

}else{ if ( $CurrentTrapDevice = "BRAVO" ) {
$NameSpace := nsBravo;

}else{ if ( $CurrentTrapDevice = "ISS7" ) {
$NameSpace := nsIss7;

}else{ if ( $CurrentTrapDevice = "MDECT" ) {
$NameSpace := nsMDECT;

}else{ if ( $CurrentTrapDevice = "SCCS" ) {
$NameSpace := nsSccs;

}else{ if ( $CurrentTrapDevice = "CALL_SERVER" ) {
$NameSpace := nsCallServer;

}else{ if ( $CurrentTrapDevice = "MEDIA_CARD" ) {
$NameSpace := nsMediaCard;

}else{ if ( $CurrentTrapDevice = "SIGNALLING_SERVER" ) {
$NameSpace := nsSigServer;

}else{
$NameSpace := nsGenericOrUnknown;

}}}}}}}}}}}}
}

rule ns1 {  
if (1) {
 ns();
}

}
}

///end

/* Email notification definition */
  notification email ne_samplemail {
    from:="test@company.com";
    address:="name@company.com";
    server:="0.0.0.0";
 }

/* Email notification definition */
  notification email ne_serge {
    from:="xyz@company.com";
    address:="serge@company.com";
    server:="15.12.2.3";
 }

/* Email notification definition */
  notification email ne_adrien {
    from:="xyz@company.com";
    address:="x@company.com";
    server:="47.82.32.184";
 }

/* Numeric pager notification definition */
  notification npager nn_samplenpag {
    phone:="9,555-555-5555";
 }
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/* Alphanumeric pager notification definition */
  notification apager na_sampleapag {
    phone:="9,555-555-5555";
    pin:="0000";
  }

/* Up-stream manager notification definition */
  notification snmp ns_samplesnmp {
    address:="114.21.25.149";
    trap:="6.10";
  }

/* Modem notification definition */
  notification modem nm_samplemodm {
    phone:="9,555-555-5555";
 }

/* File notification definition */
  notification file nf_samplefile {
    filename:="c:\otm_log.txt";
 }

/* Script definition */
script GeneratedScript {

  /* Notification Counters definition */
    counter count_ne_samplemail := 0;
    counter count_ne_serge := 0;
    counter count_ne_adrien := 0;
    counter count_nn_samplenpag := 0;
    counter count_na_sampleapag := 0;
    counter count_ns_samplesnmp := 0;
    counter count_ns_samplesnmp_BRAVO := 0;
    counter count_ns_samplesnmp_BS450 := 0;
    counter count_ns_samplesnmp_CALL_PILOT := 0;
    counter count_ns_samplesnmp_ISS7 := 0;
    counter count_ns_samplesnmp_ITG := 0;
    counter count_ns_samplesnmp_ITG_ISDN_TRK := 0;
    counter count_ns_samplesnmp_ITG_IP_LINE := 0;
    counter count_ns_samplesnmp_ITG_IP_PHONE := 0;
    counter count_ns_samplesnmp_MDECT := 0;
    counter count_ns_samplesnmp_Meridian1 := 0;
    counter count_ns_samplesnmp_CALL_SERVER := 0;
    counter count_ns_samplesnmp_MEDIA_CARD := 0;
    counter count_ns_samplesnmp_SIGNALLING_SERVER := 0;
    counter count_ns_samplesnmp_MMAIL := 0;
    counter count_ns_samplesnmp_MMCS := 0;
    counter count_ns_samplesnmp_MMCS_AP := 0;
    counter count_ns_samplesnmp_OTM := 0;
    counter count_ns_samplesnmp_SCCS := 0;
    counter count_ns_samplesnmp_SL100 := 0;
    counter count_nm_samplemodm := 0;
    counter count_nf_samplefile := 0;

  /* Severity levels definitions already defined as global counters */

  /* Function to get Severity level understandable */
    function string AlarmLevelToString (counter level) {
        string result;
        if (level=Minor) {
            result := "Minor";
        } else {
            if (level=Major) {
                result := "Major";
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            } else {
                if (level=Critical) {
                    result := "Critical";
                } else {
                    if (level=Unknown) {
                        result := "Unknown";
                    } else {
                        if (level=Warning) {
                            result := "Warning";
                        } else {
                            if (level=Cleared) {
                                result := "Cleared";
                            } else {
                              if (level=Info) {
                                 result := "Info";
                              } else {
                                  result := "Undetermined";
                              }
                            }
                        }
                    }
                }
            }
        }
        return(result);
    }

  /* Function(s) definition */
    function counter fn_ne_samplemail (counter n) {
      string severity_level;
      severity_level := AlarmLevelToString($NormalizedSeverity);
      n:=n+1;
      if (n=3) {
         if (

( ($CurrentTrapDevice="SCCS")
)

            or (($CurrentTrapDevice="CALL_PILOT")
            )
          ) {
         send(ne_samplemail,
                    $DeviceTime,": Device ",$CurrentTrapSource,
                    " generated a ",$CurrentTrapMajor,".",$CurrentTrapMinor,
                    " trap with severity level: ",severity_level,", AlarmCode: ", $AlarmCode, 

", OperatorData: ",$OperatorData, ".");
         n:=0;
         }
         else {
          send(ne_samplemail,
                    $DeviceTime,": Device ",$CurrentTrapSource,
                    " generated a ",$CurrentTrapMajor,".",$CurrentTrapMinor,
                    " trap with severity level: ",severity_level,", ErrorCode: ", $ErrorCode, 

", OperatorData: ",$OperatorData, ".");
         n:=0;
         }
       }
      return(n);
   }

    function counter fn_ne_serge (counter n) {
      string severity_level;
      severity_level := AlarmLevelToString($NormalizedSeverity);
      n:=n+1;
      if (n=2) {
         if (

( ($CurrentTrapDevice="SCCS")
)

            or (($CurrentTrapDevice="CALL_PILOT")
            )
          ) {
         send(ne_serge,
                    $DeviceTime,": Device ",$CurrentTrapSource,
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                    " generated a ",$CurrentTrapMajor,".",$CurrentTrapMinor,
                    " trap with severity level: ",severity_level,", AlarmCode: ", $AlarmCode, 

", OperatorData: ",$OperatorData, ".");
         n:=0;
         }
         else {
          send(ne_serge,
                    $DeviceTime,": Device ",$CurrentTrapSource,
                    " generated a ",$CurrentTrapMajor,".",$CurrentTrapMinor,
                    " trap with severity level: ",severity_level,", ErrorCode: ", $ErrorCode, 

", OperatorData: ",$OperatorData, ".");
         n:=0;
         }
       }
      return(n);
   }

    function counter fn_ne_adrien (counter n) {
      string severity_level;
      severity_level := AlarmLevelToString($NormalizedSeverity);
      n:=n+1;
      if (n=1) {
         if (

( ($CurrentTrapDevice="SCCS")
)

            or (($CurrentTrapDevice="CALL_PILOT")
            )
          ) {
         send(ne_adrien,
                    $DeviceTime,": Device ",$CurrentTrapSource,
                    " generated a ",$CurrentTrapMajor,".",$CurrentTrapMinor,
                    " trap with severity level: ",severity_level,", AlarmCode: ", $AlarmCode, 

", OperatorData: ",$OperatorData, ".");
         n:=0;
         }
         else {
          send(ne_adrien,
                    $DeviceTime,": Device ",$CurrentTrapSource,
                    " generated a ",$CurrentTrapMajor,".",$CurrentTrapMinor,
                    " trap with severity level: ",severity_level,", ErrorCode: ", $ErrorCode, 

", OperatorData: ",$OperatorData, ".");
         n:=0;
         }
       }
      return(n);
   }

    function counter fn_nn_samplenpag (counter n) {
      n:=n+1;
      if (n=1) {
         send(nn_samplenpag,"12345");
         n:=0;
       }
      return(n);
   }

    function counter fn_na_sampleapag (counter n) {
      string severity_level;
      severity_level := AlarmLevelToString($NormalizedSeverity);
      n:=n+1;
      if (n=1) {
         send(na_sampleapag,
                    $CurrentTrapSource," : ",severity_level," ",
                    $CurrentTrapMajor,".",$CurrentTrapMinor);
         n:=0;
       }
      return(n);
   }

    function counter fn_ns_samplesnmp_BRAVO (counter n) {
      n:=n+1;
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      if (n=3) {
         send(ns_samplesnmp,
 "1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         

"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,             
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                  
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,                    
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,                   
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", "na",                 
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", "na");                 

         n:=0;
       }
      return(n);
   }

    function counter fn_ns_samplesnmp_BS450 (counter n) {
      n:=n+1;
      if (n=3) {
         send(ns_samplesnmp,
           "1.3.6.1.2.1.2.2.1.1.1","Integer",$Port1,
                "1.3.6.1.2.1.2.2.1.1.2","Integer",$Port2,
                "1.3.6.1.2.1.2.2.1.1.3","Integer",$Port3,
                "1.3.6.1.2.1.2.2.1.1.4","Integer",$Port4,
                "1.3.6.1.2.1.2.2.1.1.5","Integer",$Port5,
                "1.3.6.1.2.1.2.2.1.1.6","Integer",$Port6,
                "1.3.6.1.2.1.2.2.1.1.7","Integer",$Port7,
                "1.3.6.1.2.1.2.2.1.1.8","Integer",$Port8,
                "1.3.6.1.2.1.2.2.1.1.9","Integer",$Port9,
                "1.3.6.1.2.1.2.2.1.1.10","Integer",$Port10,
                "1.3.6.1.2.1.2.2.1.1.11","Integer",$Port11,
                "1.3.6.1.2.1.2.2.1.1.12","Integer",$Port12,
                "1.3.6.1.2.1.2.2.1.1.13","Integer",$Port13,
                "1.3.6.1.2.1.2.2.1.1.14","Integer",$Port14,
                "1.3.6.1.2.1.2.2.1.1.15","Integer",$Port15,
                "1.3.6.1.2.1.2.2.1.1.16","Integer",$Port16,
                "1.3.6.1.2.1.2.2.1.1.17","Integer",$Port17,
                "1.3.6.1.2.1.2.2.1.1.18","Integer",$Port18,
                "1.3.6.1.2.1.2.2.1.1.19","Integer",$Port19,
                "1.3.6.1.2.1.2.2.1.1.20","Integer",$Port20,
                "1.3.6.1.2.1.2.2.1.1.21","Integer",$Port21,
                "1.3.6.1.2.1.2.2.1.1.22","Integer",$Port22,
                "1.3.6.1.2.1.2.2.1.1.23","Integer",$Port23,
                "1.3.6.1.2.1.2.2.1.1.24","Integer",$Port24);
         n:=0;
       }
      return(n);
   }

    function counter fn_ns_samplesnmp_CALL_PILOT (counter n) {
      n:=n+1;
      if (n=3) {
         send(ns_samplesnmp,
 "1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         

"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,             
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", "na",                 
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                  
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,                    
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,                   
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,       
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", "na",                 
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"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", "na");              
         n:=0;
       }
      return(n);
   }

    function counter fn_ns_samplesnmp_ISS7 (counter n) {
      n:=n+1;
      if (n=3) {
         send(ns_samplesnmp,
 "1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         

"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,             
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                  
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,                    
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,                   
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", "na",                 
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", "na");                 

         n:=0;
       }
      return(n);
   }

    function counter fn_ns_samplesnmp_ITG (counter n) {
      n:=n+1;
      if (n=3) {
         send(ns_samplesnmp,
 "1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         

"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,             
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                  
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,                    
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,                   
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", "na",                 
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", "na");                 

         n:=0;
       }
      return(n);
   }

    function counter fn_ns_samplesnmp_ITG_ISDN_TRK (counter n) {
      n:=n+1;
      if (n=3) {
         send(ns_samplesnmp,
 "1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         

"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,             
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                  
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,                    
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,                   
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", "na",                 
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", "na");                 

         n:=0;
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       }
      return(n);
   }

    function counter fn_ns_samplesnmp_ITG_IP_LINE (counter n) {
      n:=n+1;
      if (n=3) {
         send(ns_samplesnmp,
 "1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         

"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,             
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                  
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,                    
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,                   
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", "na",                 
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", "na");                 

         n:=0;
       }
      return(n);
   }

    function counter fn_ns_samplesnmp_ITG_IP_PHONE (counter n) {
      n:=n+1;
      if (n=3) {
         send(ns_samplesnmp,
 "1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         

"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,             
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                  
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,                    
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,                   
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", "na",                 
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", "na");                 

         n:=0;
       }
      return(n);
   }

    function counter fn_ns_samplesnmp_MDECT (counter n) {
      n:=n+1;
      if (n=3) {
         send(ns_samplesnmp,
                 "1.3.6.1.4.1.1417.1.1.1.5.0",     "OctetString", $DeviceTime,
                "1.3.6.1.4.1.1417.1.1.3.2.1.2.0", "OctetString", $OperatorData,
                "1.3.6.1.4.1.1417.1.1.3.3.1.4.0", "OctetString", $OperatorData,
                "1.3.6.1.4.1.1417.1.1.3.3.1.8.0", "OctetString", $OperatorData,
                "1.3.6.1.4.1.1417.1.1.3.9.0",     "OctetString", $OperatorData,
                "1.3.6.1.4.1.1417.1.1.3.5.1.0",   "OctetString", $OperatorData,
                "1.3.6.1.4.1.1417.1.1.3.7.0",     "OctetString", $OperatorData,
                "1.3.6.1.4.1.1417.1.1.2.1.6.0",   "OctetString", $OperatorData,
                "1.3.6.1.4.1.1417.1.1.3.1.0",     "OctetString", $ErrorCode);
         n:=0;
       }
      return(n);
   }
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    function counter fn_ns_samplesnmp_Meridian1 (counter n) {
      n:=n+1;
      if (n=3) {
         send(ns_samplesnmp,
 "1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         

"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,    
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                   
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", $System,              
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,    
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,                    
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,                   
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $ExpertData,          
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $Text);                

         n:=0;
       }
      return(n);
   }

    function counter fn_ns_samplesnmp_CALL_SERVER (counter n) {
      n:=n+1;
      if (n=3) {
         send(ns_samplesnmp,
 "1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         

"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,    
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                   
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", $System,              
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,    
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,                    
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,                   
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $ExpertData,          
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $Text);                

         n:=0;
       }
      return(n);
   }

    function counter fn_ns_samplesnmp_MEDIA_CARD (counter n) {
      n:=n+1;
      if (n=3) {
         send(ns_samplesnmp,
 "1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         

"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,             
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                  
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,                    
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,                   
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", "na",                 
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", "na");                 

         n:=0;
       }
      return(n);
   }
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    function counter fn_ns_samplesnmp_SIGNALLING_SERVER (counter n) {
      n:=n+1;
      if (n=3) {
         send(ns_samplesnmp,
 "1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         

"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,             
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                  
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,                    
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,                   
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", "na",                 
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", "na");                 

         n:=0;
       }
      return(n);
   }

    function counter fn_ns_samplesnmp_MMAIL (counter n) {
      n:=n+1;
      if (n=3) {
         send(ns_samplesnmp,
 "1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,                    

"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,             
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                  
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,                    
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,                   
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $Text,                
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $ExpertData);           

         n:=0;
       }
      return(n);
   }

    function counter fn_ns_samplesnmp_MMCS (counter n) {
      n:=n+1;
      if (n=3) {
         send(ns_samplesnmp,
 "1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         

"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,    
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                   
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", $System,              
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,    
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,                    
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,                   
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $ExpertData,          
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $Text);                

         n:=0;
       }
      return(n);
   }
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    function counter fn_ns_samplesnmp_MMCS_AP (counter n) {
      n:=n+1;
      if (n=3) {
         send(ns_samplesnmp,
 "1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         

"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,             
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                  
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,                    
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,                   
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", "na",                 
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", "na");                 

         n:=0;
       }
      return(n);
   }

    function counter fn_ns_samplesnmp_OTM (counter n) {
      n:=n+1;
      if (n=3) {
         send(ns_samplesnmp,
 "1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         

"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     $NameSpace,             
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,           
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                  
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", $System,              
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $OriginatingAgent,    
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,                    
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,                   
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,        
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $ExpertData,          
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $Text);      

         n:=0;
       }
      return(n);
   }

    function counter fn_ns_samplesnmp_SCCS (counter n) {
      n:=n+1;
      if (n=3) {
         send(ns_samplesnmp,
 "1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,         

"1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,          
"1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,  
"1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,             
"1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", "na",                 
"1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,                  
"1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", "na",                 
"1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,     
"1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $CurrentTrapSource,   
"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,                    
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,                   
"1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,       
"1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", "na",                 
"1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", "na");              

         n:=0;
       }
      return(n);
   }
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    function counter fn_ns_samplesnmp_SL100 (counter n) {
      n:=n+1;
      if (n=3) {
         send(ns_samplesnmp,
         "1.3.6.1.4.1.562.50.1.2.1.0",  "Integer",     $AlarmSeqNum,
                "1.3.6.1.4.1.562.50.1.2.2.0",  "OctetString", $DeviceTime,
                "1.3.6.1.4.1.562.50.1.2.3.0",  "Integer",     $NormalizedSeverity,
                "1.3.6.1.4.1.562.50.1.2.4.0",  "Integer",     nsOtm,
                "1.3.6.1.4.1.562.50.1.2.5.0",  "OctetString", $ErrorCode,
                "1.3.6.1.4.1.562.50.1.2.6.0",  "OctetString", $Site,
                "1.3.6.1.4.1.562.50.1.2.7.0",  "OctetString", $System,
                "1.3.6.1.4.1.562.50.1.2.8.0",  "OctetString", $SystemComponent,
                "1.3.6.1.4.1.562.50.1.2.9.0",  "OctetString", $OriginatingAgent,

"1.3.6.1.4.1.562.50.1.2.10.0", "Integer",     $TrapType,                    
"1.3.6.1.4.1.562.50.1.2.11.0", "OctetString", $AssocUser,                   

                "1.3.6.1.4.1.562.50.1.2.12.0", "OctetString", $OperatorData,
                "1.3.6.1.4.1.562.50.1.2.13.0", "OctetString", $ExpertData,
                "1.3.6.1.4.1.562.50.1.2.14.0", "OctetString", $Text);
         n:=0;
       }
      return(n);
   }

    function counter fn_nm_samplemodm (counter n) {
      string severity_level;
      severity_level := AlarmLevelToString($NormalizedSeverity);
      n:=n+1;
      if (n=1) {
         if (

( ($CurrentTrapDevice="SCCS")
)

            or (($CurrentTrapDevice="CALL_PILOT")
            )
          ) {
         send(nm_samplemodm,
                    $DeviceTime,": Device ",$CurrentTrapSource,
                    " generated a ",$CurrentTrapMajor,".",$CurrentTrapMinor,
                    " trap with severity level: ",severity_level,", AlarmCode: ", $AlarmCode, 

", OperatorData: ",$OperatorData, ".");
         n:=0;
         }
         else {
          send(nm_samplemodm,
                    $DeviceTime,": Device ",$CurrentTrapSource,
                    " generated a ",$CurrentTrapMajor,".",$CurrentTrapMinor,
                    " trap with severity level: ",severity_level,", ErrorCode: ", $ErrorCode, 

", OperatorData: ",$OperatorData, ".");
         n:=0;
         }
       }
      return(n);
   }

    function counter fn_nf_samplefile (counter n) {
      string severity_level;
      severity_level := AlarmLevelToString($NormalizedSeverity);
      n:=n+1;
      if (n=1) {
         if (

( ($CurrentTrapDevice="SCCS")
)

            or (($CurrentTrapDevice="CALL_PILOT")
            )
          ) {
         send(nf_samplefile,
                    $CurrentPCTime,": Device ",$CurrentTrapSource,
                    " generated a ",$CurrentTrapMajor,".",$CurrentTrapMinor,
                    " trap at ",$DeviceTime," with severity level: ",severity_level,", AlarmCode: ", $AlarmCode, 

", OperatorData: ",$OperatorData, ".");
         n:=0;
         }
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         else {
          send(nf_samplefile,
                    $CurrentPCTime,": Device ",$CurrentTrapSource,
                    " generated a ",$CurrentTrapMajor,".",$CurrentTrapMinor,
                    " trap at ",$DeviceTime," with severity level: ",severity_level,", ErrorCode: ", $ErrorCode, 

", OperatorData: ",$OperatorData, ".");
         n:=0;
         }
       }
      return(n);
   }

  /* Rule definition */
    rule r_samplerul2 {
      if (
               (    ($CurrentTrapDevice="ITG")
               )
         ) {
           count_nf_samplefile:=fn_nf_samplefile(count_nf_samplefile);
      }
      else {
      }
    }

  /* Rule definition */
    rule r_simplesamp {
      if (
               (    ($CurrentTrapDevice="Meridian1")
               )
           and (    ($NormalizedSeverity=Critical)
               )
         ) {
           count_ne_adrien:=fn_ne_adrien(count_ne_adrien);
           count_nf_samplefile:=fn_nf_samplefile(count_nf_samplefile);
      }
      else {
      }
    }

  /* Rule definition */
    rule r_samrulecs {
      if (
               (    ($CurrentTrapDevice="CALL_SERVER")
               )
         ) {
           count_ne_adrien:=fn_ne_adrien(count_ne_adrien);
      }
      else {
      }
    }

} /* End of GeneratedScript script */

/* End of file */
553-3001-330 Standard 3.00 November 2002



Index-1
Index
A
access

properties 320
restriction 144
rights 321, 361
telephones 363
Web Navigator 361
Windows Navigator 361

Access Server 63, 153

acronyms 36

Active Directory 292

add
a phantom station 453
a single station 452
multiple stations 454
new stations 451
site 92
station template 457
stations 455
system

Meridian 1 94
Succession CSE 1000 113

add-on modules 461

administration 474

Administrators user group 84

Alarm Banner 664, 665
launching 664

Alarm browser page 330, 658

Alarm Filter 661

alarm management 60
components 653
configuration 655
configuring 676

network level 656
site level 656
system and device level 655
Web-based 658
Windows-based 663

Alarm Notification 665, 679
events processing 691
process 680
sample scripts 725
scripting 692
set up 683
view event properties 691
window 682

Alarm Script Wizard 717
generate script file 724
notification types 720
rules 721

alarms 329

alternate currency 151

architecture 480

authentication 78, 144, 358

B
B- and D-channels 733, 794

commands 796

backup 281
Branch Office 285
run utility 286
Succession CSE 1000 system 285

Billing Reports 384, 426

Branch Office
backup 285
configure 129
Using Optivity Telephony Manager Release 2.0x



Index-2
restore 290

C
Call Detail Records (CDR) 260

Call Party Name Display (CPND) 465, 480, 484, 
486, 490
Link To Directory 506
synchronization 500

Call Tracking
maintenance 147

card inventory file 799

change a feature/DN key 400, A-20
Auto Dial key 401, A-21
feature key type 406, A-25
find DNs 411, A-30
MCR DN key 403, A-22
remove a key 409, A-28

change confirmation pages 419, A-38

Changing Sections 602

changing viewed Station Administration data 593

CLI
communication 158
configuration 155
data encryption 160
log file 156
operation 157
status window 154

Client Utility 310

cloning 283

Common Services 52

communicating with
Meridian 1 557
Succession CSE 1000 557

Communications 430

communications logs 573

Compact and Repair Utility 149

compact database 279

configurations, OTM 54

configure alarm management 676

configuring OTM 89
gatekeeper zones 132
sites 92
systems

Branch Office 129
Meridian 1 94
Succession CSE 1000 113

users 139

confirm change pages 419

connectivity 58

conventions, text 36

Conversion utility 430, 577

Core CPU 732, 771
commands 773

Core CPU page 741

Corporate Directory 179
Corporate Directory feature for M3900 Series 

and IP telephones 201
data fields 197
Data Fields tab 191
General tab 189
M1 Corporate Directory feature

generate report 207
requirements 201
upload configuration 202
upload report 207

Output tab 192
reports 185

customized 196
generate now 186
predefined 195
properties 188
schedule 187

Upload tab 194

CPND 429, 438, 481

Critical alarm notification 665

currency
alternate 151
local 149

current configuration 388

current record 571
553-3001-330 Standard 3.00 November 2002



Index-3
Custom Help 347

customer support 40

D
Data Buffering and Access (DBA) 239
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Event Log Viewer 208

Events Monitor 664, 666

excess DN report 177, 487

Exchange Server 292

export reports 590

export utility 274

F
Feature Group 472

feature key modules 461

Features button 470

Find DN button 411

find DNs

unused 411
used 413

Find PE Units page 765

Find Results page 333
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login 82
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pending changes 388
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Power User tool 629
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Report Generator 430
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restore 281
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run utility 291
Succession CSE 1000 system 287

retrieve all data 563
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set inventory file 801

set report parameters 611

site
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Station Administration 429
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administration 474
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Help menu 449
Options menu 449
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553-3001-330 Standard 3.00 November 2002



Index-9
System Alarms table 660

system data, update 437

System Monitor 232
access 232
set up alarms 238
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and disable applications 236
CPU information 234
disk usage 234
memory available 233
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System Navigator 323

system properties 436

System Speed Call 506

System Terminal 211
advantages over a TTY 217
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using 217
window 216
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Task Status table 341

TBS Web Reporting 384

technical documentation 42

technical publications 39

technical support 40
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EndUser 420
HelpDesk user 423
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Troubleshooting page 396
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template view 450
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Reserve TN feature 468
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example 813
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User Authentication 356
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User Groups 82

user groups 320
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User Login page 383
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Electronic Data Dump (EDD) 312
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V&H table 846

Validate button 389

validating station data 639
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virtual ports 377

Virtual System Terminal
Web 370
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data considerations 538
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Web Administration 347

Web Desktop Services 381

Web Maintenance Windows 328

Web Navigator 49, 317, 326
access 361

Web Services 317

Web Station 331

Web Virtual System Terminal 370
menus 372

Web-based maintenance 741

Web-based Station Administration 432

Windows Navigator 49, 65, 326
access 361
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